Please help with Win XP recovery!!!

Hi I would really appreciate any help with this.

My antivirus found that a .dll file was infected and so I told it to
delete the file. Didn't know this would be a mistake...

Now the pc won't load into windows. It just hangs half way through boot
up.

I do have data on the drive I want to try to recover if possible so if
anyone can give me some ideas about what I should try to get it up and
running again that would be amazing.

The file was ws2_32.dll
PC is running WinXP Pro SP3
I have one hard drive partitioned into C: (Win install) and D: (apps
and files)

THANKS!!!


-- 
captain_69uk
0
undisclosed
2/9/2010 1:33:56 PM
windowsxp.general 3897 articles. 1 followers. Follow

13 Replies
677 Views

Similar Articles

[PageSpeed] 28

 That file is a monitored SFC/Windows File Protection component. As
soon as you deleted it the file would have been quietly replaced from the
DllCache or Service Pack source folder.

 To get Windows running you might try a Safe Mode boot using the
"Last Known Working Configuration". Press F8 from a Cold boot to
get to the Safe Mode menu options.

 The Dynamic Link Library file is a key Windows component related to
networking.

<undisclosed> wrote in message 
news:3cad088f7b5926f7230ed71d31561459@nntp-gateway.com...
>
> Hi I would really appreciate any help with this.
>
> My antivirus found that a .dll file was infected and so I told it to
> delete the file. Didn't know this would be a mistake...
>
> Now the pc won't load into windows. It just hangs half way through boot
> up.
>
> I do have data on the drive I want to try to recover if possible so if
> anyone can give me some ideas about what I should try to get it up and
> running again that would be amazing.
>
> The file was ws2_32.dll
> PC is running WinXP Pro SP3
> I have one hard drive partitioned into C: (Win install) and D: (apps
> and files)
>
> THANKS!!!
>
>
> -- 
> captain_69uk 


0
R
2/9/2010 2:02:05 PM
Thank you R I tried pressing F8 severl times after a cold boot but
nothing different happens. It gets to the same point in start up and
freezes. There is no instruction to hit F8 for options at any point
before the system freezes.

Is there anything else I could try?

Thanks


-- 
captain_69uk
0
undisclosed
2/9/2010 2:28:26 PM
 To "Catch" the safe mode menu you have to repeatedly press F8 at
about a 1/2 second interval. There is only a short time that the system
detects and responds to the F8 key press.

 The reason for the Safe Mode boot is to determine if Windows is
bootable ( & not corrupted ). If Safe Mode does not work then the
next step is to perform an in-place or repair install of XP. :However,
if you have really critical data that must be saved you'd want to image
or backup the machine before attempting a repair install. For that
you would need bootable imaging capability from a program like
Acronis True Image or other imaging software.

 If Safe Mode does work you would want to use that opportunity to
backup your data to something like a Flash Thumb drive.

<undisclosed> wrote in message 
news:b319bb136d316e1237bab3cd062d3a1c@nntp-gateway.com...
>
> Thank you R I tried pressing F8 severl times after a cold boot but
> nothing different happens. It gets to the same point in start up and
> freezes. There is no instruction to hit F8 for options at any point
> before the system freezes.
>
> Is there anything else I could try?
>
> Thanks
>
>
> -- 
> captain_69uk 


0
R
2/9/2010 2:37:59 PM
<undisclosed> wrote in message 
news:b319bb136d316e1237bab3cd062d3a1c@nntp-gateway.com...
>
> Thank you R I tried pressing F8 severl times after a cold boot but
> nothing different happens. It gets to the same point in start up and
> freezes. There is no instruction to hit F8 for options at any point
> before the system freezes.
>
> Is there anything else I could try?
>
> Thanks
>
>
> -- 
> captain_69uk

If you have a USB keyboard, you may have to either go into your BIOS and 
make sure Legacy USB Devices is enabled, or plug in a PS/2 keyboard so the 
F8 keystroke is recognized.
-- 
SC Tom

0
SC
2/9/2010 2:49:45 PM
On Feb 9, 8:33=A0am, undisclosed wrote:
> Hi I would really appreciate any help with this.
>
> My antivirus found that a .dll file was infected and so I told it to
> delete the file. Didn't know this would be a mistake...
>
> Now the pc won't load into windows. It just hangs half way through boot
> up.
>
> I do have data on the drive I want to try to recover if possible so if
> anyone can give me some ideas about what I should try to get it up and
> running again that would be amazing.
>
> The file was ws2_32.dll
> PC is running WinXP Pro SP3
> I have one hard drive partitioned into C: (Win install) and D: (apps
> and files)
>
> THANKS!!!
>
> --
> captain_69uk

What antivirus did you run?

If ws2_32.dll is totally missing, your system will generate a Stop
Error when it tries to load XP (I just tried it by deleting mine using
Recovery Console).

Try to get that Safe Mode LKG working or at least try it.

If you are suspicious of ws2_32.dll, you can just replace it by
booting using a Recovery Console CD that you can make yourself, or use
your genuine bootable XP installation CD.

If you want to make a bootable RC CD and have no genuine XP media
laying around, here are some instructions:

http://www.bleepingcomputer.com/forums/topic276527.html
0
Jose
2/9/2010 2:54:55 PM
Hi!

> The file was ws2_32.dll

How about this? You'll need a second computer, hopefully running the 
same release of Windows at the same service pack level.

Put the hard drive from the computer that won't start up into the 
working computer. Set it up as a slave drive (PATA) or plug it into an 
open connector (for SATA drives). Then you should be able to copy the 
missing file back to where it belongs, and your system should hopefully 
start up again.

Update your anti-virus software immediately afterward if you are 
successful in getting the system to run again.

William
0
William
2/9/2010 3:46:26 PM
Hi 
thank you very much for all the replies.

to start with i have tried the easiest thing - i plugged in my old C:
hard drive which also still has winxp pro installed. i activated it and
it works.

i have also plugged in the problem drive (one that won't boot) in the
second SATA slot and windows explorer shows it as drive D:

BUT when try to open it i get a message saying 'drive D: is not
formatted. do you want to format it now?'  !!!

what? how can this be the case?
has this virus somehow prevented acces to the hdd or should i try some
other options before re-installing windows?

as before any help is extremely gratefully received.
THANKS! :smile:


-- 
captain_69uk
0
undisclosed
2/9/2010 5:43:22 PM
Hi captain_69uk,

    Reformat and reinstall the Windows XP Pro under the original setup by 
booting from the installation CD. Just make sure that the Data partition is 
seen. You will need to reinstall all the other programs.


-- 
thecreator





<undisclosed> wrote in message 
news:6f42decf3762872d4f881a6048ef4289@nntp-gateway.com...
>
> Hi
> thank you very much for all the replies.
>
> to start with i have tried the easiest thing - i plugged in my old C:
> hard drive which also still has winxp pro installed. i activated it and
> it works.
>
> i have also plugged in the problem drive (one that won't boot) in the
> second SATA slot and windows explorer shows it as drive D:
>
> BUT when try to open it i get a message saying 'drive D: is not
> formatted. do you want to format it now?'  !!!
>
> what? how can this be the case?
> has this virus somehow prevented acces to the hdd or should i try some
> other options before re-installing windows?
>
> as before any help is extremely gratefully received.
> THANKS! :smile:
>
>
> -- 
> captain_69uk 


0
thecreator
2/9/2010 10:37:44 PM
Hi all thanks for all the answers.

I have done a Malwarebytes scan of the drive and it produces this log
file:

Malwarebytes' Anti-Malware 1.44
Database version: 3720
Windows 5.1.2600 Service Pack 3
Internet Explorer 8.0.6001.18702

10/02/2010 17:03:46
mbam-log-2010-02-10 (17-03-46).txt

Scan type: Full Scan (D:\|)
Objects scanned: 106777
Time elapsed: 1 minute(s), 13 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)

Didn't take very long considering the size of all the media files that
are on there...

I have tried running setup from the WinXP cd and the program only sees
a partition which is approx 130gb (out of 320) and does NOT show
anything else!
It can't see the rest of the drive? I'm not sure what is best to do
now?

Any more help gratefully received!!!


-- 
captain_69uk
0
undisclosed
2/10/2010 5:09:09 PM
I also tried running the first stage of teh disk formatting program in
windows for teh problem drive and it only shows it has being 127gb when
its a 320gb drive...

I did transfer the whole of my old C: drive with windows install over
to this one (current problem drive) - could that be causing the problem?
The thing is i'm sure i formatted it before i did this so windows should
not be telling me the drive is not formatted, surely?

Anyone got any ideas? Reckon the HDD has somehow gone faulty?

thanks for any responses in advance. 		:smile:


-- 
captain_69uk
0
undisclosed
2/13/2010 6:45:04 PM
Hi  captain_69uk,

That's your problem. Never transfer. How large was the old Hard Drive?

    Also the Hard Drive isn't faulty, your Windows XP CD is. It needs to be 
at least Windows XP Pro Service Pack 2. You need to create a SlipStream XP 
CD or buy one.

http://www.theeldergeek.com/slipstreamed_xpsp2_cd.htm


-- 
thecreator



<undisclosed> wrote in message 
news:c7f8b4adbd27b43836309224f720e2b2@nntp-gateway.com...
>
> I also tried running the first stage of teh disk formatting program in
> windows for teh problem drive and it only shows it has being 127gb when
> its a 320gb drive...
>
> I did transfer the whole of my old C: drive with windows install over
> to this one (current problem drive) - could that be causing the problem?
> The thing is i'm sure i formatted it before i did this so windows should
> not be telling me the drive is not formatted, surely?
>
> Anyone got any ideas? Reckon the HDD has somehow gone faulty?
>
> thanks for any responses in advance. :smile:
>
>
> -- 
> captain_69uk 


0
thecreator
2/14/2010 12:25:27 AM
thanks

well that is a shame... so you're saying i won't be able to recover the
data on teh hard drive?


-- 
captain_69uk
0
undisclosed
2/15/2010 7:52:34 PM
Hi!

> to start with i have tried the easiest thing - i plugged
 > in my old C: hard drive which also still has winxp pro
 > installed. i activated it and it works.

> what? how can this be the case?

It could be a very simple problem. How up to date is the old copy of XP 
that you are using? Is it at least at the SP1 level?

If not, you need to fix that if you intend to use that to recover data 
from your other drive.

If you do have SP1 or later, and the drive with the damaged copy of 
Windows on it is larger than 137 gigabytes, you MUST enable 48-bit or 
"big" LBA support by changing a registry setting.

http://support.microsoft.com/kb/303013

Otherwise, you won't be able to access the contents of a large drive, 
and if you persist in trying, you will corrupt its contents, possibly 
beyond any means of recovery.

William
0
William
2/16/2010 4:54:56 PM
Reply:

Similar Artilces:

Org Charts?? Please help
Can anyone please help me with org charts? I need to create one that has from president down how do I create one that fits tons of people?? thank you so much.. I could use the help with either visio or powerpoint, if visio how do I transfer to powerpoint..if anyone can give me some examples that would be awesome, ive never done done :( -- 2 Hi, you can insert Orgcharts in PPT 2003 via Insert menu -> Picture-> Orgchart or in 2007 via insert tab->Illustrations group->Hierachy... all shapes/labels will be resized in accordance to the number of shapes to keep every...

HELP! Where do i find incoming and outgoing server information?
Hi im trying to add my first account to outlook and i get as far as it asking me for server information. Im using an MSN email account but dont kno whwere to find the incoming and out going server information? PLEASE HELP! lizzie 13 <lizzie 13@discussions.microsoft.com> wrote: > Hi im trying to add my first account to outlook and i get as far as > it asking me for server information. Im using an MSN email account > but dont kno whwere to find the incoming and out going server > information? Is this MSN account a POP account (for which MSN would have sent you server det...

ask help for DLL Export Library Definition File
Hello, guys! I got a problem when I build an MFC App which call a MFC Extension DLL that has implemented some API, but I don't know where is the problem, in DLL, in dll def file or in MFC App? the API like this: ___________________________________________________ head file extern "C" AFX_EXT_API long WINAPI PassThruConnect ( unsigned long ProtocolID, unsigned long Flags, unsigned long *pChannelID ); cpp file extern "C" long WINAPI PassThruConnect ( unsigned long ProtocolID, unsigned long Flags, unsigned long *pChannelID ) {....} and its def file like this: __...

help with filtering
Hi, How do I use the autofilter to show me three items. It only seems allow me two when I use the custom filter. thanks Susie Hi do you mean 3 conditions?. If yes this is not possible with the autofilter -- Regards Frank Kabel Frankfurt, Germany Susie wrote: > Hi, > > How do I use the autofilter to show me three items. It > only seems allow me two when I use the custom filter. > > thanks > > Susie Susie, Advanced filter may be the answer http://www.techonthenet.com/excel/filters/advanced2.htm Barbara Susie wrote: > Hi, > > How do I use the autofilter...

Looking for help with "440 Posting Not Allowed" server error
Please help anybody . . . I have been able to post messages via microsoft's news server but when I try posting to those same newsgroups via titannews.com (for which I am a paying subscriber) I always get a "440 Posting Not Allowed" server error. This wouldn't have anything to do with needing posting privelages for the newgroup would it? If it's a server error then it's not even getting to the intended newsgroup? Or may this type of error result from other causes? Maybe there's a seasoned news server user who can point me in the right direction for resolving t...

Please wait while Microsoft Outlook exits..
I have noticed a few postings on this subject and was wondering the = final solution. It seems that many individuals are expereiencing the = problem but no public explanation has been given. My experience is as = follows: We run on exchange 2000 I can recreate the issue on both NT4 and XP workstations. The problem does not happen to other individuals on the same stations. It happens consistently after exiting outlook. It seems to point to an issue with exchange rather than my local box, as = the problem follows me wherever I go. Thoughts? ...

If IsNull...And...= Then Help!
I am trying to us If IsNull to create requirements on a form that need to be fulfilled, but I don't think I have the "language" quite right. Can anyone help me correct this? Here is what I have so far: Private Sub SubmitFitConcern_Click() If Len([CountermeasureDate] & "") = 0 Then MsgBox "You must select a Countermeasure Date." Exit Sub End If If Len([CountermeasureDate] & "") < (RequestDate) Then MsgBox "The Countermeasure Date must be greater than the Request Date." Exit Sub En...

Setting up an IMAP account 'Properly'in outlook XP
Hi everyone, I'm sorry if this question's been asked before, but I really didn' find an answer, even after a two hour search. I have been using Outlook express up 'till now and I want to star using Outlook. Now then, I have an Imap mail account and in Outloo express I can set my account to automatically jump to my Imap inbo when I start the program and to automatically remove emails from th server when I delete them, now every mail that I delete is marked by line through the subject but they're not effectively removed, you kno what I mean. I can't seem to find those...

Need Excel help on how to create a invoice.
i'm in abit of a dilema my project requires me to create an invoice bu i have no idea to do it, does anyone have msn/icq that can go thoug the process of creating an invoice with me.. thx in advance, any help appreciated -- translatio ----------------------------------------------------------------------- translation's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=2612 View this thread: http://www.excelforum.com/showthread.php?threadid=39454 anyone? able to help me :) -- translation -------------------------------------------------------------------...

Help, how do I import a CSV file when Negatives are in Parenthesis
I am attempting to import a Comma Separated Value (CSV) file into an MS Access 2007 mdb table. The table consists of text and numeric (defined as Double) fields. Unfortunately, negative amounts are NOT enclosed by double quotes in the CSV file, instead the are enclosed with parenthesis signs. Example: "10,485.16","24",(42),"16.35",(835.33) Currently, when I import the CSV file, the negative amounts are NOT imported. I need assistance with how to import these negative amounts. Thanks in advance. "ND Pard" <NDPard@discussions....

Visual Basic for Applications Help not working right.
OS = WinXP Home and Pro with SP2. Under Office 2003 Professional Edition with SP1, if I open the VBA Editor and search for a function (say Msgbox) I get a whole list of things that can be displayed. All selections respond to a mouse click and provide a wealth of information except for those noted as (Visual Basic for Applications.) For those, nothing happens -- the system just sits there with the mouse cursor changed to a hand. I have gone to Control Panel/Add Remove Programs and followed the instructions that appear in several places on the web for adding the VBA help files. The ...

trying to open .CHM help file
Can anyone help me please? i am trying to open a .CHM help file via a command button on my form. I have tried using SHELL but that doesnt work, presumably because it is not a .EXE. any help greatly appreciated Already answered in another newsgroup to which you posted the same question. If you feel you need to post to more than one group (HINT: it's seldom necessary), please have the courtesy to cross-post (send the one message to all groups at once), rather than multi-post (send individual messages to each group). In this way, all responses to your post will be available together, ...

Access 2000 on Windows XP
Is there a way to run Access 2000 through Windows XP without having to convert the entire database? I work in an office that shares an Access 2000 database. All of the users are currently running Windows 2000 but a few of the users would like to switch to Windows XP. Thank you in advance for ideas/help! I have a database developed under Office 2000/Windows 2000 which runs successfully on a machine with OfficeXP/WindowsXP. However if I then alter any VB code on the latter, the program fails. Any ideas? >-----Original Message----- >Hi Christine, > >Whether you are using Wi...

need help writing function
Column A has Days of the week listed for the entire month Column B has data listed for days of the week Want formula to count data in column B if it equals a certain day of the week like if sunday then count all data listed for sundays in column B "a" "B" Sunday 21 Monday 15 Tuesday 28 Sunday 14 Monday 10 Tuesday 12 sunday=35 Monday=25 Tuesday=40 Hi, Let's assume th...

Sum of Numbers appear as zero- Please help
Please help! I have a spreadsheet that adds up sales projects for each of our territories into a total company. When I went back to verify the calculations, I realized that zeros were appearing in some of the calculations. It appears that the column format was set to text. I've tried to change it to general or number but nothing works unless I retype everything. Is there something else I can do? Example: Group 1: =sum(A1:A2)=0 [Should be 700] Product 1: 200 Product 2: 500 Any ideas would be greatly appreciated. Tina Hi Tina - Put the number 1 in a blank cell (that is form...

Please help and visit my site
http://www.requestforhelp.org Thankyou Sian ...

Formula Help 01-04-10
I am trying to do the following and can't figure out the formula. I have cells across a column that have one of the following numbers: 0,1,2,3,4. I want to get the number of cells that have a 1 or a 2. For example, lets say A3 is a 1, C3 is a 3, E3 is a 4 and G3 is 2. I want the forumala to give me 2 (1 in A3 and 2 in G3). I am sure it is fairly simple, but I can't figure it out. Thanks Try: =COUNTIF(A3:Z3,1)+COUNTIF(A3:Z3,2) -- Gary''s Student - gsnu200909 "Casey" wrote: > I am trying to do the following and can't figure out t...

Need some help with excel spreadsheet...
I'm running excel 2003 on a winxp pro machine. I have a spreadsheet with the following information. Cust Number, Cust Name, Inv Num, Inv Date, Description, Amount There are many invocices per customer number. The date appears as 1YYMMDD. There are a couple of things I would like to Change. I want to change the date to MMDDYY format. I want to add the amount on the invoices and have the following per customer numnber: Cust Number, Cust Name and a Total amount from the invoice amount. Instead of having one 5 lines for 5 invoices for 1 customer number I want to have 1 customer number an a ...

Corrupt exchange database recovery
Hey all not in a state of emergeny but doing research incase one develops. Can any one give me some good links on how to recover a currupt exchange database? Im perparing a disaster recovery plan so any help is appreciated. Thanks, CaptianWeasel "captianweasel" <captianweasel@discussions.microsoft.com> wrote: >Hey all not in a state of emergeny but doing research incase one develops. >Can any one give me some good links on how to recover a currupt exchange >database? Im perparing a disaster recovery plan so any help is appreciated. Try http://www.micr...

Encrypted Key For Signing Help
I've opened an old VB project that I've not touched in nearly a year and when I go to build, it says this: IMPORT KEY FILE - THIS PROJECT INCLUDES A PASSWORD-ENCRYPTED KEY USED FOR SIGNING. How do I remove or recover the Password? Thanks! Brian "Brian" <nospam@nospam.com> wrote in message news:314B657C-F24E-4BED-8128-F77A7079ED9D@microsoft.com... > I've opened an old VB project that I've not touched in nearly a year and > when I go to build, it says this: > > IMPORT KEY FILE - THIS PROJECT INCLUDES A PASSWORD-ENCRYPTED KEY US...

Realtime Exchange Mirroring for Disaster Recovery
I am looking to configure an offsite DR network, and would like to mirror an existing Exchange server at the remote site. We are currently running Exchange 2000, but would upgrade to 2003 if need be. Is there any way to accomplish realtime mirroring of Exchange between two servers over an IP link? Jeremy Jeremy, Realtime mirroring is not possible with any version of Exchange. The closest alternative would be to run Exchange in a clustered environment. This posting is provided AS IS with no warranties, and confers no rights. LynneW@Online.MICROSOFT.COM (Lynne Williams [MSFT]) wr...

Please help...writing to XML file
I have looked in all my books and online and can't find a way to make this rather simple task work. Could someone please review the code and see what errors I've made? Thanks!!!!!! I have an aspx for with a textbox and a button. The goal is to simply have the user type a message, hit the button and it should append to the XML file. I can open the aspx in the browser with no problem, but the XML file does not get updated. What's wrong with this code? Thanks! <script runat="server"> Private Sub Page_Load(ByVal sender As System.Object, _ ByVal e As System.Event...

Help required to create a Chart at Runtime and export it to a web page
Hey Friends I am trying to export some values to a excel sheet and then create a Graph for the values. I tried to create a excel template and then export values to it but if i use a chart in the excel template then i have to define the range but the range is known after the data has been exported. Can someone please help me for creating graph at runtime in excel. Moreover when i save the excel sheet as webpage the page is saved with blank entries as well. So number of pages to print out becomes 3 instead of actual number of pages. but i want only actual number of pages to print out and ign...

strange characters appearing on emails need help to stop this happening please
I have set up my outlook express on my lap top. (vista home premium) had a problem with the coding changing seemed to fix that but am now getting this at the bottom of sent emails, any ideas what I should do please? Oh, and I am an OAP and need very simple instructions please, I can be a bit of a thicko. &#20540;&#15422;&#21064;&#15422;&#20527;&#15422;&#15952;&#3338;&#17212;&#20037;&#17748;&#15954;&#18748;&#18253;&#21280;&#17234;&#8765;&#18755;&#14916;&#14459;&#16948;&#13105;&#17477;&#...

OWA Question
Can anyone help me with this problem? We use Public Folders on our exchange server in order to have a central place to post info like programs, pricelists, telephone lists, etc. We have some external users who wish to use Outlook Web Access (OWA) in order to be able to view their mail. Because they're not in the USA, dialup is not an option for them. Because they're satellite connected, they cannot use VPN. The problem with it that we've seen is Public Folders (and forms), which are really 2 problems. First: The folders display fine. The contents of them, the dates, etc. sh...