Installing SQL on the SBS server

Hi all,

I know that with SBS 2008 Premium you would normally use the second Win Srv 
2008 SE licence to install SQL 2008 SE on.  I remember hearing years ago 
that it is not  recommended  that SQL and Exchange be installed on the same 
Windows instance (i.e. one Windows Server OS running both Exch and SQL). 
Have things moved on?  Is this not so much of an issue with Exch 2007 and 
SQL 2008, and therefore it is not such a bad move to stick both SQL and Exch 
on the SBS server?

The reason I ask is that I have bought the Backup Exec 2010 SBS bundle. 
Really good value.  However, you have to install all the agents on the one 
machine.  They still support this separate SQL box setup.  To achieve this 
you would install the BE Remote Agent (included in the bundle) on the 
Premium server running SQL.  This allows the SBS server running the BE SQL 
agent to communicate with the MS SQL instance via the BE Remote Agent on the 
Premium server.

Aha, but here is my snag.  I want to set my SBS 2008 domain up in a virtual 
environment running Hyper-V.  The licencing for the Hyper-V Agent requires 
that an SQL agent is needed for each application on each VM.  And seeing as 
it forces the SQL Agent to be installed on the same instance of Windows 
server as the Exchange Agent... (Remote Agents don't help here, BTW)

So, it would seem to me that the only way to make use of this bundle would 
be to install SQL on the SBS box.

TIA,

Jarryd 

0
Jarryd
5/5/2010 9:44:20 AM
windows.server.sbs 1975 articles. 0 followers. Follow

3 Replies
382 Views

Similar Articles

[PageSpeed] 15

On 05/05/10 10:44, Jarryd wrote:
> Hi all,
>
> I know that with SBS 2008 Premium you would normally use the second Win
> Srv 2008 SE licence to install SQL 2008 SE on. I remember hearing years
> ago that it is not recommended that SQL and Exchange be installed on the
> same Windows instance (i.e. one Windows Server OS running both Exch and
> SQL). Have things moved on? Is this not so much of an issue with Exch
> 2007 and SQL 2008, and therefore it is not such a bad move to stick both
> SQL and Exch on the SBS server?
>
> The reason I ask is that I have bought the Backup Exec 2010 SBS bundle.
> Really good value. However, you have to install all the agents on the
> one machine. They still support this separate SQL box setup. To achieve
> this you would install the BE Remote Agent (included in the bundle) on
> the Premium server running SQL. This allows the SBS server running the
> BE SQL agent to communicate with the MS SQL instance via the BE Remote
> Agent on the Premium server.
>
> Aha, but here is my snag. I want to set my SBS 2008 domain up in a
> virtual environment running Hyper-V. The licencing for the Hyper-V Agent
> requires that an SQL agent is needed for each application on each VM.
> And seeing as it forces the SQL Agent to be installed on the same
> instance of Windows server as the Exchange Agent... (Remote Agents don't
> help here, BTW)
>
> So, it would seem to me that the only way to make use of this bundle
> would be to install SQL on the SBS box.
>

I think it was only ever a matter of resources, both Exchange and SQL 
Server being of the heavyweight persuasion. I've put SQL Express 2005 on 
SBS2003 without any issues other than performance.

Be prepared to buy more RAM...

-- 
Joe
0
Joe
5/5/2010 2:54:47 PM
Hi Joe,

Thanks for your reply.  I am running into other problems here now though but 
at least this SQL + Exch option isn't going to be an issue.

I have already posted a thread about this, but do you know if there is any 
way to get the Exch 2007 mgmt tools (64 bit) off the SBS media?  I need to 
install the tools (only) on my backup server or half the features don't 
work.  Any ideas?

TIA,

Jarryd

"Joe" <joe@jretrading.com> wrote in message 
news:OVRQpLG7KHA.5708@TK2MSFTNGP02.phx.gbl...
> On 05/05/10 10:44, Jarryd wrote:
>> Hi all,
>>
>> I know that with SBS 2008 Premium you would normally use the second Win
>> Srv 2008 SE licence to install SQL 2008 SE on. I remember hearing years
>> ago that it is not recommended that SQL and Exchange be installed on the
>> same Windows instance (i.e. one Windows Server OS running both Exch and
>> SQL). Have things moved on? Is this not so much of an issue with Exch
>> 2007 and SQL 2008, and therefore it is not such a bad move to stick both
>> SQL and Exch on the SBS server?
>>
>> The reason I ask is that I have bought the Backup Exec 2010 SBS bundle.
>> Really good value. However, you have to install all the agents on the
>> one machine. They still support this separate SQL box setup. To achieve
>> this you would install the BE Remote Agent (included in the bundle) on
>> the Premium server running SQL. This allows the SBS server running the
>> BE SQL agent to communicate with the MS SQL instance via the BE Remote
>> Agent on the Premium server.
>>
>> Aha, but here is my snag. I want to set my SBS 2008 domain up in a
>> virtual environment running Hyper-V. The licencing for the Hyper-V Agent
>> requires that an SQL agent is needed for each application on each VM.
>> And seeing as it forces the SQL Agent to be installed on the same
>> instance of Windows server as the Exchange Agent... (Remote Agents don't
>> help here, BTW)
>>
>> So, it would seem to me that the only way to make use of this bundle
>> would be to install SQL on the SBS box.
>>
>
> I think it was only ever a matter of resources, both Exchange and SQL 
> Server being of the heavyweight persuasion. I've put SQL Express 2005 on 
> SBS2003 without any issues other than performance.
>
> Be prepared to buy more RAM...
>
> -- 
> Joe 

0
Jarryd
5/5/2010 4:55:42 PM
On 05/05/10 17:55, Jarryd wrote:
> Hi Joe,
>
> Thanks for your reply. I am running into other problems here now though
> but at least this SQL + Exch option isn't going to be an issue.
>
> I have already posted a thread about this, but do you know if there is
> any way to get the Exch 2007 mgmt tools (64 bit) off the SBS media? I
> need to install the tools (only) on my backup server or half the
> features don't work. Any ideas?
>

Sorry, I did reply to the other thread, but I installed the 32-bit tools 
on a Vista workstation. As I said then, I have been led to believe that 
part of a 32-bit Outlook installation was necessary for mailbox import, 
which was the only function I needed then:

http://technet.microsoft.com/en-us/library/bb691363%28EXCHG.80%29.aspx

# To import data from a .pst file, you must use the 32-bit version of 
the Exchange management tools. You cannot run the 32-bit version of the 
Exchange management tools on a server that is running Exchange 2007 
because it is a 64-bit computer. You must run the Import-Mailbox cmdlet 
from a 32-bit computer that has the following installed:

     * The 32-bit version of the Exchange management tools
     * Microsoft Office Outlook 2007 or Outlook 2003 Service Pack 2 (SP2)

-- 
Joe


0
Joe
5/5/2010 5:07:36 PM
Reply:

Similar Artilces:

CRM repair problem: Action Microsoft.Crm.Setup.Server.RepairBulkOp
Hi, got the following problem when trying to repair Mircrosoft CRM: 11:17:10| Info| Executing Install action: Microsoft.Crm.Setup.Server.TurnOnSetupModeAction 11:17:10| Info| Executing Install action: Microsoft.Crm.Setup.Server.RepairBulkOperationProcessAction 11:17:10|Verbose| Retrieving CUserAuth data ... 11:17:10| Info| CUserAuth.UserId: {2315eb52-9a9e-da11-ad6d-00123fc10a29} 11:17:10| Info| CUserAuth.MerchantId: {b036f143-9a9e-da11-ad6d-00123fc10a29} 11:17:21| Error| Install exception.System.Exception: Action Microsoft.Crm.Setup.Server.RepairBulkOperationProcessAction failed....

error 80070103 after trying to install my saitek cyborg x joystick
i have tried installing my saitek cyborg x joystick several different ways - install cd, "plug and play" while getting the drivers from microsoft and the saitek websites and have had no luck. still getting the "error 80070103" message. help? Tip: Do not install any driver updates offered by Windows Update. Get them from the manufacturer's website instead. http://www.saitek.com/uk/down/drivers.php "gabriel_blues" wrote: > i have tried installing my saitek cyborg x joystick several different ways - > install cd, "plug and play" ...

CDO eMail messages not working from FoxPro since installing KB8929
We installed the Exchange 2000 Update (KB892986) and since then our code that creates CDO eMails errors out with the following message: "OLE IDispatch exception code 0 from CDO.Message.1: The transport lost its connection to the server." We are planning to reverse thes updates over the weekend. Does anyone know a better way around this? ...

2008 SBS questions... 07-04-10
I am trying to get a 2008 sbs running as efficiently as I can & was wondering about a couple of things. 1) I know it wants to be the DHCP server on a network, but what about for wireless clients? I have a wireless sonicwall TZ-170 for wireless laptops to connect to. They really don't need network access, just internet, so can I leave this running, as long as the addresses it hands out aren't in my same network? 2) Although the bought an SBS, the customer is not & probably won't be running exchange for a while. Can I remove exchange all together? I really see no rea...

RPC over HTTP
Hi I am trying to setup RPC over HTTP service on a Windows 2003 Enterpise server SP1 running Exchange 2003 Service Pack 1 I have installed the RPC over HTTP service I have installed the Certificate Authority and issued a certificate to the web site containing the Exchange features. Everytime you visit the https:// site and you install the certificate, you prompted the next time you visit the site again. Its seems that the certificate will not install correctly, this causes Outlook not to connect. any help or tips will be much apperciated. My Link with the certificate https://www....

IFD install needed help
Hi, After facing many errors and difficulties during the CRM 4.0 installation I successfully installed the product. Now I am trying to install CRM as IFD. I want to install IFD without any problems So I have some questions. What is the SDK root domain and web application root domain mean? Is the below config file format is alone enough for IFD installation. Is there anything else i need to look up.?? I went through the MSDN documentation. Can anyone guide tell me how and what configurations i should use to install IFD successfully. <CRMSetup> <Server> <ifdsettin...

Exchange 2003 installed SP2 now IMF is not working.
I had Exchange 2003 SP1 and installed the IMF. I heard that SP2 has the IMF bulit-in. During the SP2 install it said I had to uninstalled the old IMF, which I did. I then installed Exchange 2003 SP2, I see the tabs in the "System Manager", Global Settings, "Message Delivery" But no IMF portion under the SMTP. I tried to reinstalled the IMF but still it doesn't show up under the SMTP protocals. What am I doing wrong? Within system manager, go to protocols|smtp and select Properties, the Advanced button and then the edit button. Then select the checkbox for en...

Microsoft CRM 3.0 (KB922815) Installation Error
When i try to install Update Rollup 1 for MSCRM 3.0 i get following error. Setup could not find Microsoft CRM 3.0 Server or you have a mismatch between update language and Microsoft CRM language. The installation of this update has stopped. Is this rollup language dependent? I have a swedish installation of MSCRM. Thanks! // Mats ------=_NextPart_0001_11F19277 Content-Type: text/plain Content-Transfer-Encoding: 7bit Yes this rollup is language dependent. You need to install SVE(swedish - sweden) UR1 package. Thanks, Indira Dhingra This posting is provided "AS IS" with no...

HELP with Office 2004 not loading after installing Adobe Acrobat 7.
Hi, Word, Excel and Powerpoint won�t launch anymore after installing Adobe Acrobat 7. I checked on office/startup and the three folders are empty. All I get is window telling me that app couldn�t launch.. Error reporting. Is there a way to fix this? I don�t want to reinstall OSX. I have uninstalled and reinstalled Office several times to no avail. Entourage launches fine. Thanks, AJ There are troubleshooting techniques linked from this page, work through them: http://www.mcgimpsey.com/macoffice/ see General Troubleshooting and Troubleshooting for Office 2004 If they get to the splash sc...

Install rpc over htttp
i installed small business server 2003. Exchange servers works properly via owa. I used the process described in document entitlled "Exchange Server 2003 RPC over HTTP Deployment Scenarios" in section single server (page #17) "To configure an Exchange Server 2003 SP1 single-server installation to use RPC over HTTP" The pb is that when we take server properties the the RPC-HTTP tab does not appear (rpc over htttp is installed within Windows settings) Thanks for your help Maybe this can help you http://support.microsoft.com/default.aspx?scid=kb;en-us;833401 -- Jammy...

SBS 2008 Fax Sent Items Not showing all faxes sent
Hello, I need to allow sent faxes to be seen by all users. I have Windows XP and Windows 7 64bit client machines. Currently they can only see their sent faxes. In SBS 2003 they were able to see all sent faxes. Any suggestions? Could you create an Outlook rule based on the fax sent acknowledgement that copied the fax to a public folder? "RodSoh" <RodSoh@discussions.microsoft.com> wrote in message news:A4541A0E-18C2-4A83-A13D-8E7D045C29E8@microsoft.com... > Hello, > > I need to allow sent faxes to be seen by all users. I have Windows XP...

SQL Server
I'm currently using MS-Access to write reports using a SQL Server db as the data source in a client/server arrangement. The database is sufficiently large (2gb) that data retrieval speed is an issue. The current setup is linked tables to the SQL Server db via ODBC, and then the usual queries. 1. Can views and/or stored procedures on the SQL Server side along with paramaterized queries provide a significant performance boost? 2. I've read that views and stored procedures can be created w/i Access. Is this the same as creating them in SQL Server? 3. Are there other things I sho...

Removing an exchange server member
I have a 2000 exch backend and a 2003 exch frontend setup. The front end hard disk just recently died. And so was not correctly un installed from AD. There are still elements of exchange hanging around. For instance, in the system manager. But the system manager wont let me delete the front end server under the first administrative group. Do i have to use adsiedit to remove this or is there a much simplier way. Cheers Paul To my best knowledge, it adsiedit. "Yakeni" <Yakeni@discussions.microsoft.com> wrote in message news:B352B981-F5B7-4527-8A48-04E3976C99D9@microsoft.c...

In what order do installed AddIns open?
I had no joy with my other post 'Trying to read CustomDocumentProperties of an open 2007 AddIn Options ' so I'm trying another tack... To work around a problem I'm having, since upgrading a complex tool to Excel 2007, I need to ensure that my Version Checker AddIn always opens before my Engine AddIn. Is there any useable logic that dictates the order in which Excel opens its installed AddIns (e.g. alphabetical, order of installation, position in list) or is it one of those unknown internal processes that will forever remain a mystery? Br, Nick. First Com...

User can not acces from home the EXchange server
Currently we allow our users to access there email VIA the web using http:yayaya.com/exchange. however one of my user's is unable to log in this way. On-site using outlook he has no problem but when he try's entering his login name and password via the web he gets a message saying username and password are incorrect. For some reason it will not validate his information. Can someone please point me in the right direction. Thanks ...

problem with multiple SMTP domains in Exchange Server 2003
Hi there I have added a second SMTP domain to the Email Addresses (Policy) as follows: Recipients > Recipient Policies > Default Policy > Email Addresses (Policy) > New ... > SMTP Address > @xyz.com > (checked) This Exchange Organization is responsible for all mail delivery > to this address > Apply. When I do so, I no longer receive external emails on the first SMTP domain (@abc.com). Is this related to relay settings, or perhaps something else? Best regards Loane ...

Help: message "Requesting data from Exchange Server"
Has anyone figure out why we receive the pop-up message "Requesting data from Exchange Server" when we try to open an email in outlook? We are using Exchange 2000. Is there a parameter we can change to fix this issue? "Kenny" <anonymous@discussions.microsoft.com> wrote: >Has anyone figure out why we receive the pop-up >message "Requesting data from Exchange Server" when we >try to open an email in outlook? We are using Exchange >2000. > >Is there a parameter we can change to fix this issue? Depends to a greater or lesser extent ...

Excel 2007. How do I get un-installed add-ins off the toolbar?
I have 2 Large Icons on the ribbon/toolbar of Excel 2007. These are Omnipage and s-force. Both of these have been uninstalled and I have de-activated both add-ins. How do I get these off the toolbar forever? thanks ...

HQ Client
We are trying to process 501 worksheet from different stores. But these worksheets are getting timed out. There are about 40K items on each store. We tried communicating one store at a time, but with no results. Can someone help? Thanks in advance ...

SBS2008 and SQL 2005
Hello All, So here is my question, we have the SBS 2008 Premium, and all the installation media are sent to us. And that includes the SQL 2005 and 2008 installation disks. But after I installed the SBS 2008 on my first server which we also would like to turn it to SQL, I looked into the Program And Features and found SQL 2005 already installed. But I haven't really insert any SQL installation disk. So is that a valid copy of SQL or just some thing like SQL Express? Do I need to uninstall that and install from my SQL install disk or I can start to use that? Thanks! Ben T...

A SQL error has occurred. Going off line with Outlook CRM 4.
I have seen this in multiple workstations. Running the diagnostics, does not report any errors, however removing the temprary data under advenced fixes the problem by deleting the content of the off line database. The problem with this fix is that it may take up to 12 hours for some of our overseas employees to do their initial off line. When is SP1 due? ...

ADAM Error with Web Service Installation
i need to install the Business Portal for GP 10.0 the web services is required. during the installation of the web services, i encountered an error " ADAM Error 128" what could cause this and how do i solve this? Any one help!!!!! Hi Taiwo Are the web services already installed? If they are it sounds like the issue may be that a different user account installed the web services (other then the one that is installing the BP) Fliehigh "Taiwo" wrote: > > i need to install the Business Portal for GP 10.0 > the web services is required. > during the insta...

Major instal issue
I have Money 2002 installed, and have had for some time. About two weeks ago, I started getting the Windows Installer "preparing to install" message repeatedly when I open Money, or when the Money Viewer is invoked in IE. Both Money and the viewer work fine, but no matter if I cancel or ignore the message, it keeps coming up roughly once every two seconds. The real issue though is this: since this started happening, I've been unable to install or uninstall anything else that uses the Windows installer (including trying to uninstall Money to solve the issue), as it fails saying t...

CRM 3.0 SDK Web Services
Hi I am writing a small data migration tool to migrate account and contact data. I have approximate 1500 accounts and 6000 contacts to import to CRM 3.0. I finished the application and ran the data migration, I will able to migrate all of the account records without any problem at all. when I run the contact migration, it can migrate 2800 contact records when it get over 2800, my application throw me the following error message: The underlying connection was closed: Unable to connect to the remote server. I am running CRM 3.0, SQL server and my data migration on the same server. I am wonder w...

How to Install language pack?
I downloaded the language pack from Microsoft and I can not fogiure out how to get the languages installed in Word. When I got to the language preference page in Word it tells me the languages are not installed and when I click on it I just go back to the download web page. I have done the download. Where do I put the file and how do I get it to load into Word? Thanks I haven't downloaded a language pack myself, but usually with downloads there is an executable file that you can click to start the installation process. -- Stefan Blom Microsoft Word MVP &q...