Why my setting doesn't work?

I am trying to write a program similar to "ping".Like the example provided in 
MSDN,I call setsockopt function to set SO_RCVTIMEO value for my raw 
socket.And before I make a call to recvfrom,I call getsockopt to ensure that 
the value ihas been correctly set,and it has.But recvfrom does not return 
automatically when the specified timeout is exceeded,conversely ,it gets 
stuck permanently if no packet can be received. If anyone knows why ,could 
you please tell me what I should do to get the result I want?Thank you in 
advance for you help.

0
7/29/2005 2:53:05 PM
vc.mfc 33608 articles. 0 followers. Follow

0 Replies
497 Views

Similar Articles

[PageSpeed] 43

Reply:

Similar Artilces:

Outlook 2003 working with Groupwise client
We are moving our people from Groupwise to Exchange and I am having a horrible time getting the two to work together. We need to keep both clients on the machine for a short time while the switch is done. I installed Outlook 2003 on my workstation running Windows XP and Outlook and Groupwise are happily coexisting. When I tried this on a Windows 2000 machine everything went to crap. I've tried all of the tricks I can think of. I've removed Groupwise and windows messaging and reintalled everything from scratch and no dice. I just keep getting Outlook MAPI errors and messages s...

The Settings button keeps disappearing
Hi, I'm having a weird problem when I access CRM using the web client. When I access the site, I see all the buttons (Workplace, Sales, etc) except the Settings button. If I reboot, the button is back. My security role is system Admin. Any idea what is wrong? Thanks! Simon Are you running the Microsoft CRM Outlook Desktop client in parallel? Frank Lee, Microsoft CRM MVP Workopia, Inc. http://microsoft-crm.spaces.live.com "Simon Renshaw" wrote: > Hi, > > I'm having a weird problem when I access CRM using the web client. When I > access the site, I s...

Rules not working #7
I have a mail profile that I use with one email address that gets a LOT of spam. I have a fair size number of rules (probably 10-15) for categorizing and filtering it, all of them starting wth "Apply this rule after the message arrives". Problem is that most of them only work about half the time. I'll get some messages that were moved to the correct folders, and some similar messages still in the inbox. If I click "Rules Wizard" and the "Run Now" button, selecting all the rules, it moves the ones still in the inbox to the correct folder. How come it didn&#...

Public Folders: How to set up Auto-Reply in EX2003?
Hi guys, I've configured a public folder to receive mail from the Internet, and also set up an auto-reply rule using the Folder Assistant to reply when an e-mail is sent to the folder. The folder will auto-reply just fine if I e-mail it from within the Exchange organization, but if folks from the Internet e-mail the folder, it doesn't reply. Any ideas? Thanks! Jeff I ended up figuring out what the problem was. Just in case anyone else has this problem, what I needed to do to fix it was: - Open Exchange System Manager > Global Settings > Internet Message Formats - Right-c...

Hyperlinks do not work in email in outlook
Shortly after installing the new service pack for Windows XP I began getting this message whenever I tried to click on a hyperlink in an email: "This operation has been canceled due to restrictions in effect on this computer. Please contact your system administrator." I assume it is because some switch has been set. Could someone tell me how to regain the ability to use the embedded links in email in outlook? Thanks Bob <anonymous@discussions.microsoft.com> wrote: > Shortly after installing the new service pack for Windows > XP I began getting this message whene...

failure of Open XML 1.1.4 to work
Version: 2004 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel Previous versions of this worked fine. This version comes up with comment &quot;not enough memory&quot;. As I have 2mg Ram this seems strange. Any help appreciated. I'm afraid you haven't provided sufficient information for anyone to go on, especially since that message quite often has nothing to do with memory. For any questions of a technical or performance nature it's important that you specify your current update level of OS X as well as for Office. Exactly when does this messag...

Setting .doc default to .doc, not .dox
Version: 2008 Operating System: Mac OS X 10.5 (Leopard) Processor: intel How do i do this for all new documents? > How do i do this for all new documents? I meant .doc instead of .docx Word> Preferences> Save, choose Word 97-2004 Document (.doc) from the Save Word files as: list - just keep in mind that you'll be constantly working in Compatibility Mode which will prevent the use of some of 2008's features. HTH |:>) Bob Jones [MVP] Office:Mac On 4/23/08 7:50 PM, in article ee99690.-1@webcrossing.caR9absDaxw, "dbdbdb@officeformac.com" <dbdbdb@officeform...

Trying to set up account, geting nowhere FAST!
From: "Lenora" <lmandre@windstream.net> Subject: Understanding what Microsoft Communities Date: Friday, September 14, 2007 5:41 PM Hello out there! What is Microsoft Communities all about? Is it something that comes with no charge when you get Microsoft Vista? This is the 4th computer I've had (besides ones at work). First a Compaq that I loaded everything I could from work, the computer guy gave me stuff...did work at home, brought it back to work, and visa versa. Second was a re-built computer that was given to me by a man in the town we had moved to...out of the g...

hyperlinks within the same document are not working
Hi. I am trying to create an email publication in MS publisher 2007. It has several stories that will be sent out in email and the first section is supposed to contain a summary with hyperlinks to each story within the same email for more details. I am adding a bookmark at the begining of each story, and then trying to create a hyperlink in the summary section to the bookmark. However, when I send the publication as email, or do an email preview, the hyperlinks do not work. Please help! ...

Printing
Hope you folks can help me out with a strange one. I have several worksheets formatted in exactly the same way as follows: Col A - width 4 Col B - hidden Col C - width 4 Col D - Width 108 Col E - Width 3 Col F - Width 11 Col G - Hidden Col H - Width 11 & Empty My print range should be Cols A:G (I have used page setup to set the scaling to fit 1 page wide by [blank] pages tall, thus each sheet will print as many pages as required depending on number of rows] When I have the print range set to A:G only columns A:E show on the print preview (and also on the actual print out) and when I m...

Setting directory for file save in macro
Hi Thanks to a generous poster I now have a great bit of code to use in a macro for Excel which saves a text file (I'm no VBA programmer so this was really helpful), i.e.: Open "Test.txt" For Output As #1 (rest of code) My problem now is this: The macro saves test.txt to Excel's current active folder, rather than the folder that the current workbook is contained in. For example, if I last saved an Excel workbook to c:\workbooks\, and the workbook that I have open exists in c:\workbooks\workbook1\, when I run the macro it saves the text file in c:\workbooks\. If I ...

Exchange 2003 Envelope Journaling not working
Hi, I have a single Exchange 2003 SP1 server. I'm trying to get envelope journaling to work. I have enabled message journaling and then used "exejcfg.exe -e" to enable envelope journaling. The journal mailbox is receiving the standard message journal messages, but not the envelope journal formatted messages. I have verified with LDP to confirm the heuristic value is 512 for the Exchange Org object. Anyone else seen this before or have any advice? Thanks --- Greg Reboot maybe? greg@intellireach.com wrote: > Hi, > > I have a single Exchange 2003 SP1 server. I...

DB Mail is is not working. Need help please.
I have try stop and start the db mail by executing the SPs below but no luck. Does anyone has seem the error below and how to fix it. Thanks in advance for your advise/help. --steps USE msdb; go EXECute sysmail_stop_sp; go EXECute sysmail_start_sp; go EXECute sysmail_help_queue_sp @queue_type = 'Mail'; go queue_type length state last_empty_rowset_time last_activated_time ---------- ----------- ---------------------------------------------------------------- ----------------------- ------------...

How do I get automatic completion to work for an in-cell dropdown
If I have a list of Alpha, Beta, Gamma and an in-cell dropdown, I'd like typing 'G' to auto-select Gamma. I'm pretty sure it was doing that at some point, but now, it does not. This isn't supported under data|validation. You could use A,B,G in the dropdown and then use a helper cell with a formula in it, though. Say you put your abbreviations in A1:A3 of sheet2 and the real names in B1:B3, then you could use: =if(a1="","",vlookup(a1,sheet2!a:b,2,false)) Joseph Weisblatt wrote: > > If I have a list of Alpha, Beta, Gamma and an in-cell dropd...

_CRTDBG_MAP_ALLOC doesn't seem to work
I'm having problems tracking down a meory leak and thought the best way would be to follow the instructions in MDSN: "Detecting and Isolating Memory Leaks Using Microsoft Visual C++" However, I can only get the basic memory dump, without source file and line number. It's as if _CRTDBG_MAP_ALLOC is being ignored. I tried building a test application (basic MFC SDI application) to try it out. At the top of Leaktest.h, I have #define _CRTDBG_MAP_ALLOC #include <stdlib.h> #include <crtdbg.h> In CLeakTestApp::InitInstance(), I have _CrtSetDbgFlag( _CRTD...

OWA timeout does not work for every client
I set the timeout setting on OWA, i don't have any issues but i'm getting lots of complaints that users are getting logged of after 15 min. why does this happen with some clients but not all? thx ...

I cannot paste from one workbook to another. Copy works, paste do.
When I attempt to copy from one workbook and paste into another, copy appears to work but paste does not. The paste menu item is grayed out in the workbook to which I attempt to paste. Are there setting that can be changed to aloow the paste?? Check to see if either workbook and/or worksheet is protected. If so, unprotect. Then Copy/Paste should work. BTW, how are you copy?paste(ing) Tab or content? Dennis "JimmyMc" wrote: > When I attempt to copy from one workbook and paste into another, copy appears > to work but paste does not. The paste menu item is grayed out...

Work Schedule in Excel doc ... Don't have Excel
I just started a new job and the boss sent next weeks schedule in Exce format but I don't have excel. Is there anyway to just read an Exce file? If not can someone tell me my schedule for me -- charlene202 ----------------------------------------------------------------------- charlene2021's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1641 View this thread: http://www.excelforum.com/showthread.php?threadid=27780 Hi you can get a free viewer for excel from the microsoft site .. the following link should get you there http://office.microsoft.com/en-us/of...

Journal stopped working #2
I have noticed that after upgrading from Outlook XP (2002) to Office Outlook 2003 my journal has completely stopped logging entries. I have turned it off and re-initialized it and still not entries. I mailing want it to log Word and Excel files. Any help would be appreciated I am running Exchange 2003 in cached outlook mode on a SBS 2003 server. ...

Setting up Exchange 2003
I had this problem the other day while extending the schema in preparation for an upgrade to Exchange 2003. I searched through a lot of databases and search engines, and found that a lot of people have had this problem, but none of the forums led to a clear cut answer to the issue. So, I thought I'd share my solution to try and help others out, and save them some time and frustration. I was ready to call Microsoft support right before I figured this out. While running forest prep (setup /forestprep), setup failed with Error code 0XC103798A. It then specified to check the Exchange inst...

Spreadsheet macro stopped working!
Hi, I recently made an Excel spreadsheet for keeping track of my golf score. The spreadsheet is quite simple. It consists of 4 sheets: Scorecard, statistics, database and equations (for calculating some specific). I insert informations about the golf course I'm playing and how my score was etc. I then hit a button "Save scorecard" that runs a macro. The macro inserts specifik values from the scorecard into the database sheet (which works like a charm). The macro also updates the "Statistics" sheet with information about stroke number and points for ...

Working with elapsed time data
How do I set up Excel to accept race times for a cross- country team? I want to enter minutes and seconds for each runner for each race. Then I want to calculate each runner's average time. When I enter minutes and seconds, Excel converts it to the time of day - which is not what I want. Go to www.cpearson.com for lots of tips on working with time. Bernard "DW" <dweskalnies@vertisinc.com> wrote in message news:080f01c38854$46e18100$a401280a@phx.gbl... > How do I set up Excel to accept race times for a cross- > country team? I want to enter minutes and seconds for...

Why don't hyperlinks work in my outlook docs?
I know it must be something simple but hyperlinks don't work in incoming email messages. Can anyone help me? ...

Outlook Today is not working
In Outlook XP when I click on Outlook today I get the message Action Canceled. Unable To Link to the Web Page. If I cut and past the link into IE, it will open it there. I've tried restoring factory defaults, but still no go. If I log in at another location then I'm OK. So I tried deleting my profile, but the issues occurs. Thanks, Dave Fixed it. Deleted the profile and the home folder this time. Problem is now gone. >-----Original Message----- >In Outlook XP when I click on Outlook today I get the >message Action Canceled. Unable To Link to the Web Page. > &g...

Set Application Page permissions in WSS 3.0
Example: Using the HelpDesk template, how can I apply permissions to Service Rep and Mgr Home pages? TIA! -JS ...