std::vector and object errors

I'm using a vector object in my code.

(from MyType.h)
std::vector<CMyType> m_vMyType;

(from MyType.cpp)
CString sTemp = "test string";
tjTemp = new CMyType(sTemp);
tjTemp->SetLinkLevel(NO_LINK);
m_vMyType.push_back(*tjTemp);

I'm getting this error on the m_vMyType.push_back(*tjTemp); line:

c:\program files\microsoft visual studio\vc98\include\xutility(19) :
error C2679: binary '=' : no operator defined which takes a right-hand
operand of type 'const class CMyType' (or there is no acceptable
conversion)
        c:\program files\microsoft visual
studio\vc98\include\vector(65) : see reference to function template
instantiation 'class CMyType *__cdecl std::copy(const class CMyType
*,const class CMyType *,class CMyType *)' being compile
d
c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
error C2558: class 'CMyType' : no copy constructor available
        c:\program files\microsoft visual
studio\vc98\include\xmemory(66) : see reference to function template
instantiation 'void __cdecl std::_Construct(class CMyType *,const class
CMyType &)' being compiled

0
henrybg (59)
5/30/2006 2:15:43 PM
vc.mfc 33608 articles. 0 followers. Follow

7 Replies
675 Views

Similar Articles

[PageSpeed] 51

Benry wrote:
> I'm using a vector object in my code.
>
> (from MyType.h)
> std::vector<CMyType> m_vMyType;
>
> (from MyType.cpp)
> CString sTemp = "test string";
> tjTemp = new CMyType(sTemp);
> tjTemp->SetLinkLevel(NO_LINK);
> m_vMyType.push_back(*tjTemp);
>
> I'm getting this error on the m_vMyType.push_back(*tjTemp); line:
>
> c:\program files\microsoft visual studio\vc98\include\xutility(19) :
> error C2679: binary '=' : no operator defined which takes a right-hand
> operand of type 'const class CMyType' (or there is no acceptable
> conversion)
>         c:\program files\microsoft visual
> studio\vc98\include\vector(65) : see reference to function template
> instantiation 'class CMyType *__cdecl std::copy(const class CMyType
> *,const class CMyType *,class CMyType *)' being compile
> d
> c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
> error C2558: class 'CMyType' : no copy constructor available
>         c:\program files\microsoft visual
> studio\vc98\include\xmemory(66) : see reference to function template
> instantiation 'void __cdecl std::_Construct(class CMyType *,const class
> CMyType &)' being compiled

Guess I should have asked a question:
What is going on, and how can I fix this?  Should I declare the vector
with references rather than values?

0
henrybg (59)
5/30/2006 2:27:40 PM
"Benry" <henrybg@gmail.com> wrote in message 
news:1148998543.357718.323440@y43g2000cwc.googlegroups.com...

> I'm using a vector object in my code.
>
> (from MyType.h)
> std::vector<CMyType> m_vMyType;

> c:\program files\microsoft visual studio\vc98\include\xutility(19) :
> error C2679: binary '=' : no operator defined which takes a right-hand
> operand of type 'const class CMyType' (or there is no acceptable
> conversion)

You need to supply an assignment operator - typically of the form

CMyType & CMyType::operator = ( const CMyType &x )
{
.............
}

> c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
> error C2558: class 'CMyType' : no copy constructor available

and a copy constructor

CMyType::CMyType( const CMyType &x )
{
..........
}

Dave
-- 
David Webber
Author MOZART the music processor for Windows -
http://www.mozart.co.uk
For discussion/support see
http://www.mozart.co.uk/mzusers/mailinglist.htm


0
dave1 (356)
5/30/2006 2:31:23 PM
David Webber wrote:
> "Benry" <henrybg@gmail.com> wrote in message
> news:1148998543.357718.323440@y43g2000cwc.googlegroups.com...
>
> > I'm using a vector object in my code.
> >
> > (from MyType.h)
> > std::vector<CMyType> m_vMyType;
>
> > c:\program files\microsoft visual studio\vc98\include\xutility(19) :
> > error C2679: binary '=' : no operator defined which takes a right-hand
> > operand of type 'const class CMyType' (or there is no acceptable
> > conversion)
>
> You need to supply an assignment operator - typically of the form
>
> CMyType & CMyType::operator = ( const CMyType &x )
> {
> ............
> }
>
I do.
 CMyType  CMyType::operator=(  CMyType &other ) {
	//vector <int> v4( v2 );
	std::vector <CString>::iterator v_Iter;
	for ( v_Iter = other.vFields.begin( ) ; v_Iter != other.vFields.end( )
; v_Iter++ ){
		this->vFields.push_back( *v_Iter );
	}
	this->sTableName = other.sTableName;
	return *this;
}

> > c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
> > error C2558: class 'CMyType' : no copy constructor available
>
> and a copy constructor
>
> CMyType::CMyType( const CMyType &x )
> {
> .........
> }

I do that too.

 CMyType:: CMyType( CMyType &rhs)
{
	std::vector <CString>::iterator v_Iter;
	for ( v_Iter = rhs.vFields.begin( ) ; v_Iter != rhs.vFields.end( ) ;
v_Iter++ ){
		vFields.push_back( *v_Iter );
	}
	sTableName = rhs.sTableName;
}

Perhaps it's because I'm not using const? (five minute pause)...ok I
changed it to const, and now am having a problem with the vector
assignment loop.  Perhaps if this is fixed?  Could you recommend
something to fix the vector copying?

-Benry

0
henrybg (59)
5/30/2006 2:51:21 PM
Benry wrote:
> David Webber wrote:
> > "Benry" <henrybg@gmail.com> wrote in message
> > news:1148998543.357718.323440@y43g2000cwc.googlegroups.com...
> >
> > > I'm using a vector object in my code.
> > >
> > > (from MyType.h)
> > > std::vector<CMyType> m_vMyType;
> >
> > > c:\program files\microsoft visual studio\vc98\include\xutility(19) :
> > > error C2679: binary '=' : no operator defined which takes a right-hand
> > > operand of type 'const class CMyType' (or there is no acceptable
> > > conversion)
> >
> > You need to supply an assignment operator - typically of the form
> >
> > CMyType & CMyType::operator = ( const CMyType &x )
> > {
> > ............
> > }
> >
> I do.
>  CMyType  CMyType::operator=(  CMyType &other ) {
> 	//vector <int> v4( v2 );
> 	std::vector <CString>::iterator v_Iter;
> 	for ( v_Iter = other.vFields.begin( ) ; v_Iter != other.vFields.end( )
> ; v_Iter++ ){
> 		this->vFields.push_back( *v_Iter );
> 	}
> 	this->sTableName = other.sTableName;
> 	return *this;
> }
>
> > > c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
> > > error C2558: class 'CMyType' : no copy constructor available
> >
> > and a copy constructor
> >
> > CMyType::CMyType( const CMyType &x )
> > {
> > .........
> > }
>
> I do that too.
>
>  CMyType:: CMyType( CMyType &rhs)
> {
> 	std::vector <CString>::iterator v_Iter;
> 	for ( v_Iter = rhs.vFields.begin( ) ; v_Iter != rhs.vFields.end( ) ;
> v_Iter++ ){
> 		vFields.push_back( *v_Iter );
> 	}
> 	sTableName = rhs.sTableName;
> }
>
> Perhaps it's because I'm not using const? (five minute pause)...ok I
> changed it to const, and now am having a problem with the vector
> assignment loop.  Perhaps if this is fixed?  Could you recommend
> something to fix the vector copying?

Forget it, I took out the loop, and just used the std::vector equals
operator, and it works now.  Thanks for the hint!!

-Benry

0
henrybg (59)
5/30/2006 3:04:50 PM
Benry wrote:

> Benry wrote:
> 
>>David Webber wrote:
>>
>>>"Benry" <henrybg@gmail.com> wrote in message
>>>news:1148998543.357718.323440@y43g2000cwc.googlegroups.com...
>>>
>>>
>>>>I'm using a vector object in my code.
>>>>
>>>>(from MyType.h)
>>>>std::vector<CMyType> m_vMyType;
>>>
>>>>c:\program files\microsoft visual studio\vc98\include\xutility(19) :
>>>>error C2679: binary '=' : no operator defined which takes a right-hand
>>>>operand of type 'const class CMyType' (or there is no acceptable
>>>>conversion)
>>>
>>>You need to supply an assignment operator - typically of the form
>>>
>>>CMyType & CMyType::operator = ( const CMyType &x )
>>>{
>>>............
>>>}
>>>
>>
>>I do.
>> CMyType  CMyType::operator=(  CMyType &other ) {
>>	//vector <int> v4( v2 );
>>	std::vector <CString>::iterator v_Iter;
>>	for ( v_Iter = other.vFields.begin( ) ; v_Iter != other.vFields.end( )
>>; v_Iter++ ){
>>		this->vFields.push_back( *v_Iter );
>>	}
>>	this->sTableName = other.sTableName;
>>	return *this;
>>}
>>
>>
>>>>c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
>>>>error C2558: class 'CMyType' : no copy constructor available
>>>
>>>and a copy constructor
>>>
>>>CMyType::CMyType( const CMyType &x )
>>>{
>>>.........
>>>}
>>
>>I do that too.
>>
>> CMyType:: CMyType( CMyType &rhs)
>>{
>>	std::vector <CString>::iterator v_Iter;
>>	for ( v_Iter = rhs.vFields.begin( ) ; v_Iter != rhs.vFields.end( ) ;
>>v_Iter++ ){
>>		vFields.push_back( *v_Iter );
>>	}
>>	sTableName = rhs.sTableName;
>>}
>>
>>Perhaps it's because I'm not using const? (five minute pause)...ok I
>>changed it to const, and now am having a problem with the vector
>>assignment loop.  Perhaps if this is fixed?  Could you recommend
>>something to fix the vector copying?
> 
> 
> Forget it, I took out the loop, and just used the std::vector equals
> operator, and it works now.  Thanks for the hint!!
> 
> -Benry
> 

Benry:

1. Assignment operator and copy constructor should always take a const 
reference argument; otherwise you cannot copy a constant object. The 
correct syntax is as given by David Webber.

2. In your posted code, why are you creating tjtemp on the heap? You are 
storing objects in your vector, not pointers. Surely your code is 
leaking memory?

3. It is not clear why you need to specify your own assignment operator 
and copy constructor here. Doesn't the default one (member-wise copy) do 
what you want?

David Wilkinson
0
no-reply8010 (1791)
5/30/2006 3:24:52 PM
David Wilkinson wrote:
> Benry wrote:
>
> > Benry wrote:
> >
> >>David Webber wrote:
> >>
> >>>"Benry" <henrybg@gmail.com> wrote in message
> >>>news:1148998543.357718.323440@y43g2000cwc.googlegroups.com...
> >>>
> >>>
> >>>>I'm using a vector object in my code.
> >>>>
> >>>>(from MyType.h)
> >>>>std::vector<CMyType> m_vMyType;
> >>>
> >>>>c:\program files\microsoft visual studio\vc98\include\xutility(19) :
> >>>>error C2679: binary '=' : no operator defined which takes a right-hand
> >>>>operand of type 'const class CMyType' (or there is no acceptable
> >>>>conversion)
> >>>
> >>>You need to supply an assignment operator - typically of the form
> >>>
> >>>CMyType & CMyType::operator = ( const CMyType &x )
> >>>{
> >>>............
> >>>}
> >>>
> >>
> >>I do.
> >> CMyType  CMyType::operator=(  CMyType &other ) {
> >>	//vector <int> v4( v2 );
> >>	std::vector <CString>::iterator v_Iter;
> >>	for ( v_Iter = other.vFields.begin( ) ; v_Iter != other.vFields.end( )
> >>; v_Iter++ ){
> >>		this->vFields.push_back( *v_Iter );
> >>	}
> >>	this->sTableName = other.sTableName;
> >>	return *this;
> >>}
> >>
> >>
> >>>>c:\program files\microsoft visual studio\vc98\include\xmemory(34) :
> >>>>error C2558: class 'CMyType' : no copy constructor available
> >>>
> >>>and a copy constructor
> >>>
> >>>CMyType::CMyType( const CMyType &x )
> >>>{
> >>>.........
> >>>}
> >>
> >>I do that too.
> >>
> >> CMyType:: CMyType( CMyType &rhs)
> >>{
> >>	std::vector <CString>::iterator v_Iter;
> >>	for ( v_Iter = rhs.vFields.begin( ) ; v_Iter != rhs.vFields.end( ) ;
> >>v_Iter++ ){
> >>		vFields.push_back( *v_Iter );
> >>	}
> >>	sTableName = rhs.sTableName;
> >>}
> >>
> >>Perhaps it's because I'm not using const? (five minute pause)...ok I
> >>changed it to const, and now am having a problem with the vector
> >>assignment loop.  Perhaps if this is fixed?  Could you recommend
> >>something to fix the vector copying?
> >
> >
> > Forget it, I took out the loop, and just used the std::vector equals
> > operator, and it works now.  Thanks for the hint!!
> >
> > -Benry
> >
>
> Benry:
>
> 1. Assignment operator and copy constructor should always take a const
> reference argument; otherwise you cannot copy a constant object. The
> correct syntax is as given by David Webber.

Fixed, and will note for the future.

> 2. In your posted code, why are you creating tjtemp on the heap? You are
> storing objects in your vector, not pointers. Surely your code is
> leaking memory?

I am deleting the pointer after it's being used, so there are no leaks.
 I'm using new because of the constructor, and it's been that way since
I started?  I don't know I guess.

> 3. It is not clear why you need to specify your own assignment operator
> and copy constructor here. Doesn't the default one (member-wise copy) do
> what you want?

There are two error messages, and using my own assignment operator and
copy constructor are what was needed to fix the issue.  My program
works now.  Thank you.

-Benr

0
henrybg (59)
5/30/2006 3:35:00 PM
Replies inline.

Benry wrote:

>>Benry:
>>
>>1. Assignment operator and copy constructor should always take a const
>>reference argument; otherwise you cannot copy a constant object. The
>>correct syntax is as given by David Webber.
> 
> 
> Fixed, and will note for the future.
> 
> 
>>2. In your posted code, why are you creating tjtemp on the heap? You are
>>storing objects in your vector, not pointers. Surely your code is
>>leaking memory?
> 
> 
> I am deleting the pointer after it's being used, so there are no leaks.
>  I'm using new because of the constructor, and it's been that way since
> I started?  I don't know I guess.
>

Well, there was no delete in your posted code. There is no need to 
create on the heap. You can do like this:

CString sTemp = "test string";
CMyType tjTemp(sTemp);
tjTemp.SetLinkLevel(NO_LINK);
m_vMyType.push_back(tjTemp);


>>3. It is not clear why you need to specify your own assignment operator
>>and copy constructor here. Doesn't the default one (member-wise copy) do
>>what you want?
> 
> 
> There are two error messages, and using my own assignment operator and
> copy constructor are what was needed to fix the issue.  My program
> works now.  Thank you.

Well, you do not show your entire CMyType class defintion, but from what 
I have seen you should not have to provide your own versions of 
assignment and copy constructor. For example, if your copy cosntructor does

CMyType:: CMyType(const CMyType &rhs)
{
   vFields = rhs.vFields;
   sTableName = rhs.sTableName;
}

or better

CMyType:: CMyType(const CMyType &rhs):
vFields(rhs.vFields),
sTableName(rhs.sTableName)
{
}

then this is just what the default does, so you should not need it.

BTW, the reason your loop did not work was because you did

std::vector <CString>::iterator v_Iter;

where you should have done

std::vector <CMyType>::iterator v_Iter;

David Wilkinson







0
no-reply8010 (1791)
5/30/2006 3:59:11 PM
Reply:

Similar Artilces:

Compile error #2
Hi all I've received a worksheet from a colleague, when trying to run a macro, I get a compile error - 'Cannot find project or library' Code stops at --- hilltest = LCase(hilltest) with LCase highlighted. Can anyone explain the problem? Code below --------------------------------------------------------------------------- Sub NameSearch(xtest) Dim myName As String Dim i As Integer, idb As Integer, myrow As Integer Dim hilltest As String 'Dim xtest As Integer idb = 3688 myName = Application.InputBox("Choose a Hill: You can use * as a wildcard", Type:=2 + ...

"connection failure, timeout or low disk" error
Every once in a while during periods of heavy demand and some large reports running I see this error in the SSRS log: library!WindowsService_2!fd8!05/13/2010-01:17:26:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException: An error occurred within the report server database. This may be due to a connection failure, timeout or low disk condition within the database. I have read information on the internet regarding the various timeouts configurable in SSRS and have them all set fairly high so I don't know why I am getting this e...

lost in error 3075
Help! I am trying to modify another's code to use a form to input a date (datbegin) in a query (see below) instead of having to manually change it. I dimensioned datbegin as Date and set datebegin = [Forms]![frmMK]![lbodatbegin] and with MsgBox I know that part is working. However, I get the 3075 error pointing to this: Set rstMKTable = db.OpenRecordset(strQry) I did this Dim rstMKTable As DAO.Recordset, hopefully correctly from postings re error 3061. strQry = "SELECT ACME.STATION_ID, ACME_PAR.PARAM_NAME, ACME.SAMP_DATE, ACME.VALUE, ACME.FLAG, ACME.UNITS...

Internal Server Error
Hi Have an Exchange 2003 set up with Front end server doing OWA. There is a public folder set up as a shared calander, which is moderated to forward all new entries to a single user. When a new appointment is booked, and save and close button pressed, I get a pop up saying internal server error. and the new appointment window stays where it is. I close the new appointment window and the appointment is entered, as if there were no problem. Anyone have an idea why the error pop up? Thanks M ...

calling objects method
Hello, I have a collection of objects. Each object has few properties and few methods, among which: save, delete, recall and others. The "save" method of each object runs few private class functions to double check data and if everything is fine it adds the data collected in few tables. I would need a way to iterate the objects in the Collection (and I know how to do this) and call for each of them the "save" method. Is this possible? Hoping first it is clear... Thanks, Rocco it should be: myCollectionName.Item(itemIndex).Save ....I guess... "ro...

CTreeCtrl
Question: I have a CTreeCtrl which makes many dynamic insertions and deletions during it's life time. I am currently using each nodes HTREEITEM in an std::map as a key. My question is, is this safe? Say that I insert a new node into the tree, or delete a node...will all __OTHER__ HTREEITEMs remain valid? I currently have an app that does just that...and everything seems to remain in place. I am just a little worried because I am doing so many dynamic insertions and deletions etc...can someone verify that once a valid HTREEITEM is stored, it will remain valid until it is deleted, rega...

error when reinstalling XP Pro
thHi, I have a Dell Latitude D620. That was having some issues with ethernet and wireless connections. Nothing really found as fas as malware or viruses, without updates of course. I tried to do a windows repair from the XP CD and right when it shows starting windows to choose repair or install windows I get a blue screen with the error... PCI.SYS-address F76130BF base at F76000000 Date stamp 3B7D855C. I tried a few times and even set the BIOS to minimal. Then I pulled the hard drive out and connected to another laptop using a usb cradle, formated the drive and put it back in th...

Crystal Reports Error 09-15-03
We are receiving the following error when attempting to view reports in CRM. This error occurs when selecting a specific report to generate. We've turned on the dev error message but can make no sense of this one. Any ideas? Thanks in advance. ---------------------------------------------------------------- Microsoft CRM Platform Error Report: Error Description: Unable to communicate with the report viewer : Invalid report output (SSO or Crystal logon, or other error) Error Details: Details on this error have not been provided by the platform. ...

Fatal error LNK 1104: cannot open file "nafxcwd.lib"
I 've executed all instructions of the article of that error in the "RESOLUTION" but the error appears again and again. I don't know what to do. I have no idea. Please, help me. Thank YOU in advance. ...

Permissions error when offline
Hello - I have a user who when he goes offline with his CRM data he cannot access some parts of the CRM system. So he has all of his Contacts, Accounts, Leads, Opportunities, etc. synced. When he is offline, he can go into Contacts and Leads no problem. When he goes into Accounts or Opportunities, he gets an error that states, the 'the user either does not have access or does not have permissions'. This user does have permissions/security to these areas. He can view them just fine when working online. Any ideas? I'm having the same issue with one user. Has anyone fou...

report error when printing sales anaylisis
we are using great plains dynamics, and when we print a sales anaylisis period report we get an error message undefined symbol f00347d04767indexlong any idea where to look to correct this....im guess someone type in something where it doesnt belong. thanks SS, You have a problem with the report. Did someone try to modify it recently? Log into Customer Source and have a look at Article #862263 or just search on "undifined symbol error" (without the quotes of course). Lyle On Wed, 20 Sep 2006 10:22:02 -0700, seldomseen <seldomseen@discussions.microsoft.com> wrote: >...

Error Message: c:\windows\system32\avgxch32.dll(avgxch32.dll)
I am running Cloudmark's Spamnet within Outlook 2002. When I try to delete a large number of emails from the Spam folder (choosing Edit/Select All/Delete) I get the following error message: "c:\windows\system32\avgxch32.dll could not be installed or loaded. This problem may be resolved by using Detect and Repair on the Help menu. Out of memory or system resources. Close some windows or programs and try again." a. Even if no other programs are open, the problem still occurs. b. Running Detect and Repair makes no difference. c. Worst of all, I cannot close the error window. Wh...

Error after applying SP3 to GP9.0
error message "A product on the computer is on a different version than the database version. You will not be able to use the application until this issue is resolved. Use the GP_LoginErrors.log file in your temp directory to assist in resolving this issue". I have applied SP3 and did not get any errors during the install. The error while trying to open any of the companies. There are no previous service packs installed prior to applying SP3. I am also not able to locate "GP_LoginErrors.log" You need to apply the service pack on your server FIRST before you apply i...

Report Writer - error message
i'm working on updating our SOP blank packing slip form and received an error message when trying to print it - Max symbol length exceeded: increase MAX_TOK_LEN. we have GP version 10. Any suggestions on what caused this and how to fix it? ...

#Deleted Error
I have a record that was deleted by another user that does not seem to be completly gone. When I access the table the record shows #Deleted in every row. I can delete the record but it comes back when I open the table again. It also will not allow queries to work that encompass this record. I have compacted the database and still the same. Any suggestions? I'd reccomend using a reliable database, like SQL Server and Access Data Projects "PJB710" <PJB710@discussions.microsoft.com> wrote in message news:36E17600-13F8-488E-ABAE-CCEFA07E7ACB@microsoft.com... >...

Excel Filter error
I have excel file with macro, size 2mb.... every show all filter its always restart and recover. The dialog message is: AppName: excel.exe ModVer: 10.0.6501.0 AppVer: 10.0.6501.0 Offset: 003f16c1 ModName: excel.exe OS: WinXP Office XP Regards, jaka fahrial ...

outlook closes due to error?
While running on a hard wire connection outlook appears to run ok, that is it hasn't crash. but while on wireless, it will shut saying outlook has encountered an error and needs to shut down. very weird? I am looking for a solution, but doesn't seem to be anyone else having this problem. any experts here who may have an answer?? windows XP home Microsoft 0ffice 2007 and I just upgraded to 2007 from 2003 which was working fine. could I be needing a service pack of some sort?? Thanks If you run MS Update, or Office update you will be advised of any critical updates "Willi...

Overflow Error 6 when opening journal
Hi, I am getting error 6 overflow when opening journal or looking at receipt template properties. It's a customized receipt but the very same receipt template works fine on another computer. I have seen this error before and it was fixed by applying all available Windows updates. This time the computer is up-to-date so there are no updates to apply. Best Regards, Richard Korenek Check your default printer and make sure its correct. "RichardK" <RichardK@discussions.microsoft.com> wrote in message news:986369DB-A6AB-4FC6-870F-F07EAF7BE6BF@microsoft.com... > Hi, ...

error RC2144 : PRIMARY LANGUAGE ID not a number
When I build a project in VC6, I got errors below: D:\Program\XXXX.rc (25): error RC2144 : PRIMARY LANGUAGE ID not a number D:\Program\XXXX.rc (34): error RC2135 : file not found: 653 The project could be built successfully before I re-install my VC6. What's the matter with my VC6? Or is there any wrong with my setting? Why do you assume that VC6 is wrong? What does line 25 in XXXX.rc say? -- Serge. http://www.apptranslator.com - Localization tool for your MFC applications "Chen" <chenqi@uniscope.com.cn> wrote in message news:eyuxKoDXJHA.1532@TK2MSFTNGP03.phx.gbl...

error message "554 SMTP service not available"
When an email is sent to .rcn.com or .juno.com this email message comes back instantly reading as follows: A mail message was not sent due to a protocol error. Can you telnet from your server to one of these remote domains and drop off a piece of mail? Anything in the app log? Craig -- Craig Philbeck a-cphil@online.microsoft.com Microsoft PSS Please do not send email directly to this alias. This alias is for newsgroup purposes only. This posting is provided "AS IS" with no warranties, and confers no rights. "rJennett (Removethis) @rpjassociates.com" <anony...

Error -3253
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Email Client: Exchange Our server recently crashed over the weekend, and ever since then, I can send emails, but not emails with attachments. I keep getting the error code &quot;-3253&quot;. How does this get corrected? What is wrong? On 3/16/10 11:44 AM, Sarah_K@officeformac.com wrote: > Our server recently crashed over the weekend, and ever since then, I can > send emails, but not emails with attachments. I keep getting the error > code "-3253". How does this get corrected? What is wrong? Thi...

Errors running Small Business Backup
I had given up trying to use NTBackup as it would only work when it wanted to, and when it didnt work it wouldnt only generate a blank report. I tried doing the small business backup, but it is giving me issues also. Can someone please point me into a direction to see why this doesnt work. Below is the error I receive when trying to run the backup manually. [Error Log 1] 8/23/2006 8:49 AM ------------------------------- Date: 8/23/2006 Time: 8:49 AM User: administrator ------------------------------- Backup Runner started. NTMS session started successfully. EnumerateNtmsObject(NTMS_L...

Error Message While Sorting
When I try to sort I am getting the following error message. This operation requires the merged cells to be identically sized. Any suggestions -- arku ----------------------------------------------------------------------- arkum's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1648 View this thread: http://www.excelforum.com/showthread.php?threadid=31493 Hi arkum Remove the merged cells and never use merged cells again. Always trouble when you use this. Select the cells and use Ctrl-1 to go to the Alignment tab to change this -- Regards Ron de Bruin http...

incompatible version of the RPC stud error message
i am running windows ME... every time i try to print a web page or email from internet explorer or outlook, i get the above error message. what can i do to fix this? i know very little if any about fixing anything with a computer... i'm lost, so any help you can give would be greatly appreciated. ...

Reminder Error Messages
I have reinstalled Outlook 2003 after backing up my data files. When I opened the backup,the data is not in the Calendar folder, but another folder called "Calendar in Personal Folders". When I try to add an event to the folder with the data, I get an error message stating the the reminder will not appear because the item is not in my "Calendar or Tasks Folders". How do I correct this? What the error message is indicating is that reminders will only trigger from the calendar folder that is in your primary PST file. The primary PST file is the file that you...