Ctrl+Alt+L does not work.

Hi All:

In VS 2008, the accelerator of active resolution bar is Ctrl+Alt+L. But it 
does not work. I create a MFC mdi sample, and set a menu's accelerator to 
Ctrl+Alt+L, it does not work too. Why?

Thanks

Fiveight 


0
fiveight (72)
4/24/2008 9:25:55 AM
vc.mfc 33608 articles. 0 followers. Follow

7 Replies
930 Views

Similar Articles

[PageSpeed] 35

Are you sure it's just that keystroke combination that doesn't work?  The 
first thing I would do is set it to something else (like Alt+F2) and see if 
that works just to make sure it's not something in the focus mechanism.  If 
that does work, then  my guess is that you may have something else with the 
same keystroke elsewhere that has prior focus.  For example, I've seen 
problems when running in the debugger if I use keystrokes the debugger wants 
to use.

Tom

"fiveight" <fiveight@tom.com> wrote in message 
news:%23RlT10epIHA.2256@TK2MSFTNGP05.phx.gbl...
> Hi All:
>
> In VS 2008, the accelerator of active resolution bar is Ctrl+Alt+L. But it 
> does not work. I create a MFC mdi sample, and set a menu's accelerator to 
> Ctrl+Alt+L, it does not work too. Why?
>
> Thanks
>
> Fiveight
> 

0
tom.nospam (3240)
4/24/2008 1:14:24 PM
OK, are you talking about a VS2008 IDE shortcut, or a shortcut that you want to put in
your program?  Has it worked in any previous version of VS?  What OS did it previouslyl
run under, and what OS are you using now?  What is an "accelerator of active resolution"?

Far too little information, and vaguely presented.
					joe

On Thu, 24 Apr 2008 17:25:55 +0800, "fiveight" <fiveight@tom.com> wrote:

>Hi All:
>
>In VS 2008, the accelerator of active resolution bar is Ctrl+Alt+L. But it 
>does not work. I create a MFC mdi sample, and set a menu's accelerator to 
>Ctrl+Alt+L, it does not work too. Why?
>
>Thanks
>
>Fiveight 
>
Joseph M. Newcomer [MVP]
email: newcomer@flounder.com
Web: http://www.flounder.com
MVP Tips: http://www.flounder.com/mvp_tips.htm
0
newcomer (15975)
4/24/2008 2:04:43 PM
OK, I find out the reason. Just like Tom said,  I have something else (may 
be the anti-virus software) with the same keystroke  that has prior focus. I 
try the Ctrl+Alt+L shortcut on another pc, it works well.

Pardon me, joe. My English is poor. It should be "shortcut of activating 
resolution bar".

"Joseph M. Newcomer" <newcomer@flounder.com> 
??????:5o41145i3dj9aqft3ljrdn8jmpff2ie1r6@4ax.com...
> OK, are you talking about a VS2008 IDE shortcut, or a shortcut that you 
> want to put in
> your program?  Has it worked in any previous version of VS?  What OS did 
> it previouslyl
> run under, and what OS are you using now?  What is an "accelerator of 
> active resolution"?
>
> Far too little information, and vaguely presented.
> joe
>
> On Thu, 24 Apr 2008 17:25:55 +0800, "fiveight" <fiveight@tom.com> wrote:
>
>>Hi All:
>>
>>In VS 2008, the accelerator of active resolution bar is Ctrl+Alt+L. But it
>>does not work. I create a MFC mdi sample, and set a menu's accelerator to
>>Ctrl+Alt+L, it does not work too. Why?
>>
>>Thanks
>>
>>Fiveight
>>
> Joseph M. Newcomer [MVP]
> email: newcomer@flounder.com
> Web: http://www.flounder.com
> MVP Tips: http://www.flounder.com/mvp_tips.htm 


0
fiveight (72)
4/25/2008 4:57:50 AM
I have the same problem with programs that have "hot key" implementations; I'd love to be
able to detect any and all programs that have "hotkeys" and delete those hotkey sequences.
				joe

On Fri, 25 Apr 2008 12:57:50 +0800, "fiveight" <fiveight@tom.com> wrote:

>OK, I find out the reason. Just like Tom said,  I have something else (may 
>be the anti-virus software) with the same keystroke  that has prior focus. I 
>try the Ctrl+Alt+L shortcut on another pc, it works well.
>
>Pardon me, joe. My English is poor. It should be "shortcut of activating 
>resolution bar".
>
>"Joseph M. Newcomer" <newcomer@flounder.com> 
>??????:5o41145i3dj9aqft3ljrdn8jmpff2ie1r6@4ax.com...
>> OK, are you talking about a VS2008 IDE shortcut, or a shortcut that you 
>> want to put in
>> your program?  Has it worked in any previous version of VS?  What OS did 
>> it previouslyl
>> run under, and what OS are you using now?  What is an "accelerator of 
>> active resolution"?
>>
>> Far too little information, and vaguely presented.
>> joe
>>
>> On Thu, 24 Apr 2008 17:25:55 +0800, "fiveight" <fiveight@tom.com> wrote:
>>
>>>Hi All:
>>>
>>>In VS 2008, the accelerator of active resolution bar is Ctrl+Alt+L. But it
>>>does not work. I create a MFC mdi sample, and set a menu's accelerator to
>>>Ctrl+Alt+L, it does not work too. Why?
>>>
>>>Thanks
>>>
>>>Fiveight
>>>
>> Joseph M. Newcomer [MVP]
>> email: newcomer@flounder.com
>> Web: http://www.flounder.com
>> MVP Tips: http://www.flounder.com/mvp_tips.htm 
>
Joseph M. Newcomer [MVP]
email: newcomer@flounder.com
Web: http://www.flounder.com
MVP Tips: http://www.flounder.com/mvp_tips.htm
0
newcomer (15975)
4/25/2008 7:33:54 AM
It's getting more difficult all the time to figure out a key you can use 
that someone else hasn't already used.  I'd recommend turning off the hot 
key in the virus checker (or whatever), but that doesn't preclude one of 
your users from having the same problem.  Fortunately, this is really only a 
problem for programs with global focus.

I like your URL by the way :o)

Tom

"fiveight" <fiveight@tom.com> wrote in message 
news:%232EluDppIHA.4736@TK2MSFTNGP06.phx.gbl...
> OK, I find out the reason. Just like Tom said,  I have something else (may 
> be the anti-virus software) with the same keystroke  that has prior focus. 
> I try the Ctrl+Alt+L shortcut on another pc, it works well.
>
> Pardon me, joe. My English is poor. It should be "shortcut of activating 
> resolution bar".
>
> "Joseph M. Newcomer" <newcomer@flounder.com> 
> ??????:5o41145i3dj9aqft3ljrdn8jmpff2ie1r6@4ax.com...
>> OK, are you talking about a VS2008 IDE shortcut, or a shortcut that you 
>> want to put in
>> your program?  Has it worked in any previous version of VS?  What OS did 
>> it previouslyl
>> run under, and what OS are you using now?  What is an "accelerator of 
>> active resolution"?
>>
>> Far too little information, and vaguely presented.
>> joe

0
tom.nospam (3240)
4/25/2008 2:14:48 PM
BTW,  thanks for posting in English and don't worry about how well you speak 
it.  I think you'll find from Giovanni that the best way to learn it is just 
to jump in and use it.  Your English is likely better than my "whatever 
language you natively speak".

Tom

"fiveight" <fiveight@tom.com> wrote in message 
news:%232EluDppIHA.4736@TK2MSFTNGP06.phx.gbl...

> Pardon me, joe. My English is poor. It should be "shortcut of activating 
> resolution bar".

0
tom.nospam (3240)
4/25/2008 2:17:48 PM
Joseph M. Newcomer wrote:
> I have the same problem with programs that have "hot key" implementations; I'd love to be
> able to detect any and all programs that have "hotkeys" and delete those hotkey sequences.

Simply enumerate hot keys and reset them.
0
cadel (1)
4/25/2008 3:51:59 PM
Reply:

Similar Artilces:

Beginning balance total on G/L trial balance after year-end close
We ran the G/L year-end close during which we received SQL errors. We did get the report printout and the year being closed was marked as historical. Plus, for the new year, the balance sheet accounts now have beginning balances and revenue and expense accounts have zero beginning balances. However, when we print a G/L trial balance for the new year, the total of the Begininning Balance column has an amount. Normally, the total of this column should be zero. So, when we drill down to the BBF entry, it's out of balance by the amount of the beginning balance column on the trial ba...

Can't get bar code font to work in EXCEL 2003
I have a simple formula that converts a part number to a 3 of 9 bar code font in Excel 2003. Works great on my computer but a co-worker, who also has Excel 2003, can't get this to work. On her PC it show the 3 of 9 font in the drop down box but in the cell it is not converting it to a bar code image. Any suggestions? Thanks, Tony Most likely the font is not installed properly... She needs to reinstall the font. It can be done through Control Panel -> Fonts if you have the font available. "Tony" wrote: > I have a simple formula that conve...

Outlook does not d/l entire imap message, though it is set to
I am using Outlook 2007 and am having trouble getting it to consistently download an entire message instead of just the headers. I went into Define Send/Receive Groups to specify the particular folder in question, and selected it as being one for which all items incl. attachments should be completely downloaded. However, many times it only grabs the header. Is this a bug? And how can I make it always download the complete item? Thanks, Garrett "Garrett" <Garrett@discussions.microsoft.com> wrote in message news:710C17CC-B12C-452F-BF95-DC2317E572A6@microso...

Ctrl- F for search
I have a search button on the form which works fine. I tried to use Ctrl-F to do the same function and get "an error occurred in a call to the Windows Date and Time Picker control" I have DateTimePicker control on the form. Are there any conflict with Ctrl-F search function and DateTimePicker ActiveX control? Your information is great appreciated, ...

Record Macro Relative does not work?
Can someone help me with this macro. I want to go to any cell of my choice and press f2 to edit, then go to the fifth character of that cell, then select the next 6 characters and change them to a smaller font size (8), then "enter". I tried to make this macro using the record macro function, but it did not work how I want it to. It ends up pasting the contents of the cell which I used to record the macro initially. Can this kind of macro be done? To get a relative recorded macro, make sure the stopr recording toolbar is visible, it has 2 icons, one is to s...

OWA stopped working on one of the Cluster Nodes
Our environment has 2 FE servers and an A/A/P cluster. Recently (not sure how long ago) OWA stopped allowing logons on one of the BE nodes. I have checked the configuration for the HTTP resources and they all appear to be identical. When I move the EVS from the Active to Passive node OWA starts working properly. I had installed Symantec's SMSMSE 4.6 around the same time frame and have since removed that. I have tried to Restore the IIS configuration to an earlier date and that fixed the Passive Node but not the Active node. I have removed Exchange and reinstalled and removed IIS and...

Reply rule doesn't work consistantly
I've got an Outlook 2003 client and we are trying to setup a rule to emulate the Out of Office Assistant. I've setup a rule that is supposed to send reply with a template if the sender is from a list of contacts that I've chosen. It isn't working as expected. The first time I tried it, I entered only one (internet) email address which worked perfectly. If I add any addresses to that list, it doesn't work anymore - the reply is not sent. I know that it can reply to internet email addresses, since it worked that one time, but I can't figure out why it won't work when...

Double Click on file and mouse not working
Good afternoon, thanks for taking time to look at my problem. I am trying to open a word document by double clicking on the file name in "my documents". Word opens, but not the document. If you go into File and Open, you can open the document, but the mouse cursor will not go anywhere in the document. I have tried to open Word in safe mode, blasted the normal.dot, copied a normal.dot from another computer, heck I tried disassociating doc from Word. Nothing worked. I even installed Windows Live so I could uninstall it. I'm hoping someone has fixed this problem. ...

DCount?? not working. Pls help
My data is orgnaised as follows: A B C D E David 2245 abcd efgh ijk Susan 2249 xyz etc etc Mickey 1234 etc 123 etc Arnold 4321 etc.... David 1441 Mickey abcd etc etc I want to count the number of non blank cells in B for each "David", "Susan" etc in A, and have the value returned in another sheet. I tried DCount, but it doesnt seem to be working. -- KDDXB I mocked up your data as you provided it, with names in A1:A6 etc. I entered "David" in A8 and this formul...

Alt S wont send anymore
I can't be dreaming - installed outlook 2003 about 2 weeks ago. After creating a message, I was able to just hit alt S and the message would be sent. Now, I have to hit enter after alt S. What changed? Any ideas? thanks, larry ...

Why doesn't the page preview have the same order as work page?
Why doesn't the preveiw page look like the one I built on the work pages. I have "saved as" and "saved. The nagagation bars in preview goes to different pages than titled. HELP!!!!!! ...

Downloading in Outlook 2003 creates a file "needs list" instead of d/l file
When I have an email with attachment, and I go to download it, it downloads it and sometimes renames it to "needs list". It is the same size as the original file, however it cant be opened by any known program. In this case, it should be a .dwg autocad file, but it has happened a couple of times. the name in the saveas box is correct, you download it, and go to that directory and what you were expecting to be there isnt, instead needs list is there. Anyone here of this before? I searched Google, and the newsgroups and the MShelp files, and found nothing. Any ideas woul...

SendTo PDF Not Working on GP 10
I upgraded a client from GP 8.0 to GP 10.0. Since the ugprade, they are unable to use the SendTo PDF option from within GP. We have tried reinstalling Adobe and that hasn't changed anything. The users can see the PDF being created but a blank email doesn't open from their email client as it used to. The client is on version 10.00.0991 and I thought this issue was to be resolved in 10.0 SP 1 but obviously it hasn't been for us. The client is also using Outlook. Is this still a bug with 10.0 or are we missing something? I am on Adobe Acrobat Standard 8.0 with Microsoft ...

Can't get Date Range to work from Form to Report
Hi, I've followed Allen Browne's directions very closely for creating a form for a date range to limit results to that date range on a report and can not get it to work for some reason. I've read many threads on this board which all say the same thing and it seems to work for everyone else. :( Here's what I have: A form with two unbound text boxes called [txtDateBegin] and [txtDateEnd]. The form is called "frmDateRange" and the report is called "Sales Activity Report". The two unbound text boxes are set to "Short Date" format which the user ...

Insert list of figures does not work for Pictures
Version: 2004 Operating System: Mac OS X 10.5 (Leopard) Processor: Intel I can generate a list of all of my inserted objects by caption: Figure, Example, Table, Song, Chart. But when I try to generate a list of the pictures I have inserted (caption reads Picture ...), I get the following message: Error! No table of figures entries found. It's as if the macro that reads the caption list doesn't have Picture in its internal dictionary. I do have the Picture captions in a text box that is formatted as "tight" to allow text-wraparound; could that be causing the problem? If so h...

Money Stopped Working Problem Solved! (or at least explained)
After the SP1 update my Money Plus Deluxe on Vista Ultimate would "stop working" when I selected Portfolio or Help. It turns out that the problem was a conflict with my Roboform program which is a password fill-in program that attaches itself to web pages in order to automatically enter my personal information. Because Portfolio and Help look like web pages to Roboform, it tries to attach and apparently crashes Money. If I stop Roboform before starting Money all is well. Alternatively, I can start Money "as administrator" and that will work too. In microsoft.publi...

Setting up email to work
I created a webpage for my company and when I created the send button I went into Format Form Properties and selected Submit and then went to Form Properties. I then selected Send Data to me in Email and entered in a valid Email. However when I go to test the web page and I enter in the required information and I click Send I get a The Page Cannot Be Displayed error and HTTP 405 - Resource not allowed. What do I do? Reference: "Publisher web publication forms 101": http://msmvps.com/blogs/dbartosik/archive/2006/01/07/80564.aspx DavidF "Russ" <Russ@discussions.mic...

Function for convertion of leters doesn't work.
I'm using function LOWER to convert string i my table on small size but Access gives me a message that the function is not defined.Please, do you know another function? MS Access does not have a LOWER function. Try LCase() instead. -- Cheryl Fischer Law/Sys Associates Houston, TX "Stenli" <svet2000@seznam.cz> wrote in message news:10b201c3626e$b613a050$a301280a@phx.gbl... > I'm using function LOWER to convert string i my table on > small size but Access gives me a message that the function > is not defined.Please, do you know another function? ...

Coments on a Work Order
Hello I have been using the system for almost 2 years, and the following error, which began after I install SP 1.3, is driving me crazy. I sell items that require serial numbers. I had added the term "S/N:" on SubDescription 1 for some items. This is where my problem comes to life, Ex. I create a work order for a client, add some items to it, and add the serial numbers. I save it, so I can do something else. After recalling the Work order, none of the coments (not even the S/N) are on it. I have check the Configuration \ Options on the manager and it seems to be ok. Any sugge...

Linking items GREATER THAN O on another worksheet in the same Work
I have a workbook that has about four worksheets … I want to create a list of items that will automatically be included on worksheet tab 4 from Worksheet tab 1 if the quantity for the item listed on the first worksheet has been changed from 0 to any other number (i.e. 1 or 10 etc). I have a list of equipment with pricing on worksheet tab 1 and the list is long. Many of the items will have quantities of zero and will not increase as they will not be selected for the project being created. We have additional columns for cost, extended cost, labor hours etc. If the quantity changes for a...

Calculate the total overlapping time of multiple tasks, excluding non-working times
I am developing a tracking calculator for an overall process. Within the overall process, there are 3 steps which are completed. These steps can be completed independently from one another, but can also (sometimes) overlap. I am trying to determine the total time for the overall process (from beginning to end), without counting the duplicated times where the steps are running parallel to one another, or times when some steps may be completed and are waiting for another to start. I have outlined the basic design of the worksheet below, with times in mm/dd/yyyy hh:mm format. S...

Links don't work in mail
Hello What would cause outlook (and outlook express) to not allow the links in my emails to work? They open a browser window, but nothing ever gets loaded. If this were happening only for 1 link, I'd say it was the url, but this happens with text links, button links etc. I have to "view source" for the button links, copy the url and paste it into my browser -- and that works fine. Email links seem to work. Any suggestions? Thank you Terry V Hold curser over link, press shift key, now you can click on link. "Terry V" wrote: > Hello > What would cause ou...

Handling Cut (CTRL-C) in a CListCtrl dervied control
Hello, I have a CListCtrl derived control which presents some data. Now, I want to add handling of CTRL-C: When the user presses CTRL-C the text of the currently selected item should be copied to the clippboard. As far as I figured, accelerators are my best option? Am I right or is there an 'easy' neat whay like some OnCTRLCPressed messages? Best regards, Oliver >I have a CListCtrl derived control which presents some data. > >Now, I want to add handling of CTRL-C: >When the user presses CTRL-C the text of the currently selected >item should be co...

Rules Work Sporadically
I use an email classification tool (POPfile . . . getpopfile.org) that marks each email header using X-Text-Classification. I then set up rules in Outlook to recognize the header text and move the email to the proper folder. Here is the problem: sometimes Outlook places the email into the correct folder and sometimes it just lets the email pass through into the default folder even though the header reflects the proper X-Text-Classification. Does anyone have any idea why this rule would only work sporadically? Thanks. ...

Some rules don't work
Outlook 2007, XP Many of my rules have stopped working. Not all, but many, if not most. I even tried to delete some of the non-working rules and re-write them. But when I run them with messages already in my inbox, they don't work. I frequently copy my outlook.pst file for use on a laptop when travelling. It seems that some--but not all--stopped working at the time of such a transition. Of course, that does not explain why some won't work right after I make them. Many of the rules are what to do with emails I send and receive from certain people. Any suggest...