always relink no matter what ...

Hi,

I have a VS 2005 solution with 26 projects, that are all converted from VC++ 
6.0.  Now each time I build the solution, one of the projects has to be 
relinked once even nothing has been changed in the project (as shown below). 
If I hit the F7 key n times, I get the following message n times.   Do you 
know anything that may cause the following message.  Your help is much 
appreciated.

1>------ Build started: Project: kyGraph, Configuration: PseudoDebug 
Win32 ------
1>Linking...
1>Embedding manifest...
1>Build log was saved at 
"file://d:\c\c\kyGraph\i386\PseudoDebug\BuildLog.htm"
1>kyGraph - 0 error(s), 0 warning(s)
========== Build: 1 succeeded, 0 failed, 25 up-to-date, 0 skipped ==========

JD

ps. Now the project has some behavior wierd and I suspect if the conversion 
from VC++ 6.0 has any cause of it. 


0
jdt_young (239)
5/16/2007 9:59:44 PM
vc.mfc 33608 articles. 0 followers. Follow

5 Replies
750 Views

Similar Articles

[PageSpeed] 23

JD Young wrote (in news:%23D%23LEWAmHHA.4768@TK2MSFTNGP05.phx.gbl):

> I have a VS 2005 solution with 26 projects, that are all converted from VC++
> 6.0.  Now each time I build the solution, one of the projects has to be
> relinked once even nothing has been changed in the project (as shown below).
> If I hit the F7 key n times, I get the following message n times.   Do you
> know anything that may cause the following message.  Your help is much
> appreciated.

Usually when this happens it�s because one or more files have a bad timestamp.
Check to see if any of the files have a timestamp set in the future. Try using a
touch utility to update the timestamps of all the files in the project.

-- 
Alec S.
news/alec->synetech/cjb/net


0
Alec
5/16/2007 10:05:31 PM
"Alec S." <@> wrote in message news:ui7oVZAmHHA.596@TK2MSFTNGP06.phx.gbl...
> JD Young wrote (in news:%23D%23LEWAmHHA.4768@TK2MSFTNGP05.phx.gbl):
>
>> I have a VS 2005 solution with 26 projects, that are all converted from 
>> VC++
>> 6.0.  Now each time I build the solution, one of the projects has to be
>> relinked once even nothing has been changed in the project (as shown 
>> below).
>> If I hit the F7 key n times, I get the following message n times.   Do 
>> you
>> know anything that may cause the following message.  Your help is much
>> appreciated.
>
> Usually when this happens it's because one or more files have a bad 
> timestamp.
> Check to see if any of the files have a timestamp set in the future. Try 
> using a
> touch utility to update the timestamps of all the files in the project.
>
> -- 
> Alec S.
> news/alec->synetech/cjb/net
>
>

Hi Alec,

What is the "touch" utility?  I didn't find it in my menu item "Tools" 
group.

Thanks.
JD


0
jdt_young (239)
5/17/2007 12:10:50 AM
"Alec S." <@> wrote in message news:ui7oVZAmHHA.596@TK2MSFTNGP06.phx.gbl...
> JD Young wrote (in news:%23D%23LEWAmHHA.4768@TK2MSFTNGP05.phx.gbl):
>
>> I have a VS 2005 solution with 26 projects, that are all converted from 
>> VC++
>> 6.0.  Now each time I build the solution, one of the projects has to be
>> relinked once even nothing has been changed in the project (as shown 
>> below).
>> If I hit the F7 key n times, I get the following message n times.   Do 
>> you
>> know anything that may cause the following message.  Your help is much
>> appreciated.
>
> Usually when this happens it's because one or more files have a bad 
> timestamp.
> Check to see if any of the files have a timestamp set in the future. Try 
> using a
> touch utility to update the timestamps of all the files in the project.
>
> -- 
> Alec S.
> news/alec->synetech/cjb/net
>
>

Hi Alec,

I double check the project folder and its sub-folders.  All the files have 
timestamps in the past.  So probably my case is not due to the wrong 
timestamps.  Thanks.

JD


0
jdt_young (239)
5/17/2007 12:15:23 AM
JD Young wrote (in news:eogX3hBmHHA.4032@TK2MSFTNGP02.phx.gbl):

> "Alec S." <@> wrote in message news:ui7oVZAmHHA.596@TK2MSFTNGP06.phx.gbl...
> > JD Young wrote (in news:%23D%23LEWAmHHA.4768@TK2MSFTNGP05.phx.gbl):
> > > I have a VS 2005 solution with 26 projects, that are all converted from
VC++
> > > 6.0.  Now each time I build the solution, one of the projects has to be
> > > relinked once even nothing has been changed in the project (as shown
below).
> >
> > Usually when this happens it's because one or more files have a bad
timestamp.
> > Check to see if any of the files have a timestamp set in the future. Try
> > using a touch utility to update the timestamps of all the files in the
project.
>
> I double check the project folder and its sub-folders.  All the files have
> timestamps in the past.  So probably my case is not due to the wrong
> timestamps.  Thanks.

Like Chen said, you have to use a 3rd party touch tool, there�s plenty of free
ones available (*nix has it built into the OS).  I mentioned it because that�s
exactly how I fixed it for each of my projects that had that problem.  You can
also delete all interim files and folders, then rebuild to clear out any corrupt
files.

Check this page: http://untidy.net/blog/2006/07/10/vs-always-builds/

-- 
Alec S.
news/alec->synetech/cjb/net


0
Alec
5/17/2007 5:27:57 AM
en~,i think you should check the date of the files(source code, etc.), not 
the folders.

by the way, visual studio 2005 doesn't contain any touch utility, but you 
can download a touch utility from the internet, there is a url:
http://www.jddesign.f2s.com/touchpro.htm


-- 
Chen Liangqiao


"JD Young" <jdt_young@yahoo.com> wrote in message 
news:eogX3hBmHHA.4032@TK2MSFTNGP02.phx.gbl...
> "Alec S." <@> wrote in message 
> news:ui7oVZAmHHA.596@TK2MSFTNGP06.phx.gbl...
>> JD Young wrote (in news:%23D%23LEWAmHHA.4768@TK2MSFTNGP05.phx.gbl):
>>
>>> I have a VS 2005 solution with 26 projects, that are all converted from 
>>> VC++
>>> 6.0.  Now each time I build the solution, one of the projects has to be
>>> relinked once even nothing has been changed in the project (as shown 
>>> below).
>>> If I hit the F7 key n times, I get the following message n times.   Do 
>>> you
>>> know anything that may cause the following message.  Your help is much
>>> appreciated.
>>
>> Usually when this happens it's because one or more files have a bad 
>> timestamp.
>> Check to see if any of the files have a timestamp set in the future. Try 
>> using a
>> touch utility to update the timestamps of all the files in the project.
>>
>> -- 
>> Alec S.
>> news/alec->synetech/cjb/net
>>
>>
>
> Hi Alec,
>
> I double check the project folder and its sub-folders.  All the files have 
> timestamps in the past.  So probably my case is not due to the wrong 
> timestamps.  Thanks.
>
> JD
>
> 
0
chenlq (2)
5/17/2007 6:12:50 PM
Reply:

Similar Artilces:

Why is my Validate always succeeding?!
Hi XmlTextReader reader = new XmlTextReader("Accounts.xsd"); XmlSchema schema = XmlSchema.Read(reader, null); schema.Compile(null); XmlDocument d = new XmlDocument(); d.LoadXml("<ThisShouldNotValidate/>"); d.Schemas.Add(schema); d.Validate(null); I'm just nulling the event handlers for the moment so exceptions would be thrown ... but they're not, in particular in the XmlDocument.Validate which is what I'd expect! So, what have I done that's silly then? Here's the schema, which compiles fine (as you can see, I was having a play with xs:include ...

AutoFormat settings always revert to defaults
This is driving me nuts. I do not like Word auto formatting, and have turned it off multiple times (under all tabs in options). I've even deleted Normal.dot in case it was corrupted and has some effect on this. Yet, the settings keep turning back on. Again and again and again. Any idea why? Any idea where this is stored? Maybe I'm deleting a cached settings file without realizing it. Thanks for any help. Word 2003 particularly has a minor problem related to corruption of the data key in the registry which causes it to lose personal settings. It can often be fixed (...

ALWAYS get Disable Macros warning
We have a user here that when opening Excel, he always gets the Macro warning... even if he sets the Macro security to "low". Is there a fix for this? Thanks ...

Transactions with ATM for number always try to configure a category
I have MOney 2007 but 2006 did this too. When I open a new "Withdrawal" and type "ATM" where the check number belongs, It always shoves "ENTERTAINING" in the first category box (I have mine set to show two boxes, main, then sub) and immediately brings up the new category wizard. I don't want that. I have Leisure as my main category and Entertaining as a sub. I have never had ENTERTAINING as a main category, not since starting with Money 95. I think Money 2006 started this junk because for a decade it worked fine. How can I get this to stop? I have to press...

powershell_ise always echos output
Hi, I am using powershell_ise if I write the following simple script $a = Get-Date -Format "yyyyMMdd" Write-Host "Filename $a" the output is PS C:\WINDOWS\system32\windowspowershell\v1.0> $a = Get-Date -Format "yyyyMMdd" Write-Host "Filename $a" Filename 20100305 when I would expect simply Filename 20100305 can anybody please tell me why every line is echoed to screen and if I can stop this behaviour please. I would like the editor to act more line the commandline powershell. thanks in advance. cheers martin. ...

More evidence that the system doesn't always roll back errors
Your honor, I present Exhibit B in the case of The People vs. Microsoft Dynamics GP, regarding how the system does not always recover from errors properly... While posting a cash receipts batch yesterday, one of our A/R people got an error message that something went awry (unfortunately he can't remember the exact text) and the message said to run batch recovery. He did so, and it appeared to him that the posting went OK. However, this morning we noticed that apparently the system didn't fully recover what had occurred prior to the error. Although it appears the Receivables pay...

Pasting picture files to Excel
Whenever I paste ia jpg picture nto Excel (or Word for that matter), I get only 3 choices (bitmap, metafile (bigger than bitmap), and photoediting (bigger than both)) . My question is, is there anyway to paste in a picture to an Excel file, but keeping it compressed as a jpeg file, this way the excel file size doesn't grow by leaps and bounds? Thanks. Matt: Since Excel has the ability of editing a picture, the software has to limit its pictures to those formats that MS has editing tools to work with. That's why you can't easily set up JPG or GIF pictures as embedde...

QueryDefs("name") always returning first QueryDef in collection
Hello all, I have the following code snippet in my Access app: Dim dbQueryDef As QueryDef Set dbQueryDef = CurrentDb.QueryDefs("QUERY_NAME") ' (1) Set dbQueryDef = CurrentDb.QueryDefs(26) ' (2) Line (1) does not do as I expect it - it always returns the first QueryDef in the QueryDefs collection (seen by examining the QueryDefs object at debug time). However if I pass the ordinal of the correct QueryDef as in line (2) above then it works fine. Anyone know what is going on? Is the string in (1) above being converted into 1 before being passed to the Item(Item) method ...

Word wrap doesn't always work properly
I have something odd happening with word wrap for text fields in a report: Word wrap is not consistent. For this text field the 'Can Grow' property is set to yes, and the field wraps, but it often cuts off the end of words. For example, the text "No charge work order (WO 159407) CK WTR HTR/WORKING FINE" in this particular field appears as: No charge work order (WO 159407) CK WTR HTR/WORKIN FINE As you can see, the last letter of the word "WORKING" is missing. Anybody out there have any thoughts? Do the upper case characters have something to do with this ...

Incoming email not always added to CRM
Hi all, we have retained the email GUIDs so that email replies go to CRM, however I have noticed that sometimes they dont ! The mails arrive in outlook OK and the GUID looks intact, but they are not picked up by CRM. This does seem intermittant - I would say that 2 out of 20 have been impacted. Any ideas ?? Ian Ian; Do you have more than one Exchange server in your organization? If so, is the CRM Exchange Router installed on all of them? Dave "Ian Kelsall" <ian.kelsall@crmnews.com> wrote in message news:eECrIKGwFHA.3080@tk2msftngp13.phx.gbl... > Hi all, > &g...

Reconciling non-inventoried items always hangs
Ever since version 8 or so (we are now on version 9), whenever inventory reconcile is run, it hangs on discontinued and misc charge items. There barely any data for these items. Why does this consistently happen? This adds about 4 hours to our reconciliation process whenever we need to run it. ...

Investment Account Summaries are always blank
I am a brand new user to Money 2006. After the very first time I set up my Ameritrade brokerage account, it neatly listed my positions in the account summary (after clicking on the account from the account list). Unfortunately, that was the only time my holdings were displayed in the summary. Now the summary is always blank, and I have to click on Investing Tools --> Portfolio Manager to see the positions. I have no idea what's wrong. I even setup a manual (non-linked) investment account and it does the same thing, it wont display my holdings in the account summary. I have ...

New virtual server always creates ExchWeb
Hi, we have a problem getting OWA to work correctly through our content switch. In our test-domain, we have 2 virtual servers running on the same IIS server, both a unique IP. When you create a new vertual server, a new web is created, and in that new web, Exchange automatically creates a virtual directory called ExchWeb. Is this hardcoded in Exchange 2003? We need to be able to change this in a way, because our content switch (Cisco CSS 1100) routes user requests to 1 destination based on the content. What happens, is that if users connect to the non-https server with url http://som...

always open presentation file in slide show format
Before Office 2007 all my presentations opened in "slide show" mode VS "edit" mode. Can I set Powerpoint to always default to slide show when opening power point files? If so how? Hi, It all depends on the extension of your powerpoint animation. For instance, once you are done with your power point animation you can " Save As" the show as a " Power Point Show" File Type. Once the file is saved like that any user that clicks on it and it will automatically take him/her to Show mode. Let me know if this information helps, -- Vicen...

can you teach me how to set up my email useing yahoo? it always . #2
im having a real hard time setting up my email on outlook i had given up hope on my old computer to set up my accont, but now that i have outlook 2003 i really want to set it up. i need to know if i can use yahoo because that where my email adress is, famvid is my mother's email. please email me back soon ...

CRMAF_ prefiltering doesnt work no matter what I do.
I have been trying for days now to make even the simplest reports prefilterable with no luck. I have absolutely no problem writing the report and getting ALL the data to appear on the output, however when I try to add in the CRMAF_ option to allow for prefiltering nothing happens. I can save the RDL file and it will show with the CRMAF_xxxxx in the query but there will be no edit filter button for the report. If you click the change default filter option a box pops up and says there can be no default filter on this report. This makes absolutely no sense to me as I am following the Mi...

How to make catalog selection relink DLL
I added a driver to my catalog in CE 6.0 R2, with radio buttons for different platforms. Based on the platform selected, I have different SYSGEN variables that cause the inclusion of the right library to link for this driver DLL. I found I have to go to the Solution view and manually build the components whenever I make a change to the source code. If you have an idea for automating the build of these components, that would be cool. But the main frustration I have right now is that I wasted several hours last week when I switched from one catalog option to another, and chose ...

Inbox in Outlook 2003 always shows one unread e-mail
I did a search first, but couldn't find anything that applied to me. We use Outlook 2003 and until today everything was fine. Starting this morning however, my personal Inbox shows that I have one unread e- mail, but there is nothing in there. I have done an advanced find on my entire Mailbox and tried using the Search Folders for Unread Mail with no luck. This is really annoying because no matter how many e- mails I get, it continues to show just the one unread mail. Any help would be great, Richard Could be a Read Receipt. "Richard.M.Henry@gmail.com" wrote: > I did ...

It always wraps my text
Hello all, When I copy things from Access into Excel, the values always "Wrap" i the cells. Then I need to highlight the cells - Format cells... an uncheck "Wrap text". Is there a way to change the default so that it does not wrap the tex evey time? It can get a bit annoying at times. Great thanks in advance. Peace, Roac -- Message posted from http://www.ExcelForum.com paste values across, not all >-----Original Message----- >Hello all, > >When I copy things from Access into Excel, the values always "Wrap" in >the cells. Then I need to hi...

Add a line guide to Excel so that no matter what column you're wo.
When working in Excel I often have to look for a certain cell, then write down the info and then go back to the cell next to it, and it can be very confusing. I often confuse rows especially when working with numbers. Excel should have an option on the view menu to add a guideline like you would use on a document holder. It would shade the entire row you're selecting as you use the up/down arrow to move through rows. While the whole row is shaded, the current cell would be outlined just as it is normally so you know which cell you're actually in. This could also be used with...

Exchange Server Unavailable
Hi W2k AD Domain with Exchange 2000 in 2,000 users+ environment Problem 3 users setup in external workgroup, use Windows XP and Outlook 2003 to connect to exchange The first time they connect (from switching on /logging on) they ge "your microsoft exchange server is unavailable Then the 3 button "retry" "work offline" "cancel Clicking on retry always then connects up sucessfully and then can use outlook without problem Don't think it is dns or wins problem as can ping and map drives (\\...) both by name and IP Anyway have added enteries to hosts for excha...

Online Defrag Always Interrupted
I have been watching my exchange private store because it has passed the 100GB mark and we want to switch over to new disk and break out the store to multiple stores. I've noticed that this event is continually in the logs but it never finishes. Is there something I should be concerned with short term? How long does it take to complete an online defrag with a store of 100GB? I have increased my maintenance window from 1-5am to 10PM to 6AM to give it more time. My database backups run from 6:00PM to 8:30PM I have shut down the bricklevel backups Today - Wednesday to see if I can get...

Main dialog window always remains behind other dialogs: how can I change this?
Hi, In a test MFC application I have a main window (derived from CDialog), which opens other mode-less top-level dialog windows, which are to be used independently. I am annoyed by the fact that the (initial) main window always remains behind the other dialogs that are created. ( These other mode-less dialogs are set to have no parent, and are totally autonomous from the initial dialog. ) Does the main window remain locked behind because the thread's m_pMainWnd points to this first dialog? ( it's the only explanation I can think of, yet I cannot leave m_pMainWnd as NULL either...

Help! Form always in design mode
I'm pretty new to forms, I completed my first one yesterday which woks fine. However, I'm now doing a second which is causing no end of headaches! I have followed the instructions in help, but every time I open the form up it is always in design mode by default, which mean that I have to unprotect it and turn design mode off before I can use it properly. I have tried saving it in several different ways, as a word doc and as a template, but still it opens up in design mode, (still protected), but the check boxes do not work. What am I doing wrong? -- KerryOrr The fact that you m...

Number 10 envelopes always tile across 3 pages.
I'm using Publisher in Windows 2000. I want to print #10 envelopes but they are always tiling across three pages. What settings do I need to print correctly? Set the paper size (envelope) in Printer Setup first. -- Don Vancouver USA "MarkHammari" <MarkHammari@discussions.microsoft.com> wrote in message news:5E0A481C-8908-4C63-A514-2E88ECFB2863@microsoft.com... > I'm using Publisher in Windows 2000. I want to print #10 envelopes but > they > are always tiling across three pages. What settings do I need to print > correctly? I did that first,...