DB Mail is is not working. Need help please.

I have try stop and start the db mail by executing the SPs below but no luck. 
 Does anyone has seem the error below and how to fix it.

Thanks in advance for your advise/help.

--steps
USE msdb;
go
EXECute sysmail_stop_sp;
go
EXECute sysmail_start_sp;
go

EXECute sysmail_help_queue_sp @queue_type = 'Mail';
go

queue_type length      state                                                 
           last_empty_rowset_time  last_activated_time
---------- ----------- 
---------------------------------------------------------------- 
----------------------- -----------------------
mail       3           [red]INACTIVE[/red]                                   
                      2010-05-04 22:26:16.850 2010-05-04 22:31:46.840

Error message:

ate		5/4/2010 3:26:21 PM
Log		Database Mail (Database Mail Log)

Log ID		2346
Process ID		1032
Last Modified		5/4/2010 3:26:21 PM

Message
1) Exception Information
===================
Exception Type: 
Microsoft.SqlServer.Management.SqlIMail.Server.Common.BaseException
Message: The Transaction not longer valid.
Data: System.Collections.ListDictionaryInternal
TargetSite: Void ValidateConnectionAndTransaction()
HelpLink: NULL
Source: DatabaseMailEngine

StackTrace Information
===================
   at 
Microsoft.SqlServer.Management.SqlIMail.Server.DataAccess.ConnectionManager.ValidateConnectionAndTransaction()
   at 
Microsoft.SqlServer.Management.SqlIMail.Server.DataAccess.ConnectionManager.RollbackTransaction()
   at 
Microsoft.SqlServer.Management.SqlIMail.IMailProcess.QueueItemProcesser.GetDataFromQueue(DataAccessAdapter da, Int32 lifetimeMinimumSec)
   at 
Microsoft.SqlServer.Management.SqlIMail.IMailProcess.QueueItemProcesser.ProcessQueueItems(String 
dbName, String dbServerName, Int32 lifetimeMinimumSec, LogLevel loggingLevel)
0
Utf
5/4/2010 10:40:01 PM
sqlserver.programming 1873 articles. 0 followers. Follow

1 Replies
2274 Views

Similar Articles

[PageSpeed] 34

On Tue, 4 May 2010 15:40:01 -0700, LN <LN@discussions.microsoft.com>
wrote:

>I have try stop and start the db mail by executing the SPs below but no luck. 
> Does anyone has seem the error below and how to fix it.
>
>Thanks in advance for your advise/help.
>
>--steps
>USE msdb;
>go
>EXECute sysmail_stop_sp;
>go
>EXECute sysmail_start_sp;
>go
>
>EXECute sysmail_help_queue_sp @queue_type = 'Mail';
>go
>
>queue_type length      state                                                 
>           last_empty_rowset_time  last_activated_time
>---------- ----------- 
>---------------------------------------------------------------- 
>----------------------- -----------------------
>mail       3           [red]INACTIVE[/red]                                   
>                      2010-05-04 22:26:16.850 2010-05-04 22:31:46.840
>
>Error message:
>
>ate		5/4/2010 3:26:21 PM
>Log		Database Mail (Database Mail Log)
>
>Log ID		2346
>Process ID		1032
>Last Modified		5/4/2010 3:26:21 PM
>
>Message
>1) Exception Information
>===================
>Exception Type: 
>Microsoft.SqlServer.Management.SqlIMail.Server.Common.BaseException
>Message: The Transaction not longer valid.
>Data: System.Collections.ListDictionaryInternal
>TargetSite: Void ValidateConnectionAndTransaction()
>HelpLink: NULL
>Source: DatabaseMailEngine
>
>StackTrace Information
>===================
>   at 
>Microsoft.SqlServer.Management.SqlIMail.Server.DataAccess.ConnectionManager.ValidateConnectionAndTransaction()
>   at 
>Microsoft.SqlServer.Management.SqlIMail.Server.DataAccess.ConnectionManager.RollbackTransaction()
>   at 
>Microsoft.SqlServer.Management.SqlIMail.IMailProcess.QueueItemProcesser.GetDataFromQueue(DataAccessAdapter da, Int32 lifetimeMinimumSec)
>   at 
>Microsoft.SqlServer.Management.SqlIMail.IMailProcess.QueueItemProcesser.ProcessQueueItems(String 
>dbName, String dbServerName, Int32 lifetimeMinimumSec, LogLevel loggingLevel)


You don't check the return status of he first two procedures to see if
they worked.

What does sysmail_help_status_sp return? Can you run
sysmail_help_queue_sp on it's own if it is started?

John
0
John
5/5/2010 8:15:23 AM
Reply:

Similar Artilces:

please help!!! Unable to delete emails
NAVCE deleted the edb.log file from my \exchsrvr directory. We were able to do a hard restore to get it back up but we have several emails in users inboxes that cannot be opened. When you double-click the email you get a 'can't open this item' error. It appears something did not synch properly during the restore but my email is now up and running. I personally have a couple dozen emails in my inbox from 9am - 2pm yesterday that I cannot open and get that message. How can I permanently delete those emails??? Getting them back would be nice but I don't want to ri...

Outlook conflicting with Windows Mail
I have Vista Business. I get e-mails from Yahoo groups. When I left click Reply to sender or Reply to group I get Outlook opening up to handle it, even though the e-mail is received via Windows Mail. I want that stopped. I use Windows Mail to handle everything, Outlook is just for handling Business contact info until I'm sure I want it permanent. The problem started when I downloaded the trial version of Outlook and it just started doing that BS on its own. How do I get it back to having Windows Mail handle that? Thank you, Mike Tried setting your mail handler in Internet Options...

Macro to help update data from protected files
I need help in creating a macro. I have a master file X1 and it connects to 55 other files all password protected. When i open the Master file , it asks the protected fiel to be open to update the data, otherwise it gives error. Can someone help me create a macro which will update the data witout opening the protected fiels one by one. Thanks I don't think you'll find a macro that can do this. But what you could do is create a new workbook that opens each of those 55 other files (supplying the password) and then opens your real workbook. hamad.fatima@gmail.com wrote: > > I ...

Exchange 2007
From the EMS, how do I search for and delete a specific e-mail message from all mailboxes? E.g.: An unwanted e-mail message contains the subject "viagra", and I want to delete all messages containing this word in the subject from all mailboxes. Would it be something based on the cmdlet get-message -filter *viagra* ? On Tue, 6 Mar 2007 16:37:25 -0800, jering <jering@discussions.microsoft.com> wrote: >From the EMS, how do I search for and delete a specific e-mail message from >all mailboxes? > >E.g.: An unwanted e-mail message contains the subject "viagra&...

NEED TO FIND FIRST " " FROM RIGHT
Help - I have a column in excel that contains names, such as: Joe Smith Joe E. Smith Joe Edward Smith, esq. etc I need to isolate the LAST WORD in the column, for example: Smith Smith esq. The only way I know how to do this is to search for the first " " - but I need to start the search from the RIGHT, not the LEFT. As far as I know, FIND function starts the search from the right... which isn't what I want. Can someone please tell me how to accomplish this task. THANK YOU =RIGHT(A1,LEN(A1)-FIND("^^",SUBSTITUTE(A1," ","^^",LEN(A1) -...

Formula assistance please . .
Hi people, Had a query passed to me about a formula and despite my efforts, have reached the decision to seek help from your good selves! Worksheet looks like this; Col F Col AB Col AC 8564848485858565 5236523652365236 0 8484848484848484 7412741274127412 0 1234567891234567 8484848484848484 1 2582582582582586 8484848456789253 0 8484848484856547 8567458698562311 0 Column F is an ever-increasing year-to-date li...

Need info on scheduled meetings: time scheduled/who scheduled it
We have a situation where many people have access to the managers calendar and can scheule meetings. It would be very helpful to be able to identify not only who scheduled the original meeting (and the date/time) but also who modified meeting parameters after it was orignally scheuled. The current 'properties' tab only tells you the last time the file was modified, which is typically not very helpful. thanks "Joe Bruin" <Joe Bruin@discussions.microsoft.com> wrote in message news:126EFECB-58AF-4253-A53F-C629E4A354F7@microsoft.com... > We have a s...

Please recommend a good newsreader?
I read and post to newsgroups daily. Sometimes I subscribe to a variety of different newsgroups and post in different newsgroups. Sometimes in sci.math, sometimes in programming related, sometimes in sports related, sometimes move on to another nntp server, for example, Micorsoft News server to ask techinical questions... , etc. Is there a software can collect what I have post and what other people replied and present them in front me in an efficient and uniform way, and with new replies arrival pop-up/notification feature? Currently I am using Outlook Express. It is not convinient at...

Help #30
Hi, I have a row of data that I need to find a minimum value and a maximum value. That's done. Now, I have to delete both the minimum and maximum values from the row. Can you tell me how to easily do this? I have a larg :confused: e worksheet with many rows, so Edit+Find really won't help. -- only1joal ------------------------------------------------------------------------ only1joal's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=24589 View this thread: http://www.excelforum.com/showthread.php?threadid=381823 Assume data is in Sheet1, in row1 down ...

Outlook 2003 not receiving mail
I have a Laptop with Outlook 2003 setup with offline files. This computer will sit few only a few minutes and then will no longer send and receive. It forces you to hit the send receive button to get your mail. I have it set to automatically send receive every 4 mins, but this is not happening. Any help would be great. Thanks ...

New to XML services book recommendation please
Hi all, I am about to move into programming using an xml web services model. The first thing I need to know is whether you can use them privately within a corporate LAN, or whether you need to be connected to the internet for something. Secondly I'd like a good book recommendation (I'm in the UK). The documentation online is a minefield if you aren't familiar with the whole ..net framework. I am very comfortable with C++ and the traditional framework model. I understand the reason for the XML services model but none of the specifics regarding implementation. I also know next to ...

outgoing email stopped working
My outgoing email stopped sending yesterday, although I can still receive email fine. I've been through text support with my ISP (prodigy/SBC) and they say it is an outlook problem. Any suggestions? Julie Fairchild What errors do you get? Julie wrote: > My outgoing email stopped sending yesterday, although I > can still receive email fine. I've been through text > support with my ISP (prodigy/SBC) and they say it is an > outlook problem. Any suggestions? > > Julie Fairchild >-----Original Message----- >My outgoing email stopped sending yesterday, a...

Assign Macro to button in Excel doesnt work Any ideas?
I have followed the instructions in help but when I get to step 3 "right click to bring up shortcut menu & enter Assign Macro" the assign macro" option does not appear!! Any Ideas Hi Mike can you see assign macro - but it is greyed out? or is it not an option at all? if it is greyed out you'll notice around the button little diagonal lines, click on these and they should go furryish .. now try right mouse clicking. if the option is not there at all, please post back letting us know how you created the button. Cheers JulieD "Mike@Becketts" <Mike@B...

Upgrade 9 to 10 only work if update instance, not if new instance
I'm testing a GP 9 to 10 upgraded on a test server. Everything installs; however, GP Utilities will bomb out if I created a new instance when installing 10. There is no error message, it just fails. If I do an update to the 9 instance, it works fine. Why should this make any difference? It's the only thing I'm changing in the two installs. Thanks Not sure I understand. What do you mean by "instance"? Best regards, -- MG.- Mariano Gomez, MIS, MCP, PMP Maximum Global Business, LLC http://www.maximumglobalbusiness.com The Dynamics GP Blogster at http://dynamicsgpblogster...

On Create Workflow not working
I am trying to add a new workflow rule to our system. All I want to do is send an email when a new order is created, that's it. I have many other, much more complex workflows running just fine. However, it seems I can no longer add an On Create workflow rule. If I change this rule to On Assign, it runs fine. For some reason, any new On create rules are not running, the old On create rules still work. Does anyone know what this could be? Any help is appreciated. This is only affecting the Creation of workflow rules for Orders. Is there a maximum # of rules allowed for each...

Outlook 2007
We are implementing Outlook 2007 - Exchange 2010 across the company and we are noting that while we can open and save attachments directly from the email in either preview pane or full view (by right clicking and saying "Save As"), the Save Attachment button does not work in the Email Toolbar. Having put the Save Attachment button in my quick access toolbar, I note that it does not work either when I open the full Email. I am thinking this might be related to the Exchange/Outlook relationship. Our exchange server in on our LAN and I have my connection set to "Dow...

adding subject line to e-mail template
I have depts in my company who weekly send me a spreadsheet of companys to receive a standard e-mail sent using Outlook 98. I created a DOT file in Word for the e- mail body. I set the mail format to Word and the template to the DOT file. Since the subject is the same for each e- mail, is there a way to add the subject line to the template? ...

Help with Exchange 5.5 Queue problem
Okay, first off, I inherited this Exchange server. It has been over 5 years since I last touched one of these. Client noticed that no e-mails were being sent out. I checked the IMC queues and they were packed full of email going to .tw, .fr, .de, etc. Disconnected the ethernet cable from the back of the box. Ran the much needed virus check and got rid of 225 Netsky and Beagle viruses. Reran a few times just to be on the safe side - server is clean (latest norton updates). And made sure that relaying was also turned off - just for fun. Cleaned out the queues (deleted the contents of the ...

Publisher and PDF help...
I am trying to find a solution to my delima. I have publisher on one computer and adobe acrobat on another. Is there a Publisher viewer or some work around that anybody knows of. Thanks in advance... While in a state of ecstasy after repairing his laptop, Ed sees a message from Neal <Neal@discussions.microsoft.com>. On it is written: > I am trying to find a solution to my delima. I have publisher on one > computer and adobe acrobat on another. Is there a Publisher viewer or > some work around that anybody knows of. Options: a) Output a PostScript file from Publisher and di...

Sending a report to word then mailing it.
is there a way to send a report by email as a word doc. i have messed about with the button wizard and managed to get the report to attach to an email. the only thing is it only attached as a rtf, txt or html file. and these do not show the report as it appears on access. how can i do it, so the recipient can print it off sa it is on my screen. Cheers To get the exact same report you need to export to Snapshot Format (viewer & add-in Downloadable from microsoft) Pieter "Steve Moss" <SteveMoss@discussions.microsoft.com> wrote in message news:ED6150E8-C397-4D2F-...

Money Import Handler doesn't work anymore in Money Deluxe 2006
It used to, for years, but now whenever I download an account statement, whether from my bank or from a credit card account, the statement gets downloaded, apparently, but Money doesn't do anything with it. If I save the downloaded .OFX file, instead of choosing the Money Import Handler, I can then go to File - Import - Download Statement and Money uses the data correctly. Under Tools - Settings - Online Service Settings, the following options are chosen: Overwrite transaction dates... Replace downloaded payee name... Automatically mark accepted transactions... Enter electronic pay...

Saving e-mails on server
I am having a problem with my e-mails being saved on the server of my internet provider. When that file is full, I do not receive any e-mails. I have gone onto providers website and deleted the 152 or so messages. One would think that would fix the problem, but no soap. I am told that my Outlook is set up to save these messages to the server? Any thoughts or suggestions? Or if you really do want them on the server because you check your email from multiple PCs, just leave the box checked but then check one of the other boxes for Delete after XX days or Delete when you delete the m...

E-Mail-Router Problem
CRM-Version 3 RTM (german) We have the problem, that while trying to route incomming e-mails to CRM the following soap-error-messsage in the event-viewer appears as mentioned below. We created an dissabled account ("CRMRouter") on AD for the e-mail-Router and activated the "CRMMailEnabled"-attribute. After installing the Router on the exchange-server we used the rule-deployment-assistant to create the rule for copying the mails, which are send to an specific user to the CRMRouter-account. Then the router should take this mails and create activities in CRM. But we...

unable to access any featuress on Live mail
I downloaded latest version overnight. it has uploaded all the mail and files, and looks for changes (receive new mails). When i try to click on anything in th live mail screen, I cannot (seems frozen screen) nothing is able to be activited by clicking over any feature in the Live mail. I also cannot click on any dropdowns etc to close out in the top right. Any suggestions ? I have been accessing my hotmail account without any errors prior to this through web and ive messenger. thanks ...

missing new mail notification icon
Hello, I have 2 users running Office 2007 Enterprise SP2 on Vista Enterprise SP2 and each is missing their new mail notification icons. I understand this only works with mail that remains in the inbox (instead of being moved via a rule to another folder). Neither user is hiding the taskbar and "show an envelope icon in the notification area" is enabled in Advance e-mail options of outlook. Any suggestions for what else to look for here? thanks, CK "CK" <CK@discussions.microsoft.com> wrote in message news:CBFB0D51-EA91-4F3D-A9C0-E40F242BE83C@m...