FilesystemObject doesn't work anymore. How to fix?

I think that scrrun.dll is messed up (New technical term) somehow.  But if I 
knew what I am talking about, I wouldn't be bothering you folks.

This line:   Set fso = CreateObject("scripting.filesystemobject")
causes this error message to appear:
    Error: (null)  Code: 8002801D

I've dragged scrrun.dll onto regsvr32.exe several times (just to be sure I 
actually had done it) , each time getting the message: DllRegisterServer in 
C:\Windows\System32\scrrun.dll succeeded.

I'm running WinVista Ultimate 64bit, completely updated.

Does anybody have any ideas about how I can get the filesystemobject working 
again?  I'm crippled w/o it.

Thanks,

                                      Marc



 

-- 
MarceepooNu
0
Utf
3/5/2010 12:22:02 AM
scripting.vbscript 564 articles. 0 followers. Follow

2 Replies
1499 Views

Similar Articles

[PageSpeed] 5

> I think that scrrun.dll is messed up (New technical term) somehow.  But if
I
> knew what I am talking about, I wouldn't be bothering you folks.
>
> This line:   Set fso = CreateObject("scripting.filesystemobject")
> causes this error message to appear:
>     Error: (null)  Code: 8002801D
>
> I've dragged scrrun.dll onto regsvr32.exe several times (just to be sure I
> actually had done it) , each time getting the message: DllRegisterServer
in
> C:\Windows\System32\scrrun.dll succeeded.
>

  Windows 64 is a mess. The 64-bit system folder is named
System32, while the 32-bit folder has the ridiculous and
misleading name of "SysWOW64". So if you're dragging
scrrun.dll from System32 onto RegSvr32 then you have the
wrong mix. (Or it's only partially registering. I haven't used
Win64. I know there are two versions of wscript.exe. I assume
there are also two versions of scrrun.dll, but I'm not certain.)

   I would think that your script would find the right version
either way. If it really is not registered then the question is
how either version could have become unregistered.
Virus? A busybody who thinks scrrun.dll is unsafe. (A lot of
corporate network admins think so.)

   I did a quick search and don't find anything like what you're
describing, except from people who are trying to create FSO
from ASP.

> I'm running WinVista Ultimate 64bit, completely updated.
>
> Does anybody have any ideas about how I can get the filesystemobject
working
> again?  I'm crippled w/o it.
>
> Thanks,
>
>                                       Marc
>
>
>
>
>
> --
> MarceepooNu


0
mayayana
3/5/2010 8:22:22 PM
Thank you.  Very helpful.
-- 
MarceepooNu


"mayayana" wrote:

> 
> > I think that scrrun.dll is messed up (New technical term) somehow.  But if
> I
> > knew what I am talking about, I wouldn't be bothering you folks.
> >
> > This line:   Set fso = CreateObject("scripting.filesystemobject")
> > causes this error message to appear:
> >     Error: (null)  Code: 8002801D
> >
> > I've dragged scrrun.dll onto regsvr32.exe several times (just to be sure I
> > actually had done it) , each time getting the message: DllRegisterServer
> in
> > C:\Windows\System32\scrrun.dll succeeded.
> >
> 
>   Windows 64 is a mess. The 64-bit system folder is named
> System32, while the 32-bit folder has the ridiculous and
> misleading name of "SysWOW64". So if you're dragging
> scrrun.dll from System32 onto RegSvr32 then you have the
> wrong mix. (Or it's only partially registering. I haven't used
> Win64. I know there are two versions of wscript.exe. I assume
> there are also two versions of scrrun.dll, but I'm not certain.)
> 
>    I would think that your script would find the right version
> either way. If it really is not registered then the question is
> how either version could have become unregistered.
> Virus? A busybody who thinks scrrun.dll is unsafe. (A lot of
> corporate network admins think so.)
> 
>    I did a quick search and don't find anything like what you're
> describing, except from people who are trying to create FSO
> from ASP.
> 
> > I'm running WinVista Ultimate 64bit, completely updated.
> >
> > Does anybody have any ideas about how I can get the filesystemobject
> working
> > again?  I'm crippled w/o it.
> >
> > Thanks,
> >
> >                                       Marc
> >
> >
> >
> >
> >
> > --
> > MarceepooNu
> 
> 
> .
> 
0
Utf
3/8/2010 7:40:01 PM
Reply:

Similar Artilces:

Working with dates
I've spent far too long on a seemingly simple problem, calculating date windows. I have a cell that calculates a date based on another date. This is a template with no data entered yet. So for instance A1 is a column where a date will be entered, A2 adds 15 to that date and A3 adds 30 to that date providing a "window." Being that this is a template and no data has been entered, when the formulas are written in to A2 and A3 the value is 15-Jan-1900 and 30-Jan-1900. Is there anyway to leave these fields Blank until a value is entered in A1? -- matt330 ---------------------...

Outlook 2000 signature not working
I have created a signature using a graphical image and text. It shows perfect in the preview window when using the "signature picker". However, when a new message is created the signature shows as a blank box with a small red X in the upper left corner. Can anyone help ? HI EBS, maybe this article could solve your problem http://www.techzonez.com/forums/archive/index.php/t-9792.html -- Ich habe nichts gemacht, gestern gings noch! Bitte in den Newsgroup antworten damit jeder etwas davon hat. Bravestar@Datenschutzministerium.de ...

IMAP not working for old users
Hi, I am trying to use IMAP to log in to Exchange 2003. IMAP is running, as I can connect. However, I get "unknown user name or bad password", even though I'm certain that the login/password is correct. I am able to connect using the same login/password via OWA. I've tried the following combinations for logins: LOGIN DOMAIN/LOGIN DOMAIN/LOGIN/LOGIN DOMAIN/LOGIN/Inbox I get the same failed authentication in all cases (for all tested old users). I'm sure IMAP is active for this user. But, When I create a NEW user login is succefful ! (or r...

Live Streaming not working in Media player in Vista
I am not able to watch the live streaming using WMP 11. It was working fine with Vista before. It still works when I use my another machine which has XP on it. When I click play it says (connecting to media...) and after some time it goes back to "Ready". I read somewhere that Vista's video driver update is clashing with media player. Is there any solution to this problem? ...

how to work with food products that have best befor dates
How to controll end of validity time for produt? How to handle parties of received produkts an validity date for party? I don't found parties in RMS If by "parties" you are referring to lots, I don't think RMS supports this, where you can assign item to a lot, then the expiration date to that lot....I don't think you have much of an option, unless you want to consider manually setting on and off the "block sales of this item" flag (not very practical).... "Martins" wrote: > How to controll end of validity time for produt? > How to handle...

Copying and pasting list information that is not fixed (using dynamic ranges)
I have a database with 43 fields (mainly text) in which users will be entering information via a data form. I would like to add another worksheet that provides a summary of all the records, except with less fields (only 17) and different formatting. I've encountered problems trying to copy this information to another worksheet mainly because I'm not sure how many rows will have to be copied over at any given time. I've found references on the web informing how to create dynamic ranges (for both test and numeric information), so I've named each of the 17 fields and used the...

Excel 2003 Working Day Formula
Hi I am after a formula to clauclate working days for office 2003 not 2007? For example if the date which i have in cell B2: what code/formula would I use to determine one working day from that date for cell C2? Hope that makes sense, basically I want to clauclate 1 working day from the date entered in a cell. Mnay thanks Check your other post. housinglad wrote: > > Hi > > I am after a formula to clauclate working days for office 2003 not 2007? > > For example if the date which i have in cell B2: what code/formula would I > use to deter...

Does CToolBar::LoadBitmap work with 24 or 32-bit images?
I was hoping that LoadBitmap() would be able to load 24 and/or 32-bit images. I could not find anything in on-line docs that would suggest that this api is limited to lower color images (which I know is true for LoadToolbar()). I've tried a 32-bit bitmap with 8 images and it 'almost' worked. It seemed like the first image was wider by one pixel and then all the remaining images were cut on the left side. I was surprised that the alpha blending worked. The same bitmap converted to 24-bits and loaded into the toolbar produced black squares. Could someone please give me s...

Copied graphs not working
I had a workbook of data with a number of graphs in one worksheet; each graph series was populated by a named range (A_, B_, C_, D_, etc.). A_ was the only direct (actually, indirect) reference, and the other series are all offsets of A_ I had some new data in a new workbook, so I used the worksheet/copy/move functionality to make a copy of the worksheet that contains the graphs in my new workbook. I copied over the named ranges and re-set them in my new workbook to the new data areas (and verified that they accurately point to ranges of data- which they do). However, the 'new'...

Fixed assets
I had a problem at a customer who said that their fixed assets depreciation for the year so far did not look right. They normally work a 5/4/5 etc period set up but the depreciation calculated per period did not look correct i.e. some months had a 2 lots of depreciation calculated. When we checked the calendar setup, it was wrong - just standard monthy set-up. Customer rebuild calendar and I advised doing a reset year for an asset to set if this would recalculate the correct depreciation so far. Response was 'As suggested, I tried the reset year flag on CC031. The system created reve...

Money
This has been going on for many days. Please address this problem. "Greg K" <Greg K@discussions.microsoft.com> wrote in message news:20ED6E8B-08EB-4E86-9C6A-72562CF95BEF@microsoft.com... > This has been going on for many days. Please address this problem. If you think posting something here will have an affect, you're wrong. MS or rather MS Supplier is working on it. The NAV is actually changing but the date isn't. -- Regards Bob Peel, Microsoft MVP - Money For UK tips & fixes see http://support.microsoft.com/default.aspx?scid=fh;EN-GB;mny. I do no...

why isn't this IF function working??
=IF(D26<>0,D26,IF(E26<>0,E26)) It currently isn't recognizing the values in column E. This is what I am trying to do: If D has text, return that value. If E has text, return that value. And if possible, can I also add this as the final IF variable: If both are zero, return "Zero" Thanks!!! you did say text =IF(ISTEXT(D1),D1,IF(ISTEXT(E1),E1,0)) -- Don Guillett SalesAid Software donaldb@281.com "broken" <broken.logan@gmail.com> wrote in message news:1126030178.370525.156610@f14g2000cwb.googlegroups.com... > =IF(D26<>0,D26,IF(E26<>0...

Outlook and Exchange 2010 List of Bug Fixes
Hello-- I work for a large corporation that is currently running an Exchange 2007 cluster with clients on a mix of Outlook 2003 and some 2007. We are having issues with delegates and scheduling and have referred them to the article regarding Essential Do's and Don'ts and yet the issues of random calender items disappearing, etc. etc. continue to occur. See: http://office.microsoft.com/en-us/outlook/HA011276781033.aspx So, my question is if any of the consequences associated with the items mentioned on the website I referenced are resolved with Exchange 2010 and the ...

How does PeekMessage really work?
Hi everyone, I'm writing an application where Windows messages are used in a special manner and want to clarify how flexible is access to the thread message queue. I've read the MSDN article about PeekMessage and many web sites where different opinions are expressed. My questions are the following... 1) What really does PeekMessage()? Does it process messages sent from other threads by means of SendMessage-family routines or just picks a message from the queue (or from where?) and give me a chance to analyze it and process it by myself? 2) Does PeekMessage process ALL sent messages ...

IE8 works, but Firefox, Opera etc. do not
On a laptop loaded with XP Pro (SP2), IE8 and Outlook Express appears to work fine. However, other browsers (Firefox & Opera) cannot seem to connect to the Net and Outlook 2007 cannot send/receive e-mail. What could be wrong and what could be done to fix this? Thanks Ganz Doof wrote: > On a laptop loaded with XP Pro (SP2), IE8 and Outlook Express > appears to work fine. However, other browsers (Firefox & Opera) > cannot seem to connect to the Net and Outlook 2007 cannot > send/receive e-mail. > What could be wrong and what could be done to fix this? ...

Find not working...
Running Outlook 2003 & find isn't working. I can have an email with the word 'kettle' in the message, but if I tell it to look for kettle in the inbox, & tell it to search all text & each message, I'm getting nothing. Any ideas why? Does Advanced Find work? -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. ALWAYS post your Outlook version. How to ask a question: http://support.microsoft.com/KB/555375 After furious head scratching, Mike asked: | Running Outlook 2003 & find isn't working. | I can have an ...

Work Order Partial Close Problem
Does anyone know of a way to close a partial Work Order where the deposit is not equal to the full amount. For example- Customer comes in and orders 4 pieces of furniture for $1000 and pays deposit of $600. 3 pieces we have in stock and deliver them to customer, 1 piece out standing on Purchase Order 10 week delivery. 3 pieces delivered retail for $600 and we would like to close them off the Work Order. If the Order had a deposit for the full amount no problem. As POS is, it will not let you do a Partial Pick Up if the order is not paid in full. Thanks in advance, Edward Jensen ...

Absolute positioning not working; am I thinking about it wrong?
I was under the impression that if one used the "$" in a cell reference, that would mean that whether or not columns and/or rows are inserted, the reference would remain at the ORIGINAL spot. So, for instance, if I put in cell C3 the following: =$A$1 Then C3 would show what's in cell A1. I THOUGHT that if I then inserted a column to the left of A, C3 would STILL have: =$A$1 It doesn't, however. When I insert the column, C3's formula changes to: =$B$1 What I find especially confusing about this is that the behavior is identical when I DON'T use the "...

Using OR in IF doesn't work...
I found this function in this group, and trying to use in my macro, But I have problem with this line... > If Contains(Item.To, "Marcus") Or Contains(Item.To, "Info") Then What is wrong? CODE ************************************ Public Function Contains(spBody, ParamArray spText() As Variant) As Boolean Dim slText As Variant For Each slText In spText() If InStr(spBody, slText) Then Contains = True Exit For End If Next End Function ************************************ Private Sub colSentItems_ItemAdd(ByVal Item As Obje...

A problem in OE 6
My system C drive on my main machine failed the other day with a refusal to even have any OS recognized. So I replaced it, and restored an image from True Image from the recent past. Apparently there was some small corruptions in that image. And I have a strange situation in Outlook Express 6. All works well, except for when I click on FILE>IMPORT>MESSAGES to import some dbx files from the past, or another machine running OE6. I have these DBX files stored in a folder on my main machine, and the import has always worked very nicely. But now, when the import screen co...

Consolidated data ranges not working in my Pivot table
I have a total of 3 worksheets that get the data from a Access database queries. Basically, the query in the Access database are the same, meaning that the column name are identical, therefore, the label name returned are all the same, except that the rows retrieved in these 3 queries are different. I tried to create a Pivot table using the option - 'Multiple Consolidation Ranges' in Step 1 of 3 of the Pivot Wiazard and selected these 3 worksheets and the ranges. However, at the Wizard layout of my Pivot table, i noticed that it does not gives me each column's label name, instead,...

Access 2003 Form no longer works in 2007
I have a client that developed a series of forms in Access 2003. We upgraded them to Access 2007. Now a form does not work like it use to. We have made sure the source database was trusted. We have turned off Macro protection. When a search is put in a field, it use to come back with a set of data. Now it simply does nothing. In the field, we filter by name then type the name. Is that enough info to get this started? Thanks, On Wed, 3 Feb 2010 12:53:01 -0800, purtech <purtech@discussions.microsoft.com> wrote: >I have a client that developed a series of forms...

Opening MS Works files in Excel
How can I open an MS Works with name xxxxx.db.wdb in Excel? The file was sent to me by someone else, I really want the information, but I don't have MS Works. Tell them to save as excel files and resend them -- Regards, Peo Sjoblom "Judy White" <Judy White@discussions.microsoft.com> wrote in message news:DC9FA825-1303-4B20-A141-F6D6708E31A2@microsoft.com... > How can I open an MS Works with name xxxxx.db.wdb in Excel? The file was > sent to me by someone else, I really want the information, but I don't have > MS Works. Generally you would normally ...

Autocomplete not working on https sites (IE8 XP SP3)
My mother wants IE8 to remember what she puts in forms, but not her passwords. Unfortunately, AutoComplete refuses to save anything on https pages, so it makes it mostly useless. Is this correct behavior, or is there a way to make IE8 save forms on https pages? This is on XP SP3. Hi Fred, It depends, the web site developers can stop IE browsers from remembering autocomplete passwords and Usernames. Bank sites usually do this, in fact I would be suspicious of any https page offering autocomplete usernames and passwords. When enabled on web pages IE's autocomplete does not ...

Looking forward to working with you all!
I am excited to be working with all of you! -- wgm007 And you would be??? But welcome in any case. Gord Dibben MS Excel MVP On Tue, 26 Feb 2008 21:34:04 +0000, wgm007 <wgm007.20a75bf@excelbanter.com> wrote: > >I am excited to be working with all of you! > And you would be??? Double - O - Seven ... James Bond (re OP's moniker) -- Max Singapore http://savefile.com/projects/236895 xdemechanik --- Good point "M" Gord On Wed, 27 Feb 2008 10:54:46 +0800, "Max" <demechanik@yahoo.com> wrote: >> And you would be??? >Double -...