Problem with getting a full backup from sharepoint farm

We have a server farm (one virtual machine for SQL2008,one for SharePoint and 
one for project server), and the system works fine. I am able to get a backup 
using stsadm -o backup -url <url> -filename <name>, but when I try to get a 
full backup using SharePoint backup and restore tools or stsadm -o backup 
-directory E:\Backup -backupmethod full I am getting error message regarding

WSS_Search_sharepoint-serber-name

I am getting the same error message when I run the full back from project 
server server.
Any thought on this issue? Any port/services that I need to open?
Thanks

1
Utf
6/1/2010 10:32:01 PM
project.server 1346 articles. 1 followers. Follow

3 Replies
5872 Views

Similar Articles

[PageSpeed] 58

i haven't got any respond yet.
Here is my error:
Error: Object SharePoint_Config failed in event OnBackup. For more 
information, see the error log located in the backup directory.
	SqlException: Cannot open backup device 'E:\Backup\spbr0003\00000016.bak'. 
Operating system error 3(The system cannot find the path specified.).
BACKUP DATABASE is terminating abnormally.
[6/2/2010 1:53:40 PM]: Debug:    at 
System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean 
breakConnection)
   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException 
exception, Boolean breakConnection)

We use a genereic accound, and we are not running based on the administrator 
, and the sql,projectserver and sharepoint has been installed based on the 
generic accound. I've added the generic accound to the e:/backup folder.
Please advice.

Thanks

"Bahram" wrote:

> We have a server farm (one virtual machine for SQL2008,one for SharePoint and 
> one for project server), and the system works fine. I am able to get a backup 
> using stsadm -o backup -url <url> -filename <name>, but when I try to get a 
> full backup using SharePoint backup and restore tools or stsadm -o backup 
> -directory E:\Backup -backupmethod full I am getting error message regarding
> 
> WSS_Search_sharepoint-serber-name
> 
> I am getting the same error message when I run the full back from project 
> server server.
> Any thought on this issue? Any port/services that I need to open?
> Thanks
> 
0
Utf
6/2/2010 9:08:01 PM
I found my problem. Just in case if anyone faces the same issue:
The account the SQL server is running under needs write access 
to the file share where the backup files will go in order to write the .bak 
files. Once I gave the SQL account rights there, the backup worked 
perfectly.
Shared the folder if it is not a shared/web folder and give the sql server 
an access and point your backup to \\projectserver\backupfolder
Thanks

"Bahram" wrote:

> i haven't got any respond yet.
> Here is my error:
> Error: Object SharePoint_Config failed in event OnBackup. For more 
> information, see the error log located in the backup directory.
> 	SqlException: Cannot open backup device 'E:\Backup\spbr0003\00000016.bak'. 
> Operating system error 3(The system cannot find the path specified.).
> BACKUP DATABASE is terminating abnormally.
> [6/2/2010 1:53:40 PM]: Debug:    at 
> System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean 
> breakConnection)
>    at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException 
> exception, Boolean breakConnection)
> 
> We use a genereic accound, and we are not running based on the administrator 
> , and the sql,projectserver and sharepoint has been installed based on the 
> generic accound. I've added the generic accound to the e:/backup folder.
> Please advice.
> 
> Thanks
> 
> "Bahram" wrote:
> 
> > We have a server farm (one virtual machine for SQL2008,one for SharePoint and 
> > one for project server), and the system works fine. I am able to get a backup 
> > using stsadm -o backup -url <url> -filename <name>, but when I try to get a 
> > full backup using SharePoint backup and restore tools or stsadm -o backup 
> > -directory E:\Backup -backupmethod full I am getting error message regarding
> > 
> > WSS_Search_sharepoint-serber-name
> > 
> > I am getting the same error message when I run the full back from project 
> > server server.
> > Any thought on this issue? Any port/services that I need to open?
> > Thanks
> > 
0
Utf
6/2/2010 10:40:39 PM
Now my question is, is there any way to overwrite the data on stsadm -o 
backup -directory <path> -backupmethod full -quiet  command?
I think -overwrite only works on when we use stsadmn with -url -filename,etc. 
I want to get a full backup on my project severe and I want to schedule it 
with windows scheduler, so I need a command to overwrite my data, and I don't 
want the system to create a new folder each time.

Please let me know.

Thanks

"Bahram" wrote:

> I found my problem. Just in case if anyone faces the same issue:
> The account the SQL server is running under needs write access 
> to the file share where the backup files will go in order to write the .bak 
> files. Once I gave the SQL account rights there, the backup worked 
> perfectly.
> Shared the folder if it is not a shared/web folder and give the sql server 
> an access and point your backup to \\projectserver\backupfolder
> Thanks
> 
> "Bahram" wrote:
> 
> > i haven't got any respond yet.
> > Here is my error:
> > Error: Object SharePoint_Config failed in event OnBackup. For more 
> > information, see the error log located in the backup directory.
> > 	SqlException: Cannot open backup device 'E:\Backup\spbr0003\00000016.bak'. 
> > Operating system error 3(The system cannot find the path specified.).
> > BACKUP DATABASE is terminating abnormally.
> > [6/2/2010 1:53:40 PM]: Debug:    at 
> > System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean 
> > breakConnection)
> >    at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException 
> > exception, Boolean breakConnection)
> > 
> > We use a genereic accound, and we are not running based on the administrator 
> > , and the sql,projectserver and sharepoint has been installed based on the 
> > generic accound. I've added the generic accound to the e:/backup folder.
> > Please advice.
> > 
> > Thanks
> > 
> > "Bahram" wrote:
> > 
> > > We have a server farm (one virtual machine for SQL2008,one for SharePoint and 
> > > one for project server), and the system works fine. I am able to get a backup 
> > > using stsadm -o backup -url <url> -filename <name>, but when I try to get a 
> > > full backup using SharePoint backup and restore tools or stsadm -o backup 
> > > -directory E:\Backup -backupmethod full I am getting error message regarding
> > > 
> > > WSS_Search_sharepoint-serber-name
> > > 
> > > I am getting the same error message when I run the full back from project 
> > > server server.
> > > Any thought on this issue? Any port/services that I need to open?
> > > Thanks
> > > 
0
Utf
6/2/2010 11:26:00 PM
Reply:

Similar Artilces:

Problem
Ever since I added a Microsoft Exchange Server Account and all it6s associated folders and its in-box to my pre-existing Personal Outlook 2003 POP3 folders, I have had nothing but confusion. The Exchange Server account from my workplace downloads its messages into the in-Box for my private ISP POP3 account and vice versa. When I try to configure a rule for my personal POP3 account so that any messages addressed to my workplace account are loaded into the exchange server in-box on my client PC, the software tells me I have to go on-line to Exchange Server - even to create rules for th...

date problem #10
Thanks a lot, Dave This piece of code works great. M P Redd -- mpredd ----------------------------------------------------------------------- mpreddy's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1327 View this thread: http://www.excelforum.com/showthread.php?threadid=26358 ...

How do I get a filter to "UPDATE" the rows selected?
Hey there! I am using Excel 2002 and I have a speadsheet that has prices in it. If I have the filter set to (the filter criteria is much more complex than this though) prices for items that cost >$5.00. Of I change an item to 4.59, it should not be seen. How can I get it to re-update the rows shown, with out releaseing the filter and resetting it? Is there something like refresh.filter or anything like that? Thanks Phil AFAIK you must release and reset but a macro with a worksheet_change event could trigger this for you so that it would happen automatically. -- Don Guillett SalesAid...

Problem changing parent Business unit
WE have re-arranged some business units into a more appropriate hierarchy, however, we have noticed that a user in a role with deep privileges (own business unit and children I think) to read users can only see users in his own business unit and only one of the child business units (there are 2 child business units). We cannot enable him to see all the users in both child business units. We tried reassigning the parent business unit to the one child that is not appearing, but it doesn't seem to make any difference. WE also tried adjusting the privileges up and down (i.e. Global and local...

create new users STRANGE problem
Hi, I'm developing a web application (using standard asp and not asp.net) to let certain remote users administer exchange 2003. I have installed win2003 standard edition, exchange 2003 enterprise edition,owa and my web application on the same server. My web app, let users to create mailboxes, delete mailboxes, change user password. All works fine, but for example, if I reboot the server, a web application user can create 50 mailboxes. But when any of these users log on to owa, something goes wrong and the admin user cannot mailbox enable other user accounts through the web app, even if he ...

Problem w/ Outlook
I'm running Office XP and all of a sudden I can't move messages to other folders not delete messages from my Inbox. It doesn't give me a specific error code, just suggests that I restart Outlook. I've tried that with no success. I went to ControlPanel and repaired my Office installation. Any ideas? Eudora is looking beter all the time. ...

ProbleM: when I restore a mailbox using Exmerge with a pst file, nothing is transferred.
Hi, I am practising Exmerge for a big remote site migration in a couple of weeks. One thing I dont understand is that I can backup one test mailbox fine using Exmerge (I know this works, as I have opened the mailbox pst file within outlook and everything is there), but when I perform the restore using the pst file, nothing happens. There is no error messages, and Emerge goes through the motions (though it finishes supsiciously quick), but when I open the mailbox, no emails have been restored. Although it is great that Exmerge is working for the backup part of the stage, I am disappointed it i...

Problems with Outlook 2003
This only happens with externally sent messages. Internal messages work fine. One of my users alerted me to this issue, so I tested this myself. I created 2 messages (internal and external) and added delayed delivery to both. They were both set to go out at the same time. The internal message went, and the external message is still in the outbox. The user who alerted me to this found her message went "before" the scheduled time.We are not running in cached mode and of course running Outlook on Exchange. Is this a bug? ...

memory problem of Excel 2003 copy & paste
Hi all, I am using Excel 2003 for some project. I am having 2GB C drive harddisk space. After a while, the Excel begins to be extremely slow in copy and paste... It takes about half an hour to copy and paste just a few cells... I've consulted people. It seems a memory problem. But I cannot close my windows and kill the processes, because I am running long-running (overnight) jobs... I cannot reboot either. Is there a way to clean the memory and let Excel 2003 clipboard function properly without rebooting or killing my 4 long-running processes? Thanks! p.s. I am sure this is an is...

Windows XP Shared PC
We are using Outlook 2000. The PC, which already had Microsoft Office 2000 loaded on it, was upgraded from Win 98 to Win XP. I then created Windows XP logons for all four people that will be sharing this PC. When I did, the Outlook shortcut automatically ended up on the desktop of each person when they individually logged in. When I clicked the shortcut the first time I went in to each person's desktop, I setup the mail account for JUST THAT PERSON. And when I go back and log into each person's desktop it still shows ONLY THEIR ACCOUNT. However, whatever mail they receive ALS...

Public Folder/OWA problem
We're running a pure Ex2k3 environment. I'm trying to setup a public folder where end-user software can be posted. This way, users can access our front-end OWA server outside of the network, open public folders, and then save the software to their local PC. The problem is that i get a "403 Forbidden" error whenever i try to download the file off of OWA. I checked that users had all permissions to the folder.. I found this TechNet article that describes something very similar (http://support.microsoft.com/kb/834743/en-us). The only problem is that it refers to som...

Shared workbook and VBA problem
Shared workbook and VBA problem Hi Group, I am new at this Excel stuff and I am hitting my head on a silly problem that I am sure many have seen before. I wrote a very simple spreadsheet where I use the Calendar control to pick some dates. Everything was fine until I decided that I needed to share it on the network with other users. As soon as I share it the calendar control stops working. I get a "runtime error 1004, unable to set left property of oleobject class". That's because the first thing I try to do is position the calendar. If I don't do that, it still doesn't...

outlook express 6 password problem
Help I have outlook express 6, windows xp. My internet provider just changed from att broadband to comcast. now i keep getting a password rejected error and i cant receive any mail. i cant seem to find a way to shut off the password. in my wifes page of xp it works ok. Hi, Bill - This is a group to support Outlook from the Office group of programs. Outlook Express is a part of Internet Explorer and is a quite different program, despite its similar name.. You will probably get a faster and more expert answer if you post this to an Outlook Express news group. Try posting in one of these n...

cannot get BCM to work on Office Enterprise 2007 and Windows 7
I have Windows 7 and Office enterprise 2007 and tried to install BCM 2007 and got it installed then opened Outlook and said it could not setup database. Is BCM 2007 compatible with Enterprise and Windows 7. Is there a work around? ...

Problems Recieving Emails
I have two accounts one for me and one for the better half. I have them set up on outlook correctly . The problem is I can only down load the wife's email using out look express. I also use Mail Washer to wash the crud out and it does not see the email either although it logs on to the accounts. Cox is my ISP. I have discussed it with them and the answer was to take it up with Microsoft, but that was a waste of time as they have not found any cause for the action. Any ideas of the problem would be kindly accepted. 1. Version of Outlook? 2. Separate mail profiles? 3. Separate Windows L...

getting tight vertical fit automatically
Is there a way to get a tight fit vertically, without having to hand-adjust many row heights (some of three lines, some of 1, etc)? If format|row|autofit is too "loose", then I think manually is the way to go. Kevin wrote: > > Is there a way to get a tight fit vertically, without having to > hand-adjust many row heights (some of three lines, some of 1, etc)? -- Dave Peterson ...

Hebrew Oulook problem solved
Removing the com add-in Outlook Attachment remover solved the problem. ...

Crystal Reports problem 07-11-05
Hi, Client was seeing the usual logon problem when trying to access reports. Tried re-starting all services and this error disappeared but now isn't showing any reports at all. Checked all the files and databases and can't see where the problem is - any suggestions please. By the way this is post install - no one has yet been prompted to install the activex viewer. Hello Pete, This could be Active Directory related. Could you check you added the Microsoft CRM server and the SQLServer computer to the Pre-Winodws 2000 Compatible Access group? This solved a number of problems at ...

Date Problem #2
Hi All Please can someone advise me what to do, I have a date in a textbox where I am using the AddDate method to increment the day , but I am getting strange results. Is this because the US date? if so how do I change this to work for the UK date? Any help would be greatly appreciated regards Subs Hiya- i'm not sure what formula you're using- I put a random date in A1 and pasted the following formula in B1 & C1: =DATE(YEAR(A1),MONTH(A1),DAY(A1)+1) it increased the day by 1 in both cells. I then changed the format to UK and it worked just fine. Is this what you're l...

clip art preview problem
I just downloaded the new microsoft security pack and now my Clip Art function on all of my office programs will not display a preview from the Online Clip Art search program. I know it searches because lots of boxes come up and some of them will insert and show up in my document if I double click them. but I can't spend all of my time inserting them into my document to see if they are the ones I want. A few times the Office Assistant has said that a picture is not available because I do not have the right graphic converter and to press help for more info - that just takes me in ...

How do I get upgarde for publisher 98 to 2000 ?
I have set up the publisher 98 but I have installed in office 2000 on my pc. My system is run win xp so now microsoft update office 2000 SR-1 ...so what shall I do then . aknz2004 wrote: >I have set up the publisher 98 but I have installed in > office 2000 on my pc. My system is run win xp so now > microsoft update office 2000 SR-1 ...so what shall I do > then . ======================================= If you want Publisher 2000, you'll have to purchase a copy of the program. You cannot upgrade Pub98 to Pub2000...they are two separate programs. -- John Inzer return e-mail...

Vista getting shut down by a Trojan
Do anyone know what to to to scan for a Torjan on WinVista? This one shut the machine down within 5 minutes of startup. -- Member - Liberal International This is doctor@nl2k.ab.ca Ici doctor@nl2k.ab.ca God, Queen and country! Never Satan President Republic! Beware AntiChrist rising! http://twitter.com/rootnl2k http://www.facebook.com/dyadallee Hey! Hey! Ho! Ho! Lying Stephen Harper has got to go! Hey! Hey! Ho! Ho! On 10/03/2010 13:10, The Doctor wrote: > Do anyone know what to to to scan for a Torjan on WinVista? > > This one shut the machine down within 5 minutes of...

Why do I get this?
IMCEAEX-_O=ABC_OU=CN121_CN=RECIPIENTS_CN=USER1@companyABC.com <-- why am I getting this as the FROM field from a recently upgrade user to Exchange 2003? ...

Paying Bills
Hello, I have two accounts that go to the same payment service for payment. I can only create one bill for the first account # I do not see how to add a second bill for my second account # Is there a way around this? Thanks Frank Money 2004 Yes. Use different payees like MasterCard {hers} and MasterCard {his}. The braces ant their contents make this work and suppress the contents when, say, printing a check. "Frank" <farocco@hotmail.com> wrote in message news:Oln2RCfQEHA.620@TK2MSFTNGP10.phx.gbl... > I have two accounts that go to the same payment service for paymen...

Outlook is trying to think for me again and getting it wrong (again!)
Please dear lord tell me there is a way to turn this off... I recently composed an email using Microsoft Outlook (2003 SP2) that was supposed to be a list of items, each on a single line. line 1 line 2 line 3 Well, for some reason unknown to me, when the email was sent Outlook reformatted my email and put all the individual lines into a single paragraph with commas and spaces between them. line1, line2, line3 NO NO NO NO NO!!! Not only did I never get a warning that this was going to happen or a chance to reject these changes, but I wanted it the way I freaking typed it! Is there an ...