Problems posting to store account

I have created customers with store accounts in Quickbooks and imported them 
into RMS. Whenever I ring up a sale charging to a store account and close the 
batch I get this whenever I attempt post: "Quick Books error - There was an 
error when saving a General Journal transaction.  QuickBooks error message: 
A/R detail line must have customer" or if I switch the AR accounts around I 
get "Quick Books error - There was an error when saving a General Journal 
transaction.  QuickBooks error message: Transaction split lines to accounts 
receivable must include a customer on that split line." 
I don't understand what I'm missing because I don't see any fields in the 
RMS XML file for "customer" I am trying to work this out on the demo version 
(1.2) since the other system is in production. 

Any help would be great
Hoss
digital_pirate<at>tds<dot>net
0
Hoss1 (3)
5/10/2006 4:39:01 AM
pos 14173 articles. 0 followers. Follow

5 Replies
619 Views

Similar Articles

[PageSpeed] 51

Hoss,

See if these help.

http://tinyurl.com/kcpan

http://tinyurl.com/8rkn7

http://tinyurl.com/bk4wz

Must have access to CustomerSource
-- 
=

 Get Secure! - www.microsoft.com/security

You must be using Outlook Express or some other type of newsgroup reader
 to see and download the file attachment.  If you are not using a reader,
 follow the link below to setup Outlook Express.  Click on "Open with 
newsreader"
 under the MS Retail Management System on the right.

 http://tinyurl.com/75bgz

==========

"Hoss" <Hoss@discussions.microsoft.com> wrote in message 
news:0DDC8711-40EB-4C77-BE13-827CEF9F8751@microsoft.com...
>I have created customers with store accounts in Quickbooks and imported 
>them
> into RMS. Whenever I ring up a sale charging to a store account and close 
> the
> batch I get this whenever I attempt post: "Quick Books error - There was 
> an
> error when saving a General Journal transaction.  QuickBooks error 
> message:
> A/R detail line must have customer" or if I switch the AR accounts around 
> I
> get "Quick Books error - There was an error when saving a General Journal
> transaction.  QuickBooks error message: Transaction split lines to 
> accounts
> receivable must include a customer on that split line."
> I don't understand what I'm missing because I don't see any fields in the
> RMS XML file for "customer" I am trying to work this out on the demo 
> version
> (1.2) since the other system is in production.
>
> Any help would be great
> Hoss
> digital_pirate<at>tds<dot>net 


0
spam3944 (2163)
5/10/2006 10:26:27 AM
Since I don't have access to customer source, those links are of no use...but 
thanks for replying. While I wait for a response from my online form for 
customer source I'll see if I can figure it out.

thanks
Hoss
digital_pirate<at>tds<dot>net

"Jeff" wrote:

> Hoss,
> 
> See if these help.
> 
> http://tinyurl.com/kcpan
> 
> http://tinyurl.com/8rkn7
> 
> http://tinyurl.com/bk4wz
> 
> Must have access to CustomerSource
> -- 
> =
> 
>  Get Secure! - www.microsoft.com/security
> 
> You must be using Outlook Express or some other type of newsgroup reader
>  to see and download the file attachment.  If you are not using a reader,
>  follow the link below to setup Outlook Express.  Click on "Open with 
> newsreader"
>  under the MS Retail Management System on the right.
> 
>  http://tinyurl.com/75bgz
> 
> ==========
> 
> "Hoss" <Hoss@discussions.microsoft.com> wrote in message 
> news:0DDC8711-40EB-4C77-BE13-827CEF9F8751@microsoft.com...
> >I have created customers with store accounts in Quickbooks and imported 
> >them
> > into RMS. Whenever I ring up a sale charging to a store account and close 
> > the
> > batch I get this whenever I attempt post: "Quick Books error - There was 
> > an
> > error when saving a General Journal transaction.  QuickBooks error 
> > message:
> > A/R detail line must have customer" or if I switch the AR accounts around 
> > I
> > get "Quick Books error - There was an error when saving a General Journal
> > transaction.  QuickBooks error message: Transaction split lines to 
> > accounts
> > receivable must include a customer on that split line."
> > I don't understand what I'm missing because I don't see any fields in the
> > RMS XML file for "customer" I am trying to work this out on the demo 
> > version
> > (1.2) since the other system is in production.
> >
> > Any help would be great
> > Hoss
> > digital_pirate<at>tds<dot>net 
> 
> 
> 
0
Hoss1 (3)
5/10/2006 1:37:02 PM
Thanks, Jeff, those articles did the trick. It's a shame that this info isn't 
included in the documentation shipped with the sofware. 


Hoss


"Hoss" wrote:

> Since I don't have access to customer source, those links are of no use...but 
> thanks for replying. While I wait for a response from my online form for 
> customer source I'll see if I can figure it out.
> 
> thanks
> Hoss
> digital_pirate<at>tds<dot>net
> 
> "Jeff" wrote:
> 
> > Hoss,
> > 
> > See if these help.
> > 
> > http://tinyurl.com/kcpan
> > 
> > http://tinyurl.com/8rkn7
> > 
> > http://tinyurl.com/bk4wz
> > 
> > Must have access to CustomerSource
> > -- 
> > =
> > 
> >  Get Secure! - www.microsoft.com/security
> > 
> > You must be using Outlook Express or some other type of newsgroup reader
> >  to see and download the file attachment.  If you are not using a reader,
> >  follow the link below to setup Outlook Express.  Click on "Open with 
> > newsreader"
> >  under the MS Retail Management System on the right.
> > 
> >  http://tinyurl.com/75bgz
> > 
> > ==========
> > 
> > "Hoss" <Hoss@discussions.microsoft.com> wrote in message 
> > news:0DDC8711-40EB-4C77-BE13-827CEF9F8751@microsoft.com...
> > >I have created customers with store accounts in Quickbooks and imported 
> > >them
> > > into RMS. Whenever I ring up a sale charging to a store account and close 
> > > the
> > > batch I get this whenever I attempt post: "Quick Books error - There was 
> > > an
> > > error when saving a General Journal transaction.  QuickBooks error 
> > > message:
> > > A/R detail line must have customer" or if I switch the AR accounts around 
> > > I
> > > get "Quick Books error - There was an error when saving a General Journal
> > > transaction.  QuickBooks error message: Transaction split lines to 
> > > accounts
> > > receivable must include a customer on that split line."
> > > I don't understand what I'm missing because I don't see any fields in the
> > > RMS XML file for "customer" I am trying to work this out on the demo 
> > > version
> > > (1.2) since the other system is in production.
> > >
> > > Any help would be great
> > > Hoss
> > > digital_pirate<at>tds<dot>net 
> > 
> > 
> > 
0
Hoss1 (3)
5/11/2006 1:01:02 PM
Jeff/Hoss,

I am getting the same errors when posting to QuickBooks from RMS.  I
don't see the answer posted in this newsgroup.  Any chance of
forwarding on/posting the answer?  Thanks,
Bob C

Hoss wrote:
> Thanks, Jeff, those articles did the trick. It's a shame that this info isn't
> included in the documentation shipped with the sofware.
>
>
> Hoss
>
>
> "Hoss" wrote:
>
> > Since I don't have access to customer source, those links are of no use...but
> > thanks for replying. While I wait for a response from my online form for
> > customer source I'll see if I can figure it out.
> >
> > thanks
> > Hoss
> > digital_pirate<at>tds<dot>net
> >
> > "Jeff" wrote:
> >
> > > Hoss,
> > >
> > > See if these help.
> > >
> > > http://tinyurl.com/kcpan
> > >
> > > http://tinyurl.com/8rkn7
> > >
> > > http://tinyurl.com/bk4wz
> > >
> > > Must have access to CustomerSource
> > > --
> > > =
> > >
> > >  Get Secure! - www.microsoft.com/security
> > >
> > > You must be using Outlook Express or some other type of newsgroup reader
> > >  to see and download the file attachment.  If you are not using a reader,
> > >  follow the link below to setup Outlook Express.  Click on "Open with
> > > newsreader"
> > >  under the MS Retail Management System on the right.
> > >
> > >  http://tinyurl.com/75bgz
> > >
> > > ==========
> > >
> > > "Hoss" <Hoss@discussions.microsoft.com> wrote in message
> > > news:0DDC8711-40EB-4C77-BE13-827CEF9F8751@microsoft.com...
> > > >I have created customers with store accounts in Quickbooks and imported
> > > >them
> > > > into RMS. Whenever I ring up a sale charging to a store account and close
> > > > the
> > > > batch I get this whenever I attempt post: "Quick Books error - There was
> > > > an
> > > > error when saving a General Journal transaction.  QuickBooks error
> > > > message:
> > > > A/R detail line must have customer" or if I switch the AR accounts around
> > > > I
> > > > get "Quick Books error - There was an error when saving a General Journal
> > > > transaction.  QuickBooks error message: Transaction split lines to
> > > > accounts
> > > > receivable must include a customer on that split line."
> > > > I don't understand what I'm missing because I don't see any fields in the
> > > > RMS XML file for "customer" I am trying to work this out on the demo
> > > > version
> > > > (1.2) since the other system is in production.
> > > >
> > > > Any help would be great
> > > > Hoss
> > > > digital_pirate<at>tds<dot>net 
> > > 
> > > 
> > >

0
bob3251 (1)
6/4/2006 8:55:52 PM
Bob,

Did you try clicking on the links below to find the answer?

> > > http://tinyurl.com/kcpan
> > >
> > > http://tinyurl.com/8rkn7
> > >
> > > http://tinyurl.com/bk4wz
> > >
> > > Must have access to CustomerSource

-- 
*
Get Secure! - www.microsoft.com/security

You must be using Outlook Express or some other type of newsgroup reader to
see and download the file attachment.  If you are not using a reader, follow
the link below to setup Outlook Express.  Click on "Open with newsreader"
under the MS Retail Management System on the right.

http://tinyurl.com/75bgz

**********

"Bob" <bob@b-sky.com> wrote in message 
news:1149454552.079829.240270@y43g2000cwc.googlegroups.com...
Jeff/Hoss,

I am getting the same errors when posting to QuickBooks from RMS.  I
don't see the answer posted in this newsgroup.  Any chance of
forwarding on/posting the answer?  Thanks,
Bob C

Hoss wrote:
> Thanks, Jeff, those articles did the trick. It's a shame that this info 
> isn't
> included in the documentation shipped with the sofware.
>
>
> Hoss
>
>
> "Hoss" wrote:
>
> > Since I don't have access to customer source, those links are of no 
> > use...but
> > thanks for replying. While I wait for a response from my online form for
> > customer source I'll see if I can figure it out.
> >
> > thanks
> > Hoss
> > digital_pirate<at>tds<dot>net
> >
> > "Jeff" wrote:
> >
> > > Hoss,
> > >
> > > See if these help.
> > >
> > > http://tinyurl.com/kcpan
> > >
> > > http://tinyurl.com/8rkn7
> > >
> > > http://tinyurl.com/bk4wz
> > >
> > > Must have access to CustomerSource
> > > --
> > > =
> > >
> > >  Get Secure! - www.microsoft.com/security
> > >
> > > You must be using Outlook Express or some other type of newsgroup 
> > > reader
> > >  to see and download the file attachment.  If you are not using a 
> > > reader,
> > >  follow the link below to setup Outlook Express.  Click on "Open with
> > > newsreader"
> > >  under the MS Retail Management System on the right.
> > >
> > >  http://tinyurl.com/75bgz
> > >
> > > ==========
> > >
> > > "Hoss" <Hoss@discussions.microsoft.com> wrote in message
> > > news:0DDC8711-40EB-4C77-BE13-827CEF9F8751@microsoft.com...
> > > >I have created customers with store accounts in Quickbooks and 
> > > >imported
> > > >them
> > > > into RMS. Whenever I ring up a sale charging to a store account and 
> > > > close
> > > > the
> > > > batch I get this whenever I attempt post: "Quick Books error - There 
> > > > was
> > > > an
> > > > error when saving a General Journal transaction.  QuickBooks error
> > > > message:
> > > > A/R detail line must have customer" or if I switch the AR accounts 
> > > > around
> > > > I
> > > > get "Quick Books error - There was an error when saving a General 
> > > > Journal
> > > > transaction.  QuickBooks error message: Transaction split lines to
> > > > accounts
> > > > receivable must include a customer on that split line."
> > > > I don't understand what I'm missing because I don't see any fields 
> > > > in the
> > > > RMS XML file for "customer" I am trying to work this out on the demo
> > > > version
> > > > (1.2) since the other system is in production.
> > > >
> > > > Any help would be great
> > > > Hoss
> > > > digital_pirate<at>tds<dot>net
> > >
> > >
> > >


0
spam3944 (2163)
6/6/2006 7:20:52 AM
Reply:

Similar Artilces:

Instant Search Pane Problem in Office 2007 Outlook
User on XP SP3 Recently updated user from Office 2003 to Office 2007. Once inside Outlook 2007, the User tries to do a Search of email from a certain user using the "Instant Search Pane" window and only receives Email from two days ago, nothing in the past, which indeed there is email from this "User" she is looking for. Tried REMOVING the Outlook Profile and creating it again and this did not work. Next Step was to Rename the Windows Profile Reboot device and Rebuild it again and this did not work. Had 3 different people log onto this system and the "Instant ...

Posting/publishing to the web
I have a detailed excel spreadsheet - with multiple pages, range names, formulas and control box objects (check boxes and drop down lists). Is there any way to get this to be a web page and allow the same functionality to remain ? interactivity and checkboxes (some formulas are based on results in the text box so I need it all). I tried the publish function but that didnt carry over the control boxes, some conditional formatting and I think a few minor things. IF Excel cant do it - can anyone recommend a software package that can ? Thanks !! Yosef ...

X.400 stack problem
Hello i need help with this, i cant create a tcp x400 stack in the x400 protocol, the procedure that i followed is the next, but the problem is that the option "new" dont appers. if someone know abotu this.. thanks. PROCEDURE To create a TCP/IP X.400 stack: Start System Manager: On the Start menu, point to Programs, point to Microsoft Exchange, and then click System Manager. Navigate to X.400. : System Manager Administrative Groups Administrative Group Servers Server Protocols X.400 Right-click X.400, click New, and then click TCP/IP X.400 Service Transport Stack. ...

Ballancing Problem
I recently setup a new bank account and have been having problems ballancing it for the past 4 months. I key all my transactions into my register manually and then download them from the bank about every other day, or so, to know what has cleared and what hasn't. I rarely use the manual C, all of my transactions have the E. Now I like to double check the bank to the paper statement monthly, all I used to do is start the ballancing process it I would key in the info from my statement and it would move over to the ballancing side leaving the "E" in the "C" field...

Need help with dual domain name problems
Setup: FES: Windows 2003 Server SP1 Exchange 2003 Standard SP2 BES: Windows 2003 Server SP1 Exchange 2003 Enterprise SP2 I'm just getting Exchange setup, I have internal communications working properly but have run into a problem sending externally. The organization has different internal & external domain names, lets call them abc.com (internal) & xyz.com (external). When a message is sent to an external address it goes out as user@abc.com. Since abc.com doesn't exist externally reply attempts fail. I need the exchange to change the sender to user@xyz.com when sendin...

If then-problem
I created a report with 2 entryfields: Afdeling BGVer I wrote following code If Me!Afdeling = "Groodkeukenmedewerker" Then Me!BGVer = "ikke" End If I tried to put it in the Details_Format property and the Report_Page property without any result. What did I do wrong? Thanks JP Problem solved.... never mind this question Jean-Paul wrote: > I created a report with 2 entryfields: > > Afdeling > BGVer > > I wrote following code > > > If Me!Afdeling = "Groodkeukenmedewerker" Then > Me!BG...

autofilter problem #2
Is there a formula to delete empty rows within a column? I use autofilter to delete empty rows. but when the data changes in the cells, I have to manually operate the listbox each time in order to delete empty rows that have changed. i am trying to cut out the extra step of using the listbox to delete empty rows. ------------------------------------------------ ~~ Message posted from http://www.ExcelTip.com/ ~~ View and post usenet messages directly from http://www.ExcelForum.com/ ...

Problems with CAsyncSocket::Receive
I'm having problems with my CAsyncSocket derived class. I'm using TCP and the problem manifests itself on the client side. Sometimes my OnReceive will get called and when my handler calls Receive, will return with a zero return value. Microsoft help states "If the connection has been closed, it returns 0." When this happens, what should I do? Is there cleanup I should do? I've tried calling CAsyncSocket::Close. My code then waits 5 seconds and then attempts to reconnect. It seems to get into a funny state and all communications grinds to a halt. What should I do?...

post cards #2
I am getting the same address 4 times per page on my post card document. Heck, I am not even getting that. I used to get that and somehow, it has disappeared. I am trying to print 2 per page front & back. I have read some of the articles on this forum and tried to use the tips suggested, but for the life of me I cannot figure out how to get 2 up front & back on 1 page ... "candyb" wrote: > I am getting the same address 4 times per page on my post card document. Are you actually printing it or just doing a preview? Print Preview has a glitch and will only show one...

How to send consecutive stored procedures and its parameters
Hi Community I have an ASP.NET web project. In this project I am consecutively sending and passing 5 different stored procedures along with a parameter to a receiving method. The first stored procedure (sp1) and its parameter gets processed by the receiving method without a problem but when the second stored procedure (sp2) gets passed with its parameter to the receiving method the receiving method crashes and the program aborts. Below is an example of how I am trying to pass the 5 stored procedures along with its parameter to the receiving method, the lines that it s...

Problem with 'Tasks' in Outlook
Not sure if this goes here, but I thought I would ask since we are using Exchange 2003. We have some users that like to use the Tasks in Outlook. The person that creates a task is the owner. If they owner closes a task then that task will be closed for everyone else that is part of the task. Somehow this group of users managed to create a task that says it has a different owners. Example: On user A's workstation Outlook says the task owner is user B. On user B's workstation outlook says the own is user A. So, it says it has two different owners, but it actually behave...

Exchange 2000 address books permissions problem
I have several exchange address books in all address books and global address books. My problem is thus - I want to hide certain address books from all users of a particular domain ie the Global Address Book from Doma in 1 users. I have tried denying to domain 1\ users as well as denying from domain 1\securitygroup - where the security group contains those users. I have also blocked inheritance on the test address book I wish to hide - Any ideas ???? ...

Limit Accounts displayed to just customers while in Service Activi
What's the easiest way to limit the Accounts that are displayed in the Form Assistant to actual customers when I create a new Service Activity? I've set the "Relationship Type" within the Account record. I'm assuming I could do an OnLoad trick to filter the Account based on "Relationship Type = Customer" right? Any pointers?? ...

Problem printing inserted images
I've been having a strange printing problem lately, when I insert images in my files some of them print out as solid black rectangles. The strange thing is that up to about a week ago I was able to print out the same images just fine, and if I open the images in Microsoft picture and fax viewer they print fine as well (so I know the file isn't corrupt). Does anyone know how to solve this problem? Publisher is more critical about printer drivers than many applications. Go to your printer manufacturer's web site and look around for an updated driver. -- Mary Sauer MS MVP http://o...

Web store software
I use RMS for my physical retail store and I plan to open a web store. What storefront, shopping cart software do you recommend that is hosted by an ISP, highly customizable, and can possibly integrate with RMS database? I tried Miva and OpenUI hosted on Value Web but it's been a disaster. It just does not work! Try: www.newestech.com Jim Janke Emerald Business Systems "mas" <mas@discussions.microsoft.com> wrote in message news:519092F4-54F9-4746-AD62-582DB999BAB0@microsoft.com... > I use RMS for my physical retail store and I plan to open a web store. What >...

Outlook 2002 and Mail Accounts
Hi, I have a DSL service and my mail accounts with GoDaddy.com. I was able to set up my mail accounts but when I go to make a new message and pick from which account I want to the mail to go through nothing shows up except my default mail. Can anyone help. I am at my wits end. I have already uninstalled and reinstalled Office. Thanks There are two things you may want to try: First recommendation: ---------------------------------------- 1. On the Tools menu, point to Send/Receive Settings, and then click Define Send/Receive Groups. 2. Click All Accounts, and then click Edit...

two PC's connecting to a single email account on Exchange 2003
I have setup a user with a office and a home PC. When the home PC's Outlook was configured it received the email from the Exchange server, but now the old email messages don't show up in Outlook on the office PC. I don't think this is normal and it seems like it is probably an easy fix, but I am not sure where to look. Any suggestions will help. Thanks, Giff it was most likely downloaded to a personal folder. How is the person accessing the mailbox from home? pop3? that is the problem. You'd be better off with a VPN setup...that way, all the mail can stay in the E...

Dcount Problem
I know this is an elementary problem but the more I try to fix it the more confused I get. I need some simple help here. I have searched the Group for an answer but can't find one so here goes. ----------------------------------- I have a form that contains a Dcount. I can't seem to get the syntax correct. Table name: tblNameList Field: option1. This field only contains one of two records both currency. It either contains $0.00 or $15.00. I am trying to count the number of times that $15.00 appears in the field option1. The Dcount I am trying is this but I get an error...

Development Environment
Hi, First off I cross posted this on the ...crm.developer news group but didn't get a reply today so I thought I would cross post this message here... let me know if that is a big no no in the MS crm forums. I am new to MS CRM and have been immersing my self in all the documenation over the last week as well as watching the MS webcasts, reading the news groups and just generally trying to get myself up to speed on the platform SDK. I wanted to know what is the recommended way of developing and testing applications that are going to use the SDK. Specifically I am a remote developer and...

Problem
I'm a Newbie. Church secretary died, no one knows how to use database as is. I have re-entered data from scratch in new worksheet - all of it! Because many couples do not share same last name, it was suggested that I create these columns First_Name1, Last_Name1, AND, (actually a column containing the conjunction "and") First_Name2, Last_Name2. This design was based on creating mailing labels and a directory. To have it work in printing labes, etc, I was to leave Last_Name1 blank if the couple shared the same last name. A limited test was positive with data imported by word for...

Select query problems Access 2003
Good morning everybody I'm using Access2003 on Windows XP SR2 I want to run a select query using parameters to query a table of placenames and details. All pretty straightforward. When I try a click event using the selection of a combo or listbox to set the criteria in the query { Forms![frmSearch]![cboName] } the query gives a nil return nothing happens....the form opens but doesn't display any results. But when is use a txtBox and manually enter known data and run a command button everything works as it should This is the code for the cmd button. Private Sub cmdS...

problem with append query
Hello experts, I have a form witha subform, I need to append the records from the subform into a table. I set it up and it seems to be fine but there is a problem. Only one record from the subform is appended into the table and it is always the record that is selected. is there any way to send all the records that are showing in the subform window to the table? Thanks again in advance Isn't this the same question I just replied to in the Reports NG? Please ask your question in a single NG. -- Duane Hookom Microsoft Access MVP If I have helped you, please help me by donating to UC...

Account payables Subledger
A/P subledger is not Balancing to the GL. How would I go about running a report or Querry to see how they became out of balance? -- Adam H You can start with a historical distribution report in Payables History reports. Run it for the month and compare it to a cross-reference report in GL for the same period, selecting only the purchasing series. You can also run an Historical Aging Trial Balance in Payables for the previous month's end and compare it to the GL's previous month's end balance to make sure those amounts are still in balance. "Adam H" wrote: >...

Due date on loan account
How do I change the due date on a loan account? I can change the loan terms and interest rate, but I can't figure out how to change the due date. Changing the date on the bill series doesn't do it. More context might help. Are you talking about an Apay configured through Money? If changing the date on the bill series doesn't do what you are wanting to do, what is it you are wanting to change? What will appear different or happen differently? "Dave Has No Money" <DaveHasNoMoney@discussions.microsoft.com> wrote in message news:C372A2D6-665C-4A65-BE51-B2FFDD5...

Duplicate Dates Problem
Hello, Using Excel 2007. I have three Columns of data, similar to this: Wish to have the dates as the X axis, and show the next two Columns on the same plot. 21-Apr 143 21 26-Apr 147 93 3-May 144 91 13-May 135 128 13 May 128 81 17-May 143 93 17 May 137 86 22-May 127 89 22-May 123 83 I have the first, the Date column, formatted as: Date / 14 Mar I was hoping to graph this data, and have a line connecting "all" the points (of each column's data). For the second Column, I do have lines connecting the data with the unique dates of 21 Apr thru 3 May For some reaso...