Contacts in GAL using Cached Exchange Mode

Hey all

I am using Outlook 2003 in cached exchange mode connecting to Exchange 
2000. I have an issue when doing lookups for addresses in the GAL.

Before I changed to cached exchange mode, I used to type the first part 
of someone's email address (ie cameron.mc) and press Crtl-K which would 
look up the contact from the GAL. It would also work by entering the 
contact name (ie cameron mcshane) and clicking Ctrl-K. However, once I 
chanegd to cached mode this no longer works. I now must either type the 
full address, or the contact as it appears in the GAL ('McShane, 
Cameron' or 'McShane') before hitting Ctrl-K. I have tested this on 
several machines, and it seems to be the case for all. Is this by 
design? Is there a way around it? I have become very used to typing the 
first part of the address, and it is driving me crazy now it doesn't work.

Thanks for your help


Cameron
0
Cameron
1/27/2005 11:02:37 PM
outlook 87535 articles. 11 followers. Follow

2 Replies
284 Views

Similar Articles

[PageSpeed] 3

When you are working in Cached Exchange mode, name resolution takes place 
against the Offline Address Book, which exposes fewer fields for resolution 
than the full GAL. Specifically, it uses displayName, mailNickname (the 
mailbox alias), physicalDeliveryOfficeName, and Sn (surname). It 
specifically does not use the account's email addresses.

If you need to always use the GAL when resolving names to actual addresses, 
you can force Outlook to do this by modifying the registry:

Key: 
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\Cached 
Mode

Value name: ANR Include Online GAL
Value type: REG_DWORD
Value: 1 (1=enabled, 0=disabled)

-- 
Sue Mosher, Outlook MVP
Author of
     Microsoft Outlook Programming - Jumpstart for
     Administrators, Power Users, and Developers
     http://www.outlookcode.com/jumpstart.aspx


"Cameron McShane" <cameron.mcshane@_csiro.au> wrote in message 
news:O$xoMRMBFHA.3524@TK2MSFTNGP15.phx.gbl...
> Hey all
>
> I am using Outlook 2003 in cached exchange mode connecting to Exchange 
> 2000. I have an issue when doing lookups for addresses in the GAL.
>
> Before I changed to cached exchange mode, I used to type the first part of 
> someone's email address (ie cameron.mc) and press Crtl-K which would look 
> up the contact from the GAL. It would also work by entering the contact 
> name (ie cameron mcshane) and clicking Ctrl-K. However, once I chanegd to 
> cached mode this no longer works. I now must either type the full address, 
> or the contact as it appears in the GAL ('McShane, Cameron' or 'McShane') 
> before hitting Ctrl-K. I have tested this on several machines, and it 
> seems to be the case for all. Is this by design? Is there a way around it? 
> I have become very used to typing the first part of the address, and it is 
> driving me crazy now it doesn't work.
>
> Thanks for your help
>
>
> Cameron 


0
suemvp (4038)
1/28/2005 1:52:45 PM
Sue

Thanks for your help and suggestion. Will making this registry change 
have any impact on Outlook when it is offline - ie will it keep trying 
to lookup against the Online GAL?

Cheers


Cameron


Sue Mosher [MVP-Outlook] wrote:
> When you are working in Cached Exchange mode, name resolution takes place 
> against the Offline Address Book, which exposes fewer fields for resolution 
> than the full GAL. Specifically, it uses displayName, mailNickname (the 
> mailbox alias), physicalDeliveryOfficeName, and Sn (surname). It 
> specifically does not use the account's email addresses.
> 
> If you need to always use the GAL when resolving names to actual addresses, 
> you can force Outlook to do this by modifying the registry:
> 
> Key: 
> HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\Cached 
> Mode
> 
> Value name: ANR Include Online GAL
> Value type: REG_DWORD
> Value: 1 (1=enabled, 0=disabled)
> 
0
Cameron
1/30/2005 5:59:33 AM
Reply:

Similar Artilces:

Use Form to prompt for report criteria
I have a form that I am using to prompt for report criteria. When I run the query outside of the form, it works fine - prompting me for both criteria. However when I run from the form, I get #Error#. Can you see what I am doing wrong? Thanks in advance. I have two combo boxes that I have put in my underlying query. In the fields of the query are: [Forms]![frmSelection Criteria Form]![OfficeNumber] [Forms]![frmSelection Criteria Form]![Manager] *** On the OnClick event is the following: Private Sub Command6_Click() On Error GoTo Err_command6_Click Dim stDocName As String st...

Browse for Drive/Dir/File using MFC
Is it possible, in an MFC app, to use one of the standard dialog-based classes/functions to browse for either a drive OR a directory OR a file? Any help appreciated, Steve. Take a look at the SHBrowseForFolder() API. -- Cheers Check Abdoul [ VC++ MVP ] ----------------------------------- "Steve Carroll" <ctrl@optusnet.com.au> wrote in message news:#tR$bmdfDHA.696@TK2MSFTNGP09.phx.gbl... > Is it possible, in an MFC app, to use one of the standard dialog-based > classes/functions to browse for either a drive OR a directory OR a file? > > Any help appreciated...

Exchange 2000 DST Changes
How is one supposed to address the DST changes for Exchange 2000 if they do not have extended support to get the patch? Will Microsoft be providing a workaround like they did for Windows 2000? I'm referencing the following article: http://support.microsoft.com/kb/930879 It states : What to do before you run the Exchange tool Install DST updates Before you run the Exchange tool, make sure that client and server computers are updated correctly with the operating system and application DST updates. These updates must be installed in the following order: 1. Install the Windows DST upda...

Restoring Exchange 2000 cluster to "standard" Exchange 2000 Enterp
Hi all, At the moment we are creating a "full" test environment built from backup tapes from our live environment. DC's are all up and running. Our 2000 native forest exists out of a top domain and 2 child domains. All DC's are running 2000 SP3 as well as the Exchange servers. Exchange servers are located in the child domains. In one of the child domains which is NL.top.net we have an Exchange cluster, 2 nodes active/active eg. These would be EX01 and EX02 and running EX04 and EX05. Since we unfortunately do not have a SAN in our test site I will not be able to do a DR...

Adding an item to a popup menu in outlook's inbox using VBA
Hello all, On rightclicking on the mailitems in the outlook's inbox we can see a popup menu.i want to add a menu item to that popup menu using outlook VBA. Please do help me in this regard. Thanking you regards, Revathy.v ...

converting tabular structures in a Word document into an actual table or reading data from the tabular structures using VBA code
I have a macro which can read the last cell/column of all tables in a Word 2003/2007 document and store the data in an MS-Access table. But, some Word documents have the data in structures like a table format but are not actually tables. The structure looks like a table, but the table borders are actually line connectors. These documents were created by a software(VeryPDF PDF to Word converter) which converted the PDF documents(the original format these documents were) into Word documents. 1. Is there a way I can convert/replace the tabular structures with actual tables in Word so t...

OL2003 (Exchange) and OE6 running in the same PC
We are currently upgrading our OS from W98SE to WinXP. Our VP is using Netscape v4.67 with dial-up to access his personal email from the ISP and Novell Groupwise for his internal corporate email. With the new WinXP, he will be authenticate to Active Directory and using Exchange 2003 (Outlook 2003) for corporate email. (Yep, no more Groupwise!!) I want to move him away from Netscape to OE6 (built-in with XP pro). During my test in the lab, for some reasons I can't have OE6 and OL2003 running at the same time. (I can launch either one but not both at the same time) He wants OE6 as his...

Exchange 2003 OWA #6
Exchange 2003 OWA I would appreciate if someone would be able to help me. When I'm trying to access Exchange 2003 Server via OWA, I'm getting error "The folder can't be displayed. You do not have permission to perform this action" We also running Microsoft ISA Server. Thanks ...

Exchange Connector Wizard error
I received this error while trying to run this wizard for a generic CRM user(what role does it have to have?) that would accept all email directly to CRM. I ran it on a client computer (was this wrong?) Here is the error, anyway. "Failed to initialize the rule management subsystem." What is the correct procedure to run this wizard? I did not find it anywhere. Thanks! ...

Exchange 5.5 to 2003 upgrade issue 3
We have upgraded our Exchange 5.5 server to 2003 and moved all the mailboxes and moved and re-homed the folders following the KB articles. We turned off the 5.5 services and for a week everything was working fine. Now for some reason the messages to the main distribution list is being sent to the old 5.5 server on a x400 protocol. How can I stop this and assure that the 2003 server is self contained so I can get rid of this server? ...

NNTP move to Exchange?
Hi, I'm having a problem with getting a NNTP feed from a INND 2.2.1 server to Exchange 2003; are there any known issues here? Has anyone done this type of migration before? What issues did you encounter? It seems as if Exchange just wants to pull down a few of the groups (of which we have over 100 internal) and even with that, not even pull all of the messages in from those few groups (it usually gets a few hundred messages). I'm using the basic NNTP wizards but everything looks to be configured correctly. Thanks, Dan ...

"the wizard is unable to open your query in datasheet mode, possi
"the wizard is unable to open your query in datasheet mode, possibly because another user has a source table open in exclusive mode. your query will be opened in design view" what this message mean ,and how can i solve it Hi - Please provide more details as to what you are doing when you get the error, what your database setup is (i.e. split Fe/BE?, multiuser?, version? etc). Without more information, we can only guess. Thanks - John amr wrote: >"the wizard is unable to open your query in datasheet mode, possibly because >another user has a ...

Metadata Cache Error 04-14-04
When trying to "Go Offline" after synchronization completes I receive the: "Metadata Cache Error" No Entity Anyone experience/solve this issue? Hi, You may have replication setup issue on your SQL server, I suggest you to go through this article : http://mbs.microsoft.com/TechKnowledge/techknowledge.asp?print=true&id=33588&code=7842 If this is OK, you may test the following manipulation : Open SQL Enterprise Manager; go to Start select All Programs and then Microsoft SQL Server. Expand Microsoft SQL Servers, expand SQL Server Group, expand your Microsoft CR...

Exchange Server 2000 Secuirty Setup problems
Dear I have apply wrong setting to our exchange server 2000 . The wrong setting as from exchange manager . mail store , I have apply everyone send as and receive as access right, the group included remote access via offline sync. This setting once apply , all user access other mailbox without apply access right. I have try disable this setting, after all local office user no problems, but a remote offline sync laptop user does not work . The error as below: Unable to display the folder. Microsoft Outlook could not access the specified folder location. The file C:\exchange\shawnb.ost cannot b...

Catch all outgoing email on Exchange and send copy to specified account
Hi all. I have been asked to find out if there is anyway to configure our mail server to catch all outgoing email from certain email accounts on our Exchange 2003 Enterprise server and forward a copy of this email to a specified account, also on the Exchange server. If anyone could point me in the right direction I'd be grateful. On 25 Oct 2006 04:10:54 -0700, googlegroups@tlbsolutions.com wrote: >Hi all. > >I have been asked to find out if there is anyway to configure our mail >server to catch all outgoing email from certain email accounts on our >Exchange 2003 Enterpr...

How do I setup an SMTP gateway / smart host for Exchange 5.5 internet bound mail
My current setup has a Windows NT 4.0 Exchange 5.5 server setting on our company LAN behind a Microsoft ISA Server. The Exchange server's Internet Mail Connector binds to (I assume this is the proper terms) port 25 on the ISA server for inbound and outbound Internet Mail. Our company has finally upgraded to a new Cisco Pix Firewall which we are able to setup a DMZ on. The suggestion by our ISP is to setup an SMTP gateway in the DMZ and have our internal Exchange server send mail to it destined for the Internet. I am aware that most of the work for making the connections from the SMTP ...

Insert,Update Data in sage (MS Access Linked tables) using Vb.net form
Hi folks, I am developing application using vb.net which requires integration with SAGE LINE 50 (Accounting software ) V11... The data which SAGE is using is MC ACCESS 2003 database... with linked tables in it... Now I Have developed the Sage connection using ODBC which works fine when reading the record but cannot Add or Update record into the Linked tables.... When i debug the program the error is at the line where it has... <br> MyodbcCommand.ExecutenonQuery() <br> Can anybody Help ????? -- Message posted via AccessMonster.com http://www.accessmonster.com/Uwe/Forums.aspx/acce...

Lost contacts
A customer brought his laptop from work and added it to his SBS 2000 network. Now he can not get to his old mail or contacts. The operating system is Windows XP Pro. His Outlook is also XP from Office XP Pro. He did not create a PST file prior to adding the laptop to the network. I belive his old mail and contects are still there but in a different profile. I can not find them in the Office 10 folder. Can anyone tell me how to recover his old contacts and mail or piont me to a Knowledgebase article? TIA Dan ...

Using atl based win dll with CString functions from the mfc projec #3
I have atl based general windows dll with class which contains functions which uses CString as parameters or return values. This dll might be used from the atl or mfc project. Dll can be used from ATL project without problems but whenever I try to use this class from the MFC project I get the following linker errors: error LNK2019: unresolved external symbol "__declspec(dllimport) public: int __thiscall MyClass::AddMenu(long,class ATL::CStringT<wchar_t,class StrTraitMFC_DLL<wchar_t,class ATL::ChTraitsCRT<wchar_t> > > const &,long)" ... If I replace CStri...

Business contact manager install failure
Office 2007 BCM gives me this error when I try and install it: Setup cant finish because it can't delete: c:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\temp_MS_AgentSigningCertificate_database_log.LDF Any ideas? ...

Duplicate Containers in AD after Exchange 2003 Migration
The scenario is: We migrated from an NT domain to a 2000 domain. Then about a year later we migrated from exchange 5.5 to exchange 2003. Once the migration was complete, we discovered that there were duplicate containers and OUs in "Active Directory Users and Computers" which were empty. For example, when we did the AD migration we created an OU hierarchy at the root of the domain. After the exchange migration we found a duplicate hierarchy structure under the Users container but it didnt actually contain any objects/information that was in the original OU structure. We don...

Not using zeros in graphing.
I have a running workbook that has tons of information. I have added a sum page in order to have all the data summed up in one simple place. I have formulas that read back into the workbook to link to a cell. Depending on what moth it is, that cell could be empty as it is a yearly wookbook. For example, if this is August, then there is information in the workbook up to August, but none after. With that said, the sum page has the #DIV/0! in the cell which essentially equals zero. I also have graphs that I have linked to this sum page. My problem is in order to keep the graphs up to...

using vba so search multiple Sheets
i'm trying to search across multiple sheets based on data submitted via an input box. So essentially, you click the button, a box appears, you type what your looking for and if it finds it, it'll select it otherwise a error message appeats. i found the below code, but it only works if the cell with the value in it is active (i.e. i've clicked on it). Code: Dim datatoFind Dim sheetCount As Integer Dim counter As Integer Dim currentSheet As Integer On Error Resume Next currentSheet = ActiveSheet.Index datatoFind = InputBox("Please enter the value to search...

DPM and VMM on same server using side-by-side SQL installation
Windows 2008 Std R2 Server, 64bit VMM 2007 is currently installed (with the built-in default database) SQL 2005 Express Edition, SP3, 32bit. I was advised by Microsoft that both VMM and DPM could be installed on the same server (small DR environment) The VMs are hosted on a Windows 2008 Enterprise Server w/ VS2005R2 - because the hardware didn't support HyperV. VMM works great to manage the Windows 2008 VS2005R2 Host running Win2K3 server instances ... after lots of trial and error. Now, I need to install DPM 2007 onto the same server... DPM wants to install the 64bit vers...

Outlook won't conect to Exchange
Client: XP pro, Office 2003 Pro Server: Server 2003 I cannot get a client's Outlook to connect to Exchange server--or at least I THINK that's the issue. I have tried everything that I and the sys admin can think of. We've even uninstalled and re-installed the whole of Office. Out of desparation, I tried something that I thought would probably not have any impact, but it worked--temporarily. I deleted the use's mail profile, and the application opened and displayed all the users mail! I thought I was pretty close to being home free, so then I closed Outlook and re-opened...