BUGS BUGS BUGS

Dear Microsoft. I can understand programming bugs - you invent, you create, 
everyone makes mistakes etc etc. But how on earth can you have bugs in 
financial calculations? Take Finance 101 book. Replicate formulas. DON"T 
CHANGE THEM! 

I have already complained about mistakes in calculating bond yields in M2005 
(has it been fixed?) where accrued interest is simply disregarded in 
calculations. 

Performance calculations in multiple currencies ARE ALL WRONG!!! 
here is example

"buy" any asset in the account which is in a currency different to your base 
(say base is US$ and account currency is Euro). so far so good. 

now switch to currency say GBP as your base. look at you performance. did 
you just lose 45%? well, thank you Microsoft for using US$/EURO exchange rate 
in calculating "Avg cost" of the asset in GBP. 

Now how complicated to get this right? if you cannot make functionality work 
- don't introduce it. Cannot deal with multicurrencies and simple bond 
calculations? Don't mislead customers by selling defective software. 

has any of these bugs been fixed in 2006 and 2007?

 
 
0
8/16/2006 11:13:02 AM
money 28651 articles. 7 followers. Follow

0 Replies
861 Views

Similar Articles

[PageSpeed] 38

Reply:

Similar Artilces:

bugs in Money 2004
I have recently installed Money 2004 over Money 2003. There are two significant bugs. The dates in my autopay bills section for online banking were changed from next month to various dates in 2004 and 2005. Thus my bills aren't being paid and I have to manually cancel each of them and and resubmit all of them. Microsoft doesn't have a clue how to solve the problem. When I download my checks from online banking, Money 2004 changes the payee. For example, the bank paid Company A $104.25. When it appears in my Money register, it says it paid $104.25 to Company B. Thus I h...

In need of an IProgressDialog Bug workaround
I am using the IProgressDialog interface to display a simple progress dialog to the users of my product. The problem is that there seems to be a bug when using the interface to display a modal version of the dialog. In this case, when the user selects cancel the main application loses focus and hides behind any other active applicaiton on the desktop. I have seen references to this problem on CodeProject, and descriptions of the cause of the problem, but no workarounds. I do not see the problem when using other programs that seem to be employing IProgressDialog. The problem does no...

Please validate my bug report with MS
I've filed a bug report with MS: https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=330188 I've gained a lot of useful insight from the folks here and I really appreciate the time that everyone takes to answer questions. I found what I believe to be a bug in the MIDL compliler in VS 2008. I would really appreciate it if you have time to try to verify my bug and add to the Validation count for that bug so that it get's increased and I know that someone other than myself is able to reproduce it. Included in the bug report is an attachment with eve...

Bug: Cannot import brokerage statement
I just installed Money 2005 and then added my 401k account (Prudential Investments). When it asked me what transactions I wanted to download, I selected all. After the download finished I go to the Review investment activity page. I see a list of all the investment activity. I click the Next button to update Money to this statement. I get a dialog stating that a security was found where it already exists but under a different name. There are two radio buttons, the first to confirm that it is the same security, the second to add it as a new investment. I select the first(default) and the...

Format Zip Code Bug
Using the latest version of Excel, 2003. If you have a column of zip codes, some 5 digit and some 9 digit, and format them as 9 digit zip codes the formatting tool is not smart enough to leave the 5 digit zip codes alone. Instead it insert 4 leading 0's. Probably not how it should work. Maybe you could use a custom format to cover both 5 digits and 9 digit zips: [>99999]00000-0000;00000 Al Franz wrote: > > Using the latest version of Excel, 2003. If you have a column of zip codes, > some 5 digit and some 9 digit, and format them as 9 digit zip codes the > form...

Have I found a bug in Outlook's filters?
I have two filters I use. I take my contacts and move them to a folder called "Friends". The second filter I use takes any message with my first name, last name, or my nickname in the subject/body and also puts them in the "Friends" folder. I month or so I started getting mail in my "Friends" folder that I could not understand why. Now there are more and more showing up. I found out that the reason I am getting unexpected mail in my "Friends" folder is because the mail is addressed to "friend" I thought that because friend was so close to...

Pivot Table Not Refreshing Properly? Excel BUG???
Dear All Any clue why the pivot table is still remembering old data? I have field where I have names and numbers as data... For some reasons, th numbers are always among row field items even though I have delete those data with the numbers leaving only names among the data... An clue or it's an Excel Bug??? Cheer -- Message posted from http://www.ExcelForum.com When I have encountered this same problem the only solution I found was to drag the field off the table (sometimes had to close the workbook and re-open it), then drag the field back onto the table. On Thu, 16 Sep 2004 21:47...

Any one seen this BUG in Matrix Items.
Hi All, I have come across what I think is a bug in RMS Matrix Items occurring when the description of the dimensions contain a single inverted comma ('). Take this example:- Matrix Item called: Magazine ItemLookupCode: MAG Single Dimension called: Title Add any item and set the Title column to somethin like: Jason's Adventures. Save the Matrix Item. Sell the Item MAG in POS, The matrix selection screen appears - choose the Item Jason's Adventure, then crash with this error and POS Closes. "Run-time error '3001' Arguments are of the wrong type, are out of accepta...

BUG in MFC vc2008!
Hello Microsoft's guys! :-) I have detected a bug in MFC, with vc2008! Take a look at afxstate.cpp: Line 185-190: m_pDllIsolationWrappers = new CDllIsolationWrapperBase*[_AFX_ISOLATION_WRAPPER_ARRAY_SIZE]; #ifndef _AFX_NO_AFXCMN_SUPPORT m_pDllIsolationWrappers[_AFX_COMCTL32_ISOLATION_WRAPPER_INDEX] = new CComCtlWrapper; #endif m_pDllIsolationWrappers[_AFX_COMMDLG_ISOLATION_WRAPPER_INDEX] = new CCommDlgWrapper; m_pDllIsolationWrappers[_AFX_SHELL_ISOLATION_WRAPPER_INDEX] = new CShellWrapper; Then line 335-339: #ifndef _AFX_NO_AFXCMN_SUPPORT delete m_pDllIsolationWrappers[_AFX_COMCTL32...

Value by Investment Report Bug
Here's a problem I stumbled upon and it appears to affect both Money 2004 and 2005. I'm trying to display a Pie Chart that shows the value of each of my investments in a 401(k) account. I selected the "Portfolio by Investment Type" report and customize it as follows: 1. Click Customize 2. Click on the Rows & Columns tab 3. Select "Subtotal by: None" (this selection makes it show each individual fund or stock in your accounts) 4. Click on Account tab 5. Deselect all accounts except for the 401(k) account (this could be any account you want to display...

OL 2002 SP3: Documentation bug about client-only rules
There is incomplete information under the "My rule name contains Client Only" section of "Troubleshooting Outlook Rules" page (located at mk:@MSITStore:C:\Program%20Files\Microsoft%20Office\Office10\1033) It fails to mention that adding a rule to look for specific words in recipient's address also will also cause the rule to become client only. ...

Bug of Solver?
Dear All In A1 put =(B3-B4)^2 and in B3 and B4 put 0. Afterwards, use Solver to maximize the formula in A1 by changing B3:B4 and with the following constraints: B3:B4<=1 B3:B4>=0 The maximum is 1 but Solver founds 0 as the maximum. Is is a bug of Solver? Thanks in advance, Paul Solver is just quiting early because it got confused when the starting values in B3:B4 are equal. Try starting Solver with different values in B3 & B4 and it "should" work. I would delete the constraint that B3:B4>=0 and instead check the option to "Assume non-negative." -...

Bugs/Problems with named entities and innerHTML
The following web page demonstrates some buggy behavior with named entity handling in IE8 (also IE7), along with bugs/inconsistencies in how innerHTML in IE8 (and 7) deal with named entities. <head> <script type="text/javascript"> function displaySource() { var el = document.getElementById('hasEntities'); alert("innerHTML: '"+ el.innerHTML + "'\ninnerText: '" + el.innerText + "'"); } </script> </head> <body> <h1>Improperly Handled Entities</h1> <p>This is a...

is this a bug? macro? virus?
I don't know how this started, but I open my Excel, and everything i fine... I open a file, and things are fine... but once I click on cell in the document, it continues to select wherever my mouse goes and nothing seems to stop it! if I leave the file open, but alt-tab, it will keep scrollin indefinitely, into 6-figures of cells. ack! my macros are set on high security, and I don't have any enabled. any ideas, please -- Message posted from http://www.ExcelForum.com Hi you have probably invoked the 'extended selection'. Check if there is an 'EXT' in the statusba...

Exchange 5.5 -2003 Move Mailbox BUG
Hi all I have an issue that I must say I feel has to be a BUG in Move Mailbox procedure in Exchange 5.5 - 2003. I have set up a Exchange 2003 server in the same site as my old 5.5 server and followed the Deployment Tools with no errors at all (with ADC). The problem started when I tried to move mailboxes in between servers. Everything looked fine, but when the users started to log on in the morning some of them found that their mailboxes were empty. A look at the servers showed that some of the users now had a mailbox on the 2003 server but also a mailbox on the 5.5 server which was emp...

Bugs? or weakness?
Hi all why I can't add Project Accounting windows for Cards, Inquiry and Transaction when I tried to add on the Quick Links in GP Homepage? is there any setting to be done for it? Please advice million thanks, kat ...

GP 10 Metrics widget bug with Office 2007
HI all: We have version 10 of GP installed (SP3 10.00.1328) and we recently upgraded to Office 2007 from Offcie 2003. This has caused the Metrics "widget" on users' home page to throw an error message. (The Metrics widget is not able to use the Office 2007 version of the Microsoft Office chart control.) We can of course get around the error by not showing this widget. However, does anyone know of a way to resolve this? Thanks much. -- Norman Norman, this is from the notes on the client requirements for GP 10.0: The Microsoft Office Web Component...

PropertyPage Drawing Bug in VC6 ?
Hi guys, Sometimes my PropertyPages have a grey background, not the white like they're supposed to have. I had one working great until I resized the dialog box in the resource editor, then it became grey. I checked all the values in the .rc file and they are fine (I compared them to another property page that works), it's very annoying to say the least. Is there a fix ? I'm using VC6 (SP5) on XP Pro (SP2) Thanks. > Sometimes my PropertyPages have a grey background, not the white like > they're supposed to have. I don't understand that statement. Property ...

OL2000: BUG: Outlook composes message in Rich text format when the "mailto" link contains the "body" parameter
Example: mailto:xxx@xxx.xxx?subject=hi - opens a new message in plain text or HTML text, based on the default setting mailto:xxx@xxx.xxx?subject=hi&body=test - opens a new message in Rich text. User then has to manually change to plain text. How can I submit this bug to Microsoft? Thanks, Ivan Ivan B�tora <xxx@xxx.xxx> wrote: > Example: > > mailto:xxx@xxx.xxx?subject=hi - opens a new message in plain text or > HTML text, based on the default setting > > mailto:xxx@xxx.xxx?subject=hi&body=test - opens a new message in Rich > text. User then has to manu...

BUG: Sending message x of x
Yet another Outlook 2007 bug. I get "sending 13 of 13" when choosing Send/Receive except the problem is that I'm not sending any messages. I think this happens when I'm sending one message. And my G-d, it's slow. It hits the hard drive endlessly. Does anyone else notice that your hard drive won't stop spinning with Outlook 2007 open? Most of what you are calling "bugs" are most likely not. Many are probably settings you have misconfigured. Did you even bother to create a new profile after you upgraded? That has always been a requirement in Outlook. -- R...

Excel 2003 Subtotal
i used subtotal with excel 2000 and everything was fine. now using exce 2003 i have some strange problems: using the subtotals more then 2 times, the totals are not sorte correctly and also the total isn't correct. see attachment: line 52/53 correct, line 58/59 wrong. also "gesamtergebnis" line 77 is wrong! can anyone help? is this a software bug? sorry for my bad english, but i don't know how to describe this i english, perhaps someone here speaks german, this would be muc easier! best ragrds grego +-------------------------------------------------------------------...

x64 thread scheduling bug?
We have experienced some abnormal behavior with multithreaded programs in x64 (XP Pro x64 and W2K3 Server x64). I believe the OS scheduler isn't operating correctly. Basically, we have an cpu intensive app that divides work and creates threads to take advantage of SMP on multiprocessor systems. Lower priority tasks were not being pre-empted, and sometimes performance was just poor. Here's one thing I've found which leads me to suspect the scheduling: I created a small project that creates worker threads that will use 100% of a given cpu. This works fine if no background tas...

Is it Windows BUG? (Japanese + MBCS + Command line)
Hi All, I' m currently working with an application which is build using _MBCS and want to use it on Japanese. I'm passing a string from command line ?????????? to my application. The problem I'm having is two bytes change automatically. ?????????? Actual representation: C4 83 CC 88 9F D0 8A 95 A9 ED B4 90 AC F6 A9 8F 98 lpCmdLine : C4 83 CC 88 9F D0 8A 95 A9 FA D0 90 AC F6 A9 8F 98 m_lpCmdLine : C4 83 CC 88 9F D0 8A 95 A9 FA D0 90 AC F6 A9 8F 98 Clearly two bytes ED B4 is changed to FA DO. If I reset these two bytes my app works fine. My guess is that the...

Is this a bug or not?
I replied to an email that was archived in Outlook 2007. The 'sent' copy was placed in the archived sent folder instead of the one in my personal folders. Is this normal or a bug? Is there anyway that I configure responses to archived 'mails to be put in the current sent folder? TIA. Cheers, Guy ** Stress - the condition brought about by having to ** resist the temptation to beat the living daylights ** out of someone who richly deserves it. "Dr Teeth" wrote in message news:db8si3lpuejhnpm3luacpu2rkkaef66stt@4ax.com... > I replied to an email that was archiv...

Web Access Bug when logging in
I have found with Exchange 2003, if I add a new user in AD and then I try to log into the web access app, everything works fine. But, when I change or remove the original primary email account, I am no longer able to log into the web access tool. I have tried this many different was but this I drilled down to to every time I change or delete the primary email account, I am not longer able to log in. Does anyone else see this or know why this is happening? "I change or remove the original primary email account" Do you mean account or e-mail address? The exchange folder i...