Websites don't recognize IE8

I have Windows XP SP3 and IE8. It has happened before with some websites 
which would not display, saying that I have an older version of IE and need 
to upgrade to version 8. I ignored it thinking their JavaScript was acting 
weird. However, today it happened with Facebook, too. This is the message I 
get: 

You may want to upgrade your browser.
You're using an old version of Internet Explorer to browse Facebook right 
now. Facebook will work better for you if you upgrade or switch to another 
browser.

Any ideas?
0
Utf
11/17/2009 6:16:04 AM
internetexplorer.general 1684 articles. 0 followers. Follow

6 Replies
1821 Views

Similar Articles

[PageSpeed] 22

shqipo wrote:
> I have Windows XP SP3 and IE8. It has happened before with some websites 
> which would not display, saying that I have an older version of IE and need 
> to upgrade to version 8. I ignored it thinking their JavaScript was acting 
> weird. However, today it happened with Facebook, too. This is the message I 
> get: 
> 
> You may want to upgrade your browser.
> You're using an old version of Internet Explorer to browse Facebook right 
> now. Facebook will work better for you if you upgrade or switch to another 
> browser.

Likely either (1) something is forging a userAgent string which 
corresponds to an old version of IE, or (2) a browser sniffer is too 
dumb to determine the correct version of IE.

Try this.  Go to:

     http://www.upsdell.com/BrowserNews/res_browser.htm

In the table which has columns Property and Value, you should see a 
property navigator.userAgent:  what is the value?
0
C
11/17/2009 6:26:12 AM
Start here http://www.fiddlertool.com/useragent.aspx or maybe here 
http://www.enhanceie.com/ietoys/uapick.asp

Try "spoofing" IE7 User Agent strings.

Also reply to C A Upsell's post.


shqipo wrote:
> I have Windows XP SP3 and IE8. It has happened before with some websites
> which would not display, saying that I have an older version of IE and 
> need
> to upgrade to version 8. I ignored it thinking their JavaScript was acting
> weird. However, today it happened with Facebook, too. This is the message 
> I
> get:
>
> You may want to upgrade your browser.
> You're using an old version of Internet Explorer to browse Facebook right
> now. Facebook will work better for you if you upgrade or switch to another
> browser.
>
> Any ideas? 

0
PA
11/17/2009 6:46:39 AM
I have Vista with IE8 and have the same issue, some sites still think I'm 
using IE7 even though I have the compatibility mode switched off. This site 
reports I'm using IE7... http://www.wellsfargo.com/help/wfonline/browsertest, 
this site tells me I need to upgrade my browser... 
https://www.smssoccer.ca/sms/index.jsp

"shqipo" wrote:

> I have Windows XP SP3 and IE8. It has happened before with some websites 
> which would not display, saying that I have an older version of IE and need 
> to upgrade to version 8. I ignored it thinking their JavaScript was acting 
> weird. However, today it happened with Facebook, too. This is the message I 
> get: 
> 
> You may want to upgrade your browser.
> You're using an old version of Internet Explorer to browse Facebook right 
> now. Facebook will work better for you if you upgrade or switch to another 
> browser.
> 
> Any ideas?
0
Utf
11/17/2009 3:48:02 PM
Cleaning up my UA using the script in 
http://www.enhanceie.com/ietoys/uapick.asp
 as given by PA Bear's post fixed my problem. My UA was too long.

thanks PA,
Colin

"shqipo" wrote:

> I have Windows XP SP3 and IE8. It has happened before with some websites 
> which would not display, saying that I have an older version of IE and need 
> to upgrade to version 8. I ignored it thinking their JavaScript was acting 
> weird. However, today it happened with Facebook, too. This is the message I 
> get: 
> 
> You may want to upgrade your browser.
> You're using an old version of Internet Explorer to browse Facebook right 
> now. Facebook will work better for you if you upgrade or switch to another 
> browser.
> 
> Any ideas?
0
Utf
11/17/2009 4:07:02 PM
"shqipo" <shqipo@discussions.microsoft.com> wrote in message 
news:A0155A6C-D7F9-4575-979E-CCF1547DB151@microsoft.com...
>I have Windows XP SP3 and IE8. It has happened before with some websites
> which would not display, saying that I have an older version of IE and 
> need
> to upgrade to version 8. I ignored it thinking their JavaScript was acting
> weird. However, today it happened with Facebook, too. This is the message 
> I
> get:
>
> You may want to upgrade your browser.
> You're using an old version of Internet Explorer to browse Facebook right
> now. Facebook will work better for you if you upgrade or switch to another
> browser.
>
> Any ideas?


Are you sure you're using IE8? It's odd that you could use IE8 and get 
warnings that you're using an older version.






0
Jeff
11/17/2009 4:26:59 PM
YW, Colin.  Thanks for your feedback.

Colin wrote:
> Cleaning up my UA using the script in
> http://www.enhanceie.com/ietoys/uapick.asp
> as given by PA Bear's post fixed my problem. My UA was too long.
>
> thanks PA,
> Colin
>
> "shqipo" wrote:
>
>> I have Windows XP SP3 and IE8. It has happened before with some websites
>> which would not display, saying that I have an older version of IE and 
>> need
>> to upgrade to version 8. I ignored it thinking their JavaScript was 
>> acting
>> weird. However, today it happened with Facebook, too. This is the message 
>> I
>> get:
>>
>> You may want to upgrade your browser.
>> You're using an old version of Internet Explorer to browse Facebook right
>> now. Facebook will work better for you if you upgrade or switch to 
>> another
>> browser.
>>
>> Any ideas? 

0
PA
11/17/2009 9:32:47 PM
Reply:

Similar Artilces:

IE8 install caused 370% increase in computer boot time
I was using IE7. I just installed IE8 through windows update. Boot up time increased by 370%. (I used a digital kitchen timer) After boot up, IE8 worked fine and everything else is normal. No other problems other than slow boot time. Shut-down-start-up a couple of times and same slow boot time with no other problems. I uninstall IE8 using the restore point. Boot time went to normal and IE7 and everything else worked fine (except FF-I will reinstall). After the third shut-down-start-up, boot up time increased by the exact 370% again. My use of the restore point must not ha...

Dvd/Cdrw not recognized?
I have a Dell Inspiron 5000 laptop.I am running windows xp professional.I was running a cd drive perfectly, when I took a cdrw/dvd from another Dell Inspiron 5000 and installed it in my laptop it does not recognize any hardware for new dvd drive anywhere. I have tried mr.fix it,3hrs and no result. I have tried the registry fix, did not work. I have looked for a driver, none found. Please tell me if it is possible to have a dvd cdrw while running xp professional? If so HOW! Please help! =?Utf-8?B?UGF1bCBH?= <PaulG@discussions.microsoft.com> wrote in news:A73F7A24-A427-4...

ie8 is extremely slow for javascript
i have been using javascript (jQuery and prototype javascript) for developing a webpage which works extremely well on Firefox and Google Chrome. Any javascript operation is done instantaneously on Firefox and Google Chrome, but the same operation take few seconds to be executed on IE. Even the event handlers are very smooth on other browsers and they seem to be buggy on IE. Developer-specific resources include: MSDN IE Development Forum (post such questions here instead) http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads Tip: When posting in Developer for...

My Calendar Does Not Recognize Me?
I can orginate a meeting and invite others including a alias that I happen to be a member of. Later, I want to change the time of one of the recurring meetings. When I open the meeting and choose just the single occurance I see that I am listed as the orginator. However, it does not recognize me as the orginator. I can change the meeting for myself but not generate a meeting change notification for the others on the list. ...

Excellent Website for Microsoft Exams
Hi there, Excellent website which have ALL the IT Certifications available, http://certadvisor.blogspot.com Good luck. ...

CRM4 Installation error due to missing file on Microsoft website
Hi, I hope Microsoft monitor these newsgroups! I'm trying to install CRM4 on a clients Windows 2008 x64, SQL2008 x64 server. As per advice I am clicking 'Update Installation Files' however this produces an error. The wizard says you can download the updates manually, so it's an English install code 0x409, so I follow this link (x64 English Server update): http://go.microsoft.com/fwlink/?LinkID=104228&clcid=0x409 And it turns out that link fails (probably explains why the main install update fails!)... So now I cant install CRM4 because I need that update on that se...

MS Excel as backend/database for a website
Hello, If I use MS Excel as the backend/database for a website, how stable is it? Can you please offer any information on the pros and cons of doing so? Thank you ...

Connecting to Bank Website
I use spysweeper and a few days ago I got the warning that MM was trying to change IE settings: block or not block. The first time I said block after which MM would not connect to the bank's website. I got the message again and did not allow the block and I still can't connect to the website while in the register. Any suggestions? ...

usb device not recognized
My computer is not recognizing any devices I plug into the USB ports. I can charge my cell phone, but my mouse, printer, and external HD don't work. Thanks in advance. :( -- Jojo89 ------------------------------------------------------------------------ Jojo89's Profile: http://forums.techarena.in/members/186318.htm View this thread: http://forums.techarena.in/windows-xp-support/1307545.htm http://forums.techarena.in ...

Trend Micro Community website
It's been a long time coming, but this should be great self-help. http://community.trendmicro.com -- ----------------------------------------------- Les Connor [SBS MVP] ...

IE8 Restore Links
I wonder if there is a fix for IE8 not being able to properly restore links upon reopening. This works wonderfully in FireFox but IE8 falls short and I typically have both browsers open with several tabs. A typcial scenario might be that I update windows while using IE8 and after updating I'm asked to reboot the system so I do. Upon coming out of reboot, all of my open tabs in IE8 are lost (well not lost, I can reopen them from memory). IE8 will ask if I want to open the previous tabs and I say yes but this doesn't lead to all previous tabs being opened. Is there a f...

Ole Server isnt recognized
When I try to create a Pivot Table from a query I get a message that hte Ole Server isnt registered and MS Access cannot communicate with the Ole server. It worked yesterday. Any ideas? I did a detect and repair using my Office 2002 disk. ...

IE8 and ActiveX Control issues.....
I've recently upgraded from IE7 to IE8, and I'm running Windows XP with SP3. My problem with IE8 stems from using Facebook. Whenever I try to upload photo's, first, I'm told I must install ActiveX Controls, and all of a sudden, an error message pops up. The message says, and I quote; "iexplore.exe - Application Error The instruction at "0x10160068" referenced memory at "0x10160068". The memory could not be "written". Click on OK to terminate the program Click on CANCEL to debug the program" When I click on OK, all the p...

OWA
I am wondering how many of you have your OWA available on the public internet. And what you do to protect it, any issues. So that corporate users can get email from any web kiosk or PC HTTPS through Firewall to IIS/Exchange server. Port 443 >-----Original Message----- >I am wondering how many of you have your OWA available on the public >internet. And what you do to protect it, any issues. So that corporate users >can get email from any web kiosk or PC > > >. > Firstly, I'd suggest implementing Exchange 2003 OWA if you can. The forms-based authentication fea...

IE8 Accelerator issue
Hi, I just got IE8 last week and I immediately went out and went out and built myself some nifty new accelerators. I have made about 5 of them and most of them work just fine, but one of them seems to sometimes cause all accelerators to fail when it is set as the default in its category. Everything seems fine when it is not the default. When it is default, I still get the blue arrow thingie, but it shows nothing when I click on it. This effect seems to also be linked to the page I am on when I have it try to use it. For example, no accelerators work from http://www.micros...

Tab feature in IE8
I just updated to IE8 and am using XP SP3. The new Tabs feature is driving me nuts because it won't let me separate consecutive screens; it puts everything in tabs and only lets you look at one screen at a time. Here's my problem: In IE7, if I have a series of thumbnail photos and I select one of them, I can move that resulting large image to my other monitor and stll see the thumbnail photos on the first monitor, which is what I wnat to be able to do. But in IE8, instead of ADDING a screen, it REPLACES THE SCREEN, and just adds a tab, so I can only look at one imag...

GP 8 doesn't recognize SQL 2005
I am attempting to move GP 8 from a Windows 2000 server with SQL server 2000 to a SBS 2003 server with SQL 2005 (the version that comes with SBS 2003 Advanced). After installing GP 8, I try to login and I get an error indicating I don't have the right version of SQL and I need to "upgrade" to SQL 7. Obviously GP 8 doesn't recognize SQL 2005. Is there a patch or some way around this? I suppose I could uninstall SQL 2005 and install SQL 2000. I have a small organization with few users - performance is not an issue. And could someone give me a link to documentation r...

How do I reference a Website project
I am working on an existing asp.net website project (not a web application project). I want to add a unit test project to the solution, but I don't know how to reference this website project in my unit test project. It is easy if it were a web application project because I could select from the project tab. This website project does not show up in the project tab. I am talking about the project tab in the Add Reference dialog box. Any idea? Thanks. On Mar 3, 5:46=A0pm, niberhate <gnewsgr...@gmail.com> wrote: > I am working on an existing asp.net website project (n...

i think u should try these websites! ;) #5
go to this url: a) http://offto.net/forexkiss1/ b) http://offto.net/5technic1/ c) http://offto.net/50weeksforex1/ d) http://offto.net/makemoneyfirst1/ e) http://offto.net/cashsecret1/ f) http://offto.net/millionairesecret1/ g) http://offto.net/luxuryhomes/ h) http://offto.net/forextrader1/ well, these are just my suggestions.. i dont get any commissions for promoting these websites to you. good luck! ;) ...

Your own Website On .WS Domain Before it's too Late.
UNLIMITED GLOBAL POTENTIAL I've been Internet marketing for 5 years now, and nothing had ever caught my attention like GDI. Just 5 months ago, I dropped everything else I was doing to concentrate on this business because I saw the immense power in your product and your marketing system. I can't tell you how glad I am that I did. My earnings for the last 30 days are approaching $8,000, and it's all from a simple, proven business that didn't cost me a dime to start. This unlimited global potential of this business is staggering, and anyone can do it. I'm having a blast workin...

DEP and IE8 under XP
After a hardware upgrade (to an Athlon II x2 Regcor 245 chip and new motherboard), I'm struggling with a DEP-related problem. Running XP SP3 and IE8. The new chip is hardware DEP capable; the old one wasn't. The DEP is set to "protect critical programs," if I recall the wording correctly, not to protect all programs. Although the latter setting is supposedly the default, the "critical programs" setting showed the radio button when I looked at the DEP settings the first time. There is only one problem I've found (...my wife has found -- it's h...

WMP 12 on Windows 7
I am attempting to get all my digital media centralized and organized, got all the DVD ripped into Media Center now I am attempting to get my music synced as well. Problem: Windows Media Player and Media Center is not picking up the mp3's in their respective locations. I have mapped and remapped them to the approriate location and it isn't pulling them into the library. Ran the MS diagnostics via troubleshooting on both the library and media player. It states I have a corrupt media library, and it gives me no hints on how to correct the issue. Any suggestions? ...

BUG? Windows 7/64bit and IE8/32bit
Hi, Just 2 short weeks ago I installed Windows7 64bit on my nice and shiny new NB and already my nerves are on edge because of IE8's weird behaviour. Since IE8/64 does not support Flash I was forced to switch to IE8/32 and that's when the trouble started. It does not seem possible to open any new window or tab from the context menu. i.e. right-clicking on a link and choose "open link in new tab". A new tab is created alright, but it hangs and hangs and hangs and never shows any content. I either have to click a link directly - which works but will "lose&qu...

can't find file when trying to open IE8
When executing IE8, I get this error message: Can't find file:///c:/Program%20files/AOL%20Toolbar/welcome.html. Make sure the path or the Internet address is correct. After acknowledging this error message, IE8 does open up but won't navigate to the home page, it just shows this error again. If I hit the Home button, it does indeed work and goes to the home page. I can navigate anywhere I need to go, but just wondering how to correct this error on it's execution? Rockitman <Rockitman@discussions.microsoft.com> wrote: > When executing IE8, I ...

subreport not recognizing query reference
I have a form that once filled in completed opens a report. the report has a subreport. I keep the completed form open until after the report has successfully displayed. The main report is opened using the DoCmd.OpenReport function. The subreport contains data from an existing table in the DB. The subreport content is selected based on a query that contains a reference to a data value on the still open form. The format for the reference is: [forms]![formname]![fieldname] When the subrport is being opened it doesn't recognize the reference and prompts ...