moving data from one server to another with difference in collatio

Hi all 

I am facing a problem...which is summed up as follows...I am moving data 
from one server to another....they both have GP 8.0 and SQL 2000 installed on 
same plateform..however the SQL collation is different...the new server has 
Arabic collation which we want it to be like this...and the old server has 
English collation...so taking a backup and restoring it won't work...so I 
used DTS to transfer the data and I succeeded up to this step....however when 
I try to logon on GP with the ‘sa’ user...I get this error 
“Your SQL Server Login record is not a valid user record in great plains. 
Enter a different login or contact your Great Plains system administrator"

So can anyone tell me how can I solve this or how can I move the data from 
one server to another and change the collation to match the destination 
collation and not the source????

Thanks in advance
0
mskaldas (2)
7/24/2005 10:20:01 AM
greatplains 29623 articles. 6 followers. Follow

5 Replies
565 Views

Similar Articles

[PageSpeed] 15

When moving data from one server to another, all user-id values will change. 
They will appear alright when you first look at them but the Id's behind the 
scenes will be different. You will have to use the SQL Server Enterprise 
Manager to remove the users from the database and then put them back in 
again. Make sure that logins have been created for each user.

"mskaldas" <mskaldas@discussions.microsoft.com> wrote in message 
news:A48BA1FA-0C1F-4284-8FF9-0C130F39E7D2@microsoft.com...
> Hi all
>
> I am facing a problem...which is summed up as follows...I am moving data
> from one server to another....they both have GP 8.0 and SQL 2000 installed 
> on
> same plateform..however the SQL collation is different...the new server 
> has
> Arabic collation which we want it to be like this...and the old server has
> English collation...so taking a backup and restoring it won't work...so I
> used DTS to transfer the data and I succeeded up to this step....however 
> when
> I try to logon on GP with the 'sa' user...I get this error
> "Your SQL Server Login record is not a valid user record in great plains.
> Enter a different login or contact your Great Plains system administrator"
>
> So can anyone tell me how can I solve this or how can I move the data from
> one server to another and change the collation to match the destination
> collation and not the source????
>
> Thanks in advance 


0
AAinTX (120)
7/25/2005 1:01:48 PM
Dear Thomas 

thanks for replying...i succeeded in doing what u mentioned about the users 
but what about the 'Collation'

thanks

"Thomas R. Moore" wrote:

> When moving data from one server to another, all user-id values will change. 
> They will appear alright when you first look at them but the Id's behind the 
> scenes will be different. You will have to use the SQL Server Enterprise 
> Manager to remove the users from the database and then put them back in 
> again. Make sure that logins have been created for each user.
> 
> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message 
> news:A48BA1FA-0C1F-4284-8FF9-0C130F39E7D2@microsoft.com...
> > Hi all
> >
> > I am facing a problem...which is summed up as follows...I am moving data
> > from one server to another....they both have GP 8.0 and SQL 2000 installed 
> > on
> > same plateform..however the SQL collation is different...the new server 
> > has
> > Arabic collation which we want it to be like this...and the old server has
> > English collation...so taking a backup and restoring it won't work...so I
> > used DTS to transfer the data and I succeeded up to this step....however 
> > when
> > I try to logon on GP with the 'sa' user...I get this error
> > "Your SQL Server Login record is not a valid user record in great plains.
> > Enter a different login or contact your Great Plains system administrator"
> >
> > So can anyone tell me how can I solve this or how can I move the data from
> > one server to another and change the collation to match the destination
> > collation and not the source????
> >
> > Thanks in advance 
> 
> 
> 
0
mskaldas (2)
7/25/2005 1:18:02 PM
There is a good article on the Microsoft Web Site in dealing with different 
collating sequences.

http://support.microsoft.com/default.aspx?scid=kb;en-us;325335

I am running an Albanian instance of Great Plains with no issues.

"mskaldas" <mskaldas@discussions.microsoft.com> wrote in message 
news:69E35AC2-50D3-4865-9C3F-6E6E7CA42941@microsoft.com...
> Dear Thomas
>
> thanks for replying...i succeeded in doing what u mentioned about the 
> users
> but what about the 'Collation'
>
> thanks
>
> "Thomas R. Moore" wrote:
>
>> When moving data from one server to another, all user-id values will 
>> change.
>> They will appear alright when you first look at them but the Id's behind 
>> the
>> scenes will be different. You will have to use the SQL Server Enterprise
>> Manager to remove the users from the database and then put them back in
>> again. Make sure that logins have been created for each user.
>>
>> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message
>> news:A48BA1FA-0C1F-4284-8FF9-0C130F39E7D2@microsoft.com...
>> > Hi all
>> >
>> > I am facing a problem...which is summed up as follows...I am moving 
>> > data
>> > from one server to another....they both have GP 8.0 and SQL 2000 
>> > installed
>> > on
>> > same plateform..however the SQL collation is different...the new server
>> > has
>> > Arabic collation which we want it to be like this...and the old server 
>> > has
>> > English collation...so taking a backup and restoring it won't work...so 
>> > I
>> > used DTS to transfer the data and I succeeded up to this 
>> > step....however
>> > when
>> > I try to logon on GP with the 'sa' user...I get this error
>> > "Your SQL Server Login record is not a valid user record in great 
>> > plains.
>> > Enter a different login or contact your Great Plains system 
>> > administrator"
>> >
>> > So can anyone tell me how can I solve this or how can I move the data 
>> > from
>> > one server to another and change the collation to match the destination
>> > collation and not the source????
>> >
>> > Thanks in advance
>>
>>
>> 


0
AAinTX (120)
7/25/2005 2:52:46 PM
I've never tried changing the collation of a backup database before but 
Microsoft has released articles that you can always change the collation at 
DB level and column level without resintalling SQL Server [if it is sql 
server 2000 or above]

"Thomas R. Moore" wrote:

> There is a good article on the Microsoft Web Site in dealing with different 
> collating sequences.
> 
> http://support.microsoft.com/default.aspx?scid=kb;en-us;325335
> 
> I am running an Albanian instance of Great Plains with no issues.
> 
> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message 
> news:69E35AC2-50D3-4865-9C3F-6E6E7CA42941@microsoft.com...
> > Dear Thomas
> >
> > thanks for replying...i succeeded in doing what u mentioned about the 
> > users
> > but what about the 'Collation'
> >
> > thanks
> >
> > "Thomas R. Moore" wrote:
> >
> >> When moving data from one server to another, all user-id values will 
> >> change.
> >> They will appear alright when you first look at them but the Id's behind 
> >> the
> >> scenes will be different. You will have to use the SQL Server Enterprise
> >> Manager to remove the users from the database and then put them back in
> >> again. Make sure that logins have been created for each user.
> >>
> >> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message
> >> news:A48BA1FA-0C1F-4284-8FF9-0C130F39E7D2@microsoft.com...
> >> > Hi all
> >> >
> >> > I am facing a problem...which is summed up as follows...I am moving 
> >> > data
> >> > from one server to another....they both have GP 8.0 and SQL 2000 
> >> > installed
> >> > on
> >> > same plateform..however the SQL collation is different...the new server
> >> > has
> >> > Arabic collation which we want it to be like this...and the old server 
> >> > has
> >> > English collation...so taking a backup and restoring it won't work...so 
> >> > I
> >> > used DTS to transfer the data and I succeeded up to this 
> >> > step....however
> >> > when
> >> > I try to logon on GP with the 'sa' user...I get this error
> >> > "Your SQL Server Login record is not a valid user record in great 
> >> > plains.
> >> > Enter a different login or contact your Great Plains system 
> >> > administrator"
> >> >
> >> > So can anyone tell me how can I solve this or how can I move the data 
> >> > from
> >> > one server to another and change the collation to match the destination
> >> > collation and not the source????
> >> >
> >> > Thanks in advance
> >>
> >>
> >> 
> 
> 
> 
0
Dukester (155)
8/1/2005 7:38:02 PM
Yes, you should be able to accomplish this using the technique described in 
the article.

http://support.microsoft.com/default.aspx?scid=kb;en-us;325335

"Dukester" <Dukester@discussions.microsoft.com> wrote in message 
news:C0A39997-09EE-41F8-8277-286021F879BC@microsoft.com...
> I've never tried changing the collation of a backup database before but
> Microsoft has released articles that you can always change the collation 
> at
> DB level and column level without resintalling SQL Server [if it is sql
> server 2000 or above]
>
> "Thomas R. Moore" wrote:
>
>> There is a good article on the Microsoft Web Site in dealing with 
>> different
>> collating sequences.
>>
>> http://support.microsoft.com/default.aspx?scid=kb;en-us;325335
>>
>> I am running an Albanian instance of Great Plains with no issues.
>>
>> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message
>> news:69E35AC2-50D3-4865-9C3F-6E6E7CA42941@microsoft.com...
>> > Dear Thomas
>> >
>> > thanks for replying...i succeeded in doing what u mentioned about the
>> > users
>> > but what about the 'Collation'
>> >
>> > thanks
>> >
>> > "Thomas R. Moore" wrote:
>> >
>> >> When moving data from one server to another, all user-id values will
>> >> change.
>> >> They will appear alright when you first look at them but the Id's 
>> >> behind
>> >> the
>> >> scenes will be different. You will have to use the SQL Server 
>> >> Enterprise
>> >> Manager to remove the users from the database and then put them back 
>> >> in
>> >> again. Make sure that logins have been created for each user.
>> >>
>> >> "mskaldas" <mskaldas@discussions.microsoft.com> wrote in message
>> >> news:A48BA1FA-0C1F-4284-8FF9-0C130F39E7D2@microsoft.com...
>> >> > Hi all
>> >> >
>> >> > I am facing a problem...which is summed up as follows...I am moving
>> >> > data
>> >> > from one server to another....they both have GP 8.0 and SQL 2000
>> >> > installed
>> >> > on
>> >> > same plateform..however the SQL collation is different...the new 
>> >> > server
>> >> > has
>> >> > Arabic collation which we want it to be like this...and the old 
>> >> > server
>> >> > has
>> >> > English collation...so taking a backup and restoring it won't 
>> >> > work...so
>> >> > I
>> >> > used DTS to transfer the data and I succeeded up to this
>> >> > step....however
>> >> > when
>> >> > I try to logon on GP with the 'sa' user...I get this error
>> >> > "Your SQL Server Login record is not a valid user record in great
>> >> > plains.
>> >> > Enter a different login or contact your Great Plains system
>> >> > administrator"
>> >> >
>> >> > So can anyone tell me how can I solve this or how can I move the 
>> >> > data
>> >> > from
>> >> > one server to another and change the collation to match the 
>> >> > destination
>> >> > collation and not the source????
>> >> >
>> >> > Thanks in advance
>> >>
>> >>
>> >>
>>
>>
>> 


0
AAinTX (120)
8/2/2005 1:40:24 PM
Reply:

Similar Artilces:

Outlook Live 2003 re: reply to msg sent to different e-mail account
Issue: I want a different e-mail account to display to recipient I'm just subscribed to Outlook Live and using Outlook 2003. I simply want to configure Outlook 2003 as I have my Outlook Express configured (ie receipient sees the same "reply to" e-mail address no matter which e-mail account I use to send the original e-mail). For my POP3 account, I easily configued Outlook 2003 to work using a different "reply to" address. However, for the Hotmail account (http radio button) I don't have the same options available to change the "reply to" address. Rev...

RDP incoming not working on Server 2003
I have a server running Server 2003 Standard which has been running just fine for some time but this week a new problem has arisen. I cannot establish an RDP session with it, no remote system on its subnet can even make an initial RDP connection at all. On the server itself, I can RDP out to any PC on the subnet with no problem. I've also looked all through the Event Logs and there are no errors at all that have anything to do with this or at the times I've tried to connect from a remote PC. I checked over and over to make sure Remote Connections are allowed in My ...

Microsoft CRM server is not responding
Hi, Workflow Manager write: The specified Microsoft CRM server is not responding. This might happen if it is currently unavailable, it is not a Microsoft CRM server, or you are not a valid user. Fro more information, contact your system administrator. How fix it? In IE i can logon to CRM. ----- wbr, Eugene I've resolved this problem by restoring the metabase with the original version in IIS Regards Edgard Eugene wrote: > Hi, > > > Workflow Manager write: > > The specified Microsoft CRM server is not responding. This might happen if > it is currently un...

All macros failing part way through with different error messages
All the macros I have in various workbooks are failing - usually part-way through - with different error messages each time. When I check the debugger and try to edit the text, there seems no reason why there should be a problem. The macro has so far stopped on instructions to : - open a workbook - select a worksheet - paste a column in a different place Several times the macro has just stopped running without completing and without showing an error message. I cannot run a host of urgent daily reports without using the macros. Please help! NO way to help unless you tell us exactly...

Pass Through to SQL Server Optimization Questions
On an autoexec function several recordsets are opened. Some are queries to local tables, some are to sql server tables. I have been trying to optimize performance but I haven't seen much difference in speed between queries run directly against linked SQL Server tables vs pass through queries. Here is my code for creating the pass throughs (I have another function OpenRecordSetLocal that handles queries to tables within the frontend. The ODBC connection string resides in the query Q_PassThrough. Am I missing something key? Is there a better way to do this? Thanks. Function OpenRecord...

converting tabular structures in a Word document into an actual table or reading data from the tabular structures using VBA code
I have a macro which can read the last cell/column of all tables in a Word 2003/2007 document and store the data in an MS-Access table. But, some Word documents have the data in structures like a table format but are not actually tables. The structure looks like a table, but the table borders are actually line connectors. These documents were created by a software(VeryPDF PDF to Word converter) which converted the PDF documents(the original format these documents were) into Word documents. 1. Is there a way I can convert/replace the tabular structures with actual tables in Word so t...

Twist Data?...
Hi all... I've got the following in a dataset: 19 30 1200 FI FI 20030906 36 19 30 1324 FI FI 20030906 36 and I want the following result: 19 30 1200, 1324 FI FI 20030906 26 Any guess on how to do this? thanks much!... Hmmm... Not quite clear: The data is arranged in columns, I assume It looks as if both items in the same column are the same, you want just one item, otherwise the one in the top row first, then the one from the bottom row. But what about the last 36s that should yield 26? Typo? Does the dataset have more columns or more rows or both? And how big is it?...

moving payables data from open to history
Hello: A client says that someone imported data about a year or two ago into Great Plains from their AS400. Many payables documents that were imported should have been coded during the import as open, instead of history. The client knows that she can take care of this herself within two hours, by simply turning off the posting to the GL and entering and posting the payables documents to move them to history. But, she is wondering if there is a quick and easy way to do this on the back-end. I'm familiar with the open and history payables tables within GP. And, I know through a T...

Excel moving horizontal columns to vertical
I am trying to find a simple way of moving data in horizontal columns (referencing the key in column 1) to vertical colums (still referenceing the same key). This would mean automatically repeating the values in column one for every entry in the moved columns. I can do this through the pivot table, but this is a long drawn out process. Any ideas I'm not sure if this will work for you, but you can try this: - Highlight & copy on the horizontal value you want to make vertical - Now highlight the vertical area you want these value to got - Right Click when highlighted & choose...

Yet another duplicate record dilemma
I have a table with records where one field are duplicates. I'm able to query to find duplicates and delete them, however what I need to do is find the duplicates, produce a total from another field, delete the duplicates and update the record field with the new total. Use the Find duplicates wizard, the build an Update query and either add to the field: Update MyTable Inner Join Querty1.ID On MyTable.ID Set MyField = MyField + Query1.MyField or just update it: Update MyTable Inner Join Querty1.ID On MyTable.ID Set MyField = Query1.MyField Then delete the duplicate data. -- Ar...

NNTP move to Exchange?
Hi, I'm having a problem with getting a NNTP feed from a INND 2.2.1 server to Exchange 2003; are there any known issues here? Has anyone done this type of migration before? What issues did you encounter? It seems as if Exchange just wants to pull down a few of the groups (of which we have over 100 internal) and even with that, not even pull all of the messages in from those few groups (it usually gets a few hundred messages). I'm using the basic NNTP wizards but everything looks to be configured correctly. Thanks, Dan ...

merging 2 cells without losing data?
How can I merge 2 cells without losing data from the other cell? Hi Bob Not possible I'm afraid. Try placing the dat from both cells into one and use "Center across selection" under Format>Cells>Alignment Merge cells always end up causing grief. they are best avoided. ***** Posted via: http://www.ozgrid.com Excel Templates, Training & Add-ins. Free Excel Forum http://www.ozgrid.com/forum ***** "bob" <bobree@hotmail.com> wrote in message news:%23JuOM9HGEHA.2308@tk2msftngp13.phx.gbl... > How can I merge 2 cells without losing data from the other...

Transformation of data into columns
Hi, I have the data from a flattened spreadsheet in a table in the following form: f1 f2 f3 period to: Scheme1 Scheme2 31/01/2005 Net Gross 28/02/2005 Net Gross 31/03/2005 Net Gross 30/04/2005 Net Gross 31/05/2005 Net Gross 30/06/2005 Net Gross 31/0...

How can I sort duplicate text data in excel?
I have a large list of noames that I need to make sure that none of them are duplicated. Is there a way to have excel check it quisker than me reading every name until I find a duplicate? After selecting your data go to filter Advanced filter and check "Unique records only" You can even copy it to another area all uniques entries if you want to ... "TinaScheu" <TinaScheu@discussions.microsoft.com> wrote in message news:0399D580-7E69-4DF0-A969-E7FC5F777C70@microsoft.com... >I have a large list of noames that I need to make sure that none of them >are >...

Problems Converting Data from Quicken 2001 Deluxe to MS Money
Hello, I have a relatively new Compaq Desktop (2.5 GHz Celeron with 512 MB RAM). I have a Viewsonic Pocket PC and I wanted to use it to track my financial data so I purchased Money 2003 Standard. I tried several times to convert my Qucken Data (it's a big file--I've been using Quicken since 1995). My Quicken program is Quicken 2001 Deluxe. Anyway, the MS Money program started to convert and after a few minutes said: "Your Quicken file could not be converted. Money could not convert your Quicken file. You might have run out of disk space or system memory. Try closing othe...

Trying to create an Update query based on HR data to find upline V
Hi All, looking for some advice. I have an HR table that contains employee information but does not contain management chain info. Basically i am trying to determine who the employees upline VP is. The fields i have to work with are [Employee Name], [Manager Name] and [Job Title]. I figure the logic would be to check the employees' manager and if the manager is a VP (based on job title), return the manager's name to a field called [VP]. If the manager is not a VP then check that manager's manager, so on and so forth until a VP is found. Any ideas would be much appr...

Data Validation List not showing
I'm using Excel 2003. My data validation lists have stopped working on one sheet in my workbook. It is working on all other sheets. I have googled the problem and found the following advice: 1. Make sure freeze panes is off.... check. 2. Select "Show All" under Tools->Options->View->Objects ... check. The problem remains. Any ideas? "Stopped working" doesn't do much to describe your problem. When you select one of the "stopped working" Data Validation cells, do you see the drop-down arrow to the right of the cell? When you select t...

Insert,Update Data in sage (MS Access Linked tables) using Vb.net form
Hi folks, I am developing application using vb.net which requires integration with SAGE LINE 50 (Accounting software ) V11... The data which SAGE is using is MC ACCESS 2003 database... with linked tables in it... Now I Have developed the Sage connection using ODBC which works fine when reading the record but cannot Add or Update record into the Linked tables.... When i debug the program the error is at the line where it has... <br> MyodbcCommand.ExecutenonQuery() <br> Can anybody Help ????? -- Message posted via AccessMonster.com http://www.accessmonster.com/Uwe/Forums.aspx/acce...

Outlook 2003: Most messages are moved to junk folder
Guys, I am getting a lot of spam recently, at least looking at the numbers of mails in my junk folder. However, it turns out that these messages are not spam at all, but just regular messages (even from the same domain), that should remain in the regular inbox. Even when I identify a message as 'Not spam', then subsequent messages from that sender keep popping up in the junk folder. Obviously I have changed the junk mail settings to 'No automatic filtering' but Outlook keeps thinking it is smarter than I am. Any idea? Googled the internet already but couldn't find anoth...

how to config Server for one user which has 2 mail address.
we have one NT4.0 + Exchange 5.5 Server "A" Email abc@xxx.com.cn ��and another windows2003 + exchange 2003 Server "B" abc@cn.xxx.com user name is same in A B��Mx record was be set ,question is how to config Exchange 2003 to receive down the mail to Server A , because of we need to replace A with B. thanks a lot. E2K3 setup guides you through common scenarios (like yours) pretty much holding your hand - on welcome screen tell it that you have existing E55 org and want to join it, then follow on-screen instructions. Having usable backup of Exchange databases and AD i...

How to make a Add key disabled after adding one record unless
Hi, I have a form where I am adding records. There are two boxes where one has to put the lineitemnumber and another box where one has to put the description. Unless the above two boxes are filled in the Add command box need to be disabled. Now, the problem is after adding one record the Add button is enabled and I cannot disable it. I would appreciate any help to solve this. The error message is: The methos is not supported The following is the code: Private Sub cmdadd_Click() On Error GoTo Err_cmdadd_Click If (IsNull(Me.LineItemID) = True) Or (IsNull(Me.Description) = True) Then ...

Dropped connection to POP3 servers
Just installed Office 2003 under XP Home. Outlook is dropping connection to POP3 servers, I check 2 different servers with a S/R. Both fail at the same time, never separately. Sometimes I can exit Outlook gracefully but a reboot is required to get Outlook to work again. Sometimes locks entire system and have to powerdown manually. Pattern not fully determined but it appears to happen when there is other activity to the internet that is going to specific servers using an ID and password. I use Medved Quotetracker with E*Trade quotes (requires ID). If I bring up Quotetracker, Ou...

Messenger emoticons
I have changed laptops and I did grab the old laptops custom emoticons folder (all in dt2 and id2 file endings.) But when i copy everything in the folder and add it to my new laptops custom emoticons folder... they get added (i.e. show up in the folder) but the images/gifs or names dont show up on the actual msn... *what gives*? Do I have to change the dt2 endings to gif or jpeg and go to "create" in msn for each of them to add them in? (I tried with one and it worked) Only problem is i have alot, like 203 dt2 files so changing the ending to .gif and adding each singu...

How Can I Control When Messages are Downloaded from Server
I have the box "Check for messages every ___ minutes" unchecked (tools/options/general). Yet seemingly randomly, messages get downloaded a couple of times a day without my clicking "Sync." This is problematic due to the way I share the computer. Is there another setting I need to keep this spontaneous downloading from occurring? "Gripper" <Gripper@discussions.microsoft.com> wrote in message news:F22A9D3A-AFB5-4C85-B94B-79B109E4829E@microsoft.com... > I have the box "Check for messages every ___ minutes" unchecked > (too...

Removing Last 5.5 Server that has an IMC
I am following the steps in the article: http://support.microsoft.com/kb/883407/ before removing my last 5.5 server and moving the smtp services over to my 2003 server. The scenario that applies is single\last 5.5 server (it is a single AND last :) Step 3 - verify the smtp connector is seen in your exchange server 5.5 configuration - is the step that keeps failing. I have repeated step 2 now a couple of times and waited for about 3 hours now and the connection still does not show up. I also see no obvious (or any) errors in the event log on my 5.5 server. if I can successfully send a...