macro to login GP using Window XP Schedule Tasks stopped working

I have create a batch file that runs a macro to login to Great Plains and 
then print out report to a text file then logs out of Great Plains.  This is 
run every night on the server so I use the 'Schedule Tasks' in Window XP to 
do this.  I normally logon to the server using Remote Desktop Connection to 
see if it is running. I actually see GP being login to, print the report & 
then logs out.

It has been working fine about 90% of the time for the last 2 months.  But I 
sometime would get an "Error:   Field on window is inactive or disabled.  
Last Line:    20".  In my macro the line #19 is "NewActiveWin dictionary 
....... "  and at line #20 is "MoveTo field '(L) Print Report BDL' item 0".  
I'm not sure why it is doing this. Can't find any solution anywhere.  

Now all of a sudden I can't see my macro running at all.  I look into the 
Schedule Task window and it says that it is "running" but nothing comes on 
the screen anymore.  I also look at the Task Manager to see if Great Plains 
is running but nothing.  I'm finding out that my macro is somehow login in to 
GP because when i try to login to GP using the user ID that I used in the 
macro, I get message that that user is alread logged in.

Thanks in advanced.


0
quoc (7)
8/7/2007 3:28:02 PM
greatplains 29623 articles. 6 followers. Follow

1 Replies
737 Views

Similar Articles

[PageSpeed] 5

It sounds like your user id didn't properly get logged out at some
point. Login to GP on the box, choose to delete the session when
asked, logout and then rerun your macro. That should get it going
again.

As for the other, I have a few macro's that occasionally exhibit
similar behavior. I'm not sure why either. My only guess is that
occassionally there's a delay in processing and the macro fires it's
request before the form is actually available, but I'm guessing.

Mark (DynamicAccounting.net)




On Aug 7, 11:28 am, quoc <q...@discussions.microsoft.com> wrote:
> I have create a batch file that runs a macro to login to Great Plains and
> then print out report to a text file then logs out of Great Plains.  This is
> run every night on the server so I use the 'Schedule Tasks' in Window XP to
> do this.  I normally logon to the server using Remote Desktop Connection to
> see if it is running. I actually see GP being login to, print the report &
> then logs out.
>
> It has been working fine about 90% of the time for the last 2 months.  But I
> sometime would get an "Error:   Field on window is inactive or disabled.  
> Last Line:    20".  In my macro the line #19 is "NewActiveWin dictionary
> ...... "  and at line #20 is "MoveTo field '(L) Print Report BDL' item 0".  
> I'm not sure why it is doing this. Can't find any solution anywhere.  
>
> Now all of a sudden I can't see my macro running at all.  I look into the
> Schedule Task window and it says that it is "running" but nothing comes on
> the screen anymore.  I also look at the Task Manager to see if Great Plains
> is running but nothing.  I'm finding out that my macro is somehow login in to
> GP because when i try to login to GP using the user ID that I used in the
> macro, I get message that that user is alread logged in.
>
> Thanks in advanced.


0
mpolino (496)
8/7/2007 8:22:27 PM
Reply:

Similar Artilces:

Macro Function
How do I create a new function in Excel? -- Tomas Hi Thomas, You can have a look at this link: http://www.exceltip.com/st/Writing_Your_First_VBA_Function_in_Excel/631.html Regards, Bondi THANKS!!!! Very good tip -- Tomas "Bondi" skrev: > Hi Thomas, > > You can have a look at this link: > > http://www.exceltip.com/st/Writing_Your_First_VBA_Function_in_Excel/631.html > > Regards, > Bondi > > ...

Error while opening GP windows from BP
Hi all . I am getting an issue when we click 'Create Journal entries' item in the Financial Back Office Tasks webpart in Business Port4.0. "null-CWTSSession.openCannes:'oWTS' is null or not an object" I done a Terminal Server Setups as per the BP installation Document. Version Details : GP10.0,BP4.0,MOSS 2007 Note : I am getting this even for Administrator Login Regards Sunny Hi Sunny, A simple troublshooting steps: 1. Ensure that you can remotely access the server (where BP is installed) via Remote Desktop Connection (RDP). This will ...

Using MS Access information in Outlook
I have an MS Access DBase that contains our companies contact information. I want to be able to use that information in an Outlook contact folder. I do not want to import the information into Outlook. I want it to be automatically synchronized. Is this possible? Mikeal ...

How to generate XML file as follow, using XmlDocument
Hello, I have to generate XML file as follow, using XmlDocument. <Company> < Employee EID=3D=94111=94 Description=3D=94 xyz=94> <Dept DeptNo=3D=94D10=94> <FirstName> Abhijit </FirstName> <LastName> Babar </LastName> </Dept> <Dept DeptNo=3D=94D20=94> <FirstName> Sahine </FirstName> <LastName> Ghavane </LastName> </Dept> </Employee> < Employee EID=3D=94222=94 Description=3D=94 abc=94> <Dept DeptNo=3D=94D10=94> <FirstName> Swapnil </FirstName> ...

Macro is not logging out of Great Plains
I created a macro to login, run checklinks and then log out. I set it up in the Task Scheduler on my system to run after hours, using a bat file. It worked for several months, and then in January it didn't finish the macro and log out. I would come in the morning, and I would still be logged in and the scheduled task was still running. I had to end task and delete my login in Great Plains. I have tried recreating the macro, I have tried running it on the server, and I am still having the same problem. In most cases, the report is generated - so I know the checklinks are finishing...

How to generate a truly empty cell
"" generates a zero-length string, not a truly empty cell. This is causing problems elsewhere. I'd like to find an output for an IF statement that will give me a truly empty cell. The current formula is: =IF(COUNT(C24:C29)>0,SUM(C24:C29),"") Any ideas? If it involves a macro (as I think it might, having read other posts), please explain how to implement it. Thanks! <This is causing problems elsewhere> It shouldn't. Don't use ISBLANK(A1), use A1="" -- Kind regards, Niek Otten Microsoft MVP - Excel "paulkaye" <paulmjkaye@gm...

Macro
Is it possible to add a macro as a custom POS button? Thank you, Sylvain ...

PatchFactory 2.0 Released. Professional and easy-to-use patch building tool for Win9x/Me/NT/2000/XP.
Description: Professional and easy-to-use patch building environment that can help you to create instant patch packages for software and file updating. Generated patch packages are small size self-extracting executable update programs in a famous installer style with adjustable user-friendly interface and multilingual support. Enhanced with features like easy-to-use interface including a Wizard mode, powerful patch engine, integrated compression technology, adjustable multilingual user-friendly interface of the update program, this program will most definitely become a valuable asset for softw...

Macro for checkbox (2) #2
Hi Still does not work new message is Sub or function not defined. I normaly just record macros so this is a bid more of a chalange Sub Macro1() ' ' If CheckBoxes(46).Value = True Then Range("O54").FormulaR1C1 = "50000" Range("T54").FormulaR1C1 = "4000" Range("Y54").FormulaR1C1 = "4000" Range("AD54").FormulaR1C1 = "4000" Range("AI54").FormulaR1C1 = "4000" Range("AN54").FormulaR1C1 = "4000" Range("AS54").FormulaR1C1 = "...

Why doesn't indirect work with a dynamic range created using offse
Hi Has anyone else experienced this issue or I am doing something wrong. I have a series of dynamic range names defined using offset. For example the name USCities is defined as =offset(AA1,0,0,Counta(AA:AA),1) and the name Europeancities is defined as =offset(AB1,0,0,counta(AB:AB),1) In column A, dataentry into the cells is limited to USCities or Europeancities. In column B, I want to limit data entry to the range name appearing in column A. For example if USCities is selected in A1, data entry in cell B1 is to be limited to those cells forming the USCities range name. I have tri...

Outlook Rules not working with new Exchange Server
We recently (last week) upgraded our Exchange 5.5 server with a new machine running Exchange 2003. Since that change, a few clients who use Outlook Rules to forward messages to other email addresses have noticed that those messages are no longer being delivered. We have clients using Outlook 2000 and some using 2003 - it doesn't seem to matter which version of Outlook that's being used. The rules work just fine for placing specific messages into specific folders, but anytime that a message is supposed to be forwarded to an outside email address, it is never delivered. Any ide...

XP Pro Sp3 DeviceMgr Q re "Non-Plug & Play Drivers"
I'll save a long winded description for now, but essentially as a result of a major trojan virus infection (now deemed clean by Trend Micro), serious damage was done to my network adapters (all showing yellow ! marks) and some of the non-plug and play drivers (e.g., AFD, IPSEC driver, TCP/IP Protocol Driver). My tech friend and the manuf. of the Mavell Yukon PCI/PCI-E controllers have already walked me thru trying to update the drivers from the Marvell site, so the next step seems to be to see if the non plug and play drivers are the underlying culprit. So my initial que...

Create Outlook 2003 Rule using 'Or' operator in 'Sent to' condition
How do I create a rule that uses the 'or' operator in the 'sent to' condition? I actually have a rule like this, but don't know how I created it. In other rules, when I try to add more that one email address or group in 'sent to,' Outlook inserts the 'and' operator. What is the exact rule in full? In general you'd create additional rules but it depends a bit on the condition or action that you are using. -- Robert Sparnaaij [MVP-Outlook] Coauthor, Configuring Microsoft Outlook 2003 http://www.howto-outlook.com/ Outlook FAQ, HowTo, Downloads, Add-Ins ...

Match Duplicate Accounts doesn't work?
I just recently upgarded my Money 2004 to 2006 Deluxe. To take advantage of new features, I started setting up the online services for my checking account. I was able to have Money establish a connection w/ my bank and login w/ my supplied username and password. Then I got to the part where Money asks "Are you already keeping track of any of these accounts ..." - Yes - No - I'm not sure So, I select Yes because I have indeed already set up that account (and have many years worth of data in it!). Then I click thex Next buton whic...

DLookup Not Working
I have a form i want to create a DLookup where I get the Last_Name on the tblUserNameTest when the field txtUser on the active form equals the User_IDon the tblUserNameTest table. I have this and it is not working what am I doing wrong? =DLookUp("[Last_Name]","tblUserNameTest","User_ID = " & [txtUser]) Whatever you can do to help would be greatly appreciated. Thanks. lisa What data type is the field User_ID? Your code indicates it is a numeric data type. If txtUser is a form control on the current form, you should be qualifying it with either Me. or...

Hyperlinks to pdfs and word documents are not working
My Access database was recently upgraded to Access 2007. Now all of the hyperlinks I have to pdfs and word documents are not working. In browsing "external data" I see that I can link to text files and excel files, etc. Please explain why my links to pdfs and word documents no longer are working and how I can fix them. -- Archivist Try to eplain a little more, what do you mean by not working? Do the links react but present you with some kind of warning. In what way were the links created. Have you set the directory where your files reside as trusted in the trus...

How do gift cards work?
I'm new to MS POS 2.0, so please forgive me if this is off base... I want to be able to sell and accept gift cards in my store. I do not want to use pre-loaded Visa cards, but rather just a custom card that I will have someone build for me. What is the right way to go about this? I'm thinking that I need to get cards with a unique code on their mag-stripe which I can register in MS POS 2.0 with an associated $ amount. Is this correct? MS POS doesn't support Gift Cards, only RMS. Craig "Randy M" <RandyMagnuson@hotmail.com> wrote in message news:%23pJNqwRFI...

Permission to use object denied.
I have a user on a Windows 2000 machine with user rights. The user is also running office 97. When he opens a excel speedsheet and Enable's Macros, he gets the following message; "Permission to use object denied". Hi Shannon............ It sounds like there is some sort of link to another workbook that a macro is calling and your user does not have rights to it. I think I would open the book without enabling the macros, and then take a look at them to see if one is trying to do such a thing. hth Vaya con Dios, Chuck, CABGx3 "Shannon" <Shannon507@aol.com>...

Accessing a linked file in a Word document using VBA
Hi - Basic question, in my Word template I have some linked images. I want to use VBA to change the path and filename of some of these links ... can anyone give me a clue as to how I should best do this? Thanks Robin Hi Robin, To see how to paths in Word using vba, check out the macro solution I've posted for implement relative paths at: http://lounge.windowssecrets.com/index.php?showtopic=670027 -- Cheers macropod [Microsoft MVP - Word] "Robin" <Robin@discussions.microsoft.com> wrote in message news:7EA2C548-7D01-4515-BCC8-2EF3210439C9@microsof...

LDAP lookup not working with Outlook 2003
I have recently upgraded to Outlook 2003 and notice that I could no longer resolve names via the LDAP server. I get always get a message that there are too many matches in the Internet Directory. This does not occur with Outlook 2002 or Outlook Express. With these two applications, the name is always resolved in less that 20 seconds. Any ideas? Try a new mail profile. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the Swen virus, all e-mails sent to my actual account will be deleted w/out reading. After searching google.groups...

Windows Resizing
Hello, I have a DLL app that contains a dialog and inside a dialog there is a CWebBrowser2 control. I am trying to make CWebBrowser2 get maximized together with the Dialog so when a user maximizes dialog CWebBroswer2's width and height are changed with Dialog's width and height. Does anybody know how to make it work? Thank you, Victor. Catch the WM_SIZE message in your dialog (This message gets called when the user is changing the size of the dialog box) and change the size of the control accordingly. AliR. "victorsk" <victorsk@discussions.microsoft.com> wrot...

Data validation causing problems when using a data form in Excel 2
I have an Excel 2007 workbook that includes data validation set on a number of cells. When using a data form to enter data and I enter an invalid value on the form field corresponding to one of those cells I receive the validation error dialogue that prompts me to retry. I enter the correct data into that field on the form then close the form. My worksheet only has the data relating to the corrected field entered. All other data entered via the form is not entered onto the worksheet. Is this a bug in Excel 2007? I previously was using Excel 2002 and found that when using a ...

Outlook (and Excel) stops working after MSXML installation
I installed MSXML 4.0 as per the "critical updates" message on my W98 today. After re-boot, when I try to open Outlook I get message "Unable to open your defauilt mail folder - the information store could not be opened" and then "Would you like to open your default file system folder instead?" - this is no good and I can't find anything. I can't open Excel either, I get messages about Visual Basic and when I close it, I get message "This process will stop the debugger". I now have a shortcut on my desktop "Microsoft MXL 4.0 parser&...

Using Outlook on a MAC
Does anyone know why I can't forward HTML email with Outlook on my MAC? It is received ok but when I forward it, it goes out as text and all the formatting and images are gone. I'd appreciate the help. ...

Using Exmerge in batch-mode doesn't work
Hi there, I want to "backup" the mailboxes from my Exchangeserver to pst-files with Exmerge. I seem to have the same problem though as more people seem to have with the Exmerge utility but I haven't seen any solutions yet :-(. If I walk through the Exmerge steps using the GUI everything seems to go allright. I get a list of mailboxes, I pick the ones I want to export to .pst en Exmerge does it's thing creating a bunch of perfectly healthy .pst's. When I want to use it in batch-mode using MAILBOXES.TXT containing the mailboxes I want to export, Exmerge logs it can...