GP10 security issue

Hi. I just upgraded GP7.5 to v.10. As well as the servers (now its SQL2008 on 
Windows 2008 OS)

I did adding up new users, tasks & roles. When I tried the accessing GP 
using the new users, tasks & roles I created (doing this on the GP server) I 
was successful.

When I go to the workstation & access gp using the same user login, I was 
able to enter the user ID & the password. However, after I selected the 
company and clicked OK, I was prompted "You are not priviledged to open this 
form"

Please help.
0
GPSupport2 (10)
1/28/2009 10:46:01 PM
greatplains 29623 articles. 6 followers. Follow

4 Replies
411 Views

Similar Articles

[PageSpeed] 8

Are the workstations on a Terminal Server?
-- 
Richard L. Whaley
Author / Consultant / MVP 2006-2008
Documentation for Software Users

Get our Free Tips and Tricks Newsletter and check out our books at 
http://www.AccoladePublications.com



"GP Support 2" wrote:

> Hi. I just upgraded GP7.5 to v.10. As well as the servers (now its SQL2008 on 
> Windows 2008 OS)
> 
> I did adding up new users, tasks & roles. When I tried the accessing GP 
> using the new users, tasks & roles I created (doing this on the GP server) I 
> was successful.
> 
> When I go to the workstation & access gp using the same user login, I was 
> able to enter the user ID & the password. However, after I selected the 
> company and clicked OK, I was prompted "You are not priviledged to open this 
> form"
> 
> Please help.
0
info4071 (3004)
1/29/2009 12:23:02 AM
No. The workstations are running on Vista OS 32Bit, ODBC connection.

The server by the way is @64Bit

"Richard Whaley -- MVP 2006-2008" wrote:

> Are the workstations on a Terminal Server?
> -- 
> Richard L. Whaley
> Author / Consultant / MVP 2006-2008
> Documentation for Software Users
> 
> Get our Free Tips and Tricks Newsletter and check out our books at 
> http://www.AccoladePublications.com
> 
> 
> 
> "GP Support 2" wrote:
> 
> > Hi. I just upgraded GP7.5 to v.10. As well as the servers (now its SQL2008 on 
> > Windows 2008 OS)
> > 
> > I did adding up new users, tasks & roles. When I tried the accessing GP 
> > using the new users, tasks & roles I created (doing this on the GP server) I 
> > was successful.
> > 
> > When I go to the workstation & access gp using the same user login, I was 
> > able to enter the user ID & the password. However, after I selected the 
> > company and clicked OK, I was prompted "You are not priviledged to open this 
> > form"
> > 
> > Please help.
0
GPSupport2 (10)
1/29/2009 1:47:01 AM
On Jan 28, 7:47=A0pm, GP Support 2
<GPSuppo...@discussions.microsoft.com> wrote:
> No. The workstations are running on Vista OS 32Bit, ODBC connection.
>
> The server by the way is @64Bit
>
> "Richard Whaley -- MVP 2006-2008" wrote:
>
> > Are the workstations on a Terminal Server?
> > --
> > Richard L. Whaley
> > Author / Consultant / MVP 2006-2008
> > Documentation for Software Users
>
> > Get our Free Tips and Tricks Newsletter and check out our books at
> >http://www.AccoladePublications.com
>
> > "GP Support 2" wrote:
>
> > > Hi. I just upgraded GP7.5 to v.10. As well as the servers (now its SQ=
L2008 on
> > > Windows 2008 OS)
>
> > > I did adding up new users, tasks & roles. When I tried the accessing =
GP
> > > using the new users, tasks & roles I created (doing this on the GP se=
rver) I
> > > was successful.
>
> > > When I go to the workstation & access gp using the same user login, I=
 was
> > > able to enter the user ID & the password. However, after I selected t=
he
> > > company and clicked OK, I was prompted "You are not priviledged to op=
en this
> > > form"
>
> > > Please help.

Are the .set files the same on the workstations and the server?  If
the workstation has product dictionaries loaded that are not loaded on
the server client, you may get this error.
0
katelinn53 (17)
1/29/2009 2:14:32 AM
------=_NextPart_0001_235A0992
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hi There

I would suggest you look at my blog posts on application level security in particular the post on resolve security errors on login. 
Also have a look the latest build 10 of the Support Debugging Tool which has new features specifically designed to make working 
with v10 security much easier. Links below:

Microsoft Dynamics GP Application Level Security Series 
http://blogs.msdn.com/developingfordynamicsgp/archive/2008/11/10/microsoft-dynamics-gp-application-level-security-
series.aspx

How to resolve Security errors on Login
http://blogs.msdn.com/developingfordynamicsgp/archive/2008/11/17/how-to-resolve-security-errors-on-login.aspx

Support Debugging Tool Build 10 released
http://blogs.msdn.com/developingfordynamicsgp/archive/2008/12/18/support-debugging-tool-build-10-released.aspx

David Musgrave [MSFT]
Escalation Engineer - Microsoft Dynamics GP
Microsoft Dynamics Support - Asia Pacific

Microsoft Dynamics (formerly Microsoft Business Solutions)
http://www.microsoft.com/Dynamics

mailto:David.Musgrave@online.microsoft.com
http://blogs.msdn.com/DevelopingForDynamicsGP

Any views contained within are my personal views and not necessarily Microsoft policy.
This posting is provided "AS IS" with no warranties, and confers no rights.  

------=_NextPart_0001_235A0992
Content-Type: text/x-rtf
Content-Transfer-Encoding: 7bit

{\rtf1\ansi\ansicpg1252\deff0\deflang3081{\fonttbl{\f0\fnil\fprq2\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\f0\fs20 Hi There
\par 
\par I would suggest you look at my blog posts on application level security in particular the post on resolve security errors on login. Also have a look the latest build 10 of the Support Debugging Tool which has new features specifically designed to make working with v10 security much easier. Links below:
\par 
\par Microsoft Dynamics GP Application Level Security Series 
\par http://blogs.msdn.com/developingfordynamicsgp/archive/2008/11/10/microsoft-dynamics-gp-application-level-security-series.aspx
\par 
\par How to resolve Security errors on Login
\par http://blogs.msdn.com/developingfordynamicsgp/archive/2008/11/17/how-to-resolve-security-errors-on-login.aspx
\par 
\par Support Debugging Tool Build 10 released
\par http://blogs.msdn.com/developingfordynamicsgp/archive/2008/12/18/support-debugging-tool-build-10-released.aspx
\par 
\par David Musgrave [MSFT]
\par Escalation Engineer - Microsoft Dynamics GP
\par Microsoft Dynamics Support - Asia Pacific
\par 
\par Microsoft Dynamics (formerly Microsoft Business Solutions)
\par http://www.microsoft.com/Dynamics
\par 
\par mailto:David.Musgrave@online.microsoft.com
\par http://blogs.msdn.com/DevelopingForDynamicsGP
\par 
\par Any views contained within are my personal views and not necessarily Microsoft policy.
\par This posting is provided "AS IS" with no warranties, and confers no rights.  
\par 
\par }
------=_NextPart_0001_235A0992--

0
dmusgrav7144 (312)
1/29/2009 3:08:34 AM
Reply:

Similar Artilces:

Clip Art Issue-RPCRT4.DLL
I have a Windows 98 box with Office 2000 and a recent install of Publisher 2000. In Pub, when the user tries to insert clip art, we get an error message as follows: "MSPUB caused an invalid page fault in module RPCRT4.DLL" I haven't found a fix that works yet. Any ideas?? (Don, an uninstall of Pub 2000 is indeed like pulling lawn weeds :) "Invalid Page Fault" Error Message When You Insert ClipArt http://support.microsoft.com/default.aspx?scid=kb;en-us;812081 This does not address Publisher 98 specifically, however it does address Office 2000. -- Mary Sauer MS M...

Exchange 2003 and Outlook 2003 Retrieving mail issues
Help please. We are in the process of upgrading all our users to Office 2003 from 2000. We have Exchange server 2003 sp3 on windows server 2000 sp4. Users are complaining outlook is slow after we upgrade them and they log into outlook 2003. We do not have Cache mode enabled. Our store is 66Gig in size. Could this affect performance. The message displays every so often that outlook is retrieving data and it is slow for some users. Some users have realy large mailboxes i.e. over 500Meg. Has anyone else ever experienced this with outlook 2003 before. thanks -- Kath On Wed, 25 Apr...

Issues with analytical accounting and frx
In the analytical accounting company in FRx, when we pick up the dimension segments in the row format, we only see one or two dimension codes listed in the lookup. I looked at the frx_acct_code_aa table and saw that the dim01_Value is empty for all but 2 entries and the dimenions on these 2 entries is what I am seeing in the lookup. How can I fix this table. The above is happening in the Test environment. The Production environment shows this table correct and I am able to see all the dimension codes in FRx. The test environment company is refreshed every week from Production. I tried...

exchange 5.5 queue issues....
Help, I have an exchange 5.5 box; for only another (4) wks... but I have a ton of SMTP mail stuck in the following folders... C:\exchsrvr\mailroot\Queue I can not delete, as it says there is a sharing violation... what are they from and how do I clear out... thanks for any help AL as far as I know, exhcange 5.5 dont have mailroot folder. can you describe your server setup? Me "Al" <ascssmith@gmail.com> wrote in message news:OMZ8p5dnFHA.4056@TK2MSFTNGP10.phx.gbl... > Help, I have an exchange 5.5 box; for only another (4) wks... but I have a > ton of SMTP mail stu...

CRM 1.2 to CRM 3.0 Upgrade Active Directory Issues
Hi, It was decided to reinstall CRM 3.0 after a successful upgrade from Version 1.2 (Except reporting services). As part of the install a mistake was made and therequired groups for CRM 3.0 upgrade from 1.2 were deleted (PrivUserGroup, SQLAccessGroup, UserGroup, ReportingGroup). We manually recreated them. Now in trying to reinstall CRM 3.0 on an already upgraded and exsitng MSCMR Database, we keep getting stopped at the Verification Tasks under the section of "Microsoft CRM User Input" with a error that "One or more of the Microsoft CRM Groups do not exist". Al...

ItemLookup/PartNumber Issue
I am looking for a SQl script that will move/relink an older part nunber that has history to a new part number that does not. Someone create a partnumber that should have been reserved, but instead was created and has some history and sale transactions. Is this possible to do ? Thanks for your help in advance. ...

Security breach?
Running Exchange 2003, Outlook 2003, 100 internal users, OWA enabled for 700 outside users, with an ISA gateway. Last week an internal user sent an email to himself and blind copied three others, outside our domain, asking for a delivered receipt and a read receipt. An hour later he received a read reply from a person not on the original address list. How is this possible? If one of the three forwarded the email, would the original sender get a read receipt from the forwardee? If not, how else could this happen (sensitive matieral to an unfriendly person) short of someone hacking i...

Historical Stock Status Report as of Specific Date-Issue
Hi, While generating inventory report from report window, if we take any historical inventory report, it shows average unit value for some other day instead of the cut off day for which report has been generated.The Valuation method followed is Average Perpetual. Why is it so and any solution please? Thanks Janakiram M.P. ...

Blue Screen Issues!! HELP!
Hi... I'm getting a bluescreen that never fails to appear right after I log in to my profile. A couple times I was able to dial up and get online and stay on for a half an hour, and then the bluescreen would pop up. I have... Windows XP (media edition) SP3 on a Dell Dimension E520. The bluescreen... Says something about a "wait operation *somethingsomethingsomething* DPC Routine." the error code is STOP: 0x000000B8 I can boot in safe mode just fine. Any help or suggestions is greatly appreciated!! Thanks! RLH If safe mode is available,then once in xp...

Yet another issue
I'm slowly gaining confidence in using Outlook. I'm really grateful for all the help here. In addition to transitioning from Essential PIM, I'm also transitioining from Seamonkey -- a Mozilla-based mail/news/browser combo. I have a large folder with about 200 mails saved. I'd like to bring those mails into Outlook. I'm using WinXP, Outlook 2003. Thanks again! And sorry to be such a pest. -- ------------------------------------------ Jeffrey Needle jeff.needle@gmail.com Which export options are available to you in that program? Which ...

Login issues
After logging into the Bus portal, I go to SITE SETTINGS (we just upgraded to 8.0 with portal and snap in for sharepoint) Manage Business Portal Users, Prompt again for credentials and select add new users. My problem is the screen is too small and I cant resize it to make correct selection. Any thoughts out there to reolve? Hi I am not too sure about resizing the add user wizard. You can add users using the c:\Inetpub\wwwroot\bin\SecuritySetupUtility from the Business Portal server. Regards James "JCooper" <JCooper@discussions.microsoft.com> wrote in message ...

PowerPoint 2007 Printing issues
Hi, This issue has been driving me crazy: we have presentations that have linked excel tables and pictures, and everything looks awesome in print preview and presentation mode, but when I print, some linked excel tables and pictures just show blank. I have played around with it, and the only way to guarantee it prints is to paste everything as Bitmap picture, but we need the linked Excel table function to save tons of time cutting and pasting. As I said, some of the tables will print, but some of them don't, which is driving me nuts, and everything is fine electronical...

Access 2007 Read Only Issue
One of the groups in my company has an MDB file that they are running in Access 2007. Somehow it has not been converted. It will be converted once I can isolate the following problem; When I open the file on my computer, it opens with no problem, When one of the user group opens it, it opens read only. Question - Is there a setting that could be selected on all of there computers that is not selected on mine that would cause this. If not, what should I look for to correct this. As soon as this is resolved, I will convert and split this db file into a Front and Back End convifigu...

GP10 Smartlist problem output to Excel 2010
When we see the listing in the Smartlist, we click the button with Excel logo, to export the listing to Excel, but GP prompt with error message :Unable to start Microsoft Excel http://img137.imageshack.us/img137/4100/errorw.png This is the newly purchased workstation. This is the first computer that is come with Microsoft Office 2010 version, the rest are still using Office 2007. And this new computer has never been successfully launched Excel from the Smartlist. We are wondering if the Office 2010 STARTER edition can work work with Dynamics GP 10 with FP1 SP4. Please advice ...

NTLM issue
I'm using exchange 2003 and I can access a mailbox fine using Outlook 2003. The authentication on Outlook 2003 is set for Kerberos/NTLM Password authentication. If I try with a Outlook 2000 or Outlook 2002 client I am prompted for a username and password and I can't authenticate or access the mailbox. I know the Kerberos authentication setting is the key. That can't be set on Outlook 2000 from the advanced tab. Is there anyway to set Exchange 2003 to use NTLM and Kerberos? Thanks Ask in an Exchange group. --� Milly Staples [MVP - Outlook] Post all replies to the grou...

OWA Security
Hi, I wanted to ask you somethng about OWA. I have Exchange Server 5.5 installed. And my users are constantly being locked out. It seems somehow, someone got a users list, or maybe it is someone who knows the mails of everyone, can this be possible? And if it is so, how can I prevent users to get locked out, and mantain security??? Thanks, Andys ...

Security Role Documentation in GP10
Hi-- Anyone come across a spreadsheet or other documentation regarding the standard roles and tasks in GP 10? I have found Victoria's post on creating a view, but was curious if anyone else has found anything? Thanks! Christina Christina, Thanks for the shout out! :-) This post by Jivtesh might have what you're looking for: http://www.jivtesh.com/2007/11/gp-10-security-excel-sheet-which-has.html -- Victoria Yudin Dynamics GP MVP Flexible Solutions - home of GP Reports http://www.flex-solutions.com/gpreports.html blog: www.victoriayudin.com <turtlesoup00@hotmail.com> wr...

Combo Box Issue
I have made one of my fields in a subform a combo box. When I open the form in form view, everything looks ok, but when I open the drop-down arrow and make a selection, an error window immediately opens. This is the message: You can't assign a value to this object. *The object may be a control on a read-only form. *The object may be on a form that is open in Design view. *The value may be too large for this field. I can hit the Return key and move on to the next field and the selected data stays in the field. Can anyone help in resolving this error? Thanks in advance! ...

Outlook .pst file
It appears that the .pst file keeps growing and growing and growing. Even after "emptying" my deleted items folder (which had about 400 messages in it) the size of my .pst file stayed the same. Can anyone tell me how I can reduce the size of it...without archiving? Again, you'd think that if you got rid of mail, it would get smaller, but that's not the case. Thanks, Greg PSTs do not reclaim space properly on their own. Right click the top level folder and choose properties. Click the Advanced button. Click the Compact Now button. Do this three times. Som,etimes the ...

Cannot Access E-Mail After Security Update
re: Outlook 2003 I ran and installed the most recent security update (see Knowledge Base 892843); ever since, I can no longer send or receive e-mails. I checked all of the settings and nothing seems to have changed. What gives? In news:xIbyf.4948$WY5.1760@newsread2.news.pas.earthlink.net, J-Man <J-Man@yahoo.com> typed: > re: Outlook 2003 > > I ran and installed the most recent security update (see Knowledge > Base 892843); ever since, I can no longer send or receive e-mails. I > checked all of the settings and nothing seems to have changed. What > gives? W...

GetProcAddress issues
Tried to load dll file using "LoadLibrary" and used "GetProcAddress" to get the adderss of a specific function, "fnTestFun". It returned NULL, and "dependancy walker" (%microsoft-visual-studio-home%\Common \Tools\depends.exe) showed that the currupted function name (? fnTestFun@@YAHPAD000000000000PAVTestClass2@@@Z). Tried to use this, "? fnTestFun@@YAHPAD000000000000PAVTestClass2@@@Z" as function name it worked fine. what could be possible causes for this issue? Thanks in advance. On 15 Mar 2007 01:43:58 -0700, "v4vijayakumar" <...

Outlook 2003 Address Book Issues
Before installing Outlook 2003 over Outlook 2000, the Windows Address Book (%ProgramFiles%\Outlook Express\wab.exe) and Outlook were unified in the sense that the Outlook contacts and Address Book held the same entries. So opening the Address Book from the start menu and opening it by clicking the icon in the Outlook tool bar displayed exactly the same list. After the installation of Outlook 2003, the described unification went somewhat out of order: 1. The Address Book displayed by clicking the icon in the Outlook tool bar starts up an address book program different from "wab.exe"....

Outlook 2003 Default Incoming E-Mail Address Format Issue
My company is running Exchange Server 2003 as our Enterprise mail system, and we are using Outlook 2003 as our typical mail client. I have noticed that when receiving external mail (from the Internet), the messages are often listed as being addressed as from a nickname rather than a valid e-mail domain. For example, hypothetical user "John Smith" from company XYZ may use the nickname "Johnny". Typically, when this occurs, the following information can be found in the message header. From: "Johnny" <john.smith@xyz.com> Question - is there any way t...

It is a permission issue! And I've got it sorted
Finally got to the root of the problem... Request for the permission of type System.Net.WebPermission, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed. inside the GetEntity method Fixed it by following: public override object GetEntity(Uri absoluteUri, string role, Type ofObjectToReturn) { if(absoluteUri.Scheme == "http") { System.Net.WebPermission p = new System.Net.WebPermission(System.Security.Permissions.PermissionState.Unrestricted); p.Assert(); return base.GetEntity(absoluteUri, role, ofObjectToReturn); ...

2008 R2 server, scheduled task issue
I have a scheduled task running xcopy. When I run XCOPY manually, it works and outputs data to a log file. the command is xcopy %fromCopy% %toCopy% /Q /E /I /M /Z /Y > xcopy.log When run under a scheduled task, with a local admin account, the log is not updated, although the xcopy works. Why does the log not update? The log file is in the same directory as xcopy. "Rossb2" <Rossb2@discussions.microsoft.com> said this in news item news:7E90646A-3214-4C96-A9BB-BAF5DDDA7C95@microsoft.com... > I have a scheduled task running xcopy. When I run XCOPY manual...