Foreground locking error running scheduled integration

I have a scheduled integration setup that first runs the login to GP, then an 
integration group (2 AR integrations).  I have them set at 5 minutes apart.  
The TK article for this particular error says that the error is because 
"Great Plains is still in the process of launching when the Integration 
Manager starts running."  I then increased the time to 15 minutes 
apart and finally at 30 minutes apart, but the first record of both 
integrations still fails with this error "could not set foreground locking 
value to 0."

How can I get rid of this error?  It only takes less than a minute to 
completely log into GP.  It defeats the whole purpose of a scheduled 
integration when I have to manually re-run each integration every morning.  

0
Luvsql (265)
10/5/2005 1:29:07 PM
greatplains 29623 articles. 6 followers. Follow

3 Replies
966 Views

Similar Articles

[PageSpeed] 25

I started a support case and they discovered that with certain adapters, IM 
does not update the registry setting properly for the "Foreground locking" so 
the first record always fails.  This has been an issue for a number of years. 
 There is a problem report (5711) and the issue will very unlikely get fixed 
(they said this).  So, I have to manually run our integrations (takes over an 
hour each day).

"Luvsql" wrote:

> I have a scheduled integration setup that first runs the login to GP, then an 
> integration group (2 AR integrations).  I have them set at 5 minutes apart.  
> The TK article for this particular error says that the error is because 
> "Great Plains is still in the process of launching when the Integration 
> Manager starts running."  I then increased the time to 15 minutes 
> apart and finally at 30 minutes apart, but the first record of both 
> integrations still fails with this error "could not set foreground locking 
> value to 0."
> 
> How can I get rid of this error?  It only takes less than a minute to 
> completely log into GP.  It defeats the whole purpose of a scheduled 
> integration when I have to manually re-run each integration every morning.  
> 
0
Luvsql (265)
11/16/2005 4:43:07 PM
Luvsql,

That really stinks.  I know how it is with development not fixing PR's
sometimes or maybe not for quite a while.  I have a bunch of them logged
myself that I'd like fixed but falls under "not enough guys to fix them and
not high enough priority to fix it with the people/time we have.".  I
understand but I don't have to like it.

In your case though, the only thing I can think of is to make sure that the
first record of your import file is one that won't integrate.  So if you're
integrating SOP transactions, enter in an invalid customer.  So if that one
is skipped, no big deal.  If not, then it'll be rejected anyway.

Of course I realize that the bigger issue might be getting your source file
created so that it's "broken" to provide the invalid record.  But it's a
thought and one that might be possible for you.

patrick
mbs dev support

-- 
This posting is provided "AS IS" with no warranties, and confers no rights.


"Luvsql" <Luvsql@discussions.microsoft.com> wrote in message
news:64991DE3-D770-4B32-8A2D-21FBDDF00128@microsoft.com...
> I started a support case and they discovered that with certain adapters,
IM
> does not update the registry setting properly for the "Foreground locking"
so
> the first record always fails.  This has been an issue for a number of
years.
>  There is a problem report (5711) and the issue will very unlikely get
fixed
> (they said this).  So, I have to manually run our integrations (takes over
an
> hour each day).
>
> "Luvsql" wrote:
>
> > I have a scheduled integration setup that first runs the login to GP,
then an
> > integration group (2 AR integrations).  I have them set at 5 minutes
apart.
> > The TK article for this particular error says that the error is because
> > "Great Plains is still in the process of launching when the Integration
> > Manager starts running."  I then increased the time to 15 minutes
> > apart and finally at 30 minutes apart, but the first record of both
> > integrations still fails with this error "could not set foreground
locking
> > value to 0."
> >
> > How can I get rid of this error?  It only takes less than a minute to
> > completely log into GP.  It defeats the whole purpose of a scheduled
> > integration when I have to manually re-run each integration every
morning.
> >


0
prot1 (1345)
11/17/2005 4:35:35 AM
That's exactly what I've started to do.  I have entered a Dummy record, then 
unionized my real records.  The only thing I have to determine now is how to 
prevent the email notifications from saying a record failed for this one, but 
not for the real failures  (as well, if in the morning, there aren't any 
"Real" records to integrate, I don't want it to run).

"Patrick [MSFT]" wrote:

> Luvsql,
> 
> That really stinks.  I know how it is with development not fixing PR's
> sometimes or maybe not for quite a while.  I have a bunch of them logged
> myself that I'd like fixed but falls under "not enough guys to fix them and
> not high enough priority to fix it with the people/time we have.".  I
> understand but I don't have to like it.
> 
> In your case though, the only thing I can think of is to make sure that the
> first record of your import file is one that won't integrate.  So if you're
> integrating SOP transactions, enter in an invalid customer.  So if that one
> is skipped, no big deal.  If not, then it'll be rejected anyway.
> 
> Of course I realize that the bigger issue might be getting your source file
> created so that it's "broken" to provide the invalid record.  But it's a
> thought and one that might be possible for you.
> 
> patrick
> mbs dev support
> 
> -- 
> This posting is provided "AS IS" with no warranties, and confers no rights.
> 
> 
> "Luvsql" <Luvsql@discussions.microsoft.com> wrote in message
> news:64991DE3-D770-4B32-8A2D-21FBDDF00128@microsoft.com...
> > I started a support case and they discovered that with certain adapters,
> IM
> > does not update the registry setting properly for the "Foreground locking"
> so
> > the first record always fails.  This has been an issue for a number of
> years.
> >  There is a problem report (5711) and the issue will very unlikely get
> fixed
> > (they said this).  So, I have to manually run our integrations (takes over
> an
> > hour each day).
> >
> > "Luvsql" wrote:
> >
> > > I have a scheduled integration setup that first runs the login to GP,
> then an
> > > integration group (2 AR integrations).  I have them set at 5 minutes
> apart.
> > > The TK article for this particular error says that the error is because
> > > "Great Plains is still in the process of launching when the Integration
> > > Manager starts running."  I then increased the time to 15 minutes
> > > apart and finally at 30 minutes apart, but the first record of both
> > > integrations still fails with this error "could not set foreground
> locking
> > > value to 0."
> > >
> > > How can I get rid of this error?  It only takes less than a minute to
> > > completely log into GP.  It defeats the whole purpose of a scheduled
> > > integration when I have to manually re-run each integration every
> morning.
> > >
> 
> 
> 
0
Luvsql (265)
11/17/2005 2:18:21 PM
Reply:

Similar Artilces:

Function "Workingdays" query error date
I am trying to calculate the number of days, excluding weekends, between two dates. I am using the "workingdays" VBA code. I have pasted the code in a module, naming it "mdlWorkingdays". The code is listed below along with a sample of the data. "mdlWorkingdays" Option Compare Database '*********** Code Start ************** Public Function Workingdays(Start_Date As Date, End_Date As Date) As Integer '.................................................................... ' Name: WorkingDays ' Inputs: StartDate As Date ' EndDate As Da...

Event ID Error: 9785
We have used the database portability to transfer a database to another server and then moved the -configurationonly for those mailboxes to the new server. All user mailboxes are working fine but this error is coming up about every 2 minutes. We are using Exchange 2K7 SP2. MS knowledge base doesn't have any info on this error. What are the possible causes/fixes for this? Event Type: Error Event Source: MSExchangeIS Mailbox Store Event Category: Event History Event ID: 9785 Date: 12/9/2009 Time: 10:35:44 AM User: N/A Computer: EXCH2007B Description: An attempt to ...

Error Message 0x800CCC78
Whenever I try to send emails from Outlook Express 2002, I receive the error message 0x800CCC78 - Unable to send the message. Please verify the email address in your account properties. I have actually changes email addresses> I have called my ISP. The y say since I am able to send emails through the web, it is not their problem. I have also tried to switch over to MS Outlook Express - same error message appears when send ing emails. Please let me know how to resolve this problem. Are you using Outlook 2002 or Outlook Express? There is no such beast as Outlook Express 2002. If y...

An unexpected error occurred during a VSS operation.
I have a W2k3 server that the replica is inconsistant and i cannot run a consistency check. It does nothing when I tell it to. On the alert page recommended actions besides rerunning consistancy is to clear the fault. When I do I get this error: An unexpected error occurred during a VSS operation. Retry the operation. ID: 207 Details: Unknown error (0x80042306) (0x80042306) the DPM Server Event says: Event Type: Error Event Source: DPM-EM Event Category: None Event ID: 1 Date: 12/11/2009 Time: 3:00:21 PM User: N/A Computer: SLOSSDC02 Description: The replica ...

0x8004010f error starting Exchange 2003 info store
I've deployed a few Exchange 2007 servers in our org and moved some mailboxes to them. Additionally, I've moved some roles (OAB generation, RUS...) to those Exchange 2007 servers. Immediately, and without warning, our Exchange 2003 servers are no longer able to start their Information Store or MTA Stack services. When trying to start the info store, I get these two errors: Event Type: Error Event Source: MSExchangeIS Event Category: General Event ID: 1121 Date: 4/24/2007 Time: 4:34:13 PM User: N/A Computer: EXCH7 Description: Error 0x8004010f connecting to the Microsoft Act...

Have you seen this error?
Greetings. very basic programming knowlege here. Using Win3K AD and Exchange3K SP1. I have creaged a VB6 (no, I do not have .NET), program that creates a user and an exchange mailbox. It worked fine until I upgraded my workstation exchange management tools to Exchange3K SP1. I get Run-Time Error 13. Type Mismatch on the 'SET OMAILBOX = OBJUSER' section. The code I am using is canned from Microsoft. ADSI portion. Link is below. http://msdn.microsoft.com/library/default.asp?url=/library/en-us/e2k3/e2k3/_cdo_imailboxstore_createmailbox.asp When I unregister the Exch3K SP1 CDO...

VBA project locked
Hi While importing the Calender package (Calendar80.Package) i got the following error "Package contains items that cannot be imported becuase their VBA project locked" Date Dialong , Microsoft Calender control 11.0 and Rm_Analysis Report were shown as locked How to resolve this ? ...

Integrity Problems in PivotTables
Hi All, I have used this workbook for some time and it appears the same as many others I use, but lately after opening it a couple of times I receive an error message that - 1, "Cannot read file", followed by 2, all my pivotTables lose functionality "Due to Integrity Problems" and I have to reset all the ranges again. I am using 2003 version and the range in question for the first table is in another workbook on the server. TIA Roger. Hi Roger, (reply in excel.misc) I don't have Excel 2003, but you might double check the several pa...

Errors at ActiveSync Mobile Administration Web tool.
Dear colleagues, We've met problems trying remote wipe feature at ActiveSync Mobile Administration Web tool. Namely we've received the following error after entering smtp address to lookup list of devices: Server Error in '/MobileAdmin' Application. -------------------------------------------------------------------------------- Enumerator is positioned before the first item or after the last item. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it o...

Error Message using Personal Folders Back-up
I recently downloaded and installed the Personal Folders Back-Up program into my Outlook 2000. I have it set to back up my Personal folder to a Zip drive when I exit Outlook. When the I exit the program I keep getting the following message "Cannot copy outlook: The process cannot access the file because another process has locked a portion of the file." What do I need to do to get this to work properly? I would like to be able to back up my Personal folder without exporting each subfolder to the zip drive individually. I also tried backing up to other locations with the sam...

error message: None of your e-mail accounts could send to this recipient
My Outlook 2003 suddenly is rejecting my outgoing messages when I send them by bouncing them back with the error message: "None of your e-mail accounts could send to this recipient". I've checked the MS Knowledge Base, Google, and this newsgroup, but I've found nothing to help me. Does the problem have something to do with SP2? Is it some new security 'feature'? Can anyone lead me to a solution? Thanks ...

Run-time error 432
I'm getting a run-time error 432 when trying to open some areas of a VB program in excel. This program works on some machines and not others. We all have the same version of excel and our settings seem to be the same. Does anyone have any idea where I can start to look for the reason this is happening? Thanks Kevin After doing a search of Google, you may like to try this solution... Go to... http://www.dlldump.com/download-dll-files_new.php/dllfiles/D/dao360.dll/03.60.8618.0/download.html download and install file.... Then go to RUN and type: Regsvr32C:\WINDOWS\SYSTEM\Dao360.dll ...

Error 0x80040155 interface not registered
I installed Microsoft office professional 2003 Academic Edition and have Office outlook as a default email program. I was using it without any problems, but suddenly when I try to use outlook to send email I… a) Can not send email directly from word or excel b) If I try to copy and paste a word document into a new message, or attach it, I receive an error stating “Word unspecified error” or “interface not registered error 0x80040155” and finally, I cannot send the email. I have tried finding info in this error in Microsoft office help with o success I tried to repair the office...

Email Integration
Hello, I am a CRM 4.0 user and using router for both incoming and outgoing. The incoming uses forward mailbox and outgoing uses SMTP. No user is using outlook client for CRM. I need help in better understanding the following scenario: The e-mail gets initiated from CRM. It reaches the CRM external contact (even though in CRM e-mail the status is pending). Why is this happening? The CRM external contact replies to this e-mail and it reaches back to CRM user. This CRM user now uses outlook (with no crm client) to reply to this e-mail, no update happens in contact's CRM history. My ...

VBA Error Message "Compile Error...."
I used a macro from Ron's website to mail each worksheet to the email address in cell a1. I ran this macro and it worked perfectly for one workbook BUT... when I tried to use it for another workbook I got the follwing error message "Microsoft Visual Basic Compile Error Can't find project or library Ok Help". Help me please... do I have to check some more references in the VBA tools? Thanks, Steve Hi Steve Have you set the reference to Outlook in that other workbook also ? You must do that in every workbook or you can use Late binding. See my site for a example --...

Error 2455 Closing Access 2007 database with form open
I have a form with a subform that is requeried when you select a new key for the main form from a combo box. Everything works fine - usually. But sometimes if you have the form open when you close the database down you get the following error message (twice) in a pop up. You say OK (twice) and the database closes OK "2455 you entered an expression that has an invalid reference to the property form/report" If I close the form before the database I never get the error. If I do not touch the form before you close the database I don't get the error. If I update a field by t...

OWA Error for http links
links inside a message body always generate an asp redirect code that does not execute at all thus giving an http 500 error - page not found. Example on a link to http://www.nightlight.org within a mail body. http://orange/exchweb/bin/redir.asp? URL=http://www.nightlight.org/ Exchange Server 2003 running on Server 2000 SP4 PLease help. ...

Integrating Great Plains 8.0 and CRM 1.2 and Windows Small Busines
Integrating Great Plains 8.0 and CRM 1.2 I run a Windows Small Business Server 2003 Premium box along with a Windows Server 2003 Standard box used for my Great Plains 8.0 and SQL 2000. I’m considering introducing CRM 1.2 Professional into the mix. From a hardware stand point I know I’m fine all around. I’ve been researching how I should configure CRM and am a bit confused. The info I’ve found in KB887153 states “When you install Microsoft Business Solutions CRM Integrations for Great Plains 7.0, 7.5, or 8.0, Microsoft BizTalk Server is also installed. However, BizTalk Server 2000 and B...

Upgrading
I want to upgrade from Microsoft Money Financial Suite OEM Edition Version 11.0 to latest version but on trying to open the money file in Microsoft Money 2007 I get the following error message: File was created by an incompatible version Question 1: As the old version was pre-loaded into the Computer when I bought it in India, I don't know which country US/Canada/UK/Australia this software belongs to. So how can I confirm which country is it for? Question 2: And, how can I upgrade it to a version of Money from US or UK. -- Kapil ...

Function doesn't run
In my spreadsheet, I have the following function =VLookup(K16, zips, 2) However, instead of returning a result, the function remains in the cell. How do I fix this problem? Format the cell as General and re-enter the formula (F2, ENTER) -- Kind regards, Niek Otten Microsoft MVP - Excel "Justin" <jmeyer@incrementaladvantage.com> wrote in message news:1165596899.059148.31580@80g2000cwy.googlegroups.com... | In my spreadsheet, I have the following function | =VLookup(K16, zips, 2) | However, instead of returning a result, the function remains in the | cell. How do I fix th...

Scheduling formula question
I know both are the same equation. Which one is by definition ? "Duration = Work / Units" or "Work = Duration x Units". I have a three day task with a resource assigned (Max. Units 100%, Units:100%). All calendars are the default Standard base calendar; Hours per day is 9 hours. How do we build the equation to calculate 27 hours of work ? TBol -- To be technically correct, the Duration Equation formula is written as: Duration = Work/(Hours Per Day x Units) You find the Hours Per Day value on the Calendar page of the Options dialog, accessed by clic...

Outlook and Windows Integrated Authentication
Hello All, Does anyone know if Outlook (not OWA) can use Windows Integrated Authentication (like IE) to automatically log onto Intranet Web sites to retrieve graphics in HTML messages? Right now we get a logon dialog and have to manually log in. Thanks. if you paste the url into a browser, does it work as desired? -- Diane Poremsky [MVP - Outlook] Author, Teach Yourself Outlook 2003 in 24 Hours Coauthor, OneNote 2003 for Windows (Visual QuickStart Guide) Need Help with Common Tasks? http://www.outlook-tips.net/beginner/ Outlook 2007: http://www.slipstick.com/outlook/ol2007/ Outloo...

Outlook Inbox running tally of e-mails in it
HELP ! This should be simple for someone but not me. I used to have a number on the left side of my screen when in my in-box that would tell me the total number of e- mails in my inbox (normally around 200-300). This was not JUST the new ones which are reflected on the folders line. It was at the bottom of the page and would change immediately if I deleted or added one. I lost the number and want it back. How do I do that? Thanks for any help anyone can give ! Cindy view - status bar "Suzanne" <anonymous@discussions.microsoft.com> wrote in message news:0bb901c3deda$1...

ESM 2003 info store Error on WinXP PC
ESM 2003 on Windows XP SP1a PC: Installed exchange system manager onto a windows xp sp 1a pc. I can run ESM fine, yet not administer public folders. When I access a public folder's properties, select the Permissions Tab and click "client permissions" button, I get an error-- The information store could not be opened. The logon to the Microsoft Exchange Server computer failed. MAPI 1.0 ID no: 80040111-0286-00000000 ID no: c105000 Exchange System Manager OK. Any ideas to resolve? Using ESM on server (even through RDC) works fine! Thanks! ~Terry ...

Error trying to make an account default
I have a new computer and my outlook 2003 is not letting me assign a default account to send and receive. I get this error: "The Specicied Account could not be found. It might have been deleted." I have four accounnts setup and have tried removing the accounts and recreating them and still get the error. when the account has been made, it tests fine. None of the four can be made default. Thanks in Advance! ...