"Operation must use an updateable query" error in IM

Our Client is running GP10 SP1 with all users connecting through Terminal 
Server to Sql 2005.  Receiving error "Operation must use an updateable query" 
 when trying to run an AP Transaction integration that has worked fine until 
this week.

The source files are *txt files and they are not using any Sql scripting in 
the integration. 
0
MES (112)
3/19/2008 8:49:01 PM
greatplains 29623 articles. 6 followers. Follow

2 Replies
1077 Views

Similar Articles

[PageSpeed] 47

I get that whenever I have an Access database that has somehow been marked 
read only or if the user I am logged in as only has read permissions. Since 
IM uses an Access database internally, I would suggest checking that the 
user who's logged in and running the integration can still write to the 
database?

- Dave

"MES" <MES@discussions.microsoft.com> wrote in message 
news:1A6E10C0-30AC-4FF5-ACD4-5058580E10C5@microsoft.com...
> Our Client is running GP10 SP1 with all users connecting through Terminal
> Server to Sql 2005.  Receiving error "Operation must use an updateable 
> query"
> when trying to run an AP Transaction integration that has worked fine 
> until
> this week.
>
> The source files are *txt files and they are not using any Sql scripting 
> in
> the integration. 


0
3/20/2008 3:06:10 PM
Thank you David, you nailed it. Turns out the System Admin changed user 
security this past weekend and the GP user running the integration no longer 
had sufficient rights to the IM.mdb. 

"David E. Patrick" wrote:

> I get that whenever I have an Access database that has somehow been marked 
> read only or if the user I am logged in as only has read permissions. Since 
> IM uses an Access database internally, I would suggest checking that the 
> user who's logged in and running the integration can still write to the 
> database?
> 
> - Dave
> 
> "MES" <MES@discussions.microsoft.com> wrote in message 
> news:1A6E10C0-30AC-4FF5-ACD4-5058580E10C5@microsoft.com...
> > Our Client is running GP10 SP1 with all users connecting through Terminal
> > Server to Sql 2005.  Receiving error "Operation must use an updateable 
> > query"
> > when trying to run an AP Transaction integration that has worked fine 
> > until
> > this week.
> >
> > The source files are *txt files and they are not using any Sql scripting 
> > in
> > the integration. 
> 
> 
> 
0
MES (112)
3/20/2008 8:13:02 PM
Reply:

Similar Artilces:

Operation must use an updateable query
Hi What the four and a half is that about? This is my query: UPDATE [LKQRY_LCO-12m] INNER JOIN TM_CompContact ON [LKQRY_LCO-12m].PK_Contact = TM_CompContact.PK_Contact SET TM_CompContact.LCO_Due = -1 WHERE (((TM_CompContact.LCO_Due)<>-1)); How do I get this blighter to work? Stapes Jet often does not like joined tables in an update query, so the query must be rewritten to use a subquery: UPDATE TM_CompContact SET TM_CompContact.LCO_Due = -1 WHERE TM_CompContact.LCO_Due <> -1 AND EXISTS (SELECT [LKQRY_LCO-12m].PK_Contact FROM [LKQRY_LCO-12m] WHERE [LKQRY_LCO-12m].PK_Contact...

"Operation must use an updateable query" error in IM
Our Client is running GP10 SP1 with all users connecting through Terminal Server to Sql 2005. Receiving error "Operation must use an updateable query" when trying to run an AP Transaction integration that has worked fine until this week. The source files are *txt files and they are not using any Sql scripting in the integration. I get that whenever I have an Access database that has somehow been marked read only or if the user I am logged in as only has read permissions. Since IM uses an Access database internally, I would suggest checking that the user who's logged i...

Operation must use an updateable query
When I run an update query within Microsoft Access 2007, the following error message appears: 'Operation must use an updateable query'. Background: The update query is part of a tool with an Access 2007 front end. The tool contains several links to tables containing the underlying data. These tables used to be in another Access 2007 database but I am in the process of moving the underlying data from Access 2007 to SQL Server 2005. So far I have recreated the tables in SQL Server 2005 and redirected the links to the equivalent SQL tables. I am logged into Windows as a user ...

Excel using ado.net
This is driving me nuts. I'm trying to update an Excel spreadsheet using ADO.Net and Oledb in VB.Net. The connection is open, the adapter is connected and the dataset is loaded. Here's the code in question: myDataRow = myDataSet.Tables(0).Rows(RowNum) myDataRow(ColumnCount) = Ailment Adapter.UpdateCommand = New OleDbCommand("UPDATE [" & SheetName & "] SET F" & ColumnCount & " = '" & Ailment & "' where F1 = " & RowNum & "", Conn) Adapter.Update(myDataSet, "[...

'Operation must use an updateable query'
I have an issue with a query that I cannot figure out the answer to. I keep getting the error 'Operation must use an updateable query'. The query I am running is: UPDATE DGBTestVariations SET DGBTestVariations.JURISDICTION = IIF(DGBTestVariations.JURISDICTION = "NoMoneyMuni", (SELECT DGBJurisdictionCOO.JurisCodes FROM DGBJurisdictionCOO WHERE DGBJurisdictionCOO.ID=3), IIF(DGBTestVariations.JURISDICTION = "Municipalities", (SELECT DGBJurisdictionCOO.JurisCodes FROM DGBJurisdictionCOO WHERE DGBJuri...