SMTP service does not fail over to the next mail MX record

I have a problem whit SMTP outgoing mail on my Exchange server 2003 sp2 on a 
Windows 2003 sp1 and all fixes and updates on.

The SMTP service does not fail over to the next mail MX record after the 
host for the first (lowest) MX record returns error.
I have tested with SMTP Diag from the exchange server to several domains 
where the first MX record return error and  
SMTP diag failes over like it should do.
I’ve tried to use both internal and external DNS whit the same result.
I know that this error was fixed in W2K3 SP1.

Any ideas ?


0
PW (7)
9/22/2006 1:39:02 PM
exchange.admin 57650 articles. 2 followers. Follow

3 Replies
430 Views

Similar Articles

[PageSpeed] 25

What are you determining to be an error here?  Is the remote host accepting 
a connection on port 25?

-- 
Ben Winzenz
Exchange MVP
MessageOne
Read my blog!
http://winzenz.blogspot.com
http://feeds.feedburner.com/winzenz (RSS Feed)


"PW" <PW@discussions.microsoft.com> wrote in message 
news:1D50F216-5393-43AD-A3E5-FB4AF3B1043F@microsoft.com...
>
> I have a problem whit SMTP outgoing mail on my Exchange server 2003 sp2 on 
> a
> Windows 2003 sp1 and all fixes and updates on.
>
> The SMTP service does not fail over to the next mail MX record after the
> host for the first (lowest) MX record returns error.
> I have tested with SMTP Diag from the exchange server to several domains
> where the first MX record return error and
> SMTP diag failes over like it should do.
> I've tried to use both internal and external DNS whit the same result.
> I know that this error was fixed in W2K3 SP1.
>
> Any ideas ?
>
> 


0
Ben
9/22/2006 3:50:47 PM
The error occurs when emailing domains with multiple MX-records, and when the 
first MX-record (with lowest priority) is unavailable.

During manual tests from our Exchange-server we notice that the MX-record 
with lowest priority is completely unavailable (e.g telnet 
mx-record.somedomain.com 25 won't connect).

However, there are other MX-records with higher priority online (when trying 
telnet to theese, we get the expected SMTP replies)

Regards,
Per


"Ben Winzenz [Exchange MVP]" wrote:

> What are you determining to be an error here?  Is the remote host accepting 
> a connection on port 25?
> 
> -- 
> Ben Winzenz
> Exchange MVP
> MessageOne
> Read my blog!
> http://winzenz.blogspot.com
> http://feeds.feedburner.com/winzenz (RSS Feed)
> 
> 
> "PW" <PW@discussions.microsoft.com> wrote in message 
> news:1D50F216-5393-43AD-A3E5-FB4AF3B1043F@microsoft.com...
> >
> > I have a problem whit SMTP outgoing mail on my Exchange server 2003 sp2 on 
> > a
> > Windows 2003 sp1 and all fixes and updates on.
> >
> > The SMTP service does not fail over to the next mail MX record after the
> > host for the first (lowest) MX record returns error.
> > I have tested with SMTP Diag from the exchange server to several domains
> > where the first MX record return error and
> > SMTP diag failes over like it should do.
> > I've tried to use both internal and external DNS whit the same result.
> > I know that this error was fixed in W2K3 SP1.
> >
> > Any ideas ?
> >
> > 
> 
> 
> 
0
PW (7)
9/25/2006 7:26:01 AM
I'd open a PSS incident then.  If you've found a bug, then they will be able 
to isolate the cause.  I've never experienced the behavior you are noting.

-- 
Ben Winzenz
Exchange MVP
MessageOne
Read my blog!
http://winzenz.blogspot.com
http://feeds.feedburner.com/winzenz (RSS Feed)


"PW" <PW@discussions.microsoft.com> wrote in message 
news:38D52AC8-9CC7-4AE4-A509-1575BFAB11D2@microsoft.com...
> The error occurs when emailing domains with multiple MX-records, and when 
> the
> first MX-record (with lowest priority) is unavailable.
>
> During manual tests from our Exchange-server we notice that the MX-record
> with lowest priority is completely unavailable (e.g telnet
> mx-record.somedomain.com 25 won't connect).
>
> However, there are other MX-records with higher priority online (when 
> trying
> telnet to theese, we get the expected SMTP replies)
>
> Regards,
> Per
>
>
> "Ben Winzenz [Exchange MVP]" wrote:
>
>> What are you determining to be an error here?  Is the remote host 
>> accepting
>> a connection on port 25?
>>
>> -- 
>> Ben Winzenz
>> Exchange MVP
>> MessageOne
>> Read my blog!
>> http://winzenz.blogspot.com
>> http://feeds.feedburner.com/winzenz (RSS Feed)
>>
>>
>> "PW" <PW@discussions.microsoft.com> wrote in message
>> news:1D50F216-5393-43AD-A3E5-FB4AF3B1043F@microsoft.com...
>> >
>> > I have a problem whit SMTP outgoing mail on my Exchange server 2003 sp2 
>> > on
>> > a
>> > Windows 2003 sp1 and all fixes and updates on.
>> >
>> > The SMTP service does not fail over to the next mail MX record after 
>> > the
>> > host for the first (lowest) MX record returns error.
>> > I have tested with SMTP Diag from the exchange server to several 
>> > domains
>> > where the first MX record return error and
>> > SMTP diag failes over like it should do.
>> > I've tried to use both internal and external DNS whit the same result.
>> > I know that this error was fixed in W2K3 SP1.
>> >
>> > Any ideas ?
>> >
>> >
>>
>>
>> 


0
Ben
9/25/2006 1:39:50 PM
Reply:

Similar Artilces:

Can E-mail recipient policy be linked to the OU membership?
Running Exchange 2003 (mixed mode) and Windows 2003 server (Windows 2000 mixed mode): I'd like to create a e-mail recipient policy that is linked to the different OU's that are created on the system. Is it possible to link the policy to a specific OU or do I need to create groups on the AD to control which recipients a policy applies to? Martin Moustgaard Yes, you can create a recipient policy that looks to just a specific OU. It is done through LDAP queries. Here are some references to articles and whitepapers that discuss how to work with recipient policies. 249299.KB.EN-US HO...

Outlook Send/Receive mail SLOW
When I receive/send email, it loads sends/receives extremely slow. The percentage indicator when receiving/sending starts at 3-5% and stays that way for awhile. After several minutes, the mail eventually comes through. Any reason for this? ...

Macro for Sharepoint List and another Table?? Same # records?
I am creating a database which we have a form made up of prepopulated data (from a sharepoint list) and also data input needed by a user (for example, comments, etc.). I have two tables: one sharepoint list that is linked to sharepoint website and another table that houses the additional user inputs [table 2]. I have linked the files based on the primary key. So, every record in my table 2 has a plus sign and it will expand and you will see the linked data from the sharepoint list. Is there a way that I can automatically create a record for every corresponding record ...

Setting up a new e-mail account
I'm trying to set up my yahoo account so that I receive my e-mail messages in my Outlook Inbox. I went to Accounts, and servers, and put in mail.yahoo.com for incoming mail (POP3) and smtp.yahoo.com for outgoing mail (smtp). When I click on the send/receive button I get an error message. Dave <anonymous@discussions.microsoft.com> wrote: > I'm trying to set up my yahoo account so that I receive > my e-mail messages in my Outlook Inbox. I went to > Accounts, and servers, and put in mail.yahoo.com for > incoming mail (POP3) and smtp.yahoo.com for outgoing mail &...

Receiving POP3 mail into Outlook without Send/Receive
I want the POP3 mail to be received into Outlook (If open) when the mail arrives in POP3 account. Is that possible? Set an Automatic Polling Interval. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. All unsolicited mail sent to my personal account will be deleted without reading. After furious head scratching, delanda asked: | I want the POP3 mail to be received into Outlook (If open) when the | mail arrives in POP3 account. Is that possible? ...

Office 2003 Service Pack 3--subsequent problems opening Publisher
I run Publisher 2003 on Windows XP. On June 13, I updated my system with Office 2003 Service Pack 3 so that I could open Word documents with the file ext docx. Subsequent to the Service Pack 3 installation, whenever I open a Publisher file (which I created), I get the following message: "Publisher has detected a problem in the file you are trying to open. If you are certain that this file came from a trusted source and does not contain harmful information, click OK." What is causing this and is there a way to stop this pop-up message? All publications? Error message when you...

Replying to an Outlook e-mail
When replying to e-mail in Outlook, everything works fine. But when I try to reply to an e-mail that has an embedded picture in it, Outlook won't send it. I get the message that the e-mail was sent, but it stays in the outbox and never sends. Any suggestions? -- Jack "Jack Johnson" <hotshotz@comcast.net> wrote in message news:D6C50AC7-EB37-4B54-9611-F9F42F1F1BA0@microsoft.com... > When replying to e-mail in Outlook, everything works fine. But when I try to > reply to an e-mail that has an embedded picture in it, Outlook won't send > it. &...

Service Products Tracking.
We run a workshop repair service, what is the best way to track customers products, as it seems unfeasible to add products when booking an over the counter repair order in CRM. I would like to track repairs against machine manufacturer to do simple reporting like reliability against brand etc. I would recommend the following as the product you sell is a service I would create the service as the product i.e. create product Start-up costs, hourly rate, etc. To track brand reliability I would create one or more custom entities which contain the brand and maybe even their products. T...

Help me identify my missing permission (Cannot open public folder) -2147217843 (Maybe Authentication Fails?)
The following snippet of code throws an error number -2147217843. When I googled this error code, I see many references to authentication failed. I am assuming my problem is some kind of permission related problem on the "MyNewFolder" public folder. -- start code --- Dim objFolder As New CDO.Folder Dim f As ADODB.Field 'sURL is like: file://./backofficestorage/mydomain.com/Public Folders/MyNewFolder/ objFolder.DataSource.Open sURL, , adModeReadWrite, adFailIfNotExists --- end code -- I have code that runs before this that actually creates the "MyNewFolder" publ...

I want to add a mail account without setting a SMTP server. Is it possible?
I want to add a second mail account that is outside my company. Since the company firewall does not allow us to connect to SMTP-servers I want to add this account without setting the SMTP propertiy. I cannot specify the company server as it is an Exchange server and the outside one an IMAP one. Currently I have specified the outside SMTP server since outook does not allow me to add an account wihtout setting this. I keep getting annoying error messages as my computer can't connect to the outside SMTP. Any one know a way around this? cheers, mortb The company server has SMTP enabled, u...

Saving e-mail & attachments when upgrading
I'm upgrading from NT4 to XP Home and the only data I need to keep are the emails & attachments. I have to format the hard drive to eliminate the partitions. This machine is on a network and I can save to the other machune. Look here for all the information you need on backup and restoration of Outlook data: http://www.slipstick.com/config/backup.htm -- Jocelyn Fiorello MVP - Outlook *** Replies sent to my e-mail address will probably not be answered -- please reply only to the newsgroup to preserve the message thread. *** "Mike" <mike@hosemart.com.au> wrote ...

how to install Microsoft Mail to Outlook 2003
pls help I found 'this' (http://www.outlook-tips.net/howto/msmail.htm) on www.outlook-tips.net I don't know if it works... ------------------------------------------------ ~~ Message posted from http://www.ExcelTip.com/ ~~View and post usenet messages directly from http://www.ExcelForum.com/ It does. -- Diane Poremsky [MVP - Outlook] Author, Teach Yourself Outlook 2003 in 24 Hours Coauthor, OneNote 2003 for Windows (Visual QuickStart Guide) Outlook Tips: http://www.outlook-tips.net/ Search for answers: http://groups.google.com Most recent posts to the Outlook newsgroups: ...

isinteg reports configuring tstmgr failed : ecBadVersion
we have lost our mail after NAV did it's worst. have performed eseutil /p and /d as suggested elsewhere now get error from isinteg help please Update - have now sorted this thanks ...

Duplicate E-Mail #4
Every time I get e-mail from certain users I get their e-mail twice. I have not been able to figure out why this is happening. Is it their fault or my fault and if it is my fault, how do I fix it? Thanks, Al Alfred Kaufmann <al_kaufmann@hotmail.com> wrote: > Every time I get e-mail from certain users I get their e-mail twice. I > have not been able to figure out why this is happening. Is it their > fault or my fault and if it is my fault, how do I fix it? See if this helps: http://www.howto-outlook.com/faq/duplicates.htm -- Brian Tillman [MVP-Outlook] ...

me too, problem with import... only 15 records
me too, problem with import... only 15 records.... also in one of my customers crm i need a fast answer.... I dont see a question to answer...? JUAN MARKETING wrote: > me too, problem with import... only 15 records.... also in one of my > customers crm > > i need a fast answer.... Hehe yeah, what is the question!? what are you trying to import? Sorry, I don't know the reason, bu each time i try to import x number of accounts or contacts, MSCRM only import 15 records... Promise, everything is ok... columns, format csv from excel, size, records.... I say that, becau...

Subquery
Hi, I'm trying to code a subquery on a table but to no avail...it's a very simple table that has Date (short date, just recording the day) and NAV which is a number (double). All I'm wanting to do is have a query that displays the Date, the NAV and the NAV from the day before - only recording business dates. In other words, the subquery number I want is the NAV from the record preceeding the current one. I've got as far as the below, but that just gets the same NAV number as today's: SELECT tblNAV.Date, tblNAV.NAV, (SELECT LAST(x.NAV) FROM tblNAV as X LEFT JOIN tblNAV on...

Exchange 2003, Two Sites, Two Smarthosts, One Domain, No Internal mail!!
Hi, I hope there is someone out there who can point me in the right direction. We have two sites, Brisbane and Sydney, connected by a frame realy connection. Sydney is currently running exchange 2003 (upgraded by migration from exchange 5.5 about a month ago). Brisbane is currently running their mail through sendmail and sendmail only. We have just installed exchange 2003 on server 2003 box in Brisbane and are trying to get the two sites working in two routing groups. The topology will be the same in both Brisbane and Sydney, in that each city will have an external mail server running sendma...

Odd e-mail duplication problem
All e-mails promoted or Tracked in CRM Outlook client are being copied to one particular Account that is unrelated. The e-mails are copied correctly to the history of the desired accounts and Contacts but also copy to one particular Accountl as well. As anyone seen anything like this and have any ideas what could be wrong? -- Darryl - dh@mtccrm.com -www.mtccrm.com - Only Microsoft CRM ...

Windows mail asking to verify username and password
I was in Windows Mail when suddenly a box popped up asking for my username and password from Windows Mail.. Although I attempted correctly several times it still will not work. I contacted my kerrlake server and we tried several things including deleting the account and resetting it back up but it still will not open. I can receive my emails on my blackberry and can get on the internet. Also, a protocal error message pops up. Please help! -- Diamond & Associates When you get that repeated prompt for username and password, click = Cancel, which should then produce an erro...

Start macro creating a mail with contact data and autotext
Hallo, I am working with an user form. The developing of that form started with Outlook XP with a lot of code inside for different buttons. I changed to Outlook 2007 and unfortunately the code of the form was not longer displayed. What I learned about this is that MS does not support to much code in the form (or maybe a bug). They also do not support any longer. I was sending this form to MS support but they told it is do much code inside and they do not know, why the code is not displayed. In Outlook 2003 the code is displayed as in Outlook XP. Because I do not know real...

How to Identify Records with Overlapping Dates
I need to be able to systematically identify any instance where there are overlapping date ranges in a data set. I need to pull records like those listed below out of a larger data set. I previously posted a question similar to this and was advised to pull the same table in a query, match on Member Number, and qualify that the product code from TableA did not match product code in TableA_1 where the Begin Date TableA was < Term date TableA_1 and TableA_1 Begin Date < TableA End Date. Which worked great for me finding overlapping records where the product was different, bu...

Loading Adventure Networks Database fails
I am following the instructions page 331 to load the Adventure Networks database. I am running on an absolutely fresh Win2003 SBS and have followed all the instructions. A couple of problems (referring to the bullets in the manual): 2. My Administrator account has domain and local admininstrator privileges and was used to install MS CRM. MS CRM works perfectly. So far so good. 7. I cannot confirm that the five users were created? Why is that? What should I do about it? 10. After entering URL I get an error: That I do not have a MS CRM license??? Help, - Jakob Jakob, ...

Sending E-mails at a defined time with MS Exchange Server
We're using MS Exchange Server at the office. We have around 150 e-mail accounts set up. Some of our users are sending enourmous attachement (~100 Mega) and sometimes to 50 different addresses. During the day this is chewing up all our bandwith. What we would like to know if it's possible in Exchange to define that sort of rule : - Send e-mails with an attachment bigger than 8 M�g only after 20h00 ? (so they don't chew up the bandwith during the day as this has an impact on our FTP transmission module and our client server applications) Or maybe an add-on ? Any suggestions...

ACC: How to Display Line Numbers on Subform Records
I found this article on MS' website http://support.microsoft.com/kb/q120913/ but ran into problems when I pasted the code and tried to compile it. It gives a Compile Error: Method or data member not found when it reached the line below: RS.FindFirst "[" & KeyName & "] = " & KeyValue and it highlights "FindFirst". I have a sub-form (child) of a parent form's and I have a variable in the child that the user currently manually increments from 1,2,3 and so forth. Can this not be done w/o the user's intervention? Hi, ...

proper casing mail merge
Hi All, I have a mail merge document where all the information is in ALL CAPS. Is there a quick way to turn into Proper casing? Thanks, rodchar Select the whole text, Format, Change Case, you will now have various options to choose from. Also, note that Shft+F3 toggles between no caps, Initial caps, and all caps. -- Hope this helps DeanH "rodchar" wrote: > Hi All, > > I have a mail merge document where all the information is in ALL CAPS. Is > there a quick way to turn into Proper casing? > > Thanks, > rodchar thanks, that help...