Outgoing SMTP problem [exchange 2003]

In my new installation of Exchange 2003 SP 3 on Windows 2003 Server SP1, 
a problem re-occurs that was supposed to have been fixed with SP1 or a 
hotfix for prior versions.

Outgoing email to domains using some kind of DNS load balancing and 
multiple MX records is almost certain to fail.

The KB article is:

<http://support.microsoft.com/kb/837993/>
"The SMTP service does not fail over to the next MX record after the 
remote SMTP host for an MX record responds with a 4xx error"


I am running Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830

Is anyone else experiencing the same problem?

Currently I have to forward through the Postfix SMTP on a OS X Server 
machine configured as smart host in the SMTP connector but I have a 
another SMTP virtual host configured for testing.

This is a trial version of Exchange 2003.

I do appreciate any feedback.

Florian /FFF/
0
4/4/2006 4:23:52 PM
exchange.admin 57650 articles. 2 followers. Follow

4 Replies
318 Views

Similar Articles

[PageSpeed] 52

I take it you mean Exchange 2003 SP2? If not apply SP2. Do you get NDRs? Can 
you share them. Any event log entries. Have you positively identified a 
number of domains with this problem?

Nue
"Florian Feuser /FFF/" <florianSPAMTRAP@funnygarbage.com> wrote in message 
news:20060404122333256-0400@News.Individual.DE...
> In my new installation of Exchange 2003 SP 3 on Windows 2003 Server SP1,
> a problem re-occurs that was supposed to have been fixed with SP1 or a
> hotfix for prior versions.
>
> Outgoing email to domains using some kind of DNS load balancing and
> multiple MX records is almost certain to fail.
>
> The KB article is:
>
> <http://support.microsoft.com/kb/837993/>
> "The SMTP service does not fail over to the next MX record after the
> remote SMTP host for an MX record responds with a 4xx error"
>
>
> I am running Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830
>
> Is anyone else experiencing the same problem?
>
> Currently I have to forward through the Postfix SMTP on a OS X Server
> machine configured as smart host in the SMTP connector but I have a
> another SMTP virtual host configured for testing.
>
> This is a trial version of Exchange 2003.
>
> I do appreciate any feedback.
>
> Florian /FFF/ 


0
imaneophyte (3004)
4/4/2006 7:12:36 PM
On 4/4/06 3:12 PM Nuevo wrote:
> I take it you mean Exchange 2003 SP2? If not apply SP2. Do you get 
> NDRs? Can  you share them. Any event log entries. Have you positively 
> identified a  number of domains with this problem?
>
> Nue


Just realized that in Exchange System Mgr, my Mail server shows version 
6.0 SP3 (in Properties/General).

Exchange 2003 is definitively running. I Installed Exchange 2003 in 
Disaster recovery mode after being unable to re-install Exchange 2000 on 
a Win 2003 Server that had to be rebuilt after a hardware failure. 

Apparently I ended up with components of different versions although I 
don't know how that could have happened.
	
The SMTP service that seems to be giving me problems is v. 6.0.3790.1830.
According to the KB article in my OP, the problem was remedied with 
versions greater than 6.0.3790.137

Does Exch2k3SP2 install an improved version of the SMTPSVC.DLL?

Florian
0
4/5/2006 2:06:01 AM
I'd be considered at some of the inconsistencies you are seeing. Reapply SP2 
as a critical first step. See if this helps if not then consider trying to 
bring a new (temp) Exchange server so you can do a fresh install of Exchange 
on your existing box.

Nue
"Florian Feuser /FFF/" <florianSPAMTRAP@funnygarbage.com> wrote in message 
news:20060404220540991-0400@News.Individual.DE...
> On 4/4/06 3:12 PM Nuevo wrote:
>> I take it you mean Exchange 2003 SP2? If not apply SP2. Do you get
>> NDRs? Can  you share them. Any event log entries. Have you positively
>> identified a  number of domains with this problem?
>>
>> Nue
>
>
> Just realized that in Exchange System Mgr, my Mail server shows version
> 6.0 SP3 (in Properties/General).
>
> Exchange 2003 is definitively running. I Installed Exchange 2003 in
> Disaster recovery mode after being unable to re-install Exchange 2000 on
> a Win 2003 Server that had to be rebuilt after a hardware failure.
>
> Apparently I ended up with components of different versions although I
> don't know how that could have happened.
>
> The SMTP service that seems to be giving me problems is v. 6.0.3790.1830.
> According to the KB article in my OP, the problem was remedied with
> versions greater than 6.0.3790.137
>
> Does Exch2k3SP2 install an improved version of the SMTPSVC.DLL?
>
> Florian 


0
imaneophyte (3004)
4/5/2006 12:37:31 PM
On 4/5/06 8:37 AM Nuevo wrote:
> I'd be considered at some of the inconsistencies you are seeing. 
> Reapply SP2  as a critical first step. See if this helps if not then 
> consider trying to  bring a new (temp) Exchange server so you can do a 
> fresh install of Exchange  on your existing box.
>

Nuevo,

You gave me the right idea, although the solution was not re-applying 
the Exchange SP2 but the Windows 2003 Server SP1.

Outgoing SMTP to DNS load-balancing domains such as yahoo.com or gmx.net 
now works and so does the failover for recipient domains whose primary 
MX host is unavailable.

Florian /FFF/
0
4/7/2006 1:09:18 PM
Reply:

Similar Artilces:

Windows XP x64 MFC application problem
I can't start my application on Windows XP Prof. 64-bit wersion, there is messagebox "Failed to create empty document". Application works fine on Windows 2000 SP4 and Windows XP Prof. SP2. What can I do to solove this probem? >I can't start my application on Windows XP Prof. 64-bit wersion, there is >messagebox "Failed to create empty document". Application works fine on >Windows 2000 SP4 and Windows XP Prof. SP2. What can I do to solove this >probem? The obvious response is - try debugging it on that platform and find where it's giving rise ...

Autonumber created.. problems in the future?
I managed to create an autonumber in Microsoft CRM. I did this by making a field "Number"(in the database "New_Number") and I published it on the form. Then I went To the SQL server and I changed the field in the table to Identity Yes, Identity seed 1, Identity Increment 1. I locked the field on the form. It worked! I think that this is not supported by Microsoft. But has anybody got any idea which troubles i could get with this configuration? San ________________________________ Do you know all add-ons for Microsoft CRM? Visit http://www.pimpmycrm.com The biggest dange...

Voice connector on Exchange server 2007.
Is there any functionality available in exchange server 2007 regarding voice connector? If not how can we create it? Thanks in advance. Ashwin Exchange 2007 has the "Universal Messaging" role which is intended for this purpose. Do you have a PBX? -- Ed Crowley MVP - Exchange "Protecting the world from PSTs and brick backups!" "Microsoft Exchange 2007 command shell" <MicrosoftExchange2007commandshell@discussions.microsoft.com> wrote in message news:FAE20A61-AD17-4218-90C2-9356CA90B2A0@microsoft.com... > Is there any functionality available in exch...

Problems with reallocations in the Advanced Budget
I am a using the Advanced Budget in Money and for years I have reallocated money between categories and months. recently when I updated my transactions all my real locations were wrong. Basically the money I allocated from March to February was not only back in February it reversed it and made it look like I sent Money from February to March so now any category that I have reallocated money (an that is most) is wrong. Does anyone know of a way to fix this, I have run the repair, but that did nothing. Microsoft Money Plus Premium Version 17.0.125.1415 I am so glad to see that I am...

From Outlook 2000 to Outllook 2003
How do I migrate I personal folders file (.pst) from Outlook 2000 to Outlook 2003? Read the Help Files: http://office.microsoft.com/en-us/assistance/HA010771141033.aspx -- Russ Valentine [MVP-Outlook] "rolo" <rolo@discussions.microsoft.com> wrote in message news:706405A0-2971-409F-B213-67714B12713C@microsoft.com... > How do I migrate I personal folders file (.pst) from Outlook 2000 to > Outlook > 2003? Thanks Russ it helped. By the way how can I get to this useful help files? "Russ Valentine [MVP-Outlook]" wrote: > Read the Help Files: > htt...

Excel button problem
Hi All I have a macro that copies a worksheet in the active workbook and puts it into a new workbook - then formats it and deletes any buttons on the worksheet. On the first click on the button the macro works ok. On the second click, it fails because the all assigned macros on all buttons in the active workbook changed from "mba" to "book1!mba". Book 1 doesn't exists (wasn't opened, wasn't saved, doesn't have the macros). I've never experienced this problem before?? Can anyone help to solve this problem? FYI The macro to do this is c...

Question -Problem
Has anybody ever seen an error message (0x800cccF6) message? I cannot configure my Outlook to retrieve Hotmail. Works with other profiles on this computer running winxp. Stan-The-Man-2006 wrote: > Has anybody ever seen an error message (0x800cccF6) message? I cannot > configure my Outlook to retrieve Hotmail. Works with other profiles > on this computer running winxp. If you have a free Hotmail account, note that it won't work anymore (even your other profiles will eventually have problems) - see http://www.slipstick.com/addins/services/online.htm#hotmail ...

AD Sync problem
Hello, One of my DC was disconnected from the network for quite a long time and cannot be synchronized with AD anymore. I have been trying to apply the http://support.microsoft.com/kb/325850/en-us procedure to reset the machine account password. After launching the command "netdom resetpwd /S: ....." I've got the following error message : "The machine account password for the local machine could not be reset. Echec d'ouverture de session : unknown user or incorrect password. The command failed to complete successfully." ANy idea to help me ? Man...

WCF Client serialization problem
I posted the problem on another forum, and to prevent duplicate posts, but get as many professionals as possible to look at it, I include the url in this post. Please help! http://stackoverflow.com/questions/2948657/migrating-webclient-to-wcf-wcf-client-serializes-parametername-of-method ...

Problem with Range
Hello All, Using Windows & Excel XP. I have a worksheet that has times located in every other column, A1:A30, C1:C30, E1:E30. I then name the range "times". I want to find the count of times that are between 0:30:00 and 0:39:59 (30 and 39:59 minutes). I write the formula: =COUNTIF(times,">=" & TIME(0,30,0)) - COUNTIF(times,">=" & TIME(0,39,59)) but get the error #VALUE! I have tried writing a formula for times in one column and consecutive columns and it gives the correct count, it is just when the times in every other column that th...

outlook 97 and express email problems
Hi, I am currently on an IBM X21 laptop and is running windows 98 se with office 97 pro. I recently experienced some problems with outlook (illegal operations etc) and reinstalled office to fix the problem but since then I have not been able to send or recieve emails with outlook 97 and outlook express 6. I simply get an error message saying the host can't be found (but does exist and I can ping it successfully). Any suggestions on what I might do? I have tried creating new accounts in windows mail and outlook express, but I still get the same error. Thankyou in advance! Tim D...

Having problem with spoofing email
Our users just received multiple email from different users outside the company. In the To: line, it shows his user name correctly but when he print those email, the To: line was showing somebody else name on the print out. Is there a way to block this behavior? I'm using E2k3. For some reason our spam (postini) didn't pick up these emails. Thank you, Could you please post the message in raw format (including the mail headers) Petch wrote: > Our users just received multiple email from different users outside the > company. In the To: line, it shows his user name cor...

How do I Remove a Split from my Comments in Excel 2003? #2
I have set my current workbook to split/freeze the first column and first 2 rows. Now, when I add a comment to the second row (in any column) my comments are cut off if I should scroll down. I don't ever remember the behavior before. And I don't know what I've done to enable it but it's really annoying. How do turn this off ? ...

unable to paste Excel 2003 chart into Outlook 2003
(This was posted on "excel.charting" group.) I have a user who's unable to paste an Excel 2003 chart into Outlook 2003 email message. In Outlook options, the checkbox is selected for "Use Microsoft Office Word 2003 to edit e-mail messages". When I tested this on my own computer running the same version of Office, if the box is check, I have no problem pasting; if this box is cleared, I cannot paste. But on his computer, it doesn't work regardless. Thanks and regards, TL ...

will CRM load on a 2003 server?
will CRM load on a 2003 server? Microsoft CRM v1.2 supports Windows 2000/2003 Server. Frank Lee Workopia, Inc. >> Other Microsoft CRM Online Forum Resources: http://www.workopia.com/Links.htm >-----Original Message----- >will CRM load on a 2003 server? >. > No problem. We just completed a 1.2 installation on a 2003 server, without any problems. Brian Demoe "Troy Hicks" <tlhicks@nc.rr.com> wrote in message news:03dd01c3dcb2$93653a00$a501280a@phx.gbl... > will CRM load on a 2003 server? CRM 1.2 will also load on Small business server 2003 as wel...

Disable Secure Sockets Layer on exchange server when using RPC over HTTP
Hi im trying to enable RPC over HTTP to enable users to establish contact to my Excahger server 2003 over the internet. Now, I dont want to use SSL (security not that important) and i am told by this article that i can disable SSL in windows registry. Quote: Note While RPC over HTTP does not require Secure Sockets Layer, you must modify the registry to enable RPC over HTTP if you do not want to use Secure Sockets Layer. Microsoft recommends that you enable and require Secure Sockets Layer for your RPC over HTTP communications. At this address: http://support.microsoft.com/?id=833401 But i ...

setup Windows Mail as Word 2003 default emailer
All I can do is setup Outlook. I do not use Outlook. I would like to email Word docs using MS Windows Mail (new version of Express) In the Windows Start area, type Regedit into the search bar and then start the Registry Editor and go to HKEY_CURRENT_USER>Software>Clients>Mail Right Click on the (Default) item and then on Modify and in the Value data: field enter Windows Mail so that after you click OK, you have (Default) REG_SZ WIndows Mail -- Hope this helps. Please reply to the newsgroup unless you wish to avail yourself of my services on a pa...

Filters not working in Exchange 2003
I have been trying to turn on the Recipient, Connection, and Sender filters. I have gone to the Default SMTP Virtual Server and turned it on there without getting an error but when I go to the Properties and add senders to block and the hit Apply, it tells me that I must manually turn the filtering on in the SMTP VS. I have stopped and started the Default SMTP VS but still no luck. Any ideas? Hi Wayne That is a standard dialog box, it does not check to see if it is already enabled, have you tested the sender filtering? -- Mark Fugatt Microsoft Limited This posting is provided &quo...

Contacts in Exchange #2
We are running Exchange 2003 and Outlook 2003. I have tried to give a user rights to her boss's contacts through delegation and setting the rights on the contacts folder, however, while she has the rights she is unable to add or see her boss's contact folder in her Outlook. She can see it if she runs a search, but can not permanently put it in her list of contact folders. IS there a way that I can accomplish this through the back-end? Thanks, Joseph rapoport jrapoport@insurmark.net ...

Outlook 2003 Drag and Drop Emails
I have an issue where there is a SBS 2003 server (newly installed) & when I drag emails to the file system (explorer window) in order to create file records of the emails it generates an error. Dialog Box Name: Error Copying File or Folder Error Msg: Not enough storage is available to process this command. I can't find an error logged anywhere, either on the server event logs or on the local machine event logs... I have searched the MS KB & Office online, but no joy yet... If anyone can help that would be great!!! R ...

Redirect Exchange 2000 IS backup to different Exchange 2003 server
I recently added an Exchange 2003 server to the same org as a 2000 server. I have dbs from the 2000 server that I need to restore to retrieve email from a user whose mailbox was moved to 2003. So I need to restore the db for that mailbox from BEFORE it was moved because when you move mailboxes you lose any deleted items that were being saved by retention policy. Is this possible? I'm using Veritas Backup Exec 10 but nothing in their support KB seems to follow this exact scenario. If it helps, the old Exch 2000 server is currently empty of users and is ready to be uninstalled. W...

eConnect Outgoing
We have a system that feeds Invoices into Payables Transactions in GP. GP is used to generate Payments (Checks) for these transactions. I'd like to use eConnect Outgoing services to read what check paid what invoices. I am able to get the check transaction pushed into the eConnect_Out table along with the invoices that are being paid. Though, I do not see a way to figure out which check paid what invoice. If anyone else has encountered this before, we will appreciate your input. Best Regards, RS ...

Recreating site/directory connectors on 2003?
Just got the first 2003 server up and running. We have a single domain, and two sites/admin groups. SiteA contains the current 5.5 server (ServerA) and the new 2003 server (ServerB). SiteB contains a single 5.5 server (ServerC). There is a site connector created under 5.5 between SiteA and SiteB with ServerA and ServerC as the bridgeheads in each site. There is also a directory replication connector between SiteA and SiteB, again with ServerA and ServerC as the bridgeheads in each site. The ADC is installed and working with the default mailbox/public folder CA's for both SiteA ...

Exchange 2007 Content Conversion/Encoiding issue.
Hello I have an Exchange 2007 RTM box running in a Windows 2003 only domain. When we scan a document from our Dell 1815n multifunction and have the output emailed, the document shows up as encoded garble instead of an attached document. A message header from a bad email is below. When we scan a document from the same device and send it to a mailbox that still lives on our last remaining Exchange 2003 server, the output from the scanner is attached as a PDF document normally. Any ideas? Thanks Michael Buckley Header from email recieved to Exchange 2007: (server names and I...

XSL Problem
Hi, I have the following problem. There are 3 files. ------------------------------------------------------- a) XML file <?xml version="1.0" encoding="UTF-8"?> <?xml-stylesheet type="text/xsl" href="hall.xsl"?> <quizcirclecontests> <contest> <id>1</id> <date>15-Nov-02 to 22-Nov-02</date> <participants> <name>AS</name> <name>JP</name> </participants> </contest> <contest> <i...