oma doesn't work #2

The oma on my Exchange 2003 SP2 cluster stopped working recently. 

From the web page I get the following info :

-------------------------------------------------------------------------------------------------

Stack Trace: 


[InvalidOperationException: Collection was modified; enumeration operation 
may not execute.]
   System.Collections.ArrayListEnumeratorSimple.MoveNext() +2756158
   Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean 
value) +167
   Microsoft.Exchange.OMA.UserInterface.Global..ctor() +262
   ASP.global_asax..ctor() +5

[TargetInvocationException: Exception has been thrown by the target of an 
invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean 
publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, 
Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean 
fillCache) +103
   System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean 
skipVisibilityChecks, Boolean fillCache) +261
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +66
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder 
binder, Object[] args, CultureInfo culture, Object[] activationAttributes) 
+1036
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, 
Binder binder, Object[] args, CultureInfo culture, Object[] 
activationAttributes) +114
   
System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext 
context) +184
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext 
context) +106
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +317

 
-------------------------------------------------------------------------------------------------


In event viewer I get the following ASP.NET 2.0.50727.0 EventID 1309 warning :




Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: 21/11/2006 14:37:33 
Event time (UTC): 21/11/2006 13:37:33 
Event ID: a8b4948f198646fe83f52e796a0f09eb 
Event sequence: 2 
Event occurrence: 1 
Event detail code: 0 
 
Application information: 
    Application domain: /LM/W3SVC/101/root/OMA-1-128085898535568022 
    Trust level: Full 
    Application Virtual Path: /OMA 
    Application Path: C:\Program Files\Exchsrvr\OMA\Browse\ 
    Machine name: SEDUSAN01 
 
Process information: 
    Process ID: 6748 
    Process name: w3wp.exe 
    Account name: NT AUTHORITY\NETWORK SERVICE 
 
Exception information: 
    Exception type: InvalidOperationException 
    Exception message: Collection was modified; enumeration operation may 
not execute. 
 
Request information: 
    Request URL: http://172.23.15.60/OMA/oma.aspx 
    Request path: /OMA/oma.aspx 
    User host address: 172.23.15.60 
    User:  
    Is authenticated: False 
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE 
 
Thread information: 
    Thread ID: 1 
    Thread account name: NT AUTHORITY\NETWORK SERVICE 
    Is impersonating: False 
    Stack trace:    at 
System.Collections.ArrayList.ArrayListEnumeratorSimple.MoveNext()
   at Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean 
value)
   at Microsoft.Exchange.OMA.UserInterface.Global..ctor()
   at ASP.global_asax..ctor() 

-------------------------------------------------------------------------------------------------


I've seen a number of posts in different forums for this problem but haven't 
found an answer. Any ideas ?
0
Wooden (1)
11/21/2006 1:42:02 PM
exchange.admin 57650 articles. 2 followers. Follow

2 Replies
292 Views

Similar Articles

[PageSpeed] 36

Did you try re-registering your ASP.NET?

http://support.microsoft.com/?id=306005

James Chong

Gary Wooden wrote:
> The oma on my Exchange 2003 SP2 cluster stopped working recently.
>
> From the web page I get the following info :
>
> -------------------------------------------------------------------------------------------------
>
> Stack Trace:
>
>
> [InvalidOperationException: Collection was modified; enumeration operation
> may not execute.]
>    System.Collections.ArrayListEnumeratorSimple.MoveNext() +2756158
>    Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean
> value) +167
>    Microsoft.Exchange.OMA.UserInterface.Global..ctor() +262
>    ASP.global_asax..ctor() +5
>
> [TargetInvocationException: Exception has been thrown by the target of an
> invocation.]
>    System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean
> publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor,
> Boolean& bNeedSecurityCheck) +0
>    System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean
> fillCache) +103
>    System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean
> skipVisibilityChecks, Boolean fillCache) +261
>    System.Activator.CreateInstance(Type type, Boolean nonPublic) +66
>    System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder
> binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
> +1036
>    System.Activator.CreateInstance(Type type, BindingFlags bindingAttr,
> Binder binder, Object[] args, CultureInfo culture, Object[]
> activationAttributes) +114
>
> System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext
> context) +184
>    System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext
> context) +106
>    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +317
>
>
> -------------------------------------------------------------------------------------------------
>
>
> In event viewer I get the following ASP.NET 2.0.50727.0 EventID 1309 warning :
>
>
>
>
> Event code: 3005
> Event message: An unhandled exception has occurred.
> Event time: 21/11/2006 14:37:33
> Event time (UTC): 21/11/2006 13:37:33
> Event ID: a8b4948f198646fe83f52e796a0f09eb
> Event sequence: 2
> Event occurrence: 1
> Event detail code: 0
>
> Application information:
>     Application domain: /LM/W3SVC/101/root/OMA-1-128085898535568022
>     Trust level: Full
>     Application Virtual Path: /OMA
>     Application Path: C:\Program Files\Exchsrvr\OMA\Browse\
>     Machine name: SEDUSAN01
>
> Process information:
>     Process ID: 6748
>     Process name: w3wp.exe
>     Account name: NT AUTHORITY\NETWORK SERVICE
>
> Exception information:
>     Exception type: InvalidOperationException
>     Exception message: Collection was modified; enumeration operation may
> not execute.
>
> Request information:
>     Request URL: http://172.23.15.60/OMA/oma.aspx
>     Request path: /OMA/oma.aspx
>     User host address: 172.23.15.60
>     User:
>     Is authenticated: False
>     Authentication Type:
>     Thread account name: NT AUTHORITY\NETWORK SERVICE
>
> Thread information:
>     Thread ID: 1
>     Thread account name: NT AUTHORITY\NETWORK SERVICE
>     Is impersonating: False
>     Stack trace:    at
> System.Collections.ArrayList.ArrayListEnumeratorSimple.MoveNext()
>    at Microsoft.Exchange.OMA.Tracing.OmaTrace.set_DebugOutputTracing(Boolean
> value)
>    at Microsoft.Exchange.OMA.UserInterface.Global..ctor()
>    at ASP.global_asax..ctor()
>
> -------------------------------------------------------------------------------------------------
>
>
> I've seen a number of posts in different forums for this problem but haven't
> found an answer. Any ideas ?

0
jamestechman (1266)
11/21/2006 4:10:14 PM
I checked the kb article and it didn't seem to fit too well but I applied it 
anyways since it can't break anything. Unfortunately the om still doesn't 
work and gives the same error messages.
0
11/21/2006 4:25:01 PM
Reply:

Similar Artilces:

junk mail filter doesn't work with rules?
Hello, I receive mail from many pop3 accounts and mailing lists. I use rules to organize the mail within my mailbox. One problem I am having is that the junk mail filter does not screen mail that is affected by the rules. So for instance, I get an email from some alternate account that I have. The mail comes in and gets picked up by the rule and moved to the appropriate folder. When this happens, the junk mail filter never checks the message. Only mail left in the Inbox is screened. Can someone help figure out how to make this work or does anyone have a workaround? I'd hate to ...

Problems with creating a newsletter
I chose the form "Newsletter - email". I have created a 3 page newsletter. Now, I have NO IDEA how to send it out as an email. I do not want to send it as an attachment. I cannot figure out which "save as" format or what I need to do so that i can email this newsletter. Is there a website that goes through how to do this? Am I correct when I say that it has to be html in order for me to send it as email? That is not one of the options. Any help you give me would be greatly appreciated. Thank you, Markis www.adreamforabetterworld.com ...

Meeting updates #2
My users cannot update meetings created when they were on the old email server. I have noticed that the old string is still mapped to the meeting. e.g x400;c=us;a= ;p=Org name;o=exchagne;s=Lastname;g=firstname; Take a look at the following article: 275134 XADM: Cannot Reply to Messages That Are Sent from a User Account That http://support.microsoft.com/?id=275134 The same thing applies to meetings. How did you move them and what version(s) of Exchange? Thanks, Richard Roddy Microsoft Exchange Support This posting is provided "AS IS" with no warranties, and confers no ri...

Changing SQL Server for CRM 1.2
As my SQL server is currently on its last breath I am in the process of moving our CRM 1.2 databases to a new dedicated serever. I have detatched the databases from the old server, copied the files to the server and attached them. I have then gone into CRM deployment manager and changed to the SQL server to the new server. That all appears to work fine, no error messages. But when users try to access the CRM system they get an error and the CRM server event log fills with error messages. A few are listed below: dmLog: Failed to execute the SQL batch in the file sqlbatch.sql. MSCRM P...

How do you turn off/on the "1" or "2" or "+" or "-" view hide/unh.
What is or how do you control, turn on/off the small "1" "2" or "+" "-" hide/unhide view buttons right above the "A" cell? Sometimes shows when I hide columns. Hi 'Data - Goup/Outline' -- Regards Frank Kabel Frankfurt, Germany Seth wrote: > What is or how do you control, turn on/off the small "1" "2" or "+" > "-" hide/unhide view buttons right above the "A" cell? Sometimes > shows when I hide columns. You can toggle them to hide or display with <Ctrl> <8> Usi...

Steps to Share Outlook on 2 different drives
This is a problem created by a dual boot of XPPSP2 on one drive C:\ and Vista on another drive E:\ that I use to format for new builds of Vista on the same box. I want to take my Outlook 2003 in box and folders on two different drives on one box and combine them so that all the emails go to one account and all the folders can be shared or used on each drive. I want to do the same with Outlook Express as well, and since this is an *Outlook newsgroup, I'll just take what I learn here and apply it to the ..dbx folder(s) in it. The idea is to receive email on both drives in one in one...

printing 2 charts on single page
Using Excel 2k, Win 2k I was trying to print to line charts on a single page to demonstrate the corelation between the two data sets. I would like to print in portait mode with one chart on top of page and one on bottom. Excel only seems to offer putting chart 2 on a separate page or embedding it in chart one. I am not very familiar with excel charting capabilites can anyone suggest a resorce? Thanks ...

Offline folder problems #2
Hi Guys, Basically I installed Outlook 97 on my office PC which is connect to microsoft exchange server. For some reason all of my messages were copied into offline folders, this causes a problem, whenever I open up outlook I get this message. Upload of offline changes could not be completed you do not have sufficient permission to perform this operation on this object. See the folder contact or see your system administrator. I do not administrator access on my user profile, every time I open outlook it resets everything I have changed (view etc) and gives that error message. How ...

Receiving Transaction Entry #2
I went into Receiving Transaction Entry to record the receipt of an item. The invoiced price did not agree with the purchase order. I had to add Shipping and adjust the provincial tax. I went to the proper screen to over-ride the calculated tax and the system told me that I couldn't do that because I had not filled in all the BOLD, RED areas. At that point I wanted to close down that screen, but the system would not let me do that either. I could minimize the screen and then I could also see that there wasn't any required information that had not be entered. The only way I c...

Opening pub files created with older Publisher versions #2
I have just upgraded to Publisher 2003 from 2000 and am having trouble with pub files sent to me for our chuch newsletter which is using Publisher 97 The text is not wrapping around graphics boxes. Can I fix this? I really don't want to go back to Pub 200 Thank Richard this is caused by Publisher 97 not been printer independent. Even if you went back to Publisher 2000, unless you have the identical font versions and printer driver you would have issues with formatting. It sounds like the person sending you the file has a garbage HP inkjet printer. Get them to install the HP5P laser p...

Associating Multiple Existing Contacts to an Account, Until CRM 2.x
I have racked my pea-sized brain for endless days for a way to associate multiple existing contacts (or accounts) to an account. My client has accounts that have many contacts (or accounts) involved at different stages of acquiring a new account. The logical method would be to add a custom attribute with lookup functionality into the existing CRM contact or account objects but this is not possible with CRM 1.x. The resulting UI would allow an end user to associate different contacts (or accounts) to an account. Example: Account: ABC - AccountPhysician: (existing account or con...

Ctrl+D not working on outlook messages
Any idea why? alltimefav wrote: > Any idea why? And what are you expecting to happen? "alltimefav" wrote in message news:a95c52df-a387-4a8f-bf9d-269ff485451f@i29g2000prf.googlegroups.com... > Any idea why? So instead of hitting Ctrl+D to delete an item, what happens when the item is selected and you hit the Del key, or the "X" toolbar button, or right-click on the item and select Delete? Did you really expect a detailed response for such a vague question? You didn't even bother to say what "not working" means, like the item does not get delete...

VCard issue #2
This is a weird problem, but when I send a vcard to someone, it shows up in my sent items as a vcf file, and has a vcard icon on it, but when the recipient gets the VCard, it shows up as msg file, with an envelope icon as the attachment. When I open it, nothing is there - it's empty. I can't find anything regarding this problem on google or MS's website. Anybody have any ideas? Is it a problem with Outlook? Do I need to do a detect and repair, a reinstallation? Thanks for your help! Does the same happen when you send a message to yourself? Is he/she able to see it w...

Some Excel formatting functions taking a long time to work #2
Excel 2000 SP3 When I use some formatting functions for the first time in a session, such as bold, increasing font size etc, it takes up to 30 seconds to work. Meantime Excel is locked up until it completes that formatting call. I suspect faulty DLL? Has anyone experienced this? How to fix (other than a complete re- install) ? Any advice appreciated. Piri On Nov 5, 8:39=A0am, Piri <wiremu.pare...@hotmail.com> wrote: > Excel 2000 SP3 > When I use some formatting functions for the first time in a > session, such as bold, increasing font size etc, it takes =A0up to 30 > secon...

how to make macro work even a sheet is hidden.
hello there I have macro assigned to a button in Sheet 1 which goes to sheet 2. Press a button to Refresh and then PRINT preview It does work in normal state. I do not want the user to see the Sheet 2. I hid sheets from Format-sheet-hide. but the macro is not working when sheet 2 is hidden. how to overcome this error "can't execute code in break mode" the macro code is Sub Print_Preview() Sheets("PaySlips2009-10").Select Application.Run "'Latest 2009Payslip.xls'!Sheet2.HURows" ActiveWindow.SelectedSheets.PrintPreview ...

2 Domains, 1 Exchange Server
Hi, We're trying to go with 2 seperate 2003 domains, but with only one Exchange 2003 Server. What would be needed for the domain that the Exchange server is not in to access e-mail? We've contemplated having those users use OWA, but would really like them to be able to use Outlook 2003. We're a school district and want to segregate the kids domain from the administration domain, but only have funding for one Exchnage server. Any ideas\help will be appreciated. TIA. Hi, This should explain what it requires: http://support.microsoft.com/?id=278888 Leif "tj woo...

Creating a Macro to Delete Commas #2
I have an excel file that the size will varry. I need a macro that will check all the fields for a comma. If there is one I would like to get rid of it. Does anyone have any idea how to do this? I have no idea and I have been assigned this task. Help --- Message posted from http://www.ExcelForum.com/ No macro required. ctrl-H for find/replace. find , replace nothing (leave the replace field blank). You can of course record that within a macro if you wish. Drabbacs >-----Original Message----- >I have an excel file that the size will varry. I need a macro that will >check ...

how do I import my contacts from IncrediMail 2.0 to MOutlook2007
I am new to using microsoft outlook 2007 and am searching for a way to upload my contact list, from Incredimail 2.0 to Outlook 2007. Any help would be definitely appreciated, thanks! How do I save my IncrediMail Address Book and move it to a different location? http://help.incredimail.com/incredimail/help_center/help_article.aspx?is=t&article_id=67&lang_id=9 In Outlook - File --> Import and Export ... import the CSV file created via process noted above Karl -- ____________________________________________________________ Karl Timmermans - The Claxton Group Co...

Money 2004 Debt Planner #2
When trying to add a loan to the debt planner, Money keeps telling me that I am 6 months past due on this particular loan. In reality, I have made consistent entries for each month's payment. This is making it really difficult to use the debt planner! What do I need to do? ...

Indirect Method for Name Box Variable? #2
DARN The reason I want to do this is that I have to collect data on a dail basis but I have to display it on a graph on a weekly basis. I select the entire week of cells and give it a name like week52. The following week I have to select the entire week and name i week53. Everything is set up that I can just copy and the numbers will progres for whatever length of time I need to graph (months, years, etc) excep this. Maybe I'll just go back to using the range of cell numbers. Thanks guys -- Chris Brenna ----------------------------------------------------------------------- Chris Bre...

80070005 error #2
I am getting this error when trying to view public folder property from system manager. My issue is same as what you can find out from http://forums.msexchange.org/ultimatebb.cgi? ubb=get_topic;f=19;t=000114 Anyone has a clue? ...

How do I insert space between 2 consecutive columns of an XL Shee.
I want to have space between two consecutive columns of a worksheet (of course, without having inserted another column between the two) in order to have separated the Border Lines of the adjacent cells/columns. Please guide me if it can be done in XL. Can you achieve the effect that you're looking for by using a double vertical border down the right side of the left column and having no border down the left side of the right column? Rgds, ScottO "Shamshad Butt" <Shamshad Butt@discussions.microsoft.com> wrote in message news:1222EE13-11A9-4354-9F12-D1F1155D3902@microsof...

RMS 1.2 vs 1.3, plus integrate with Great Plains
1.) I am working on an assessment for upgrading our current RMS software from 1.2 to 1.3. My assessment will take in account the benefits, broken down by store operations (Retail) and the benefits to IT. Also, list risks and potential problems that might be experienced. We currently have 28 stores with 3+ registers per location with another 22 new stores on the schedule over the next 2 years. Are their other in this group of similiar size that have done this upgrade to the new version? 2.) If we do not upgrade the software, can we still integrate the RMS to Great Plains? Would we...

HQ Licensing question V.2
I have a client running HQ client at 8 stores + HQ server at the warehouse. They would like to be able to use transfers from the warehouse to the stores, so I would have to setup a new PC running Store Ops and a new database, however, in order for the transfers to take place, I need a HQ Client License correct? Do I also need a POS key? I appreciate any insights you may have. Thanks in advance Hi Phil yes - you'll need an HQ Client license so it can exchange with your headquarters - "export" the wh database as you would any store from HQ no - you won't need a PO...

CRM Email Displays Size=2>
One of my users is experiencing an issue when they save an email that is tracked within CRM the email displays in CRM with "Size=2>" directly in front of certain lines of the email. So for example "Size=2>" will appear in front of someone's comments in the email or in front of their name. Does anyone know why "Size=2>" is displaying in front of the lines of an email? Thanks. Mike H. "Mike H." wrote: > One of my users is experiencing an issue when they save an email that is > tracked within CRM the email displays in CRM wit...