no ndr bounce message

I am using Exchange Server 2003. I belive that since the time that I have 
configured it to use a smarthost that ndr messages are not being delivered to 
senders when they send to an invalid address at my domain. I had to start 
using a smarthost because we were having problems sending email to several 
different domains.

I have gone into the system manager to the properties of "Internet message 
format" and verified that "Allow non-delivery reports" is checked... 

I have tested this from my yahoo account and sending to joejoe@mydomain.com, 
which should send a bounce message back to my yahoo account saying that the 
email address couldn't be delivered....

Any help is greatly appreciated.
0
MarkI1 (13)
4/20/2006 2:16:01 PM
exchange.admin 57650 articles. 2 followers. Follow

6 Replies
538 Views

Similar Articles

[PageSpeed] 24

Mark,

First thing to do is enable message tracking and see if an NDR is generated 
and see if it gets sent to the smarthost. Give me a shout if you need help 
doing this.

Regards

Paul Ford
Edge IT Ltd

"Mark I" <MarkI@discussions.microsoft.com> wrote in message 
news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
>I am using Exchange Server 2003. I belive that since the time that I have
> configured it to use a smarthost that ndr messages are not being delivered 
> to
> senders when they send to an invalid address at my domain. I had to start
> using a smarthost because we were having problems sending email to several
> different domains.
>
> I have gone into the system manager to the properties of "Internet message
> format" and verified that "Allow non-delivery reports" is checked...
>
> I have tested this from my yahoo account and sending to 
> joejoe@mydomain.com,
> which should send a bounce message back to my yahoo account saying that 
> the
> email address couldn't be delivered....
>
> Any help is greatly appreciated. 


0
paulford1 (138)
4/20/2006 2:39:33 PM
Paul,

Thank you for your reply. In the message tracking where is should say 
"message transferred to dukecmmtar02.coxmail.com" for the smarthost, it says 
"SMTP: Message sent to Badmail"... not sure where Badmail comes from.


"Paul Ford" wrote:

> Mark,
> 
> First thing to do is enable message tracking and see if an NDR is generated 
> and see if it gets sent to the smarthost. Give me a shout if you need help 
> doing this.
> 
> Regards
> 
> Paul Ford
> Edge IT Ltd
> 
> "Mark I" <MarkI@discussions.microsoft.com> wrote in message 
> news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
> >I am using Exchange Server 2003. I belive that since the time that I have
> > configured it to use a smarthost that ndr messages are not being delivered 
> > to
> > senders when they send to an invalid address at my domain. I had to start
> > using a smarthost because we were having problems sending email to several
> > different domains.
> >
> > I have gone into the system manager to the properties of "Internet message
> > format" and verified that "Allow non-delivery reports" is checked...
> >
> > I have tested this from my yahoo account and sending to 
> > joejoe@mydomain.com,
> > which should send a bounce message back to my yahoo account saying that 
> > the
> > email address couldn't be delivered....
> >
> > Any help is greatly appreciated. 
> 
> 
> 
0
MarkI1 (13)
4/20/2006 3:00:02 PM
Badmail is a folder on the server where it places mail that it cannot 
process. Is it jst NDRs that this is happening on ? What about normal 
messages or read receipts ? Describe your environment a bit more, is it a 
single server environment or multiple servers ? What anti-virus software do 
you have on the Exchange Server ? What other third party software do you 
have on the Exchange server ?

Regards

Paul Ford
Edge IT Ltd

"Mark I" <MarkI@discussions.microsoft.com> wrote in message 
news:2B6CF3D2-71A5-4FD1-B0CB-CA39DFDC8098@microsoft.com...
> Paul,
>
> Thank you for your reply. In the message tracking where is should say
> "message transferred to dukecmmtar02.coxmail.com" for the smarthost, it 
> says
> "SMTP: Message sent to Badmail"... not sure where Badmail comes from.
>
>
> "Paul Ford" wrote:
>
>> Mark,
>>
>> First thing to do is enable message tracking and see if an NDR is 
>> generated
>> and see if it gets sent to the smarthost. Give me a shout if you need 
>> help
>> doing this.
>>
>> Regards
>>
>> Paul Ford
>> Edge IT Ltd
>>
>> "Mark I" <MarkI@discussions.microsoft.com> wrote in message
>> news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
>> >I am using Exchange Server 2003. I belive that since the time that I 
>> >have
>> > configured it to use a smarthost that ndr messages are not being 
>> > delivered
>> > to
>> > senders when they send to an invalid address at my domain. I had to 
>> > start
>> > using a smarthost because we were having problems sending email to 
>> > several
>> > different domains.
>> >
>> > I have gone into the system manager to the properties of "Internet 
>> > message
>> > format" and verified that "Allow non-delivery reports" is checked...
>> >
>> > I have tested this from my yahoo account and sending to
>> > joejoe@mydomain.com,
>> > which should send a bounce message back to my yahoo account saying that
>> > the
>> > email address couldn't be delivered....
>> >
>> > Any help is greatly appreciated.
>>
>>
>> 


0
paulford1 (138)
4/20/2006 3:26:26 PM
Single server (Windows 2000 Server). It acts as just a basic file serve but 
also running exchange, active directory. Using Norton Anti-Virus. I dont' 
know if this is happening on read-receipts or out-of-office replies... I'll 
take a look. 


"Paul Ford" wrote:

> Badmail is a folder on the server where it places mail that it cannot 
> process. Is it jst NDRs that this is happening on ? What about normal 
> messages or read receipts ? Describe your environment a bit more, is it a 
> single server environment or multiple servers ? What anti-virus software do 
> you have on the Exchange Server ? What other third party software do you 
> have on the Exchange server ?
> 
> Regards
> 
> Paul Ford
> Edge IT Ltd
> 
> "Mark I" <MarkI@discussions.microsoft.com> wrote in message 
> news:2B6CF3D2-71A5-4FD1-B0CB-CA39DFDC8098@microsoft.com...
> > Paul,
> >
> > Thank you for your reply. In the message tracking where is should say
> > "message transferred to dukecmmtar02.coxmail.com" for the smarthost, it 
> > says
> > "SMTP: Message sent to Badmail"... not sure where Badmail comes from.
> >
> >
> > "Paul Ford" wrote:
> >
> >> Mark,
> >>
> >> First thing to do is enable message tracking and see if an NDR is 
> >> generated
> >> and see if it gets sent to the smarthost. Give me a shout if you need 
> >> help
> >> doing this.
> >>
> >> Regards
> >>
> >> Paul Ford
> >> Edge IT Ltd
> >>
> >> "Mark I" <MarkI@discussions.microsoft.com> wrote in message
> >> news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
> >> >I am using Exchange Server 2003. I belive that since the time that I 
> >> >have
> >> > configured it to use a smarthost that ndr messages are not being 
> >> > delivered
> >> > to
> >> > senders when they send to an invalid address at my domain. I had to 
> >> > start
> >> > using a smarthost because we were having problems sending email to 
> >> > several
> >> > different domains.
> >> >
> >> > I have gone into the system manager to the properties of "Internet 
> >> > message
> >> > format" and verified that "Allow non-delivery reports" is checked...
> >> >
> >> > I have tested this from my yahoo account and sending to
> >> > joejoe@mydomain.com,
> >> > which should send a bounce message back to my yahoo account saying that
> >> > the
> >> > email address couldn't be delivered....
> >> >
> >> > Any help is greatly appreciated.
> >>
> >>
> >> 
> 
> 
> 
0
MarkI1 (13)
4/20/2006 3:35:03 PM
Ouf of Office replies work fine.


"Mark I" wrote:

> Single server (Windows 2000 Server). It acts as just a basic file serve but 
> also running exchange, active directory. Using Norton Anti-Virus. I dont' 
> know if this is happening on read-receipts or out-of-office replies... I'll 
> take a look. 
> 
> 
> "Paul Ford" wrote:
> 
> > Badmail is a folder on the server where it places mail that it cannot 
> > process. Is it jst NDRs that this is happening on ? What about normal 
> > messages or read receipts ? Describe your environment a bit more, is it a 
> > single server environment or multiple servers ? What anti-virus software do 
> > you have on the Exchange Server ? What other third party software do you 
> > have on the Exchange server ?
> > 
> > Regards
> > 
> > Paul Ford
> > Edge IT Ltd
> > 
> > "Mark I" <MarkI@discussions.microsoft.com> wrote in message 
> > news:2B6CF3D2-71A5-4FD1-B0CB-CA39DFDC8098@microsoft.com...
> > > Paul,
> > >
> > > Thank you for your reply. In the message tracking where is should say
> > > "message transferred to dukecmmtar02.coxmail.com" for the smarthost, it 
> > > says
> > > "SMTP: Message sent to Badmail"... not sure where Badmail comes from.
> > >
> > >
> > > "Paul Ford" wrote:
> > >
> > >> Mark,
> > >>
> > >> First thing to do is enable message tracking and see if an NDR is 
> > >> generated
> > >> and see if it gets sent to the smarthost. Give me a shout if you need 
> > >> help
> > >> doing this.
> > >>
> > >> Regards
> > >>
> > >> Paul Ford
> > >> Edge IT Ltd
> > >>
> > >> "Mark I" <MarkI@discussions.microsoft.com> wrote in message
> > >> news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
> > >> >I am using Exchange Server 2003. I belive that since the time that I 
> > >> >have
> > >> > configured it to use a smarthost that ndr messages are not being 
> > >> > delivered
> > >> > to
> > >> > senders when they send to an invalid address at my domain. I had to 
> > >> > start
> > >> > using a smarthost because we were having problems sending email to 
> > >> > several
> > >> > different domains.
> > >> >
> > >> > I have gone into the system manager to the properties of "Internet 
> > >> > message
> > >> > format" and verified that "Allow non-delivery reports" is checked...
> > >> >
> > >> > I have tested this from my yahoo account and sending to
> > >> > joejoe@mydomain.com,
> > >> > which should send a bounce message back to my yahoo account saying that
> > >> > the
> > >> > email address couldn't be delivered....
> > >> >
> > >> > Any help is greatly appreciated.
> > >>
> > >>
> > >> 
> > 
> > 
> > 
0
MarkI1 (13)
4/20/2006 3:42:02 PM
Do you forward onto a smarthost or use DNS for name resolution ?
Do you have any kindof event sinks running on the Exchange Server ?
First step I would try is to disable/uninstall Norton and see if this is 
affecting it, if its not at least we have eliminated it from the picture.

Regards

Paul Ford

"Mark I" <MarkI@discussions.microsoft.com> wrote in message 
news:EB88D13E-46B5-471B-97B6-C0650CCF585D@microsoft.com...
> Ouf of Office replies work fine.
>
>
> "Mark I" wrote:
>
>> Single server (Windows 2000 Server). It acts as just a basic file serve 
>> but
>> also running exchange, active directory. Using Norton Anti-Virus. I dont'
>> know if this is happening on read-receipts or out-of-office replies... 
>> I'll
>> take a look.
>>
>>
>> "Paul Ford" wrote:
>>
>> > Badmail is a folder on the server where it places mail that it cannot
>> > process. Is it jst NDRs that this is happening on ? What about normal
>> > messages or read receipts ? Describe your environment a bit more, is it 
>> > a
>> > single server environment or multiple servers ? What anti-virus 
>> > software do
>> > you have on the Exchange Server ? What other third party software do 
>> > you
>> > have on the Exchange server ?
>> >
>> > Regards
>> >
>> > Paul Ford
>> > Edge IT Ltd
>> >
>> > "Mark I" <MarkI@discussions.microsoft.com> wrote in message
>> > news:2B6CF3D2-71A5-4FD1-B0CB-CA39DFDC8098@microsoft.com...
>> > > Paul,
>> > >
>> > > Thank you for your reply. In the message tracking where is should say
>> > > "message transferred to dukecmmtar02.coxmail.com" for the smarthost, 
>> > > it
>> > > says
>> > > "SMTP: Message sent to Badmail"... not sure where Badmail comes from.
>> > >
>> > >
>> > > "Paul Ford" wrote:
>> > >
>> > >> Mark,
>> > >>
>> > >> First thing to do is enable message tracking and see if an NDR is
>> > >> generated
>> > >> and see if it gets sent to the smarthost. Give me a shout if you 
>> > >> need
>> > >> help
>> > >> doing this.
>> > >>
>> > >> Regards
>> > >>
>> > >> Paul Ford
>> > >> Edge IT Ltd
>> > >>
>> > >> "Mark I" <MarkI@discussions.microsoft.com> wrote in message
>> > >> news:18E6FAC8-8916-48F2-98D5-A6A4196A11C6@microsoft.com...
>> > >> >I am using Exchange Server 2003. I belive that since the time that 
>> > >> >I
>> > >> >have
>> > >> > configured it to use a smarthost that ndr messages are not being
>> > >> > delivered
>> > >> > to
>> > >> > senders when they send to an invalid address at my domain. I had 
>> > >> > to
>> > >> > start
>> > >> > using a smarthost because we were having problems sending email to
>> > >> > several
>> > >> > different domains.
>> > >> >
>> > >> > I have gone into the system manager to the properties of "Internet
>> > >> > message
>> > >> > format" and verified that "Allow non-delivery reports" is 
>> > >> > checked...
>> > >> >
>> > >> > I have tested this from my yahoo account and sending to
>> > >> > joejoe@mydomain.com,
>> > >> > which should send a bounce message back to my yahoo account saying 
>> > >> > that
>> > >> > the
>> > >> > email address couldn't be delivered....
>> > >> >
>> > >> > Any help is greatly appreciated.
>> > >>
>> > >>
>> > >>
>> >
>> >
>> > 


0
paulford1 (138)
4/21/2006 3:25:59 PM
Reply:

Similar Artilces:

New message To, CC, BCC and Subject fields don't accept 'delete'
Hi all, I'm having a bit of a problem, actually more like an annoyance: whenever I create a new mail (that includes replying, forwarding etc...) I can type in the header field no problem. However, if I hit 'delete' or 'back' it does not deletethe characters in the field, but the ones in the email body! the only way I can get rid of something I already typed in those fields is by highlighting it and typing over it. It started happening recently, without me doing anything special. I have tried deleting the normal.dot, frmcache.dat and outcmd.dat (the last too out of hope r...

Can Exchange messaging sessions be saved for posterior auditing?
Hi all, We just started to use Exchange Messaging in our enterprise. It looks to become a very useful tool for management. It has the advantage of the written word. You can see what was written before so it is potentially auditable. My boss is asking me if is it possible to save a log of everything that is written on the service. I remember icq had this very useful thing. Is possible to save a log on the server of everything that is written by the users? Is it any vendor with such a solution? Thanks in advance Sammy On Thu, 10 Nov 2005 09:03:27 -0600, "SammyBar" <samm...

Message Count under Inbox
Dear All, Would there be any ways that we can issue a command line call to our Exchange 2003 Server and find out the number of messages currently stored under the Inbox? If there is, could you let me know how please? Any help will muchly be appreciated. Thanks and Regards Andy ...

Send many email messages
Currently when I send many emails there is a significant delay between each email as I wait for the mesaage to actually be sent Is there any way to send it quicker? On Thu, 28 Jun 2007 13:25:17 +0100, "Samuel" <samuel.shulman@ntlworld.com> wrote: >Currently when I send many emails there is a significant delay between each >email as I wait for the mesaage to actually be sent > >Is there any way to send it quicker? How are you sending the emails? > > Scott McDaniel scott@takemeout_infotrakker.com www.infotrakker.com SendObject "Scott McDaniel&...

Outlook 2003
Hello, I migrate from Outlook Express 6 to Outlook 2003. I have problems with my rules: I have a first set of rules to MOVE messages to specific folders according to e-mail addresses (To: ...) AND a second set of rules to filter spam (MOVE messages to Deleted Items) This set of rules worked perfectly with OE6 (more than 90% of spam filtered). With Outlook 2003, COPIES of messages filtered remain in Inbox and specific folders of first set of rules. So I have now 3 copies of 200 junk mails per day, now... It is a real problem Why does Outlook make COPIES of the messages when I ask to MOVE t...

Error with permissions, error sending messages, just too many erro
I must be doing something wrong, because everyone I've shown this server to says they have nevre seen this many problems with Exchange on an out-of-the-box installation. It never occured to me that extreme sensitivity of this application would be the biggest problem I am having with it... I can right click on a message in my Public Folder contact lists, click on "New Message to Contact" and it will create an e-mail to the person. Sounds good right? This process works for every single folder *EXCEPT* one. When I try to send a message to any contact in that folder (and i...

[ANN] How-To: Dealing with error messages and solving problems
Today's article outlines how to find help when you receive an error or if you are experiencing problems. Before asking on a mailing list, newsgroup or calling support, check the Error Page or the Solve Crashes & Conflicts Page. Searching for answers if often the quickest way to find an answer, plus when you search for answers yourself you often find other bits of useful info along the way. Don't expect someone else to always provide the answers. For example: You receive the error "The action could not be completed. An unknown error (4362) occurred." How do you find what ...

why is my typing in message not showing up?
i cannot create a new message without selecting font color for each message even though i have selected auto. how do i correct this? Are you using stationary? Perhaps your text is set to be the same colour as the background. "camel" <camel@discussions.microsoft.com> wrote in message news:4694EA48-ABE5-48D9-AA7F-200A9E146F9C@microsoft.com... > i cannot create a new message without selecting font color for each message > even though i have selected auto. how do i correct this? On 3/19/2010 8:45 AM, Orland, Kathleen wrote: > Are you using stationary? Pe...

Some messages in Outlook 2007 appear empty
Hello, I guess I am not the only one to face this issue. For some reason, some messages in outlook 2007 sent to me appear empty (without body); there is subject, CC: etc but no body of the message. When the message is sent to someone else besides me, the other person will see the content. Even when double clicked or saved to file, there is no body. Is there a way to fix this? I have no solution but am attempting to solve same issue. I have noticed that these message without content are generally from someone who has replied to my message sent to them. Additionally my email server is runni...

error message when shutting down Microsoft outlook
I have just started using Outlook (previously Outlook Express) when I downloaded trial version of McAfee Spam. Message comes up saying "Microsoft Outlook has encountered a promlem and needs to close. We are sorry for the inconvenience." Why is this I have checked all the settings that I know of. Have you tried removing the McAfee product to see if it's causing the problem? "SVA" <SVA@discussions.microsoft.com> wrote in message news:CB626E03-8610-4030-A1DD-EF2761DC7D75@microsoft.com... >I have just started using Outlook (previously Outlook Express) when...

Outlook 2003 messages no longer showing extending characters
Greetings, Has anyone else experienced this recently? It started happening over the last week. Does anyone know how to correct this issue? Thanks, Mike "Mike Forman" <msf427@hotmail.com> wrote in message news:jhbDe.15687$3o4.10429@tornado.socal.rr.com... > Greetings, > > Has anyone else experienced this recently? It started happening over the > last week. Does anyone know how to correct this issue? > > Thanks, > > Mike > What do you mean by "extending characters"? Sorry. I receive a lot of messages from Asia. For some reas...

Can I import my previous message w/o "Folders.dbx"
Hi, I just knew that importing the previous OE mail message requires the file "Folders.dbx". Because I have lost this file, is there any way to import my previous OE5 message / folders to OE6 without checking the file "Folders.dbx"? Symptom: Whenever I try to import the previous mail message, an "Import Message" says - No message can be found in this folder or another application is running that has the required files open. Please select another folder or try closing applications that may have files open. It doesn't work either do I put the previous f...

FYI: Open Word doc without unwanted messages
With the help of Doug Steele (thanks!) I was able to create a function to open Word docs more smoothly. Maybe it can be of use to someone else. See below for code and comments. Lars Function fOpenWordDoc(strFullPath As String) On Error GoTo Err_Handler 'Purpose: Open/BringToFront Word document without unwanted messages 'Comment: This function either opens a Word document or, ' if already opened by the user, brings it to front. ' Bringing it to front and not re-opening the Word ' document, prevents the default Word dial...

Cannot send messages
Hi all, thanks in advance for reading this. Our router died and we got a new one. I had the port 25 and 110 mapped, which allowed all the incoming to come in, but the outgoing is still qued and will not send. Any ideas? Exch 5.5. THANK YOU. Question 1 Do you have a Firewall ? What Flavor ? Question 2 What version of Exchange are you running ? Question 3 Did you do the following in MS Knowledge Base article. 153119 "David" <anonymous@discussions.microsoft.com> wrote in message news:1222c01c3c011$df8ad2e0$a601280a@phx.gbl... > Hi all, thanks in advance for reading...

repeated messages
i cant seem to stop a particular message from continuing to appear in my inbox -- over and over. i keep deleting it and it keeps coming back multiple times -- like once a minute. my i received it iver 100 times yesterday and it is still coming today. it is NOT spam. I did send it to my junk inbox -- so now it goes to delted items but it is still annoying as it keeps coming over and over.i have already received it anotehr 11 times in the past 15 minutes. how do i get it to stop? ali <anonymous@discussions.microsoft.com> wrote: > i cant seem to stop a particular message from c...

Pop up message if marcos are disabled
Hi All, Is there anyway to force a simple pop up message every time particular spreadsheet is opened ONLY IF the user opening it has macro disabled? The pop up message needs to be of the form... 'You have macros disabled' [with one 'OK' button] Any help would be greatly appreciated CHEERS The Grinc -- The Grinc ----------------------------------------------------------------------- The Grinch's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=244 View this thread: http://www.excelforum.com/showthread.php?threadid=39286 No, that would require ...

Message box blocking PostMessage() API
Hi, i am trying to show a message box when i try to quit from my application.I already have 1 thread running in background which does some specific operation.if i wont respond to the message box, i am using PostMessage() to a window which is in another dll.PostMessage() is not doing the job. I could not see the message i have posted using Spy++ resulting in odd behavior of the PostMessage(). Is there anything like 'not responding to a messagebox() will block PostMessage() call' or is it the problem of threads. In my case message is being sent from UI thread of my application to ...

Theme font, Outlook 2007, can't change for new messages received
In Outlook 2007 some, but not all, new incoming messages are presented in a font that's called helvetica, but appears more like ALGERIAN. We have set the font for; New mail messages, Replying or forwarding messages, and Composing and reading plain text messages, to Arial 11, but it has no affect on the messages that are displayed in (?) ALGERIAN or helvetica. In 'Theme or Stationary', '(No Theme)' is selected, but in the pane to the right the heading, bullet, text, etc. all look like ALGERIAN. Some of the messages are to groups, but no other recipients see the ...

Windows Live Mail error message
For the last two days I have had a pop up box every time I open Windows Live mail which says: Sorry, something unexpected happened and Windows Live mail must close. Your most recent changes may not be saved. Obviously when I close the box it closes Windows Live mail. Very frustrating!! ...

Apparently erroneous error message
My client's Outlook (Office 2k) gives the error message "The location messages are delivered to has changed for this user profile. To complete this operation, you may need to copy the contents of the old Outlook folders to the new outlook folders. For information..." When you tell it ok, you get this message: "Outlook could not save the updated folder shortcot information. Check to make sure there is sufficient disk space and that the file "C:\documents and Settings\Administrator\Application Data\Mic..." is nor marked read-only Another attempt to save will be ...

Create rule after email message sent
Is there a way to create a rule, whereby once an email is sent to a recipient it will automatically move to a designated folder. Example send an email to ABC Company from DCE company, i would like to have a folder called DCE and once the email is sent it will automatically move to this designated file. I have found a way to have a copy put into the proper file but not moved. I am trying to avoid having two copies of the same email in two different locations, the sent folder and the dce folder? Anyone have any ideas. I have three different companies I would like to automize this f...

msconfig changes= a message when I start up, and computer manageme
Hi. I recently went into msconfig and shut off some programs at startup. I did not start anything else up. I shut off something to do with my photoediting program, ZuneLauncher (I have a Zune player and the software installed) and an icon that pops up to open and edit my HIDef Audio Deck. The Audio Deck is not the driver or anything, my sound still works. It is the interface to adjust sound properties like the sound icon/option you can adjust in windows notmally. I adjusted NOTHING else. In msconfigs general tab it is not on Normal startup (to load all device drivers and se...

When using Outlook I get "Your message failed" 554 Tranaction
When I try to send certain e-mails (not all) I receive the message "Your message did not reach the intended recipient" " 554 Transaction failed" This message pops=up immediately. Please help. Are you sending via the same SMTP server as the ISP you are using? That type of message usually indicates you are trying to relay through another ISP SMTP server. -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. ALWAYS post your Outlook version. How to ask a question: http://support.microsoft.com/KB/555375 After furious head scrat...

Received a Thread Message in a infinity-looped Thread Function
Hi, I've a thread-function which contains the following code: while (TRUE) { bRet = ReadFile(m_hDevice,&m_szIncomingData,dwNobytestoread,&dwNobytesread,&m_osr); if (!bRet) { WaitForSingleObject(m_osr.hEvent, 1000); } } And also, I want to receive some thread messages. How can I do? Regards, Damon Graham >And also, I want to receive some thread messages. How can I do? Have you considered using MsgWaitForMultipleObjects? Have a look at "Waiting in a Message Loop" in MSDN for an example of its use. Dave -- MVP VC++ FAQ: http://www.mvp...

error message 0x800ccc13 #2
For the past three days, I havew been getting a similar message and I also can send but not receive email through Outlook 2000. I can, however, retrieve my email through my ISP site but I am also stumped as to how to rectify this issue. Any help would be greatly appreciated. ...