Adding SMTP Server after Exchange installation

I wanted to have multiple SMTP services running.

After installing Exchange 2003 I change the port on the SMTP service inside 
Exchange system manager to port 2025.

Then I added a new SMTP service using Internet Information Services, and 
configured that for port 25.  
 
My problem is that as soon as I clicked 'ok' after added the second smtp 
service, I can no longer get in to configure it.  The service does not appear 
in the Internet Information Services list or the Exchange list.  I can verify 
it is running by connecting to port2025 the exchange smtp responds, and 
port25 the smtp I set up responds.  I guess I should have added the new SMTP 
service from exchange, but how should I proceed now?  can I somehow delete 
the invisible smtp entry I made?

Was this clear? was this the right place to post?
0
Reisner (1)
11/15/2004 6:09:07 PM
exchange.admin 57650 articles. 2 followers. Follow

5 Replies
392 Views

Similar Articles

[PageSpeed] 10

Methinks you went about this the wrong way.  The correct method for adding additional SMTP Servers is in Exchange System Manager, not IIS Admin.  In ESM, under server, protocols, SMTP, you would right-click and choose to add a new SMTP Virtual Server.  I'm not sure how exactly you were able to add another SMTP server via IIS, as Exchange takes over that functionality once you install it.

If you uninstall IIS (more specifically, the SMTP portion), then reinstall it, then reinstall Exchange, it should fix this.

Ben Winzenz
Exchange MVP

> I wanted to have multiple SMTP services running.
> 
> After installing Exchange 2003 I change the port on the SMTP service
> inside  Exchange system manager to port 2025.
> 
> Then I added a new SMTP service using Internet Information Services,
> and  configured that for port 25.
> 
> My problem is that as soon as I clicked 'ok' after added the second
> smtp  service, I can no longer get in to configure it.  The service
> does not appear  in the Internet Information Services list or the
> Exchange list.  I can verify  it is running by connecting to port2025
> the exchange smtp responds, and  port25 the smtp I set up responds.  I
> guess I should have added the new SMTP  service from exchange, but how
> should I proceed now?  can I somehow delete  the invisible smtp entry
> I made?
> 
> Was this clear? was this the right place to post?
> 

0
Ben
11/15/2004 6:19:57 PM
Ouch, you think Ill need to re-install exchange, thats my only option?

Well thank you very miuch for your help.

btw: I was able in IIS to just righ-click and choose new smtp server

"Ben Winzenz [Exchange MVP]" wrote:

> Methinks you went about this the wrong way.  The correct method for adding additional SMTP Servers is in Exchange System Manager, not IIS Admin.  In ESM, under server, protocols, SMTP, you would right-click and choose to add a new SMTP Virtual Server.  I'm not sure how exactly you were able to add another SMTP server via IIS, as Exchange takes over that functionality once you install it.
> 
> If you uninstall IIS (more specifically, the SMTP portion), then reinstall it, then reinstall Exchange, it should fix this.
> 
> Ben Winzenz
> Exchange MVP
> 
> > I wanted to have multiple SMTP services running.
> > 
> > After installing Exchange 2003 I change the port on the SMTP service
> > inside  Exchange system manager to port 2025.
> > 
> > Then I added a new SMTP service using Internet Information Services,
> > and  configured that for port 25.
> > 
> > My problem is that as soon as I clicked 'ok' after added the second
> > smtp  service, I can no longer get in to configure it.  The service
> > does not appear  in the Internet Information Services list or the
> > Exchange list.  I can verify  it is running by connecting to port2025
> > the exchange smtp responds, and  port25 the smtp I set up responds.  I
> > guess I should have added the new SMTP  service from exchange, but how
> > should I proceed now?  can I somehow delete  the invisible smtp entry
> > I made?
> > 
> > Was this clear? was this the right place to post?
> > 
> 
> 
0
11/15/2004 6:44:03 PM
Just wanted  to let everyone know that I was able to resolve this by:
1) Remove SMTP in add/remove program
2) Re-Add SMTP in add/remove program
3) With exchange system manager stop the SMTP service, and then start it again

This avoided having to re-install exchange, and thus avoided a reboot.
Step 3 was the trick.  My SMTP within exchange was configured to answer on 
port 2025, but It was answering on port 25 after step 2.  I stopped and 
started SMTP within services but that didnt help, but using ESM to stop and 
start it made it listen on port 2025.


"Ben Reisner" wrote:

> Ouch, you think Ill need to re-install exchange, thats my only option?
> 
> Well thank you very miuch for your help.
> 
> btw: I was able in IIS to just righ-click and choose new smtp server
> 
> "Ben Winzenz [Exchange MVP]" wrote:
> 
> > Methinks you went about this the wrong way.  The correct method for adding additional SMTP Servers is in Exchange System Manager, not IIS Admin.  In ESM, under server, protocols, SMTP, you would right-click and choose to add a new SMTP Virtual Server.  I'm not sure how exactly you were able to add another SMTP server via IIS, as Exchange takes over that functionality once you install it.
> > 
> > If you uninstall IIS (more specifically, the SMTP portion), then reinstall it, then reinstall Exchange, it should fix this.
> > 
> > Ben Winzenz
> > Exchange MVP
> > 
> > > I wanted to have multiple SMTP services running.
> > > 
> > > After installing Exchange 2003 I change the port on the SMTP service
> > > inside  Exchange system manager to port 2025.
> > > 
> > > Then I added a new SMTP service using Internet Information Services,
> > > and  configured that for port 25.
> > > 
> > > My problem is that as soon as I clicked 'ok' after added the second
> > > smtp  service, I can no longer get in to configure it.  The service
> > > does not appear  in the Internet Information Services list or the
> > > Exchange list.  I can verify  it is running by connecting to port2025
> > > the exchange smtp responds, and  port25 the smtp I set up responds.  I
> > > guess I should have added the new SMTP  service from exchange, but how
> > > should I proceed now?  can I somehow delete  the invisible smtp entry
> > > I made?
> > > 
> > > Was this clear? was this the right place to post?
> > > 
> > 
> > 
0
11/15/2004 6:49:06 PM
You are correct, untill I reinstalled exchange the smtp service would no 
longer think that it was handling mail for the domain, and would try to 
deliver the mail externally

"Ben Winzenz [Exchange MVP]" wrote:

> I'm not 100% sure that I would trust that.  In order to manage SMTP correctly, you may need to reinstall Exchange.  Also, you shouldn't have to reboot after reinstalling.  I've never had to that I can recall.
> 
> Ben Winzenz
> Exchange MVP
> 
> > Just wanted  to let everyone know that I was able to resolve this by:
> > 1) Remove SMTP in add/remove program
> > 2) Re-Add SMTP in add/remove program
> > 3) With exchange system manager stop the SMTP service, and then start
> > it again
> > This avoided having to re-install exchange, and thus avoided a reboot.
> > Step 3 was the trick.  My SMTP within exchange was configured to
> > answer on
> > port 2025, but It was answering on port 25 after step 2.  I stopped
> > and
> > started SMTP within services but that didnt help, but using ESM to
> > stop and
> > start it made it listen on port 2025.
> > "Ben Reisner" wrote:
> > 
> >> Ouch, you think Ill need to re-install exchange, thats my only
> >> option?
> >> 
> >> Well thank you very miuch for your help.
> >> 
> >> btw: I was able in IIS to just righ-click and choose new smtp server
> >> 
> >> "Ben Winzenz [Exchange MVP]" wrote:
> >> 
> >>> Methinks you went about this the wrong way.  The correct method for
> >>> adding additional SMTP Servers is in Exchange System Manager, not
> >>> IIS Admin.  In ESM, under server, protocols, SMTP, you would
> >>> right-click and choose to add a new SMTP Virtual Server.  I'm not
> >>> sure how exactly you were able to add another SMTP server via IIS,
> >>> as Exchange takes over that functionality once you install it.
> >>> 
> >>> If you uninstall IIS (more specifically, the SMTP portion), then
> >>> reinstall it, then reinstall Exchange, it should fix this.
> >>> 
> >>> Ben Winzenz
> >>> Exchange MVP
> >>>> I wanted to have multiple SMTP services running.
> >>>> 
> >>>> After installing Exchange 2003 I change the port on the SMTP
> >>>> service inside  Exchange system manager to port 2025.
> >>>> 
> >>>> Then I added a new SMTP service using Internet Information
> >>>> Services, and  configured that for port 25.
> >>>> 
> >>>> My problem is that as soon as I clicked 'ok' after added the second
> >>>> smtp  service, I can no longer get in to configure it.  The service
> >>>> does not appear  in the Internet Information Services list or the
> >>>> Exchange list.  I can verify  it is running by connecting to
> >>>> port2025 the exchange smtp responds, and  port25 the smtp I set up
> >>>> responds.  I guess I should have added the new SMTP  service from
> >>>> exchange, but how should I proceed now?  can I somehow delete  the
> >>>> invisible smtp entry I made?
> >>>> 
> >>>> Was this clear? was this the right place to post?
> >>>> 
> 
> 
0
11/17/2004 4:09:06 PM
Yes I am sure.
I can go computer management -> services and applications -> internet 
information services, then I right click an unused area and choose new-> SMTP 
Virtual Server

"Ben Winzenz [Exchange MVP]" wrote:

> That doubly doesn't sound right.  Once you install Exchange, ALL SMTP functions are supposed to be taken away from IIS Admin.  Are you sure that you weren't doing this within Exchange System Manager?  When I open up IIS Admin from an Exchange 2003 server, I do not have any options to create a new SMTP server.
> 
> As far as reinstalling Exchange, it isn't as painful as you think.  It only replaces the binary files, and won't touch the databases.  So you won't lose any data.  It will probably take 15-20 minutes total for everything.  Just make sure to re-apply any service packs (such as SP1 for Exchange 2003).
> 
> Ben Winzenz
> Exchange MVP
> 
> > Ouch, you think Ill need to re-install exchange, thats my only option?
> > 
> > Well thank you very miuch for your help.
> > 
> > btw: I was able in IIS to just righ-click and choose new smtp server
> > 
> > "Ben Winzenz [Exchange MVP]" wrote:
> > 
> >> Methinks you went about this the wrong way.  The correct method for
> >> adding additional SMTP Servers is in Exchange System Manager, not IIS
> >> Admin.  In ESM, under server, protocols, SMTP, you would right-click
> >> and choose to add a new SMTP Virtual Server.  I'm not sure how
> >> exactly you were able to add another SMTP server via IIS, as Exchange
> >> takes over that functionality once you install it.
> >> 
> >> If you uninstall IIS (more specifically, the SMTP portion), then
> >> reinstall it, then reinstall Exchange, it should fix this.
> >> 
> >> Ben Winzenz
> >> Exchange MVP
> >>> I wanted to have multiple SMTP services running.
> >>> 
> >>> After installing Exchange 2003 I change the port on the SMTP service
> >>> inside  Exchange system manager to port 2025.
> >>> 
> >>> Then I added a new SMTP service using Internet Information Services,
> >>> and  configured that for port 25.
> >>> 
> >>> My problem is that as soon as I clicked 'ok' after added the second
> >>> smtp  service, I can no longer get in to configure it.  The service
> >>> does not appear  in the Internet Information Services list or the
> >>> Exchange list.  I can verify  it is running by connecting to
> >>> port2025 the exchange smtp responds, and  port25 the smtp I set up
> >>> responds.  I guess I should have added the new SMTP  service from
> >>> exchange, but how should I proceed now?  can I somehow delete  the
> >>> invisible smtp entry I made?
> >>> 
> >>> Was this clear? was this the right place to post?
> >>> 
> 
> 
0
11/17/2004 4:12:01 PM
Reply:

Similar Artilces:

SQL SERVER 2000
Given a table like this Station Status_date A 01/01/2009 A 02/01/2009 -- more records for A B 31/01/2008 -- only record for C C 01/01/2009 -- more records for C How can I pick the 30 most recent records for each station? Thanks Thanks Russell - gives me exactly what I was after. "Russell Fields" wrote: > Excuse me, I ignored the very clear topic that said this was SQL Server > 2000. > > SELECT K.Station, K.Status_Date > FROM your_table K JOIN your_table X > ON K.Station = X.Station > A...

Outlook not connecting to Exchange after power outage
Hi Crew, Yesterday, one of my clients had a power failure which unfortunately shut down all the servers. Since the servers are up and running again, client computers cannot use outlook to read their mail. OWA works so there is a temporary solution. Outlook reports "Cannot connect to your default e-mail folders. The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance. What I've done so far: The event logs on the AD server and on the Exchange server show no errors, only informationa...

Retrieving Data from Exchange Server
Hello, Running Outlook XP with an Exchange 5.5 server. Recently I had to create a new Priv.edb and ExMerge data into it from a PST for all mailboxes. Ever since, several users have reported seeing the following popup on Outlook when they are connected locally in the office via ethernet. RETRIEVING DATA FROM THE MICROSOFT EXCHANGE SERVER. This a normal message remote dial up users may receive on the road but not here in the office. Any suggestions? Thank you. ...

Problem installing CRM 09-09-03
We are trying to install Microsoft CRM Server for testing purposes on a Windows Server 2003 machine. I have install all the needed software, including SQL Server SP3, IIS, Indexing services, Message Queuing, etc. We are running into some issues: First, anyone know for sure that CRM Server will run on Win Server 2003? Prob 1: When I try to open http://localhost on the server, it gives the following message: "The Microsoft CRM server or security service has been disabled or has not yet started..." Prob 2: When I try to open the CRM deployment manager, I get the following er...

Adding Transactiontype from Journals into Detailed sales report
I am trying to build up a customised active report, and require the transactiontype identified for each transaction. I cant seem to find a link to the Journal table where this info is stored. Any Ideas Try this: LEFT JOIN Journal WITH(NOLOCK) ON Journal.CustomerID = Customer.ID Begin Column FieldName = "Journal.TransactionType" DrillDownFieldName = "" DrillDownReportName = "" Title = "Transaction Type" VBDataType = vbString Formula = "" ColHidden = False ColNotDisplayable = False FilterDisabled = False ColWi...

Remove Exchange 5.5 server from Site
I have 2 Exchange 5.5 server configured under 1 site name. What is the proper way to remove 1 of the Exchange server from the site? The purpose is to shutdown the Exchange server. Make sure that it's not the first server in the site and all site roles are on the server you want to keep. All mailboxes are moved and then delete it from the admin. "jj" <anonymous@discussions.microsoft.com> wrote in message news:3cb301c4ac47$3c948b80$a501280a@phx.gbl... > I have 2 Exchange 5.5 server configured under 1 site > name. What is the proper way to remove 1 of the Exchang...

Exchange 5.5 Public Contacts and DL
I am currently using Exchange 5.5SP4. We have some contact books in the public folders area. For example, a contact book for SUPPLIERS. Our company is moving and we'd like to send an email to all SUPPLIERS advising of this. Preferrably their email information would not be visible to each other. I can create a personal distribution list to do this but have three issues: 1) Email info is visible 2) It is a pain because you have to go through the list and select each users email instead of business fax 3) A personal DL seems limited to 165 addresses so I would have to next a few DL's ...

Question: Exchange and AD
In AD sites and services there is an entry for our exchange 2000 server with a folder called "Exchange Services" under it. Is this left over from an Exchange 5.5 ADC or is it needed for Exchange 2000/2003? We have two exchange server and neither one is a front end server but we only have an entry in AD for one of our servers. If it is needed for Exchange 2000/2003 should there be an entry for the other server? What is the entry in AD used for? ...

Error Installing DPM Agent in non-trusted domain
I am running into an issue with DPM agent working wiht a standalone workstation When I push an agent to a system it always error. i already tried to SetDPMServer command, it cant go thought with the [-updatePassword] -- KT To install the agent on workgroup computers , can you please follow the steps present at: http://technet.microsoft.com/en-us/library/ff634193.aspx -- Thanks, Praveen D [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. DPM Newsgroup will be deprecated very soon. Please start using DPM TechNet forum at:http://...

two CRM User to one AD user
Hi, I Have in MSCRM 30 two users which are connected to the same AD User. The users in MS CRM has the same names two. No I Have a problem with the repair fuktion of MS CRM, the protokol says it is one of this User in MS CRM. How can I delete one of the two users in MS CRM. Thanks you a lot for your helping! Alwin ...

Disabled account in AD and re-enabled. Now user can't login to Outlook.
A user's account was disabled in Active Directory and then re-enabled a short time later. Now the user cannot login to Outlook. Can anyone tell me why this is happening? Thanks ...

Installing MS CRM on SBS 2003
Thanks to any one who will lend a hand. I successfully installed and configured SBS 2003. Active directory is set up, exchange - tested - works, SQL etc. All worked well until I installed MS CRM tonight. 1. I went to change the password for crystal reports and got an error... something really strange...couldn't complete it. 2. Went to begin the CRM deployment and the snap in would not start (I was loggid as the admin who installed - always am.) 3. I went to test exchange in order to make sure tht it was still working. From a browser, I accessed the site, was prompted for username and pas...

SMTP Protocol Question
I am getting a couple hundred domains showing up in my SMTP Qeue list (Exchange 2000) and I am pretty sure that I do not have an open relay. How can I lock this down further to prevent this from happening? How are they getting to my exchange. I have several asp web sites with a "Contact Us" utility. Is that how? What can I do to prevent this? Thanks~ "Bob Schneider" <BobSchneider@discussions.microsoft.com> wrote in message news:8FFA533A-5390-4787-8457-FE5F6AB3953F@microsoft.com... > I am getting a couple hundred domains showing up in my SMTP Qeue list &g...

MSDE Install Fails
I start the install process and it fails at the installing MSDE. I've tried installing SP4 MSDE separately and it fails still as well. The system reports "Fatal error during installation.". When I install manually I get "A strong SA password is required for security reasons. Please use SAPWD switch to supply the same. Refer to readme for more details. Setup will now exit." Below is the log file of the manual install as I could set a trace on it. Anyone ever experience this and have a solution? John === Logging started: 9/27/2006 13:44:39 === Action 13:44:39: INSTA...

Server Spec
I am running 5 tills, and 6 back office computers, i have a 3.0GHZ dual core Pentium server, with 2GB of RAM, and am running full SQL Server. We are noticing times when thing are very slow, especially when we are doing large reports, and the server is also running our SAGE requirements- Should i have a faster server, or is the above spec adequeate? Thanks for any help on this! I'm not sure what SAGE is - is that your accounting package? Anyway, you might want to boost the memory - more is always better, but 2GB should be adequate. Do you have any hubs in your network? If so ...

Exchange 2003 critical, service pack patch process
I’m looking to do some system patch update on my Exchange Cluster. I’m not sure how to patch clusters. Can someone please provide me a best practices link on patching exchange server on a cluster? I’m running Windows 2003 Enterprise with Exchange 2003. Thank you, Juan Hi, for Exchange, the procedure is relatively easy: You allways have to install the SP on the node that is not active ! Bye. "Juan" wrote: > I’m looking to do some system patch update on my Exchange Cluster. I’m not > sure how to patch clusters. > > Can someone please provide me a best p...

simple way to do a server-side autoreply in E2K ?
Hi all....looking for a little advice once again =/ I'm looking for a simple way to make E2K reply with a blurb anytime email is sent to a particular email address. I would prefer not to have to involve Outlook with some client-side rule.....was just hoping for a way to make E2K kick off an autoreply. So far, the only thing I've done in Global Settings | Internet Message Format | Advanced Properties of Default, is enabled Automatic Replies. Some of the posts mentioned using event sinks, which I know nothing about. Any ideas? Thanks in advance! Robert Robert wrote: > Hi all.....

setup was unable to find an instance of the microsoft CRM server c
please help 1 domain controller with Exchange, IIS, CRM, and SQL. 1 workstation with winxp sp2. I CAN NOT install CRM Sales for outlook on client. I am administrator of the local box and domain. Both computers are in same domain. NIC NOT firewalled. Everything worked fine in the test environment but not in live network. just like everyone else. i do have SSL on server as well.. i think this may be the problem... First, is the CRM server functional? Be sure to check that the SQL/CRM services are running on the server. Second, are you able to access it via the web interface? If so, w...

Uninstalling Exchang 2000
Dear Sirs, Hoping you are fine. Kindly. I would like to ask you a question, and I expecting your help in this matter. My exchange server is not working probably, so that I would like to reinstall it meaning (remove it & install it again). Could it be possible to help me what to do? Note: It is necessary to know that I do have 4 servers,, though I would like to uninstall the exchange with out losing the active directory , it is very important. Thanking for your cooperation in advance. Looking forward to hear from you. With best kind & regards, Kiarash naseri, see ...

OL 2000 smtp error
My client receives the following error message when sending message, this happens about 9/10 times, and after the error pops up a few time the message goes through...any ideas? "The TCP/IP connection was unexpectly terminated by the server. Account:XXXX, SMTP Server: mail.uu.net, Error NUmber 0x800ccc0f" Marc ...

Exchange 2k3 Relays
My exchange is configured by default not to relay. But I can easily relay. Its driving me nuts. Is that a common problem? Please explain how you are relaying. Please also post what your current relay settings are on the SMTP Virtual server. -- Ben Winzenz Exchange MVP MessageOne "John Smith" <smith@nosuchdomain.com> wrote in message news:e0ldGZvrFHA.308@TK2MSFTNGP10.phx.gbl... > My exchange is configured by default not to relay. But I can easily > relay. > Its driving me nuts. > > Is that a common problem? > > How are you testing it? Did y...

Exchange 2003 and SRS
We recovered an Exchange 2003 server from a hardware failure. All went well. When we ran a new ntbackup job, and just verified it works, we got an SRS error. So we did a new job and did not select the SRS stuff. Will this be a problem? SRS is only necessary if we still have exchange 5.5 in the organization? Is this correct? Thanks! On Fri, 2 Mar 2007 08:27:24 -0600, "Dan J.S." <smeski@gmail.com> wrote: >We recovered an Exchange 2003 server from a hardware failure. All went well. >When we ran a new ntbackup job, and just verified it works, we got an SRS >err...

Help me with settings POP/SMTP for second account in outlook
Help me with settings for the second account in outlook 2002, The POP/SMTP. I received an error "account in use" what must changes "Charlotte" <Charlotte@discussions.microsoft.com> wrote in message news:CECE06BB-79E2-47D2-B9A9-FF51E965DA0A@microsoft.com... > Help me with settings for the second account in outlook 2002, The POP/SMTP. > I > received an error "account in use" what must changes If you tell us exactly what you're doing we may be able to tell you if what you're doing is wrong. There's no way, however, we can give you s...

Exchange 2010 Site Resilience
Hi Folks I've read all the whitepapers but it still isn't clear. Here is what I thought was a simple question, but I dont seem to be able to find a clear answer: Say we have a single DAG with members split across 2 physical sites, lets say 2 members in the primary DC and 1 member in the secondary DC. The FSW is configured to reside in the primary DC (Highest number of users) DAC mode is enabled All DAG members will contain active databases as there will be a couple of hundred users locally based at the second DC. The second DC is not a pure DR site. When the WAN g...

Is it bad to Defrag a server running exchange?
My server needs to be degraged, but I am unsure if this will cause any problems with exchange. Can someone let me know if it is safe to do so.? Thanks Habib On Thu, 11 Aug 2005 12:55:06 -0700, "Habib" <Habib@discussions.microsoft.com> wrote: >My server needs to be degraged, but I am unsure if this will cause any >problems with exchange. Can someone let me know if it is safe to do so.? > >Thanks >Habib It is safe to run a file level defrag on the server. Back it up before and afterwards. Don't have Exchange running Try not to have anything else on the di...