Problems with Combobox in Userform

Hello!
I need some help as I can not get around my problem.
If I use a Combobox on the sheet with 4 rows the linked cell shows the
number of the row selected but if I do the same in a userform with a
combobox the linked cell writes out the text instead. I can�t figure out how
to make the linked cell to show the number of the selected row instead. (I
use the number to select witch equation to make in a later step...) Please
help me on this one.......

Many thanks in advance!

Marcus


0
9/13/2004 6:58:44 PM
excel 39879 articles. 2 followers. Follow

1 Replies
584 Views

Similar Articles

[PageSpeed] 38

If you use the DropDown from the Forms toolbar, you get that behavior--the index
into the list, not the value itself.

But if you use a combobox from the control toolbox toolbar, you'll see you get
the value of the combobox.

You could use a helper cell that contains a formula:

=match(yourlinkedcell,yourlist,0)
like:
=MATCH($B$1,$A$1:$A$10,0)

to get the number.

"Marcus Peders�n" wrote:
> 
> Hello!
> I need some help as I can not get around my problem.
> If I use a Combobox on the sheet with 4 rows the linked cell shows the
> number of the row selected but if I do the same in a userform with a
> combobox the linked cell writes out the text instead. I can�t figure out how
> to make the linked cell to show the number of the selected row instead. (I
> use the number to select witch equation to make in a later step...) Please
> help me on this one.......
> 
> Many thanks in advance!
> 
> Marcus

-- 

Dave Peterson
ec35720@msn.com
0
ec35720 (10082)
9/13/2004 9:29:28 PM
Reply:

Similar Artilces:

Installation problem with Outlook 2000: 'The operation failed due to an installa
I installed Outlook 2000 on a laptop, which already had some of the Office 2002 products (Word, Excel, PowerPoint). When I try to open Outlook I get an error message 'The operation failed due to an installation problem. Restart Outlook and try again. If the problem persists, please reinstall'. I uninstalled and reinstalled Outlook a couple of times, but still the same problem. Does anyboday have an idea what the problem could be and how it could be solved? ...

Problem setting text on a userform's "label"
I have a Userform that contains a Label form and here is the initialize code: -------------------------------------------- Private Sub UserForm_Initialize() . . Call SetMyLabel ' procedure call End Sub ---------------------------------------------- Public Sub SetMyLabel() Dim s1, s2 as String s1 = "Hello " s2 = "World!" UserForm1.Label1.Caption = s1 & s2 ' This code has no effect End Sub ----------------------------------------------- So, when this code runs, my label ends up being blank....

build problem?
My old pc went down and I have just completed reloading programs and transferring files on my new machine. I did have one problem when I reinstalled Visual Studio (6.0), related to symbols and some data not matching a dll, as I recall. Now, when I execute from within the IDE, whether in debug or release, I consistently get the message "The following files are out of date or do no exist:". This is followed by a short list including .exe, a few .obj's and ..res. Also I sometimes am getting hung in the build, after linking has begun and possibly when browse info is being ...

Worksheet Protection Problem
I have Excell 2003 (11.5612.5606). My worksheet is protected (tools+protection+protect worksheet), and fo the most part, the protection seems to be doing its thing okay. When go to protect the worksheet, the only thing I have checked to allow th user to do is "select unlocked cells"; the "format cells" is NO checked. I have used the format+cells+protection to lock only the cell I want protected. The problem is when the user uses "CTRL C" & "CTRL V" to copy and past data from one cell to another, it also copies the cell's format (???) As a re...

checkbox coding problem
I'm having an issue coding a check box in relation to a date field combo box that I'm hoping someone can assist me with. Here are the particulars: I have a combo box (cboDate) using the calendar control for the user to select the date. I wanted the combo box to show yesterdays date by default so I set the default value to Date()-1. This works just fine but I wanted to add the option of a user adding multiple records with a different date (other than yesterday or date()-1) without the need to always select the date. In other words if a user had 10 records to add for last thurs they...

Microsoft Excel Sort Problem
I have always been able to sort columns in micosoft excel. I select auto format but when I go to the Data area I cannot sort - the "sort" selection is in gray. Please help! Thanks! Is the sheet protected? -- Regards, Peo Sjoblom "VK" <anonymous@discussions.microsoft.com> wrote in message news:089601c3d45d$d89a8c40$a601280a@phx.gbl... > I have always been able to sort columns in micosoft > excel. I select auto format but when I go to the Data > area I cannot sort - the "sort" selection is in gray. > Please help! Thanks! How about...

Outlook 2000
I recently purchased a new computer with Windows XP and loaded my Office 2000 software. All seemed to work well until I created an additional email account for my wife. The new email account takes all of the attachments sent (pdf files, dwg files, etc...) and converts them into dat files which nobody is able to open. I have tried to trouble shoot the account and software and am at a loss. Switch to HTML or Plain Text format. You are now setup with Rich Text which is the least supported (but most functional) message format. http://www.howto-outlook.com/faq/richtext.htm -- Robert Sp...

Owa Logon problem Please help!!!
My users report that the Owa is not loading after entering password and username. They see the first screen where they can enter credentials, after they give an enter it seems like OWA does not validate the password. it stays on this page https://x.x.229.44/exchweb/bin/auth/owalogon.asp?url=https://x.x.229.44/exchange&reason=0 Owa has always worked from intern and extern exchange 2003 Sp1 on winodw 2000 Sp4 machine. How can I resolve this problem. I already tried resetting the IUSR and IWAM user account, but no difference. Can I reinstall exchange and will this solve my problem, I am ...

Please help me with Money Invoice Designer problem
I am having a problem with Money 2003 D&B Invoice Designer. I reinstalled Money 2003 D&B, and acknowledged the EULA. But when I try to start the Invoice Designer, either from withion Money or from the Start, Programs, Money menu, I get a message the Windows Installer is "preparing to install", then an error message the Windows Installer "Can't load fiile C:\Docume~1\Joe\Locals~1\Temp\{7F581D1D-CA97-4C77-B88A-27537173CEDF}\Seria lNumber.dll", and my only choice is to click on "OK". This message repeats 8 more times before the invoice designer finally...

excel format cells/Number/Category: Number problem
Hi, When I trie to Format a cell, in Number Tab, Categorie Number, in the negative Numbers: I'm missing the 2 options of ( ) I on ly have 2 choices: -1234.10 1234.10 (in red) I need: (1234.10) (1234.10) (in red) But its missing! Anyone can help me? Hi create a custom format (the automatic availability of this format depends on your Windows settings): 0.00_);[Red](0.00) -- Regards Frank Kabel Frankfurt, Germany "Matts" <Matts@discussions.microsoft.com> schrieb im Newsbeitrag news:EA0BCEE7-5DFA-44F1-869B-ED5A52DD8129@microsoft.com... > Hi, > When I trie to Format a ...

DSUM error# Syntax problem?
I am trying to use DSUM to create a running total via Method 1 in MS TID 290136. I am getting an error in my DSUM statement. Very simple query: SELECT SalesForGraph.Week AS CWeek, SalesForGraph.[2006Profit], DSum("2006Profit","SalesForGraph","[WEEK] <= " & [Cweek]) AS RunTot FROM SalesForGraph ORDER BY SalesForGraph.Week; The string for Criteria resolves to: [week] <=1 [week] <=2 etc. What am I doing wrong? Phil Changed it to SELECT SalesForGraph.Week AS CWeek, SalesForGraph.[2006Profit], DSum("2006Profit","SalesForGraph&quo...

Access 97 to 2000 conversion debut problem.
My DB conversion from Access 97 to 2000 looks good and runs okay but when I try to use the debug feature on my old modules and procedures (after break) to "Step Into", etc. this feature doesn't work. No error msgs appear... just a bonk sound meaning that this feature isn't available. I have run "Debug" "Compile DB" okay. I have used the "Design Mode" then "Save" rountine on all tables, queries, forms, etc. I have created new modules that do work with the "Debug" "Step Into" program feature. What am I missing. TIA ...

SHGetFileInfo SHGFI_ICON and DrawIcon problem.
Hi all. I get the handle to icon in system imagelist as: m_hIcon = NULL; SHFILEINFO psfi; ::ZeroMemory(&psfi, sizeof(SHFILEINFO)); if (::SHGetFileInfo(fullPath, FILE_ATTRIBUTE_NORMAL, &psfi, sizeof(SHFILEINFO), SHGFI_USEFILEATTRIBUTES|SHGFI_ICON|SHGFI_SMALLICON)) { m_hIcon = psfi.hIcon; } and i got handle to icon with no problems. Now i have owner-drawn CListCtrl which tries to draw that icon like: CDC dc; dc.Attach(lpDrawItem->hDC); CRect rItem(&lpDrawItem->rcItem); int oldMapping = dc.SetMapMode(MM_TEXT); m_yicon = ::GetSystemMetrics(SM_CYSMICON); // Returns 1...

Outllook 2002 pst. data file retrieval problem
I was backing up my data file and when I returned to outlook all my emails for the past week had disappeared. I then went to open the pst. file and it won't let me open it - I am advised to go to the microsoft website (useless) or use another program to open it - none of which work. does anyone know how i can retrieve the lost emails or get into the pst. data file? Thanks, Katie Where did you store the backup? --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name here) virus, all mail sent to my perso...

Recipients policy filter rules problem.
Hi all, We are running ex2003 with win2003 AD. I am trying to setup Recipient policy to clean up people's mailbox. Somehow i can pick dividual mailbox in the Modify wizard, but it either run all mailboxes or none. I tried different OU and group also, it does the same thing. I see that it has 2 policy there to begin with, the default policy and another policy. I believe the second policy was created by itself when our previous IT person migrated the exchange from 5.5 to 2003. I see the another server under the servers tap but that server no longer exist. i think that should be the ...

November 10, 2009 Security Update macro problems
After the Security Update for Excel 2003 and 2007 from November 10, 2009, macros became much slower and a refresh problem started happening. What happens is that when, through VBA, I place a value on a cell on an inactive sheet, the cell where the value has been placed is seen in the active sheet. This is causing some unusual behavior, as i place a lot of values in sheets that are not active. Does anyone have a problem like this? http://www.microsoft.com/office/community/en-us/default.mspx?dg=microsoft.public.officeupdate&tid=c67c9a0d-4c83-41ec-b4c6-778974190066&cat=&a...

KB977165 blue screen problem to some
Running XP Pro SP 2, Firefox 3.5.7, IE 7.0.5130.11, Avast AV 4.8.1368 I installed KB977165 along with other updates and have had no problems. Should I still do the workaround to remove KB977165, etc. as shown in Windows Update forum post by Kevin Hau here: http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/73cea559-ebbd-4274-96bc-e292b69f2fd1/ gram gram pappy wrote: > > Running XP Pro SP 2, Firefox 3.5.7, IE 7.0.5130.11, Avast AV 4.8.1368 > > I installed KB977165 along with other updates and have had no problems. > > Should I still do...

weird CFileDialog / GetOpenFileName problem
I'm having two weird problems with CFileDialog and/or GetOpenFileName that QA is on my back to fix :). 1) Bring up a normal CFileDialog or GetOpenFileName dialog on Windows XP. Go to the filename field and leave it blank. Hold down the enter key and you will see the "Look in" label, the "Look in" combobox, the "File name" label, the "Files of type" label, the "File name" combo box, and the "Open" button all flash like crazy ** I found a fix for this bug, just reporting it ** 2) Bring up a normal CFileDialog or GetOpenFileName ...

OWA loading problems
Starting to dislike OWA!!! On my exchange server, logged in as admin, everyting works great.. On other workstations, it justs says loading. any quick ideas? Dennis On Fri, 3 Mar 2006 15:14:57 -0600, "Dennis Burgess" <dmburgess@surdyk_e.com> wrote: >Starting to dislike OWA!!! > >On my exchange server, logged in as admin, everyting works great.. On other >workstations, it justs says loading. any quick ideas? > >Dennis > http://support.microsoft.com/?kbid=280823 http://support.microsoft.com/?kbid=910119 ...

Sum Product Problem
I want to do a sumproduct calculation, but it won't work because one of the columns of data has formulas in it as well as blank rows. I took the formulas out and just used the data and it worked, but with the formulas in there I get an error message. Is there any way do this? If you need more info, let me know. Thanks. What is the SumProduct formula you tried and what is intended to calculate? JDT wrote: > I want to do a sumproduct calculation, but it won't work because one > of the columns of data has formulas in it as well as blank rows. > > I took the formulas ou...

CFileDialog: Multiselection problem
How can I increase the file buffer size for a CFileDialog in order to get as much multiple selected files as possible ? The following code runs into an assertion, I do not no why, is the nMaxFile too large?: If I omit fd.m_ofn.nMaxFile the program runs but only with a few number of multi selected files CFileDialog fd(TRUE,_T("bmp"),_T("*.bmp"), OFN_FILEMUSTEXIST|OFN_ALLOWMULTISELECT|OFN_EXPLORER, _T("Windows Bitmap (*.bmp)|*.bmp|JPEG File (*.jpg)|*.jpg|")); fd.m_ofn.nMaxFile = 2048; if (fd.DoModal() == IDOK) { ... } Thank for all useful hin...

Problem with Office 2003 SP3
In Access 2003, I have a Combo box in a form with one of the columns formatted Yes/No (the table the data comes from is also yes/no data). When the Combo Box was dropped-down, the column correctly showed "Yes" or "No"...until I installed Office 2003 SP3. Now, the column shows "-1" or "0" now matter that the format property is set to "Yes/No". Has anyone else experienced this and found a solution? Brossyg Change the SQL To Rowsource: Select MyField, Format(MyField,"yes/no") As Display From MyTable change the column count to 2...

OAB Problems (0x8004010F)
We've been having 0x8004010F errors trying to download/sync the Offline Address Book in Outlook since we migrated from Exchange 5.5 to Exchange 2003 The OAB is being generated correctly - new users don't suffer the problem, only users existing at the time of transfer. In fact, if users log on under their old domain account (there is an associated external account), then they can sync. However if they log in under the new account no joy. They can still function online - emails go to and fro, and calendar works without a problem. The choose address book combo in the Download Of...

Office 2007 security problem 03-29-10
We have a series of Word 2003 templates. These templates sit on a network folder with NT security permissions of Read & Execute, List Folder Contents, Read, and Write. Not Modify. A user can open these templates, make a change and save the changes using Word 2003. The same user using an Office 2007 installation receives an error message of "Access denied. Contact your administrator". Does anyone know why? ...

URL/link problems, isv.config, window.dialogArguments
Hi, I created a new webSite (and virtual directory) in the same server of CRM (3.0) but another port (I can´t keep CRM and my webSite in the same port). I changed the isv.config and add a button with a URL that link to page in my webSite: <ToolBar ValidForCreate="0" ValidForUpdate="1"> <Button Title="CORPORE --> CRM" Url="http://myServerNname:85/Corpore.NET/CRMMSIntegraAlunoCorporeCRMMSProcessando.aspx" PassParams="1" WinParams="dialogHeight: 400px; dialogWidth: 600px; dialogTop: px; dialogLeft: px; edge:...