ColorIndex property stopped working

This is a multi-part message in MIME format.

------=_NextPart_000_0013_01C3EBDA.56470A40
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

    I am using Excel 2002.  I have an extensive VBA application that has =
been working for years in several Windows systems.  I am now getting an =
error, that I can't explain.  It occurs under both WinXP (my desktop) =
and WinME (my laptop) in the same application.  It may also occur under =
other O/S's, but those are the only ones I am using right now.  Since it =
occurs on 2 different computers with 2 different O/S's and 2 different =
Excel installations, it must be a problem with the application itself.

    When I run a line in my code such as:
    Range("ServoForcerWeight").Font.ColorIndex =3D 1, or any of many =
such statements that use the ColorIndex property (and used to work), I =
get the following

    Runtime Error 1004: "Unable to set the ColorIndex property of the =
Font Class."

    I have no idea how I broke my system.  The help file isn't much =
help, and I couldn't find an answer on the MSKB -- or through Google.  I =
think I need an expert.

    Please help.
------=_NextPart_000_0013_01C3EBDA.56470A40
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2800.1400" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; I am using Excel =
2002.&nbsp; I=20
have an extensive VBA application that has been working for years in =
several=20
Windows systems.&nbsp; I am now getting an error, that I can't =
explain.&nbsp; It=20
occurs under both WinXP (my desktop)&nbsp;and WinME (my laptop) in the =
same=20
application.&nbsp; It may also occur under other O/S's, but those are =
the only=20
ones I am using right now.&nbsp;&nbsp;Since it occurs on 2 different =
computers=20
with 2 different O/S's and 2 different Excel installations, it must be a =
problem=20
with the application itself.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; When I run a line in =
my code=20
such as:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp;=20
Range("ServoForcerWeight").Font.ColorIndex =3D 1, or any of many such =
statements=20
that use the ColorIndex property (and used to work), I get the=20
following</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; Runtime Error 1004: =
"Unable to=20
set the ColorIndex property of the Font Class."</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; I have no idea how I =
broke my=20
system.&nbsp; The help file isn't much help, and I couldn't find an =
answer on=20
the MSKB --&nbsp;or through Google.&nbsp; I think I need an =
expert.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;&nbsp;&nbsp; Please=20
help.</FONT></DIV></BODY></HTML>

------=_NextPart_000_0013_01C3EBDA.56470A40--

0
gbNOSPAM (4)
2/5/2004 7:22:27 PM
excel.misc 78881 articles. 5 followers. Follow

2 Replies
392 Views

Similar Articles

[PageSpeed] 58

Gary

Wander through these google search results.  You might find something that
will help.

http://snipurl.com/4b5h

Gord Dibben Excel MVP

On Thu, 5 Feb 2004 11:22:27 -0800, "Gary Burton" <gbNOSPAM@pvbb.net> wrote:

>    I am using Excel 2002.  I have an extensive VBA application that has been working for years in several Windows systems.  I am now getting an error, that I can't explain.  It occurs under both WinXP (my desktop) and WinME (my laptop) in the same application.  It may also occur under other O/S's, but those are the only ones I am using right now.  Since it occurs on 2 different computers with 2 different O/S's and 2 different Excel installations, it must be a problem with the application itself.
>
>    When I run a line in my code such as:
>    Range("ServoForcerWeight").Font.ColorIndex = 1, or any of many such statements that use the ColorIndex property (and used to work), I get the following
>
>    Runtime Error 1004: "Unable to set the ColorIndex property of the Font Class."
>
>    I have no idea how I broke my system.  The help file isn't much help, and I couldn't find an answer on the MSKB -- or through Google.  I think I need an expert.
>
>    Please help.

0
Gord
2/5/2004 8:05:55 PM
    I read all of those that could possibly apply and none of them did.
Thanks anyway.

    I discovered that my particular problem is caused by the fact that I am
working with a protected workbook.  I apparently used to unprotect the sheet
while the code was running, then protect it again when I finished.  I must
have removed that code, and didn't remember it.  Therefore, the ColorIndex
command was trying to make a change in a protected sheet.

    It bothers me that I can't remember making the changes that caused the
problem, but that must be what happened.  I guess my problem is solved.


"Gord Dibben" <gorddibbATshawDOTca> wrote in message
news:lb8520pa2bsrgt44lhfgungu0q4k9jupg8@4ax.com...
> Gary
>
> Wander through these google search results.  You might find something that
> will help.
>
> http://snipurl.com/4b5h
>
> Gord Dibben Excel MVP
>
> On Thu, 5 Feb 2004 11:22:27 -0800, "Gary Burton" <gbNOSPAM@pvbb.net>
wrote:
>
> >    I am using Excel 2002.  I have an extensive VBA application that has
been working for years in several Windows systems.  I am now getting an
error, that I can't explain.  It occurs under both WinXP (my desktop) and
WinME (my laptop) in the same application.  It may also occur under other
O/S's, but those are the only ones I am using right now.  Since it occurs on
2 different computers with 2 different O/S's and 2 different Excel
installations, it must be a problem with the application itself.
> >
> >    When I run a line in my code such as:
> >    Range("ServoForcerWeight").Font.ColorIndex = 1, or any of many such
statements that use the ColorIndex property (and used to work), I get the
following
> >
> >    Runtime Error 1004: "Unable to set the ColorIndex property of the
Font Class."
> >
> >    I have no idea how I broke my system.  The help file isn't much help,
and I couldn't find an answer on the MSKB -- or through Google.  I think I
need an expert.
> >
> >    Please help.
>


0
gbNOSPAM (4)
2/6/2004 3:57:27 AM
Reply:

Similar Artilces:

Outlook doesnt prompt to work online/offline
OS: XP Office: 2002XP MS doesnt always prompt to work online/offline when opening outlook. The problem is that it might give u the option the 1st time you open outlook, but the 2nd and 3rd time it will not prompt you, it will just open outlook (online). I have disconneted the pda/pocket pc from the computer to make sure that it was not keeping a link between the two. I have closed outlook and killed the Outlook.exe that was running, but it still wont give the option. Anyone had this problem? Thanks ...

SUMPRODUCT Works Sometimes Why
I have use this formula before, but i try it again on another sheet and now it does not work. This Works: =SUMPRODUCT(('Dec Actual'!$F$2:$F$100="0103")*('Dec Actual'!$G$2:$G$100=B101)*('Dec Actual'!$I$2:$I$100)) This does not: =SUMPRODUCT(('Source'!A5:A350="A")*(Source'!B5:B350=A8)*('Source'!AM5:AM350)) > it does not work. Means??? -- Don Guillett SalesAid Software donaldb@281.com "Mestrella31" <mestrella@mxn.com> wrote in message news:A88DF055-648D-46E7-A66F-5C6AF9359E0E@microsoft.com... > I have us...

How to stop access confirmation in Outlook
When I try to sync my PDA/Phone with Outlook (2000) it ask for me to allow access for 'x' number of munites. How do I stop this request? Thanks Clive Try updating your PDA sync software. (If the PDA uses Activesync, upgrade to 3.7x) And if you are curious to know how/why you are getting the prompt, see the following links. http://www.slipstick.com/outlook/esecup.htm http://www.slipstick.com/outlook/esecup/admin.htm -- Neo [MVP Outlook] Due to the Swen virus, all e-mails sent to this account will be deleted w/out reading. "Clive" <someone@NOTHANKS.com> wrote i...

Does ? work under excel search?
Hi, Wondering if there is any way to search/find the ? inside of a cell? It does not work for me unless the ? is by itself in a cell. I need to dig out this symbole from within a cell. For example, cells may have "abc?123" in it and I need to find and delte it. Is it feasible? Thanks Hi Harry in the find what box type ~? in the replace with box leave blank click on options and ensure that match entire cell contents is not checked run the replace Cheers JulieD "harry" <harryliuusa@yahoo.com> wrote in message news:eqFRJCIsEHA.1712@tk2msftngp13.phx.gbl... &g...

SetWindowPos ZOrder does not work with overlapping controls?
Hello NG, I have a problem with the ZOrder of SetWindowPos. In my CDialog, I use a bitmap CStatic to display a background picture. On that, I want to show some controls. I do it as follows: m_stcBackgroundPic.SetWindowPos(&wndBottom, 0,0,1024,496, SWP_HIDEWINDOW); m_btnDoSomething.SetWindowPos(&wndTop, 10,10,100,60, SWP_HIDEWINDOW); m_stcEditCaption.SetWindowPos(&wndTop, 10,175,150,30, SWP_HIDEWINDOW); m_ctlEdit.SetWindowPos(&wndTop, 170,175,170,30, SWP_HIDEWINDOW); Later, I show the controls with ShowWindow in the same order as above (first the background pic, then the butt...

How to stop Pie Chart from using N/A# for values
Hello, I have 2 columns: Column 1 is customer name. Column 2 is sales for the period. If a customer had no sales for the period the sales column will either be N/A# or zero. When I plot in a pie chart, I only want to show customers who had sales for that period. Is there a way to only plot those customers with sales without having to change the range and sort every period? Customer Sales Cust1 $100 Cust2 0 Cust3 $50 Cust4 N/A The pie chart data labels show the customer regardless of sales and if I blank out the customer, the value data label s...

Rules only work when I first start Outlook 2003
Hi all. I have a problem with my rules in Outlook 2003. I've upgraded from OL XP, and now my rules only seem to work when I first start up OL 2003 and it checks my mail. I'm using several POP accounts and I want the mails moved to specific folders depending on the mail account they come in on. The rules worked fine when I was running OL XP, but now they only run on the first mail check as soon as I open OL. Any subsequent mail checks, either automatic (every 5 mins) or manual just sends any new mail to the Inbox. I have read about an OL prob where the rules don't work on the fir...

Accessing Spreadsheet Documents (Works Suite 2003)
I recently converted over from a Mac to Windows. I had several spreadsheet documents that I converted using Maclink. They converted over okay. But, when I try to use them, and then wanted to save them, I have to save in Works 7.0. Then when I try to open them up I get the following type message: BUW1, contains a formula reference outside the area that Works can access. There are other similiar references like: LDI1, KMS1, AND MX1. I do not know how to remove these problems so that I may utilize the documents. Please help. Thanks. JB I'd suggest asking this in a Works gr...

work 04-30-07
Michael Johnson On August 1, 1996, Michael Johnson electrified the world by winning an Olympic gold medal in the 200-meter dash with a time of 19.32, shattering his own world record and capping one of the greatest individual track and field performances in Olympic history. Johnson became the first person in history to win both the 200 meters and 400 meters in the same Olympic Games. These performances in front of an American audience highlight a decorated career for Johnson, who will be competing in his third Goodwill Games in 1998. Some of Johnsons accomplishments include: � W...

HELP: Deleted Items Limit Set to 0 days does not work!
Hi Gurus, I've set the Deleted Items Limit to 0 days from the Deletion Setting at the Mail store level but when i delete an item from one of the mailbox it does not removed from the server immediately. Has anyone come accross this issue? Please advice. Thanks in advance On Wed, 2 Feb 2005 20:20:23 +0800, "hanafiah" <hanafiahh@hotmail.com> wrote: >Hi Gurus, > >I've set the Deleted Items Limit to 0 days from the Deletion Setting at the >Mail store level but when i delete an item from one of the mailbox it does >not removed from the server immediat...

IInternetProtocol Start Method not working correctly
Hello, I've been searching and searching and found nothing to help me out. Here's my situation: I need to capture URL Requests (clicks or address bar entries) and if it matches a specific URL like "http://somedomain.com/blorg.exe" I want to be able to intercept that and tell IE i'll take care of it myself, OR, if it does not pass my criteria, let IE handle the click. I DO NOT want to register my own protocol like mark://somedomain.com/.... I need to be able to look at the whole URL This is what I've done so far: I have created a namespacehandler in the HKCR are...

AutoSummarize not work
I try to access the autosummarize tool box but always I have no dialog box appear. I coudn't do work it . please tell me what shall i do? Are you using Word 2007? It seems as if the feature is no longer supported in that version. Although you can add the AutoSummary Tools command to the Quick Access Toolbar, nothing happens when you click AutoSummary Tools | Auto Summarize. -- Stefan Blom Microsoft Word MVP (Message posted via NNTP) "Moataz" <Moataz@discussions.microsoft.com> wrote in message news:13E5455D-1AA0-4B32-AAFB-6F70E67D99B6@microsoft.com...

Help working out hourly production rates in spreadsheet please.
Hi all, Stuck on this one now. In my spreadsheet i have 3 columns that contain the following info for my production machines Total shift time (this will usually be 7:45 or 8:30 - formatted in hh:mm format) Downtime per shift (any value upto max shift time - formatted in hh:mm format) Kgs produced. I would like to keep the time in hh:mm format as i do further calculations on these - % downtime, total downtime, total shift hours etc (and also cos it took be ages to figure out how to add up in time and i couldn't believe how simple it was when i figured it out) What i would like to be abl...

Advanced Find doesn't work
After having updated my Office 2000 version with service release 1a and service pack 3 the Outlook 2000 advanced find function no longer works. It doesn't deliver any results and pretends to continue searching forever. Anyone any ideas about this problem? Thanks, Steve Same problem here....except it doesnt seem to keep searching. It will only find something within the last day or so. "Steve Kraft" <anonymous@discussions.microsoft.com> wrote in message news:00a501c3c472$93d71c90$a601280a@phx.gbl... > After having updated my Office 2000 version with service > rele...

inserting equations in Word document from MathType not working anymore
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel I've just starting using Snow Leopard after worked with Tiger previously. I'm noticing some odd behavior that's different than before. <br><br>I have the MathType 6 Insert Eqn button installed in Office 2008 for Mac. When I click on that, MathType opens. So far, so good. I type in my equation, but, when I'm finished editing or creating my equation, I'm used to clicking on the red button to close the MathType window and return to my Word document. When I do that now, my Word d...

Chart Wizard won't work
I have classwork to perfoerm on EXCEL, but I am unable to use the Chart Wizard because it is grayed out, and unavailable. I have made certain that I have selected ranges with data in them, so what do I do next??? Perhaps it's not installed? Some versions of MS Office do not install the wizards when the default install method is used. Use Custom install, and choose "Run all from my computer". ************ Anne Troy www.OfficeArticles.com "peg2unic" <peg2unic@discussions.microsoft.com> wrote in message news:255A90EF-B896-48EF-86DC-5988EEC707C1@microsoft.com....

Landscape orientation doesn't work
I've checked my page and printer settings but I can't seem to print in landscape (ideally, landscape legal size). I've also posted this in 'worksheet f(x)'. Can anyone assist? p.s. I've even repaired/re-installed with my office 2000 CD but problem persists. Did you also check File>Page Setup>Page, orientation? -- Kind Regards, Niek Otten Microsoft MVP - Excel "Gerry Simone" <anonymous@discussions.microsoft.com> wrote in message news:c93f01c48a06$533f49f0$a601280a@phx.gbl... > I've checked my page and printer settings but I can...

Problem with getting warning banner message working in OWA
We are using Exchange 2003 with a front-end & back-end server setup and using forms based authentication. Has anyone successfully implemented a Warning banner for OWA that users have to click the OK button before getting to the login page? I have tried out the steps provided at http://www.somorita.com/E2K324seven/Ch21-OWA-WarningBanner.doc but the warning banner still doesn't show up. Would greatly appreciate if anyone has implemented could provide any information to get this working. Thanks in advance. Mark While you are looking at the logon page in IE, use the View/Source...

How to I stop the form from resetting
I have a table linked to the header of my form. The table has for records. Here's what happens. When I choose a record (say record 3) record 1 ALWAYS prints. The form is meant to be printed out. Can someon please tell me how I can get the record I choose to print out? Thanks in advance!! :o) Although it is possible to print a form, it is not advised. You will get better results if you create a report and print the report. -- Dave Hargis, Microsoft Access MVP "Printing only filtered data in a form" wrote: > I have a table linked to the header of my form. The table h...

RPC stopped working
I was working from home last Monday and I was connected to my Exchange server using RPC over HTTPS. I am in Windows 7 64bit and Outlook 2003. When I try to log back into the RPC connection now, it keeps prompting me for my password over and over again and never lets me in. It was working find and now it has just stopped. Does anyone have any ideas about how I can fix this? Where does the boss's new router fit into the timeline? (I assume it's a new router at home, not in the Exchange network). If you both were affected at about the same time, its more likely an is...

How to stop calculating CPP when employee turns to 65 years of age
Hi; I am using Canadian Payroll in GP 10, one of my employee who turned to 65 years of old, subject to Canada regulation, he does not need to contribute CPP. How can I configure Canadian Payroll to calculate CPP under this employee, today; I have to remove the calculated amount manuall when I ran pay roll each time. The date of birth of the employee has been entered in system already. -- Kane I assume the Canadian Payroll is similar to that of the US in the sense that you have benefits and deductions. Canada Pension Plan (CPP) is a deduction that is (must be) associated to an empl...

How to stop spam?
I am an administrator of an Exchange 2003 server in a 2000 domain. I have applied the "Inetlligent Mail Filter" from microsoft (which is a free download). It does catch some spam but we are still getting spam to the heavy e-mail users. We are also nonprofit so there is little to no money for an expensive solution. Can anyone give me some suggestions as far as network (firewall) configuration and maybe some less expensive but good for the money solutions to stop spam? Reagrds, Try using SpamByes it can be downloaded from spambayes.sourceforge.net >-----Original Message...

Outlook2000-How can I stop the Message "A pgm is trying to"
In Outlook 2000, How can I stop the message "A program is trying to automatically send email on your behalf. Do you want to allow this?" What Outlook setting do I need to change? I know how to stop it in Outlook Express" Help! Dennis Rose wrote: > In Outlook 2000, How can I stop the message "A program is trying to > automatically send email on your behalf. Do you want to allow this?" > > What Outlook setting do I need to change? > > I know how to stop it in Outlook Express" > > Help! Do you even know what pro...

how do i work out what price to charge
i am a nail technician, and would like help with working out what i spend every month( on supplies e.g nails, nail polish , nail polish remover, fuel( car) , etc etc ), then be able to have a total figure at the end where i charge for a certain job, i.e french nails $30... by being able to work out how much im spending a month, compared to how much im earning... i'll soon realise whether or not im under charging myself look forward to your response kind regards Good questions. You could start with a simple table, say with 5 columns: Date, Category, Description, Expense, Revenue....

Office Notifications no longer work
Sometime in the last month, my Office notifications have stopped working. The Microsoft Office Notifications application is running and I have made sure that it launches at startup, but that hasn't helped the problem. I have repaired permissions since this problem began and have run both Norton Disk Doctor and Alsoft DiskWarrior as part of my regular routine, not specifically for this problem. Again, no effect toward the problem. I am running a dual 1.8 GHz G5 with OS 10.3.9. Office 2004 (Entourage v 11.1.0 (040913)). Any suggestions to fix this? -- Roy Behymer I think you're mor...