JWalk Chart Tools series label problem

I am using John Walkenbach's "JWalk Chart Tools" add-in to label a data
series with values from other cells. (I want percentages as data labels even
though the series is charted as actual values.) The two cells I'm using to
label the two points in my series are not next to each other, if this is
important. I CTRL-click the two cells and they are listed in the selection
window with a comma, like this: 'Source data'!$D$8, 'Source data'!$AG$8 .
This looks good to me. But while the values in D8 and AG8 are 5.33% and
5.16%, the labels show up as 5.33% and 21.93%

Bizarre, huh? I thought for a second that 21.93 might be the PRODUCT of 5.33
and 5.16, but that product is closer to 28. Can anyone help?

What I'd really like to do, while I'm at it, is to show BOTH the actual
values and the percentages in a two-part data label. (At the moment, the
actual values can only be estimated from the labels on the Y-axis.) If
anyone can do that, I will be deeply impressed.

Thank you very much,

Jamie


0
7/23/2003 7:36:08 PM
excel.charting 18370 articles. 0 followers. Follow

5 Replies
1354 Views

Similar Articles

[PageSpeed] 18

Jamie, the labels range needs to be in a contiguous range.

You can use a formula to combine two or more values in a single cell.
Something like this:

=A1 & ", " & B1

This shows the value in A1 and B1, separated by a comma. Do that for each
data point, and make sure that these formulas are in a contiguous range.
Then the Chart Tools utility should work.

John Walkenbach
For Excel tips, macros, & downloads...
http://j-walk.com/ss

"Jamie Martin" <lionsmouth2002@yahoo.com> wrote in message
news:uZMm$GVUDHA.2180@TK2MSFTNGP12.phx.gbl...
> I am using John Walkenbach's "JWalk Chart Tools" add-in to label a data
> series with values from other cells. (I want percentages as data labels
even
> though the series is charted as actual values.) The two cells I'm using to
> label the two points in my series are not next to each other, if this is
> important. I CTRL-click the two cells and they are listed in the selection
> window with a comma, like this: 'Source data'!$D$8, 'Source data'!$AG$8 .
> This looks good to me. But while the values in D8 and AG8 are 5.33% and
> 5.16%, the labels show up as 5.33% and 21.93%
>
> Bizarre, huh? I thought for a second that 21.93 might be the PRODUCT of
5.33
> and 5.16, but that product is closer to 28. Can anyone help?
>
> What I'd really like to do, while I'm at it, is to show BOTH the actual
> values and the percentages in a two-part data label. (At the moment, the
> actual values can only be estimated from the labels on the Y-axis.) If
> anyone can do that, I will be deeply impressed.
>
> Thank you very much,
>
> Jamie
>
>


0
john9024 (37)
7/23/2003 7:56:12 PM
OK, I see what JWalk is doing: it uses the first label I specify and then
just reads down one row to get the next label, ignoring the second cell
address I specified. Is there anything I can do about this?


"Jamie Martin" <lionsmouth2002@yahoo.com> wrote in message
news:uZMm$GVUDHA.2180@TK2MSFTNGP12.phx.gbl...
> I am using John Walkenbach's "JWalk Chart Tools" add-in to label a data
> series with values from other cells. (I want percentages as data labels
even
> though the series is charted as actual values.) The two cells I'm using to
> label the two points in my series are not next to each other, if this is
> important. I CTRL-click the two cells and they are listed in the selection
> window with a comma, like this: 'Source data'!$D$8, 'Source data'!$AG$8 .
> This looks good to me. But while the values in D8 and AG8 are 5.33% and
> 5.16%, the labels show up as 5.33% and 21.93%
>
> Bizarre, huh? I thought for a second that 21.93 might be the PRODUCT of
5.33
> and 5.16, but that product is closer to 28. Can anyone help?
>
> What I'd really like to do, while I'm at it, is to show BOTH the actual
> values and the percentages in a two-part data label. (At the moment, the
> actual values can only be estimated from the labels on the Y-axis.) If
> anyone can do that, I will be deeply impressed.
>
> Thank you very much,
>
> Jamie
>
>


0
7/23/2003 7:56:41 PM
That's sweet. I'd really like to have each value on its own line. Is there a
return character, such as =A1 & "/n" & B1 ?

> You can use a formula to combine two or more values in a single cell.
> Something like this:
>
> =A1 & ", " & B1
>


0
7/23/2003 9:53:21 PM
Use CHAR(10) to force a new line.

John Walkenbach
For Excel tips, macros, & downloads...
http://j-walk.com/ss

"Jamie Martin" <lionsmouth2002@yahoo.com> wrote in message
news:OKUu0TWUDHA.1688@TK2MSFTNGP11.phx.gbl...
> That's sweet. I'd really like to have each value on its own line. Is there
a
> return character, such as =A1 & "/n" & B1 ?
>
> > You can use a formula to combine two or more values in a single cell.
> > Something like this:
> >
> > =A1 & ", " & B1
> >
>
>


0
john9024 (37)
7/23/2003 11:09:39 PM
=text(f15,"0.00%") & char(10) & "(" & e15 & ")"

(It should look ok in the cell--untested in the chart.)

And set that cell to wordwrap (format|cells|alignment tab).





Jamie Martin wrote:
> 
> Here's another problem. I currently have this formula in a cell I want to
> use as a label for a point in my series
> 
> =F15 & " (" & E15 & ")"
> 
> F15 is the percentage value of the point, and E15 is the actual value. But
> the value from F15 no longer displays as a percentage once my formula
> includes a reference to E15 as well. I am asking Excel to use two different
> number formats in one cell. Can I get it to do that, and show F15 as a
> percentage while showing E15 as a number?
> 
> > > You can use a formula to combine two or more values in a single cell.
> > > Something like this:
> > >
> > > =A1 & ", " & B1

-- 

Dave Peterson
ec35720@msn.com
0
ec35720 (10082)
7/23/2003 11:13:22 PM
Reply:

Similar Artilces:

Problems with public folders #2
I am having two problems which may or may not be related. 1) In System Manager when I try to view or work with the public folder tree, I get the following error "The token supplied to the function is invalid", ID no:80090308. I cannot see any public folders or manage them at all after that. 2) Whenever anyone clicks on send/receive in outlook 2003, they get the following error "Task 'Microsoft Exchange Server' reported error (0x8004010F):'The operation failed. An object could not be found.'" Does anyone have an idea of what the problem is for either...

Free Data Process/Query Tool
If you use Excel everyday and spend lots of time on data/text processing, then you will find the this tool (UDQ Add-in) is very powerful and can speed up your daily data processing work. Currently the tool is free for everyone. Please feel free to distribute this tool to your friends/colleagues if you think it is helpful to your work. The following is a list of features/functionality of the tool: 1> Query/Import Data from Multiple External Data/Text/ASCII Files (Can useful import data from hundreds of files within minutes) 2> Query/Import Data from Multiple Closed Excel Files (Can...

Percentage Column Charts
HI!! I think I am thinking too much about this and it is easier than it seems, but I cant figure it out! hopefully someone can help. So I need to create a chart with 2 column...plan vs. actual. But I need each of these bar columns to be separted by percentages of the categories that make them up. EX: I need to make a comparison on how big of a percentage the Labor part of the Budget was when they planned and how it differs from the actual execution. Thanks for your help! Stacked Column Graph Set up as labor code ACT PLAN a 1 1 b 3 2 c 5 3 d ...

Problem in Setting up CRM server
Hi We are trying to install CRM server. but we getting following error message and we don't know the reason for this. Action Microsoft.Crm.Setup.Server.GrantDatabaseAccessAction failed. ---> Microsoft.Crm.Setup.Common.SetupException: Setup could not complete this action. This might be due to the fact that there are multiple Domain Controllers and they have not replicated new Microsoft CRM information yet. If this is the case you have several options: 1. Go to the domain controller and manually force synchronization. 2. Wait 15 minutes (typically) until the domain controller synchron...

XY chart labeller Issue: (Magic quadrant) But with a twist.
Hiya Folks I have the same problem as has already been discussed on the forum (see below@ end of my email), but in my case there is an additional twist. The orginal issue was solved by using Rob Bovey's XY Chart Labeler to add labels. The free download is at his web site: http://www.appspro.com/Utilities/ChartLabeler.htm But in my case I have lots of XY points (155 to be precise). The problem is that 155 visible labels make the chart look very messy. Is there anyway to make the XY labels invisible until you hover over them with a mouse/pointer? Any help would be greatl...

Problems with address books
I've had to re-install outlook '97 a couple of times to sort out some problems. Now I find that contacts isn't the default mail list. That's to say when I want to send an email the list of people is from an old address book and not from the contact list I have in front of me! How do I make sure that when I want to send an email or fax that I'm presented with a choice from my contact list? How can I safely delete the old address books which are now a waste of space? Peter ...

Money '04
I'm trying to use the 'Money Browser' w/in MSN Money 2004 and get "Page Cannot Be Displayed" or sometimes "Action Cancelled", but I can surf the web just fine with my cable modem...what's up with that? I've read on this forum that other users are having difficulties w/ this particular issue, any resolution would be helpful. I've tried: regsvr32 msxml3.dll in start|run also have un-installed and re-installed cookies enabled ...

chart question #4
Can anyone please give me some guideline on how to draw a chart with y-axis is the count of the item in x-axis? I am using Excel 97. Thanks. I am not certain I fully understand your question, but I am going to give it a stab. Excel charts are very flexible, and I think you need to keep in mind that you need to have the right data in place to draw the chart. I.e. don't focus on the chart itself, focus on the data in the spreadsheet you are trying to chart, and once that is in place, your chart will look the way you want. -- ChrisJ Omaha "00KobeBrian" wrote: > Can...

problems with toolbar-can't access certan commands i.e.hyperlink
can't access some commands - was working fine - now some commands are in grey - the commands disappeared from the pull down in the commands bar. Help magnus wrote: > can't access some commands - was working fine - now some commands are in grey > - the commands disappeared from the pull down in the commands bar. The hyperlink option may only appear when you are creating a Web Publication in certain versions of Publisher. -- Ed Bennett - MVP Microsoft Publisher http://ed.mvps.org Trial version? You may have run out of time. Some pulldowns only work when you are creating a ...

Label Options
I am creating binder spine labels using Publisher. It will allow me to make more than one copy per page, but I would like to make at least 4 different labels per page. Any suggestions? What version Publisher? What size are the labels? You will need to setup your page manually. Arrange, Layout Guides (This layout is for Avery's CD spine label) Side Margins 1.34 Top & bottom margins .5 Grid guides 1 column 15 rows zero spacing. If you are creating your own label sizes, the above is a sample of how to do a page layout so each label is different. -- Mary Sauer http://msauer.mv...

How to order chart in descending order of Freq?
I am using Access 2000-03. The graph is a subset to excel, but very close. I have a Access Graph Chart with the Row Source set to: "TRANSFORM Sum([Freq]) AS [SumOfFreq] SELECT [Personnel] FROM [Rept#704_Joint_Personnel] GROUP BY [Personnel] PIVOT [RP];" Currently, my graph order the personnel in Ascending order of Personnel. I want to now order it by Descending Order of Freq. In the query [Rept#704_Joint_Personnel], I have the following fields: a) Freq b) Personnel Can someone please help me here! Thank You, Gary I don't know how you'd have to modify your ...

Word problems 2003 and 2007 version
hey everyone both on my main computer and my brothers laptop word isnt working! its so annoying! on my desktop PC i have windows xp and word 2003. after getting a virus which stopped the internet from working i had to do a system restore - which got rid of the virus. but when i click on word it says that "this shortcut only applies to installed products", and when i go to word through program files it says "this product is not installed on this user" - but there is no setup thing i can press - will i need the disc maybe? on my bro's laptop he got the sa...

Problem exporting/importing .psf
Hi guys, I searched the community before and couldn't find anything regarding this issue. I am trying to export an Outlook 2000 mailbox from one user account to another. However, when I try and import it, I get the message saying that "Personal Folders "Properties for this information service must be defined prior to use". I have looked up solutions for this and they say to make sure its not read only. I tried this and it doesnt work, its currently NOT read only. Please note: This is a computer where the Outlook folder source for the export is on a user account no...

StretchDIBits problem with 16-bit (65536) colours
hello all, when the color-palette from the windows-desktop (properties) is set to 16-bit (65536), the print preview does not show the bitmaps properly. I guess the ::StretchBlt(...)/::StretchDIBits(...)/::BitBlt(...) don't work properly. the bitmap is divided in 2 parts, the right (1/3 from the bitmap) is put on the left place and the left is displaced to the right. at all the other color-settings there's no problem: 8-bit, 24-bit... any ideas? thanx a lot, tschu. the code: BOOL CDib::Draw(CDC* pDC, CPoint origin, CSize size) { if(m_lpBMIH == NULL) return FALSE; if(m_hPalette !...

Excel Graphing Line References off when chart is a sheet.
I have noticed that when any graph is created in EXCEL and you hover you mouse over the dataline you receive that corect response. If you convert the chart to a sheet, the hover of the data line is now not representative of the the y axis directly below it. The data being graphed is correct now the hover represents the "series" (x-Axis) correctly but does not represent the "Point" (y-axis) correctly at all. Tne Y-axis datapoint reference is wrong. Any help? ...

new document and framework problem
Hi, I have a dialog I need to display at the start of a new document in my SDI app. My problem is the first time through, it will show before the app is drawn. Where should I put a call to run the dialog if I want to be sure to only do so after the app is initially drawn? I currently use a check in the view's OnDraw, but I'm hoping someone else who knows the framework better has a better idea. Thanks, scott I don't think OnDraw is appropriate at all because that gets called all the time. How about OnInitialUpdate? -- Jonathan Wood SoftCircuits http://www.softcircuits....

CRM 4.0 VPC Problem
I downloaded CRM 4.0 VPC, extracted them, and I got MSDYCRM40VPC_BASE.vhd. After I create a new virtual machine for this vhd, I got an message "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device" when I clicked Start. So, it have not brought me to WINDOW LOGIN SCREEN. Anyone had this CRM 4.0 VPC worked, please help me how to get it work to get away from a message above. Thanks and Appreciations -Toi "Toi Day" <ToiDay@discussions.microsoft.com> wrote in message news:50BF3D76-10D8-4CF0-90BC-EFF8E0D925A0@microsoft.com... > I...

JWalk Chart Tools series label problem
I am using John Walkenbach's "JWalk Chart Tools" add-in to label a data series with values from other cells. (I want percentages as data labels even though the series is charted as actual values.) The two cells I'm using to label the two points in my series are not next to each other, if this is important. I CTRL-click the two cells and they are listed in the selection window with a comma, like this: 'Source data'!$D$8, 'Source data'!$AG$8 . This looks good to me. But while the values in D8 and AG8 are 5.33% and 5.16%, the labels show up as 5.33% and 21.93% B...

Display Missing Data Labels as N/A on a Chart
I am displaying values as the data labels in a chart but missing values are displayed as 0's. Is there a way to display them as N/A instead? ...

Number Format Problem Prevents Proper Sorting
I have a long list of numbers that were exported from anothe application that I can't seem to format properly to sort in ascendin order. I have changed the format from General to Number and back wit no success. I'm sure that this is an easy fix, but I'm not seeing th answer. The third entry below (1103) should be toward the top of th list. Any ideas? 110272 110277 1103 110329 110338 11033 -- 65Stan ----------------------------------------------------------------------- 65Stang's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1500 View this threa...

Problems with CListCtrl
I'm having trouble with a CListCtrl object. I'm trying to automatically set the selected items of the list from my code. I try the following statement: m_List.SetItem (pos, 0, LVIF_STATE, NULL, 0, LVIS_SELECTED, LVIS_SELECTED, 0); The SetItem function returns non-zero, which supposedly means it was successful. However, I don't see any selection showing up. I even called RedrawItem on this list item, but it didn't help either. Anyone know about this? -Eric >I'm having trouble with a CListCtrl object. I'm trying to automatically >set the selected ite...

Printing Problems...
Hello All.. I am trying to get my worksheets to play nicely..but no success. I have say 10 worksheets, and in cell "B4" I have Client Copy (across all sheets), so it needs to print all those sheets... Then I need to change "B4" to Delivery Copy, then print all those sheets, etc etc Problem is at the moment, it goes through all the sheets, and only prints the Dock Copy sheets (the last set). I see the text at "B4" change to what it should, but just keeps going and ignoring the print call. Sub delivery_copy() Dim sh As Worksheet For Each sh In ThisWorkbo...

Windows Service problem
Hello all, I have a program that I'm running as a service on a Window's NT machine, I used 'Srvany.exe' to install it, and it's running fine. But, when I try to do the same thing on a Window's 2000 machine, I get a "Error 1053: The service did not respond to the start or control request in a timely fashion". Does anybody have any ideas why this same program will not work on different operating systems? ...

exchange tools listed twice in ADUC right click
We installed exchange but forgot to install the tools option so we did it after. When that happened it locked up with errors part of the way thru. When I restarted after a system reboot and installed them again it now listed in the active directory users and computers extensions twice when you right click on an object. I removed the tools, it removes both entries. I reinstalled and now both entries are back. Where can I find these entries in AD and remove the duplicate. Thanks Comments inline below. -- Ed Crowley MVP "There are seldom good technological solutio...

OWA attachment problem #2
Hello, I'm experiencing unexpected behaviour in Outlook Web Access. When i attach a Level1FileType-file to an e-mail and i save it in the drafts folder instead of sending it, then i should not be able to access the attachment when i re-open the e-mail from the drafts-folder according to this article/webcast: http://support.microsoft.com/default.aspx?scid=%2Fservicedesks%2Fwebcasts%2Fwc061600%2FWCT061600.asp Since this article states: if you're working on a message and you attach one of these Level 1 attachments and you work for awhile and then you close the message to save it i...