Chart series #2

Hello! I have previously posted questions in this field but I have never 
gotten an answer. I really really need help with this. I have never 
programmed before and now I am supposed to do this VBA application for Excel. 
What I want to do is simple enough but I have trouble implementing it and 
since and really do not know anything about programming I do not know what is 
wrong. The problem is that I am supposed to replace the existing series for a 
chart with new series. I have the new series but when applying them to a new 
chart it does not work if I have not manually erased the old chart series. 
This does not seem like an obstacle but this code have to work for other 
applications. I try to change the series in a loop. Code:

Do While k < (UBound(rng))
      If Not IsEmpty(rng(k)) Then
            ActiveChart.SeriesCollection(k).Values = 
Sheets(varWorksheetInfoArray(0)).Range(rng(k).Offset(i, 0).Address & ":" & 
rng(k).Offset(j, 0).Address)
        Else: End If
    k = k + 1
    Loop 
The find function returns the correct range so that is not a problem. The 
problem is that if the chart already has a series the new data does not apply 
to the chart. I have tried referring to the number instead of the name of the 
series but with no success. Is there anything that you should do with the 
chart (this is the first time I am using xl/vba)? Should you try to delete 
the series or something. Please if you know anything about this help me out. 
If you see that the code is correct then let me know. I know I have posted 
questions about this before but I really must get this to work and I have not 
gotten a proper answer. I have never programmed before and now I am stuck 
until midnight every day since I have to do this outside of my other things. 
I know that it just a line or something that is missing but I have no clue 
where/what or how to figure it out. Please I am begging all you out there if 
you know anything about this help me out. I have vistited e.g. the Metha 
Consulting page where there are tips for dynamically chart making but that 
does not apply here. Please again any help is truly appreciated!  

0
7/18/2006 12:59:01 PM
excel.charting 18370 articles. 0 followers. Follow

0 Replies
635 Views

Similar Articles

[PageSpeed] 45

Reply:

Similar Artilces:

Batch Sattlement Problem #2
Today was my first day with Mercury Payment. and end of day When I try to sattle the batch and I am keep getting error CONNETION ERROR. I am trying to sattle same way I was doing with city bank. Is mercury setting different way ? Is any body here to help me to sattle the batch. I am getting connection error. Please Help This is a multi-part message in MIME format. ------=_NextPart_000_02D9_01C6F83C.869E10F0 Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: quoted-printable Gas, Any firewalls running? If so, turn them off temporarily to see if it = the...

LNK2019 error #2
Hi, I've got a really nasty linker error which actually shouldn't appear. The code itself compiles fine. It's just a simple console application with MFC for CStrings and other stuff. Here is the full message: ClassifierAcc error LNK2019: unresolved external symbol "class ATL::CStringT<char,class StrTraitMFC_DLL<char,class ATL::ChTraitsCRT<char> > > __cdecl GetNextKeyWord(char *,unsigned __int64,unsigned __int64 &)" (?GetNextKeyWord@@YA?AV?$CStringT@DV?$StrTraitMFC_DLL@DV?$ChTraitsCRT@D@ATL@@@@@ATL@@PAD_KAA_K@Z) referenced in function "st...

Q: When 0 <> 0 ? #2
A: When you add it in excel! Example: Place the following values in a column and sum them. -116.33 98.53 17.80 0 ============= Excel returns: 0.0000000000000035527136788005 Correct Answer: 0 If you remove 0 from the list ( or put it in a different place in the list, the proper result, 0 is returned. I assume this has to do with the known floating point issues, but I've never seen an example where 0<>0, so I thought I'd share. I have a workaround, but would love to see comments... See http://tinyurl.com/7dp22 -- HTH RP (remove nothere from the email address if mailing ...

Opening attachments in Outlook #2
Outlook 2002 Windows XP When I ago to send an email, add an attachment and try to open that attachment to check it's okay, I get the following error message: this object was created in outlook this application is not available to open this object Any ideas? Thanks ...

2 sided document one side upside down!
I'm creating a 2 sided document on 11x17 paper. The problem is no matter what i try, one side of the paper is flipped, so when you fold it, then open it, you have to turn it around. Can anyone help?? In the printer settings change from tablet to booklet. -- Don Vancouver, USA "bain_monica" <bain_monica@discussions.microsoft.com> wrote in message news:4BC3578A-A4A3-494F-B778-646DBAAAD1EF@microsoft.com... > I'm creating a 2 sided document on 11x17 paper. The problem is no matter > what i try, one side of the paper is flipped, so when you fold it, then ...

Excel Document of 2.5mb takes up to 20min to open up
Finally I have found the cure, basically it was caused by a corrupted EMF file which used up to 100% of a CPU and the Spooler is in a never ending loop. Fix: 1) Do a search for *.emf files (they will be found in the Temp directory) 2) If there are any then this is probably the cause - delete them all 3) Boot to an alternate install of NT and delete the *.shd and *.spl file from the Spool folder. 4) If you have a multi-processor, you can pause the printer and delete the files. After deleting all the *.emf files, which took me almost 15min (20000 files) I tested the Excel doc and it opened up...

Upgrade to POS 2.0, or downgrade to XP? Cheaper option?
I have been using POS 1.0 for several months now, and purchased a second computer to use as a backup. What I wanted was a turnkey backup station which could be turned on in an instant if my primary POS crashed - thus I needed a second license for POS. So I bought one assuming that it would work with my new machine, but it turns out that MSDE is required for POS 1.0, and SQL2005 is the only server Vista supports (my new machine came with Vista Basic, so I bought an upgrade to Business). So from what I understand, I have two options. Either: 1) Upgrade my POS software to POS 2.0 twice...

2007- unwanted column chart n/a labels displaying
I am using Excel 2007 and have found that I cannot get the NA() labels to NOT display. As desired, there is no column where the cell values are na() but the labels for those cells are displaying as "N/A". How do I keep these labels from appearing? Interesting. I made a Line chart with =NA() and the points were joined (as expected) When I added labels, the #N/A did NOT appear A copy of the same charge was changed to a Column chart and the #N/A does appears But then, with a column chart you could just leave the cell blank. What type of chart are you using? best wishes -- Bernard...

Hyperlinking problem #2
Hi there I have an excel spreadsheet that has more than 500 different hyperlinks to link 500 different emails stored in a folder. Now as soon as the number of emails exceed 100, I create a new folder and move the already-linked emails into the folder thus losing all the linkings. Is there a way to avoid losing the linkings... isn't there a way to link a document so that the link is not lost even if the linked document is moved? Thanks Raj ...

Column
Hi, I have spent hours trying to work out how I can create a chart with 2x Y axes that are column - column - that don't overlap but are represented by to bars next to each other - NOT OVERLAPPING. I feel that I have tried everything - I have tried fiddling with the overlap ect... but I can't seem to get two seperate bars. I would love any hints and even to know if is possible or not. I thankyou in advance for you response. Hayley -- Hayley44 ------------------------------------------------------------------------ Hayley44's Profile: http://www.excelforum.com/member.php?actio...

AutoFilter #2
When using AutoFilter, is it possible to have the text value of the filter selected inserted into a cell? I am using Excel to evaluate survey results. I have a worksheet set up so that filters can be applied to different columns to look at the data in a variety of ways. The results of those filters are used to calculate percentages, such as percent favorable responses from respondents fitting a certain criteria. Those results are displayed on a separate worksheet that updates as different filters are applied. However, I don't know how to get that worksheet to display the fil...

chart type #3
On a number of occasions I have selected XY chart type with points only. When the chart is drawn the type is XY chart with points and lines. Has anyone else had this problem? Why would the chart type change? Thanks for any help. mk Hmmm. I can't replicate your problem. Can you give more specifics? Wigi "mk" wrote: > On a number of occasions I have selected XY chart type with points only. > When the chart is drawn the type is XY chart with points and lines. Has > anyone else had this problem? Why would the chart type change? > > Thanks for any help. ...

NNTP #2
Hi All, I posted this query few days ago but still do not get response... :-( has anyone been using Exchange 2003 connecting to this newsgroup? I found exchange 2003 does not work with NNTP pull but exchange 2000 works well without any problem. thanks ...

Charts created in Excel 2003 are not showing up in excel 2007
I have several charts that are displayed as their on worksheets in excel 03 but don't show up in excel 07 how can i fix it so that these charts will display? "RLang07" wrote: > I have several charts that are displayed as their on worksheets in excel 03 > but don't show up in excel 07 how can i fix it so that these charts will > display? I had this exact problem when I upgraded from Excel 2003 to Excel 2007 on my Vista (Home Premium) system. I couldn't work out what the problem was and had given up trying to solve it... However, I somehow managed to fix...

id display's funny on form built on qry built on 2 tables ?? (usnint the form Wizard)
i create a query (qryAB) built on 2 tables... tblA and tblB (tblB is a 'child" of tblA) >From tblA the query has 1 fielsds... idA >From tblB the query has 2 fields... idA, idB Now I use the form Wizard to build a Form on qryAB and elect to show all the fields in qryAB on the form The Wizzard ask me "How do you want to view your data?" I click on tblB and the only option is "single form" so I take this option. Now my form doesn't display idA correctly... the 3 fields show like this... tblA_idA -- (note the underbar should show tblA.idA) idB tblB_idA...

Send E-Mails to 2 SMTP Server
Hi, we have two companies sharing one SBS 2003 Server. Lets say one has the domain company1.com and the other one has company2.com The problem is, that company1.com and company2.com are hosted by two different hosting companies. We use PopCon to recive the E-Mails from all the pop3 accounts at company1.com and company2.com and forward them to our exchange server. Now we need to setup exchange in a way that some user use addresses at company1.com and some at company2.com for outging mail. I've read how to add the domains to the recipient policy, and how I can set the default smtp...

Chart data with zeroes
I have used an IF formula to replace blanks, zeroes etc. with #N/A as I thought charts ignored this. My source data is 2 columns as below displaying as a line chart: #N/A #N/A 0.20 0.0017497 0.40 0.0017613 0.60 0.0017538 0.80 0.0017459 1.00 0.0017397 1.20 0.0017358 1.60 0.0019809 2.00 0.0021619 #N/A #N/A #N/A #N/A #N/A #N/A The #N/As are plotted as zeroes with #N/A displaying instead of a figure on the X axis. I need to get rid of the #N/As displaying on the X axis and have excel ignore them on the chart. Any help greatly appreciated. ---------------- This post is a suggestion for Micr...

RMS 2.0
On the PartnerSource home page, on the left-hand side menu, under Resources>Industry Solutions>By MBS Product, there's a thread for Retail Management System 2.0 partners. Now my question is, has there been a secret RMS release that I'm unaware of? Seriously, how do you explain this? And in case my eyes are playing tricks on me again, anybody knows when the next RMS release is due and what the advertised changes are? Thanks, Hi Tom :-) I was chequing on what you were saying... and I would be all that alarmed. ;-) There is an information session for partners in a few days....

Drop down box with country list #2
Thanks Bob, however what I want is a dropdown which we can find in the web site applications (e.g. airways ticketing) where we can use choose a country using the drop down with a complete list of world's countries. In Data Validation method, I have to re-type all the possible country's names. John. Bob Phillips Wrote: > Enter the countries in a range (say column M) and then add a Data > Validation > (DataValidation) and select the List option with a formula of say > =M1:M100 > or however many countries > > -- > HTH > > Bob Phillips > > "jo...

Series Split
Hi, Firstly - apologese for the bad explanation of my problem! I have made a line chart, and at a certain point I would like the series to split into three lines. One for different forecasted results. Is this possible? Many Thanks Hi, Sounds like you really need to use 3 data series. They would all have the same values up to the point of the split. Cheers Andy Wilkesy50 wrote: > Hi, > > Firstly - apologese for the bad explanation of my problem! > > I have made a line chart, and at a certain point I would like the series to > split into three lines. One for differ...

One to many relationship with Invoice Product as parent #2
I need to create a one to many relationship in CRM 4.0 with the Invoice Product entity (invoicedetail) as the parent and a custom entity as the child. I see that the functionality to create this particular type of relationship has been disabled in the regular entity customization tools. Does anyone know of a supported (preferred of course) or unsupported way to create this relationship and display it in the usual manner on the Invoice Product and custom entity forms? Is there a reason that I should know about why CRM does not allow this type of relationship to be created? ...

chart data line in two colors
My boss wants a data line in my chart be green when abouve goal and red when below goal. I do not think it is possable, but I thought I would check out here first. Hi there might be a way to automate this, but i'm not sure how, but it is possible to manually generate a chart where the line changes colour between data points .... create the line chart as per usual, and then click on the bit of the line you want to change colour (all the points should show as selected) and then click again (only the points at the end of the line you're clicking on should show as highlighted) no...

email links #2
hi, i have recently installed office 2003 pro and i have switched from outlook express 6 to outlook (the one that comes with office 2003 pro). since i have started using outlook everytime i click an email link on a webpage or in an email message i get about 40 or so "new message" windows open up. can anyone help? thanks, cya john ...

creating a chart not working
my charts all come out with just gray lines no matter what I do, I know I am setting it up wrong, but have tried several ways, is there a trick? is this when you print it or on your display? make sure your print options say to pringt in color and not grayscale. "samm" wrote: > my charts all come out with just gray lines no matter what I do, I know I am > setting it up wrong, but have tried several ways, is there a trick? ...

Upgrade from BP 2.5 Service Pack to BP 4
In preparing for a GP10/BP4 upgraded, I've created a test environment with GP 8.0SP5 and BP2.5 with feature pack on MSDE. My understanding is that the upgrade path is as follows: Upgrade GP 8.0SP5 to GP 10.0 Upgrade WSS 2.0 to WSS 3.0 Install MOSS 2007 Run the migration utility and then install BP 4 The GP upgrade runs smoothly. Can someone who's been down this road before please help me with what to expect during the Business Portal upgrade? I'm assuming that as I upgrade WSS to each higher level, the original BP site will not be working as BP 2.5 doesn't support WSS...