Unexpected WSE 2.0 errors in Event Log

Hello,

We run a very stable and well functioning ASP.Net 1.1 webservice using WSE 
2.0 sp 3. 

Every now and then the following error appears in the system event log:

HTTP/ASMX Message Receive Failure: System.Xml.XmlException: This is an 
unexpected token. The expected token is 'EndElement'. Line 1, position 4387.
   at System.Xml.XmlTextReader.Read()
   at Microsoft.Web.Services2.Xml.XmlSkipDTDReader.Read()
   at System.Xml.XmlLoader.LoadCurrentNode()
   at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean 
preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at Microsoft.Web.Services2.SoapEnvelope.Load(Stream stream)
   at 
Microsoft.Web.Services2.Messaging.SoapPlainFormatter.Microsoft.Web.Services2.Messaging.ISoapFormatter.Deserialize(Stream stream)
   at 
Microsoft.Web.Services2.WebServicesExtension.BeforeDeserializeServer(SoapServerMessage message)


What can I do about this?

-- 
rvangeldrop
0
4/7/2006 8:53:02 AM
dotnet.xml 7266 articles. 0 followers. Follow

5 Replies
405 Views

Similar Articles

[PageSpeed] 38

Hello,

It seems it receive the incorrect soap message which is not well formatted. 
Unfortunately, we cannot tell more details with current information. You 
may need to catch the exception in code and check what message/object cause 
such a problem, and test if the problem is reproduable. 

Luke Zhang
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from your issue. 
==================================================

(This posting is provided "AS IS", with no warranties, and confers no 
rights.)

0
lukezhan (72)
4/10/2006 5:36:27 AM
Hello Luke,

Debugging this will be hard, since so far we did not see an exception 
attached to this logging behaviour, since it is not our own application that 
logs this but WSE.

Is it possible to stop WSE from logging this error to the event log?

Regards,

-- 
rvangeldrop


"Luke Zhang [MSFT]" wrote:

> Hello,
> 
> It seems it receive the incorrect soap message which is not well formatted. 
> Unfortunately, we cannot tell more details with current information. You 
> may need to catch the exception in code and check what message/object cause 
> such a problem, and test if the problem is reproduable. 
> 
> Luke Zhang
> Microsoft Online Community Support
> 
> ==================================================
> When responding to posts, please "Reply to Group" via your newsreader so 
> that others may learn and benefit from your issue. 
> ==================================================
> 
> (This posting is provided "AS IS", with no warranties, and confers no 
> rights.)
> 
> 
0
4/25/2006 3:08:02 PM
WSE only will raise an exception to your web service. The Eventlog part 
should be in your web service. You may check if your web service project 
have any exception handling part and try block the exception there.

Luke Zhang
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from your issue. 
==================================================

(This posting is provided "AS IS", with no warranties, and confers no 
rights.)

0
lukezhan (72)
4/26/2006 5:39:06 AM
Hello Luke,

We have some more progression on this issue. The problem is caused by the 
WebProxy on a client, that is not threadsafe. If the proxy is accessed by two 
threads for signing and sending a SOAP Request the WSE interface has trouble 
decoding the SOAP:XML on the server side. The WSE dll logs an entry to the 
EventLog in that case. The SOAP-request never resolves and this means we were 
unable to debug it, since nothing happened in our code.

It means that WSE 2.0 dll logs errors to the EventLog by itself. We do not 
log anything at all. 

I expect that you look into this to see if the logging of these errors to 
the EventLog can be disabled (or redirected to a different log group). Can 
you please look to this?

Kind regards,

-- 
rvangeldrop


"Luke Zhang [MSFT]" wrote:

> WSE only will raise an exception to your web service. The Eventlog part 
> should be in your web service. You may check if your web service project 
> have any exception handling part and try block the exception there.
> 
> Luke Zhang
> Microsoft Online Community Support
> 
> ==================================================
> When responding to posts, please "Reply to Group" via your newsreader so 
> that others may learn and benefit from your issue. 
> ==================================================
> 
> (This posting is provided "AS IS", with no warranties, and confers no 
> rights.)
> 
> 
0
6/8/2006 6:26:02 PM
Hello,

After searching more documents, I found a event og source "Microsoft WSE 
2.0" will be created when WSE 2.0 is installed on a server. But I didn't 
finda way to disable it. The only way I think is not to grant the 
application the permission to write event log.

Regards,

Luke Zhang
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from your issue. 
==================================================

(This posting is provided "AS IS", with no warranties, and confers no 
rights.)

0
lukezhan (72)
6/9/2006 3:26:27 AM
Reply:

Similar Artilces:

recieved error message 0x8DE00006
I cannot get Outlook to send a mass mailer out to business emails. Is ther a max amount that I can send too? I just keep getting this error message and then I go to look it up and there is not solution. Please help!? I have about 375 emails addresses in a distribution list. I just can't seem to send it out. This is most probably an issue with your ISP. They put a quota on how many emails you can send out at a single time. It is a control put in place to restrict Spam. Call your ISP for info -- Peter Please Reply to Newsgroup for the benefit of others Requests fo...

parsing a date and time field #2
I am having trouble parsing the date and time in a field. I download data from a data base and the date and time come together in one field. I want to seperate the two. The date and time comes across as the following: "2/1/2009 14:37" in the cell. When I parse it, it seperates into three columns as follows: "2/1/2009", 2:37 AM", and "PM" I can see what is going on but I would like to get two columns with one as the date and the other as the correct time. are they any ideas on how to address this? Try using the TimeValue and DateValue functions. First format ...

X Error Bars appearring when it is not set
Hi, I am using the ErrorBars in my chart. I only want the Y Error Bars to show on my chart and I set it correctly in my program using .ErrorBar Direction:=xlY but it appears as a bug in Microsoft Excel Macro. I tried the method in Article 157110 of the Microsoft Knowledge Base to remove the erronously set X Error Bars as follows and it doesn't seem to work: Application.ExecuteExcel4Macro ("SELECT(""Series 1 X Error Bars"")") Selection.Delete What else should I check or what other method can I use? Is this problem corrected in the the latest Microsoft...

RSS stack error help pls
I need to demo RSS for CRM (VPC image), i install the CRMrss from michaeljon miller site, extract to C:\Program Files\Microsoft CRM Server\CRMWeb\rss\ change the two .cs files so port include 5555. check the web.config to ensure app key is there for ISV integration. copy the isv.config.xml to the resources folder. go to visual studio 2005 command prompt, go to rss\code to run the make.bat. output from screen is 1 file copied. open the browser, i got the Exception of type System.Web.HttpException was thrown, stack error.. any help? thanks! ...

Error opening a document in Sales Literature
Anyone see this error instead of the document?: {{handler "C:\PROGRA~1\MICROS~3\Server\bin\AttachmentHandler.dll"/Download}} ...

All macros failing part way through with different error messages
All the macros I have in various workbooks are failing - usually part-way through - with different error messages each time. When I check the debugger and try to edit the text, there seems no reason why there should be a problem. The macro has so far stopped on instructions to : - open a workbook - select a worksheet - paste a column in a different place Several times the macro has just stopped running without completing and without showing an error message. I cannot run a host of urgent daily reports without using the macros. Please help! NO way to help unless you tell us exactly...

3.0 Customization
Is it possible in 3.0 to have one set of screens appear for one group of users and another set for another group. For instance, could our service people only see the service screens while our sales people only see the sales screens? I know I can restrict access to different areas, but we want to have a totally different look and feel for each group... Sorry - I dont believe this can be done "Matt Harvey" <rifleman@gmail.com> wrote in message news:OR2vU$3GGHA.740@TK2MSFTNGP12.phx.gbl... > Is it possible in 3.0 to have one set of screens appear for one group of >...

Report CRM 3.0
Hi, I would need to find out the detailed procedure (step by step) to customize a report…. Could anybody inform about any links or documents concerning this issue? Thank's Marco I'm not sure if it's detailed enough, but the technical training manual has a section on creating and customizing reports. You can find it here: http://www.microsoft.com/businesssolutions/crm/using/whatsnewtechnical.mspx HTH, -- Jeffry van de Vuurst CWR Mobility www.cwrmobility.com -- "Marco Rocca" <Marco Rocca@discussions.microsoft.com> wrote in message news:CEF80683-EC26-456C-82C...

macro #2
I am pretty new to using (or attempting to use) a Macro in a workbook. I am having trouble following how and what to do to even start the process; ie If there needs to be a worksheet already in progress or can I start from a new sheet. THEN where to go from there. Can I have some help in this area? Can some one supply me with a sample MACRO? Any help would be greatly appreciated Dan The best way to get started with macros is to use the Macro Recorder. Go to the Tools menu, choose Macros, then Record New Macro. Then, carry out some simple tasks and examine the code that is produced. ...

merging 2 cells without losing data?
How can I merge 2 cells without losing data from the other cell? Hi Bob Not possible I'm afraid. Try placing the dat from both cells into one and use "Center across selection" under Format>Cells>Alignment Merge cells always end up causing grief. they are best avoided. ***** Posted via: http://www.ozgrid.com Excel Templates, Training & Add-ins. Free Excel Forum http://www.ozgrid.com/forum ***** "bob" <bobree@hotmail.com> wrote in message news:%23JuOM9HGEHA.2308@tk2msftngp13.phx.gbl... > How can I merge 2 cells without losing data from the other...

Statements #2
How are statements sorted? Alphabetically by name or by account number? Does anybody know? -- Any help is appriciated, Deb Mine are done alphabetically by name. -- Elizabeth M. "Deb" <Deb@discussions.microsoft.com> wrote in message news:D58FEF32-7509-473B-A554-6A48E02697CF@microsoft.com... > How are statements sorted? Alphabetically by name or by account number? > Does > anybody know? > -- > Any help is appriciated, Deb ...

how to config Server for one user which has 2 mail address.
we have one NT4.0 + Exchange 5.5 Server "A" Email abc@xxx.com.cn ��and another windows2003 + exchange 2003 Server "B" abc@cn.xxx.com user name is same in A B��Mx record was be set ,question is how to config Exchange 2003 to receive down the mail to Server A , because of we need to replace A with B. thanks a lot. E2K3 setup guides you through common scenarios (like yours) pretty much holding your hand - on welcome screen tell it that you have existing E55 org and want to join it, then follow on-screen instructions. Having usable backup of Exchange databases and AD i...

Money Central Portfolio #2
My print function has gotten corupted. When I print it flips to WORD / format and prints in a format that is 4x normal. ...

js error in ie8
Hi, i am opening a popup window in ie8, the popup is load with loaded with one url and some javascript classes are intialized and able to call the member functions are from page and then i am re-directing the page the another url and the js classes are reinitialized. when i try to call the member function of the js class in the re-directed page, ie8 throws js error as "Unexpected call to method or property access". When debug the code, i found that the class is properly initialized and able to access the member variables of the class. i am getting problem only ...

Exchange Connector Wizard error
I received this error while trying to run this wizard for a generic CRM user(what role does it have to have?) that would accept all email directly to CRM. I ran it on a client computer (was this wrong?) Here is the error, anyway. "Failed to initialize the rule management subsystem." What is the correct procedure to run this wizard? I did not find it anywhere. Thanks! ...

VLookup in VBA giving error message
Hi, I'm having trouble making the vlookup function work in VBA. the values that are used are all dates, I don't know if that makes a difference. Worksheets("sheet1").range("a1").value = application.WorksheetFunction. _ Vlookup(Range("c1"), range("a:a"), 2) this gives me a run-time error '1004' Unable to get the vlookup property of the Worksheet function class so i tried this: Worksheets("sheet1").range("a1").value = application.Vlookup(Range("c1"), _ range("a:a"), 2) but this gives me a #REF ...

Metadata Cache Error 04-14-04
When trying to "Go Offline" after synchronization completes I receive the: "Metadata Cache Error" No Entity Anyone experience/solve this issue? Hi, You may have replication setup issue on your SQL server, I suggest you to go through this article : http://mbs.microsoft.com/TechKnowledge/techknowledge.asp?print=true&id=33588&code=7842 If this is OK, you may test the following manipulation : Open SQL Enterprise Manager; go to Start select All Programs and then Microsoft SQL Server. Expand Microsoft SQL Servers, expand SQL Server Group, expand your Microsoft CR...

CRM 4.0 Custom Report Filter Problem
I am using the Report Wizard to create a simple report. Report is using Quotes and Quote Products I have a custom field in Quote Products which is a bit field Yes-No When I use that field as a filter for report output, I get all records. The filter criteria appears to be ignored Is this an inherent problem with Report Wizard or Am I doing something wrong? Thanks. depends on your business logic and what you want to see. If you have three quotes: Quote-1 has three products, all with the custom field set to Yes Q2 has three products, two set to Yes, 1 to No Q3 has three products, all set...

Vb.net 2008 ContextMenuStrip logical error when running code
Greetings, I have a connectmenustrip item that when clicked runs the following code (see below) Now if the event is called by the button i.e. cmdDeleteingBooking.Click the linq query returns the appropriate value. However when called by cntMnuCancelBookingItem.Click is returns 0 even if a checkbox is of 'TRUE' value. Debugging shows the code runs exactly the same code (which loops around rows in a datagridview checking if the checkbox has been checked). Could someone explain the reasoning why the same code would return different results? Private Sub cmdDelete...

"Application has failed to start..." error message with VS2005 on new machine
VC++ MFC Project working absolutely fine on one machine Installed Visual Studio on a new portable and copied the project and all the settings over, done a complete rebuild which worked fine but now get an error message "The application has failed to start becuase the application configuration is incorrect. Reinstalling the application may fix this problem" Have tried reinsalling (but I dont think this is relevant as I am working with VStudio) the message pops up a couple of times but then the program runs OK Does anyone know what this means and how to find out what is missin...

Macro
Here is one for you experts - I am a novice I want to add a macro to a worksheet that will print selected information held on certain rows of the worksheet. Once the 'button' has been selected a mesage box will pop up asking the user to input which row number he/she wishes to print. On input that number is matched to the corresponding row of the worksheet and that row is copied (without any formula - just cell values) and pasted into another worksheet where it is placed into other formats and printed. Seems like a simple(!!) job - but far to difficult for me to programme Can an...

Label Error with image?
Hi, We are trying to print a label for jewelry, the only issue we seem to have is that when an image is put into the label designer the image is the right dimensions but instead of being an image it is a box with red lines cris-crossing with the word 'ERROR' displayed in the center. This all happens before printing, although when we try to print there is no image. So what is it that we are doing wrong to not have an image displayed in the Label designer of RMS PO Manager. Any help[ would be greatly appreciated! Thanks ___________________ Dave Dave, In Label Designer, you have ...

Can you create custom activities? MSCRM 3.0
Hi, Is there a way to create a new custom activity instead of customising an existing one? I have created a custom entity called 'Chat' utilising an IFRAME. All works well but this entity really should be an activity considering it's properties. In fact I've just been introduced to MS-CRM 3.0 and don't really understand what the difference is between an entity and activity. Would anyone shed the light for me? BTW, I think 3.0 looks great. Gotta admit it's improved. Cheers. Ty In my experience, you cannot create custom activities. In fact, I have been dire...

error on install to pocket pc
"window\mny2day.dll" is in use or is in ROM. IFthe file is not in ROM, please close the application using the file. I do not understand what file could be using the same application or how to check the ROM. ...

Frx Susbcript 9 error
I am running a consolidated Income Statement in FRx and I get an Error 9 when it hits this one company. It consolidates 5 different companies, one that is translated. I just can;t figure it out. I have a very similar Balance Sheet that runs just fine. I have tried everything, change the output names, etc. I can run the report if I just select that one company but when I run the total company it won't run, it stops with the error. I am using row linking and currency translation. I can run the report for all companies individually. I just don't get it. I have gone through the various kb...