Problem connection to local db in VWD2010

Hi, I hope this is the right forum. I just loaded VWD2010 via the MS
installer tool. VWD2010 appears to work fine except that  I am unable
now to connect to the local database. Also, the Db creation option is
grayed out.

Attempting to open the local db raises the following error message:
"Failed to generate a user instance of SQL Server due to a failure in
starting the process for the user instance. The connection will be
closed."

All processes are enabled in the SQL Confguration manager (Shared
memory, named pipes, TCP/IP, etc.).

Someone posted a similar question last month (Harlan Messinger, Mar
27). One of the posters thought the issue was related to
authentication.

The local connection string (which worked fine in VWD2008)  is:
<add name="conLocal" connectionString="Data Source=.
\SQLEXPRESS;AttachDbFilename=|DataDirectory|\localDB.mdf;  Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/
>

I noticed that SQLServer 2008 works if the connection string is set
via "Microsoft SQL Server (SqlClient)" (eg. Data Source=localHost
\SQLEXPRESS;Initial Catalog=localDb.mdf;Integrated Security=True.).

However, substituting "localHost\SQLEXPRESS" for ".\SQLEXPRESS" in the
connection string  yields the same run-time error.

TIA for any suggestions
0
helveticus
4/17/2010 2:14:53 PM
dotnet.framework.aspnet 1425 articles. 0 followers. Follow

2 Replies
599 Views

Similar Articles

[PageSpeed] 24

After re-visiting other forums, I changed the the user instance from
"true" to "false" in the connection string ie:

 <add name="conLoc" connectionString="Data Source=locSrv
\SQLEXPRESS;AttachDbFilename=|DataDirectory|\locDb.mdf;Integrated
Security=True;User Instance=False"
providerName="System.Data.SqlClient"/>

This seems to do the job.
0
helveticus
4/17/2010 3:48:59 PM

"helveticus" <msch.prv@gmail.com> wrote in message 
news:66797901-5692-45c1-a31d-95639a88009c@u31g2000yqb.googlegroups.com...
> After re-visiting other forums, I changed the the user instance from
> "true" to "false" in the connection string ie:
>
> <add name="conLoc" connectionString="Data Source=locSrv
> \SQLEXPRESS;AttachDbFilename=|DataDirectory|\locDb.mdf;Integrated
> Security=True;User Instance=False"
> providerName="System.Data.SqlClient"/>
>
> This seems to do the job.

Unless you are deploying to an ISP that uses Express, this is not the wisest 
way to work with databases. You can, of course, set up the connection 
however you like in production, without regard to development, but it is 
easier to keep them as similar as possible.

You can use SQL EM to attach the database and then connect using 
server/database syntax without the UserInstance bits. Then the database will 
actually be in the server, as it will be on many ISPs.

-- 
Peace and Grace,
Greg

Twitter: @gbworld
Blog: http://gregorybeamer.spaces.live.com

************************************************
|    Think outside the box!                        |
************************************************ 

0
Gregory
4/18/2010 3:24:44 PM
Reply:

Similar Artilces:

One domain on exchange server not accepting connections
I setup a second domain on an Exchange 2003 server, and thought everything was working. Now, though, mail going to the second domain gets rejected, but mail going to the original domain is still working. I can telnet to the original domain, but not to the second domain. I've checked everything I know to check (I've setup plenty of domains on Exchange servers, so I believe I've gotten the setting correct), but I just can't get it to work. The MX records are correct, and mail.theseconddomain.com resolves to the right IP address (the same IP as mail.originaldomain.com), so it sh...

Problem converting from MSXML2 to MSXML4 in C#
I had a piece of code working fine with MSXML2 (it does an open get and then a send, returning the webpage of the url in the get) but my server is hosted by a company that uses MSXML4 - help? I added a reference to MSXML4 - I right clicked on my project name -> clicked Add Reference -> Went to Com tab ->Chose Microsoft XML v4.0 c: \windows\system32\msxml4.dll It asked if I wanted to replace MSXML2 and I said yes - I regret this as I think it has now screwed something up. I removed the using MSXML2; at the top of my C# and replaced it with using MSXML4; but when I try typing MSXML4 the...

outlook delete message outbox problem
I am seeing that this is not an unusual problem. I have tried working "offline". I have tried disconnecting the internet connection to the computer, restarting, delaying message sending, etc. File still will not delete or be moved. I have noticed same "error" message as some others have gotten, mapi spooling? and "message has already begun transmission what a joke this has been for 2 weeks and I don't even know what archives this has been pulled from. Does anyone have any suggestions? ...

Maintenance Plan and Read Only DB
I'd like to use a Maintenace plan to run DBCC + Update Statistics on my DBs, but since i have one DB which is Read Only it stacs on that DB. What can I do? If the DB is read-only why update stats ? "Gal" <Gal@discussions.microsoft.com> a �crit dans le message de news: 345532F2-4689-44B0-8F39-1E637FD64179@microsoft.com... > I'd like to use a Maintenace plan to run DBCC + Update Statistics on my > DBs, > but since i have one DB which is Read Only it stacs on that DB. > What can I do? I forgot to mention that I like to use the option of &...

Problem with empty page
hi asp.net 3.5 I have a webpage which if it has a querystring attached it'll display some usefull information. But if no querystring is attached it displays this content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML><HEAD> <META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD> <BODY></BODY></HTML> I've tryed to put some logic into the page so when no querystring is used it should give some values to a Literal control on the page. That code executes ...

still having send receive problems
I have posted several times but have not had a resolve to my problem. I am using outlook from the office 2003 suite. I have 3 accounts one personal, one business and one hotmail, all correctly configured. When I click on send and receive all, mail that is in the respective server mailboxes is delivered to my respective accounts but then it hangs at 83% and does not move off that percentage. What is causing this? is one of the accounts timing out? that can usally cause problems if connection's have problems "Headtheball" <noanswer@hotmail.com> wrote in message news...

Problem changing wallpaper on Vista
I am trying to change the wallpaper on Vista. I have a sub that works on XP with .jpg and .bmp images... Private Sub SetActiveDesktopWallpaper(ByVal sFileName As String, ByVal lStyle As Long, ByVal fForce As Boolean) Dim ad As ActiveDesktop Dim co As COMPONENTSOPT Dim wpo As WALLPAPEROPT Set ad = New ActiveDesktop 'check if AD is enabled co.dwSize = Len(co) ad.GetDesktopItemOptions co, 0& With wpo .dwSize = Len(wpo) .dwStyle = lStyle End With With ad ' set wallpaper style... .SetWallpaperOpt...

Can't connect after updates.
I downloaded the two software updates and now I can't connect with Live ID. Anyone one else have this problem? I am actually experiencing the same issue. I just installed, it said that there were updates available which I installed and now I can not connect from within money... I am using vista, not sure if that is part of the problem or not... "Jakryk" wrote: > I downloaded the two software updates and now I can't connect with Live ID. > Anyone one else have this problem? I'm using Vista also. I've reinstalled Money and I cancel the updates. It happen...

Exchange no longer available
Courtesy of Katrina, my brother-in-law's job and Exchange server are no more. He knows he has personal folders and contacts on his laptop, but Outlook choles on not connecting to Exchange and won't let him see the local stuff either. How does one tell Outlook not to try to connect to Exchange and instead use the local pst file? It might be easier to create a new profile and then use File Open to access the personal folder file, you create a new profile in Control Panel || Mail <philmcin@yahoo.com> wrote in message news:1126736961.961262.92120@g43g2000cwa.googlegroups.com... ...

Local folders
G'day, When I go to my Outlook Express, Local Folders The Folder named All forums always comes up opened. It has only just started doing this. When I close it to unopened, ie. + sign it will come up opened, - sign, next time I use Outlook Express. Is there a way to change this? -- chequer When the game is over, the King and the pawn share the same box. This group is for posts concerning MS Office. Outlook Express is not part of Office Please repost giving full details of your Operating system and version of OE. OE newsgroups. news://msnews.microsoft.com/microsoft.pu...

VBA problems
Hello, I just started messing around with VBA and I got something approaching what I want (what I want is to highlight a row based on a value in the 1st column). This is highlighting the wrong row though! It looks like all the numbers are correct... for instance, when I step through it, I'll get the correct row selected but a different row highlighted! Please shed some light on this! It's quite frustrating. ' first column has dates from 12/2003 to 12/2006 Private Sub Worksheet_Activate() Const Yellow = 6 Dim row As String Range("A1").Select Do While...

Money 2006 problem
I just installed the money 2006 trial version but when I try to run Money it just opens briefly and then immediately closes. Money 2003 was doing the same thing but I thought maybe 2006 would fix the problem. Can anyone help me please? Instead of opening Money, navigate to the folder where you have your .mny file using My Computer or Windows Explorer and double click on the sample.mny file. That will tell us if your My Money.mny file is faulty or the M2006 installation. -- Regards Bob Peel, Microsoft MVP - Money For UK tips & fixes see http://support.microsoft.com/default.aspx?sc...

Combo Box Problems
I would like to make a combo box in my worksheet do exactly what the Name Box does. When a item in the combo box is selected scroll right or left through the worksheet and find that heading that was selected in the combo box?.....Is there a way to do this? Thanks. On Aug 13, 10:00=A0am, daphoenix <daphoe...@discussions.microsoft.com> wrote: > I would like to make a combo box in my worksheet do exactly what the Name= Box > does. When a item in the combo box is selected scroll right or left throu= gh > the worksheet and find that heading that was selected in the combo > bo...

Problems switching to new hardware
after removing active directory from the machine, I tried to activate it as a 2nd machine for the new Dell machine. No luck, it still could not locate the machine. After tinkering around I finally gave up and reinstalled the OS on the new machine from scratch. I recreated the user list and also installed the email server. We're up and running again. I only have one problem left. Our old domain was server1.xxx.org. The new domain I created was just xxx.org. So now anytime we try to access the external web site from our provider called xxx.org I don;t get it. I've tried to use the DNS ma...

Colour Problem in Excel 2002
Hi, I'm having a really annoying problem. When I create autoshapes in Excel 2002 (XP), when I scroll down the page, and then back up, the colour is distorted and ruined to look at. It prints fine, but it is very annoying, and bad to look at. It's like the colour just doesn't stay, lines and bits of colour vanish every time this happens. Has anyone had this problem before? I've never seen this. But Excel and other windows programs use the printer driver to know how to display stuff. You may want to try a different printer (or printer driver) to see what happens. Maybe even...

Scrolling Problem in EXCEL Visual Basic
I recently upgraded to XP, EXCEL is 2000. The scrollwheel doesn't do anything for an object (userforms, modules) in VB. It scrolls in all other windows in VB (Properties, Projects and Object Browsers). Don ...

having problems using performanceCouter
hi, i've made a program that shows the CPU idle time using the performance counter, using Visual C# . however, from some reason, it works on any computer other than my home PC . i've searched on the net but couldn't find what causes it. what i get is an exception that if is not caught, closes the program. here's a picture of what i get while debugging: http://img294.yfrog.com/i/picture20091211182403.png/ what i think is that maybe some service of windows (that the performance counter needs) doesn't work well(or is just disabled) . my computer runs on Windo...

Dbl sided printing problem
I am making a "Program" for a Barbershop Chorus concert using MS Publisher in the "Catalog" mode (which prints both sides of course.) I cannot seem to find out what kind of paper I can get (short of photo imaging paper) that is opaque enuff to prevent the backside of a page from showing through the "white areas" of the front side. It's not a bleed-through, it's just that the paper is to darn translucent. I am using 24 lb inkjet paper with an inkjet printer. I am sure this is anything but a new problem, but I have not found anything in the Goog...

Outlook 2007 Clients can't connect
I posted a similar question yesterday to the guys over at microsoft.public.exchange.setup as well, to maybe attack this issue from an Exchange server perspective. Maybe the folks over here can offer some insight, as this may be a client issue. I have a new Exchange 2007 server. New Outlook 2003 clients can connect just fine. Outlook 2007 clients tested on both XP and Vista, fail. The error I'm seeing is: "Outlook cannot log on. Verify you are connected to the network and you are using the proper server and mailbox name. The connection to Microsoft Exchange is unavailable. Outlo...

How does clickonce find the local application?
Hi, The shortcut file created by clickonce deployment having an extension .appref-ms only has a link that looks like: http://127.0.0.1/ClickOnceDemo/ClickOnceDemo.application#ClickOnceDemo.application, Culture=neutral, PublicKeyToken=27d66f1bda5f165d, processorArchitecture=msil The file http://127.0.0.1/ClickOnceDemo/ClickOnceDemo.application has the name and version number of the executable assembly. When ClickOnce application is invoked, the framework compares the version of the locally installed app against the version in the deployment manifest. My question is, how does th...

Junk E-mail Problem
Hi All, Our company using Small Business Server 2003, all the user use outlook 2003. We connect email through Exchange Server. We had a big problem, my boss email usually go to junk mail at Exchange Server mail box. But not every email. We had added him to safe sender list but the problem still exist. I had checked the server but I can't find the definition of filter email. My boss is using Powerbook Macintosh and Microsoft Entourage 2004 to send email. His company email is always forward to his ISP email and he receive email from ISP pop3 account. He use ISP smtp account to send emai...

Publisher 2000 print problem
What we see in the working document and what goes to print is different. Is there a way to enter the print preveiw document to fix it at that point. There seems to be no way to resolve this issue??? Please help if you can. ...

Known, but still unsolved problem
I have a well known problem concerning Outlook (it seems that it affects many versions, my version is Outlook 2000 SR-1 in WinXP Pro): the program doesn't end when closed and the window remains open. I've found many suggestions in the newsgroups, such as to remove addons, if present, or to check the integrity of the pst file, but none has been successful. Can someone help me? Thanks. Giovanni GRL <giovrell@tin.it> wrote: > I have a well known problem concerning Outlook (it seems that it > affects many versions, my version is Outlook 2000 SR-1 in WinXP Pro): > the pro...

Exchange contact sync problems.
I have a problem with contact synconizations under Ex2003. We bought a (3rd party) modul for sync'ing contact between Axapta and Exchange. Only problem is, the address data is synced wrong and the company that sold us the modul, claims that the problem lies in our Exchange installation sins the module runs fine on other installations they've done. Fx: converting from Ax to Ex Zipcode is converted into the "provins" field cityname is converted into both city and zipcode field The other way zip -> cityname cityname just disapear The Ex2003 installation is a migration off...

Problem with resources on W98
My application, which seems to work without problem on XP, has a problem on W98 with resource : when working on W98 french version after a while the application display a dialog box with the french message "Une ressource requise était non"(in english "A required resource was not") After that message the application seems to lack resources to work correctly. What should I check on my code ? -- Joel Windows 98 does not manage system resources as well as XP, so if you create a bitmap for example, but do not free it, Windows 98 will eventually break. 2000/XP handle syst...