RNDIS, WLK 1.5, crash

Moin,

I test a RNDIS device which is connected via USB to the host.
During power management tests the RNDIS driver part usb8023x.sys holds the 
IRP too long and the driver verifier complains about it with 
DRIVER_POWER_STATE_FAILURE (9f)
A driver is causing an inconsistent power state.

The tests fail on XP x86 SP 3 and Vista x86 SP2.
Does MS provide a fixed driver ? 

Best regards,
Stefan

P.S.: The first analysis with WInDbg shows

*******************************************************************************
*                                                                            
 *
*                        Bugcheck Analysis                                   
 *
*                                                                            
 *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver is causing an inconsistent power state.
Arguments:
Arg1: 00000003, A device object has been blocking an Irp for too long a time
Arg2: 88ff0030, Physical Device Object of the stack
Arg3: 89022030, Functional Device Object of the stack
Arg4: 9dac0e90, The blocked IRP

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE:  3

IRP_ADDRESS:  9dac0e90

DEVICE_OBJECT: 89022030

DRIVER_OBJECT: 8b0bd7c8

IMAGE_NAME:  usb8023x.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  49e02090

MODULE_NAME: usb8023x

FAULTING_MODULE: 8bac6000 usb8023x

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

LAST_CONTROL_TRANSFER:  from 818353ab to 818d1b0d

STACK_TEXT:  
818f9acc 818353ab 0000009f 00000003 88ff0030 nt!KeBugCheckEx+0x1e
818f9b28 81834fc8 818f9b94 818f9c50 807b9a01 nt!PopCheckIrpWatchdog+0x1ad
818f9b68 818ae2eb 819124e0 00000000 53a2e280 nt!PopCheckForIdleness+0x343
818f9c88 818adeab 818f9cd0 890bba02 818f9cd8 nt!KiTimerListExpire+0x367
818f9ce8 818ae615 00000000 00000000 0000d232 nt!KiTimerExpiration+0x22a
818f9d50 818ac87d 00000000 0000000e 00000000 nt!KiRetireDpcList+0xba
818f9d54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x49


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  0x9F_VRF_IMAGE_usb8023x.sys

BUCKET_ID:  0x9F_VRF_IMAGE_usb8023x.sys







0
Utf
6/12/2010 3:35:32 PM
development.device.drivers 941 articles. 0 followers. Follow

0 Replies
841 Views

Similar Articles

[PageSpeed] 19

Reply:

Similar Artilces:

Outlook XP Cannot Access Exchange 5.5
Hi all, We are currently migrating our outlook clients from 2000 to XP. But with some users (1 out of 10) cannot access there mailbox, on our exchange 5.5 SP server, with Outlook XP. They get a dialog asking them for there username and password. When you type in nothing happens no error, you just have retype the password. If they use Outlook 2000 they can there mailbox just fine. I have found MS KB 297781 "You Repeatedly Receive a Prompt for Credentials When You Log On to the E-mail Server" But this seems to be only if access with a pop3 account. Is this a know problem?...

Can't connect to 5.5 during forestprep
While running forestprep in my root domain (Exchange 5.5 resides in another trusted domain), I received this message: "Setup encountered an error while attempting to bind to the Exchange server "servernamehere": 0XC103FC93(64659): Could not bind to the Microsoft Exchange Directory server servernamehere. The Microsoft Exchange Server computer does not respond." Any ideas? Many thanks, Mark Here's an update - now I've gotten a little farther. It's telling me that I don't have permissions required to complete the operation. The plot thickens... I hav...

Exchange 5.5 Relay
I posted this earlier this week, but have done some research and can clarify my question. I found that my IMC queue is full of outgoing messages that appear to be spam (including the famous Paypal phishing scam). It seems obvious that my exchange 5.5 is being used as a relay. The reading I have done has left me questioning what would be the BEST way to stop this from happening, since there is a lot of advice on this issue. This exchange server is 5 yrs old, slow, and low on disk space (just above 1gb left. So this is constantly filling up my log files. Can anyone give me advice o...

Auto fill keeps adding 1 digit or 1 cell
When I try to drag a formula or value down or across the spreadsheet in Excel 2002 (Win XP Professional)it automatically adds 1 didgit to the value or references the cell next door to calculate the formula. How can I make the drag and autofill more accurate? Hi Try draggin with the right mouse button. When you get to the end of your range you get a list of fill options. -- Andy. "Ricardo" <anonymous@discussions.microsoft.com> wrote in message news:2b0bc01c46826$09b920f0$a501280a@phx.gbl... > When I try to drag a formula or value down or across the > spreadsheet...

I have 5,00 images that need renamed to part numbers
I have 5,000 images I have to change to current name to a part # found on an excel spreadsheet. How do I change the actual name (not one at a time) but globally with these part #'s? On 2/1/10 4:01 PM, Elizabeth wrote: > I have 5,000 images I have to change to current name to a part # found on an > excel spreadsheet. How do I change the actual name (not one at a time) but > globally with these part #'s? This seems like something that you could do with VBA as long as there is a way to identify the new name from the old name (is the old name listed in the Excel ...

Merged Cells #5
Is there some way to find which cells are merged without having to look at each cell? Sometimes I want to move or delete cells and it says" cannot move part of merged cell" or something like that, but it does not show me which cell is merged. Hi Terry, I am not aware of any inbuilt method for displaying merged cells. One possibility would be to use a macro like the following which will select (and therefore temporarily highlight) merged cells. As written, the macro will select all merged cells in the selected range. If the selection comprises a single cell, all merged cell...

Computer crashed suring revent update
My computer froze during the restart process of a recent update (KB971512) forcing me to manually restart it and now loads very slowly. It runs fine except for whenever it need to load (example: Left 4 Dead 2 take about 10 minutes to load a level, but then runs fine besides the occasional sputter when it loads during play). Other things: whenever I start Windows, it comes up with "Windows update: Configuring 3/3 0%" but then moves onto the login screen. I also tried running Windows update again (I thought maybe it would catch it's own error or something) but I get err...

Multiple companies / 1 report dictionary / 3 different check stubs
We currently use a modified "Direct Deposit Statement of Earnings" and Employee Checks Stub on Top and Bottom - L" reports to print paychecks/direct deposit statements. We need 3 versions of this modified report because we have three different companies and the checks require 3 different signatures. Other than the different signatures, the report layouts are identical. We use one reports dictionary for all three companies. How best to achieve this? Best regards, Caroline This is what I would try. You have one format for a check and you can export it out from tool...

Scripting mass folder creation within Exchange 5.5 mailbox
Hi all, I am wondering if anyone has heard of a way to script the creation of a folder within every user's mailbox on Exchange server 5.5? I am trying to put filtered SPAM into a "Junk" folder within a users mailbox and then set a rule to delete all content with 30 days if unread. Of course there can be no user interaction for the process, and I'd like to do it from the server side. All ideas are welcome, except calling MS, already did. Thanks in advance, John Just an FYI that if you "ever" go to Exchange 2003/Outlook 2003 a "Junk E-mail" folder is...

5.1.1 NDRs for newer users
I have a problem that I have been unable to resolve with my newer users. Users created roughly since the first of the year are having difficulty receiving e-mails. Intermittently (and more frequently with some users than others), senders receive back a 5.1.1 Non-Delivery Report (The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address). After extensive tweaking, reconfiguring, etc., I am left with the following error messages that I have been unable to resolve and that I...

IMAPS on Exchange 5.5
Hello NG, does the Exchange 5.5 understand the handling of secure IMAP? Or do i have to upgrade the server for that? Thanx for any help. It supports IMAP over SSL. See article 175439 for more information. -- This posting is provided "AS IS" with no warranties, and confers no rights. Please do not send email to this address, post a reply to this newsgroup. "Testament" <Testament@discussions.microsoft.com> wrote in message news:D526D56E-6AC1-40C5-8452-6FDBC218AA06@microsoft.com... > Hello NG, > > does the Exchange 5.5 understand the handling of secure IM...

Issue with Insert Safari URL's v1.0.1 or My Web Page
This message is for Barry Wainwright: I have sent you two email and I suspect my ISP (att.yahoo) trashed them due to your personal domain name for email. Please send me a message to arkay at qsl.net and I will try to reply with the message that ATT trashed. ===== I have been using your Insert Safari URLs v1.0.1 with Entourage 2008 12.2.3 under OSX 10.6.2 for some time and works great until I quote my personal web page. I may have an html error in my web page header and would appreciate your comments. The format that looks correct when it goes out via Entourage but is hos...

Two mailbox stores on same Raid 5 set
I have a slight problem, I need to set email quotas on two different types of users. Is my best bet to create two mailbox stores, and if so will it be ok to use the same RAID 5 drive set for both? I don't have enough drives to be able to put them on seperate ones. I do have my transaction logs stored on a different set of disks however. I only have about 600 users. Also, if this isn't possible, is there a command line utility to change users' exchange properties in active directory? Thanks! Yes it is ok to have both MB stores on the same RAID 5 set, it is MOST import...

Outlook 2K Crashes When Forwarding an HTML Message
Specs: Win 98 SE Outlook 2K Dell Dimension PIII 192.0 MB RAM 20 GB HD ===================== If I try to FORWARD an HTML-formatted message that I received, Outlook will crash with the following message: "OUTLOOK caused an invalid page fault in module MSO9.DLL at 017f:308c60bb." Basically, I hit FWD, and the first key I press in the body of the message causes this error box to appear. It happens EVERY time I FWD a message, and many times (but not all) when I reply to an HTML message. Any ideas on what is causing this? TIA for any help you can give me... Jonny ...

OWA attachments crashing Information Store
We're running Windows Server 2003 and Exchange 2003 (both are fully patched and up to date). Whenever a user attaches a file using OWA, the Information Store crashes and the following event is logged in Exchange: ---------------------------------------- Application eventlog: Event Type: Error Event Source: MSExchangeIS Event Category: General Event ID: 9673 Description: An exception with code 0xc00000fd was thrown in module C:\WINDOWS\system32\ntdll.dll; some parameters and their values were <Exception address - 57fffffd>. A significant section of the call stack is in the data...

Importing customizations from 1.2 to 3.0???
Hi, I would expect that importing customizations from an existing MS CRM deployment (1.2) to a CRM 3.0 environment should be no issue. MS has used the seemless upgrade and metabase usage as their no.1 selling agrument. When the language codes are alike, is this possible? In other words, when upgrading to 3.0, the customizations from 1.2 (all through the standard config. tools..) should just be taken over, or not??? Thanks CRM Demo Hi, You can upgrade your system very easily if you have made no unsupported customizations. Just follow this document: http://www.microsoft.com/downloads/det...

upgrade to 2.0.0114 from 1.31010
Hi group, I plan to peform this upgrade in 10 days from now... just before the Holidays shopping season! HQ with 7 stores Any general words of advice, suggestions of steps to be taken that is not found in the published MS documentation. Thanks Frederic Hurlet Did it for 5 stores a few weeks ago and it is all pretty straightforward Only thing I will say to make sure is that if you have purchased any add-ons for RMS make sure you find out if you need to upgrade those too, most of them have to be "Frederic Hurlet" wrote: > Hi group, > > I plan to peform this upgrade...

Coverting from 3 letters to 1
I currently have a program that can convert codes from 1 letter to 3 an a number that is involved with the letters. This is the macro. MODULE Option Explicit Function myConversion(rng As Range) As String Dim res As Variant Dim LookUpTable As Range Dim iCtr As Long Dim myStr As String Set rng = rng(1) Set LookUpTable = Worksheets("sheet2").Range("a:b") myStr = "" For iCtr = 1 To Len(rng.Value) res = Application.VLookup(Mid(rng.Value, iCtr, 1), _ LookUpTable, 2, False) If IsError(res) Then myStr = myStr & "-?" Else myStr = myStr & "-&qu...

Strange Crash when trying to post a blog comment
This happens on Dev and Live...no idea why... I saw another post with a similar error on the asp.net forums with no answers, however it was identical except for the Telerik part of the stack Server Error in '/' Application. Value cannot be null. Parameter name: key Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.ArgumentNullException: Value cannot be null. Parameter name: key Source Error: ...

StartDoc() returns -1
Below is a section of code that I am using, it always works the first time but on the second call StartDoc always returns -1. I can't even find out the particular error. What is going wrong? //////////////////////////////////////////////// dcp.Attach(theApp.printerDC()); DOCINFO doc; // Doc info. // memset(&doc, 0, sizeof(doc)); doc.cbSize = sizeof (doc); doc.lpszDocName = "Doc"; doc.fwType=0; doc.lpszDatatype=0; doc.lpszOutput=0; int q=dcp.StartDoc(&doc); if (q<0) { return; } "Chris Baker" <ChrisBaker@discussions.microsoft.com> wrote in messag...

Out of Office Assistant and Exchange 5.5
I have an Exchange 5.5 SP4 server with approx 40 Outlook 2000 clients. With some clients the Out of Office Assistant works perfectly and with some even though it turns on, the text portion is not saved and no auto reply is sent for incoming mail. This is the same for both internal and external mail. As far as I can tell there is no difference between the mailbox accounts not the outlook settings. Anyone got any ideas???? ...

exchange version 6.5 build 7226.6: service pack 1 delivers blank m
hi, we use exchange 2003 sp1(version 6.5 build 7226.6: service pack 1) and we have the following problem: - when some of our PDA users sends an e-mail - some of the exchange recipients that receive the e-mail as part of a group - can see no body for the e-mail - it is just blank; on the client side users user outlook 2003. Those are the headers of the two e-mails: Header of the e-mail taken from recipients mailbox - there is no e-mail body - empty/blank: ==================== Microsoft Mail Internet Headers Version 2.0 MIME-Version: 1.0 Content-Type: application/ms-tnef; name="win...

Exchange Server 5.5 Restored from tape gives an error 3355443752 and will not start the services
I have an NT4 server that I use for restoring Exchanger Server 5.5 by using NT Backup to backup and restore. I successfully used it to restore the information store so I could retreive some deleted messages. I found that I needed to do a restore from the previous day and ran a restore from that tape. I am now getting an error 3355443752 when I try to restart the Information Store Service. I looked at Microsoft's KB and they said that I should get this if I ran "isinteg -patch" or "eseutil /r/is" before restarting the Information Store Service, but I did not run eith...

5.5 migration to 2k3
Hello All, Do I need to setup the 2k3 server to get all incoming/outgoing internet emails or it will automatically configure it self after the migration? or after I remove the exch 5.5 from the network? I was reading the white papers from microsoft but no details regarding this matter. Any advice, Thank you I will be joining the 2k3 to the 5.5 org, then remove the 5.5 server after I move all the mailboxes and public folders.. Do I still need to run the internet wizard after that? Thanks! "Chad P." <ChadP@discussions.microsoft.com> wrote in message news:F9417D8D-D86A-...

%s in XL entered as ".5" OR "50" reads as 50% if format is %age.
I have a spreadsheet I work with every day and I use fractional percentages, between 0-1%. If the field is formatted as Percentage, and I type in ".5", it reads it as 50%, which it would be if it weren't a percentage. But it is. It's a half percent. By typing in "50", I also get 50%, which doesn't make sense. If I type in "5" I get 5%, if I type in ".5", I should get .5%. Is there a way to make this happen, or is this just a glitch in Excel? Please help me figure this out. Thanks. abuzzmaster@yahoo.com Try this, Buzz: http://www.office...