Upgrading to v3.0 & Utilizing a Test Server

I would like to be able to build a test environment to test upgrade a real 
copy of our production CRM db (v1.2) and test the upgrade to v3. 

I know the best way to build a test copy is a clean install of 1.2 and 
migrate data and import our current schema. But that does not give me my 
actual db in test, all it gives me is data and schema.

I want to be able to have a test db the mirrors production with all the 
store procedures and triggers we have or may have in place. That way I know 
really what will happen when I upgrade.

Is there a way to do this? I have a second domain that I can use with AD 
(not the exact same AD as production).

Thoughts or suggestions are welcome.

THX, James G.


0
Utf
6/8/2006 1:27:02 PM
crm 35858 articles. 1 followers. Follow

2 Replies
430 Views

Similar Articles

[PageSpeed] 0

you can use the 1.2 redeployment tools.  this will allow you to bring over 
your crm 1.2 data and upgrade it to 3.0 as a test.

"James" wrote:

> I would like to be able to build a test environment to test upgrade a real 
> copy of our production CRM db (v1.2) and test the upgrade to v3. 
> 
> I know the best way to build a test copy is a clean install of 1.2 and 
> migrate data and import our current schema. But that does not give me my 
> actual db in test, all it gives me is data and schema.
> 
> I want to be able to have a test db the mirrors production with all the 
> store procedures and triggers we have or may have in place. That way I know 
> really what will happen when I upgrade.
> 
> Is there a way to do this? I have a second domain that I can use with AD 
> (not the exact same AD as production).
> 
> Thoughts or suggestions are welcome.
> 
> THX, James G.
> 
> 
0
Utf
6/8/2006 1:30:02 PM
In addition, after redeploying, you cold manually bring over the DB objects 
that you think might cause aproblem. but, unless you have made changes 
directly to the DB, the Redploy should create a similar setup.

-- 

Matt Parks
MVP - Microsoft CRM


"chad.buser@ncsi.cc" <chadbuserncsicc@discussions.microsoft.com> wrote in 
message news:5DB41077-49D5-4D5E-8865-44FD38F1850A@microsoft.com...
you can use the 1.2 redeployment tools.  this will allow you to bring over
your crm 1.2 data and upgrade it to 3.0 as a test.

"James" wrote:

> I would like to be able to build a test environment to test upgrade a real
> copy of our production CRM db (v1.2) and test the upgrade to v3.
>
> I know the best way to build a test copy is a clean install of 1.2 and
> migrate data and import our current schema. But that does not give me my
> actual db in test, all it gives me is data and schema.
>
> I want to be able to have a test db the mirrors production with all the
> store procedures and triggers we have or may have in place. That way I 
> know
> really what will happen when I upgrade.
>
> Is there a way to do this? I have a second domain that I can use with AD
> (not the exact same AD as production).
>
> Thoughts or suggestions are welcome.
>
> THX, James G.
>
> 


0
Matt
6/8/2006 4:42:45 PM
Reply:

Similar Artilces:

WinDBPro. Ver 2.0
WinDBPro. Ver 2.0 Complete DB one exe file only 12 billion Record Capacity Search / Sort / Find Built in Table 9 Catagories http://binaural.info/dbexe/dbexe.htm ...

trouble connecting to Exchange 2003 using Outlook 97 Exchange Server Service
hello, this is my setup I have one Active Directory domain containing two AD Sites, configured through AD Sites and Services, Site one is the local LAN on the 192.168.x.x subnet, Site two is a remote site in a datacentre on the public-facing 87.127.x.x subnet - the two sites are connecting via VPN on Sonicwall firewalls the VPN connection is solid - and commuications from Site one to Site two is fine, and vice versa netdiag and dcdiag from both sides report no problems My Exchange Server is in Site two, along with a DC/GC and appears to be working fine (still in testing phase), OWA works...

Switch To... while calling COM Server
Hi, everybody I'm calling some third party COM Server function from my MFC application. This functions brings up some third party dialog. During this dialog display after 5-6 seconds the dialog "Switch To... The action cannot be completed....Server is busy.." appears. After I close this third party dialog, I have to click "Switch To..." and the rest is fine. Is it possible to figure which other processes are trying to reach this COM Server? How to avoid the appearance of this "Switch To..." dialog? Thank you, Alex see How to prevent the OLE Server Busy ...

incorporate the remove #DIV/0! code into another formula to get bl
hi there, i have this formula below, and i somehow want to incorporate this =IFERROR(B1/C1,"") into it with the purpose of having the cell display nothing instead of #DIV/0! so that the column of data can then allow an index and match formula to work as it won't if any of the cells have #DIV/0! in them, any suggestion? =(SUMIF($B$2:$B$2500,">=" & T58,$M$2:$M$2500)-SUMIF($B$2:$B$2500,">=" & (T58+TIMEVALUE("1:00")),$M$2:$M$2500))/(SUMIF($B$2:$B$2500,">=" & T58,$D$2:$D$2500)-SUMIF($B$2:$B$2500,">=" & ...

Upgrade companies not showing
Im installing a GP9 instance , I restoe my 7.5 Databses to this instance , I then run gp9 Utilities. This checks and tells me dynamics is ok, it then checks for companies but doesnt find any of the companies I have restored to GP9? Any ideas or help welcome Have you restored all of the databases including hte DYNAMICS database? Be sure to change the ownership of the databases to DYNSA after you have restored them. David "clemyp" wrote: > Im installing a GP9 instance , I restoe my 7.5 Databses to this instance , I > then run gp9 Utilities. > > This checks and t...

Slow outlook after new server
Hi I have recently replaced a very slow sbs server with a super dooper dell sbs server. I exported the outlook stuff into pst files before disconnecting the old server and then imported the pst files back into outlook after connecting the new server. The problem is clients are complaining of slow outlook response specially on one particular pc. What is the problem and how can I fix it? Thanks Regards That depends on the definition of 'slow response'. If you want faster delivery of email internally (like, if 30 seconds is too slow), then turn off cached mode in Outlook. If...

upgrading from Money 2003 to 2004
I presently use Money 2003 Deluxe for business. Has anyone figured out which 2004 is the equivalent? Has anyone upgraded from one to the other? Help! Thanks I would also like to know about the new 2004 for business. What happens to personal account in Money 2003? What about online Check writing, will my existing account be carried over. Why is the documentation of this new product, Money 2004 for business, on Microsoft Web Site so poor? "Andrew" <asjg@adauro.com> wrote in message news:020601c35e7c$fa0d30f0$a001280a@phx.gbl... > I presently use Money 2003 Deluxe for...

"An Unknown Error Has Occurred. Retry the Action"
Experiencing some issues with CRM running over a two way external trust. I have installed it this way to learn these issues. Assuming that since the NT trust to a CRM active domain controller is one route, that this must be able to be setup to be possible. I also had to install Exchange and Exchange Router on the CRM domain even though I have Exchange on the non-CRM one. I was told this was necessary, anybody got it to work without needing to do this I wonder. My current issue however I am having is that the SFO client, although RUNNING and installed on a number of machines, produces the fol...

How to set locks to 0
HI Under SQLServer2005 Advanced Properties - Parallelism, I need to set Locks to zero (0) because I suspect that 5000 locks that it shows actualy, have triggered the following error: "the instance of the sql Server Database Engine cannot obtain a LOKC resource at this time. Rerun your statement when there are fewer users...." I appreciate all your wise suggestions. LAM LAM (luism0@(arroba)yahoo.es) writes: > Under SQLServer2005 Advanced Properties - Parallelism, I need to set > Locks to zero (0) because I suspect that 5000 locks that it shows > a...

MS Connector vs. Outlook 2003: 1
I've just tried to get access (again....) to my Hotmail account via Outlook 2003 by installing MS Office Outlook Connector 12.1. That did not work (Server status never gets beyond the stage of showing "Connecting...."). What is more of a real concern is that post-installation of The Connector I've lost contact with two other web-based mail accounts which I used to administer via Outlook 2003. I am also unable to gain access to the various email accounts (both from within Outlook as well as trying to go via the Control Panel). The problems persist even after un...

What is NNTP Server Name?
I'm trying to setup my Outlook Express to view this forum. What do I input for Internet News Server Name? -- Cheers, Ryan Fed up with WebNews ? msnews.microsoft.com Regards, Peter T "Ryan H" <RyanH@discussions.microsoft.com> wrote in message news:F99AFC37-979A-4234-8217-F8996A5EFF0C@microsoft.com... > I'm trying to setup my Outlook Express to view this forum. What do I > input > for Internet News Server Name? > -- > Cheers, > Ryan Ryan, I don't believe it works like that. To use Outlook Express your ISP mus...

Images Tweeked After Upgrade...
I recently upgraded to Publisher 2003... I noticed that some of the images in previous publisher 2000 files gett "toned down" when loaded into publisher 2003. What were once clean strong lines become a bunch of twisted 75 dpi scattered pixels when printed. I can't figure out what is going on... Is Office 2003 have some kind of graphic manager that is modifing the image when saved? Is Publisher causing the issue? I have printed the same file out hundreds of times on an older installation and compared it against the new - I AM GOING NUTS trying to figure this one out. A...

There is no such object on the server #2
Hi, When i try to go to the properties of my databases in one of my storage groups, I get the error "There is no such object on the server" C0072030 The databases are mounted and I can move mailboxes to them Also, if I click 'ok' on the error message, it brings up the properities sheet for the database, but the public folder store path on the general tab has the pf store name and a guid following it. I have checked permissions to the objects. Does anyone have any suggestions? Any help would be greatly appreciated. Have you tried using ADSIEdit to look at the attr...

Can i post a Q related to CRM 3.0 here?
Can i post a Q related to CRM 3.0 here? Hi Chong! Chong wrote: > Can i post a Q related to CRM 3.0 here? Until the public v3 beta, please refer questions to the private beta newsgroup. Cheers Arne Janning ...

4.0 Data Migration Wizard on SBE?
I've installed the Wizard but in the 1st step (Signing in/gathering config info), I get an ASP.net exception error. Searches for the error code (which I've lost somewhere) tell me to register the dll in the GAC but that doesnt seem to work. Has anyone run the wizard on SBE successfully? -- Thanx Grizz ...

New Exchange Server
We are trying to get a new Exchange Server up and running in our company. Everything is working fine, EXCEPT CRM. When we unplug the old Exchange box, CRM email (at least outgoing, probably incoming too) stops working. We have installed the CRM Email Router on the new Exchange box. However, when we installed it, the old box was still up and running. We are receiving SOAP error messages on the new box, even when the old one is turned on. Any ideas? Thanks in advance. Did you uninstall the router from the old Exchange server? The router config adds an entry in the registry on the CRM ser...

FAILED TO INSTALL MSI PART OF MISCROSOFT CRM SERVER SETUP UNSPECIFIED ERROR 800
While installing Miscrosoft CRM - installation fails with a reson FAILED TO INSTALL MSI PART OF MISCROSOFT CRM SERVER SETUP UNSPECIFIED ERROR 80004005 When i checked the event log these are the errors that i found. 1) APS Service starts and stops so none of the crystal report services like cristal_eventServer can regester with it. 2) Root server reported an error initilization failure reasion unable to connect to database using provided connection string ...... CRMCRYSTAL login Failed. source = crystal_crystalAPS any idea about this error any one Install iis before installin...

Time keeping systems and Project Server 2007
Can anyone suggest the best way to import actual hours from a existing time keeping system? This is my first Project Server deployment, and it has been smooth so far. I would greatly appreciate advice and/or experience in this area. Thanks, and happy new year D.L. Pruett Submitted via EggHeadCafe - Software Developer Portal of Choice ASP.NET Production Exception Logging for Dummies http://www.eggheadcafe.com/tutorials/aspnet/9bd9164a-8af4-4951-9f1b-e188b80f5c7c/aspnet-production-except.aspx It all depends upon if you want to kept timephased days/hours without any changes or...

Tracked mail in CRM 4.0.
I am working in CRM 4.0 with Outlook 2007. When i track an email in CRM this is directly in a closed state. I want to change tis behaviour so that the tracked mail is automaticaly in a draft state. Is there a poosibilty to change this? I do not want any work arrounds with workflows or follow up functions. When the mail is in a closed state there is no way that i can adjust the duration and due fields. In a draft state i can adjust these fields and this is what i want to achieve. ...

Failed to import sample data to CRM 3.0 beta
Hello, I've same big problems while trying to import the sample database with the wizard. Importing the users ist ok but the, the following error occurs (lots of them): Sample Data Wizard started at 14.11.2005 15:19:59 Refresh with new data set started at - 14.11.2005 15:21:57 fetch organization - 14.11.2005 15:22:35 Created Business Units and Users. - 14.11.2005 15:23:59 Imported workflows. - 14.11.2005 15:25:20 Created Emails - 14.11.2005 15:25:20 Created Subjects. - 14.11.2005 15:25:21 Created Territories. - 14.11.2005 15:25:21 Created Teams. - 14.11.2005 15:...

Dont want to inlcude 0's in my chart
Here is my formula, When i creat my chart it shows all the blanks or 0 data on my chart . Is there a way to do it? Please help. Thank you. =SUM(IF(Log!$A$2:$A$129=$A26,IF(Log!$R$2:$R$129>=Data!J$1,IF(Log!$R$2:$R$129<=Data!J$2,1,0),0),0)) Change the zeros in the formula to NA(). - Jon ------- Jon Peltier, Microsoft Excel MVP Tutorials and Custom Solutions Peltier Technical Services, Inc. - http://PeltierTech.com _______ "mmb" <mmb@discussions.microsoft.com> wrote in message news:7686C3F7-A1E5-4779-BF9F-F90E7570FEF4@microsoft.com... > Here is my formula, When ...

Slow connecting to server
Don't know what I have done but it seems for ever to check my emails now, before I click send/receive and in a flash the box would start downloading now I have to wait about 30sec, Any Idea Thanks in advance.........Bob Vance Bob <xxx@xx.xx> wrote: > Don't know what I have done but it seems for ever to check my emails > now, before I click send/receive and in a flash the box would start > downloading now I have to wait about 30sec, Any Idea Someone might have an idea if you had supplied any information with which to diagnose the problem, like Outlook version...

SBS std. and SQL on another server ??
I have a customer who has a SBS 2003 std. server and an seperate SQL server. Is it possible to install CRM on the SBS server and use the seperate SQL server ? Very important and urgent, please help as we are about to sell it today ! Jack One word answer - NO Small Bus Edition of CRM stipulates that SQL, Exch, AD MUST all be on the same machine as CRM - the SBS. New version of SBS out later this year will allow separate SQL and Exchange servers on different boxes. Jane "Jack" wrote: > I have a customer who has a SBS 2003 std. server and an seperate SQL server. > >...

Exchange server not using more than 1 GB of Ram
HELP! Server: Exchange 2003 Enterprise (pre SP1) Windows 2003 Enterprise Server Dell 2650 > 4GBs Ram > 2x2.8GHz procs > Hyperthreaded to 4 > Hardware Raid > 5 72 GB hard drives:2-mirror(boot,system,logs),3-Raid5 (stores) Here is my boot.ini file (pardon the word wrapping): [boot loader] timeout=30 default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /3GB /USERVA=3030 This box has plenty of RAM and Exchange will not take more than 1 GB. After ...

cannot upgrade from 2004 to 2006
I donwloaded the 2006 version of money to test it before the full upgrade, and it will not open my file from money Satndard 2004. The error says that its because I'm upgrading from an older version... that's the whole point isn't it? anyway any comments to make it work, because the 2006 seems very appealing although not enough to re-load all my data. Are you upgrading from a US version to a US version? You cannot upgrade from French to US or vice versa for example. -- Regards Bob Peel, Microsoft MVP - Money For UK tips & fixes see http://support.microsoft.com/default....