upgrade CRM 3.0 on SQL 2000 to CRM 4.0 on SQL 2008 (error)

I am trying to upgrade CRM 3.0 on SQL 2000 to CRM 4.0 on SQL 2008 and getting 
this error. (I know CRM 3.0 doesnt support SQL 2008, so a '1' step upgrade 
might have its risks).

 "Action Microsoft.CRM.Setup.Server.GrantConfigDBDatabaseAccessAction 
failed. The DEFAULT_SCHEMA clause cannot be used with a windows group or with 
principals mapped to certificates or asymmetric keys".


I'm trying this in a virtual environment first.

Any comments on this?

Thanx

Glen
0
3/10/2009 3:37:01 PM
crm 35858 articles. 1 followers. Follow

1 Replies
573 Views

Similar Articles

[PageSpeed] 2

Hi Glen,

Upgrade CRM 3.0 to SQL Server 2005 Evaluation .
then upgrade to CRM 4.0 on SQL Server 2005.
Take backup of CRM Databases.
Then install SQL Server 2008 fresh and restore CRM databases.

See if this works?



Regards,
Daniel.

"Glen at Wolfbridge" wrote:

> I am trying to upgrade CRM 3.0 on SQL 2000 to CRM 4.0 on SQL 2008 and getting 
> this error. (I know CRM 3.0 doesnt support SQL 2008, so a '1' step upgrade 
> might have its risks).
> 
>  "Action Microsoft.CRM.Setup.Server.GrantConfigDBDatabaseAccessAction 
> failed. The DEFAULT_SCHEMA clause cannot be used with a windows group or with 
> principals mapped to certificates or asymmetric keys".
> 
> 
> I'm trying this in a virtual environment first.
> 
> Any comments on this?
> 
> Thanx
> 
> Glen
0
Daniel1 (174)
4/1/2009 12:38:01 AM
Reply:

Similar Artilces:

Windows Office 2000 installer tries to execute everytime I compose or respond to a message
In OWA, Every time I try to compose or respond to a message, the Windows Office 2000 installer tries to execute and asks for the CD. Unfortunately, this Office 2000 problem has come up again even after all the updates to Office 2000. Also I am having trouble logging out. When I hit the logoff button, it brings up a sign-in screen asking for ID & password again. Whether I cancel it or fill it in and type OK, it then gives me a screen that says "access denied". I never get a screen which says that logout was successful. I have the same problem here... From what I've s...

Crash on 'Send"
My wife's Intel Celeron running ME started having this problem sporadically - now constantly. Outlook 2000 receives OK - everything seems fine until you hit the 'Send' button then Outlook crashes giving an error message that says 'Outlook has caused an error in <unknown> and has to shut down. If the problem persists you may have to restart your computer.' Re-starting however has no effect. I have re-installed Office. Used 'Detect & Repair' under the 'Help' tab, and installed all patches/updates from the Office site. But this error continues, now...

pop3 #3
My outlook express hasnt been working since I got my new Dell computer. It says that the "POP3" isnt connected so i cant receive or send e-mail!!! HELP!! How do i fix this problem? I've tried calling Dell and Microsoft and have waited hours on the phone and have not gotten any assistance! Who is your ISP/mail host? Seems like you might want to contact them for support. I presume you can get to the Internet just fine.... rose wrote: > My outlook express hasnt been working since I got my new > Dell computer. It says that the "POP3" isnt connected so > i ca...

Copy entire row where CellValue=0
I need to loop through the collumn and search for value that is more then 0. When I find it I need to copy whole row and paste it 2-3 rows below the table. I tried to select the collumn and search the selection but for some reason I copy and paste only one row. Thank you for any help. Hi as a starting point: http://www.rondebruin.nl/copy5.htm -- Regards Frank Kabel Frankfurt, Germany "OxanaB" <OxanaB@discussions.microsoft.com> schrieb im Newsbeitrag news:8628F791-CF2D-480A-9EBF-6C31BCEF0293@microsoft.com... > I need to loop through the collumn and search for value tha...

SMTP Connectors #4
Hi, I have a problem with two Front-End servers in NLB. I have two connectors with address space *, one connector with cost 10 the other with cost 20 for connector availability purposes. Inbound mails are targeted to FrontEnd1, outbound mails should go from FrontEnd2 (e.g. MX for FrontEnd1 cost is 10; MX cost for FrontEnd2 is 20) Connectors: FrontEnd1 - Address space * - cost 10 - bridgehead srv = FrontEnd1; FrontEnd2 - Address space * - cost 20 - bridgehead srv = FrontEnd2 The problem: If both servers are up and running and somehow some mail ends in queue on FrontEnd2 it correctly crea...

SQL deadlock problem
I am currently having a big issue with sql deadlocking on the PrincipalObjectAccess table. The last few months I have been working on a synchronization process using a Biztalk orchestration. The sync uses the crm webservices to create and update account and contact records in CRM. But now deployment to the production environment gives me some problems. It seems that when trying to update account records (which is one of the first actions in the sync process) the webservice gives me Generic SQL errors and SQL timeouts. After extensive profiling and tracing in SQL I found that there are...

Standalone install of Office 98 Upgrade?
I'm in the process of getting an old Mac up and running on OS 9 for my teenager. I want to install Office 98, but my version, in the box, is Upgrade. I can't find any earlier Office software around here. Does anybody know if I can install the Upgrade version as a standalone, or must I find an earlier version somewhere? Thanks. On 9/13/05 2:11 PM, in article 1126645896.323979.65210@z14g2000cwz.googlegroups.com, "violetcrumble" <sh@centurytel.net> wrote: > I'm in the process of getting an old Mac up and running on OS 9 for my > teenager. I want to install Off...

Error: Invalid byte was found at byte index 63.
Does anyone know what this means: "Invalid byte was found at byte index 63. " If yes, please help. Apogee Apogee wrote: > Does anyone know what this means: > > "Invalid byte was found at byte index 63. " That means exactly what it says: At index 63 XML parser found a byte, which is invalid either according document's encoding or is forbidden in XML documents at all (see list of allowed in XML characters at http://www.w3.org/TR/2000/REC-xml-20001006#charsets) -- Oleg Tkachenko http://www.tkachenko.com/blog Multiconn Technologies, Israel ...

How to keep format when importing Excel into SQL.
Can anybody help me please? When I import Excel file into SQL, a field that formated as 0000000000 (custom), loosing leading zeros. I tried to change data type in SQL after importing. No luck. I appretiate any help. See if using IMEX=1 helps: http://pratchev.blogspot.com/2007/10/importing-excel-data-into-sql-server.html -- Plamen Ratchev http://www.SQLStudio.com Plamen, I tried this, but got an error: "The OLE DB provider "Microsoft.Jet.OLEDB.4.0" has not been registered." Thank you very much for looking into this. "Plamen Ratchev" wr...

upgrade from mac office to pc?
Can you upgrade from Office 2004 for Mac to Office 2007 for PC for the lower upgrade price? Or do I have to basically start over and buy Office again for $250 - $300 or whatever it is, if I switch from Mac and buy a new PC? (I have Office '04 on my iMac. I'm weighing buying either a new iMac or a new Dell. The cost of buying Office again makes the inferior-but- cheaper Dell almost as expensive as a new Mac, alas.) In article <1191937383.931978.3920@y42g2000hsy.googlegroups.com>, "Charles T. Shay" <cshea2@gmail.com> wrote: > Can you upgrade from Office 2004...

XCH Error 3092, OAB replication
I am getting error 3092 for OAB in Exchnage 2003 (migrated from 5.5) "Error 1129 occurred while processing a replication event. Folder: (3-8) NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\EX:/o" Tried to delete offilne addressbook and recreate but error has not stopped. Any help will be a great help on where to look to get rid of this issue. Thanks ...

Error Generating the Offlice Address Book
I have a mixed site with 3 5.5 server and 4 2003 servers. I installed 2003 SP1 a few weeks back and since then I'm having an issue generating my Offline Address Book. Here the event log messages I'm getting. Event ID 9331: OALGen encountered error 80040107 (internal ID 501023d) accessing the public folder store while generating the offline address list for address list '/'. - Default Offline Address List For more information, click http://www.microsoft.com/contentredirect.asp. Event ID 9335: OALGen encountered error 80040107 while cleaning the offline address list public ...

printing multi page newsletters with publisher 2000
Created a new newsletter in publisher 2000, tried to print it on my Epson Photo R1800 printer which supports up to 13x19 sheet paper and 13"x***' in roll format and could not select a format to print pages 1 and 4 on one side and then 2 and 3 on the other. Downloaded an instruction sheet from Microsoft on printing "two 8.5-by11-inch pages per 11-by-17-inch sheet of paper" It says on "file" click "print", choose a printer that can print on 11x17, then click "Book Printing Option" at the bottom of the dialog box. Problem is this "Bo...

Invalid XML error when I open customization setting
I have a problem when I try to open customization setting after I import an entity. The system errored "Invalid XML" "The XML passed to the platform is not well-formed XML". Please recommend how to resolve this problem. Thanks. ...

"MS Money 2000" mit kostenlosem HBCI-Modul (HBCIFM99) kompatibel?
Hallo, Gruppe, wollte mal fragen, ob das o. g. HBCI-Modul auch mit "MS Money 2000" (also - wenn ich das richtig verstanden habe - mit der letzten deutschen Version von "MS Money" 1999/2000 aus �sterreich/der Schweiz) kompatibel ist. Vielen Dank schon im voraus f�r Eure Hilfe. Gru� Struppi Roughly translated: ------------------------- Hello, Group, I wanted to ask whether the o. g. HBCI module also with "MS Money 2000" (also - if I understood correctly that - with the last German version of "MS Money" 1999/2000 from Austria/Switzerland) is compatib...

Linker Error after upgrade from VC7.1
Hello all, After upgrading a VC7.1 project to visual studio 2005, it failed to build in the release configuration with the follwoing error : 1>nafxcw.lib(winocc.obj) : error LNK2005: "public: class CWnd * __thiscall CWnd::GetDlgItem(int)const " (?GetDlgItem@CWnd@@QBEPAV1@H@Z) already defined in InstallDlg.obj The debug build works fine. The project uses MFC in a static library. Well, after doing some research, it seems that this one is tied to the fact that in a release configuration, _AFX_ENABLE_INLINES is defined, so inline functions are embedded in the .obj file. Sure there...

Unexpected error message on closing an Excel file
Suddenly I am getting the following message when I try to close a workbook: "Your formula contains an invalid external reference to a worksheet. Verify that the path, workbook, and range name or cell reference are correct, and try again" The mysterious thing is that it does not happen consistently and that, after I click OK after the above message, I can still save the file. What might be the cause of this error message and can the "invalid reference" be tracked down using one of the utility add-ins such as J. Walkenbach's PUP? If it only happens when you close ...

error on upgrade: ID 4386
Hello, I am upgrading from DPM 2010 RC to DPM 2010 RTM, 64 bit version, on Win 2008 R2 standard. The RC is working without any issues. The upgrade scenario is supported. At the very end of the process the upgrade fails giving me the following. _____ The SQL Server installation failed because a restart was pending on this computer. Restart the computer and then start DPM Setup again. ID: 4386. Details: Unknown error (0x84be0bc2) _____ Restarting the server does not correct the issue. On the next attempt I am getting the same error message. Where to look for the pending rest...

Upgrade CRM 4.0 Professional to CRM 4.0 Enterprise
When I enter the CRM license code in the Deployment Manager to upgrade to Enterprise I get a message "The license code entered is not valid for upgrade. Make sure you have entered the license code correctly, and then try again". Do I have to reinstall CRM 4 to install Enterprise? Hi, what is your current installation? Professional? Have you entered trial version license keys ? /Aamir Current is Professional. I got the key from our MSDN subscription which didn't indicate a trial license. I was able to install the Enterprise edition on a test server using the same key w...

McAfee 8.5.0i on access scan slows down MS Dynamics CRM web client
Our organization's McAfee 8.50i slows down MS Dynamics CRM v4 - on premise web client considerabley when loading forms and data. Besides completely disabling McAfee, does anyone know how to configure McAfee (or configure CRM) to ignore CRM related form and data loads. When disabling the oncaccess scan, or when disabling the scriptcan - it improves lookups from 8-9 seconds to 4-5 seconds. However, the organizatin policy is to have these enabled. What to do? We have the same behavior, and went we reported to Microsoft says that no solution has, then we buy and install Microsoft Securi...

error 0x800cc0f
i installed windows xp, and i set up all my email accounts. they are all working , except one: i receive 0x800cc0f message, which states that the service has been interrupted, contact your ISP...., but this is not the case, since my internet conneciton is working fine all the account settings are correct I am having the same problem. I have to close outlook and reopen to retrieve all of my messages. Have you found a resolution yet? "Kerstin" wrote: > i installed windows xp, and i set up all my email > accounts. they are all working , except one: i receive > 0x800c...

Outlook freezes after sending one email after upgrading 4.0
We just upgraded from 3.0 to 4.0 this weekend. All client machines have had the desktop client upgraded and 2 have the same issue. One is XP with Outlook 2003 and the other is Vista with Outlook 2007. Open opens and the CRM addin initializes correctly. As soon as you compose and send an email, Outlook locks up and you have to kill the process in task manager to close Outlook. I've had the same problem and have tried all I can think of...how did you fix this issue? Thank you. "Sander" wrote: > We just upgraded from 3.0 to 4.0 this weekend. All client machines have...

CRM tools
Hi, I'm working with CRM, and i listening about many tools that i didn't find. Example CRMDiag and more patches that repair a lot of knowed errors and warrings. Anybody know an url to download them? thanks Hello, If you have any problems with your CRM deployment you can issue a support call to Microsoft Dynamics. They will supply you with these tools if this is needed to resolve the case. Best regards, Merijn van Mourik "makeio" wrote: > Hi, > > I'm working with CRM, and i listening about many tools that i didn't > find. Example CRMDiag and mor...

DNS Error on Exchange
I am getting the following error on my Exchange server. What is my problem? Thanks. Event Type: Warning Event Source: smtpsvc Event Category: None Event ID: 2012 Date: 1/28/2005 Time: 12:01:53 PM User: N/A Computer: PUMA Description: SMTP could not connect to the DNS server '24.220.0.11'. The protocol used was 'UDP'. It may be down or inaccessible. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: d5 04 00 00 Õ... Is that a DNS server that's configured on your Exchange box? It shoul...

outlook express 6.0 in ms 98
I cant seem to delete any of my sent mail messages in Outlook express 6.0 i am operaitng in ms 98..up to 8400 messages now. Please help ! At the risk of being obvious, click on the first item in your sent items folder while holding down the shift key. Then scroll to the bottom and click the last item. That will select them all - or you can use any range you desire. Then just click the delete icon or press the delete button. Once done, you might want to empty the deleted items folder (assuming it doesn't tell you there isn't enough room there and they'll be permanently delete...