The Settings button keeps disappearing

Hi,

I'm having a weird problem when I access CRM using the web client. When I 
access the site, I see all the buttons (Workplace, Sales, etc) except the 
Settings button. If I reboot, the button is back. My security role is system 
Admin.

Any idea what is wrong?

Thanks!
Simon 


0
Simon
2/21/2007 7:16:38 PM
crm 35858 articles. 1 followers. Follow

5 Replies
583 Views

Similar Articles

[PageSpeed] 57

Are you running the Microsoft CRM Outlook Desktop client in parallel?


Frank Lee, Microsoft CRM MVP
Workopia, Inc.
http://microsoft-crm.spaces.live.com

"Simon Renshaw" wrote:

> Hi,
> 
> I'm having a weird problem when I access CRM using the web client. When I 
> access the site, I see all the buttons (Workplace, Sales, etc) except the 
> Settings button. If I reboot, the button is back. My security role is system 
> Admin.
> 
> Any idea what is wrong?
> 
> Thanks!
> Simon 
> 
> 
> 
0
Utf
2/21/2007 11:39:00 PM
Yes I do. This is why it's happening?

I forgot to mention it in the first post, but I use IE7. I noticed that if 
the button is gone, if I clear all my private data in IE, the button is back 
after I do that.

"Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message 
news:C2533CFC-66C8-412F-8210-CB6FA09B2103@microsoft.com...
> Are you running the Microsoft CRM Outlook Desktop client in parallel?
>
>
> Frank Lee, Microsoft CRM MVP
> Workopia, Inc.
> http://microsoft-crm.spaces.live.com
>
> "Simon Renshaw" wrote:
>
>> Hi,
>>
>> I'm having a weird problem when I access CRM using the web client. When I
>> access the site, I see all the buttons (Workplace, Sales, etc) except the
>> Settings button. If I reboot, the button is back. My security role is 
>> system
>> Admin.
>>
>> Any idea what is wrong?
>>
>> Thanks!
>> Simon
>>
>>
>> 


0
Simon
2/22/2007 3:19:21 PM
Yes, running both the CRM Outlook Desktop Client and Web Client will have 
that effect.  Just run one or the other.  Running CRM Outlook Laptop Client 
and Web Client in parallel is ok.

Frank Lee, Microsoft CRM MVP
Workopia, Inc.
http://microsoft-crm.spaces.live.com

"Simon Renshaw" wrote:

> Yes I do. This is why it's happening?
> 
> I forgot to mention it in the first post, but I use IE7. I noticed that if 
> the button is gone, if I clear all my private data in IE, the button is back 
> after I do that.
> 
> "Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message 
> news:C2533CFC-66C8-412F-8210-CB6FA09B2103@microsoft.com...
> > Are you running the Microsoft CRM Outlook Desktop client in parallel?
> >
> >
> > Frank Lee, Microsoft CRM MVP
> > Workopia, Inc.
> > http://microsoft-crm.spaces.live.com
> >
> > "Simon Renshaw" wrote:
> >
> >> Hi,
> >>
> >> I'm having a weird problem when I access CRM using the web client. When I
> >> access the site, I see all the buttons (Workplace, Sales, etc) except the
> >> Settings button. If I reboot, the button is back. My security role is 
> >> system
> >> Admin.
> >>
> >> Any idea what is wrong?
> >>
> >> Thanks!
> >> Simon
> >>
> >>
> >> 
> 
> 
> 
0
Utf
2/22/2007 4:43:22 PM
Thanks, I will install the laptop client then.

"Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message 
news:B6B1A355-D3BF-48BA-9668-90A1ACAF7F62@microsoft.com...
> Yes, running both the CRM Outlook Desktop Client and Web Client will have
> that effect.  Just run one or the other.  Running CRM Outlook Laptop 
> Client
> and Web Client in parallel is ok.
>
> Frank Lee, Microsoft CRM MVP
> Workopia, Inc.
> http://microsoft-crm.spaces.live.com
>
> "Simon Renshaw" wrote:
>
>> Yes I do. This is why it's happening?
>>
>> I forgot to mention it in the first post, but I use IE7. I noticed that 
>> if
>> the button is gone, if I clear all my private data in IE, the button is 
>> back
>> after I do that.
>>
>> "Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message
>> news:C2533CFC-66C8-412F-8210-CB6FA09B2103@microsoft.com...
>> > Are you running the Microsoft CRM Outlook Desktop client in parallel?
>> >
>> >
>> > Frank Lee, Microsoft CRM MVP
>> > Workopia, Inc.
>> > http://microsoft-crm.spaces.live.com
>> >
>> > "Simon Renshaw" wrote:
>> >
>> >> Hi,
>> >>
>> >> I'm having a weird problem when I access CRM using the web client. 
>> >> When I
>> >> access the site, I see all the buttons (Workplace, Sales, etc) except 
>> >> the
>> >> Settings button. If I reboot, the button is back. My security role is
>> >> system
>> >> Admin.
>> >>
>> >> Any idea what is wrong?
>> >>
>> >> Thanks!
>> >> Simon
>> >>
>> >>
>> >>
>>
>>
>> 


0
Simon
2/22/2007 5:50:43 PM
If you don't want to install the laptop client, here is workaround.

Change the URL that the CRM Outlook Client computer is using 
(HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient).  Change it to use the IP 
address of the CRM server instead of the name of the server.  Then add that 
IP address to the Local Intranet or Trusted Site zone in Internet Explorer.  

The issue is related to the Site Map customizations being cached on the 
computer.  If you export the Site Map customizations and look at the file you 
will see that the Settings area is set to Client = “Web”.  This means that 
the area will only appear in the CRM Web client.  This is what is getting 
cached.  When you open up the CRM Outlook Client the Sitemap settings say to 
not display the Settings button since it is only available in the CRM Web 
Client.      

If you open the CRM Web client and the Site Map is cached, it will not 
display the Settings button.  Changing the CRM Outlook Client to use a 
different URL will prevent the pages cached from the CRM Outlook Client (ex. 
http://<ipaddress>) from interfering with the pages being requested by the 
CRM Web client (ex. http://crmserver).  I think instead of using IP address 
you could probably also add a Host Header in IIS (ex. http://CRMClient) and 
have the CRM Outlook client computers point to that URL instead of the IP.  
The URL for the CRM Outlook Client just needs to be different than what they 
are typing to access the CRM Web Client.

-- 
Client Solutions Manager
Micro Strategies


"Simon Renshaw" wrote:

> Thanks, I will install the laptop client then.
> 
> "Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message 
> news:B6B1A355-D3BF-48BA-9668-90A1ACAF7F62@microsoft.com...
> > Yes, running both the CRM Outlook Desktop Client and Web Client will have
> > that effect.  Just run one or the other.  Running CRM Outlook Laptop 
> > Client
> > and Web Client in parallel is ok.
> >
> > Frank Lee, Microsoft CRM MVP
> > Workopia, Inc.
> > http://microsoft-crm.spaces.live.com
> >
> > "Simon Renshaw" wrote:
> >
> >> Yes I do. This is why it's happening?
> >>
> >> I forgot to mention it in the first post, but I use IE7. I noticed that 
> >> if
> >> the button is gone, if I clear all my private data in IE, the button is 
> >> back
> >> after I do that.
> >>
> >> "Frank Lee" <FrankLee@discussions.microsoft.com> wrote in message
> >> news:C2533CFC-66C8-412F-8210-CB6FA09B2103@microsoft.com...
> >> > Are you running the Microsoft CRM Outlook Desktop client in parallel?
> >> >
> >> >
> >> > Frank Lee, Microsoft CRM MVP
> >> > Workopia, Inc.
> >> > http://microsoft-crm.spaces.live.com
> >> >
> >> > "Simon Renshaw" wrote:
> >> >
> >> >> Hi,
> >> >>
> >> >> I'm having a weird problem when I access CRM using the web client. 
> >> >> When I
> >> >> access the site, I see all the buttons (Workplace, Sales, etc) except 
> >> >> the
> >> >> Settings button. If I reboot, the button is back. My security role is
> >> >> system
> >> >> Admin.
> >> >>
> >> >> Any idea what is wrong?
> >> >>
> >> >> Thanks!
> >> >> Simon
> >> >>
> >> >>
> >> >>
> >>
> >>
> >> 
> 
> 
> 
0
Utf
2/22/2007 9:47:43 PM
Reply:

Similar Artilces:

Setting up Server information
I would like to know how to locate incoming and outgoing mail server information. Another problem I have is knowledge about how many various email account types I can use as I have an email address with yahoo and msn. -- Microsoft questioning "inevitable" <inevitable@discussions.microsoft.com> wrote in message news:3E8A5145-F746-40B1-B40F-48AD423E816E@microsoft.com... >I would like to know how to locate incoming and outgoing mail server > information. Another problem I have is knowledge about how many various > email > account types I can use as I have an ema...

multiple NTDS Settings
to whom it may concern: is it possible to have more than 1 NTDS Settings in 1 DC? any effect on this? thank you. On Fri, 28 Apr 2006 19:14:31 +0800, "sherwin de claro" <sherwin.de.claro@gmail.com> wrote: >to whom it may concern: > >is it possible to have more than 1 NTDS Settings in 1 DC? > >any effect on this? > > >thank you. > What do you mean here? If you're talking about AD Sites and Services then no, only one. You can have many replication conenctions under that, but only one "NTDS Settings" under the DC. yes its on AD Si...

News button is missing from customize toolbars
I tried to add the News button to allow the newsgroup reader function. It was there at first. I followed the instruction that said it was hidden, and I had to move it from the Customize Toolbar menu. I went under the Go section, and found News. I moved it to the Go section of my file menu, and it was there. I opened the newsgroup reader, and started to create a usenet account. I was missing some info for my account, so I canceled out and closed the newsgroup reader and Outlook. Now when I open Outlook, the News button that I put under the Go File menu is gone, and it isn't...

RMS Troubleshooting and Basic Set up v4/3/2005
http://www.simonajewelry.com/rms.aspx I have decided to post the information on the net because ms newsgroup does not have a long message retention. Natt ...

Setting random number range based on query, not table
I have a "quiz" form that randomly pulls up questions from my table. It works fine, and I don't mind that it repeats questions. This allows me to sit and review for as long as I want. The problem is, that I want to use criteria in a query to limit the available questions. If I base this form on a query and limit the number of questions, the code I am using is still setting the maximum number as the number of records in my table. In the past, I had a similar database (which I have lost) that would open the form, set the selector to the last record available to the form,...

Keeping track of which listbox has focus: Best approach question
Access 2007 working in compatibility mode with a 2003 database. I have three list boxes on a tab page. I also have buttons that operate based on which list box has focus. So my approach has been to keep track of which list box has focus by having the following kind of code in the On Got Focus function of each list box: Private Sub lbx_suspendedIndefinitely_manageMyTasks_GotFocus() If Not (IsNull(Me.lbx_suspendedIndefinitely_manageMyTasks)) Then Set suspendedListBoxWithFocus = Me.lbx_suspendedIndefinitely_manageMyTasks End If End Sub in which suspendedListBoxW...

I can not set an msn account
Hi. I could set a free hotmail account using outlook. I receintly bought an extra storage account using msn. Now I have problems trying to set the msn account using outlook, in spite I could set the hotmail account without problem. I can read and send mail using the browser. Can somebody help me to set the msn account using outlook? I am receiving the error message: Configuration: Account: MSN Server: http://services.msn.com/svcs/hotmail/httpmail.asp User name: username@msn.com Protocol: HTTPMail Port: 0 Secure(SSL): 0 Code: 800ccc19 ...

Big difference in performance
I wrote a class on which I perform unit-testing before integration in the main development line, the unit-testing and main dev being two separate projects. I wrote a routine which constructs a data structure in the class, which uses CArrays, vectors, and the nth_element routine from STL, with the routine being recursive. Now, in the unit-test project, the routine takes ~3-4 seconds to execute. In the main development code, it takes ~70 seconds to execute. This is measured for the routine itself (no setup or cleanup), same data as input, same computer, and both projects compiled for debug. ...

How to keep display format when exporting XML?
First thank you for taking the time to read about my problem. My problem is this. When exporting my xml data, the time/date values loose their display format. A time of 01:30 am, for example, becomes something like 0.001353 when exported.. What do I need to do to keep the same format as is displayed in Excel? It would sure be great if you could help. Kind regards ...

Durations keep changing... Help!
Ok... it's me again - brand new user... I need to list resources (sometimes multiple) for each task, but ONLY show it shows up on a report for each person. We do not assign or track real/actaul hours. So here's what I've done to try to simplify... Task #1: Tasks/Advanced Tab: "Must Start On" with a start date (this is the only constraint I've set in the project); Fixed Duration; Effort Driven unchecked All other tasks have the same settings except no constraint date and default to "As Soon as Possible." Each Resource: Booking type - P...

Excel
Excel is the only application that I use in Windows that wipes out the clipboard after I paste. I often need to past the same information multiple times and I wishthere was an option box that allowed me to keep the clipboard after every past ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in the message pane. If you do not see the button, follow this link to open the suggestion in the Microsoft Web-based Newsreader and then click "I Agree&quo...

How do I set up formulas to update graphs dynamically
Hello, I have the following information I need to graph date Feb-08 Mar-08 Apr-08 May-08 Jun-08 Jul-08 burn 116 23 254 inventory 3035 3011 2757 The "date" is the x-axis label and the "burn" and "inventory" are the values on the y-axis. If the values for burn and inventory are blank for a particular date, I don't want the information plotted. As I add values for each date, I would like the graph to be updated automatically. I understand I need to define a named range and use it in the graph, however, I have not been successful in doing this. Also, even t...

Toolbox wizard to create Command Button
Access 2003 Windows XP Professional I used the Control Wizard on the Toolbox to create a Command Button to close the form. When I try to use it it will not run and returns this error message - The expression On Click you entered as the event property setting produced the following error: Expected: list separator or ). * The expression may not result in the name of a macro, the name of a user-defined function, or [Event Procedure]. * There may have been an error evaluating the function, event, or macro. Any ideas why? I'm at a loss. Check to see if you haven't changed the name ...

Allocation Method set to None
Not sure I understand Allocation Method set to None. Orders must be allocated before they can be fulfilled. So what exactly does setting Allocation Method set to None do? How then does the order get allocated? Thx ...

Automatically display set text based on users composition
Hi, im trying to do something really simple, trouble is i dont know what the feature's called to be able to search for tips on how to do it. Basically in outlook messages, when a user begins writing a sentence e.g. "in the terms of" i need a tag to pop up that allows the user to press enter and then the remainder of what they will want to type in will be inserted in, its a yellow tag that comes up above the words. i dont know where it needs to be created and enabled. Cheers, Rhys. ...

Using Contact's Categories to set message categories
Is there any way to have a rule that sets an incoming message category to the categor(ies) that the sender of the message is assign to in my contacts list? In other words, I have 'George Washington' in my contacts list. George has a category of 'prez' assigned to him. When I get a message from George, I'd like that message to be assigned the category of 'prez' as well. I know I can manually setup a rule to do this for specific contacts, but it would be so much more useful to manage the rule's behavior by setting categories in the contact list. No. Here&...

Dynamically Setting a forms Input Parameter Property
Hi , I'm working with a ADP project, I have a form where I set the recordset property at design time to a SQLServer stored procedure that has one parameter. If I set the Input Parameter property of the form at design time all is well. However I'd like to be a little more flexible in that I have the calling object that Opens the form using Docmd.Openform pass OpenArgs to the form. On the Form_Open event I set the InputParameter property of form using the value in OpenArgs. The problem is I'm still prompted with the parameter popup..if I press Ok everything continue on and ...

Problem with copying and pasting tasks and keeping predecessors in
I am doing a consulting project for an organization that has a bit of an unusual request. We are doing a conversion from an old mail system to Microsoft Exchange 2007. We have developed a checklist for the technicians to follow with about 50 detailed tasks (things like, "Open up Exchange Management Console", "Assure the 'Forward' Button is unchecked", etc.). The CIO expects me to enter each of the tasks from the checklist into the project plan. Instead of having a line on the project plan with a task, "Covert Leroy Smith's Mailbox" wi...

Double-click notifications from a button?
How do you get double-click notifications from a button in an MFC dialog? I created an "ordinary" button using the resource editor. When instantiated, it has the BS_NOTIFY style, according to Spy++. If this button is double-clicked, it sends a BN_CLICKED message, but no BN_DOUBLECLICKED. This is Win XP Pro SP1 and VC++ 6.0 SP5. I would prefer to avoid solutions that require timing to see if single-clicks should be combined, and those which require me to wait after a single-click to see if another click is coming. sherNOwoodSPAM@computer.org (remove caps to get e-mail) I'...

When printing, how do I keep a letter-sized document from expandi.
I have set up a landscape, letter-sized document in MS Pbulisher. But every time I try and print it, it expands the document to a legal-sized doc. Please help!!! Check your printer settings inside Publisher. -- JoAnn Paules MVP Microsoft [Publisher] "godovino" <godovino@discussions.microsoft.com> wrote in message news:6AEC49BF-CBCA-4F05-932C-034B008D6472@microsoft.com... >I have set up a landscape, letter-sized document in MS Pbulisher. But >every > time I try and print it, it expands the document to a legal-sized doc. > > Please help!!! Could ...

Setting Up Windows Mail 01-05-10
I am having trouble setting up windows mail. This is the message I get "The connection to the server has failed. Subject 'Hello', Account: 'Work', Server: 'pop3', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E" I don't know what to enter when I go into accounts & properties. I have Time Warner Cable internet and I am working off of a laptop. "NormaH" <NormaH@discussions.microsoft.com> wrote in message news:B119C5BC-0455-4A2B-8346-FD86236D0F9C@microsoft.com... >I am having ...

Activate Purchase Button in Asset General Information window
Hi there, Does anyone know how to make the purchase button from the Asset General Information window appear (Cards >> Fixed Assets >> General) What I'm trying to do is get the link enabled between the Transaction entry window and the Asset General information window. I've create an entry and posted it, by the purchase does not appear. Thanks for your help. Hi Ian You should re-visit your Fixed Assets Company setup window as that is where you tell the system that you want the link between the purchase transaction and the Fixed Assets module. Hope that helps Sheila ...

ComboboxEx Select and buttons disappear?
When I select an item from a comboboxex on my dialog all my buttons disappear, this is really strange and I'm not sure about how to go about fixing it..Anybody had this problem? any ideas? thanks OK I figured out comboboxex is calling wm_paint but wm_paint is not redrawing the controls, how can I force this? > Nevermind it was the buttons transparent property set to true that was causing it "David S." <big_dave@comcast.net> wrote in message news:TIKcnXpQBIZ0x2KjXTWJkw@comcast.com... > When I select an item from a comboboxex on my dialog all my buttons > disa...

how do I set a semi-log plot on Excel
Create your chart. Double click on the vertical axis, and on the scale tab, check the Logarithmic Scale box. If you decide you want a log-log chart, you need to start with a scatter chart, In a scatter chart, both axes offer the Logarithmic Scale option. - Jon ------- Jon Peltier, Microsoft Excel MVP Peltier Technical Services Tutorials and Custom Solutions http://PeltierTech.com/ _______ ...

Set print width to page width in VBA
IF I set the width, e.g. ActiveWorksheet.PageSetup..FitToPagesWide = 1 It automatically makes it 1 page tall, not good on long sheets, how do I set it to scale 1 page wide and however many pages tall? -- A)bort, R)etry, I)nfluence with large hammer. I recorded a macro when I did it manually. These are the lines that I'd keep: With ActiveSheet.PageSetup .Zoom = False .FitToPagesWide = 1 .FitToPagesTall = False End With Trevor Best wrote: > > IF I set the width, e.g. > > ActiveWorksheet.PageSetup..FitToPagesWide = 1 > > It automat...