SQL Server agent

I cannot seem to locate anything that explains what SQL Server Agent is doing 
in CRM 4.0. 

We know it is a prerequisite but I cannot seem to find anything that 
explains what it is doing or why it is needed for CRM 4? 

Can anyone point me to some documentation that explains why the agent is 
needed?
-- 
Leo
0
Mrleo (10)
7/14/2008 1:36:04 PM
crm 35858 articles. 1 followers. Follow

2 Replies
1109 Views

Similar Articles

[PageSpeed] 29

It seems they are related to the deleting process . Open the store
procedure in MSCRM_config and  read the T-SQL statement.

There are two jobs in CRM 4.0 .
They execute the  following storeprocedures  on MSCRM_Config

exec p_HardDelete
exec P_CleanupsitewideNotification



/Aamir
0
whatelseto (435)
7/14/2008 2:00:36 PM
The SQL agent needs to be running to execute all backup plans and SQL Jobs , 
etc.

I also restart the agent when ever I change security.

Often I see clients or even consultants turn this off and then months later 
they have no backups or a trasaction job has filled up their drive.

Do yourself  a favor, turn it on and keep it on and keep an eye on your SQL 
server.
/:>


"Aamir Bashir" wrote:

> It seems they are related to the deleting process . Open the store
> procedure in MSCRM_config and  read the T-SQL statement.
> 
> There are two jobs in CRM 4.0 .
> They execute the  following storeprocedures  on MSCRM_Config
> 
> exec p_HardDelete
> exec P_CleanupsitewideNotification
> 
> 
> 
> /Aamir
> 
0
7/14/2008 3:29:01 PM
Reply:

Similar Artilces:

Outlook Client CRM 3.0 issues & Calender problem on Server
I have installed a test bed of CRM 3.0 on SBS premium with SQL 2005 and have a laptop which I need to use as the demo machine. However when I try to install the laptop client everything is fine in the pre reqs apartment from the fact the installation believes there is an incompatible version of the client installed on the laptop. The same version was on the laptop but it was removed prior to adding the laptop to the new domain. There are no references to the client in Add/Remove programmes, no folders under Program Files and I can find no registry entries. Does anyone know of somewhere...

Removing the Last Exchange 55 server
have recently completed an In Place Upgrade from Exchange 55 running in an NT domain to an Exch2k3 running in AD 2003. Currently the environment is in mixed mode (thanx Exh2k3 SP1) amd I want to go to native mode. My first and only Exch 55 server needs to be delete. As per MS paper on "Upgrading Exchange server 55 to Exchange server 2003 in a Medium sized oranization" I am concerned about systems folder from Exch 55 to Exh2K3. I have used the pfmigrate utility to replicate my public folders without the /S switch. All is well and now I want to go to native mode. Do I need to ...

Project Server 2003 and MS Office Project 2007
Hello, I'm very new to Project Server and am researching the creation of templates that can be used by the PMs. We would create a comprehensive template based on PMI, RUP or Prince2 and save it as a template. I found out how to save the template and I can see it in the database allright but when I create a new project in project center, I get a blank project. How and where do I configure project server to use the project template I created in Project Center. Any help is appreciated. Jason Jason -- To create a new project from one of the two new enterprise project ...

Exhange Server
I have the following: Windows NT Outlook 2002 Pentium 4 2.19 Ghz 256 MB Currently, whenever I open Outlook, it says "Your Microsoft Exchange Server is unavailable". What does that mean and how do I remedy that? Open Control Panel-Mail Icon and under your email accounts, remove Exchange ir you do not run against an Exchange server. It sounds like you are not. Ensure that your ISP mail account is installed using the settings your ISP provided. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the (insert latest virus name ...

Can't open any file from the server on some machines
Hi, We are working on server 2003. On some machines, when the user is openning any(!!!) file from the server- project crashes. We tried to see if the problem is with the user or with the machine (by logging different user to the same machine or logging the original user to another machine) and found out that the problem is with the machine. What can be the problem? Thanks, Barak Submitted via EggHeadCafe - Software Developer Portal of Choice SEO With Google, MSN, and Yahoo Site: and Link: counts http://www.eggheadcafe.com/tutorials/aspnet/06d7d9b5-8be3-4052-be2f-d7d87064...

Converting access to sql server
Hi, I have converted data from access to sql server. In one of my forms I have find method i.e DoCmd.DoMenuItem A_FORMBAR, A_EDITMENU, 10, , A_MENU_VER20. Conversion went fine but, now when I do a search page just hangs. I even tried to convert docmd.doMenuItem to DoCmd.RunCommand acCmdFind but, i still the get the same thing. Any suggestions are appreciated. Thanks in advance, BB ...

Stand By Exchange Server
Is it possible to load a stand by server with Windows 2003 server, Exchange 2003, and replicate the .edp, .stm, and log files. onto this server. If I then have a failure on my mailserver I just unplug it and point the clients to the new server. I unerstand I would need to change the IP. I am trying to have the simplest backup solution I can design. Another possibility would be to have the server ready and restore the edp from the tape and run through the transaction logs. you can either go with clustering, or a third party for this type of redundancy... "Alpine7" <darren@datas...

Exchange 2007 Edge transport server
Hi all I am reading tecknet about EX 2007 and it is saying that i need to have 2 nics on the box. One for the publi network and one for the privcate network, and that the private network should have DNS that points to the ISP. I dont see why i couldnt pull the edge transport server on the LAN dont make the box a member of the domain, configure one nic and set the DNS to point to the internal DNS server, then server publish the edge server with ISA 2004. Would this work? "The Edge Transport server role is deployed outside of the Exchange organization as a stand-alone server in th...

Rebuild Exchange 5.5 Server
Just need a little feedback. Here's the scoop. I have a three site environment. The main site is in San Francisco, there are VPN tunnels from SF to our site in England and New York. It is purley an Exchange 5.5 org, one exchange server in each site. All external mail is delivered to the Los Angeles site, then delievered to the remote sites via a Site to Site and an X 400 connector. Here is the problem, OWA is being flaky as hell in our main site and I can't find out why. The system reboots occasionally on it's own, OWA just dies inexplicabbly. that sort of thing. I would l...

Windows Mail fails when connecting to AIM.COM mail server
I tried to post this earlier, but I don't see it. Sorry if this is a duplicate. I have an HP laptop with Vista as the OS. I use Windows Mail to access my aim.com email. I've used this for over a year. Suddenly, I am getting the following error. I can connect to the aim web mail, so my password, etc is valid and working. This seems to be an SSL error, but I have not changed my configuration of the servers in Windows Mail. Any ideas why this is suddenly occurring? Thanks. -------------Error message below ------------------- The connection to the server has failed....

Unable to bind to the destination server in DNS.
I'm receiving this errormessage for 'some' messages in the queue of Exchange 2003 SP1. The mailserver uses two other Windows 2003 internal servers as AD and DNS-server, this one uses a couple of DNS-servers from our ISP as forwarder. So far so good. Most mails get out without problems, but some of them keep hanging in the queue. When I issue a nslookup-command set type=mx domain.com I get NO mx-record (it shows me the SOA-record ???) set type=all domain.com Definitely gives one or more mx-records depending on the domain. After that (the data for the domain is in the DNS-c...

Exchange 2003 mail slow from SQL, ASP, and ASP.net
Running: - Win SBS 2K3 SP1 - Exchange 2003 SP2 This has me stumped, any help would be greatly appreciated... When sending mail from Outlook 2003 or from the Outlook Web Access, everything seems fine - mail is sent instantly. When sending mail from SQL Server (from within a Stored Proc) or from an ASP.net page using SmtpMail.Send( MailMessage ) - it takes 12-16 seconds for the mail to send (per message). This holds up the stored procedure or the .net page sending the mail. This is something that has just surfaced - it has all been running extremely fast for the past 2 yrs. If I have not p...

Sharing Calendars from the Server
Hello, We have a Windows 2003 Small Business Server with Exchange. The owner of the company would like to have access to all his employees calendars (which is less than 10 people). I know how to share out the calender by logging in as a user and sharing it via Outlook, but is there a way to make the same configuration changes from the server? I'd like to expodite the sharing process (and learn a new trick)! Many Thanks, Grant ...

How can I reset the email server names in Publisher 2003?
How can I reset the email server names in Publisher 2003? What do you mean? ...

Unable to log on to incoming mail server (POP3)
I have set up a new account in Outlook using my new email address registered with service provider. I do not seem to be sending or receiving emails and when tested in the set up, get this message "Unable to logon to the incoming mail server (POP3)". I have never done this before but have checked the required information and all seems to be correct. Can anyone help? ...

Exchange 5.5: Server to Server Communication (Ports)
This is a multi-part message in MIME format. ------=_NextPart_000_0006_01C5AE27.F4C843D0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Good morning all, I have a tricky problem that I need a little help = with. I am trying to bring an Exchange server online, on the far-end of = a VPN tunnel. Exchange will not install but i think I know what the = issue is- ports are blocked. What ports? Heck if I know... Here's the story: 1) Current, functional configuration is a Mail server in location A, = with frame relay connection to Mai...

Question about moving a server into another site.
I have a Exchange server in a remote location. I would reconfigure Exchange so that is it part of our home office site. The server would remain in the current office. I have searched the KB with no luck. Can someone point me to some docs? Thanks Paul Assuming you're talking about Exchange 5.5 here given references to Sites... You're looking for Move Server Wizard http://www.microsoft.com/technet/prodtechnol/exchange/55/downloads/mvwizard.mspx -- Bharat Suneja MCSE, MCT www.zenprise.com blog: www.suneja.com/blog ----------------------------------------- "Flybywires" ...

Defrag the OS of an Exchange 2003 Server
Is it safe to defrag the OS of an Exchange 2003 Server? On Wed, 16 Feb 2005 05:49:02 -0800, "Sabo, Eric" <SaboEric@discussions.microsoft.com> wrote: >Is it safe to defrag the OS of an Exchange 2003 Server? Yes. Make sure that there are the minimum of users on it and that you have a cerified backup of the entire box, but that would be the same advice for defragging any server. Mark, thanks! "Mark Arnold [MVP]" wrote: > On Wed, 16 Feb 2005 05:49:02 -0800, "Sabo, Eric" > <SaboEric@discussions.microsoft.com> wrote: > > >Is it...

smtp server outbound problem
Hi everybody! I have Exchange 6.5 SP1 on SBS . When i send e-mail message , it goes to server queue with state - Scheduled and stay there forever. The messages are not scheduled by user. When i do 'force connection' from queue window, messages are delivered instantly with no problem. This happens to most messages. Server used to work ok and i do not know when this went wrong. Maybe after SP was applied. What is this? Thanks Edmunds Riga On Fri, 13 May 2005 09:21:09 -0700, "Edmunds" <Edmunds@discussions.microsoft.com> wrote: >Hi everybody! > >I have...

Unable to login POP3 server
Hi all, I have an account on Exchange server 2003. I can check the mails using outllook web access. But when I am trying to download the mails using outlook, pop3 server rejects the user name and password. Error message is "log onto incoming mail server (POP3); Outlook could not connect to the incoming pop3 mail server because the server did not accept your user name and password". thnks, Shaju Hi Shaju, First off are you using Outlook? Have you typed your username in the following format Domain\Username You might also need to type your username as below if your Exchange ...

Resource Availability Graph in Project Server 2007
I'm seeing a discrepency in the Resource availability graph and what a published Gantt chart is showing. Basically, the resource availability graph is no longer showing the resource as having work on a particular date, when the gantt chart clearly shows the assignment. Also, from the Resource center, when I click View Assignments for that resource, the assignment is shown just as it is in the Gantt chart. The weird thing is, the Resource Availability graph once showed this resource as having work for that project. Since then the Gantt was edited and published, but the p...

Email system failure on a singlel Exchange 2003 server running Windows 2003 standard having message store issues
Have two servers running Exchange 2003. FS2 is PDC AND FS3 runs exchange 2003. We had a power failure and it corrupted the message store. The backup was also no good because of a hardware failure. Using the recovery storage group process, I was able to copy the existing edb, and stm files off the server, create a recovery storage group, move the recovery storage group files into the primary storage group area and get the users emailing again, but I have the corrupted message and streaming files and a bunch of log files. I ran eseutil /p /r and the files seem to be fine. Just to j...

Running CRM 3.0 and CRM 4.0 on the same server
I am in the process of testing conversion from CRM 3.0 to CRM 4.0 and want to know if it is possible to run both on the same server concurrently. I currently have a test CRM 3.0 set up and would like to install and run CRM 4.0 in a second data base on the same SQL Server and Web Server. Is this possible? Al Pemberton CRM uses Active Directory to link the users in and create security groups, especially CRM3. I would not do this. "Al Pemberton" wrote: > I am in the process of testing conversion from CRM 3.0 to CRM 4.0 and > want to know if it is possible to run both on t...

The server localhost is not responding
Need help repair crm install. I had a working CRM and problems began to occur after I tryied deleting a user from crm within web client. I deleted a the user in active directory then attemped in crm but it would not work. I know that was the wrong way to do it. No I am having problems logging in to crm with any user even the admin. When I go into deployment manager to check valid users I get local host is not reponding please contact administrator. If I try from web client the page comes up with error please contact admin. I need to get into my data. All I have is a backup of ...

Sharepoint Server 2007 and MS Project 2007
I am running a sharepoint 2007/MS Project Professional 2007/Project Server 2007 environment. When I store MS Project files in sharepoint and then double click on the file in sharepont the project window will come up and I can do most of the normal work with project with the exception when I need to use a dialog box within project the mouse no longer works within the dialog box. As an example when doing a column insert I can use the arrow keys to select a column but my mouse will not operate the scroll bar. Likewise I cannot click on the buttons at the bottom of the screen. Ho...