Sql Agent Error

After installing CRM we are receiving the following error.

"An error occurred when attempting to set the SQLSERVERAGENT service to 
AutoStart:  System.ComponentModel.Win32Exception: The specified service does 
not exist as an installed service
   at 
Microsoft.Crm.Setup.Common.Utility.ServiceUtility.SetServiceToAutoStart(String serviceName, String machineName)
   at 
Microsoft.Crm.Setup.Server.ServiceRunningValidator.AutoStartLocalService(String serviceName, TimeSpan waitTimeForStart)

We have CRM on a SBS 2003 machine and SQL EE 2000 on a W2K3 machine. Both 
are DCs the SBS holds all FSMO roles.

Thanks
0
Utf
2/8/2006 9:07:29 PM
crm 35858 articles. 1 followers. Follow

2 Replies
1627 Views

Similar Articles

[PageSpeed] 1

seems as if the SQL Agent wasn't installed on the machine (or someone
removed it later).  try fixing that install first.

-- 

Matt Parks
MVP - Microsoft CRM


"MDC" <MDC@discussions.microsoft.com> wrote in message
news:1293F5DF-6534-41BD-9AAD-EDD17D52AF38@microsoft.com...
After installing CRM we are receiving the following error.

"An error occurred when attempting to set the SQLSERVERAGENT service to
AutoStart:  System.ComponentModel.Win32Exception: The specified service does
not exist as an installed service
   at
Microsoft.Crm.Setup.Common.Utility.ServiceUtility.SetServiceToAutoStart(Stri
ng serviceName, String machineName)
   at
Microsoft.Crm.Setup.Server.ServiceRunningValidator.AutoStartLocalService(Str
ing serviceName, TimeSpan waitTimeForStart)

We have CRM on a SBS 2003 machine and SQL EE 2000 on a W2K3 machine. Both
are DCs the SBS holds all FSMO roles.

Thanks


0
Matt
2/9/2006 8:04:22 AM
That was my first guess, I verified it was running using Enterprise Manager, 
unistalled CRM and re-installed, same thing....

"Matt Parks" wrote:

> seems as if the SQL Agent wasn't installed on the machine (or someone
> removed it later).  try fixing that install first.
> 
> -- 
> 
> Matt Parks
> MVP - Microsoft CRM
> 
> 
> "MDC" <MDC@discussions.microsoft.com> wrote in message
> news:1293F5DF-6534-41BD-9AAD-EDD17D52AF38@microsoft.com...
> After installing CRM we are receiving the following error.
> 
> "An error occurred when attempting to set the SQLSERVERAGENT service to
> AutoStart:  System.ComponentModel.Win32Exception: The specified service does
> not exist as an installed service
>    at
> Microsoft.Crm.Setup.Common.Utility.ServiceUtility.SetServiceToAutoStart(Stri
> ng serviceName, String machineName)
>    at
> Microsoft.Crm.Setup.Server.ServiceRunningValidator.AutoStartLocalService(Str
> ing serviceName, TimeSpan waitTimeForStart)
> 
> We have CRM on a SBS 2003 machine and SQL EE 2000 on a W2K3 machine. Both
> are DCs the SBS holds all FSMO roles.
> 
> Thanks
> 
> 
> 
0
Utf
2/9/2006 9:16:30 PM
Reply:

Similar Artilces:

Money 2004 Canadian edition capital gains errors!
Asking users of the Money 2003 or 2004 Canadian version: I find that US$ capital gains report is all wrong! I mean they are way off base. Has anyone encountered this? These are simple transactions ( that is, buy and sell stocks ). However the C$ capital gains report is accurate. Can you give me any ideas as to why? ...

"HTTP status 401: Unauthorized" Error immediately after Upgrade
Hello, I was wondering if anyone out there has encountered a problem like this. Your help would be very much appreciated. I just completed upgrading MS CRM from 1.2 to 3.0. Some parts of the web access are fully accessible (e.g., Queues, Articles, Announcements under "My Work"). However, I cannot access any of the data under Workplace, Sales, Marketing, Service, and Settings. My Report Server seems to be running fine. I can run http://<localhost>/Reports and http://<localhost>ReportServer without any errors. I access MS CRM through the web browser via http://<local...

FRx Reporter 6.7 runtime error 91
Hi; I am running FRx Reporter 6.7 with GP version 10, my user got "Runtime error 91" "Object variable or With block variable not set" while she tried to create a new Row to report. This error pop up when she create a new Row and click on the pull down list of "Link to General Ledger", I tried to run it on her computer with my SQL "sa" account but it works fine under "sa", I believed, there is some kind of permission need to open for her to create a new ROW, can anyone tell me how can I grant her the permission for creating a new ROW? -...

SQL code in VB with "Access"
Hello all, I would like to use some complex SQL statements inside my access project which uses VB and I am trying to find out a way of adding SQL code into VBA in such way that VBA understands the syntax. My aim is to work SQL commands in Access and be able to set the SQL variables from a form. Currently I know how to "wrap" SQL statements in VBA strings and then concatenate the strings and send them to be processed. For example at the moment if I have an SQL statement that looks like this: select * from employee_table where name = 'GEORGE' and employee_number = '123...

VS 2008 errors in Win7
I replaced my WinXP machine with Windows 7 machine and re-installed all software. I am running VS 2008 with Ajax Control Toolkit. When I go into a page that has ajax controls I am getting the top @ Page line underlined with the error "ASP.NET runtime error: An error occurred loading a configuration file: Failed to start monitoring changes to '..... When I go into the design mode I get "Error Creating Control. Unknown server tag 'cc1:CalendarExtender' The web site runs fine and I get none of this in my other PC which is WinXP and VS 2008. Any ideas on ...

xml parser error: xml document must have a top level element 09-22-05
hi, when deleting an invoice or order i receive the following error message: "xml parser error: xml document must have a top level element" when running sql profiler trace during the procedure, i can see that the following t-sql-statement: update Invoice SET ModifiedBy=N'{1D3ACF63-3D76-49AE-AC90-A6FEB6113545}',ModifiedOn=getutcdate(),DeletionStateCode=2 Where InvoiceId='{45280801-F8C6-4F7E-BC01-DBF3F8FDF701}' and then IF @@TRANCOUNT > 0 ROLLBACK TRAN to me it looks as if the transaction is rollbacked hereby (due to the xml parser error), but i can not u...

error upgrading GP 6.0 to GP 7.5
We are currently using Great Plains 6.0 in our production environment and would like to upgrade to v8.0 this year. I have recently created a test environment in order to upgrade our current version 6.0 to version 8.0, using an intermediate step of v6.0 to v7.5 in between. The test environment is running Windows 2003 Server and MS Sql Server 2K with SP3a installed. All is well until the Dynamics Utilities are run to upgrade the databases. The upgrade procedes smoothly until it gets to the stored procedures area. The process runs thru some of the stored procedures and then halts with this...

Changing division error
Hello, We are modifying the structure of our organization. So I created two new BU. I affected every CRM users to their new BU. Everything was ok excepted for one user. I got an error for a particular user. I realized that he was the manager of a desactivated user. So I reactived the user, and tried to change my manager's BU. But I still get an error. Watching on the server I've this error in the log : 'The server didn't want to process that request' I've tried plenty of things (changing the manager of the other user, testing with another BU...). I've noted ...

Error sending email containing "autotext"
Any time an email is sent where the body of the email contains "autotext", Outlook 2002 crashes. All other emails go through fine. The error actually appears to be more or less related to Word, as Word is currently set as the default editor for emails and the error in Outlook actually states, "Word has encounter problems..." Has anyone else had this problem or know of a fix? Thanks. ...

Outlook error #15
When i finished installing outlook , an error message occurs as below : "An OLE registration error occured" . The program is not correctly installed. My netx action was to remove completly the Office product and reinstall fresh the microsoft office, but still i have the same problem.. can you help me .. thanks with regards. ...

Sorting a form based on query gives error
I have a form based on a table that isn't sorted so I created a query and sorted it. On the form, I have a combo box which populates from the query and I've sorted a field in the in the said query. The combo box control source is AuthorTbl_ID, which is a lookup field to the Author table and stores the Author ID. I can't sort on the Author ID so I've sorted the query I made on the Author LastName. When I get back to the form, I get the error message " You tried to assign the null value to a variable that is not a Variant data type." I've tried to change the ...

Great Plains and SQL Server 2005
Does antyone know if Great Plains 9.0 supports SQL Server 2005 SP3? We need to upgrade our service pack on SQL Server and we cannot find out if it is supported. The v9 System Requirements page has not been updated to reflect compatibility with SQL Server 2005 SP3. I would not apply the service pack until it appears on the compatibility page. I am sure as I type, testing is being done to certify the service pack and Dynamics GP. If you cannot wait because you are being affected in other ways, open a Dynamics GP support case to find out the status of the testing. Best regards, -- MG.- M...

Send Receive Error
Hi all, One of our remote users connects to our Exchange 2000 mail server using Checkpoint SecuRemote VPN. He has been working OK for 4 months. He is running XP Home & Outlook 2003. Something has changed (or he has done something) and he now can't send emails from Outlook. Send/receive gives the message "Task Microsoft Exchange Server - Sending reported error (0x80070005). You don't have appropriate permission to perform this operation." When receiving he gets the same message (minus "Sending") on the first attempt but it works on the second try. Any help ap...

Error installing outlook client on office 2007/vista
Hi I have run into a problem installing the outlook client on vista / office 2007. Initially the setup program detected the CRM SQL2005 express edition missing (whcih I duely instructed it to install) and incorrectly detected ..NET 1.1 SP1 missing (1.1, 2.0 and 3.0 are all installed on the laptop). The setup program would not install the .NET 1.1 so I eventually reinstalled this manually (despite it being already present). Now if I rerun the crm setup program I recieve the following error after accepting the licence screen: "The type initializer for Microsoft.Crm.Setup.Common.Com...

Pivot Bar Chart
Hi, Using Excel 2002 SP3 to make Charts with pivot tables: it works fine to display data, but I can not manage to get error bars in the plot, or to put it differently: I make a pivot table bar chart and using another column in the data-row, I would like to add this to the pivot table bars as an indication of the error on these bars. It would be valuable if you would have idea's or suggestions, Thanks in advance, Roge ...

Deleting a Folder in Outlook
Hello All... Hope someone can help me with this. I currently successfully archive my Outlook folders each day. However, there is a second archive folder which is in my folders list and I cannot get it to go away. The normal archive folder opens and closes fine. However, this second "archive" folder cannot be opened and when I click on it, I receive the following message "The set of folders could not be opened" I've tried compacting the outlook file as well as running the inbox repair tool - scanpst.exe - on my normal outlook file and archive file. This still does...

Outlook 2003 Send/Receive errors
I continually get the following error message. Task 'Bill - Receiving' reported error (0x80042108) : 'Outlook is unable to connect to your incoming (POP3) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).' It came up at least six times yesterday, and three times already today. This has been going on since I purchased my new computer and Office 2003 in January. I have checked with SBC, and they say my setup is okay. Since they accounts do work most of the time, this seems logical. I have t...

Smart Pointers and compile error
Hello - was just switching some of my old style com calls to Smart Points when I compile now I get a C:\Program Files\Microsoft Visual Studio\VC98\INCLUDE\comip.h(662) : error C2247: 'Release' not accessible because 'IDispatch' uses 'public' to inherit from 'IUnknown error. Downloaded SP6 and that didn't seem to help - Any ideas ? ...

ESM error
I'm hoping someone can help me with this. I have Exchange2k3 SP2 running on a Win2k3 server. Our Exchange Admin is out on medical leave so I am resuming his responsibilities. My problem is I cannot access some of the storage groups using exchange system manager. We have 4 mailbox stores and I get an error trying to access 3 of them. The error is "An unknown error has occurred. ID no: 80040d1b Exchange System Manager". What is really puzzling is if I click on a storage group a second time, I don't get the error but the storage group shows up as empty. I have thi...

Error code 800f0826 when installing Vista SP1 full download packag
I am trying to install Windows Vista Service Pack 1 All Language Standalone (KB936330) 544.3 MB full download package . But it showed error Error code 800f0826 . Please help to solve problem. Windows Update error 800f0826 <http://windowshelp.microsoft.com/Windows/en-US/Help/2d96561c-0a7a-492a-b48f-8317cf4f1fde1033.mspx> Read ahead, Information about Windows Vista SP1 http://support.microsoft.com/?kbid=936330 windows vista service pack 1 is not available for installation from windows update and is not offered by automatic updates:http://support.microsoft....

9.0 Upgrade Error #2
We are upgrading from 7.5 to 9.0 using Sequel 2000. We ran into a problem with a null value in a PO field, which has been corrected. We are trying to begin the upgrade process again, and have run the Great Plains scripts to restart the upgrade. When we open the 9.0 Utility window, we see the following: First it runs a "Validating Product Version Information" and then I see the following error: Field Service: Unable to get extended version information for product 949. Any suggestions?? SW Hi hank. I had this same error. To get past it you need to remove field service from y...

Confusing error message when opening and closing excel
"Compile error in hidden module: TBrun9" When I open or close excel (any version, 2000-2002-2003) I get this message. I have installed and re-installed all versions and I have even re-installed my Windows XP operating system. I still get this message when I either open or close my excel program. Please help!!! Toll Free Phone if preferred 1-877-847-8154 Vernon Baugh Mendenhall MS 39114 Hi have a look at XL: Compile Error in Hidden Module Tbrun97.xls http://support.microsoft.com/default.aspx?scid=kb;en-us;272066 -- Regards Frank Kabel Frankfurt, Germany Vernon Baugh wrote: ...

Do not allow a file to be saved if "ERROR" is in any field
I'm using IF conditions to check certain cells for negative numbers - if they're negative the output is "ERROR". I wanted to know if there is a way to prevent the file from being saved if "ERROR" is in any cell in the workbook. Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Boolean) Dim sh As Worksheet For Each sh In ThisWorkbook.Worksheets If sh.Evaluate("SUMPRODUCT(--(ISERROR(" & _ ActiveSheet.UsedRange.Address & ")))") > 0 Then MsgBox "Errors in file" ...

Trouble sending email ERROR 554???????
Any Help Please! I can't send emails but all other Windows Live and internet connections are fine. The error is ERROR 554 Domain Relaying Denied I can't send a question through Windows support system, can not type in the additional info box therefor all required fields are not completed message blocks my submit On Mon, 12 Apr 2010 08:00:01 -0700, Valhalla wrote: > Any Help Please! I can't send emails but all other Windows Live and internet > connections are fine. The error is ERROR 554 Domain Relaying Denied > > I can't send a question through Wi...

Exchange 2003 OWA Errors
Ok here we go. Server running MS2003 Small Business Server. Exchange 2003. OWA is setup to use secure web https. Anyhow when I can log onto the OWA site and all of the various folder views load as well as email headers. However, I cannot open the emails, I cannot create new messages or calendar items or contacts. Nothing happens. I have noticed that on some workstations, Internet Explorer states that errors have been found on the page. But I cannot tell you what the errors are right now. What I can tell you is that the only thing that I can do is navigate arround the folders, and delete...