Problem in saving data in the customized case entity

Hi all,

We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
having detailed information like history,insurance,case contacts,Schedules etc

On Visit Schedules, we have attributes like order shipped date and fax order 
received etc. when I enter the shipped date and save it the modified by field 
has the System account instead of the user who is modifying. 

We have to reassign the system user to the User who is actually modifying it 
manually.This happens for all the users in CRM.

Can anyone guess where the problem could be?

Thanks

Karthik
0
Karthik (33)
8/11/2008 2:59:37 PM
crm 35858 articles. 1 followers. Follow

5 Replies
412 Views

Similar Articles

[PageSpeed] 56

Generally, the SYSTEM user is used when the record is modified by a callout 
and sometimes workflow is you have any custom assemblies in your workflow.

Are you saying that when you modify a record, it is reassigned to SYSTEM, or 
that SYSTEM shows as the user who last modified the record?

-- 
Richard Riddle
CRM Developer
Autonomix


"Karthik-" wrote:

> Hi all,
> 
> We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
> having detailed information like history,insurance,case contacts,Schedules etc
> 
> On Visit Schedules, we have attributes like order shipped date and fax order 
> received etc. when I enter the shipped date and save it the modified by field 
> has the System account instead of the user who is modifying. 
> 
> We have to reassign the system user to the User who is actually modifying it 
> manually.This happens for all the users in CRM.
> 
> Can anyone guess where the problem could be?
> 
> Thanks
> 
> Karthik
0
8/11/2008 10:18:04 PM
Hi Richard,

Yes, its shows as the SYSTEM as last modified. We are using Callout, but 
when we try changing the modified by field to the current user and save it 
and it is showing as SYSTEM.

Could you please help me out in resolving this?

Your help is greatly appreciated.

Thanks

Karthik


"Richard Riddle" wrote:

> Generally, the SYSTEM user is used when the record is modified by a callout 
> and sometimes workflow is you have any custom assemblies in your workflow.
> 
> Are you saying that when you modify a record, it is reassigned to SYSTEM, or 
> that SYSTEM shows as the user who last modified the record?
> 
> -- 
> Richard Riddle
> CRM Developer
> Autonomix
> 
> 
> "Karthik-" wrote:
> 
> > Hi all,
> > 
> > We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
> > having detailed information like history,insurance,case contacts,Schedules etc
> > 
> > On Visit Schedules, we have attributes like order shipped date and fax order 
> > received etc. when I enter the shipped date and save it the modified by field 
> > has the System account instead of the user who is modifying. 
> > 
> > We have to reassign the system user to the User who is actually modifying it 
> > manually.This happens for all the users in CRM.
> > 
> > Can anyone guess where the problem could be?
> > 
> > Thanks
> > 
> > Karthik
0
Karthik (33)
8/12/2008 1:47:00 PM
The first thing to do is try to figure out what the callout is doing.  If you 
did not implement the callout, you can look in the callout.config.xml file on 
your CRM server in the Server/bin/assembly directory under.  For testing 
purposes, you could rename that xml file to a different name, then restart 
the crm workflow service and iis and see if the behavior changes.


-- 
Richard Riddle
CRM Developer
Autonomix


"Karthik-" wrote:

> Hi Richard,
> 
> Yes, its shows as the SYSTEM as last modified. We are using Callout, but 
> when we try changing the modified by field to the current user and save it 
> and it is showing as SYSTEM.
> 
> Could you please help me out in resolving this?
> 
> Your help is greatly appreciated.
> 
> Thanks
> 
> Karthik
> 
> 
> "Richard Riddle" wrote:
> 
> > Generally, the SYSTEM user is used when the record is modified by a callout 
> > and sometimes workflow is you have any custom assemblies in your workflow.
> > 
> > Are you saying that when you modify a record, it is reassigned to SYSTEM, or 
> > that SYSTEM shows as the user who last modified the record?
> > 
> > -- 
> > Richard Riddle
> > CRM Developer
> > Autonomix
> > 
> > 
> > "Karthik-" wrote:
> > 
> > > Hi all,
> > > 
> > > We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
> > > having detailed information like history,insurance,case contacts,Schedules etc
> > > 
> > > On Visit Schedules, we have attributes like order shipped date and fax order 
> > > received etc. when I enter the shipped date and save it the modified by field 
> > > has the System account instead of the user who is modifying. 
> > > 
> > > We have to reassign the system user to the User who is actually modifying it 
> > > manually.This happens for all the users in CRM.
> > > 
> > > Can anyone guess where the problem could be?
> > > 
> > > Thanks
> > > 
> > > Karthik
0
8/12/2008 2:58:26 PM
Hello Richard,

We have implemented the callout and it's working successfully but we are not 
aware why "modifiedby" field is showing us as a system. We also try to update 
the field with current user by callout code even though "modifiedby" is still 
showing as a system. 
Is there any way we can update the field by current user name. 

Thanks,
Karthik

"Richard Riddle" wrote:

> The first thing to do is try to figure out what the callout is doing.  If you 
> did not implement the callout, you can look in the callout.config.xml file on 
> your CRM server in the Server/bin/assembly directory under.  For testing 
> purposes, you could rename that xml file to a different name, then restart 
> the crm workflow service and iis and see if the behavior changes.
> 
> 
> -- 
> Richard Riddle
> CRM Developer
> Autonomix
> 
> 
> "Karthik-" wrote:
> 
> > Hi Richard,
> > 
> > Yes, its shows as the SYSTEM as last modified. We are using Callout, but 
> > when we try changing the modified by field to the current user and save it 
> > and it is showing as SYSTEM.
> > 
> > Could you please help me out in resolving this?
> > 
> > Your help is greatly appreciated.
> > 
> > Thanks
> > 
> > Karthik
> > 
> > 
> > "Richard Riddle" wrote:
> > 
> > > Generally, the SYSTEM user is used when the record is modified by a callout 
> > > and sometimes workflow is you have any custom assemblies in your workflow.
> > > 
> > > Are you saying that when you modify a record, it is reassigned to SYSTEM, or 
> > > that SYSTEM shows as the user who last modified the record?
> > > 
> > > -- 
> > > Richard Riddle
> > > CRM Developer
> > > Autonomix
> > > 
> > > 
> > > "Karthik-" wrote:
> > > 
> > > > Hi all,
> > > > 
> > > > We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
> > > > having detailed information like history,insurance,case contacts,Schedules etc
> > > > 
> > > > On Visit Schedules, we have attributes like order shipped date and fax order 
> > > > received etc. when I enter the shipped date and save it the modified by field 
> > > > has the System account instead of the user who is modifying. 
> > > > 
> > > > We have to reassign the system user to the User who is actually modifying it 
> > > > manually.This happens for all the users in CRM.
> > > > 
> > > > Can anyone guess where the problem could be?
> > > > 
> > > > Thanks
> > > > 
> > > > Karthik
0
Karthik (33)
8/12/2008 3:22:06 PM
Why the modifiedby user is SYSTEM instead of the user who initiated the 
callout has to do with impersonation when the CRM web service is called.  In 
the SDK, there are examples for how to impersonate the calling user in 
callouts.

-- 
Richard Riddle
CRM Developer
Autonomix


"Karthik-" wrote:

> Hello Richard,
> 
> We have implemented the callout and it's working successfully but we are not 
> aware why "modifiedby" field is showing us as a system. We also try to update 
> the field with current user by callout code even though "modifiedby" is still 
> showing as a system. 
> Is there any way we can update the field by current user name. 
> 
> Thanks,
> Karthik
> 
> "Richard Riddle" wrote:
> 
> > The first thing to do is try to figure out what the callout is doing.  If you 
> > did not implement the callout, you can look in the callout.config.xml file on 
> > your CRM server in the Server/bin/assembly directory under.  For testing 
> > purposes, you could rename that xml file to a different name, then restart 
> > the crm workflow service and iis and see if the behavior changes.
> > 
> > 
> > -- 
> > Richard Riddle
> > CRM Developer
> > Autonomix
> > 
> > 
> > "Karthik-" wrote:
> > 
> > > Hi Richard,
> > > 
> > > Yes, its shows as the SYSTEM as last modified. We are using Callout, but 
> > > when we try changing the modified by field to the current user and save it 
> > > and it is showing as SYSTEM.
> > > 
> > > Could you please help me out in resolving this?
> > > 
> > > Your help is greatly appreciated.
> > > 
> > > Thanks
> > > 
> > > Karthik
> > > 
> > > 
> > > "Richard Riddle" wrote:
> > > 
> > > > Generally, the SYSTEM user is used when the record is modified by a callout 
> > > > and sometimes workflow is you have any custom assemblies in your workflow.
> > > > 
> > > > Are you saying that when you modify a record, it is reassigned to SYSTEM, or 
> > > > that SYSTEM shows as the user who last modified the record?
> > > > 
> > > > -- 
> > > > Richard Riddle
> > > > CRM Developer
> > > > Autonomix
> > > > 
> > > > 
> > > > "Karthik-" wrote:
> > > > 
> > > > > Hi all,
> > > > > 
> > > > > We have a Customized Case Entity in CRM 3.0 about a Patient ,with each case 
> > > > > having detailed information like history,insurance,case contacts,Schedules etc
> > > > > 
> > > > > On Visit Schedules, we have attributes like order shipped date and fax order 
> > > > > received etc. when I enter the shipped date and save it the modified by field 
> > > > > has the System account instead of the user who is modifying. 
> > > > > 
> > > > > We have to reassign the system user to the User who is actually modifying it 
> > > > > manually.This happens for all the users in CRM.
> > > > > 
> > > > > Can anyone guess where the problem could be?
> > > > > 
> > > > > Thanks
> > > > > 
> > > > > Karthik
0
8/12/2008 4:00:17 PM
Reply:

Similar Artilces:

GP 10 recovery and customization
Hi, we're in the process of making a recovery plan. To test it, we install GP 10 on another server. Roughly here the steps we have done successfully: 1- Restore the required databases and logins 2- Install GP 10 from CDs 3- Install GP 10 SP1 and fixes It works fine on the test server but my question is: is there a structured way to transfer customization elements (extender, smartlists, etc...) to the new installation ? Thanks. Richard, All customizations elements (SLB, Extender and Modifier) has its own import/export features, you can use these features to export customizations ...

Publisher template of a customer reply postcard
Where can I find a generic Publisher template for a customer reply postcard? I tried searching the templates on offfice.microsoft.com to no avail. There are postcard templates within Publisher. Surely you can adapt one of those. Only you know what folks are replying about. -- Mary Sauer MSFT MVP http://office.microsoft.com/ http://msauer.mvps.org/ news://msnews.microsoft.com "Erik Quist" <Erik Quist@discussions.microsoft.com> wrote in message news:D68A9CA8-4FB5-447B-928F-CD72198BA33B@microsoft.com... > Where can I find a generic Publisher template for a customer reply...

Hyperlink Problem
I previously had java Web Start loaed on my PC. I removed it. However, every time I try to open a web link in Outlook, I get something trying to load JWS). it asks me to accept or decline the license agreement. I decline. Then I go back and click on the hyperlink and it opens fine in IE 6. Any suggestions on how to rid myself of this annoyance? ...

Script Error 190 Permission Denied - Customization - Account
When trying to select a 2nd row in the Edit Filter Criteria window I get a 190 script error. Thus, I am unable to perform an 'OR' in the filtering. This error happens on other workstations, so I think it is a bug. It does not occur when performing the same action in Advanced Find versus Customization. Comments ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in the message pane. If you do not see the button, follow this link to open the su...

Sorting data #3
I have my data organized in columns based on state standards, and I want to regroup the data to get all Algebra questions together, all Geometry together, etc. Row 1: Question1 Question2 question 7 question 25 Row2: 6N1 7G8 5N15 6A9 Row 5-30 has student responses to the each question where N, G and A represent Number sense, Geometry and Algebra. I want to determine how the class did overall on each category. Thanks. -- I am pregnant with possibilities, and so are you! Jenai Your question makes perfectly good sense to you because y...

How Do I Pass Data Between 2 UserForm's
Greetings, I am trying to pass data from a TextBox on UserForm1 to a Label on UserForm2. At this point UserForm2 cannot see the TextBox on UserForm1. How can I accomplish this? TIA -Minitman If both forms are in memory, you can reference with Label1.Caption = Userform1.Textbox1.Text on userform2, or Textbox1.Text = Userform2.Label1.Caption on userform1 -- HTH Bob Phillips ... looking out across Poole Harbour to the Purbecks (remove nothere from the email address if mailing direct) "Minitman" <excelreply@i-m-p.net> wrote in message news:79ta10dqjvvuvda...

Problem accessing PF
Hello, i have a problem accessing public folder. My public folders infrastructure is: PF hierarchy: All public folders EMEA RU 1. hierarchy is stored on my server (the server has default MAPI store) 2. emea`s content is stored in another routing gfoup 3. ru`s content is stored on my server When i`m trying to access content of "ru" folder, my workstation do establish a connection to the server that holds "EMEA" folder. If i`m not wrong, permissions should be stored with hierarchy. So, all required data stored on my h...

Error serializing derived Custom Collection Class
I am receiving an error stating that File or Assembly name <filname.dll>, or one of its dependencies, was not found In one assembly I have three abstract classes In another I have three derived classes from the abstract classes The 1st class contains the 2nd class The 2nd class is a custom collection for the 3rd class when I serialize the 1st class I am receiving the error. The classes look like the following: Abstract classes: using System; using System.Xml.Serialization; namespace AbstractClasses { public abstract class ContainerBase { private LocationsCollectionBase _loc...

formula change problem
I have a working formula that looks like this: Code ------------------- .Offset(P, 5).Formula = "=IF(RC[-1]>100,IF(RC[1]=""Y"", if(rc[2]=""US"",""TRUE"")),""FALSE"")" ------------------- and I want to change it to: Code ------------------- .Offset(P, 5).Formula = "=IF(.offset(P, 4) > 100, " & _ "IF(.offset(P, 6) =""Y"", " & _ "IF(.offset(P, 7) =""US"",""TRUE"")),""FALSE&q...

Auto-filter not grabbing all the data
Hi...I'm trying to filter through a database that has over 15,000 rows and not all the data is showing up in the filter. It seems to stop somewhere between 13321 and 13401. I've read through all the threads here and everyone is saying that the Auto-filter drop-down list is the only thing limited to 10,000 items but that it should filter the whole spreadsheet. Apparently not. Can anyone help, please?? Thanks.... I never let excel guess at the range that should be filtered. I'll always explicitly select my range. If your data has empty cells in it, then excel may no...

2008 Client Deployment Problem
I am trying to move a client computer (running 32-bit Windows XP Pro) from a workgroup to the SBS 2008 domain using the SBS 2008 Client Deployment Launcher. I get to the "Move Exiting User and Settings" dialog where it is supposed to list the user profiles that exist on the clinet machine so that you can select the user to be mapped to the new profile. The list of profiles is empty - all it shows is "None". The help file says something about removing the "make private" option from the user's profile files. However this assumes the client computer...

Problem Importing a TXT File
I have a workbook named 05-03-31. It contains information for the first quarter of this year. Sheet 1 references cells on Sheet 2. Sheet 2 was created by importing a TXT file. I thought I had accomplished something wonderful at that time. I now have a new TXT file with second quarter data. I opened the first quarter workbook, 05-03-31 and saved it as 05-06-30, so now I have a second quarter workbook. When I Import the second quarter TXT file into the second quarter workbook it creates a Sheet 3. On Sheet 1 can I globally change all the references to Sheet 2 to Sheet 3? I tried deleting Sheet 2...

Image attachments problem
I am trying to set up outlook 2002 (XP). When we receive a message from someone with image attachments (jpg, gif) we are unable to view them in the message. How do I make it so we are able to view image the images in the actual message. I have tried everything, well almost everything. Can someone help? Thanks Auto ...

excel 2002 data filter
hello this is the case if i have in column A data like this: http://www.abc.com http://www.cba.com http://www.abc.com ok. When i press select complete column A and then select DATA - FILTER - ADVANCE FILTER - UNIQUE RECORDS ONLY i get folowing result: http://www.cba.com this is not what i want. I want to get folowing result: http://www.abc.com http://www.cba.com u see what i meen? Can u help please and thank you very much!!! On Feb 14, 2:10=A0am, Ivanko <Iva...@discussions.microsoft.com> wrote: > hello > this is the case > > if i have in column A data lik...

xml problems with dotnet1.1
Hi List I have developed a small app reading xml files using dotnet1.0. Now I changed to dotnet1.1. The Problem is with Dotnet1.1 the Method OuterXml from class XmlDocument returns the xml string in another format. In Dotnet1.0 the returned string looks like "<TAG ELEMENT='1'>DATA</TAG>" In Dotnet1.1 the returned string looks like "<TAG ELEMENT=\"1\">DATA</TAG>" Can I change back to output from Dotnet1.0 using Dotnet11, or is there any other workaround??? regards Bj�rn Hi Bj�rn, How did the original document look like? A...

Cannot see sample data
Hello, I've followed the exact instalation procedures of the sample data (creat AD users, run install wizard). The installation seems to be successful. I logged in under the sample data user, but could not see any data. The "announcements" section contains 4 articles, which mean it was added during the install using the wizard. What am I doing wrong? It's been so long since I have to install CRM 3.0 again, but I remember there is another step to configure so the users can see the sample data. Please advise. Thanks for your help. -- Regards, Andy Go to Settings ...

Resizing problem: SDI with a CTabCtrl, Tabs disappear?
I have a complicated and weird problem. First, I am creating an SDI application (with a menu, max/min option, etc..) with a CTabCtrl. I used a class I found on Code project to be able to resize the application. The article and downloadable code is here: http://www.codeproject.com/dialog/dynwindow.asp?df=100&forumid=363&exp=0&select=539230 After downloading the cdxDynamic files, I integrated them into my code, and it worked beautifully, except for this... I am also implementing List Controls inside of each tab, and the List Control box was resizing seperately from the SDI app. ...

Outlook Web Access Problems (SBS 2003)
Wonder if any one can help... We use Outlook Web Access and until last week we have never had any problems.... (SBS 2003) I get to the login screen and put my username and password in and I get the error "You could not be logged on to Outlook Web Access. Ensure that your user name and password are correct, and then try again." I've tested the login as both the user the admininstrator and internally on the server and I get the same problem... I'm not aware that we have installed any new apps or made any changes recently Any ideas....?, the users just seem to have los...

Data base web design
Can I use Access 2007 as database for my web site as I use MySQL "Jeff" <Jeff@discussions.microsoft.com> wrote in message news:78AB2033-4F7E-46C1-8458-C96E3B0E5AAE@microsoft.com... > Can I use Access 2007 as database for my web site as I use MySQL I think you're confusing the term database, and MS access. MS access is a tool that lets you build an application, and that application can connect to a database engine such as JET, or MySql. so it's not the MS access side that has anything to do with a web based system, it is the database engine you choose to use...

Align or Distribute problem
Publisher 2002. Win XP Home. I have created 6 small identical blank price tickets(showing store name) appearing on A4 size card (landscape) 3 across top with 3 below,spaced, by eye, as evenly as I could. These will be cut to individual useable price tickets. However I will want to print on both sides of the cards,(to make re-usable) and therefore want the spacing to be identical (mirrored ?) I have tried Edit "select all" then gone to "Arrange" /Align or Distribute /Distribute Horizontically/ DistributeVertically. The effect is to scatter the price tickets, not equall...

Help please
Hi everybody, what can be the reason why for some crm users in our domain, the incoming replies originating from crm contacts are populated as an activity but for some others they are not (eventhough replies come to their outlook inbox folder). Am I missing something in terms of user rights for that users? Any help will be appreciated! Thanks Have all the users had the CRMEMailEnable setting added to their profile in AD? -- Matt Parks MVP - Microsoft CRM "Isil" <Isil@discussions.microsoft.com> wrote in message news:9A86BDB4-F184-45D0-9A38-3C1D1470B88B@microsoft.com....

Highlight Data
I'm trying to figure out a way to create an excel formula, or vba that will allow me to highlight rows of similar data. For example, I have the following information: .. .. BW404988 BW404988 M9610-3069S M9610-3069S M9610-3069S BM404701 BM404701 BM404701 BM404701 .. .. so I'm wanting a formula that would highlight the first two, then not the next three, then the next four. Does anyone know of how to do this? There won't necessarily be this 2, 3, 4 pieces of data. I'm trying to base it off of information found within column E. Thanks much, DJ You need to be more speci...

Problem executing a macro from different workbook where it is
Hi everibody, I have a macro in a workbook called, for example, WB1.xls. The macro takes differentes ranges and copy them in another location. ex. : Public Sub ZeroizaModeloSteve() Set wbModelo = Application.Workbooks(Mid(cteLibModelo, 2)) Set wsI = wbModelo.Sheets("I") Set wsT = wbModelo.Sheets("T") Set wsmodelo = wbModelo.Sheets(cteHojaModelo) Set wsZeroing = wbModelo.Sheets(cteHojaZeoring) wsI.Range("F50:IS50").Copy wsI.Range("F51").PasteSpecial xlPasteValues end sub 'i have omitted declaration variables and desct...

Very strange RWW problem
Here's one for you folks. I have a watchguard edge router that won't let me get into RWW. I can put in a standard old Linksys router in, configure the ports and everything works fine. I use the same port configuration for the watchguard and the connection fails. While trying to trouble shoot the problem, the watchguard tech did some packet sniffing and tells me that the 443 info passes through the router fine and the 4125 info then goes to the server and the server immediately resets the connection. Again, I can hook up a linksys wrt54 router and it works perfectly. I ha...

How to protect a cell INSTANTLY the moment the data is entered!!
Hello, I want to know how to protect the cell at the very moment data i keyed in and entered without using the protection option in the tool' bar! I would like the process to be automatic!! for example: in cell B if i type in the word "king" and press ENTER! after this i must not b able to modify the word as the cell should be automatically protected if any one has a response to this please reply i would be eagerl waiting for it! thanx! Mot -- Message posted from http://www.ExcelForum.com You could do this by having the cell unprotected>entering the data>have a workshee...