Poor performance over VPN connection

Hi

We have a CRM 4 Professional deployment installed in the following 
environment:
CRM Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 32bit, 
CRM 4 Professional, UR 6
SQL Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 32bit, 
SQL Server 2008 Standard, Reporting Services, SSRS DataConnector

Within the local network CRM performance is very good (load of account form 
<1s). But when our users establish a VPN connection to the corporate network 
the performance of CRM isn't acceptable anymore (load of account form 8 - 
10s).
The users access CRM over the web client.

Does anybody have similar performance issues when working with CRM over a 
VPN connection?
Are there any settings which can be done on IIS? 
Do you know any tools for troubleshoot the issue?

Thanks everybody,
Raphael
0
Raphael (4)
10/27/2009 10:52:01 AM
crm 35858 articles. 1 followers. Follow

2 Replies
384 Views

Similar Articles

[PageSpeed] 34

Hello,
And what about other applications accessed with this vpn ?
We use vpn frequently with no problems but it depends of many parameters: 
vpn type (IPSEC based vpns could be very heavy), your network (ADSL, SDLS), 
its bandwith and quality bof connection.
Number of connected users: IIS needs many memory on the Application Server, 
try a look on the optimization guide for CRM, you could certaily find it 
browsing here:
http://www.microsoft.com/downloads/en/resultsForProduct.aspx?displaylang=en&productID=835909d0-a755-41ff-93cd-f5207c609ef5&nr=20&sortCriteria=Popularity&sortOrder=Ascending&stype=ss_sd

CS
http://www.addonnice.com  Imagine CRM - @Commerce for MS CRM

"Raphael" <Raphael@discussions.microsoft.com> a écrit dans le message de 
news:92981543-EF18-481A-9B8B-804C60DF086E@microsoft.com...
> Hi
>
> We have a CRM 4 Professional deployment installed in the following
> environment:
> CRM Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 
> 32bit,
> CRM 4 Professional, UR 6
> SQL Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 
> 32bit,
> SQL Server 2008 Standard, Reporting Services, SSRS DataConnector
>
> Within the local network CRM performance is very good (load of account 
> form
> <1s). But when our users establish a VPN connection to the corporate 
> network
> the performance of CRM isn't acceptable anymore (load of account form 8 -
> 10s).
> The users access CRM over the web client.
>
> Does anybody have similar performance issues when working with CRM over a
> VPN connection?
> Are there any settings which can be done on IIS?
> Do you know any tools for troubleshoot the issue?
>
> Thanks everybody,
> Raphael 

0
NOSPAMCS (53)
10/27/2009 12:19:35 PM
I'd take a strong look at the number of hops accross the VPN. I had similar 
issue with my latest customer, and discovered that the vpn was straddled 
taking me from (externally) my ISP to client site, then to remote site, then 
back to client site, then to a different site... 

It's my understanding that during page loads there are limited number of 
thread connections via IIS and trying to fit all the objects that a CRM page 
tries to load over so many hops can really reveal issues with VPN.

I'd definitely look at this over general CRM optimization steps.

Michael D. Mayo

"CS ADNT" wrote:

> Hello,
> And what about other applications accessed with this vpn ?
> We use vpn frequently with no problems but it depends of many parameters: 
> vpn type (IPSEC based vpns could be very heavy), your network (ADSL, SDLS), 
> its bandwith and quality bof connection.
> Number of connected users: IIS needs many memory on the Application Server, 
> try a look on the optimization guide for CRM, you could certaily find it 
> browsing here:
> http://www.microsoft.com/downloads/en/resultsForProduct.aspx?displaylang=en&productID=835909d0-a755-41ff-93cd-f5207c609ef5&nr=20&sortCriteria=Popularity&sortOrder=Ascending&stype=ss_sd
> 
> CS
> http://www.addonnice.com  Imagine CRM - @Commerce for MS CRM
> 
> "Raphael" <Raphael@discussions.microsoft.com> a écrit dans le message de 
> news:92981543-EF18-481A-9B8B-804C60DF086E@microsoft.com...
> > Hi
> >
> > We have a CRM 4 Professional deployment installed in the following
> > environment:
> > CRM Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 
> > 32bit,
> > CRM 4 Professional, UR 6
> > SQL Server (Xenon Dual Core, 4GB RAM) -> Windows Server 2008 Standard 
> > 32bit,
> > SQL Server 2008 Standard, Reporting Services, SSRS DataConnector
> >
> > Within the local network CRM performance is very good (load of account 
> > form
> > <1s). But when our users establish a VPN connection to the corporate 
> > network
> > the performance of CRM isn't acceptable anymore (load of account form 8 -
> > 10s).
> > The users access CRM over the web client.
> >
> > Does anybody have similar performance issues when working with CRM over a
> > VPN connection?
> > Are there any settings which can be done on IIS?
> > Do you know any tools for troubleshoot the issue?
> >
> > Thanks everybody,
> > Raphael 
> 
0
bayareacrm (90)
12/10/2009 12:06:44 AM
Reply:

Similar Artilces:

Pop3 Connection Problem
Hi ... I have a problem that recently developed. Accounts that I have recently created will not download e-mail via pop3. I get event IDs 1011 and 1022 in the event log on the Exchange 2003 server. The user gets the following error: There was a problem logging onto your mail server. Your Password was rejected. Account: 'BobJones', Server: 'obiwan.specsci.com', Protocol: POP3, Server Response: '-ERR Logon failure: unknown user name or bad password.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92 Looking into the MS KBs I see references ...

How do I connect my e-mail accounts?
I have both AOL and Hotmail, and Outlook 2003 won't connect them. Do you know how I can connect them? My computer uses a wireless adapter to connect to a modem in another room. How do I make it so I can view both of my mailboxes in Outlook? Hotmail requires a paid account and the instructions for AOL are on their help pages. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. All unsolicited mail sent to my personal account will be deleted without reading. After furious head scratching, fb asked: | I have both AOL and Hotmail, and Outloo...

Inbound connection + form question
Hello, I just set up sharepoint server 2007 sp1 for the first time. It works like a charm internally. I've got a domain name and it is being forwarded to my external IP address which responds ok. However when I try to go to the web address I get a page cannot be displayed. I've got my port 80 being sent to sharepoint servers IP also internally from the router (netgear prosafe). What step am I missing here any ideas? Also I was wondering if there was a way to set up a "form" so to speak where a user could click on something, it would open up say a excel spreadsh...

New Exchange 2003 server
I've set up a brand new Exchange 2003 SP2 server for our migration off of Groupwise. I've been doing some testing with Outlook 2003, and it seems that ocassionally the client will loose connectivity with the server and give the "Bookmark not Valid" error. This only happens after I've been in outlook for a few minutes. Quitting out, waiting a minute, and relaunching will usually clear the error for a while. I'm running a Dell Poweredge 2950, dual Dual Core Xeons, 4GB of RAM, Windows 2003 R2 Standard, and that's it. Server is on a gigabit connection tied into our...

MS CRM 4.0 Performance Issue
Hi, Are there any ways with which we can monitor MS CRM performance? Or how MS CRM performance can be increased? (Considering opening a new record, save and close etc). As we have deployed MS CRM for one of the client and where MS CRM is supposed to do all the processing’s in a second or two. Help highly appreciated. Thanks Bharat ...

ODBC Connect error in Script Host Version 5.8
My Access/ODBC connection code is failing in Win7/Script Host 5.8. If it runs on V 5.6, it works. If it runs inside VbsEdit debugger, on Win7, it works. It FAILS running directly on either Win7 or Server 2008 R2 (V 5.8) I guess the basic question is what is different between V 5.6 and V 5.8? If the underlying OS/provider has changed, I think that would be the same when running either in or out of the VbsEdit debugger. I'm using the generic format: Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\mydatabase.mdb;Uid=Admin;Pwd=; (From ConnectionStrings.com) Specifically: ...

SOAP error when connect to project server
I have an installation of Project 2007 Professional w/SP2 and i've been trying to connect up to our Project server but i get an error saying that the Office SOAP toolkit component is not installed correctly. I have a mixed office environment, where Project 2007 is the only 2007 office product i'm using and the rest is office XP SP3. Has anyone got any ideas on how to solve this issue? This is a multi-part message in MIME format. ------=_NextPart_000_0079_01CA9A91.D92F4690 Content-Type: text/plain; charset="Windows-1252" Content-Transfer-Encoding: quoted-p...

Must be connected to the internet
I was warned that MS Money was junk. I was also warned that Vista was not even close to a true release version. I assumed that my degree in Software Engineering and decade of industry experience would ensure that the problems I was warned about would not happen to me. I was wrong. I have purchased a new quad core dell pc with Vista. I then purchase Money Plus Deluxe and spent around 8 hours importing my accounts, categorizing my expenses, setting up a budget, setting up bill payment, etc. Today I tried to open Money. Money prompted me that it required a software update in order to proce...

Connecting Points In An XY-Scatter Plot Graph
I made a data table to help me organize my workout schedule at the gym. On the X-axis I used the date, and for the y-axis I have weight. I have several different excersizes, and thus several different plots (on the same graph). I don't do every excersize every time so the points are some what scattered. The graph is a "XY (Scatter) with data points connected by lines." Ok. My problem is that the points of a line are only connected when I do the same excercise twice in a row (not row as in column). For example; on 04/06/06 and 04/08/06 I do bicep curls, the points are conne...

Create files and performance design
Hi, I've a MFC VC++ 6 program which needs to be updated to write out image (jpg, 640x480) files at a rate of 1s. What is the best approach in designing the writer class, such that, it does not block the main thread while the images are written onto disk? My initial thought is the put the Writer class onto a separate thread? What are my alternatives? >My initial thought is the put the Writer class onto a separate thread? What >are my alternatives? Overlapped IO - see the FILE_FLAG_OVERLAPPED option of the CreateFile API. Dave You have a couple choices here. One is to ...

Boosting performance of CRM reports
I seem to recall reading that it is possible to boost the performance of CRM reporting by starting a second APS session. Is this correct? Tks...Graeme Hi Graeme You may be referring to a second Crystal Pageserver service? This is possible, but you may wish to watch CPU % for both pageserver.exe services, to be sure they are both actually being used. You should find some improvement from increasing the crystal cache server, information on this is hard to come by. Try increasing it to 512Mb, the default is 5Mb, this is a soft cache and uses disk space. Just add this parameter to the e...

error PRJ0019: A tool returned an error code from "Performing Post-Build Event..."
Hi, I am getting this error error PRJ0019: A tool returned an error code from "Performing Post- Build Event..." Not sure how to get rid of it. Can anyone please help? I am not sure what more info you will need to help me? Please let me know Thanks TS On Aug 12, 10:33=A0pm, Trups <Samant.Tru...@gmail.com> wrote: > Hi, > > =A0 I am getting this error > =A0error PRJ0019: A tool returned an error code from "Performing Post- > Build Event..." > Not sure how to get rid of it. =A0 Can anyone please help? =A0I am not > sure what more info you will...

Connectung to GP via the VPN
Hello all I cannot seem to find any information on how to configure a client to do this. Does anyone know of any whitepapers etc that I can use to help me do this? Or does anyone know how? Thanks Saira There have been a ton of posts on this. You CANNOT connect GP through a VPN without using Citrix, Terminal Services, Remote Desktop, or "even" PC Anywhere if you have to. Search through this discussion group, and you'll fnd a lot of answers. Best regards Mike MG Consulting "Saira" <Saira@nomail.5DFinance.com> wrote in message news:ek0rCbqDJHA.1008@TK2MSFTNG...

SSL connection
Hi I'm helping an elderly lady set-up her new laptop. It has Windows 7 which I don't know as I am on XP. Her email (Windows Mail as part of the Office set she bought) gives me the following message. Can anybody help me sort it out? "The server does not support a SSL connection. Subject 'test again' Server Response: 250 8BITMIME Server: 'mail.btinternet.com' Windows Live Mail Error ID: 0x800CCC7D Protocol: SMTP Port: 25 Secure(SSL): Yes" -- Thanks a LOT in advance, Dave dave@willison.org ...

Unable to connect to outgoing e-mail server
After downloading (earlier this week) the latest security patch for Outlook XP, I received the following message: "Outlook is unable to connnect to your outgoing (SMTP e-mail server. If you continue to receive this message contact your Internet service provider." I contacted my ISP and their advice was to restore my previous version of Outlook (without the patch). I haven't taken that step yet. I can access my e-mail through Outlook Express, but I prefer Outlook. Advice? Delete and recreate your mail account. Ensure that if you are required to sign onto the incomin...

How can I get Outlook to connect to Novell?
I have a old Novell NetWare server. Probably about 10 - 15 years old. I don't know much about Novell. I have the client installed on the network properties. I can get to the Novell shares. I just don't know how to get the email out. They use GroupWise and are moving to Outlook 2003. I don't know how to connect Outlook 2003 to the GroupWise mail server. It doesn't use IP Addresses does it? It has an IPX number, but I'm not sure what to do. Any guidance is appreciated. See if the info here helps: http://www.slipstick.com/addins/services/enterprise.htm#groupwise &l...

Connection Failed! 01-03-10
Every so often, when I click my Local Area Network Connection icon, I get a Connection Failed! nastygram. The only solution seems to be to reboot. Then all is well, probably for days or even weeks. Then it happens again. Any idea why?? Perhaps the NIC went to sleep? See the Power management tab for it in Device Manager properties. chuck wrote: > Every so often, when I click my Local Area Network Connection > icon, I get a Connection Failed! nastygram. The only solution > seems to be to reboot. Then all is well, probably for days > or even weeks. Then it happens a...

Outlook 2003 continuously loses connection to Exchange server
This problem began when I changed to Outlook 2003. The icon in my sys tray intermittently shows a bang with the hover text error message "Connection to your exchange server has been lost". This gets so annoying when trying to read mail and I can't access it for 15-20 seconds. This is on a corporate network and my IM has been useless in debugging this. I never had this problem until I installed Outlook 2003. Any ideas? Do you have Outlook setup to use cached mode? >-----Original Message----- >This problem began when I changed to Outlook 2003. The >icon in m...

Connect Next Ponumber
Dear All, I was trying to create purchase order entry through econnect, and for that i was using getnextponumber procedure. But iam getting the following error, System.Runtime.InteropServices.COMException (0x80040154): COM object with CLSID {12F8A948-D2E1-428C-A025-92275430932B} is either not valid or not registered. Could any body help me in this issue please. Thanks in advance ...

Outlook 2007
Hi, On a local lan, outlook 2007 connecting to Exchange 2003. If the network connection is lost between the workstation and the exchange server and outlook is running and connected to the exchange server when the connection re-establishes (no regard for duration, quick or long) then outlook will NOT correct itself and reconnect. A white screen shows and you have to "force" a close and re-open. Any ideas on why this happens or is this just a product flaw? Thanks in advance, George Hi George, I'm getting same experience, I'm trying to analze what is causing it, certa...

flash pdd/mdd aritechture work fine but performance is poor
Dear all, I port flash fmdwrapperpdd code into my wince6.0 bsp , flashpart.dll call flashmdd.dll, and flashmdd.dll call flashpdd.dll, everything work fine. but recently a performance issue appeared: In fal/fmd artitechure , speed of read file is 9M/s, (test read a 10M file in serveral times,then get average speed), but in flash mdd aritechure, the speed only 5M/s, the question is seriously. and if i skip flashpart (maybe skip flash mdd) , just call ioctl supported by flash ppd, the speed is 9M/s, so i judged the question must caused by flashpart driver or Mdd layer, and...

Programmatically connecting to backend
I have an odd issue, wondering if someone might have seen this. Not sure whether this question is more appropriate here, in security, or if this is a network administration issue - but here goes... I've got a database split into front and back end. Back end is password protected. The front-end has some code that prompts the user for a password, and then links to the back-end. This was working perfectly well at the client site, up until a few days ago. They created a new folder on the server, and restricted access to only users who are allowed access to the database. All of a sudden,...

Connect to SQL Express database difficulties
I have just joined the "I'm sure I've missed something obvious club" I have VBExpress 2008 installed with SQL Express 2008 with the SQL Express management studio. I started building a prototype database in Management Studio: nothing complex, just a cascade of administratve tables to create a logical context for the real data. Next I created a project which would provide simple linked controls to populate the tables to see if the concept worked. Next I tried to Connect the Project to the Database. I thought this would be easy as I had already experimented with an ...

Outlook can't connect after KB842773 windows update
I reinstalled windows last weekend, and this morning my system automatically downloaded and installed update KB842773. All email functionality then stopped, with a "Cannot connect. Please contact your ISP." message. Neither Outlook nor Thunderbird could connect. Un-installing the patch fixed the problem, but of course I'd rather be up to date with my patches. (But would rather be vulnerable to viruses than have no email!) The info page about the fix didn't mention anything about affecting email. Any ideas? My web access was fine, and was chat (Gaim) continued to work. ...

retrieving connection string w/ ConfigurationManager
I am trying to store and retrieve connection string info from config file and I am having trouble retrieving the connection string info. I stored the info with the following: Configuration config = null; config = ConfigurationManager.OpenExeConfiguration(ConfigurationUserLevel.None ); config.ConnectionStrings.ConnectionStrings.Add( new ConnectionStringSettings( "MyConfigurationString", "Server=local;Database=Test;Password=password;User Id=john;" ) ); config.Save(); I then remove the Add method and use the following try to retrie...