Error converting lead to account

Hi,

I got an error message from CRM when I tried to convert a lead to an account.
This error is not consistency, sometime happen, sometime not.

My situation was I deactivated a lead and convert it to an account. The 
error said 
"Duplicate Record: A record with these values already exists. A duplicate 
record cannot be created. Select one or more unique values and try again." I 
did check everywhere in the account, there was no record that already exist.

I'm not sure that this error was created by CRM or c360 product because I've 
installed the c360 product in my CRM server. From my opinion, the error seems 
like generated by CRM.

Does anyone has the same problem as mine? How can I do to this situation?
Please help,
DK.
0
Utf
2/9/2006 6:35:27 PM
crm 35858 articles. 1 followers. Follow

7 Replies
540 Views

Similar Articles

[PageSpeed] 49

Hi DK,
CRM 3.0 does not have duplicate detection out-of-the-box. So I would say 
this is not a CRM error.

-- 
Manisha Powar (Madhusudanan)
Program Manager
Microsoft Dynamics - CRM

This posting is provided "AS IS" with no warranties, and confers no rights. 
You assume all risk for your use. � 2005 Microsoft Corporation. All rights 
reserved.
"DK" <DK@discussions.microsoft.com> wrote in message 
news:A166B0A2-CF48-42A2-BE87-21F3644ED0AD@microsoft.com...
> Hi,
>
> I got an error message from CRM when I tried to convert a lead to an 
> account.
> This error is not consistency, sometime happen, sometime not.
>
> My situation was I deactivated a lead and convert it to an account. The
> error said
> "Duplicate Record: A record with these values already exists. A duplicate
> record cannot be created. Select one or more unique values and try again." 
> I
> did check everywhere in the account, there was no record that already 
> exist.
>
> I'm not sure that this error was created by CRM or c360 product because 
> I've
> installed the c360 product in my CRM server. From my opinion, the error 
> seems
> like generated by CRM.
>
> Does anyone has the same problem as mine? How can I do to this situation?
> Please help,
> DK. 


0
Manisha
2/9/2006 8:11:51 PM
I think this is coming form the c360 tools


=======================
John O'Donnell
Microsoft CRM MVP
http://codegallery.gotdotnet.com/crm




"DK" <DK@discussions.microsoft.com> wrote in message 
news:A166B0A2-CF48-42A2-BE87-21F3644ED0AD@microsoft.com...
> Hi,
>
> I got an error message from CRM when I tried to convert a lead to an 
> account.
> This error is not consistency, sometime happen, sometime not.
>
> My situation was I deactivated a lead and convert it to an account. The
> error said
> "Duplicate Record: A record with these values already exists. A duplicate
> record cannot be created. Select one or more unique values and try again." 
> I
> did check everywhere in the account, there was no record that already 
> exist.
>
> I'm not sure that this error was created by CRM or c360 product because 
> I've
> installed the c360 product in my CRM server. From my opinion, the error 
> seems
> like generated by CRM.
>
> Does anyone has the same problem as mine? How can I do to this situation?
> Please help,
> DK. 


0
John
2/16/2006 5:56:23 AM
Thank you Manisha. I contacted c360 support to help me out. Just wait for the 
new release.

"Manisha Powar (MSFT)" wrote:

> Hi DK,
> CRM 3.0 does not have duplicate detection out-of-the-box. So I would say 
> this is not a CRM error.
> 
> -- 
> Manisha Powar (Madhusudanan)
> Program Manager
> Microsoft Dynamics - CRM
> 
> This posting is provided "AS IS" with no warranties, and confers no rights. 
> You assume all risk for your use. © 2005 Microsoft Corporation. All rights 
> reserved.
> "DK" <DK@discussions.microsoft.com> wrote in message 
> news:A166B0A2-CF48-42A2-BE87-21F3644ED0AD@microsoft.com...
> > Hi,
> >
> > I got an error message from CRM when I tried to convert a lead to an 
> > account.
> > This error is not consistency, sometime happen, sometime not.
> >
> > My situation was I deactivated a lead and convert it to an account. The
> > error said
> > "Duplicate Record: A record with these values already exists. A duplicate
> > record cannot be created. Select one or more unique values and try again." 
> > I
> > did check everywhere in the account, there was no record that already 
> > exist.
> >
> > I'm not sure that this error was created by CRM or c360 product because 
> > I've
> > installed the c360 product in my CRM server. From my opinion, the error 
> > seems
> > like generated by CRM.
> >
> > Does anyone has the same problem as mine? How can I do to this situation?
> > Please help,
> > DK. 
> 
> 
> 
0
Utf
2/16/2006 8:42:27 PM
Hi John and Manisha,

I did contact the c360 support, then they said it's not c360 problem. So I 
tried to uninstall the duplicate checking and test it again. It didn't work 
the same. So now I think it's CRM problem. 

I cann't convert a lead to Account, if I convert the lead to contact already.
But I can convert a lead to Account, if I don't convert it to contact.
And of course, I cann't convert a lead to Opportunity, Contact, and Accout 
at one time. 

Any idea, please help,
Thanks,
DK.

"John O'Donnell" wrote:

> I think this is coming form the c360 tools
> 
> 
> =======================
> John O'Donnell
> Microsoft CRM MVP
> http://codegallery.gotdotnet.com/crm
> 
> 
> 
> 
> "DK" <DK@discussions.microsoft.com> wrote in message 
> news:A166B0A2-CF48-42A2-BE87-21F3644ED0AD@microsoft.com...
> > Hi,
> >
> > I got an error message from CRM when I tried to convert a lead to an 
> > account.
> > This error is not consistency, sometime happen, sometime not.
> >
> > My situation was I deactivated a lead and convert it to an account. The
> > error said
> > "Duplicate Record: A record with these values already exists. A duplicate
> > record cannot be created. Select one or more unique values and try again." 
> > I
> > did check everywhere in the account, there was no record that already 
> > exist.
> >
> > I'm not sure that this error was created by CRM or c360 product because 
> > I've
> > installed the c360 product in my CRM server. From my opinion, the error 
> > seems
> > like generated by CRM.
> >
> > Does anyone has the same problem as mine? How can I do to this situation?
> > Please help,
> > DK. 
> 
> 
> 
0
Utf
2/27/2006 10:51:31 PM
I have experienced this error before and it is a core MS CRM error.
There is also another post related to this issue that I made when I
figured it out.

Go to the relationship mapping between Lead and Account (where it tells
what fields to go where when the conversion occurs) and remove any
relationship mentioning address1id or address2id. These are unique ids
used internally to CRM and when the conversion occurs it tries to
create records with existing unique IDs that then causes the "duplicate
record" error.

Derek

0
DerekH
3/1/2006 3:08:00 AM
Derek,
I tried from your solution, but it still has the error. I can convert a lead 
to be Opportunity and Account, can convert a lead to be Opportunity and 
Contact, but I cann't convert a lead to have Opportunity, Account, and 
Contact. It seems like I cannot have Contact and Account at the same time. 
Any idea?

Thanks,
DK.

"DerekH" wrote:

> I have experienced this error before and it is a core MS CRM error.
> There is also another post related to this issue that I made when I
> figured it out.
> 
> Go to the relationship mapping between Lead and Account (where it tells
> what fields to go where when the conversion occurs) and remove any
> relationship mentioning address1id or address2id. These are unique ids
> used internally to CRM and when the conversion occurs it tries to
> create records with existing unique IDs that then causes the "duplicate
> record" error.
> 
> Derek
> 
> 
0
Utf
3/1/2006 3:50:29 PM
There will be one of the ID fields in the mapping between "lead and
contacts" and "lead and accounts". The only legitimate ID field that
should be in the mapping (off the top of my head) is originatingleadid.
Do not take my word for it though as I do not have a system in front of
me to check with. Someone else may be able to shed some light on what
ID fields should be mapped. The other suggestion that might work is
telling the system to automatically redo the mappings, but I am unsure
if the auto redo function take the ID fields into account.

0
DerekH
3/2/2006 2:16:31 PM
Reply:

Similar Artilces:

Two mailboxes for one user account after mailbox moved to a new server
After moving a user's mailbox from a Exchange 2003 to a new Exchange 2003 server, Outlook has listed two mailboxes with same name in the "All Mail Folders"area. The Outlook profile only has the user mailbox and no other mailboxes added to it. The user can send and recieve email just fine. The mailboxes seem to be clones of each other. New mail show up in the mailboxes at the sametime. How can I get Outlook to only show one mailbox? Any help would be appreciated, thanks, ...

error sending from 5.5 to 2000
When a user sends from an exchange 5.5 mailbox to a user in exchange 2000, they receive the following error: The message was undeliverable because the recipient specified in the recipient postal address was not known at this address The MTS-ID of the original message is: c=US;a= ;p=Express-Scripts;l=TEMMS014-041001192533Z-210060 <mail5.express-scripts.com #5.1.1> The same user on the 5.5 server can send to other users on the 2000 server. I looked the error up in technet and got 3 kb articles with only 1, kb295377 being anything close to my problem. I checked the entr...

When launching Outlook I recieve the following error... please he
When launching Outlook 2003 I recieve the following error: The add-in "C:\PROGRAM~1\SPAMBL~1\Bin\461~1.0\SBOLExt.dll" could not be installed or loaded. This problem may be resolved by using Detect and Repair on the Help menu. I ran the Detect and Repair and that didn't work. I ran the repair option from Add and Remove Program in Control Panel and that didn't work. I also un-installed and then re-installed Outlook 2003 and that didn't work. I'm running Windows 2000. Any ideals...? Did you have something possibly called SpamBlocker installed at some point?...

Money 2006 file repair application error
I cannot delete an old account because I get a "file may be courrupt" error so I am trying to repair my 2006 file. Following the deirections, when the progress bar almost completes, I get an application exception and send an error report to MS. My event log has 2 app errors 1) Event Type: Error Event Source: Application Error Event Category: None Event ID: 1001 Date: 4/12/2006 Time: 10:47:26 PM User: N/A Computer: xxx Description: Fault bucket 02266399. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 42 75 63 6b 65 ...

Need a default email account for all users, need help.
I have a tablet PC running WinXP Tablet with Outlook 2003. This tablet will connect to our exchange server via VPN. How can I set it up so that everyone that logs onto their account can access one (the same) email account. The problem is that I dont know at this point all of the users however anyone using the tablet will use one generic email account. So how can I set Outlook to default to this account so that no matter who logs on they will use this account? Thanks! Shane ...

unable to access mail after re-enable account
Hi, After enable an disable account and change its password, it can login to its mail account. What's happening. Is it normal? Thanks a lot What is the error message when user tries to access mailbox? Does the user still show in ADUC has having Exchange attributes? Have you looked at the MB using ESM to see if it is disconnected? "Raymond" <anonymous@discussions.microsoft.com> wrote in message news:136c01c46f11$d16f8390$a301280a@phx.gbl... > Hi, > > After enable an disable account and change its password, > it can login to its mail account. What's hap...

Business investment accounts?
Does anybody know how to add an investment account under the business catergory? Money forces you to make them personel accounts and I am becoming extremely frustrated. Doesn't anybody at Microsoft realize that companies make investments too!? I am new to this program, but I cannot find it either. My guess is that = Home and Business is designed for small home businesses that are not too = far along. If your company is far enough along to have its own = investment accounts (are you incorporated?) then you probably need to go = to something like Quickbooks and separate your business a...

Error #2950
Hi, I have three tables from which data I use to create a single table. The data is entered into the three tables via a form. I have a macro set up to create/update the single table through some make table queries and update queries of data within the first three tables. I have this macro tied a close form event and I keep getting a 2950 error when in a multiuser environment however the macro works in a single user envioronment. I only really need to have the single table updated daily. Do you have any good tips on error handling procedures so I can skip running of the qu...

is DCOM error 0x00080012 (Not all the requested interfaces were available) not an error ?
Im checking the return value of a DCOM call by using the macro: FAILED(HRESULT). One particular function call returns the error 0x00080012 (Not all the requested interfaces were available) if the DCOM service is down. Calling FAILED with this HRESULT returns false, meaning that it isnt an error! I think it should be reported as an error as my program cannot call ANY interfaaces beyond this point and crashes. The FAILED macro checks the HR to see if it is negative and 0x00080012 is positive!? Any suggestions? Thanks Andy ...

Exchg2003 First Storage Error
Exchange Enterprise 2003, SP1 on Win2003 - When I attempt to view the mailbox information store within First Storage Group I get an error (Id no. 80040d1b). The only ref. to this error I have found is: http://support.microsoft.com/default.aspx?scid=kb;en-us;817309 - checked my registry & server - they match; registry looks fine. I also am getting Veritas Exchg Info Store errors - "database corrupted". I ran the Eseutil defrag - ran successful, but still can't see mailboxes. I found MS tech net info that suggests re-installing Exchange (to repair): http://www.micr...

Error saving a Shared Workbook
I have a user using a shared workbook and gets an error everytime she does this ONE specific change. She deletes a line and then saves and gets a message that says, "EXCEL.exe has generated errors and will be shutdown by Windows... blah blah blah". If she makes anyother type of changes it saves just fine. I also had another user do the SAME change and that person also got that error message. When the file is changed to "Not Shared" then the line is deleted it saves fine also. The problem is obviously with the file itself and that is shared out. can anybody ...

I can no longer convert my files to pdf
I have Publisher 2003 and yesterday, my pdf menu on the top left disappeared and I can no longer convert my Publisher files to pdf. I've even uninstalled/reinstalled the Adobe Acrobat 7 and have also updated to 7.8 but still no luck. The next step was to uninstall and reinstall Publisher and still no luck. Any one know what may be the problem? Thanks. How are you trying to convert your files? When happens when you try? -- JoAnn Paules MVP Microsoft [Publisher] "darrellm" <darrellm@discussions.microsoft.com> wrote in message news:A78B7B52-981D-4FB7-8625-EAD9...

Outlook error message #4
Microsoft Visual C++ Runtime Error. What's the problem? ...

Error Code 80070424 12-21-09
I keep getting this Windows update error every time I boot my PC. In the window, it says Windows can't check for updates. Does anyone have any ideas? Recently I installed BitTorrent so could that be my problem? "Norm" <Norm@discussions.microsoft.com> wrote in message news:D2E5CF0C-D31B-4034-B4A8-A8204763A623@microsoft.com... > I keep getting this Windows update error every time I boot my PC. In the > window, it says Windows can't check for updates. Does anyone have any > ideas? > > Recently I installed BitTorrent so could that be my proble...

Is there a way to convert OE 03 form templates?
I have a user that has upgraded from outlook 2003 to outlook 2007 and has a form template from 2003 that is in a FDM extension. Outlook 2007 is unable to read this form. Is there a way to convert this form, or will the user just have to create a new form with their new version of outlook? Any information appreciated. Thanks, -AllenK What happens when you try to install the form? Any error message? -- Robert Sparnaaij [MVP-Outlook] Coauthor, Configuring Microsoft Outlook 2003 http://www.howto-outlook.com/ Outlook FAQ, HowTo, Downloads, Add-Ins and more http://www.ms...

Installation errors. 01-09-04
I'm setting up CRM 1.2 on a completely clean test environment of windows 2000 servers. Near the end of the installation a message pops up "Setup was unable to register the security service." What could be causing this The usual story: To get the MCCRMSecurityService starting, have you tried re-registering it as follows: On your crm server, at command prompt, go to program files - microsoft crm - bin, then run these commands crmsecurityservice -u crmsecurityservice -r -s Peter Lynch "J. Bridger" <Bridger@nospam.ofllc.com> wrote in message news:0aa001c3d6...

Error in Code
Following is some VBS code I have in my Custom Form developed in Outlook 2003. Line 61 is giving me an error stating: Object doesn't support this property or method: 'Item.GetInspector.ModifiedFormPages' Line No: 61 If you look Line 51 is the same method and it works fine. The funny thing is when I run the code, I get the error, I continue on to the Form, and the code after it works. The code that follows line 61 is dependent on line 61 as evident by if I ' comment it out, I get a separate error asking for objPage2. The code also works if I change the value of one of...

modify contact address when account address gets modified
Hi, How do I ripple my changes from company level to the related contacts ? For example the main company phone number and the main address ? Do I need a product like Scribe for this, or can this be done with the workflow ? Thanks for any advice Wim You can't do this with workflow, and I don't believe Scribe can do this (though I may be wrong - I've only used Scribe for one project). I would think that you'd need to create a post callout using the SDK. There is more info at http://msdn.microsoft.com/library/default.asp?url=/library/en-us/CrmSdk1_2/htm/v1d2microsoftcrmversi...

Active X error
I have tried removing the signature, unchecking the Smart Tags, changing the editor to Plain Text as well as to Rich text all to no avail....here is the error one of my users gets when she tries to send and email from Outlook - she can receive just fine: "One or more ActiveX controls could not be displayed because either: "1) Your current security settings prohibit running ActiveX controls on this page, or "2) You have blocked a publisher of one of the controls. As a result, the page may not display correctly." ...

Errors found Code 80070490
This appears to be one of those problems that no one seems to have a working solution. Reinstalling an operating system is not a solution it’s a reason to change operating systems. This type of problem was not supposed to happen with Vista. Let’s see some big guns on this one! Update Error: Some Updates not installed: 2 Failed updates (KB967723, KB972145) Errors found Code 80070490 (Unknown Error) Problem signature: Problem Event Name: WindowsUpdateFailure ClientVersion: 7.4.7600.226 Win32HResult: 80070490 UpdateId: AE2C61ED-AC12-4369-BED6-4375CD79CA...

OWA - change password
Getting the "Object Required" error, when somebody is trying to change their password through OWA. (Win2003/Ex FE 2003) Any ideas what could be causing this? TIA! / Per Did you follow the steps in: http://support.microsoft.com/kb/297121 ? -- Pablo D. Vernocchi Microsoft Exchange MVP MCSA + M / MCSE + Sec https://mvp.support.microsoft.com/profile=8E94A6C0-F6D9-4686-96D5-04230CC0141F http://www.itpros.com.ar http://www.msglue.org http://msmvps.com/exchangebloglatino "Per Hagstrom" <per.hagstrom@swic.eduNOSPAM> wrote in message news:Ojo%23EozNHHA.1240@TK2...

How do I convert spreadsheet from Canadian $ to American $?
The Euro conversion is not doing it for me. I am working with Canadian funds and American funds. I am desperate! Assuming the Exchange rate be .70.........type that in an unused cell, say X1, then highlight it Right-click and do Copy, then select the cell(s) with the Canadian funds therein (assuming no formulas) and do Right-click > PasteSpecial > Multiply....... Vaya con Dios, Chuck, CABGx3 "Samantha" <Samantha@discussions.microsoft.com> wrote in message news:8A43A210-BA3E-4ECC-AA07-B81D3A548D73@microsoft.com... > The Euro conversion is not doing it for me. I am...

iisadmpwd change pw gives error
Just cannot get password change to work on Exchange2003 (front-end server) & IIS 6.0 Is this a known issue Any help would be greatly appreciated. It could be that you are not (yet) allow to change your password either because password change is prohibited or because user has to wait for x days before he is allowed to change his password (domain policies). Whenever you reset a password for a user and the 'Cannot change pass before X days' is enforced, the user is not allowed to change it. David. "ss" <anonymous@discussions.microsoft.com> wrote in message news...

hide/close/delete shared account
(bear with me. i'm new and although this is my second time trying to set up money, i've run into the same problem and have yet to find the answer in the forum.) i have four bank accounts and one is shared with a family member. i don't want this account to show up at all in money essentials. i tried "closing" it. i tried "hiding" it. i tried "deleting" it. but each time i go back to "categorize my transactions," transactions from that account are still there. The problem here is that Money is designed (and Money Essentials (MEss) even ...

VLookup #VALUE! error help needed to resolve
The following is the funcation I have: =VLOOKUP(B10,'FA CC Summary Report 1141'!F$9:G$92,2,0) I have all the columns formatted the same; as in the column that the function is using to lookup is text and so is the column for this figure in order to pull back the appropriate answer. I have keyed the data instead of having links. I have replaced the final '0' with TRUE & FALSE then put it back. I have formatted the columns for text and for numbers. But I am getting the #VALUE! error in SOME of the cells NOT all of the cells. I don't know what else to d...