Email Router Failing with System.UriFormatException: Invalid URI:

I cannot seem to get a handle on this, even with a very basic email workflow 
rule.
The rule is simply to watch test@mydomain.com.  If any email goes in, send a 
notification email to user@mydomain.com

The Server has the following error.   Anyone have any ideas?



Event Type:	Error
Event Source:	MSCRMExRouterService
Event Category:	None
Event ID:	0
Date:		1/21/2007
Time:		4:01:50 PM
User:		N/A
Computer:	IAHSR0002
Description:
System.UriFormatException: Invalid URI: The hostname could not be parsed.
   at System.Uri.Parse()
   at System.Uri..ctor(String uriString, Boolean dontEscape)
   at System.Uri..ctor(String uriString)
   at System.Web.Services.Protocols.WebClientProtocol.set_Url(String value)
   at 
Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger 
logger, ExchangeSinkServiceMailbox mailbox, Message message)
   at 
Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMessage(Connection 
connection, ExchangeSinkServiceMailbox mailbox, Recordset recordSet)
   at 
Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMailbox(ExchangeSinkServiceMailbox mailbox)

For more information, see Help and Support Center at 
http://go.microsoft.com/fwlink/events.asp.

0
Nangard (25)
1/21/2007 10:08:00 PM
crm 35858 articles. 1 followers. Follow

2 Replies
747 Views

Similar Articles

[PageSpeed] 8

OK, so I fixed that. Turned out the email user that was the CRM sender got 
added to CRM.  Now I have this error. It looks like an error I have had for a 
while, but I didn't know it because I was getting the end result. So, anyone 
know anything about this one?

Event Type:	Error
Event Source:	MSCRMWorkflowService
Event Category:	None
Event ID:	16649
Date:		1/21/2007
Time:		5:13:00 PM
User:		N/A
Computer:	IAHSR0002
Description:
Condition {186BA2FA-93A9-DB11-B082-001143E8043A} failed in step 
{136BA2FA-93A9-DB11-B082-001143E8043A} of process instance 
{FE6AA2FA-93A9-DB11-B082-001143E8043A}. Please view the paused rule in the 
Microsoft.Crm.Workflow.Monitor for more information about the failure.

For more information, see Help and Support Center at 
http://go.microsoft.com/fwlink/events.asp.

"Nangard" wrote:

> I cannot seem to get a handle on this, even with a very basic email workflow 
> rule.
> The rule is simply to watch test@mydomain.com.  If any email goes in, send a 
> notification email to user@mydomain.com
> 
> The Server has the following error.   Anyone have any ideas?
> 
> 
> 
> Event Type:	Error
> Event Source:	MSCRMExRouterService
> Event Category:	None
> Event ID:	0
> Date:		1/21/2007
> Time:		4:01:50 PM
> User:		N/A
> Computer:	IAHSR0002
> Description:
> System.UriFormatException: Invalid URI: The hostname could not be parsed.
>    at System.Uri.Parse()
>    at System.Uri..ctor(String uriString, Boolean dontEscape)
>    at System.Uri..ctor(String uriString)
>    at System.Web.Services.Protocols.WebClientProtocol.set_Url(String value)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger 
> logger, ExchangeSinkServiceMailbox mailbox, Message message)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMessage(Connection 
> connection, ExchangeSinkServiceMailbox mailbox, Recordset recordSet)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMailbox(ExchangeSinkServiceMailbox mailbox)
> 
> For more information, see Help and Support Center at 
> http://go.microsoft.com/fwlink/events.asp.
> 
0
Utf
1/21/2007 11:25:00 PM
OK, that is fixed. It was because someone had but the crm email box into the 
system as a user. So, anyone have any ideas on this one?


Event Type:	Error
Event Source:	MSCRMWorkflowService
Event Category:	None
Event ID:	16649
Date:		1/21/2007
Time:		5:13:00 PM
User:		N/A
Computer:	IAHSR0002
Description:
Condition {186BA2FA-93A9-DB11-B082-001143E8043A} failed in step 
{136BA2FA-93A9-DB11-B082-001143E8043A} of process instance 
{FE6AA2FA-93A9-DB11-B082-001143E8043A}. Please view the paused rule in the 
Microsoft.Crm.Workflow.Monitor for more information about the failure.

For more information, see Help and Support Center at 
http://go.microsoft.com/fwlink/events.asp.

"Nangard" wrote:

> I cannot seem to get a handle on this, even with a very basic email workflow 
> rule.
> The rule is simply to watch test@mydomain.com.  If any email goes in, send a 
> notification email to user@mydomain.com
> 
> The Server has the following error.   Anyone have any ideas?
> 
> 
> 
> Event Type:	Error
> Event Source:	MSCRMExRouterService
> Event Category:	None
> Event ID:	0
> Date:		1/21/2007
> Time:		4:01:50 PM
> User:		N/A
> Computer:	IAHSR0002
> Description:
> System.UriFormatException: Invalid URI: The hostname could not be parsed.
>    at System.Uri.Parse()
>    at System.Uri..ctor(String uriString, Boolean dontEscape)
>    at System.Uri..ctor(String uriString)
>    at System.Web.Services.Protocols.WebClientProtocol.set_Url(String value)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceMessages.CheckIncoming(ExchangeSinkServiceLogger 
> logger, ExchangeSinkServiceMailbox mailbox, Message message)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMessage(Connection 
> connection, ExchangeSinkServiceMailbox mailbox, Recordset recordSet)
>    at 
> Microsoft.Crm.Tools.ExchangeConnectorService.ExchangeSinkServiceCore.ProcessMailbox(ExchangeSinkServiceMailbox mailbox)
> 
> For more information, see Help and Support Center at 
> http://go.microsoft.com/fwlink/events.asp.
> 
0
Utf
1/21/2007 11:26:02 PM
Reply:

Similar Artilces:

outlook 2007 no problem receiving email but problem sending
I have no problem sending and receiving emails when connected at work but from home, I can receive new messages but there is a problem sending. I get the message Sending reported error 0x80042109. Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue receiving this message contact your server administrator or ISP. Any ideas please. Thanks, Charlie Have you verified with your corporate mail admin already that the settings have been correct for usage outside of the company network and if this is indeed fully supported by your corporation? If so,...

I just activated office2003 S&T ver, cannot reply to emails
my reply icons are grayed out, I can see all incoming msg, but cannot reply In news:28E0E702-5CE2-4C2A-B033-EC618ECF90EE@microsoft.com, txcowboy <txcowboy@discussions.microsoft.com> typed: > my reply icons are grayed out, I can see all incoming msg, but cannot > reply What type of e-mail account do you use? Are you running all the Office/Outlook updates, including SP1? I got it resolved. Don't know how for sure. I am running MS office outlook 2003 I think I needed to authenticate to MSN Passport by login in. before it allowed me to do replies. All this security and I ...

how to convert to metric system in visio 2003?
how to convert to metric system in visio 2003? On Tue, 3 Mar 2009 00:00:00 -0800, alsari <alsari@discussions.microsoft.com> wrote: >how to convert to metric system in visio 2003? Don't be reluctant to tell us what you want to do. We can only guess otherwise. Do you want to use metric rather that imperial measurement templates and stencils? Do you want to convert current diagrams to metric? Do you just want to show measurements in metric units? Metric templates and stencils may not have been installed on your system. Use menu Tools -> Options to set the default measurement t...

OE6 fails after installing Office 2000
The help of the assembled multitudes is welcomed: I tried to install MS Office 2000 Premium into an environment containing MSIE6.0 and Outlook Express 6.0 (with full SP updates.) OS is Windows ME, also with full updates. Result was corruption of Outlook Express. I could view email headers and previews, but could not launch email messages and/or print them. Further, the addressbook disappeared. When I tried to access address book, I was told that the system was improperly installed and I should reinstall. Removing Office 2000 from the system restored functionality to Outlook Express. I ...

Inserting the email
Hi There I have a data base of users at our company and wish to know how to insert "@(emailaddress)" after every user in all 5000+ cells and is it possible to import this list to outlook ? please help Nik excell newbie Are they all @thesame.com? If your data is in one column, I'd insert a new column and use a formula: =a1&"@emailaddress.com Copy|paste special|values and toss the original column. And if you save the file as a .csv (comma separated values), then you can specify that inside Outlook for importing. (I might even export the existing contacts as a ....

Display System Time running real time
Hi how to display the system date time running real time in Dialog, including seconds ? I know declaring like: SYSTEMTIME systime; ZeroMemory(&systime,sizeof(SYSTEMTIME)); GetSystemTime(&systime); // gets current time then access the SYSTEMTIME structure: typedef struct _SYSTEMTIME { WORD wYear; WORD wMonth; WORD wDayOfWeek; WORD wDay; WORD wHour; WORD wMinute; WORD wSecond; WORD wMilliseconds; } SYSTEMTIME; but how to get it running in realtime as it elapses seconds by seconds like 8:56:01 AM Monday, December 02, 2008 ......

Strange outlook receiving email problem
New to this forum, hopefully you guys can help. One of my customers was having a weird issue... the whole building is on a network/domain. Everyone is set up to use outlook/ pop3. Nobody is having problems except two employees. For some reason they can't receive emails from each other. Using web mail everything works fine. Creating emails from the web mail the email is sent and received in outlook. But sending emails from outlook do not make it to the other persons outlook. Now the weird part is that these two people communicate just fine with everyone else. They can send and receive emai...

Default email server
Version: 2004 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel Email Client: pop I am changing from cable broadband to ADSL2. Internet and email from my new address are working fine but I cannot get mail from my old address to forward through the new server. It appears that the old setting has a default to the old server that I cannot over ride. The sending mail setting in the old account has been changed to the new setting. Anything that I also need to do? Thanks in anticipation On 2010-03-03 00:54:42 -0500, Gary_Lawrence@officeformac.com said: > I cannot get mai...

Re-Reciving emails.
Dear All How can I receive only newermails after reinstalling my outlook ?? Accidently I have to reinstall my microsoft Outlook. So I saved my mails in other folder. After reinstalling and opening again my old mails I started to receive to e- mails. But at that time I have to receive emils already present in my inbox. So I have to wait long long time to read my newer mail. So please tell me if there any way to receive only new mails after office reinstallation.... Thanks... Zaw Ye There is no way to do this. The information about which messages have already been receiv...

REPLY AS who email was TO.
"User A" recieves "User B". That is emails sent to "User B" are being forwarded to "User A". "User A" also has permissions to "Send on behalf" of "User B". When "User A" replys to an email that was addressed to "User B", it appears to come from "User A" unless he manually selects the reply to be from "UserB". How can I make ANY replys to "User B"'s emails appear to come from "User B" WITHOUT User A having to manually change the default? (Ofcoarse, when &...

MSN email acc in Outlook 2003
Hi. I'm a Hotmail Plus user but it seemed that I can't use the Outlook 2003 to retrieve my emails. The error: Task 'MSN: Folder: Inbox Synchroning headers.' reported error (0x800CCF4): 'An unknown error has occured. Please save any existing work and restart the program.' This error occurs only with MSN email account. The error still occurs even though I removed and added the account again. I even restart Outlook and it still the same thing. I tried adding my msn email account at work using Outlook 2003. It works there but apparently, not at home. I tried on...

limit the size of imbound/outbound emails
We use Exchange 2003, how can we limit the size of emails coming imbound and going outbound? Thanks AW Yes. See article Q322679: How to set limits for messages in Exchange Server. "SW" wrote: > We use Exchange 2003, how can we limit the size of emails coming imbound and > going outbound? > > Thanks > > AW ...

Quick Campaign: More than 1 email is sent out
Hi All, I have big problem in the email campaign module. Everytime I run quick campaign, there will be more than 1 email is sent out to each contact record. Currently, I find out that there are 3 emails sent for each contact. Does anyone know how to solve this problem? Thanks. On 25 jul, 13:14, Gunady <Gun...@gmail.com> wrote: > Hi All, > I have big problem in the email campaign module. Everytime I run quick > campaign, there will be more than 1 email is sent out to each contact > record. Currently, I find out that there are 3 emails sent for each > contact. Does anyone ...

wireless router question from a dummy
Have high speed internet. Have a 3gbsdram. And I have a router that is a g. Would I benefit as far as computer speed on the net with a router that is an n router. Also even though the computer says 802.11 a/g/n wireless I still would have to buy the the adapter that goes into the notebook? I know nothing about routers and the fact we have a g router it doesn't have an adapter needed for the computer to work. Was wondering if that is the same case with a wireless n router? thanks How do you connect to the net? Do you have more than one PC? "iluv my kitties and family&...

Email Notifications #3
I have set up an Exchange 2003 Server and everything works fine, but I have complaints that the email notification in the Web Outlook Access is not working for AD users. It works for admin accounts but not a standard user, do they need to be in a certian group in order for it to work for them. It does work for them as long as the Outlook Web Access window is maximized and on top of everthing else. On Fri, 24 Feb 2006 23:30:04 -0800, New email notifications in OWA <New email notifications in OWA@discussions.microsoft.com> wrote: >I have set up an Exchange 2003 Server and everyt...

Outlook cannot 'send' email????????
Hi Suddenly (it was working a few days ago) my Outlook 2003 on windows XP cannot 'send' email. It gets a permissions error. I have no problem downloading email, I can even add new contacts and appointments to the Outlook servers but emails will not go. I do not have this problem in Outlook 2001 for Mac or on another Windows XP box with Outlook 2003 and as I said it was working fine on this machine until a few days ago. Does anyone have any ideas????? Robin What is the exact error? --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. ...

Outlook constantly sends Phantom email
Running Outlook XP, I have no messages in outbox yet there is a 'sending message 1 of 1' indicator. It shows up every time it checks for new mail. I get a mail send error each time after it times out. Is this some sign of virus? Jerry <anonymous@discussions.microsoft.com> wrote: > Running Outlook XP, I have no messages in outbox yet > there is a 'sending message 1 of 1' indicator. It shows > up every time it checks for new mail. I get a mail send > error each time after it times out. > > Is this some sign of virus? More likely it's an undeliv...

Workflow Rule for Allowing Email
I want to update all of our current accounts with a manual workflow rule that will update the contact method on the administration tab in accounts to reflect "Allow" for Email. When trying to setup this rule, I set the "donotemail" field to false (0), but when I apply that rule, it doesn't change anything (I've also tried "donotbulkemail"). Any ideas how to make a workflow rule that will update this field from "do not allow" to "allow". -- Brandon IT Director Presentations Direct - Office Equipment & Supplies http://www.pre...

Email looping problem
Hi, We have recently taken over another company and I need to get the users at the new companies site to be able to receive emails in the format of our companies email e.g. both sites need to receive emails sent to joe.bloggs@xyz.com We have setup recipient policy on the new companies exchange to accept emails for our companies domain. We have also set the SMTP virtual server at each site to "forward email with unresolved recipients" to the public IP address of the other. The problem here is that when an email is sent to a user that doesn't exist both exchange servers w...

Total no of sent email
In Exchange 2003, a) Anyway to track which user has sent out the most email or least email(regardless of internal or external)? b) i can view the user storage used. anyway to export it as i want to file as report. "2Tian" <cmchong20@yahoo.com> wrote: >In Exchange 2003, >a) Anyway to track which user has sent out the most email or least >email(regardless of internal or external)? The message tracking logs hold the information you want. Now all you need is a way to extract that information, store it, and arrange the storage in a way that will let you query it fo...

EMail replies 12-12-05
Hi, We are trying to setup a support process using CRM 3.0 Pro. A queue has been created and is being populated using the router from e-mails coming in to support@company.com. When people are replying to e-mail in this folder the reply-to address is set to the logged on user. Is there an easy way to define that the reply-to address should be support@company.com for specific e-mails? Regards, Manso ...

System.Runtime.InteropServices.ExternalException
Hi, I get this exception when I try to run my program on a Windows 98 + NET Framework 1.1, if I run it on a Windows XP + NET Framework 1.1 it works fine... This is the rest of the message: ************** Texto de la excepci�n ************** System.Runtime.InteropServices.ExternalException: Error gen�rico en GDI+. at System.Drawing.Graphics.CheckErrorStatus(Int32 status) at System.Drawing.Graphics.DrawString(String s, Font font, Brush brush, RectangleF layoutRectangle, StringFormat format) at System.Drawing.Graphics.DrawString(String s, Font font, Brush brush, Single x, Single y)...

Outlook is deleting or archiving my emails after two weeks
I need to have these emails for my work. I cannot be looking around for them, or not have them at all. Please help me figure out where these emails are going so I can stop it. Thank you. Climbmaniac Tools > Options> Other > Autoarchive > UNCHECK Deleted Mail and definately UNCHECK Permantly delete old items. Arend "Climbmaniac" <Climbmaniac@discussions.microsoft.com> wrote in message news:4EF1AD1F-1B74-4581-9B96-14559684F6BA@microsoft.com... >I need to have these emails for my work. I cannot be looking around for > them, or not have them at all. >...

disappearing emails #5
I would appreciate any advice anyone has to offer. On a senior partners laptop he is using Outlook 2003 (Windows 98 OS). He has loads of emails in his inbox (was in the vicinity of 4000, he has now reduced this to 1800). He keeps all his old emails for reference. WHen he picks up emails, the computer shows that it is receiving eg 4 new emails, but they don't actually turn up in his inbox. I have checked for any message rules, and there aren't any. The inbox shows that there are 241 new messages, but when you scroll through the inbox, you can only see 59! Oddly enough, ...

Yahoo Email Search Function Not Working
If there is a more appropriate group to post to please advise. Lately I have been unable to use the search mail function in Yahoo mail ( beta or otherwise ). All that comes up is a blank stripped down Yahoo page. Is there a problem with the Yahoo mail search function? TIA. A more appropriate place would be on Yahoo!s pages. Yahoo! has nothing = to do with Microsoft Outlook. --=81 Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. All unsolicited mail sent to my personal account will be deleted without reading. =20 After furious head scratching, ph...