CRMv3 Reports suddenly stopped working

CRMv3 was set up months ago and has been working fine until a few days ago 
when a user alerted me that they were getting the standard "Error Check with 
Sys Admin" message when they tried to access Reports.  

EVERYTHING appears to be set up correctly - ODBC, the Reporting Config ... I 
even reinstalled the Reporting service.  I have tracing turned on and can see 
errors occurring but I do not know how to interpret what I see.  Also, as a 
result of playing with this for a few days I managed to get my server to 
start throwing 107 Events (Report Server Windows Service (MSSQLSERVER) cannot 
connect to the report server database) every 60 seconds. 

The error I see in the tracelogs reads:

Error Message: Could not find a part of the path "c:\Program Files\Microsoft 
CRM\CRMWeb\ReportServer\ReportService.asmx"

But this is not where the Reporting Server is located in IIS and this value 
isn't anywhere in the MSCRM registry keys.

In IIS, the CRMAppPool lists the following:

ROOT <Microsoft CRM v3.0>
Reports <Default Web Site>/Reports
ReportServer <Default Web Site>/ReportServer
MSCRMServices <Microsoft CRM v3.0>

And this matches the setup I have, with the Reports and ReportServer virtual 
directories located in the Default Web Site and everything else running from 
CRM v3.0

Anyone know how to get my Report service restored?  Thank you for any help 
you can offer!

Justin
0
2/23/2008 12:00:01 AM
crm 35858 articles. 1 followers. Follow

2 Replies
502 Views

Similar Articles

[PageSpeed] 3

check your rollup update 2.

Also see report configuration manager is running fine.

then what error you are getting ???

-- 
Regards,

MS CRM Certified Professional


http://microsoftcrm3.blogspot.com

Chat with me on MSN / Gmail / Skype : ID Is :.. mscrmexpert@gmail.com



"Justin Admin" wrote:

> CRMv3 was set up months ago and has been working fine until a few days ago 
> when a user alerted me that they were getting the standard "Error Check with 
> Sys Admin" message when they tried to access Reports.  
> 
> EVERYTHING appears to be set up correctly - ODBC, the Reporting Config ... I 
> even reinstalled the Reporting service.  I have tracing turned on and can see 
> errors occurring but I do not know how to interpret what I see.  Also, as a 
> result of playing with this for a few days I managed to get my server to 
> start throwing 107 Events (Report Server Windows Service (MSSQLSERVER) cannot 
> connect to the report server database) every 60 seconds. 
> 
> The error I see in the tracelogs reads:
> 
> Error Message: Could not find a part of the path "c:\Program Files\Microsoft 
> CRM\CRMWeb\ReportServer\ReportService.asmx"
> 
> But this is not where the Reporting Server is located in IIS and this value 
> isn't anywhere in the MSCRM registry keys.
> 
> In IIS, the CRMAppPool lists the following:
> 
> ROOT <Microsoft CRM v3.0>
> Reports <Default Web Site>/Reports
> ReportServer <Default Web Site>/ReportServer
> MSCRMServices <Microsoft CRM v3.0>
> 
> And this matches the setup I have, with the Reports and ReportServer virtual 
> directories located in the Default Web Site and everything else running from 
> CRM v3.0
> 
> Anyone know how to get my Report service restored?  Thank you for any help 
> you can offer!
> 
> Justin
0
mscrmexpert (134)
2/25/2008 3:57:11 PM
Imran, thank you for the response.  The rollup update 2 seemed fine though I 
reinstalled just to be sure.  The report config manager informs me that 
everything is okay.  

From the server that CRM runs on, if I go to http://server/Reports or 
/ReportServer I get a prompt to log in just like normal but after logging in 
I get a 404 error for either page (the user doesn't matter, the result is the 
same).

If I restart the Reporting Service I get a single 119 Activation error:
Report Server Windows Service (MSSQLSERVER) has not been granted access to 
the catalog content.

Followed by additional 107 errors every 60 seconds:

Report Server Windows Service (MSSQLSERVER) cannot connect to the report 
server database.

Any ideas based on this information?  Thank you Imran!

Justin

"Imran-mscrmexpert" wrote:
> check your rollup update 2.
> Also see report configuration manager is running fine.
> then what error you are getting ???

0
2/26/2008 8:25:00 PM
Reply:

Similar Artilces:

SFO Outlook Client Does NOT Work But WILL Go Offline
Hello, here are the symptoms: 1. Outlook client is installed, MSDE Service Manager is running. 2. Forms are installed. Have cleared cache several times. 3. Shortcut Icons show up, when clicked error results. Error: Access is denied: 'Microsoft.Crm.Platform.ComProxy'. 4. Have run the steps in TK 872585. Snapshots generate. 5. Enterprise Manager "sees" SFO client but does not register. Error: Cannot connect or access is denied. Despite this the SFO client WILL go offline, it just won't show the forms in Outlook. Thanks! JB check the value in the CRM registry in the cl...

page # on MRP exception report
Anybody know how to get page numbers on the MRP Exception Report? I tried adding the page number field but all it prints is a 0. The existing page number field that prints in the RH is called Page No. but i can't find it in the Tools to select and I dont think you can copy and paste a field from the report. The only selection is from Globals and that is "Page Number". Doesnt seem to work the same. Any help is appreciated. Hi Wes, This is an issue that we are addressing in the next release (8.5) that is due out later this year. In the mean time, I was able to get the page...

CRM task does not work in outlook
The service stopped working after a few days. If I tried to click the buttons(CRM task) on the tool bar, nothing would happen. (It used to come up a pop up windows for me to create th. The CRM contact and CRM E-mail stills works, so it shouldn't be a popup windows Anyone has a solution. Regards Clear the Outlook Forms Cache. See Techknowledge for articles on how to do this if you are unsure. This will solve this (very annoying) problem. Dave "edgard" <anonymous@discussions.microsoft.com> wrote in message news:2de9101c46aa8$6645d8c0$a501280a@phx.gbl... > ...

How do I stop Outlook from closing Word after using email?
Every time I write or read an email, Outlook will close Word when I'm finished. How can I stop this? Thanks. Version of Outlook? Is word closed in task manager? -- Diane Poremsky [MVP - Outlook] Author, Teach Yourself Outlook 2003 in 24 Hours Coauthor, OneNote 2003 for Windows (Visual QuickStart Guide) Author, Google and Other Search Engines (Visual QuickStart Guide) Outlook Tips: http://www.outlook-tips.net/ Outlook & Exchange Solutions Center: http://www.slipstick.com Join OneNote Tips mailing list: http://www.onenote-tips.net/ "TK" <TK@discussions.microsoft.com...

Junk Email function suddenly stop working
Suddenly from today, the Junk Email function sudenly stops working to block those junk mails. 99% of those junk mails used to be automatically put into Junk Email box now are received in my Inbox! The setting in Junkmail Option is not changed. I set it at "High". What should I do with it? BTW, I use Outlooks 2003, part of MS Office Professional Edition with SP2 Thanks a lot in advance. I am having the exact same problem, and it started about the exact same time. I've even cleaned out the "blocked senders" list, thinking that it being full might have caused the...

Cascading parameter doesn't work right in BIDS, but works fine in
FYI: SSRS 2008 on SQL 2008, VS 2008, BIDS 2008. I have a RDL that is very basic with a cascading parameter. At this stage, it is only parameters because the actual intense data gathering wasn't programmed because of the cascading problem. This problem seems to be different than the other 3rd parameter problem that was recently fixed in a cumulative update for SQL 2008. I ran this on a server that has SQL Server 2008 cumulative update 1 and it did not work. Reading through the bug fix seemed to indicate this is a different bug. The first Parameter just gets the data th...

How to pass parameters to a report
I am new user and do not know much about Access Programming. I have a form where I have a number field called memberid. I have created a report called member report which works baed on memberquery. Which is baed on a query memberquery. I have a form which fromupdate . I want to put a command button on this page. I want this command button to read value from memberid textbox and generate the report for only that member. I have parametrized the query and it asks me enter memberid and then genrates the report for that member. I want this to happen just by clicking that button....

CheckBox to open Portrait or Landscape report
Private Sub cbCategory_Click() DoCmd.OpenReport "rptPrintMainCategoryRemark", acViewPreview End Sub This is what I have at the moment but would like to change it too, My Checkbox Yes/No [ckbPortrait] on record source of My form : Private Sub cbCategory_Click() If ckbPortrait =True, DoCmd.OpenReport "rptPrintMainCategoryRemarkPort", acViewPreview or If ckbPortrait = False, DoCmd.OpenReport "rptPrintMainCategoryRemark", acViewPreview End Sub Thanks for any help.....Bob Private Sub cbCategory_Click() If ckbPortrait = True Then DoCmd.OpenRepor...

bars overlap, how do I stop this?
I have data that uses different axis'. I want to show the data in bar format, but the bars overlap. How can I show both bars without the overlap. On your chart, rightmouse and select Chart Type, then select a chart style that does not overlap like the first standard Column or the first standard Bar chart stuckersubs Wrote: > I have data that uses different axis'. I want to show the data in bar > format, but the bars overlap. How can I show both bars without the > overlap. -- Bryan Hessey ------------------------------------------------------------------------ Brya...

Start Clock/Stop Clock
In Excel, I want to create a timer, to see how long it takes users to fill the spreadsheet in. In the forms toolbar, I have selected a button and for it to be a start clock button. Did the same for stop clock. But where does the timer appear? How do I view this? Anyone know? Thank you, Rob, Teesside, UK What exactly do you mean by Start Clock and Stop Clock? What code are you using? -- HTH RP (remove nothere from the email address if mailing direct) "abfabrob" <abfabrob@discussions.microsoft.com> wrote in message news:BCFF6885-93FC-40D4-8AB3-31C00C6BF623@microsoft....

Can't see modified report in advanced security
Hello: I have modified an AP check for a client. Our reports.dic is in a shared folder and the dynamics.set file points to it. I checked the time stamp on the reports.dic folder and it reflects a change. But when I go to find the report under an existing task in advanced security, I cannot see my modified report. Thanks for any assistance! -- MP ------=_NextPart_0001_179DCDD4 Content-Type: text/plain Content-Transfer-Encoding: 7bit Try using the View By Alternate, Custom and Modified view to see if you can find the report. It will be listed underneath the original report. Have l...

Invoice Report 02-14-10
I have created 2 tables for invoce database. fields in table1 : INV_NO, DATE, TO fields in table2 : LINE_NO, DESCRIPTION, UNIT_PRICE, QTY, TOTAL_PRICE I have connected both tables as primary and foregn keys. I need to print it as below : Each invoice has one or multiple pages. In one invoce line nuber will be increasing in serial number as much as how many items. Would appreciate your favor in this matter. >>I have connected both tables as primary and foregn keys. How are they connected? I do not see any fields that appear to be common to both. -- ...

How do I auto-save multipage report printing to Acrobat Distiller
I have a macro that prints a multi-page report to Acrobat Distiller. How do I change the file save name for each page as the macro runs. Have you asked on the Acrobat web site? AFAIK, your macro will have to print one page at a time, then perhaps rename the file before printing the next page. On Tue, 8 Mar 2005 19:43:03 -0800, sbutler96 <sbutler96@discussions.microsoft.com> wrote: >I have a macro that prints a multi-page report to Acrobat Distiller. How do >I change the file save name for each page as the macro runs. ...

How do I stop messages with Message from: <>
We seem to be getting a lot of mail thru our exchange 5.5 server with a BLANK in the FROM line, and they are getting through. How can I stop the delivery of messages with a BLANK From line? Thank you in advance, Paul This is Exchange's system attendant sending a reply, non-delivery report and it is normal. As for stopping it, you will need a third party app. I'm sure someone will give you more clarification on this. "Paul Wilson" <wilson@qwest.net> wrote in message news:%23itYogguDHA.1876@TK2MSFTNGP09.phx.gbl... > We seem to be getting a lot of mail thru our ...

cd/dvd not working code 40
ive recently had to do a system recover,ive loaded everything that i wanted back on and everythings fine except my cd drive has decided to start playing up and being stubbon,i put the cd in and it lights up on the small window on the side but doesnt read it,instead it comes back with the message of windows has loaded the drivers but cant find the hardware device code 40,(something like that)ive tried device manager and that gives me a yellow icon next to the drive,ive also tried microsofts mr fixit but that comes back more or less saying the same thing,someone suggested i do some...

Report Writer #15
Hi I am entering Transaction in Project – Billing – Billing Entry here Project Notes I am entering some text when I print a report the text which I have typed in the projects Notes is not aliened properly. Can any body tell me how the alien the text in the print out. Regards Srinivasan ...

How to get data from an unbound control? Why doesn't SetFocus work?
I've been able to get data for one textbox from a bound control but not an unbound control (except by using global variables as per the below). What am I missing? Keeps returning a Null value, see the below. RL PS--Baz, if you're reading this, don't bother replying--you're fired. Your boss speaking. Private Sub Text19_Click() 'I want to get information from Textbox1 (unbound) from textbox Text19 Dim Str04 As String Textbox1.SetFocus 'textbox must have focus to get value or .Text property If Me.Textbox1.Text <> Null Then Str04 = Me.Textbox1.Text 'Never is ...

Access 2007-Report (Text Wrapping)
Is it possible to have text wrapping of a field on a report like the text wrapping function in a cell in a worksheet in Excel? Set the Can Grow property to Yes. -- Build a little, test a little. "SueW" wrote: > Is it possible to have text wrapping of a field on a report like the text > wrapping function in a cell in a worksheet in Excel? Thank you. "KARL DEWEY" wrote: > Set the Can Grow property to Yes. > > -- > Build a little, test a little. > > > "SueW" wrote: > > > Is it possible to hav...

Forms and Reports Don't Retain Size on Opening
I recently did some work on a database and reissued a new front end. On my client's system (and on another computer of mine), forms and reports open in postage stamp size (or close to it). What could be the cause of this and how do I correct it? -- susan Check the pop-up property and make sure it is set to no. Or, if they are, you can expand them or set a new size, save them, and then they should open correctly. -- Milton Purdy ACCESS State of Arkansas "Susan L" wrote: > I recently did some work on a database and reissued a new front end. On my ...

Macro Change Date for Report
I have a macro to print the Historical Stock Status. As part of it I need to change the "as of Date". I have the macro copy the date from the System Date window. In the original macro there is a type to line and it puts the date in that was in the copy command. I take out the type line and leave the Command Edit Paste in the macro. When the macro runs I get a command disabled in the macro log when it goes to paste the date in the as of field. Suggestions on changing the date? Thanks roland Roland, Why not change the setup of the report you're using to have Current Dat...

Configure Exchange to work with SMTP
Hello, Can anyone help by pointing me in the right direction? I have purchased MS Exchange 2003 and would like to configure it to work with my SMTP provider. I have already registered a domain which is hosted by 1&1.co.uk. With the domain I get smtp mailboxes, however I'd like to configure Exchange to connect to the 1&1 mailboxes and download the e-mails and distribute them accordingly. Any advice would be much appreciated. Many thanks in advance, Allan Martin Allan Martin wrote: > Hello, > > Can anyone help by pointing me in the right direction? > > I have pur...

Change email address of Non-Delivery Reports
Currently, all our NDRs have a FROM address which is the previous sys admin's name. But where do I change this so that NDR's FROM address is my name? Exchange 2003 -- | +-- JDMils | You will need to write your own event sinks to accomplish this. http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnsmtps/html/writingmngsinks.asp James Chong MCSE + Messaging, MCTP JDMils wrote: > Currently, all our NDRs have a FROM address which is the previous sys > admin's name. But where do I change this so that NDR's FROM address is my > name? Exchange 2003 &...

CScrollbar on CPropertyPage NOT working
I have a scrollbar placed on a PropertyPage and it is not receiving any scroll messages. The scrollbar control is not the dialog scrollbar. It is a child control. I'm tried trapped the message, via ON_NOTIFY(VM_VSCROLL, ID_SCROLLBAR, OnMyScrolled), but the function "OnMyScrolled" doesn't get called. I've also tried deriving a new class, MyScrollBar, and providing a OnVScroll(), but that is never getting called. Is there some property of the dialog I should have on or off? The only event I can add to the scroll bar via the .NET "class wizard", is THEME_CHANG...

GP Detailed Trial Balance Report
Hello all, we are getting some strange numbers from the trial balance detail report.. Here is what's happening. we do a section or accounts and by date select just posting accounts and open year. the report then shows only 2 decimal places so for instance an account was posted with a credit value of 144.702 and a debit of 1281.96 which if you calculate gives you a value of 1137.258 which great plains in the account number footer shows as 1137.25 for the net change. On the the report total for net change GP shows 133,964.83. when you actually calculate the total of net change am...

Period Sales Analysis Report Error
I updated to ver 10 from 9 SP2 a couple weeks ago and everything has worked relatively well (Thanks to all newsgroup members who assisted) I am getting an error "Error in equation 'Net Sales'". Has anyone else seen this and what did you do? I'm guessing this is a modified report? Open the report in Report Writer and check out the Calculated field 'Net Sales'. You will probably find an error there. If I can't figure it out just by looking, I'll look at the v 9 report to see what the calc was trying to come up with and then correct the formula in v ...