CRM Mobile Registration Error

Hello All,

I work for a Microsoft partner in the Atlanta area, and I've been
tasked with testing CRM before we put it into production.  I've hit a
brick wall with CRM Mobile 3.0, and I'm hoping someone might be able to
help, or point me in the right direction for this issue.

The situation now: We use Small Business Server 2003 Premium SP1 in our
production environment, so I'm also using it in my test environment.
The test environment consists of the server and two laptops, and is
connected to the internet, although its external URL uses a redirection
service: fakename.no-ip.org, for example.  (I mention that in case it
makes a difference concerning the SSL certificate.)  I used SelfSSL to
make the certificate.

We successfully installed CRM weeks ago, and a co-worker of mine has
been working with the web client and the Outlook client during that
time.  I installed the server portion of CRM Mobile earlier in the
week, and believe it to be installed correctly because I've been able
to create Installation Items and Deployment Packages without a hiccup.


Let me add that I do not know for certain if a Product License Key was
used when CRM was first installed on this test environment.  I read on
a blog (I'm sorry I've lost the link, and I'm paraphrasing) that CRM
Mobile will not work in an environment where an MSDN key was used.

I am also able to install CRM Mobile onto my device (Cingular 8125)
without any issues during installation (I have done this twice, with
two slightly different Deployment Packages).  However, when I use CRM
Mobile for the first time, I get an error, from which I can only view
the Details or Quit.

I chose to view the Details, and typed them into Notepad.  I have also
transferred the CRMMobileErrorLog text file from "My Device\Program
Files\CRM Mobile" to my laptop.  Interestingly (to me, at least), the
message within the ErrorLog file makes no mention of the Details that I
saw at the point when the error occurred.  I'll paste the two files
below.

Here is the Details message at the time of the error.  I couldn't copy
and paste it into a text file, so I typed it into Notepad:
----------------------------
CRMMobile.exe
SqlCeException at
System.Data.SqlServerCe.NativeMethods.CheckHRESULT() at
System.Data.SqlServerCe.SqlCeRemoteDataAccess.Pull() at
Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.SetupOutBoundDB()
at
Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.StartMessageBus()
at
Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.SendDeviceRegistrationMessage()
at
Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.Execute()
at
Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.IsRegistered()
at
Microsoft.BusinessSolutions.Mobility.Registration.IsRegistered() at
Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.RegisterMessageBus()
at
Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.Provision()
at
Microsoft.BusinessSolutions.Mobility.DeviceApp.ProvisioningForm.provision_Click()
at
System.Windows.Forms.Control.OnClick() at
System.Windows.Forms.Button.OnClick() at
System.Windows.Forms.ButtonBase.WnProc() at
System.Windows.Forms.Control._InternalWnProc() at
Microsoft.AGL.Forms.EVL.EnterMainLoop() at
System.Windows.Forms.Application.Run() at
Microsoft.BusinessSolutions.Mobility.DeviceApp.CRMAppShell.Main()
----------------------------

Here are the last few "paragraphs" from the CRMMobileErrorLog text
file, which I transferred to my laptop.
----------------------------
[TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
[TXT]Exception details :
	Message :

SQL CE exception
Error Code: 80004005
Message   :
Minor Err.: 28024
Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
:
[TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
[TXT]Exception details :
	Message :

SQL CE exception
Error Code: 80004005
Message   :
Minor Err.: 28024
Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
:
[TIM]07/28/2006 12:20:42 [CMP]mMBSException [LVL]0 [EVT]3080
[TXT]Unhandled exception. Exception details :
	Message :

SQL CE exception
Error Code: 80004005
Message   :
Minor Err.: 28024
Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
:
[TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
[TXT]Unhandled exception. Exception details :
	Message :

SQL CE exception
Error Code: 80004005
Message   :
Minor Err.: 28024
Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
:
[TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
[TXT]Unhandled exception. Exception details :
	Message :

SQL CE exception
Error Code: 80004005
Message   :
Minor Err.: 28024
Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
:
[TIM]07/28/2006 12:21:06 [CMP]mMBSException [LVL]0 [EVT]3080
[TXT]Unhandled exception. Exception details :
	Message : ThreadAbortException
	Exception Contents : System.Threading.ThreadAbortException:
ThreadAbortException
at System.PInvoke.PAL.Threading_Event_Wait()
at System.Threading.ManualResetEvent.WaitOne()
at
Microsoft.BusinessSolutions.Mobility.Threading.WorkerThread.WorkerFunction()
----------------------------

While rummaging through the device file explorer to get that text, I
found a file called "Microsoft .NET CF 2.0.LOG.TXT".  I won't bother
pasting the whole thing, because near the end there was a line that
said "Installation completed, no errors detected."

More information: I set up the Installation Item to install the
databases to the Storage Card.  I have read messages online about
making sure the storage card isn't locked.  I'm not even sure how to
lock a storage card on my device, and I saw three "new" files on the
storage card after the install: "dvcReg.sdf", "InbndCatalog.sdf", and
"OutbndCatalog.sdf".  So, I doubt the problem is the storage card.

The Deployment Packages that I created included the four items that are
always needed ("Microsoft .NET Compact Framework 2.0", "Microsoft SQL
CE 3.0", "Microsoft SQL CE 3.0 Replication", and "Certificate
Settings"--only one because I used SelfSSL to make it) and my
device-specific Installation Item.

If there is anything I haven't mentioned that would be useful, please
ask away.  

Thanks in advance,
Nathan Boster
nboster at gmail dot com

0
nboster (1)
7/28/2006 6:00:24 PM
crm 35858 articles. 1 followers. Follow

2 Replies
536 Views

Similar Articles

[PageSpeed] 13

Hello,
i have same problem, do you now anything more now? Please...

"nboster@gmail.com" wrote:

> Hello All,
> 
> I work for a Microsoft partner in the Atlanta area, and I've been
> tasked with testing CRM before we put it into production.  I've hit a
> brick wall with CRM Mobile 3.0, and I'm hoping someone might be able to
> help, or point me in the right direction for this issue.
> 
> The situation now: We use Small Business Server 2003 Premium SP1 in our
> production environment, so I'm also using it in my test environment.
> The test environment consists of the server and two laptops, and is
> connected to the internet, although its external URL uses a redirection
> service: fakename.no-ip.org, for example.  (I mention that in case it
> makes a difference concerning the SSL certificate.)  I used SelfSSL to
> make the certificate.
> 
> We successfully installed CRM weeks ago, and a co-worker of mine has
> been working with the web client and the Outlook client during that
> time.  I installed the server portion of CRM Mobile earlier in the
> week, and believe it to be installed correctly because I've been able
> to create Installation Items and Deployment Packages without a hiccup.
> 
> 
> Let me add that I do not know for certain if a Product License Key was
> used when CRM was first installed on this test environment.  I read on
> a blog (I'm sorry I've lost the link, and I'm paraphrasing) that CRM
> Mobile will not work in an environment where an MSDN key was used.
> 
> I am also able to install CRM Mobile onto my device (Cingular 8125)
> without any issues during installation (I have done this twice, with
> two slightly different Deployment Packages).  However, when I use CRM
> Mobile for the first time, I get an error, from which I can only view
> the Details or Quit.
> 
> I chose to view the Details, and typed them into Notepad.  I have also
> transferred the CRMMobileErrorLog text file from "My Device\Program
> Files\CRM Mobile" to my laptop.  Interestingly (to me, at least), the
> message within the ErrorLog file makes no mention of the Details that I
> saw at the point when the error occurred.  I'll paste the two files
> below.
> 
> Here is the Details message at the time of the error.  I couldn't copy
> and paste it into a text file, so I typed it into Notepad:
> ----------------------------
> CRMMobile.exe
> SqlCeException at
> System.Data.SqlServerCe.NativeMethods.CheckHRESULT() at
> System.Data.SqlServerCe.SqlCeRemoteDataAccess.Pull() at
> Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.SetupOutBoundDB()
> at
> Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.StartMessageBus()
> at
> Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.SendDeviceRegistrationMessage()
> at
> Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.Execute()
> at
> Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.IsRegistered()
> at
> Microsoft.BusinessSolutions.Mobility.Registration.IsRegistered() at
> Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.RegisterMessageBus()
> at
> Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.Provision()
> at
> Microsoft.BusinessSolutions.Mobility.DeviceApp.ProvisioningForm.provision_Click()
> at
> System.Windows.Forms.Control.OnClick() at
> System.Windows.Forms.Button.OnClick() at
> System.Windows.Forms.ButtonBase.WnProc() at
> System.Windows.Forms.Control._InternalWnProc() at
> Microsoft.AGL.Forms.EVL.EnterMainLoop() at
> System.Windows.Forms.Application.Run() at
> Microsoft.BusinessSolutions.Mobility.DeviceApp.CRMAppShell.Main()
> ----------------------------
> 
> Here are the last few "paragraphs" from the CRMMobileErrorLog text
> file, which I transferred to my laptop.
> ----------------------------
> [TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
> [TXT]Exception details :
> 	Message :
> 
> SQL CE exception
> Error Code: 80004005
> Message   :
> Minor Err.: 28024
> Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> :
> [TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
> [TXT]Exception details :
> 	Message :
> 
> SQL CE exception
> Error Code: 80004005
> Message   :
> Minor Err.: 28024
> Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> :
> [TIM]07/28/2006 12:20:42 [CMP]mMBSException [LVL]0 [EVT]3080
> [TXT]Unhandled exception. Exception details :
> 	Message :
> 
> SQL CE exception
> Error Code: 80004005
> Message   :
> Minor Err.: 28024
> Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> :
> [TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
> [TXT]Unhandled exception. Exception details :
> 	Message :
> 
> SQL CE exception
> Error Code: 80004005
> Message   :
> Minor Err.: 28024
> Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> :
> [TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
> [TXT]Unhandled exception. Exception details :
> 	Message :
> 
> SQL CE exception
> Error Code: 80004005
> Message   :
> Minor Err.: 28024
> Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> :
> [TIM]07/28/2006 12:21:06 [CMP]mMBSException [LVL]0 [EVT]3080
> [TXT]Unhandled exception. Exception details :
> 	Message : ThreadAbortException
> 	Exception Contents : System.Threading.ThreadAbortException:
> ThreadAbortException
> at System.PInvoke.PAL.Threading_Event_Wait()
> at System.Threading.ManualResetEvent.WaitOne()
> at
> Microsoft.BusinessSolutions.Mobility.Threading.WorkerThread.WorkerFunction()
> ----------------------------
> 
> While rummaging through the device file explorer to get that text, I
> found a file called "Microsoft .NET CF 2.0.LOG.TXT".  I won't bother
> pasting the whole thing, because near the end there was a line that
> said "Installation completed, no errors detected."
> 
> More information: I set up the Installation Item to install the
> databases to the Storage Card.  I have read messages online about
> making sure the storage card isn't locked.  I'm not even sure how to
> lock a storage card on my device, and I saw three "new" files on the
> storage card after the install: "dvcReg.sdf", "InbndCatalog.sdf", and
> "OutbndCatalog.sdf".  So, I doubt the problem is the storage card.
> 
> The Deployment Packages that I created included the four items that are
> always needed ("Microsoft .NET Compact Framework 2.0", "Microsoft SQL
> CE 3.0", "Microsoft SQL CE 3.0 Replication", and "Certificate
> Settings"--only one because I used SelfSSL to make it) and my
> device-specific Installation Item.
> 
> If there is anything I haven't mentioned that would be useful, please
> ask away.  
> 
> Thanks in advance,
> Nathan Boster
> nboster at gmail dot com
> 
> 
0
Utf
8/4/2006 8:07:02 AM
Hello Yetti,
Since I posted that message I have successfully installed CRM Mobile to
my device, with the help of Mike on the CRM Mobile team at Microsoft.
I am having a problem with "over-the-air" synchronization, but I think
that's an issue with my Cingular data network, so let me first discuss
the issue you're currently having.

The most important thing I found right after posting my message a week
ago was a post that mentioned that there are three webpages on your
server that your mobile device must be able to browse to.  They are
listed below, in the format that I had to use:

 - https://SERVER_URL:PORT_NUMBER/ssCERDA
 - https://SERVER_URL:PORT_NUMBER/CRMMobileSubscription/msgbus.asmx
 -
https://SERVER_URL:PORT_NUMBER/CRMMobileSubscription/Subscriptions.asmx

If you use 443 as the port number, there's no need to include it after
the SERVER_URL.

If you're mobile device can browse to those three pages in IE or
whatever browser you're using, CRM Mobile should work.

I tried to browse to those three pages while connected via USB cable to
my laptop.  The result was a message from my ISA Server stating that:
"The specified Secure Sockets Layer (SSL) port is not
allowed. ISA Server is not configured to allow SSL requests from this
port."  I googled that message and found a link to a tool
(http://www.isatools.org/ISAtrpe.zip) that allows you to add port
ranges to ISA, because out of the box, ISA doesn't allow outgoing
requests over most ports. I used that tool to add my PORT_NUMBER to
ISA's allowed ranges, and then I could browse to those three pages
while my device was connected via USB cable to my laptop.

With lots of help, I have come a long way since then.  I have
"everything" working in CRM Mobile on my device, except synchronizing
"over-the-air".  I believe the problem is very similar, however; I
think Cingular is blocking "unusual" SSL ports over their network just
like ISA was blocking the "unusual" SSL port over my internal network.
I have a call in to a Cingular employee to see if there's a way around
this, or else we may have use a separate public IP address so that we
can use 443.

I hope this helps.  Please write if you need more information.

Nate


Yetti wrote:
> Hello,
> i have same problem, do you now anything more now? Please...
>
> "nboster@gmail.com" wrote:
>
> > Hello All,
> >
> > I work for a Microsoft partner in the Atlanta area, and I've been
> > tasked with testing CRM before we put it into production.  I've hit a
> > brick wall with CRM Mobile 3.0, and I'm hoping someone might be able to
> > help, or point me in the right direction for this issue.
> >
> > The situation now: We use Small Business Server 2003 Premium SP1 in our
> > production environment, so I'm also using it in my test environment.
> > The test environment consists of the server and two laptops, and is
> > connected to the internet, although its external URL uses a redirection
> > service: fakename.no-ip.org, for example.  (I mention that in case it
> > makes a difference concerning the SSL certificate.)  I used SelfSSL to
> > make the certificate.
> >
> > We successfully installed CRM weeks ago, and a co-worker of mine has
> > been working with the web client and the Outlook client during that
> > time.  I installed the server portion of CRM Mobile earlier in the
> > week, and believe it to be installed correctly because I've been able
> > to create Installation Items and Deployment Packages without a hiccup.
> >
> >
> > Let me add that I do not know for certain if a Product License Key was
> > used when CRM was first installed on this test environment.  I read on
> > a blog (I'm sorry I've lost the link, and I'm paraphrasing) that CRM
> > Mobile will not work in an environment where an MSDN key was used.
> >
> > I am also able to install CRM Mobile onto my device (Cingular 8125)
> > without any issues during installation (I have done this twice, with
> > two slightly different Deployment Packages).  However, when I use CRM
> > Mobile for the first time, I get an error, from which I can only view
> > the Details or Quit.
> >
> > I chose to view the Details, and typed them into Notepad.  I have also
> > transferred the CRMMobileErrorLog text file from "My Device\Program
> > Files\CRM Mobile" to my laptop.  Interestingly (to me, at least), the
> > message within the ErrorLog file makes no mention of the Details that I
> > saw at the point when the error occurred.  I'll paste the two files
> > below.
> >
> > Here is the Details message at the time of the error.  I couldn't copy
> > and paste it into a text file, so I typed it into Notepad:
> > ----------------------------
> > CRMMobile.exe
> > SqlCeException at
> > System.Data.SqlServerCe.NativeMethods.CheckHRESULT() at
> > System.Data.SqlServerCe.SqlCeRemoteDataAccess.Pull() at
> > Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.SetupOutBoundDB()
> > at
> > Microsoft.BusinessSolutions.Mobility.RdaMessageRus.RdaMessageBus.StartMessageBus()
> > at
> > Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.SendDeviceRegistrationMessage()
> > at
> > Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.Execute()
> > at
> > Microsoft.BusinessSolutions.Mobility.Registration.DeviceRegistration.IsRegistered()
> > at
> > Microsoft.BusinessSolutions.Mobility.Registration.IsRegistered() at
> > Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.RegisterMessageBus()
> > at
> > Microsoft.BusinessSolutions.Mobility.DevicePlatform.ProvisioningProcess.Provision()
> > at
> > Microsoft.BusinessSolutions.Mobility.DeviceApp.ProvisioningForm.provision_Click()
> > at
> > System.Windows.Forms.Control.OnClick() at
> > System.Windows.Forms.Button.OnClick() at
> > System.Windows.Forms.ButtonBase.WnProc() at
> > System.Windows.Forms.Control._InternalWnProc() at
> > Microsoft.AGL.Forms.EVL.EnterMainLoop() at
> > System.Windows.Forms.Application.Run() at
> > Microsoft.BusinessSolutions.Mobility.DeviceApp.CRMAppShell.Main()
> > ----------------------------
> >
> > Here are the last few "paragraphs" from the CRMMobileErrorLog text
> > file, which I transferred to my laptop.
> > ----------------------------
> > [TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
> > [TXT]Exception details :
> > 	Message :
> >
> > SQL CE exception
> > Error Code: 80004005
> > Message   :
> > Minor Err.: 28024
> > Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> > :
> > [TIM]07/28/2006 12:20:42 [CMP]rdaMsgBusErrorTrace [LVL]0 [EVT]0
> > [TXT]Exception details :
> > 	Message :
> >
> > SQL CE exception
> > Error Code: 80004005
> > Message   :
> > Minor Err.: 28024
> > Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> > :
> > [TIM]07/28/2006 12:20:42 [CMP]mMBSException [LVL]0 [EVT]3080
> > [TXT]Unhandled exception. Exception details :
> > 	Message :
> >
> > SQL CE exception
> > Error Code: 80004005
> > Message   :
> > Minor Err.: 28024
> > Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> > :
> > [TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
> > [TXT]Unhandled exception. Exception details :
> > 	Message :
> >
> > SQL CE exception
> > Error Code: 80004005
> > Message   :
> > Minor Err.: 28024
> > Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> > :
> > [TIM]07/28/2006 12:20:47 [CMP]mMBSException [LVL]0 [EVT]3080
> > [TXT]Unhandled exception. Exception details :
> > 	Message :
> >
> > SQL CE exception
> > Error Code: 80004005
> > Message   :
> > Minor Err.: 28024
> > Source    : Microsoft SQL Server 2005 Mobile Edition	Exception Contents
> > :
> > [TIM]07/28/2006 12:21:06 [CMP]mMBSException [LVL]0 [EVT]3080
> > [TXT]Unhandled exception. Exception details :
> > 	Message : ThreadAbortException
> > 	Exception Contents : System.Threading.ThreadAbortException:
> > ThreadAbortException
> > at System.PInvoke.PAL.Threading_Event_Wait()
> > at System.Threading.ManualResetEvent.WaitOne()
> > at
> > Microsoft.BusinessSolutions.Mobility.Threading.WorkerThread.WorkerFunction()
> > ----------------------------
> >
> > While rummaging through the device file explorer to get that text, I
> > found a file called "Microsoft .NET CF 2.0.LOG.TXT".  I won't bother
> > pasting the whole thing, because near the end there was a line that
> > said "Installation completed, no errors detected."
> >
> > More information: I set up the Installation Item to install the
> > databases to the Storage Card.  I have read messages online about
> > making sure the storage card isn't locked.  I'm not even sure how to
> > lock a storage card on my device, and I saw three "new" files on the
> > storage card after the install: "dvcReg.sdf", "InbndCatalog.sdf", and
> > "OutbndCatalog.sdf".  So, I doubt the problem is the storage card.
> >
> > The Deployment Packages that I created included the four items that are
> > always needed ("Microsoft .NET Compact Framework 2.0", "Microsoft SQL
> > CE 3.0", "Microsoft SQL CE 3.0 Replication", and "Certificate
> > Settings"--only one because I used SelfSSL to make it) and my
> > device-specific Installation Item.
> >
> > If there is anything I haven't mentioned that would be useful, please
> > ask away.
> >
> > Thanks in advance,
> > Nathan Boster
> > nboster at gmail dot com
> > 
> >

0
Nate
8/5/2006 8:48:46 PM
Reply:

Similar Artilces:

Spontaneous 'Compile Error' In Queries
I've got a half-dozen queries that contain this expression: IssuerName: IIf(IsNull([tblIssuer].[IssuerID]),"[Issuer Unknown]",[tblIssuer].[IssuerName]) Haven't touched any of them, but suddenly they were all throwing "Compile error. in query expression 'IssuerName: IIf(IsNull([tblIssuer].[IssuerID]),"[Issuer Unknown]",[tblIssuer].[IssuerName])'." tblIssuer.IssuerID is still there in a link. My kneejerk was to somehow force recompiles of all the queries, so I did a Compact/Repair. After the compact/repair, all was well: the errors went away. C...

CRM Url
I initially installed the CRM server to the default url of the server (i.e. http://servername). I then installed SharePoint and it messed the configuration up. I then uninstalled SP. Now I can't get to the default server's url of http://servername. Any suggestions on how to correct? Go into IIS and setup a Host Header for the CRM site, Then add an alias for the Header to DNS. Calling the Alias will then resolve and access the site, -- Paul Papanek Stork MBA, CTT+, MCT, MCSE+I, MCSA, MCAD, MCDBA Solutient of Ohio, INC. email: pstork <<at>> att.net visit ME at: ...

Login problem to CRM 3.0
Hi, I installed CRM 3.0 Professional Edition without any error. I can login perfectly from the CRM server either using http://localhost:5555/ or http://appserver:5555/ under the crmadmin user. If I login to an XP workstation with the same user (crmadmin) and specify http://appserver:5555/ in IE6, I got a login window - where I enter the correct DOMAINNAME\crmadmin username and password - and got the following message: "You are not authorized to view this page"..."HTTP Error 401.1 - Unauthorized... I think the prolem is around IIS security, but what shoud be the next step. Th...

look way to map form at CRM frontend to tables at CRM database
How can I find out what tables which new record has been added on when I enter data through a form in CRM front end? I try to find way to map form in the CRM frontend to the tables at the CRM database at backend? It is CRM 3.0 Thank in advances for help! ...

Renaming Accounts in CRM
We are trying to change the account name in CRM, In the Account Name field when we chnage it, it goes through all cases and makes the owner of the case the person that changes the account name. Is there a way to have it not go back through all of the cases ? What you describe is not CRM functionality. Either you didn't describe it correctly, or there is some custom process performing the unwanted action I think you may mean when an account owner is changed, all the account's cases ownership also changes. Now that really is a pain!! "Rcw01" <rwilson01@gmail.com> w...

I cannot uninstall CRM client for Outlook
We have two clinet machines that had CRM client for Outlook with Office 2003. We upgraded those workstations to Office 2007 and subsequently lost the ability to use the CRM features. When I try to uninstall the CLient, the uninstall asks for the disc and proceeds to reinstall the client until it realizes that the new version of outlook is incompatible. When trying the newer install disc for CRM, I get the following message: "The older version of Microsoft CRM desktop client cannot be removed. Contact your technical support group." This is followed by " Action Micro...

Payables Transaction Edit List
Our customer had the following error print on the Payables Transaction Edit List: **ERROR: One of more landed costs need to be apportioned.Document Total. This prevented the user from posting the batch. The batch went into Batch Recovery. However, the error message did not appear when logged in as 'sa' and 'sa' was able to post the batch. This customer does not even own the landed cost module. Plus, this was an A/P invoice, not a POP invoice. Why was this message appearing? ...

Slow responce of cash drawer OR printer error
Hi every one. Some time the cash drawer response is very slow. Sometimes the cash drawer opens, but the receipt doesn't print. The computer searches for a while and then at the end it displays an error message. I have TM88IV & APG Cash Drawer, using OPOS driver, using Microsoft RMS 2.0 with Windows Vista. if any body have some idea please help me Thanks in advance I have the same experience but with a SureMark 4610 - TF6 Any ideas? Kyle "Akbar Mian" <AkbarMian@discussions.microsoft.com> wrote in message news:22EF9D16-A753-4FEF-A199-A232F571EFFD@microsoft...

Foreground locking error running scheduled integration
I have a scheduled integration setup that first runs the login to GP, then an integration group (2 AR integrations). I have them set at 5 minutes apart. The TK article for this particular error says that the error is because "Great Plains is still in the process of launching when the Integration Manager starts running." I then increased the time to 15 minutes apart and finally at 30 minutes apart, but the first record of both integrations still fails with this error "could not set foreground locking value to 0." How can I get rid of this error? It only takes les...

Error 1100009
After pushing out SP2, I've got about 700 Vista machines that are throwing an error "Publisher cannot open the file." when trying to open Publisher documents. Ctrl+Shift+I gives error 1100009 Any solutions other than removing Office and reinstalling without SP2 on 700 PCs? Patrick S wrote: > After pushing out SP2, I've got about 700 Vista machines that are throwing an > error "Publisher cannot open the file." when trying to open Publisher > documents. Ctrl+Shift+I gives error 1100009 > > Any solutions other than removing Office and reinsta...

OWA 302 error for inbox
I have two 2003 (sp2) front-end servers that are in DMZ. We have had this problem even before installing sp2. We use Network Load Balancing. After login, during OWA tries to display Inbox, I get login screen on right pane, prompting me to enter user id and pwd. In IIS Logs I see 302 error in logs when accessing frontend-02 (please see below the comparision between frontend-01 and 02 ; frontend-01 is working server). Secondly, I notice in the logs, on frontend-02, under cs-username field, there is '-', whereas on 01 server i see the username, henry. Any reason wy? To view prop...

Failed CRM for Outlook Install
I am trying to install CRM for Outlook on a computer but it kleeps failing with the following error: "Setup has failed because of an error. Setup was unable to install the .msi file for Microsoft CRM Sales for Outlook" The user has Administative rights to the system, she has an account in CRM and a license. This is very frustrating since I have to clean up the registry every time I reinstall since it crashes before putting anything in the add remove control panel. Any ideas? -- Francois Try to uninstall MSDE and make sure you have all the databases removed. The default in...

Third request for help with Payables Error message!
Ok I have posted this for the third time with no response! I need help to know if there is any kind of issue on the back end of our environment. If someone could help it would be greatly appreciated! We are currently running GP 10 SP1 and apparently since version 8 (we did not upgrade to 9) there has been the following error message while launching a transaction out of Smartlist, when we go to inquiry for AP documents, and drill down of PMTRX & PMCHK from the JE inquiry view: Unhandeled Script Exception: Index 0 array of 'PM_Transaction_Inquiry_Fill' Script terminated We ran a ...

Exchange OMA error message. Please read...
When our i-700's with Pocket PC 2003 attempts to access our mail exchange server, all we receive is the following error message: " A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator. Home" mail.domain.com/exchange works fine though. We've installed the service pack 1 for exchange 2003 to attempt to fix this issue and are having the same results. Does anyone care to share how they may have overcome this exchange problem with their compatible PDAs and Exchange's OMA (Outlook Mobile Access...

Minimum Exchange 2003 for CRM 1.2?
Hello We are trying to setup a test deployment of CRM 1.2 for 5 users We (parent organisation) already has a email system (UNIX , pop, smtp) in place. I wish to learn what is the minimum Exchange setup that I need to do to deploy the test environment Is there a way to to configure the Exchange server such that it still uses the parent email system and still be used with the CRM thank you very much for your help vikrantca Hello, vikrantca wrote: > We are trying to setup a test deployment of CRM 1.2 for 5 users. > We (parent organisation) already has a email system (UNIX , pop, > smt...

getting the error when updating file xls file.
Hi. We are using exchange 2003 server and office XP but know we start to Upgrade our office to office 2003 Know we are face problem. When our user try to make changes to file in public folder there can not make the changes it say “file is read only” but that user can make the changes or edit that same file from the P.C were office XP is installed. Do I have to install some patch if yes can you please send that patch because in trying from last two day and I can not find it. Note: If possible can you reply on parag.lopes@madinatjumeirah.com Just a guess... Are you s...

Making CRM more attractive in Outlook
Hi, I'm new to this site (and MS CRM). I am preparing a presales demo and want to make the outlook (desktop) version of CRM more attractive for users by using the shortcut buttons that CRM provides. I have two questions. One is more Outlook related, really. - Can I create a new view in the navigation pane (like mail, calendar, ...) with my CRM buttons? Right now I have all these buttons under "shortcuts" but that doesn't appeal to the user. - I have once seen a demo where a view was created with all the standard shortcut buttons in a sort of "folder list",...

Total Failure of CRM/SQL
I am (was) running CRM 1.2 and SQL 2000 SP3 on the same box when CRM started acting funny and finally i couldn't access the web interface anymore. The box was still running (W2K3)so I backed up the databases with NT backup. Now, i rebuilt the server and have tried unsuccessfully to restore the CRM data following the IG. Any thoughts? Thanks. Do you have a backup of the sql database? If you have a backup of the database you can restore and do a reinstall of CRM, dont try to restore the crm program as well. Just restore the database, install CRM and point it to the database. >-...

CRM / SBT 6.x
Hello All & Greetings. I am looking for any material / Case Studies, etc. of Installing, Configuring & CUstomizing MS CRM and SBT Pro and would appreciate any material would be of immense help. thanks in advance. kishan I would go to www.greatplains.com and also microsoft.com/crm and have a dig around "R. Kishan Boddapati" <kishanb@sciencesinc.com> wrote in message news:11de01c3847e$e9a58370$a101280a@phx.gbl... > Hello All & Greetings. > > I am looking for any material / Case Studies, etc. of > Installing, Configuring & CUstomizing MS CRM and ...

CRM Contacts
I had a user complain about this issue, does an answer/explanation jump out at anyone? Had issue where CRM sent all CRM contacts into his personal Outlook (he has since deleted them and backed up his actual contacts from his Palm Pilot) Thanks, Boolean1 Boolean1@comcast.net In one of the SFO folders, say Accounts, select Tools/Options. At the bottom of the screen the last section is titled "Create Microsoft CRM Items in my default Outlook folders". If you uncheck the Contacts box then next time you go offline contacts will not be copied from CRM down to Outlook contacts. T...

CRM for Customer Service
Hello, We've been using CRM primarily for Sales Force Automation. We're considering using the Service Module for customer service and support. Is CRM designed for self service? Can customers log onto the system and query the knowledge base, for example. Or is CRM designed primarily for internal use, i.e. phone support. Thanks! Hello MS-CRM 1.2 out of the box is aimed for internal use, but it's perfectly possible to have a web based customer portal for browsing the knowledge base or raising cases etc, using the SDK. A Microsoft Partner should be able to help you out i...

CRM Laptop Client for Outlook / TCP Ports
I was asked by our System/Network Administrator to give him an official list (Supplied by Microsoft) containing all TCP Ports that need to be opened on a Firewall in order to enable remote users to connect to the CRM server through CRM Laptop Client for Outlook. Is there such a list? Where can I find it? If not then what do you recommend we should do in order to know (ALL) the used TCP Ports by CRM Laptop client ? Thanks Here are the server ports SUMMARY This article discusses what ports Microsoft CRM uses to communicate to IIS and SQL Server. MORE INFORMATION SQL Server uses the ...

crm adapter for Biztal 2006 metadata generation
I am receiving the following error message when attempting to get lists of entities and schemas using Generate Adapter MetaData: --------------------------- Fetch Schema Exception --------------------------- The list of actions and entities cannot be loaded: The 'p' start tag on line 79 does not match the end tag of 'ul'. Line 81, position 17. --------------------------- OK --------------------------- when pointing to : http://crmserv/MSCRMServices/2006/MetadataService.asmx?WSDL I can successfully view this wsdl through a browser, and can't seem to find anything si...

Add printer W2K8 error 0x00000002 (Terminal server)
When i try to add a network printer or a local printer it fails with the folowing error: 0x00000002 We have 4 terminal servers and 3 are working fine only one gives this error. I already did the folowing: Removing the printer drivers at the server. Exporting the regkey print from a good working ts to this one. Copying al driver with printmig to the bad server. System information: Windows server 20008 Service pack 2 32 bits Terminal server If someone needs more information, just ask and i will give it to you! Thanks for all your help Kindly Regards, Alex van Duist ...

#5.5.0 smtp;500 Syntax error, command unrecognized
I just installed a new Windows Server 2003 with Exchange 2003. I get this message when I send to all Hotmail accounts and some other accounts. Any ideas? On Fri, 10 Feb 2006 14:56:04 -0800, "MikeO" <MikeO@discussions.microsoft.com> wrote: >I just installed a new Windows Server 2003 with Exchange 2003. I get this >message when I send to all Hotmail accounts and some other accounts. Any >ideas? http://support.microsoft.com/?kbid=895857&SD=tech "SMTP mail cannot be sent or cannot be received in Exchange Server" http://support.microsoft.com/defa...