Create Task in Workflow fails

Hi all:

I have a workflow rule that fires when a new lead is created. The rule 
assigns the lead to a user, sends an email to the user to inform them they 
have a lead, and then it creates a task for the user. However, for some 
reason the rule fails on the task creation, with the error:

"Error code = 80131509. This SqlTransaction has completed; it is no longer 
usable"

I thought it might be because I was trying to assign the task to the logical 
owner, and perhaps the owner had not been set yet, so I changed the rule to 
create the task for a static user and it still fails.

Can anyone suggest a fix for this?

-- 
John.

http://mscrmguy.blogspot.com/

0
Johnny
6/8/2007 10:07:58 PM
crm 35858 articles. 1 followers. Follow

5 Replies
720 Views

Similar Articles

[PageSpeed] 9

Hi

Your post does not mention your environment but I would bet that you are 
using SQL Server 2005.  

If so I have seen this several times.  It is to do with a .Net 2.0 and SQL 
Server 2005 ADO issue.  Yes I know CRM is .Net1.1 but when using SQL Server 
2005 this appears.

Check out the KB below and should resolve your issue: -

http://support.microsoft.com/?kbid=912732

If this resolves your issue please march your post as answered.  Many thanks
-- 
Rgds

Michael
MCDBA 2000 | MCITP DBA 2005


"Johnny" wrote:

> Hi all:
> 
> I have a workflow rule that fires when a new lead is created. The rule 
> assigns the lead to a user, sends an email to the user to inform them they 
> have a lead, and then it creates a task for the user. However, for some 
> reason the rule fails on the task creation, with the error:
> 
> "Error code = 80131509. This SqlTransaction has completed; it is no longer 
> usable"
> 
> I thought it might be because I was trying to assign the task to the logical 
> owner, and perhaps the owner had not been set yet, so I changed the rule to 
> create the task for a static user and it still fails.
> 
> Can anyone suggest a fix for this?
> 
> -- 
> John.
> 
> http://mscrmguy.blogspot.com/
> 
0
Utf
6/9/2007 10:50:01 PM
Hi Michael,

This may seem like a dumb question, but on what server do you install the 
fix in?  The CRM server or the SQL 2005 server?  I read someone elses thread 
where you suggested this fix and it worked, but it is still not clear to me 
where to install the fix.

Thanks in advance.

Med

"Michael Langdon" wrote:

> Hi
> 
> Your post does not mention your environment but I would bet that you are 
> using SQL Server 2005.  
> 
> If so I have seen this several times.  It is to do with a .Net 2.0 and SQL 
> Server 2005 ADO issue.  Yes I know CRM is .Net1.1 but when using SQL Server 
> 2005 this appears.
> 
> Check out the KB below and should resolve your issue: -
> 
> http://support.microsoft.com/?kbid=912732
> 
> If this resolves your issue please march your post as answered.  Many thanks
> -- 
> Rgds
> 
> Michael
> MCDBA 2000 | MCITP DBA 2005
> 
> 
> "Johnny" wrote:
> 
> > Hi all:
> > 
> > I have a workflow rule that fires when a new lead is created. The rule 
> > assigns the lead to a user, sends an email to the user to inform them they 
> > have a lead, and then it creates a task for the user. However, for some 
> > reason the rule fails on the task creation, with the error:
> > 
> > "Error code = 80131509. This SqlTransaction has completed; it is no longer 
> > usable"
> > 
> > I thought it might be because I was trying to assign the task to the logical 
> > owner, and perhaps the owner had not been set yet, so I changed the rule to 
> > create the task for a static user and it still fails.
> > 
> > Can anyone suggest a fix for this?
> > 
> > -- 
> > John.
> > 
> > http://mscrmguy.blogspot.com/
> > 
0
Utf
6/12/2007 9:04:03 PM
The fix is installed on the MSCRM/Web Server.
-- 
Rgds

Michael
MCDBA 2000 | MCITP DBA 2005


"Medardo Lacayo" wrote:

> Hi Michael,
> 
> This may seem like a dumb question, but on what server do you install the 
> fix in?  The CRM server or the SQL 2005 server?  I read someone elses thread 
> where you suggested this fix and it worked, but it is still not clear to me 
> where to install the fix.
> 
> Thanks in advance.
> 
> Med
> 
> "Michael Langdon" wrote:
> 
> > Hi
> > 
> > Your post does not mention your environment but I would bet that you are 
> > using SQL Server 2005.  
> > 
> > If so I have seen this several times.  It is to do with a .Net 2.0 and SQL 
> > Server 2005 ADO issue.  Yes I know CRM is .Net1.1 but when using SQL Server 
> > 2005 this appears.
> > 
> > Check out the KB below and should resolve your issue: -
> > 
> > http://support.microsoft.com/?kbid=912732
> > 
> > If this resolves your issue please march your post as answered.  Many thanks
> > -- 
> > Rgds
> > 
> > Michael
> > MCDBA 2000 | MCITP DBA 2005
> > 
> > 
> > "Johnny" wrote:
> > 
> > > Hi all:
> > > 
> > > I have a workflow rule that fires when a new lead is created. The rule 
> > > assigns the lead to a user, sends an email to the user to inform them they 
> > > have a lead, and then it creates a task for the user. However, for some 
> > > reason the rule fails on the task creation, with the error:
> > > 
> > > "Error code = 80131509. This SqlTransaction has completed; it is no longer 
> > > usable"
> > > 
> > > I thought it might be because I was trying to assign the task to the logical 
> > > owner, and perhaps the owner had not been set yet, so I changed the rule to 
> > > create the task for a static user and it still fails.
> > > 
> > > Can anyone suggest a fix for this?
> > > 
> > > -- 
> > > John.
> > > 
> > > http://mscrmguy.blogspot.com/
> > > 
0
Utf
6/12/2007 9:17:02 PM
Thanks!  I applied the fix and it solved the problem.

Med

"Michael Langdon" wrote:

> The fix is installed on the MSCRM/Web Server.
> -- 
> Rgds
> 
> Michael
> MCDBA 2000 | MCITP DBA 2005
> 
> 
> "Medardo Lacayo" wrote:
> 
> > Hi Michael,
> > 
> > This may seem like a dumb question, but on what server do you install the 
> > fix in?  The CRM server or the SQL 2005 server?  I read someone elses thread 
> > where you suggested this fix and it worked, but it is still not clear to me 
> > where to install the fix.
> > 
> > Thanks in advance.
> > 
> > Med
> > 
> > "Michael Langdon" wrote:
> > 
> > > Hi
> > > 
> > > Your post does not mention your environment but I would bet that you are 
> > > using SQL Server 2005.  
> > > 
> > > If so I have seen this several times.  It is to do with a .Net 2.0 and SQL 
> > > Server 2005 ADO issue.  Yes I know CRM is .Net1.1 but when using SQL Server 
> > > 2005 this appears.
> > > 
> > > Check out the KB below and should resolve your issue: -
> > > 
> > > http://support.microsoft.com/?kbid=912732
> > > 
> > > If this resolves your issue please march your post as answered.  Many thanks
> > > -- 
> > > Rgds
> > > 
> > > Michael
> > > MCDBA 2000 | MCITP DBA 2005
> > > 
> > > 
> > > "Johnny" wrote:
> > > 
> > > > Hi all:
> > > > 
> > > > I have a workflow rule that fires when a new lead is created. The rule 
> > > > assigns the lead to a user, sends an email to the user to inform them they 
> > > > have a lead, and then it creates a task for the user. However, for some 
> > > > reason the rule fails on the task creation, with the error:
> > > > 
> > > > "Error code = 80131509. This SqlTransaction has completed; it is no longer 
> > > > usable"
> > > > 
> > > > I thought it might be because I was trying to assign the task to the logical 
> > > > owner, and perhaps the owner had not been set yet, so I changed the rule to 
> > > > create the task for a static user and it still fails.
> > > > 
> > > > Can anyone suggest a fix for this?
> > > > 
> > > > -- 
> > > > John.
> > > > 
> > > > http://mscrmguy.blogspot.com/
> > > > 
0
Utf
6/12/2007 11:01:01 PM
Cool glad to hear.  Can you mark your post as answer so that others know that 
it has been helpfull
-- 
Rgds

Michael
MCDBA 2000 | MCITP DBA 2005


"Medardo Lacayo" wrote:

> Thanks!  I applied the fix and it solved the problem.
> 
> Med
> 
> "Michael Langdon" wrote:
> 
> > The fix is installed on the MSCRM/Web Server.
> > -- 
> > Rgds
> > 
> > Michael
> > MCDBA 2000 | MCITP DBA 2005
> > 
> > 
> > "Medardo Lacayo" wrote:
> > 
> > > Hi Michael,
> > > 
> > > This may seem like a dumb question, but on what server do you install the 
> > > fix in?  The CRM server or the SQL 2005 server?  I read someone elses thread 
> > > where you suggested this fix and it worked, but it is still not clear to me 
> > > where to install the fix.
> > > 
> > > Thanks in advance.
> > > 
> > > Med
> > > 
> > > "Michael Langdon" wrote:
> > > 
> > > > Hi
> > > > 
> > > > Your post does not mention your environment but I would bet that you are 
> > > > using SQL Server 2005.  
> > > > 
> > > > If so I have seen this several times.  It is to do with a .Net 2.0 and SQL 
> > > > Server 2005 ADO issue.  Yes I know CRM is .Net1.1 but when using SQL Server 
> > > > 2005 this appears.
> > > > 
> > > > Check out the KB below and should resolve your issue: -
> > > > 
> > > > http://support.microsoft.com/?kbid=912732
> > > > 
> > > > If this resolves your issue please march your post as answered.  Many thanks
> > > > -- 
> > > > Rgds
> > > > 
> > > > Michael
> > > > MCDBA 2000 | MCITP DBA 2005
> > > > 
> > > > 
> > > > "Johnny" wrote:
> > > > 
> > > > > Hi all:
> > > > > 
> > > > > I have a workflow rule that fires when a new lead is created. The rule 
> > > > > assigns the lead to a user, sends an email to the user to inform them they 
> > > > > have a lead, and then it creates a task for the user. However, for some 
> > > > > reason the rule fails on the task creation, with the error:
> > > > > 
> > > > > "Error code = 80131509. This SqlTransaction has completed; it is no longer 
> > > > > usable"
> > > > > 
> > > > > I thought it might be because I was trying to assign the task to the logical 
> > > > > owner, and perhaps the owner had not been set yet, so I changed the rule to 
> > > > > create the task for a static user and it still fails.
> > > > > 
> > > > > Can anyone suggest a fix for this?
> > > > > 
> > > > > -- 
> > > > > John.
> > > > > 
> > > > > http://mscrmguy.blogspot.com/
> > > > > 
0
Utf
6/12/2007 11:17:01 PM
Reply:

Similar Artilces:

How to mark and creat index in Publisher 2003
When I make a book in Publisher 2003, it looks like the same in Word 2003. But how can I mark and creat index in Publisher 2003, and creat the contents in the head of the book? Thanks a lot. ----James Manually. There is no function built into Publisher to do that. -- ...

Data Migration manager setup fails.
I'm trying to instaal DMM on an XP machine. Everything goes fine until the installation is stopped. The message in my logfiles is: EVENT-Id:17188 MSCRMPERFCOUNTER. Sorry the rest is in Dutcht: Kan beschrijving voor gebeurtenis-ID (17188) in bron (MSCRMPerfCounters) niet vinden. De lokale computer beschikt wellicht niet over de benodigde registergegevens of DLL-berichtbestanden om berichten van een externe computer te kunnen weergeven. U kunt mogelijk de schakeloptie /AUXSOURCE= gebruiken om deze beschrijving op te halen, zie Help en ondersteuning voor details. De volgende gegevens z...

How can I create Combo list with no VBA
I would like to create drop down list the old fashioned way. I know nothing about VBA or ActiveX. Previous version of excel allowed you to create a control with a drop down list which after selection will put the output in a specific field on which calculation could start. Is there a way to get Excel to work the old way Open up the control tool box. Select the combo box and place it on your worksheet. Put the list of values that you want in a column range somewhere. Open the properties for the combo box. Enter the range with your values in the ListFillRange property, like A2:A10 Enter the ...

online update fails, money 2004
Running Windows XP w/SP1, Ie 6.0 that claims 128bit cipher strength, and Money 2004 v12.0 When I go to the link provided there are only updates for IE5.5 and older, any ideas? Damon Damon@nospam.nospam.really-nospam.Achey.Net --------------------------- Microsoft Money --------------------------- Money was unable to establish a secure connection to the server due to a problem with the security components on your machine. <br><br>This error is often caused by an older version of Microsoft Strong Encryption. You can obtain the latest version of strong encryption from <a HREF=...

losts tasks again
They could possibly store your tasks (ext .msg) in C:\WINDOWS\Local Settings\Application Data\Microsoft\Outlook\archive.pst ...

Workflow eMail 03-21-07
What email address is used for the FROM field when defining an email in workflow? thanks The From field is depended on the owner of the record. Hopr this helps! Darren Liu Crowe Chizek and Company http://www.crowecrm.com On Mar 21, 9:38 am, "Dyawlak" <dyaw...@yahoo.com> wrote: > What email address is used for the FROM field when defining an email in > workflow? > > thanks Thanks Darren, in the case of Service case, is that the owner of the Account? Thanks "Darren Liu" <darrenliu@gmail.com> wrote in message news:1174490272.633022.73240@...

Help with creating drop down
Hi,, can anyone help me on how i can create a drop down combination(i'm not sure what it is called)? x y z X1 y1 z1 x2 y2 z2 x3 y3 z3 What im trying to do is if cell A1 has a drop down list(with X,Y,Z selection), i would like cell B1 to return another drop down list that contains a list corresponding to what was selected in cell A1.. so if cell A1 is Y, then cell B2 will show another list with Y1,Y2 and Y3 selection... Im using MS Office 2007. Please advise and thank you very much. Hi, take a look at Debra web has excellent examples http://www.contextur...

Workflows not starting automatically with one user
I am having an issue where workflow rules that were created and worked fine in 1.2 are not start automatically in 3.0 for one user (me). I can manually start the rule and it's fine and others can do the same action that should start the rule and it works for them..just not me. My research tells me is probably related to me being an administrator and/or being an administrator when I created the rules. I've also been told to look at the user that the CRM workflow service runs as and make sure that service account has the correct privaleges-which it does. I am just not sure w...

create a calendar #2
Thank you so much, JulieD ! I think it is a wonderful solution to m problem. I will email you directly also. Thank you very much again. Best regards, elenapili -- elenapili ----------------------------------------------------------------------- elenapilin's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1569 View this thread: http://www.excelforum.com/showthread.php?threadid=27225 Hi glad to assist. Hope you received the file i emailed. Cheers JulieD "elenapilin" <elenapilin.1eqmny@excelforum-nospam.com> wrote in message news:elenapilin....

Create standard folders in all users mailboxes.
I am playing with some email archiving software and instead of applying archiving rules to a user's inbox, I want to create a standard folder that users can move their mail to so it can be archived. Im sure there is a way to create this folder for all users as well as ensure it stays there in the future (and for new users, etc) ... Any suggestions ? On Tue, 22 Mar 2005 05:29:01 -0800, "Mal.Harwood" <Mal.Harwood@discussions.microsoft.com> wrote: >I am playing with some email archiving software and instead of applying >archiving rules to a user's inbox, I w...

Great Plains 10.0 Workflow installation Error
Hi, I am trying to install GP 10.0 Workflow on my PC. I have installed GP 10.0 on my Windows Server 2003 SP2 system with Sharepoint 2007 and completed all the pre-requisites required for installing GP 10.0 Workflow. While I am at the end of the installation process after providing GP Webservice and GP Security Service paths, an error dialog box appears on my screen displaying "Microsoft .NET Framework 2.0 must be installed in order to continue with the installation.". I have already installed .Net versions 1.1, 2.0, 3.0 earlier. Can anyone help me out on this?? I have foun...

How can I create a Public Contact Folder in Exchange 2003
It seems that I can only create public e-mail folders. How can I create a public contact folder? I am kind of new in exchange so any help would apreciated. Mike When you create the folder it asks what type of data to store - choose contacts. -- Hope that helps, Dan Townsend This posting is provided "AS IS" with no warranties, and confers no rights. Please do not send email to this address, post a reply to this newsgroup. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm "Mike" <recklez@cyprus-x.org>...

Create XML Document given an XSD
Hi, Does .Net framework provide a way to create an XML Document based on an XSD? I know that there may be an issue with the data inside it, but it doesn't have to be a valid XML document to start with and then the user can fill in the blanks. Regards, --- Victor Hadianto http://www.synop.com/Products/SauceReader/ Victor Hadianto wrote: > Does .Net framework provide a way to create an XML Document based on an XSD? > I know that there may be an issue with the data inside it, but it doesn't > have to be a valid XML document to start with and then the user can fill in ...

Error message "The operation failed"
Hi, we have a public contacts folder with a self designed form. This form includes a field called "Add. Notes". Since a few days, I cannot acces this field anymore when I try to create a view with this field, or when I try to drag and drop this field from the field chooser to the column title. I always get the error "The operation failed" - but this isn't really helpful :-( I've deleted the formscache already, no success. When I open an item with this field associated, it works perfectly in the form itself, only when I try to access the field from the preview pane i...

Creating a calculated field using dates in a form
I am trying to use dates from 2 fields in a form (HireDate-DOB) to calculate age. Then, using the age, I want to display a message if the age is less than 18. I think I have written a conditional statement correctly, but am unsure where to place it so that the message displays when the condition is met. I am totally new to Access 2007 and VB. You did not say what the content of your 'conditional statement' was and how you plan on using it. What has HireDate to do with it? Is it you want to see if their age is less than 18 on the date of hiring? Then this will c...

Can't create a new public folder.
I ran into the following problems: In the System Manager, the "public folders" container doesn't list public folders and system folders. Also when I tried to create a new public folder, the system didn't response at all, no even giving me any error message. Does anyone happen to know what the problem is? Thanks a lot in advance! "sun" <sun@discussions.microsoft.com> wrote in message news:F80E3901-55EB-42AA-9914-6069F19CAE90@microsoft.com... >I ran into the following problems: > > In the System Manager, the "public folders" container d...

IE7 and OWA on Vista fails.. is there a workaround?
Ti there, I bought my daughter a new laptop with Vista. She accesses her school email with OWA. IE7 on Vista has a problem with the Exchange 2003 server (IE7 crashes on email send action). According to some reading on the MS websites and elsewhere, there seem to be a known bug related to S/MIME. So, there is a patch for the Exchange server to have this fixed. This takes a while (that admin of the Exchange server is primarily a teacher) and I would like to have a workaround until this is fixed. Direct Outlook 2007 access is not enabled, nor is IMAP. Using Firefox somewhat works but is ...

How can a user created template be added to the toolbar
Running Office 2007 Pro. I inadvertently posted this question in the forms forum. I created a template that I would like to access from the toolbar instead through the menu even though I have eliminated a couple steps by putting Choose Form on the toolbar it still takes more clicks than I want. I saw instructions about adding a form but I couldn't get past "modifying selection" after selecting the macro. So how do I add my OFT file to the toolbar? Thanks for you time and assistance! ...

Create Lead from Email #2
I have setup a queue to receive incoming emails from leads. I am able to use a workflow to create a new lead for each incoming email. The issue that I have encountered is that the data for these leads are collected by outside vendors and contain additional information. Each vendors format is consistent. I would like to be able to parse the body of the email and populate fields in the lead. I would prefer to do this using CRM but if you know of some good 3rd party tools please let me know. Thanks Chris, We are developing a solution to address our client requirements, reading the email ...

Creating New E-Mail Outlook 2002 sp21
When attempting to create new email an "unspecified error" occurs and precludes me from completing the emial. Am using Office XP suite with Outlook 2002 sp1. Original issue was just a single notification and when closed would allow me to create message. Has progressed to where error frame self propagates continuously, does this sound viral ? Certainly doesn't sound healthy. Have you tried Detect & Repair? (look in Help) Is your virus checker running the latest updates - with what results? K "Scott" <anonymous@discussions.microsoft.com> wrote in messa...

Any1 know how-to create the input file needed for the Exchange DST Update Tool?
I have tried different methods suggested by MS, but I am unable to produce an input file in the following format: User_DNTABServer_Friendly_NameTABOS_Time Zone_Registry_KeyCRLF You would think the script would produce an output in the same format to use for the update... You are running MSEXTMZ in "Time Zone Extraction" Mode? (That is the mode that creates the TAB delimited TZ file) The account you are running under has correct permissions (Full mailbox access and Send As)? What does your .ini file look like? <slerche@gmail.com> wrote in message news:1171639396.9825...

create switchboard button that will close program entirely
I have a switchboard button that closes the database but leaves Access open. Is there a way I can have the button close the database and Access with one click? Dear robnsd: Try the following code: DoCmd.Quit HTH -- Fred Boer - Amateur Access Enthusiast Interests: Library software / Z39.50 / Web Services Freeware Small Library Application available here: http://www3.sympatico.ca/lornarourke/ "robnsd" <robnsd@sbcglobal.net> wrote in message news:1188765557.922703.326790@19g2000hsx.googlegroups.com... >I have a switchboard button that closes the database but leaves Ac...

After reboot Exchange Services Fail to Start
I have three new servers, a DC, and two additional domain controllers. One of the additonal domain controllers has Exchange 2003 running on it with SP2. Each time I reboot the server, the logon prompt warns that services could not be started. Upon inspection of the Event Log and Services, it appears that the Inforamation Store, MTA stacks and Attendant never start. This is even after making the 1st, 2nd, 3rd failure to restart the service. Event ID: 8026 LDAP Bind was unsuccessful on directory <<machinename>>.<<domain>>.local for distinguished name ''....

Creating Formatted Report and Emailing
I was wondering if anyone has any idea of how I might send out nicely formatted reports, where the report content is in the body of the email? I have seen a number of threads posted about sending attachments, and that will likely be my "fallback" approach. Trying to avoid attachments, however, as this required folks, who are already in email jail, to take an extra step, which results in them not seeing the report (my reports are communicating significant issues in ongoing projects, and important that they at least "See" the red flags in the report). T...

unable to Create dialog in extension dll
>From within an extension dll, I want to create a simple dialog that I create using the resource editor. This code should create and show it: MyDlg * myDlg = new MyDlg; myDlg->Create( MyDlg::IDD, CWnd::GetDesktopWindow() ); myDlg->ShowWindow( SW_SHOW ); However, when executing in my extension dll, the Create statement asserts here: BOOL CWnd::CreateDlgIndirect(LPCDLGTEMPLATE lpDialogTemplate, CWnd* pParentWnd, HINSTANCE hInst) { #ifdef _DEBUG if ( AfxGetApp()- >IsKindOf( RUNTIME_CLASS( COleControlModule ) ) ) .... This is because AfxGetApp() returns a NULL. ...