Axapta 3.0: Setting the linktype of DataSources at runtime

Hello all,

I have a button on form. It's click-EventHandler contains a line:

    CIRTRAStndTourOrderLine_ds.linkType(Transporteinheit.valueStr() ? 3 /* 
InnerJoin */ : 4 /* OuterJoin */);

Where "CIRTRAStndTourOrderLine_ds" is the data source generated by MorphX 
(CIRTRAStndTourOrderLine) is a table. "Transporteinheit" is a StringEdit.

The behaviour I would like to achieve is, that if I enter something into the 
StringEdit it sets the linktype to InnerJoin otherwise to OuterJoin another 
table.

In MorphX I set the linktype to OuterJoin (as a default).

The problem is, that axapta simply does not change anything. I suppose I 
need some kind of refresh.

Yours sincerely Hot_Ice
0
Utf
7/10/2006 2:18:01 PM
crm 35858 articles. 1 followers. Follow

1 Replies
392 Views

Similar Articles

[PageSpeed] 8

------=_NextPart_0001_5B64CACB
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hi Hot_Ice,

Thanks for the post!

This newsgroup is for install and deployment issues.  Please post this over 
in the Dev newsgroup.  They will likely have an answer there.  

That group is one level deeper at microsoft.public.crm.development

Thanks!.

Mike

Kind regards,
Mike

======================================================
PLEASE NOTE:  The partner managed newsgroups are provided to assist with 
break/fix issues and simple how to questions.  
======================================================
We also love to hear your product feedback!  Let us know what you think by 
posting from the web interface: Partner Feedback 
from your newsreader:  microsoft.private.directaccess.partnerfeedback. We 
look forward to hearing from you!
====================================================== 
When responding to posts, please "Reply to Group" via your newsreader so 
that others may learn and benefit from this issue. 
======================================================
This posting is provided "AS IS" with no warranties, and confers no rights. 
======================================================


------=_NextPart_0001_5B64CACB
Content-Type: text/x-rtf
Content-Transfer-Encoding: 7bit

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fprq2\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\f0\fs20 Hi Hot_Ice,
\par 
\par Thanks for the post!
\par 
\par This newsgroup is for install and deployment issues.  Please post this over in the Dev newsgroup.  They will likely have an answer there.  
\par 
\par That group is one level deeper at microsoft.public.crm.development
\par 
\par Thanks!.
\par 
\par Mike
\par 
\par Kind regards,
\par Mike
\par 
\par ======================================================
\par PLEASE NOTE:  The partner managed newsgroups are provided to assist with break/fix issues and simple how to questions.  
\par ======================================================
\par We also love to hear your product feedback!  Let us know what you think by posting from the web interface: Partner Feedback 
\par from your newsreader:  microsoft.private.directaccess.partnerfeedback. We look forward to hearing from you!
\par ====================================================== 
\par When responding to posts, please "Reply to Group" via your newsreader so that others may learn and benefit from this issue. 
\par ======================================================
\par This posting is provided "AS IS" with no warranties, and confers no rights. 
\par ======================================================
\par 
\par 
\par 
\par }
------=_NextPart_0001_5B64CACB--

0
mchristl
7/12/2006 6:16:32 PM
Reply:

Similar Artilces:

GP 10.0 Fresh Installation
I am trying to install GP 10.0 Trial Version on my laptop. Once when I tried half-way through the installation I had to abort installation. Subsequently after uninstalling all the installed component I restarted installation. Pre-requisite component installation window appears and installs Dextrity components. Next when I try installation using Autorun.inf file I get error "Installation Failed". If I try invoking Setup.exe directly nothing happens. Can someone help me? Hi pvravindran If this is a French Canadian Installation, I would recommend you contact Strophe (www.strop...

Upgrading to 9.0 on Windows Server 2003 64bit Edition
We are upgrading from 7.0 to 9.0. We have new SQL Servers on which we will perform the upgrade and move into production once complete replacing our existing servers. These SQL Servers are running Windows Server 2003 Enterprise x64 Edition. When attempting to install either GP v7.0 or v7.5 the error message "The image file ...\CDSetup.exe is valid, but is for a machine type other than the current machine." is presented and the installation script will not initialize. Is it possible to install GP 7.0 or 7.5 on the 64bit version of Windows Server 2003 or must we install the 32 bit v...

Reg: Tracking emails into MS CRM3.0
Hi Just now I installed MS CRM 3.0 desktop outlook client in my system. I am unable to track more than 1 email into CRM at a time from my Outlook inbox. Is there any way to track more than 1 email into CRM? please let me know......... Thx in advance. Anil V no, you can only do one at a time. If you need to track a lot of e-mail, you should investigate the CRM Exchange Router which will automatically post e-mail for you. Dave Ireland "Anil Kumar V" <AnilKumarV@discussions.microsoft.com> wrote in message news:9E965A49-5558-4D7E-836F-A80092F57F30@microsoft.com... > Hi ...

Stacked charts #3
Is it possible to create a circular stacked chart? So the radius of the circle is equivalent to the height of the bar. It seems like it should be possible but I just can't think of a way to get it done! Thanks in advance, HarryAdney Not too sure if this is what you want, but you can take the existing chart, create a circle from the drawing toolbar, copy the circle, click on the bar you want changing and paste it -- John MOS Master Instructor Office 2000, 2002 & 2003 Please reply & rate any replies you get Ice Hockey rules (especially the Wightlink Raiders) "HarryAd...

How do I set up a URL address to send and recieve e mail?
I'm using Outlook 2003. How can I set Outlook up to send and recieve e mail from Microsoft Web Access? It has a https URL. -- Thank You James P Murphy Outlook's WebDav (HTTP) protocol doesn't support HTTPS urls. http://www.outlook-tips.net/archives/2005/20050322.htm -- "J Murphy" <JMurphy@discussions.microsoft.com> wrote in message news:0D0201CB-113B-44C6-946B-206C3AAF069D@microsoft.com... > I'm using Outlook 2003. How can I set Outlook up to send and recieve e > mail > from Microsoft Web Access? It has a https URL. > -- > Thank You...

ZIP codes beginning with 0
I'm having trouble getting ZIP codes beginning with 0 to stick, even when specifying ZIP code in the format category type. No matter what I do, the initial 0 always gets dropped. Advice? Thanks. Hi Peter.......... Either pre-format your cells as TEXT, or enter a leading apostrophe before entering the number with the leading 0........the apostrophe won't show, it only forces TEXT formatting on that cell.......... Vaya con Dios,] Chuck, CABGx3 "Peter" <anonymous@discussions.microsoft.com> wrote in message news:2ab7001c46836$3382cf70$a601280a@phx.gbl... > I&...

Do I need DSClient to run Exchange 5.5 on an NT4.0 box in Windows 2003 Native Mode ADS?
Good Evening, I am in the process of migrating my WinNT4.0 domain and Exchange 5.5 Org to Windows 2003 ADS/Exchange 2003. I know best practice is to change the domain to Native mode, but how does this affect my NT4.0 server running 5.5? Do I need to simply load the DSClient onto the server? I should also note that we did an inplace upgrade from NT 4.0. This is a single domain environment. As long as you no longer have NT 4.0 BDCs you should be able to move to native mode. Your NT 4.0 server running E55 will not be affected (unless of course it is also a BDC). It is a good idea to...

Online Banking #3
I tried to use online banking with BOA these past couple of months, but it just did not work well. There are transactions just did not show up in my Money and I had to enter them myself. Is there any suggestion that I could balance my account monthly in a more efficient way? Or should I just foreget the online banking feature and start manually enter the transactions? Thanks ! Winnie "Winnie" <Winnie@discussions.microsoft.com> wrote in message news:C951ED1E-1F33-4589-947B-DB63B3B7D7B8@microsoft.com... >I tried to use online banking with BOA these past couple of m...

CRM3.0 Question on Activity
Hello, I am using CRM3.0. I have the following case. 1. Create Campaign 2. Add contact to campaign list 3. Create Campaign activity - Phone call 4. Distribute activity 5. CRM User will make phone call 6. When contact is interest, CRM user will make a "Free Trail" for contact. I am having troble in step 6. So far as I know, I have two choices for "Free Trail". A) Service Activity If I choose to create a service activity, then I can not link up the service activity with the campaign or phone call. B) Appointment If I choose appointment, I can set "regarding"...

MS CRM 3.0 Small B. ed. modules
We have installed Small business server on one computer with all requirements fullfilled. The problem is: we have available only 3 of 5 (or 6) modules: service, settings and workplace. The other 2 - marketing and sales (wich we consider to be the most important) are not available (we can't see them). Does anybody know how to solve the problem? Thank you! Hello, may be i have a solution for you. You have to check the other modules in the following menu: - startpage of CRM - extra - options (--> a new page will be shown) Then click on workplace: there you can...

unread email shows 3 envelopes
strangest thing....my unread/read emails shows three envelopes instead of one...I have the latest virus scan and checked for virus known found, checked for virus with mcafee online(free) nothing...have the latest office update and windows...I don't get any wierd errors or bsod. can anybody help appreciate it very much. >-----Original Message----- >strangest thing....my unread/read emails shows three >envelopes instead of one...I have the latest virus scan >and checked for virus known found, checked for virus with >mcafee online(free) nothing...have the latest offic...

Error message #3
Hi, everyone, I open to MS Excel 97, the following error messages was shown on screen. 26146100: file format is not valid. Please help Thanks Jimmy Something that is being opened is causing trouble. It could be an addin checked in Tools|Addins or a file in your XLStart folder (or if you are using tools|options|General|"Alternate Startup File location", it could be in there.) (Not many use the alternate startup file location, so try erasing that value from that box in excel--don't delete the real folder. If that fixed it, you're done.) If not, your task will be to...

Setting email so server will not save emails on server
I have two computers. ( Desktop & laptop) I seldom use the laptop but when I do use it and get my emails it brings up every email that I have already read and deleted from desktop. Is there a setting where I can set so the server will not keep the deleted emails? On both machines: Tools | Accounts | Mail | Properties | Advanced - Check: Leave a copy of messages on the server. On one machine only, (The desktop would be logical for you), check to Delete messages after X days to satisfy your allotted space you get from your server, and Remove from server when d...

New Entity visit Report and Integration of Participants (MS CRM 3.
Hello Newsgroup, We have created a new Entity called visit reports. We have to add Participants in this new entity. It would nice, if we could have a field like the Participants in the appointment, where you can select the Participants from Contacts, Accounts, and Users. I'll hope , some of you have a idear. Regards Thomas You have to create a new relationship for your custom entity to the types of participants you want to be available. -- Matt Wittemann http://icu-mscrm.blogspot.com "Thomas Haller" wrote: > Hello Newsgroup, > > We have created a new Entity...

Setting up an email server
I have an established 5.5 server and a I added a new domain to it. All the routing looks good, I have the new MX pointing to the domain of my external port on my firewall. And the new domain is added into Exchange. But when I try to send an email to a new recipent using the new domain name I recieve: xx.xxx.xxx.xxx does not like recipient. Remote host said: 550 Relaying is prohibited Giving up on xx.xxx.xxx.xxx. Any ideas? On Wed, 22 Feb 2006 18:57:41 -0700, "Need Help" <needhelp@address.com> wrote: >I have an established 5.5 server and a I added a new domain to it. &...

Set a recurring task ie. a task to check a website each month
It would be advantageous to be able to set a recurring task ie. a daily, weekly, monthly or other multiple task. An example would be if you needed to go to an accounts website or prospects website once a month to look for leads. Or to check out a competitor for new things on their website. It could also apply to phoning or mailing etc. This would save constantly having to remember to create a followup or write up to dozens of followups at different dates. ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote f...

Outlook2002 #3
Since I purchased Office XP Professional and started using Outlook2002, I have constant problems with "Program not responding" after a few seconds. During these seconds, it works fine. I have uninstalled, rebooted, reinstalled, downloaded every patch and the situation seems to be getting worse. I can use Outlook Express without any problem, but having paid for Outlook and prefering it anyway I would like to resolve this. I have run 2 different anti-virus programs and there does not seem to be a problem. I am using a Pentium lll 800 with 512MB of RAM and everything else work...

MS POS 1.0 Install error...
Im using XP PRO SP2 ..net 1.1 installed MS SQLServer installed When i try and install MS Point of Sale 1.0 , i get this error message at the end of the install, when it says "Installing and configuring database" ------Error Message------ System.ComponentModel.Win32Exception: The system cannot find the file specified at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo) at System.Diagnostics.Process.Start() at Microsoft.Rms.Installation.CustomActions.Utilities.OpenSqlPortInFirewall(String installPath, String portNumber, String& errorMessage...

How do I assign a set of values to a selection from a drop list?
Hi. I am trying to assign a set of values, in separate fields ,to a each selection from a drop-down list in Excel (using data validation). What I am trying to do is very smilar to, say, to selecting a SKU from a list and having the product description, unit price etc. fill into their corresponding fields automatically. For example, I pick SKU "11111" from a drop-down list to fill the SKU field, then, automatically, "5-inch widget" comes up in the product description field and "$5.00" shows up in the unit price field. Please help. Mike Along with the d...

CRM 4.0 Terminal Services support
I have read through the CRM 4.0 planning guide and the "what's new in CRM 4.0" partner guide, and see very little mention of Terminal Services support for the client Outlook 2003/2007 CRM Plugin. One example in the Planning Guide page 4-63 shows a "Terminal Server, Microsoft Dynamics CRM for Outlook" in "Domain B - Forest Y". There also appears to be a discrepancy between these two guides in support for Windows 2000 SP4 - the what's new page 2-11 specifically says it is supported, and the planning guide page 3-29 specifically says it is not. Is t...

how to save settings for printing several envelopes
I want to print addresses on several envelopes which are the same size but the addresses are different (for Christmas cards). Is there a way to do this without going to options each time and reset the size and font that I want? Create an envelope template. You can start from scratch with a new document, selecting the desired paper size (or specifying a custom size) or use Add to Document to add your envelope to the current document. Then see http://sbarnhill.mvps.org/WordFAQs/DetachEnvelope.htm for instructions on separating the envelope from the document. Once you have just the ...

How do I set up excel to make estimating(pricing) easier?
I am trying to find out how to use excel as a estimating or pricing program. Does anyone know how to do this? Hi Ann, I can send you a simple (fake) sample worksheet of pricing out the cost of manufacturing and shipping a washing machine. It may help you to get going. It uses drop down lists and VLOOKUP formulas to estimate the price of different options and shipping prices based on different zones. Regards, Howard "Ann from CCC" <Ann from CCC@discussions.microsoft.com> wrote in message news:A58874DF-8329-48B7-ACB0-4567A8BBBA89@microsoft.com... >I am trying to f...

CListCtrl InsertColumn(0, "L", LVCFMT_RIGHT)?
Hi, The CListCtrl doesn't appear to like the first column to be aligned non-left. Why? By inserting the first column with InsertColumn(1, "L", LVCFMT_RIGHT), it does show it right aligned. But what if there are columns already? Should I delete and reinsert them all? "Olaf van der Spek" <Olaf@XCC.TMFWeb.NL> wrote in message news:%23K2rr8LLFHA.2716@TK2MSFTNGP15.phx.gbl... > Hi, > > The CListCtrl doesn't appear to like the first column to be aligned > non-left. Why? > By inserting the first column with InsertColumn(1, "L", LVCFMT_R...

custom border problem #3
In Publisher 2007 when I try to create a custom border using a wmf/bmp/gif clipart of 5 to 10 kb size I get the following Alert Message: "This picture is too complex to be made into a border". How can I get around this problem as I have tried over a 100 pieces of clipart which Publisher rejects as too complex. What is an acceptable piece of clipart to Publisher? Surely there must be some simple solution to this. Can anyone help? "Broadford1" <jbane.ennis@eircom.net> wrote in message news:eJZabYejIHA.4064@TK2MSFTNGP06.phx.gbl... > In Publisher 2007 when I ...

How do I publish to the web a 3 page web pubblication from Publis.
I created a 3 page web publication in Publisher 2003, but when I 'publish it to the web', only the first page is converted. What do I need to do? Review the FAQ - http://www.publishermvps.com/Default.aspx?tabid=30 -- David Bartosik - MS MVP www.publishermvps.com "Bazbo" <Bazbo@discussions.microsoft.com> wrote in message news:4B2BCFAD-8DB3-40C3-A0E2-B1EBDC60DE74@microsoft.com... > I created a 3 page web publication in Publisher 2003, but when I 'publish it > to the web', only the first page is converted. What do I need to do? ...