ASP.NET page to access CRM store

Hi,


I am writing a web application to talk with the CRM store.  I am
having problems authenticating and running a query.  Here's my code.

bizUser.Url = strDir + "BizUser.srf"

Dim credentialCache = New System.Net.CredentialCache

Dim credentials As New System.Net.NetworkCredential
credentials.Domain = "test"
credentials.Password = "pass"
credentials.UserName = "user"

credentialCache.Add(New Uri("http://" + strServer), "NTLM",
credentials)

bizUser.Credentials = credentialCache

Dim query As New Microsoft.Crm.Platform.Proxy.CRMQuery
query.Credentials = System.Net.CredentialCache.DefaultCredentials
query.Url = strDir + "CRMQuery.srf"

Dim strErrorMsg As String
Try

 Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth =
bizUser.WhoAmI
 
 Dim strQueryXML As String = "<fetch mapping='logical'><entity
name='account'><all-attributes/></entity></fetch>"

 Dim strQueryResultXml As String = query.ExecuteQuery(userAuth,
strQueryXML)

I always error out on the line that executes the query.  The error I
get is Server Application Faulted 80040204 Invalid user auth.The user
ID does not match the thread
token.d:\crm\build\3297\src\platform\security\crmsecurity\secmain.cpp708


If I change the declaration of the userAuth line to 
Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth = New
Microsoft.CRM.Platform.Proxy.CUserAuth
 
and give the userAuth a UserID, I get the error Server Application
Faulted 80070057The parameter is incorrect, which I imagine is because
the userAuth probably didn't get made correctly.

Does anybody have any insights into why my code isn't working?


Thanks
Josh
0
kandiko
5/5/2004 6:47:57 PM
crm 35858 articles. 1 followers. Follow

6 Replies
617 Views

Similar Articles

[PageSpeed] 14

I've been struggleing with a similar issue.  I think the 
error is happening in the whoami method of your biz user 
object.  The only technical article I found had to do 
witht the port being incorrect for the web server.  
Should be 80.
Probably wont help but then MS is  notorious for lousy 
obfuscated documentation that tells developers nothing.
I still have not resolved my problem.
>-----Original Message-----
>Hi,
>
>
>I am writing a web application to talk with the CRM 
store.  I am
>having problems authenticating and running a query.  
Here's my code.
>
>bizUser.Url = strDir + "BizUser.srf"
>
>Dim credentialCache = New System.Net.CredentialCache
>
>Dim credentials As New System.Net.NetworkCredential
>credentials.Domain = "test"
>credentials.Password = "pass"
>credentials.UserName = "user"
>
>credentialCache.Add(New Uri("http://" + 
strServer), "NTLM",
>credentials)
>
>bizUser.Credentials = credentialCache
>
>Dim query As New Microsoft.Crm.Platform.Proxy.CRMQuery
>query.Credentials = 
System.Net.CredentialCache.DefaultCredentials
>query.Url = strDir + "CRMQuery.srf"
>
>Dim strErrorMsg As String
>Try
>
> Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth =
>bizUser.WhoAmI
> 
> Dim strQueryXML As String = "<fetch 
mapping='logical'><entity
>name='account'><all-attributes/></entity></fetch>"
>
> Dim strQueryResultXml As String = query.ExecuteQuery
(userAuth,
>strQueryXML)
>
>I always error out on the line that executes the query.  
The error I
>get is Server Application Faulted 80040204 Invalid user 
auth.The user
>ID does not match the thread
>token.d:\crm\build\3297
\src\platform\security\crmsecurity\secmain.cpp708
>
>
>If I change the declaration of the userAuth line to 
>Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth = 
New
>Microsoft.CRM.Platform.Proxy.CUserAuth
> 
>and give the userAuth a UserID, I get the error Server 
Application
>Faulted 80070057The parameter is incorrect, which I 
imagine is because
>the userAuth probably didn't get made correctly.
>
>Does anybody have any insights into why my code isn't 
working?
>
>
>Thanks
>Josh
>.
>
0
Eric
5/5/2004 7:41:39 PM
Hi,

I had the sam issue and my suggestion is that you check 
out the iis and see if websites\yourwebcrmfolder point to 
CRMAppPool. My didn't hence the problem. Also check out 
if there might be other access issues for you web app. 
Hope this helps.

Monika

>-----Original Message-----
>Hi,
>
>
>I am writing a web application to talk with the CRM 
store.  I am
>having problems authenticating and running a query.  
Here's my code.
>
>bizUser.Url = strDir + "BizUser.srf"
>
>Dim credentialCache = New System.Net.CredentialCache
>
>Dim credentials As New System.Net.NetworkCredential
>credentials.Domain = "test"
>credentials.Password = "pass"
>credentials.UserName = "user"
>
>credentialCache.Add(New Uri("http://" + 
strServer), "NTLM",
>credentials)
>
>bizUser.Credentials = credentialCache
>
>Dim query As New Microsoft.Crm.Platform.Proxy.CRMQuery
>query.Credentials = 
System.Net.CredentialCache.DefaultCredentials
>query.Url = strDir + "CRMQuery.srf"
>
>Dim strErrorMsg As String
>Try
>
> Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth =
>bizUser.WhoAmI
> 
> Dim strQueryXML As String = "<fetch 
mapping='logical'><entity
>name='account'><all-attributes/></entity></fetch>"
>
> Dim strQueryResultXml As String = query.ExecuteQuery
(userAuth,
>strQueryXML)
>
>I always error out on the line that executes the query.  
The error I
>get is Server Application Faulted 80040204 Invalid user 
auth.The user
>ID does not match the thread
>token.d:\crm\build\3297
\src\platform\security\crmsecurity\secmain.cpp708
>
>
>If I change the declaration of the userAuth line to 
>Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth = 
New
>Microsoft.CRM.Platform.Proxy.CUserAuth
> 
>and give the userAuth a UserID, I get the error Server 
Application
>Faulted 80070057The parameter is incorrect, which I 
imagine is because
>the userAuth probably didn't get made correctly.
>
>Does anybody have any insights into why my code isn't 
working?
>
>
>Thanks
>Josh
>.
>
0
Monika
5/6/2004 8:48:52 AM
Hi all,


I set my application to the CRMAppPool and the website stays in a
loading state.  It never comes up.  When I put the web application
back to the DefaultAppPool, it comes up just fine.  Monika, did this
fix your solution?


Thanks
Josh

PS Anybody have any other suggestions or comments (ahem, Microsoft?)


"Monika" <anonymous@discussions.microsoft.com> wrote in message news:<913c01c43346$f54084b0$a601280a@phx.gbl>...
> Hi,
> 
> I had the sam issue and my suggestion is that you check 
> out the iis and see if websites\yourwebcrmfolder point to 
> CRMAppPool. My didn't hence the problem. Also check out 
> if there might be other access issues for you web app. 
> Hope this helps.
> 
> Monika
0
kandiko
5/6/2004 2:10:46 PM
Update - 

I set the process for the application to run under the
ExchangeCRMAppPool process and it fixed the problem.  Heads up to
anyone running .aspx files to CRM.

Thanks
Josh


kandiko@appliedtech.us (jkandiko) wrote in message news:<85d5c178.0405060610.283b2454@posting.google.com>...
> Hi all,
> 
> 
> I set my application to the CRMAppPool and the website stays in a
> loading state.  It never comes up.  When I put the web application
> back to the DefaultAppPool, it comes up just fine.  Monika, did this
> fix your solution?
> 
> 
> Thanks
> Josh
> 
> PS Anybody have any other suggestions or comments (ahem, Microsoft?)
> 
> 
> "Monika" <anonymous@discussions.microsoft.com> wrote in message news:<913c01c43346$f54084b0$a601280a@phx.gbl>...
> > Hi,
> > 
> > I had the sam issue and my suggestion is that you check 
> > out the iis and see if websites\yourwebcrmfolder point to 
> > CRMAppPool. My didn't hence the problem. Also check out 
> > if there might be other access issues for you web app. 
> > Hope this helps.
> > 
> > Monika
0
kandiko
5/6/2004 10:00:22 PM
Hi.

Can U please post the "how-to"?

Any one else have any other solution for this error?

Thanks in advance.

_________________________________
Atleti de Madrid

kandiko@appliedtech.us (jkandiko) wrote in message news:<85d5c178.0405061400.7282e368@posting.google.com>...
> Update - 
> 
> I set the process for the application to run under the
> ExchangeCRMAppPool process and it fixed the problem.  Heads up to
> anyone running .aspx files to CRM.
> 
> Thanks
> Josh
> 
> 
> kandiko@appliedtech.us (jkandiko) wrote in message news:<85d5c178.0405060610.283b2454@posting.google.com>...
> > Hi all,
> > 
> > 
> > I set my application to the CRMAppPool and the website stays in a
> > loading state.  It never comes up.  When I put the web application
> > back to the DefaultAppPool, it comes up just fine.  Monika, did this
> > fix your solution?
> > 
> > 
> > Thanks
> > Josh
> > 
> > PS Anybody have any other suggestions or comments (ahem, Microsoft?)
> > 
> > 
> > "Monika" <anonymous@discussions.microsoft.com> wrote in message news:<913c01c43346$f54084b0$a601280a@phx.gbl>...
> > > Hi,
> > > 
> > > I had the sam issue and my suggestion is that you check 
> > > out the iis and see if websites\yourwebcrmfolder point to 
> > > CRMAppPool. My didn't hence the problem. Also check out 
> > > if there might be other access issues for you web app. 
> > > Hope this helps.
> > > 
> > > Monika
0
atleti_de_madrid
5/12/2004 12:02:42 PM
I don't know whether you're hard-coding your app user in the code or not but
there are two ways to get the credentials:

1. Use the default credentials.
    bizUser.Credentials = System.Net.CredentialCache.DefaultCredentials;
    This requires that you have Windows Authentication turned on for your
web application in IIS config.

2. Use a specific user credentials.
    bizUser.Credentials = new System.Net.NetworkCredential(username,
password, domain);

You do not need to add your URI etc. do the credentialCache as you do.

For example, this will get you the CUserAuth object you need for the
subsequent call to ExecuteQuery.

BizUser bizUser = new BizUser();
bizUser.Url = <yourpath to BizUser.srf>;
bizUser.Credentials = System.Net.CredentialCache.DefaultCredentials;
    or
bizUser.Credentials = new System.Net.NetworkCredential(username, password,
domain);

CUserAuth userAuth = bizUser.WhoAmI();

By the way, your subsequent calls to the CRM must use the same credentials.
I am guessing this is the source of trouble for your error since you specify
a test user to get the CUserAuth and then use DefaultCredentials to execute
the query itself.

And as for some of the other posts, mentioning CRMAppPool, as far as I know,
your web app does not and probably should not use CRMAppPool.
There is no prerequisite for an ASP.NET app to access the CRM web services
other than that are required for any other ASP.NET application and that you
of course include the two .dlls.

Hope this helps.

Jiho

"jkandiko" <kandiko@appliedtech.us> wrote in message
news:85d5c178.0405051047.451d49c@posting.google.com...
> Hi,
>
>
> I am writing a web application to talk with the CRM store.  I am
> having problems authenticating and running a query.  Here's my code.
>
> bizUser.Url = strDir + "BizUser.srf"
>
> Dim credentialCache = New System.Net.CredentialCache
>
> Dim credentials As New System.Net.NetworkCredential
> credentials.Domain = "test"
> credentials.Password = "pass"
> credentials.UserName = "user"
>
> credentialCache.Add(New Uri("http://" + strServer), "NTLM",
> credentials)
>
> bizUser.Credentials = credentialCache
>
> Dim query As New Microsoft.Crm.Platform.Proxy.CRMQuery
> query.Credentials = System.Net.CredentialCache.DefaultCredentials
> query.Url = strDir + "CRMQuery.srf"
>
> Dim strErrorMsg As String
> Try
>
>  Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth =
> bizUser.WhoAmI
>
>  Dim strQueryXML As String = "<fetch mapping='logical'><entity
> name='account'><all-attributes/></entity></fetch>"
>
>  Dim strQueryResultXml As String = query.ExecuteQuery(userAuth,
> strQueryXML)
>
> I always error out on the line that executes the query.  The error I
> get is Server Application Faulted 80040204 Invalid user auth.The user
> ID does not match the thread
> token.d:\crm\build\3297\src\platform\security\crmsecurity\secmain.cpp708
>
>
> If I change the declaration of the userAuth line to
> Dim userAuth As Microsoft.Crm.Platform.Proxy.CUserAuth = New
> Microsoft.CRM.Platform.Proxy.CUserAuth
>
> and give the userAuth a UserID, I get the error Server Application
> Faulted 80070057The parameter is incorrect, which I imagine is because
> the userAuth probably didn't get made correctly.
>
> Does anybody have any insights into why my code isn't working?
>
>
> Thanks
> Josh


0
Jiho
5/12/2004 2:14:36 PM
Reply:

Similar Artilces:

Anybody integrate ASP.NET Membership with Facebook Connect etc.
Is it becoming obvious to other developers to attract and retain the persons using our websites we have to now implement an integration strategy with the social networking sites: FaceBook, LinkedIn and Twitter to name what I think are --currently-- the "big three?" "Hillbilly" <nobody@nowhere.com> wrote in news:eYjLYxFdKHA.5472@TK2MSFTNGP02.phx.gbl: > Is it becoming obvious to other developers to attract and retain the > persons using our websites we have to now implement an integration > strategy with the social networking sites: FaceBook, ...

Is CRM 3.0 on MSDN Final?
Hi, Just want to know if the MSDN download on msdn is final? Don't wnat to go installing a BETA version.. regards Chris Yes. "Chris" <Chris@discussions.microsoft.com> wrote in message news:E1AC92BA-AAC7-4070-AFE5-C95B843821DF@microsoft.com... > Hi, > > Just want to know if the MSDN download on msdn is final? > > Don't wnat to go installing a BETA version.. > > regards > > Chris ...

cannot connect to CRM using web client
Hello... I have the following problem. I set up CRM 3.0 on a Virtual PC Server inside a windows 2003 server. Inside the VPC the crm server behaves correctly, I can open Internet explorer and connect normally. Now, when connecting from the host server or from another computer in another network, I cannot connect to CRM. Is not that I'm having network problems, because when IE tries to connect to CRM Website, it asks for a user and password. In a normal case the user will be crmdomain\user. the user is created in Active Directory and CRM within the VPC. Apparently the VPC IIS i...

Exporting CRM Opportunity List to Office Excel 2007
We have CRM 3.0 Server. Our users are using CRM Web Client to access their leads, opportunities, quotes and orders. Using the Export toolbar button in CRM, users who have Office 2003 installed on their PCs are able to export opportunity lists to Excell perfectly all right, however users who have Office 2007 installed are not able to do that! Is this a limitation in CRM 3.0 ? Is there a workaround (If any)? Any possible risks when using or applying this workaround (If any)? "luai7" <luai7@discussions.microsoft.com> wrote in message news:6CADFDC5-8439-4B5F-955A-D6DBF...

Store credit
How exactly can store credits be processed using RMS? The program we were using before would notify us if a specifc customer had a store credit in its favor. I don't see or can't find how this can happen in RMS. As an example, let's say a customer buys something either cash or credit card and wants to return it. My store policy ïs "store credit only". How do I go about having the store credit available to the customer next time he comes? I know I can make mandatory to present the receipt, but, ísn't computers supposedly take care of handling that ...

ie8 not refreshing pages
I am having rather severe problems where my IE8 isnt refreshing web pages, no matter whether I try and manually refresh. Even if I clean out temporary internet files and set to always download a new page it is not refreshing certain web sites. I am running this on Windows Server 2008 R2. I think I should try and reinstall it, but theres no way to do that on this operating system. IE Tools | Internet Options | General | Browsing history | Settings | Check for newer versions of stored webpages: Is "Every time I visit the webpage" selected? Neal Stoughton wrote: ...

Automating Excel from Access
From Access I'm trying to set the vertical alignment for all cells of an Excelfile to 'Top': Dim XLApp As Excel.Application Dim XLBook As Excel.Workbook Dim XLSheet As Excel.Worksheet Set XLApp = New Excel.Application Set XLBook = XLApp.Workbooks.Open("c:\Test.xls") Set XLSheet = XLBook.Worksheets(1) XLSheet.Activate XLSheet.Cells.Select With Selection .VerticalAlignment = xlTop End With XLBook.SaveAs ("c:\Test2.xls") Set XLSheet = Nothing XLBook.Close Set XLBook = Nothing XLApp.Quit Set XLApp = Nothing but I get the message objetvariable or blockvaria...

Converting database from Access 2002 to 2003
I am upgrading a pc from access 2002 to 2003 and an Access database I am using is not recognizing a field in 2003. Below are details to find where I am stuck: There is a form "FrmMembers" in Arbor.mdb and you look at the buttons "Print Acknowledgement" and "Print Ack Env". The buttons try to print a report that in 2003 just displays errors. If you go to the design view of "FrmMembers" and look in the field "PKID" there is an error for "Members.PKID" saying "Invalid Control Property: Control Source" "No Suc...

Script error when tyring to create new crm contact with outlook
I have just installed CRM and web interface works ok, now I started installing outlook client and it wen't ok, only needed to install xml core separately. Everything looked great until I started testing from Outlook client, I made new crm appointment and then I tried to add new contact, I click from button labeled regarding, then from window that opened I have tried to choose account and also contact, error is same, anyway after choosing contact or account I click New... soon new window opens labeled quick create account/contact, then Internet Explorer script error box opens readin...

Creating forms in Access or Excel that link to Visio Documents
Does anybody have any experience with creating forms in access or excel that are integrated with Visio? How would I go about doing this? Access by definition can store 'objects', which can include visio drawings. If prompted, don't select display icon a.) create table add oledb field add text field for name b.) open table select oledb field and right click => insert new microsoft visio edit the new drawing and close it c.) create a form based on new table drag the oledb field onto the form d.) open the form what are you attempting to do? al &quo...

OWA login fails with Error: Access is Denied.
We are in the process of moving from one exchange server to another one, but having some troubles with OWA and login. On the first exchange server everything works fine with OWA, but on the second server OWA login fails after three atempts with "Error: Access is Denied." I have tried to compere settings on the two servers, but have not found differences. If I move an account from 2.server to 1.server OWA works, if I move it back OWA stops working. Reading email with Outlook works fine. We have Windows2003Server with sp1 and Exchange 2003 with Sp2 on both servers. The only difference ...

RMS Store Ops should have a Related Items Tab in Item properties
RMS Store Ops 1.3 There should be a tab in item properties to set-up related items. This would be very useful if you're using software, like Nitrosell, to sync RMS with your webstore. ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in the message pane. If you do not see the button, follow this link to open the suggestion in the Microsoft Web-based Newsreader and then click "I Agree" in the message pane. http://www.microsoft.com/Busine...

access database 03-16-10
I have created a siimple database project file but everytime I open or close my database, another file is created, ie I will see db1, db2 or db3 appearing in the same folder as my created database and of the same file size. Please help. When you save, save it with the same file name or it will make a new one. -- Milton Purdy ACCESS State of Arkansas "Josephine Ng" wrote: > I have created a siimple database project file but everytime I open or close > my database, another file is created, ie I will see db1, db2 or db3 appearing > in the same folder ...

Missing pages when PDF entire workbook
Version: 2008 Operating System: Mac OS X 10.6 (Snow Leopard) Processor: Intel Hi Guys <br><br>I have an Excel query that is baffling me. I have a workbook with 46 sheets. When I go to PDF them, I choose &quot;Entire Workbook&quot;, preview shows 46 pages so I select my folder and let it do the work. <br><br>No matter what happens it will only do 38 individual PDF's, and every time. <br><br>I have tried selecting a different printer, deleting a sheet that wont PDF and recreating it, renaming a sheet that wont PDF, PDF a selection and nothing ...

Access 2007 Switchboard buttons stop working
Environments tested: Windows7, WindowsXP, Access 2007, Access 2003 Access data project (.adp) run in development mode in all tests. SQL Server 2005 back-end database. Trusted locations set up for all tests. The trusted location is the folder where the .adp resides, sub-folders included. Default file format: Access 2002-2003. I have a .adp application with a standard switchboard form as the main menu navigation. The buttons on the main switchboard form are used to launch forms, stored procedures, macros, and other child switchboard forms. The switchboard navigation buttons a...

Developer Extensions for Access 2003...
Alright, This is one massive run-around. I have Office 2003 Complete. SO I have Access 2003. I have Visual Studio 2008 Professional. I downloaded the VSTO for 2005 which is supposedly the package for these Access Developer Extensions. When I went to install it, it only gave me the option to repair or uninstall. I looked through and found the folder where it updated during the repair process, (under Program Files\Common Files) but the only executable is install.exe! Where is the darn thing? I'm trying to set up my system so I can finalize the development of an Acce...

CRM 3.0 / Blackberry Email Tracking
We are looking for a solution to allow Blackberry / CRM 3.0 users track emails sent from thier Blackberry, similiar to the "Track in Crm" functionality available in the Outlook CRM Add-In. The 10digits product does not track email activity. I would think someone out there has needed this functionality on Blackberry w / CRM 3.0 Marty If Tendigit doesn't have the capability to do this, it maybe pretty difficult. They are the primary add-on for Blackberry and MSCRM 3.0. Did Tendigit say anything about their future plan tolsupport this feature? Frank Lee Workopia, Inc. http:/...

MS CRM desktop client for Outlook available via internet connectio
Hi, We are currently using an online type setup of CRM desktop client on Outlook 2007. It works perfectly when the laptop is used inside the network. But the add-in does not work when the laptop is used outside the network (unless we connect to the network via VPN). Is there a way for this add-in to work offsite without using VPN as long as we have an internet connection? Thanks. Any idea will be very much appreciated. JoF Unfortunately HTTP/RDP does not work with the Outlook Client for MS DYNAMICS CRM The MS Dynamics CRM MOBILE client on the other hand does offer direct access to...

Full Text Indexing Error on CRM Install
Hi I'm getting the following error during install at select SQL Server "Full-Text Indexing needs to be running on the specified SQL server." I've installed Index Service, and also went back and reinstalled the full text module in SQL Server 2000. Still getting the error. How do I fix this? Hi Have you checked the indexing service is started in services? Regards Dan "amwbgi" wrote: > Hi > > I'm getting the following error during install at select SQL Server > > "Full-Text Indexing needs to be running on the specified SQL server....

save as web page #4
Is it possible to save a range of cells to a web page without having excel put the long and detailed html formatting instructions. I am only interested in saving the text to be reused in client excel programs --- formatting is not needed for my application. ...

Access away from home
Hello, I was wondering if someone could tell me if you can access Money from somewhere other than the computer it is downloaded on. For example can I access it from work or a friend's computer? If so, how do you do it and can you still retrieve the same info? I'm not sure what a pocket PC is but saw somewhere you can access Money from it, is this all your personal info too, like bills due, payments made, etc.? I have a phone that has things like Excel & Word on it.. how do I know if I could put Money on it? Thanks so much! Answers below. "RF" <RF@discussion...

rotate page
Received a pub file that is vertical on the page. I cannot rotate the page so am unable to read, or edit. Using Publisher 2002. Thanks, Patty What happens when you try to open the file? If you are able to do so, have you tried rotating the individual elements? -- Ron Cohen "Patty Tappan" <patty1@qwest.net> wrote in message news:WNNVd.36$0f7.1415@news.uswest.net... > Received a pub file that is vertical on the page. I cannot rotate the > page > so am unable to read, or edit. Using Publisher 2002. > Thanks, Patty > > "Patty Tappan" <...

Removing access to Task Lists in Great Plains
I have used Adv Security to remove all access for a user other than Purchase Order type access. I have removed all smart list except for PO. However, when the user logs in they still have access to the following: Setup > System > Business Alerts (even though not marked under dictionary > GP > System) Integrate > Run Integration Cards > Financial > Budgets (never should have access) Inventory Task Lists Purchasing Task Lists - should only have POP but show All Purchasing and All Payables Project Task LIsts How can I remove these from this user to "secure&quo...

Newbie CRM developer: Getting started on integration
Greetings, We're getting ready to start up some development. Our first efforts are focused on integrating MS CRM with an ERP system (QAD's MFG/PRO), not customzing MS CRM application functionality. I'm new to this and need to take my first baby steps as I'm from a blank page. We've done the design and we're pretty happy with it for the moment (thanks to the list for feedback earlier this week). Our first efforts will be focused using the SDK (as opposed to using Biztalk). My first baby step is to install visual studio on my laptop computer and then use the...

Issue with ADP form bound to Stored Procedure
I have an application that I support that is a Microsoft Access Database Project. It uses Access as a front end to a SQL Server database (SQL Server 2000). The current version of Access used in production is Access 2000 (Office 2000). My application site will be receiving new workstations next week that run Access 2002 (Office 2002/XP). When testing with the new version of Access we discovered an issue with one of the Access forms being bound to a Stored Procedure as its data source. It uses the following code to do this Me.RecordSource = "dbo.proc_frm_Input Me.UniqueTable = "d...