About CRM 3.0 Speed

We have in our production system delay of 6-7 seconds when opening any CRM 
pages.

It seems that after page reguest from client, nothing happens for this 6-7 
seconds, but after this page itself opens wery quickly.

Configuration:
Client: mainly Core 2 Duo w/ 2G
CRM / Exchange: SBS2003 w/2G, no R2 or ISA
Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
100Mb LAN

When i access CRM, it seems that no stress to SQL server is produced. So I 
am pretty sure its not SQL that causes this delay.

I have read a tons of suggested workarouds, but nothing seens to help.

Any further ideas? 
0
Utf
11/3/2007 4:55:01 PM
crm 35858 articles. 1 followers. Follow

5 Replies
366 Views

Similar Articles

[PageSpeed] 21

This is a multi-part message in MIME format.

------=_NextPart_000_078F_01C81ED1.09C431B0
Content-Type: text/plain;
	charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

nature of the beast....   its loading the .net application pool...    =20

This should only have the first time a page is loaded.... once it loads =
once .. it should run quickly.


If it runs slow throughout... perhaps you have the anti-phising turned =
on through IE7.    You might want to turn that off.



--=20
LeVar Berry
CEO
eDriven Enterprises Inc
513.322.4889x101
---Ask me how video can improve your business--

  "Perttis" <Perttis@discussions.microsoft.com> wrote in message =
news:8A811043-325B-4C86-95F7-EE079CA17481@microsoft.com...
  We have in our production system delay of 6-7 seconds when opening any =
CRM=20
  pages.

  It seems that after page reguest from client, nothing happens for this =
6-7=20
  seconds, but after this page itself opens wery quickly.

  Configuration:
  Client: mainly Core 2 Duo w/ 2G
  CRM / Exchange: SBS2003 w/2G, no R2 or ISA
  Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
  100Mb LAN

  When i access CRM, it seems that no stress to SQL server is produced. =
So I=20
  am pretty sure its not SQL that causes this delay.

  I have read a tons of suggested workarouds, but nothing seens to help.

  Any further ideas?
------=_NextPart_000_078F_01C81ED1.09C431B0
Content-Type: text/html;
	charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

=EF=BB=BF<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Dutf-8">
<META content=3D"MSHTML 6.00.2800.1106" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT size=3D2>nature of the beast....&nbsp;&nbsp; its loading the =
..net=20
application pool...&nbsp;&nbsp;&nbsp;&nbsp; </FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>This should only have the first time a page is =
loaded.... once=20
it loads once .. it should run quickly.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>If it runs slow throughout... perhaps you have the=20
anti-phising turned on through IE7.&nbsp;&nbsp;&nbsp; You might want to =
turn=20
that off.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV>&nbsp;</DIV>
<DIV><BR>-- <BR>LeVar Berry<BR>CEO<BR>eDriven Enterprises=20
Inc<BR>513.322.4889x101<BR>---Ask me how video can improve your=20
business--<BR></DIV>
<BLOCKQUOTE=20
style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV>"Perttis" &lt;<A=20
  =
href=3D"mailto:Perttis@discussions.microsoft.com">Perttis@discussions.mic=
rosoft.com</A>&gt;=20
  wrote in message <A=20
  =
href=3D"news:8A811043-325B-4C86-95F7-EE079CA17481@microsoft.com">news:8A8=
11043-325B-4C86-95F7-EE079CA17481@microsoft.com</A>...</DIV>We=20
  have in our production system delay of 6-7 seconds when opening any =
CRM=20
  <BR>pages.<BR><BR>It seems that after page reguest from client, =
nothing=20
  happens for this 6-7 <BR>seconds, but after this page itself opens =
wery=20
  quickly.<BR><BR>Configuration:<BR>Client: mainly Core 2 Duo w/ =
2G<BR>CRM /=20
  Exchange: SBS2003 w/2G, no R2 or ISA<BR>Separate SQL 2005 3G RAM, =
2x72G 10krpm=20
  Raid 1 w/battery accelerator.<BR>100Mb LAN<BR><BR>When i access CRM, =
it seems=20
  that no stress to SQL server is produced. So I <BR>am pretty sure its =
not SQL=20
  that causes this delay.<BR><BR>I have read a tons of suggested =
workarouds, but=20
  nothing seens to help.<BR><BR>Any further =
ideas?</BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_078F_01C81ED1.09C431B0--

0
LeVar
11/4/2007 3:54:14 PM
Does this always happen, or only for the first access by anybody for a while 
? If it's the latter, it's due to application pool as LeVar Berry suggests, 
and can be mitigated by tools that periodically access CRM URLs

If it always happens I'd suspect name resolution issues. The IIS logs are a 
good diagnostic tool. Try and identify if the time lag is before anything 
gets to the CRM server, or after. If it's before then it's a name resolution 
issue. I'd also check the IIS logs for the reporting server, as that is 
frequently accessed by CRM
-- 
David Jennaway - Microsoft Dynamics CRM MVP
Web: http://www.excitation.co.uk



"Perttis" wrote:

> We have in our production system delay of 6-7 seconds when opening any CRM 
> pages.
> 
> It seems that after page reguest from client, nothing happens for this 6-7 
> seconds, but after this page itself opens wery quickly.
> 
> Configuration:
> Client: mainly Core 2 Duo w/ 2G
> CRM / Exchange: SBS2003 w/2G, no R2 or ISA
> Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
> 100Mb LAN
> 
> When i access CRM, it seems that no stress to SQL server is produced. So I 
> am pretty sure its not SQL that causes this delay.
> 
> I have read a tons of suggested workarouds, but nothing seens to help.
> 
> Any further ideas? 
0
Utf
11/5/2007 11:01:03 AM
I had a similar issue. We had the problem of reduced CRM web functions if 
Outlook was open and had a solution that involved IP address WEB CRM access.
However we noticed poor connection times and discovered that going back to 
server name address solved it.
So I'd explore that route.

"Perttis" <Perttis@discussions.microsoft.com> wrote in message 
news:8A811043-325B-4C86-95F7-EE079CA17481@microsoft.com...
> We have in our production system delay of 6-7 seconds when opening any CRM
> pages.
>
> It seems that after page reguest from client, nothing happens for this 6-7
> seconds, but after this page itself opens wery quickly.
>
> Configuration:
> Client: mainly Core 2 Duo w/ 2G
> CRM / Exchange: SBS2003 w/2G, no R2 or ISA
> Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
> 100Mb LAN
>
> When i access CRM, it seems that no stress to SQL server is produced. So I
> am pretty sure its not SQL that causes this delay.
>
> I have read a tons of suggested workarouds, but nothing seens to help.
>
> Any further ideas? 


0
Pat
11/5/2007 11:16:39 AM
We were experiencing even longer delays the first time a page was opened (1 
to 2 minutes).

We found out that the client PCs had the Google Desktop installed and it was 
trying to catalog the server for faster access the next view.

Turned off Google Desktop and it worked fine!

Tom Francisco



"Perttis" wrote:

> We have in our production system delay of 6-7 seconds when opening any CRM 
> pages.
> 
> It seems that after page reguest from client, nothing happens for this 6-7 
> seconds, but after this page itself opens wery quickly.
> 
> Configuration:
> Client: mainly Core 2 Duo w/ 2G
> CRM / Exchange: SBS2003 w/2G, no R2 or ISA
> Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
> 100Mb LAN
> 
> When i access CRM, it seems that no stress to SQL server is produced. So I 
> am pretty sure its not SQL that causes this delay.
> 
> I have read a tons of suggested workarouds, but nothing seens to help.
> 
> Any further ideas? 
0
Utf
11/6/2007 6:18:00 PM
Google desktop was an issue for us as well. I didn't have the luxury of 
un-installing, but did find that setting the preferences to not store web 
files in the indexing really helped out with the speed for a couple of users.

Now to figure out why there are 10-15 second delays if resuming activity 
after being idle for 15-30 mins...no luck with the caching tool either.

"Tom" wrote:

> We were experiencing even longer delays the first time a page was opened (1 
> to 2 minutes).
> 
> We found out that the client PCs had the Google Desktop installed and it was 
> trying to catalog the server for faster access the next view.
> 
> Turned off Google Desktop and it worked fine!
> 
> Tom Francisco
> 
> 
> 
> "Perttis" wrote:
> 
> > We have in our production system delay of 6-7 seconds when opening any CRM 
> > pages.
> > 
> > It seems that after page reguest from client, nothing happens for this 6-7 
> > seconds, but after this page itself opens wery quickly.
> > 
> > Configuration:
> > Client: mainly Core 2 Duo w/ 2G
> > CRM / Exchange: SBS2003 w/2G, no R2 or ISA
> > Separate SQL 2005 3G RAM, 2x72G 10krpm Raid 1 w/battery accelerator.
> > 100Mb LAN
> > 
> > When i access CRM, it seems that no stress to SQL server is produced. So I 
> > am pretty sure its not SQL that causes this delay.
> > 
> > I have read a tons of suggested workarouds, but nothing seens to help.
> > 
> > Any further ideas? 
0
Utf
11/19/2007 8:19:02 PM
Reply:

Similar Artilces:

VC++ 6.0 class wizard
Hi everybody, I have a rather strange problem with VC++ 6.0. In my workspace I have 4 projects. (main exe, zip compression library, 2 language dlls). The language dlls were added yesterday. Before this everything worked normal. Now I want to add new classes to my main project, but if I select the class wizard, only one of the language dll projects is shown in the "project" combo box. What happened to my workspace an what can I do to solve this problem? Thanks, Chris Delete the .clw and .ncb files and then try recreate the classes. -- Vipin Aravind MVP "the.chris"...

How do I split one cell of 6 numbers into two cells of 3 and 3?
I have a column of data that has six numbers in each cell, however I need to split this into two columns, where the first column is the first three digits and the second column is the last three. There is no separator (space, comma or dash) between the numbers. Any suggestions? Use Text To Columns. Select your column of data, then: <Data> <TextToColumns> Click "Fixed Width", then <Next>, Click in the data to display the "break line", and drag it to separate the numbers as desired. Then <Finish> -- HTH, RD =================================...

CRM 3.0 on SBS2003
I've just installed CRM3.0 Small Business Edition on a Small Business Server 2003 Premium server. Everything went fine with the install, and it's all working OK apart from if I try to access the System Settings I get an error. I've seen a fair number of postings on similar type problems, but nothing seems to match my situation exactly. CRM, SQL etc are all on the one server, unlike some of the other issues that seem to have been reported. Any ideas, as I'm going nuts trying to get this all to work. Thanks, David Hi, What is the error message? Have you tried installing it ...

change the year in a list of dates ex 1/3/2003 to 1/3/2004
I have a list of dates, all in the year 2003 1/3/2003, and 5/17/2003, I want to change just the year to 1/3/2004 and 5/15/2004 in the whole list. How do I do that? say the dates you have now are in col A in a new column, type =a1+365 and copy down then do a /copy/special/values on the new column so it becomes static and no longer refers to col A... then delete col A and move teh new column to Col a work on a copy of your file to make sure I have it right... "Elaine" <Elaine@discussions.microsoft.com> wrote in message news:57252856-7A95-4C46-8B96-10E4D127EAB9@microsof...

Creating and adding a Report in CRM 3
The report manager provided by Microaoft is for CRM 1.2.How do I create a report and add it to CRM 3. Can I still create it in Crystall reports and then add it to CRM 3.(I ahve done this for CRM 1.2) Need guidance Thanks & Regards SAM Sam, CRM 3 uses SQL Reporting Services, imo a superior product than Crystal. In v3 you can use the advance find to construct queries. Its a much more dynamic reporting tool. If you created your Crystal reports then you should have no problems recreating them in SQL RS. If you dont want to however i beleive there is a method of using your Crystal repo...

Receipt Printing #3
I read previous posts about gift receipt printing and cannot seem to get it correct. I would like to print 1 standard receipt and the option to print 1 gift receipt. I set-up the gift receipt in the Receipt Printer 2 tab and selected the same OPOS printer as in Receipt Printer 1, but selected the gift receipt template and selected the promt cashier for the second receipt. It will display the gift receipt in the journal but will not print, i get "invalid operation 425, printer not accessed - locked by another application. Anyone know what I am doing wrong? Thanks in advance Sc...

How do I get Publisher 2003 to have same wordart as Publish 2000? #3
I prefer the wordart in Publisher 2000, and want to know is there a way to configure Publisher 2003 so that the wordart is the same as in Publisher 2000. ...

CRM shuts down the users Internet Explorer
Hi, I have the following configuration : SrvA (w2k3) : dc + sql; SrvB (w2k3) : Xch + crm. SrvC (w2k3) : ISA2004. Server C is NOT a member of my xxx.local domain. Internally I can reach the CRM server (webbased +thr Outlook). I have configd a srv certificate and installed it on SrvC. I want the Internet part of the communication between external clients and CRM to run thr https, the internal part thr http. For security I want the ISA srv to bridge, not to route. DNS is configd correctly. So I published a secure srv in ISA (publ rule + listener) When an external webclient tries to connect,...

User MS Contact to MS CRM Contact
Hello Experts!! I would like to ask something regarding the functionality of MS CRM. Is there any way to import selected contacts from user mailbox to MS CRM Contacts??? I know that with MS Sales for Outlook you can import MS Contacts, but the problem is that I can´t choose which contacts I will convert to CRM, so for example, if the user has personal contacts that shouldn’t be in CRM Contacts how can the user "in a easy way" export and convert them to CRM selecting only those contacts that should be in CRM from MS Outlook?? Is there any function as "Create CRM Cont...

How can I import Activities from Outlook 2003 to CRM?
Hello All, I was wondering if its possible to import the activities in outlook 2003 into the activities section of MS CRM. Is it even possible? Best Regards, -Horia ...

Adobe 6.0 Standard
Suddenly Adobe 6.0 was not saving Word, Excel, PPT in PDF. I re-installed it. Word and PPT are OK but I am unable to save Excel in PDF. Word and PPT have Adobe icons but Excel does not. Most grateful, Paul Make sure the PDFMAKER.XLA file is in your XLStart folder. For instance, the XLStart folder in Office XP is "C:\Program Files\Microsoft Office\Office10\XLStart". Paul Banerjee wrote: > Suddenly Adobe 6.0 was not saving Word, Excel, PPT in PDF. I re-installed it. > Word and PPT are OK but I am unable to save Excel in PDF. Word and PPT have > Adobe icons but Ex...

"Average" with error DIV/0
Taking average from data below I get DIV/0 Error J42=AVERAGE(J40:J41) J40 00:16:40 J41 00:09:53 J42 #DIV/0! Thank you I suspect the entries in J40 and J41 are text entries, rather than numeric. Test for this by entering the formula =ISNUMBER(j40) in an open cell. If you get a FALSE response, then you can write a formula =TIMEVALUE(J40) that will translate the text cell into a time. Remember to format the TIMEVALUE cell with a time format. ...

No page available for eConnect 10.0 SDK downloads in PartnerSource
Hi, I am trying to download the eConnect 10.0 SDK First Version (not the eConnect 10.0 SDK SP2) from the PartnerSource. But seems like I am taken to SP2 page and not to the basic version page. Can anyone send me the path to the eConnect 10.0 SDK Basic Version download page? Thanks in advance. -- Regards, Vaidy ...

McAfee slows CRM response time
McAfee seems to slow down CRM response time considerably. 30-45 seconds to load a page. We've disabled scriptscan. What else can be done to configure this? McAfee 8.5.... or 8.0 Seems it has on access scan of the IE Temp folders and it slows it down. ...

Can "Track in CRM" not look at e-mail addresses of inactive record
Creating a new Contact on Lead Conversion results in duplicate e-mail addresses in CRM. When users track e-mail in Outlook these e-mails are left unresolved until manually resolved. Is there a way to configure CRM to not look at e-mail addresses of inactive records? Thanks for your help! Suzy ...

FRx speed
What is the best way to speed up FRx? Can part of it be moved to a SQL server to make it faster? Michael, I didnt understand what you mean by moving it to SQL Server. There is nothing in FRx that goes to SQL. FRx sits on Access Database. -- Thanks Janakiram M.P. MCP-GP Note: If you are a Microsoft Partner, You can also Login to Dynamics GP partner forums at http://social.microsoft.com/Forums/en-US/partnerdynamicsgp/threads "Michael@nyresume.com" wrote: > What is the best way to speed up FRx? Can part of it be moved to a SQL server > to make it faster? It was wis...

Display 3 Sheets
I thought it was possible to display three sheets in the same workbook by using Windows|Arrange, then checking Windows of Active Workbook. But NO! Impossible? James Works for me (XL04). Do you have multiple windows open to the same workbook (Windows/New Window)? In article <ux4cMB13HHA.4676@TK2MSFTNGP05.phx.gbl>, "Zone" <KingOfWhiles@aol.com> wrote: > I thought it was possible to display three sheets in the same workbook by > using Windows|Arrange, then checking Windows of Active Workbook. But NO! > Impossible? Windows/New Window was the step I f...

CRM Sales for Outlook and Zonelabs firewall
Does anybody know a workaround for using CRM SFO in conjuction with Zonelabs Integrity Flex Client? My company has recently deployed CRM and the Outlook addin does not play nice with Zonelabs. SFO will display data fine but when to try to add a record such as a contact, activity, etc... the initial editing window will launch, but when you apply the change the form will either clear or return a blank IE window. When Zonelabs is shutdown it works fine. Our goal is to not have to shutdown zonelabs but tweak it so both can run on the systems. Any ideas??? Thanks. ...

CRM 3.0
Hi I am building a CRM 3.0 Virtual PC development environment, and I want to populate the CRM with test data. I have seen the Adventure Works Cycle CRM Virtual PC, but it uses SQL Server 2005. We are using SQL Server 2000. How can I get the Adventure Works data into my Virtual PC? Are there any scripts anybody has developed to add a heap of data into CRM? Tom ...

crm 3.0
Hi; We've recently upgraded to 3.0 from 1.2, and now only the domain admin user that performed the upgrade can see the "Settings" area in the nav bar. I have the System Admin and System Customizer roles, and yet when I log in as myself I do not see the Settings area. Doesn't seem to be permissions and the sitemap.xml looks fine. Anyone else seen this or can point me in the right direction? Thanks Dave Do you have the CRM for Outlook client running on your machine? There is a "feature" of the app that prevents the settings from displaying when the outl...

CRM Trial 05-12-05
Hi, Where can I download Microsoft CRM trial version? raffels I don't believe there is one. -- Brandon Smith IT Director Presentations Direct - Specialized Office Equipment & Supplies http://www.presentationsdirect.com "raffels" <raffels@op.pl> wrote in message news:eJcnOWyVFHA.3840@tk2msftngp13.phx.gbl... > Hi, > Where can I download Microsoft CRM trial version? > > raffels > > If you have an MSDN Universal Subscription you can download Microsoft CRM. However this is only to be used in a development environment and is not designed for use ...

External Connecter Licence for Small Business CRM
Hi there I have a question about licencing in CRM. When you expose crm data to customers like on a web portal you then need to buy a external connector licence. But as far as i knew this licence is only avilable for mscrm professional licences. But our customer has a small business licence. Now my questions: 1.) Is exposing date to a web portal throug web services tecnical possible for crm professional and small busines? 2.) Is there a external connector licence for crm small business? Tanks and regards Thomas Hi Thomas, in the licensing documentation I received from Microsoft (around ...

2nd approver in CRM 3.0 solution
We need to have support for a 2nd approver in our CRM 3.0 solution. Based on sales size different users need to approve the sale (and no other should have the rights to approve). There is no such functionality in the CRM. Does anyone have a suggestion on how to solve this or get such functionality? Any input would be most appreciated. Thanks John ...

exmerge: number of messages processed: 0
I am running exchange 2003 enterprise. I've had an instance where the log file was deleted and then firstly I could not mount the store. Did eseutil /mh, then performed eseutil /d. Got clean sheet, but could not do defragmentation. In the end had the ost files for 85% of the users and recovered them, got the pst and it was OK. As for the rest, tried using exmerge to get mailboxes into pst files. I have no issue with permissions, but when I use it, I only get folders copies and no items inside of them? (get the above number of messages processed to be 0 for the mailboxes). Basically, ...

MX record question #3
My users report that they get NDR's when sending e-mail from my organization to acertainuser@mckenna.edu Then in my Exch20003 Connector server, if I do: nslookup set type=mx mckenna.edu It times out. If I enter a valid "msn.com" domain, MX records are returned OK. Codeflux.com returns correct information for "mckenna.edu". Can you tell me what I am missing here ? I mean, is this a problem with my DNS servers not retrieving info from 'mckenna.edu' domain ? Does this times out ALL the time or the first time you try? If it times out every time, try chan...