ADP in A2007 Runtime: InputParameters not working

(Sorry about the double-post. This is the other article I wanted to
post)

Forms in ADP can have a stored procedure as the RecordSource. That
sproc can take input parameters, which are specified in the
InputParameters property. Example: RecordSource="dbo.EmployeesByID"
(or use the RecordSourceQualifier to specify "dbo"),
InputParameters="@ID=1"
On A2007 Runtime this no longer works: Bad query parameter '@ID'.
On A2007 (with or without the /runtime command line switch) it does
work.

The only workaround I have found so far is to put the entire
expression in the RecordSource property like this: "exec
dbo.EmployeesByID @ID=1", and leave InputParameters empty. I don't
think this is an intentional change by Microsoft.

I have put a backup of the NorthwindCS database and the ADP here: 
http://www.kittest.com/NorthwindCS_A2007RT.zip These files are
identical to the ones that shipped with A2000, with the addition of
the EmployeesByID and EmployeesList sprocs, and a few test buttons on
the Main Switchboard. Just like with the original NorthwindCS, you may
have to fix up the database connection before it opens properly.

I know there is a bug in the A2007 runtime. Clint Covington wrote on
Jul-20: "There is a known bug where reports don't work in ADPs. We are
working on a QFE for the issue."  That was 2 months ago, and I think
the QFE hasn't been released yet. I'm also not at all sure it will fix
this issue, if indeed it is a bug.

My questions:
* Can you confirm the behavior I am describing?
* Is this a bug?
* Any better workarounds than the one I described above?

-Tom.

0
Tom
9/27/2007 4:09:32 AM
access 16762 articles. 3 followers. Follow

0 Replies
703 Views

Similar Articles

[PageSpeed] 13

Reply:

Similar Artilces:

OWA stopped working on one of the Cluster Nodes
Our environment has 2 FE servers and an A/A/P cluster. Recently (not sure how long ago) OWA stopped allowing logons on one of the BE nodes. I have checked the configuration for the HTTP resources and they all appear to be identical. When I move the EVS from the Active to Passive node OWA starts working properly. I had installed Symantec's SMSMSE 4.6 around the same time frame and have since removed that. I have tried to Restore the IIS configuration to an earlier date and that fixed the Passive Node but not the Active node. I have removed Exchange and reinstalled and removed IIS and...

Record Macro Relative does not work?
Can someone help me with this macro. I want to go to any cell of my choice and press f2 to edit, then go to the fifth character of that cell, then select the next 6 characters and change them to a smaller font size (8), then "enter". I tried to make this macro using the record macro function, but it did not work how I want it to. It ends up pasting the contents of the cell which I used to record the macro initially. Can this kind of macro be done? To get a relative recorded macro, make sure the stopr recording toolbar is visible, it has 2 icons, one is to s...

Reply rule doesn't work consistantly
I've got an Outlook 2003 client and we are trying to setup a rule to emulate the Out of Office Assistant. I've setup a rule that is supposed to send reply with a template if the sender is from a list of contacts that I've chosen. It isn't working as expected. The first time I tried it, I entered only one (internet) email address which worked perfectly. If I add any addresses to that list, it doesn't work anymore - the reply is not sent. I know that it can reply to internet email addresses, since it worked that one time, but I can't figure out why it won't work when...

Why doesn't the page preview have the same order as work page?
Why doesn't the preveiw page look like the one I built on the work pages. I have "saved as" and "saved. The nagagation bars in preview goes to different pages than titled. HELP!!!!!! ...

Double Click on file and mouse not working
Good afternoon, thanks for taking time to look at my problem. I am trying to open a word document by double clicking on the file name in "my documents". Word opens, but not the document. If you go into File and Open, you can open the document, but the mouse cursor will not go anywhere in the document. I have tried to open Word in safe mode, blasted the normal.dot, copied a normal.dot from another computer, heck I tried disassociating doc from Word. Nothing worked. I even installed Windows Live so I could uninstall it. I'm hoping someone has fixed this problem. ...

DCount?? not working. Pls help
My data is orgnaised as follows: A B C D E David 2245 abcd efgh ijk Susan 2249 xyz etc etc Mickey 1234 etc 123 etc Arnold 4321 etc.... David 1441 Mickey abcd etc etc I want to count the number of non blank cells in B for each "David", "Susan" etc in A, and have the value returned in another sheet. I tried DCount, but it doesnt seem to be working. -- KDDXB I mocked up your data as you provided it, with names in A1:A6 etc. I entered "David" in A8 and this formul...

Can't get Date Range to work from Form to Report
Hi, I've followed Allen Browne's directions very closely for creating a form for a date range to limit results to that date range on a report and can not get it to work for some reason. I've read many threads on this board which all say the same thing and it seems to work for everyone else. :( Here's what I have: A form with two unbound text boxes called [txtDateBegin] and [txtDateEnd]. The form is called "frmDateRange" and the report is called "Sales Activity Report". The two unbound text boxes are set to "Short Date" format which the user ...

SendTo PDF Not Working on GP 10
I upgraded a client from GP 8.0 to GP 10.0. Since the ugprade, they are unable to use the SendTo PDF option from within GP. We have tried reinstalling Adobe and that hasn't changed anything. The users can see the PDF being created but a blank email doesn't open from their email client as it used to. The client is on version 10.00.0991 and I thought this issue was to be resolved in 10.0 SP 1 but obviously it hasn't been for us. The client is also using Outlook. Is this still a bug with 10.0 or are we missing something? I am on Adobe Acrobat Standard 8.0 with Microsoft ...

Insert list of figures does not work for Pictures
Version: 2004 Operating System: Mac OS X 10.5 (Leopard) Processor: Intel I can generate a list of all of my inserted objects by caption: Figure, Example, Table, Song, Chart. But when I try to generate a list of the pictures I have inserted (caption reads Picture ...), I get the following message: Error! No table of figures entries found. It's as if the macro that reads the caption list doesn't have Picture in its internal dictionary. I do have the Picture captions in a text box that is formatted as "tight" to allow text-wraparound; could that be causing the problem? If so h...

Money Stopped Working Problem Solved! (or at least explained)
After the SP1 update my Money Plus Deluxe on Vista Ultimate would "stop working" when I selected Portfolio or Help. It turns out that the problem was a conflict with my Roboform program which is a password fill-in program that attaches itself to web pages in order to automatically enter my personal information. Because Portfolio and Help look like web pages to Roboform, it tries to attach and apparently crashes Money. If I stop Roboform before starting Money all is well. Alternatively, I can start Money "as administrator" and that will work too. In microsoft.publi...

Setting up email to work
I created a webpage for my company and when I created the send button I went into Format Form Properties and selected Submit and then went to Form Properties. I then selected Send Data to me in Email and entered in a valid Email. However when I go to test the web page and I enter in the required information and I click Send I get a The Page Cannot Be Displayed error and HTTP 405 - Resource not allowed. What do I do? Reference: "Publisher web publication forms 101": http://msmvps.com/blogs/dbartosik/archive/2006/01/07/80564.aspx DavidF "Russ" <Russ@discussions.mic...

VBA in .mdb vs .adp
Hi, I just start reading about projects in Access, I have learned a lot of VBA in a .mdb application, my question is, the VBA code in a access project is the same that in a .mdb application? or I need to learn a new way of programing. Thanks Orlando <Orlando@discussions.microsoft.com> wrote: >Hi, I just start reading about projects in Access, I have learned a lot of >VBA in a .mdb application, my question is, the VBA code in a access project >is the same that in a .mdb application? or I need to learn a new way of >programing. > >Thanks The VBA programming lang...

Function for convertion of leters doesn't work.
I'm using function LOWER to convert string i my table on small size but Access gives me a message that the function is not defined.Please, do you know another function? MS Access does not have a LOWER function. Try LCase() instead. -- Cheryl Fischer Law/Sys Associates Houston, TX "Stenli" <svet2000@seznam.cz> wrote in message news:10b201c3626e$b613a050$a301280a@phx.gbl... > I'm using function LOWER to convert string i my table on > small size but Access gives me a message that the function > is not defined.Please, do you know another function? ...

Coments on a Work Order
Hello I have been using the system for almost 2 years, and the following error, which began after I install SP 1.3, is driving me crazy. I sell items that require serial numbers. I had added the term "S/N:" on SubDescription 1 for some items. This is where my problem comes to life, Ex. I create a work order for a client, add some items to it, and add the serial numbers. I save it, so I can do something else. After recalling the Work order, none of the coments (not even the S/N) are on it. I have check the Configuration \ Options on the manager and it seems to be ok. Any sugge...

Linking items GREATER THAN O on another worksheet in the same Work
I have a workbook that has about four worksheets … I want to create a list of items that will automatically be included on worksheet tab 4 from Worksheet tab 1 if the quantity for the item listed on the first worksheet has been changed from 0 to any other number (i.e. 1 or 10 etc). I have a list of equipment with pricing on worksheet tab 1 and the list is long. Many of the items will have quantities of zero and will not increase as they will not be selected for the project being created. We have additional columns for cost, extended cost, labor hours etc. If the quantity changes for a...

Calculate the total overlapping time of multiple tasks, excluding non-working times
I am developing a tracking calculator for an overall process. Within the overall process, there are 3 steps which are completed. These steps can be completed independently from one another, but can also (sometimes) overlap. I am trying to determine the total time for the overall process (from beginning to end), without counting the duplicated times where the steps are running parallel to one another, or times when some steps may be completed and are waiting for another to start. I have outlined the basic design of the worksheet below, with times in mm/dd/yyyy hh:mm format. S...

Links don't work in mail
Hello What would cause outlook (and outlook express) to not allow the links in my emails to work? They open a browser window, but nothing ever gets loaded. If this were happening only for 1 link, I'd say it was the url, but this happens with text links, button links etc. I have to "view source" for the button links, copy the url and paste it into my browser -- and that works fine. Email links seem to work. Any suggestions? Thank you Terry V Hold curser over link, press shift key, now you can click on link. "Terry V" wrote: > Hello > What would cause ou...

Rules Work Sporadically
I use an email classification tool (POPfile . . . getpopfile.org) that marks each email header using X-Text-Classification. I then set up rules in Outlook to recognize the header text and move the email to the proper folder. Here is the problem: sometimes Outlook places the email into the correct folder and sometimes it just lets the email pass through into the default folder even though the header reflects the proper X-Text-Classification. Does anyone have any idea why this rule would only work sporadically? Thanks. ...

Some rules don't work
Outlook 2007, XP Many of my rules have stopped working. Not all, but many, if not most. I even tried to delete some of the non-working rules and re-write them. But when I run them with messages already in my inbox, they don't work. I frequently copy my outlook.pst file for use on a laptop when travelling. It seems that some--but not all--stopped working at the time of such a transition. Of course, that does not explain why some won't work right after I make them. Many of the rules are what to do with emails I send and receive from certain people. Any suggest...

CMemFile not working in VC++ 6.0 RELEASE mode
I am using VC++ 6.0 and have a multi-threaded application (exe & multiple DLLs) which seem to be having a CMemFile object getting clobbered when running in release mode. It does not happen in debug mode. When running in the debugger, the calling thread that builds the memory file reports: GetPosition = 0 GetLength = 228 ptr to memfile = aa2238 the method GetTextLineNOF is passed a ptr to CMemFile and reports: GetPosition = 0 GetLength = 228 ptr to memfile = aa2238 Which agrees as expected. ==== However when running in RELEASE mode: the calling thread that builds the memory file rep...

Send/receive quit working
I have used Outlook 2002 without a problem for 6 weeks on a new Dell running home xp with the Mcafee security system including firewall. Microsoft articles suggest that outlook and Mcafee firewall are not compatible (worked for 6 weeks?) and the solution is to uninstall the Mcafee securities. Is there a way to run Mcafee with Outlook 2002? Is this just the firewall or also the anti-virus? If McAfee version 7, you will need to visit the McAfee forums for a fix. -- Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. After searching google.group...

Can a formula work on another cells formula?
I'm trying to get an offset function to work based on the target o another cells formula not on the cell itself and it's not working. Is there a way to tell a formula to act on the target cell and no simply on the cell? This is very hard to explain but it's really not that complicated. Wayn -- whagopia ----------------------------------------------------------------------- whagopian's Profile: http://www.excelforum.com/member.php?action=getinfo&userid=1608 View this thread: http://www.excelforum.com/showthread.php?threadid=27539 Hi really not sure what you're try...

Formulas not working anymore
Hello, I have Excel 2002 and have been using it for my Pet Sitting business. All of a sudden, today, all my cells with formulas in them, aren't working! I have very basic formulas [ie: =sum(e35-b34)] and similar things... Yesterday, they were working just find... and today, NONE of them are working! I can get them to work if I re-enter the formula, but I have hundreds of cells with formulas. Even doing the "fill formula" (Clicking on a cell and then pulling the corner to copy that formula to the other cells) doesn't work. Would anyone have any idea what may happened? I h...

Formula stopped working...
=SUM((D131={5,10,20,30,50,100})*{10,20,35,60,100,210}) This formula worked fine from row 7 to row 131. Then starting on row 132, it stopped working. The formula is in cells 132 - 300, but it doesn't work anymore. Same formula, but no result. What gives?? atom "doesn't work" is not too descriptive. What results do you get? Which column is it entered in? I'm assuming you copied it down from row 7. Perhaps you have no data in column D past row 131? Gord Dibben XL2002 On Sun, 09 Nov 2003 00:50:21 GMT, atom <akobrin@earthlink.net> wrote: >=SUM((D131={5,1...

Outlook wont work!
I just bought a new computer that came with a trial version of MS Office 2003. Since I already have MS Office Pro XP, I uninstalled the trial versions and installed my CD. Everything works (Word, Excel, Powerpoint, Frontpage, etc..) except Outlook. When I start the program up it says "cannot load default email folders, would you like to open the default system folder instead?" (something to that effect). Outlook then opens My Computer. There's no calendar available, no email....basically it becomes a fancy windows explorer. I've tried uninstalling and reinstalling my co...