Coding problems with User defined Visible Property

Hi
I have a report that my users supply to seavel groups. Some do not require
certain fields so these will be hidden by using a checkbox on the relevant
form. At the moment, I am using the following in code builder:
Me.txt[recordNumber].Visible = Forms![Pdoptions]!chk[recordnumbersvisible]

Which isn't doing the job. I've checked all the names and they are correct.
This code gives me eaither a syntex error, or an expected end error, but I
can find no problem. The code is sitting in the "on format" property of the
detail section header, of the report I need this to work in. If someone could
offer some corrections to this code, or tell me some alternative method of
doing this, I would be very thankful. 
By the way, if you've replyed to my eariler thread, can you repost here
please, it seems to of disappeared. It isn't even in my recent posts.

-- 
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/Forums.aspx/access-reports/200707/1

0
oliaccount
7/31/2007 11:12:44 AM
access.reports 4434 articles. 0 followers. Follow

2 Replies
513 Views

Similar Articles

[PageSpeed] 56

Forget it, I found a work around.

-- 
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/Forums.aspx/access-reports/200707/1

0
oliaccount
7/31/2007 11:26:55 AM
Your brackets appear to be in the WRONG place.  I would try the following 
assuming your controls are named txtRecordNumber and 
chkRecordNumbersVisible.

Me.[txtrecordNumber].Visible = Forms![Pdoptions]![chkrecordnumbersvisible]

-- 
John Spencer
Access MVP 2002-2005, 2007
Center for Health Program Development and Management
University of Maryland Baltimore County
..

"oliaccount via AccessMonster.com" <u33480@uwe> wrote in message 
news:75fddec86d7b3@uwe...
> Hi
> I have a report that my users supply to seavel groups. Some do not require
> certain fields so these will be hidden by using a checkbox on the relevant
> form. At the moment, I am using the following in code builder:
> Me.txt[recordNumber].Visible = Forms![Pdoptions]!chk[recordnumbersvisible]
>
> Which isn't doing the job. I've checked all the names and they are 
> correct.
> This code gives me eaither a syntex error, or an expected end error, but I
> can find no problem. The code is sitting in the "on format" property of 
> the
> detail section header, of the report I need this to work in. If someone 
> could
> offer some corrections to this code, or tell me some alternative method of
> doing this, I would be very thankful.
> By the way, if you've replyed to my eariler thread, can you repost here
> please, it seems to of disappeared. It isn't even in my recent posts.
>
> -- 
> Message posted via AccessMonster.com
> http://www.accessmonster.com/Uwe/Forums.aspx/access-reports/200707/1
> 


0
John
7/31/2007 11:41:42 AM
Reply:

Similar Artilces:

Comments problem
I've created a number of comments. When I position the comments where I want them, they only reflect their positions on "Show" or "Edit" comment. All the comments default to the same relationship to the cells when you pass over them. This is a problem because I've also used data vaildation (with lists) on these cells and you can't display the comment with the list pulled down at the same time because the comments are tool close to the validated cell. Thanks in adavance. The comment usually appears to the right of the cell, and should still allow you to see t...

Excel Mail Merger Problem
When merging excel with word for..my currrency field is dropping off zeros to the right of decimal point..if field has $ 56.03, it imports correctly, but if it is $56.00, it comes in as $56, if it is $56.30, it comes in as $56.3...this process is for invoices..any advice (I've tried everything)? Debra Dalgleish has given the following reply in newsgroups http://google.com/groups?threadm=3EBB0685.5080002%40contextures.com and has also identified the following MS KB articles in such as : http://google.com/groups?threadm=3DFA8DA8.6000209%40contextures.com 304387 - WD: Date, Phone N...

synchronising problem with Sony NWZ-S545
Up until recently i could sync tracks/albums etc to my sony S545 MP3. now when i try and drag tracks to the sync folder then click start sync the mp3 player just freezes, WMP states "processing" but nothing happens. Have searched the web for a solution but nothing. done sysem restore etc etc. I guess it must be a recent update but what one? Its a pain in the backside and hope someone can help "Wookywoo" wrote: > Up until recently i could sync tracks/albums etc to my sony S545 MP3. now > when i try and drag tracks to the sync folder then click s...

AAC/M4A VB Tag Decoder Source Code ??
Does anybody have source code that can read AAC/M4A audio files in order to extract the tags? I'm working in VB 6.0. "David Kaye" <sfdavidkaye2@yahoo.com> wrote in message news:i089v8$qrf$3@news.eternal-september.org... : Does anybody have source code that can read AAC/M4A audio files in order to : extract the tags? I'm working in VB 6.0. I just Googled it. Losts of example there. Any reason you couldn't try that first? -- Customer Hatred Knows No Bounds at MSFT Free usenet access at http://www.eternal-september.org ClassicVB Users ...

Printing problem from Excel 2007
Greetings, I am having an issue with printing from Excel 2007. Many users when printing from Excel with get several pages of non-sensical "junk" printed out on the pages. If it actually prints what is on the page, none of the items are in the cells, but look like they are just randomly thrown about the page. I have found that this most often is related to the Calibri font somehow, because I instruct them to change the font to Arial and all prints fine. That being said, if the user converts the Excel sheet into a PDF and print, it prints perfect. This is a great workaround, but kind ...

Problems printing in Publisher 2003 with HP PSC 2410 #2
I am new to publisher 2003 and am having great difficulties printing anything properly using an HP PSC 2410 all in one. As an example when trying to print a half page side folded pre-designed greetings card all that prints is page 1 and part of page 4, minus any text. Pages 2 and 3 are missing altogether. The print preview however displays everything correctly. I have reinstalled Office 2003 and updated the printer drivers to the latest versions but the problem remains. Any help is much appreciated. ...

Outlook options not showing up for user
I am in the process of training and testing with our CRM 3.0. I have installed either the laptop client or the desktop client on the user's machines. For training purposes I have also installed CRM on our training room pc's. I set the user's Outlook for that particular pc and then installed CRM with the user logged on, but I ran the installation under run as. The installation seemed to go fine, yet the user's cannot see and folders or menu when they launch their Outlook. The can get to it in the web environment though. Any ideas on why this has happened and what I can d...

Please help user accounts cannot log in
Hi all, well I caught a virus. I had essentials but some how it is unable to delete the virus and the real time protection has been disabled. Upon working with support we manage to find the problem in windows32 folder. It is a fake security virus. Unfortunately i was unable to delete the applications. I some how did something because now i cannot log in at all. Windows start up and gets to the user account section. When i click on any account it starts and then immediately logs out. This is even in safe mode under admin. I was able to at least get into windows and now i cannot. A...

Re: Extracting Exchange User Data From AD 02-24-10
If you do not like scripting, you can try GAL Exporter or Fast User Manager & Reports from IMIBO - http://www.imibo.com > > "Ringholz, Blake" <bringholz@nospam.com> wrote in message > news:76AEFC2F-85A7-4666-8262-27FB0737D09A@microsoft.com... >> Hello All - >> >> I need to get an Excel Spreadsheet that lists everyone first name, last >> name, email address, job title, etc pulled from Active Directory. Is >> there an easy way to do this? >> >> Thanks, >> Blake > > > > > ...

code problem
Hi this is a follow on to a previous thread (Copy Macro) We are now successfully creating a new Workbook using the code below. With ActiveWorkbook FName = .Path & "\code.txt" .VBProject.VBComponents("Module2_sort").Export FName End With ThisWorkbook.Worksheets(Array("Supplier Concerns")).Copy ActiveWorkbook.SaveAs Filename:="c:\Week\testing" & strFileName & ".xls" ActiveWorkbook.VBProject.VBComponents.Import FName Problem is when we open the new Workbook and run the macro the code defaults ba...

conversion lotus 123 files to excel -- problem
I am converting lotus123 files to excel2002. One problem is that in lotus, literals are ignored when found in a cell within a formula. Excel on the other hand is not doing this and therefore causing #value errors on all the formulas where this occurs. Is there a way to handle this in excel other than manually having to change all the formulas? ...

problem in changing the text of sentences before tables
I am developing a word automation application. In a method of mine, I change the text of some sentences of an opened word file, but the problem is when I change the text of a sentence which located before a table, it will be moved to the first cell of the table. My code is as follow: void myMethod( long startingSentenceNumber, const char *toBeSearched, const char *replacement, bool replace ) { Range currentSentenceRange; Selection sentenceSelection; Sentences sentencesList = m_document.GetSentences(); long sentencesCount = sentencesList.GetCount(); CString replacementCStr(...

Forcing Input as Uppercase on User Form
Hi can any one advise me how to amend the following code to ensure :- (a) only two letters are input (b) they are converted to upper case (c) how do you centre the text in a message box header as I have use spaces to achieve this Code used inputVal = TextBox1 Do Until ActiveCell = inputVal ActiveCell.Offset(1, 0).Select If ActiveCell = "" Then MsgBox ("Sorry Not Found - Please Input the first two letter only e.g. RG ") ", vbInformation, " Warning !! " Unload UserForm1 UserForm1.Show End Else End If Loop Excel v...

Code a Backup database
Is it possible to code a button command subject to a true /false box to Backup the database to say C:/temp -- Thanks in advance for any help with this......Bob MS Access 2007 accdb Windows XP Home Edition Ver 5.1 Service Pack 3 Firstly, it would be best to split the database into front and back ends so that you are only backing up the data each time. The database splitter wizard can do this for you. Spitting a database has many other advantages too. You can then back up the back end file to any location you like using the following procedure, passing the full path to the...

Time Zone / Incorrect Dates Displayed to User
When a user in the Central Time zone closes an opportunity and someone in the Mountain Time zone views it, the Actual Close Date is 1 day before the date the person in the Central Time zone selected. For instance... If someone in the Central Time zone closes an opportunity and selects the Actual Close Date as 6/2/2007: -- Users in the Central Time zone see: 6/2/2007 -- But users in the Mountain Time zone see: 6/1/2007 This is a big issue when running monthly reports as it makes some opportunities show in the wrong month... and will put that revenue in the wrong month. It would make mo...

save as problem
I cant save my excel file The "save as" option is not eviable. Whats happening? "From a prior post by Ron DeBruin, You can reset your menubar to default. Right click menubar. Customize > Toolbars Tab. Select worksheet menubar. Click Reset button. Using VBA Application : CommandBars(""Worksheet menu bar"").Controls(""File"").Reset Or the whole menubar Application.CommandBars(1).Reset You lost the things you add to the menubar!!" ========================================================== And one link that offers some sugges...

Odd problem with worksheets when opening file
Okay, here's the odd problem that's come up. When you double click on a excel file, excel opens up, but you can onl see the toolbars. The grid area looks like a snapshot of whatever you current background is before the file opened up. If you were showin your desktop, after the excel file opened, you'd still see your deskto in the datagrid area. If you start up a new excel file, then do the File>Open>file name, th file will open correctly. This problem happens across users here. Everyone is currently runnin office 2K. Any ideas on what causes the problem and any...

Problem OL 2002 Email
I am having a problem with OL 2002 email settings. I have two computers which I am setting up. One computer works perfectly. The second computer I have configured exactly the same...incoming/outgoing servers and ports, etc... are all setup the same. On the second computer when I press test email settings, everything tests fine. But when I try to do a Send/Receive, I run into problems. First, the POP3 tries to connect to the POP3 server twice at the same time. (I am able to see this on my POP3 server console.) Second, the SMTP sending mail never connects to my SMTP server. (Ag...

2007 B2 MSOO has encountered a problem
More often then not when I click to open an email in my inbox I get this MSOO pop-up with a checkbox, checked telling me MSOO has encountered a problem and needs to close. Has this been an issue for others and is there a fix. If you have Adobe Acrobat Pro 6/7 (not the reader), go into Control Panel, Add/Remove Programs, click change for Adobe Acrobat Pro and remove the Office & Outlook plugins. Patrick Schmid -------------- http://pschmid.net "Jax" <Jax@discussions.microsoft.com> wrote in message news:A74147F4-CD75-4FF8-98A7-5A18B01A8FDD@microsoft.com: > More of...

Sumproduct Problem (AB)
Hi everyone, can you please sort out this problem for me? SUMPRODUCT(('Client Opening Stock'!B2:B138=$A$1)*('Client Opening Stock'!C2:AH138=A7),'Client Opening Stock'!C2:X138) 'Client Opening Stock'!B2:B138 is the Client Name Client Opening Stock'!C2:AH138 is the Product 'Client Opening Stock'!C2:X138 is the Amount I belive the formula is not the proper formula, but this is the result I need. Thank you for your kind help You need to tell us what the problem is, and what solution you want. Why is it "not the proper formula...

Query Problem in Test.
I keep getting errors on the WHERE part of my query. I'm sure it's something simple. I don't know if you will need the whole code to see what the problem is. It is lengthy, so I will start with just where the problem is. Set rs = DBEngine(0)(0).OpenRecordset("SELECT T2.Distance, T1.* FROM (Church AS T1 INNER JOIN qryChurchZip1 ON T1.ChurchID = qryChurchZip1.ChurchID) INNER JOIN DistanceQuery AS T2 ON qryChurchZip1.Zip5 = T2.ZIPCode WHERE " & strWhere) ' See if found none If rs.RecordCount = 0 Then MsgBox "No Churches meet your crite...

Barcodes Code
I am trying to print a barcode in the 128 code. Though it seems the public domain/GPL ones of the truetype do not print a scanable barcode. Is there any suggestions... Or if anyone can point me into the right direction on how to do this or point me in direction of one that will work with access or excel 2000 or 2003. Much appreciated. Or help me figure out WHY it isnt producing a readable one in 128.. Hi Lester, Perhaps the problem is with the resolution on your printer. Try printing the barcode larger. Perhaps even turn off print to fit under print, page setup. --- HTH, David McRi...

HTA problem with IE8
We discovered an issue with some inbedded VBScript code inside an HTA written by a developer that is no longer with us. The code work in IE6 but error out on the set objMsgArea statement indicating that the object requires 'objMenuFrame' which should have been set in the previous line of code. If I put in an 'On Error Resume Next" statement in that sub the HTA appears to work correctly however I don't like putting a band-aid on something like this. Does anyone have any solution for this? Here's the code: sub AppStatusDisplay(strMsgIn, bolAddToStatusLogIn) s...

Sending email in CRM web app problem
Hi, I found this problem very annoying. Our CRM's SMTP service is hosted in YahooMail. The SMTP address is mail.bizmail.yahoo.com and this is a "locked down" server, which means required authentication by username and password. I configured the CRM server's registry by settings the SMTPServerUrl and other stuff, such as Username and password entries. Now, when we send emails from CRM web app, it works... BUT... when we send email using a template which has embedded images, it cannot send the email and reports an error: "Not valid association" something... A...

Problem with 07 Office Pdf/Xps Add-in
Hello Despite having installed the 2007 Office SaveAs Pdf/Xps add-in, I have seen Mary Sauer's posting on this somewhere asking if it in the Add-in of the Office programmes. I do not see it any of the programmes even though I have reinstalled twice with genuine validation. Anything else I can do? Thks. Menk It's like a printer...you print to it. -- ~~~~~~~~~~~~~~~~~~ Rob Giordano Microsoft MVP Expression "Menikos" <menikos88@hotmail.com> wrote in message news:u2EEuVswIHA.4564@TK2MSFTNGP06.phx.gbl... > Hello > > Despite having installed the 200...