form and query problem. please help.

All tables are linked with weak entities. However, when i enter data on the
form I can't get it to let me enter more than one partipicant without access
generating a new invoice id. however i need one invoice to many participants.
It wont work and i have no idea what to do at this point. in addition the
workshop will not let me add workshop to invoice. this is a small mdb and i'd
like to email it to anyone who can assist me with the relationships as I
think this is the problem but I don't know what to do.  please help me.


INVOICE
invoiceNO - autonumber
invoice prices

WORKSHOP
workshopNO - autonumber
workshopName

PARTICIPANT
participantNo
par_Name

user process                                          access process
enter invoice price                       autogenerate invoice no.
enter desired workshop                 select list of particpants add
workshop id to invoice
enter participants                         store first paticipant id to
invoice, store second part. id...

-MC

-- 
Message posted via http://www.accessmonster.com

0
Mitchell_Collen
7/19/2007 1:34:17 PM
access.queries 6343 articles. 1 followers. Follow

2 Replies
651 Views

Similar Articles

[PageSpeed] 59

First off, if your invoice number is an autonumber then of course it will 
create a new ID for each participant. That is what autonumber is for!

Generally I think you need to clarify your design and table relationships 
(and you should have put this in the database design area rather than queries 
which deal specifically with Access query design and SQL). You don't specify 
what your primary keys are. If you don't know what a primary key is then you 
need to do some learning (and I mean that in a nice way!)

I think I can establish that each workshop has a single invoice and each 
invoice (or workshop) has many participants?


"Mitchell_Collen via AccessMonster.com" wrote:

> All tables are linked with weak entities. However, when i enter data on the
> form I can't get it to let me enter more than one partipicant without access
> generating a new invoice id. however i need one invoice to many participants.
> It wont work and i have no idea what to do at this point. in addition the
> workshop will not let me add workshop to invoice. this is a small mdb and i'd
> like to email it to anyone who can assist me with the relationships as I
> think this is the problem but I don't know what to do.  please help me.
> 
> 
> INVOICE
> invoiceNO - autonumber
> invoice prices
> 
> WORKSHOP
> workshopNO - autonumber
> workshopName
> 
> PARTICIPANT
> participantNo
> par_Name
> 
> user process                                          access process
> enter invoice price                       autogenerate invoice no.
> enter desired workshop                 select list of particpants add
> workshop id to invoice
> enter participants                         store first paticipant id to
> invoice, store second part. id...
> 
> -MC
> 
> -- 
> Message posted via http://www.accessmonster.com
> 
> 
0
Utf
7/19/2007 1:54:00 PM
ok, thanks. yea, i had never thought about the invoice primary key being the
problem. it is autonumber. i think maybe that's all i will need to change to
link them correctly. i agree with you, this is a design issue. i will use
that link instead. thanks. MC

scubadiver wrote:
>First off, if your invoice number is an autonumber then of course it will 
>create a new ID for each participant. That is what autonumber is for!
>
>Generally I think you need to clarify your design and table relationships 
>(and you should have put this in the database design area rather than queries 
>which deal specifically with Access query design and SQL). You don't specify 
>what your primary keys are. If you don't know what a primary key is then you 
>need to do some learning (and I mean that in a nice way!)
>
>I think I can establish that each workshop has a single invoice and each 
>invoice (or workshop) has many participants?
>
>> All tables are linked with weak entities. However, when i enter data on the
>> form I can't get it to let me enter more than one partipicant without access
>[quoted text clipped - 24 lines]
>> 
>> -MC

-- 
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/Forums.aspx/access-queries/200707/1

0
Mitchell_Collen
7/19/2007 2:12:58 PM
Reply:

Similar Artilces:

Send data from one form to another
Hi All, I want to know if it,s possible to send data from 1 form to another totally unrelated form. The situation I have it one form is my MRP requirments. I want to open another form PURCHASE ORDER (PO). I was wanting to add a button to the MRP form that would send the data to the PO form. The MRP form may change to multiple items and then add these different items to the same PO. Does anyone have any suggestions on how I could do this or if it can even be done. -- Matt Campbell mattc (at) saunatec [dot] com Message posted via AccessMonster.com http://www.accessmonster.com/Uwe/Forums.as...

My Exchange 5.5 is relaying encapsulated messages HELP!
My Exchange 5.5 server appears to be relaying encapsulated messages. On the "routing" tab of the IMC, I have it set to "re-route SMTP mail..." but on the "routing restrictions" button I have every single item UNCHECKED. Also, I have rebooted the server. I heard that you have to disable encapsulated relaying via the registry, but I can't seem to find the article on Microsoft's site. Can anyone help?? Uncehck re-route SMTP mail. If you have POP or IMAP users who need an SMTP IMC to relay mail, for their use install an IMC on a separate Exchagne 5.5 s...

Problems with reports
Hi, we are having troubles with our MSCRM. We installed MSCRM on a demo-pc within our dmz. Everything works fine as long the user connects from the local company network. But if the user connects from external everything works except the reports. Even the list of reports isn't displayed within MSCRM. Has anyone a clue? Thank you very much for your help Chris are you using ssl on your external web as crystal will not work over ssl (so i have been told) "Chris" <anonymous@discussions.microsoft.com> wrote in message news:1836101c41afb$9eb7dde0$a501280a@phx.gbl... > ...

Adding multiple products to a contact: Challenge/HELP!!!
Here is a challenge: We sell products ( traing courses) where we have to be able to link a contact to a product. thanks to Andrew on the message "Mapping between standard and custom entity" we were able to do that using the ideas he posted. as well as his blog. (http://andrewn23.blogspot.com/) What we now run into is that we can have multiple courses on a single quote/order and want to associate the contact/stuent easily with the products. when one wants to for instance merge accounts there is the possibility for selecting multiples by usng the control key and then clicking ...

Refreshing a field, not an entire form
Hello - I have a form with several required fields. I want to be able to refresh the data in one dropdown field on GotFocus, based on the data in another dropdown field. DD Field 1 is called categories Cat_ID Category 1 Accommodation 2 Agriculture, Forestry and Fishing 3 Animals and Pets DD Field 2 is called Sub-Categories CatID Sub Category 1 Bed and Breakfast 1 Camping and Caravans 1 Hostels the row source for the Sub-Categories field is: SELECT SubCategories.[Sub Category], SubCategories.CatID FROM Categories INNER JOIN SubCategories ON Categories.Cat_ID = SubCategories.CatID WHE...

HEEEELLLLPPPP PLEASE!
Hi, I'm running Exchange 2003 SP1 with the latest post SP1 patch applied. Client is Outlook XP. Windows 2003 native domain. In one site (which has recently been migrated from NT4 and Exchange 5.5) I have the following problem but only for some users: When they logon to their mailbox through OWA, they can read, send mail correctly, add contacts, tasks etc... but when they go to their calendar they are unable to create new appointments and the "new" button is not available. They can see the appointments in the calender but are unable to create new ones. Here's what ...

Junk email problem...
We run a exchange 2003 environment and all of our users run Outlook 2003. We turn off the "junk email filter" in outlook but for some reason email is still going into our users junk email folders on their mailboxes. I am assuming somewhere in exchange this option is turned on and filtering this email. Any ideas on what I am missing? Thanks all Halve, I've been experiencing the same issue and have not found a solution for it as of yet. I've used group policies to disable the Junk Email filter in Outlook and have used the OWA Administration Tool to disable the Junk E...

Strange Onscreen Keyboard problem
Hello gurus ;) i'm working on an application that needs onscreen keyboard for reasons that i will not mention here. I have found some interresting code at the following location: http://www.codeproject.com/samples/onscreenkeyboard.asp The keyboard found there builds well and run fine (no problem for notepad). But when i try to use in my application where it is used for entering username and password on a prompted dialog box, then it does not seem to work properly. My dialog box is system modal. What is does is that it displays only the latest character entered in the edit field of th...

Problem with Windows Live Signin
I am currently used Money Plus Home and Business, and have problem sign in my Data with MSN Windows Live ID. I was recently chagne my Windows Live Messenger Login ID. As I read Money suppose to detect the change. Now how do I fix this problem. Thanks In microsoft.public.money, Luan Pham wrote: >I am currently used Money Plus Home and Business, and have problem >sign in my Data with MSN Windows Live ID. I was recently chagne my >Windows Live Messenger Login ID. As I read Money suppose to detect >the change. Now how do I fix this problem. Thanks See if this helps: http://s...

PROBLEM SIZING A TEXT BOX IN A FORM
Access 2007/vista I have a form in which I cannot adjust the text boxes INDIVIDUALLY. I click on a text box and it becomes surrounded by an orange border, indicating it is selected. But when I size it smaller or larger, all the other text boxes in the form move in tandem. I have not encountered this before and am baffled. Ideas? -- William ...

record and print amounts in multiple boxes on 1099 forms
We have had several clients that have been very disappointed to learn that they can only do 1 amount box per 1099. For instance, they might need an amount for rents and one for non-employee compensation. I think it would need to be settable at time of transaction entry. One of our clients said they could do that in Quickbooks and was very surprised to learn that GP won't do it. -- BrianB ---------------- This post is a suggestion for Microsoft, and Microsoft responds to the suggestions with the most votes. To vote for this suggestion, click the "I Agree" button in th...

Need help with a function
Hi I'm sorry but I'm not too much familiar with Excel. I have some listing in column A For example in A1 I have: D:\blabla\folder1\file1.xxx in A2 I have: D:\blabla\folder2\file2.xxx in A3 I have: D:\blabla\folder3\file3.xxx I want the word between the 2nd and 3rd '\' to be in color red. So in A1 folder1 should be in red, in A2 folder2 in red etc I could do it manually but there are like 3000 lines. It would take forever. Is this simple to achieve with a script/macro/? ? I hope someone can help me. Thanks in advance. Christophe Presumably you want to pick that value o...

Open File Dialog Help
I am trying to set the m_ofn.lpstrInitialDir to "My Music" on an open file dialog, but can't seem to get it to work right. I would like it to default to the c:\documents and settings\user\My Documents\My Music, regardless of the machine the application is running on. The project is being built using Visual C++ 6.0 Professional, on a Windows 2K machine, but may be running in any Windows environment. Thanks, SHGetSpecialFolderPath(CSIDL_PERSONAL) gets you to My Documents ...

Format problem #6
Somehow my formatting appears to be defaulting to time. Everytime I copy formulas or data from one cell to another the format changes to time. How do you stop this from happening? -- Gary If you land the cell pointer on a particular cell and cut-and-paste, then the format of the original cell will follow to the pasted cell. If you're encountering "phantom" formats then the cell may have been previously formatted. I tried to get a blank sprdsht to behave in the manner you describe, and couldn't. My error: this often happens to me when using cells formatted as dates or...

Page SetUp Print Problems
A friend has a spreadsheet that is giving him some problems. We go to Page Break Preview and the sheet is 2 pages wide. My friend wanted to make 1 page wide so we dragged the blue line to the right to make it one page. Excel, instead of doing that, made it 20 or more pages. We went to the Page Setup and noticed that Excel had changed the scaling down to 10%. We wanted it to be 1 page wide by 6 pages long so we put that info in but Excel did not accept it. We thought maybe something was wrong with the sheet itself so we selected all the cells and cut/paste them into a new sheet - but it s...

Problem in showing dialog boxes from a regular dll
Hi, I had a MFC application to be used as icon window (hidden). Also I had a regular MFC DLL exporting functions that will show MFC dll. All these functions are calling the AFX_MANAGE_STATE macro and PreTRansalte message is implemented. If the functions are called from any exe they work as expected even calling from my tray icon app is alright. Now I have merged some the resources (dialogs and string) of tray icon into my dll. Still tray icon works fine. There is another console application that calls my resouce dll to display dialog boxes as well and it also works fine. Now if my ...

problem with laptop client
hi everybody, i've got a lot of troubles with laptop client for outlook (CRM 3.0) i've installed MS CRM 3.0 in a win 2003 server, with sql2005 and exchange 2003. my pc is logged to a different domain, not the one with CRM, but these 2 domains are in trust between them. CRM via web works right. but if i try to install laptop client (but also desktop client) on my pc, i get an error (no communication or similar) when i run outlook (2003 sp2) during installation i put "http://192.168.0.100" (ip address of CRM server) when asked. do I have to put another ip address? or even if ...

Auto Add Textboxes in Forms
In case of the Forms I use, it is Desirable to make them as compact as possible. Stripped of any unnecessary items. It seems usefull to make a form which ads a new textbox everytime something has been entered in the last one. My question: "What Code should I use to get my forms to add a new textbox everytime something has been entered in the last one?" Thanks in Advance! Don't do it. The maintenance makes it more effort than it is worth. Just set them all up in design, and maybe hide them until needed. -- HTH RP (remove nothere from the email address if mailing direct) ...

VBA Help #6
I know this is simple so I apologize for posting it. I'm looking for the VBA code to take a sheet and sort the rows (below row 2) by a certain column, descending. After sorting, I want Excel to provide shading in alternating rows. For example: Row 2 - no shading Row 3 - Shading Row 4 - no shading Row 5 - shading. Thanks in advance for the help. On Jan 25, 10:47=A0am, SHalper <scott.m.hal...@gmail.com> wrote: > I know this is simple so I apologize for posting it. =A0I'm looking for > the VBA code to take a sheet and sort the rows (below row 2) by a > certain column,...

How do I fix a sudden problem with sending and receiving emails f.
I have been successfully using Outlook as my default email program with my SBCYahoo dsl for some months and then I was not. The only thing I can link it to, possible, is that for a short while I agreed to allow Microsoft to monitor my use of their programs. after about a week, some of the programs didn't work as well and some other problems occurred, so a uninstalled that program. what happen now is that the process times out after receiveing a few of the emails and says that "connection was interrupted"-which is impossible since I am 'always connected' via dsl...

SSL & Forms based auth messed up rich client version
Okay, I'm about ready to scrap OWA entirely. I had OWA up and running perfectly with no security, however external clients could not log into their mail boxes. They would get the login screen but their credentials were not being accepted even though I know they were typing them in correctly. So I decided to try SSL and Forms based Auth. Now when I try to login using IE6 sp1 to the premium client version about half the site loads, but stops, with a "loading" message where the viewing pane should be. I'm running exch 2003 on win2k3, for both the back end, and front end s...

Please help with contacts and address book
I am using Outlook 2000 and have two sets of folders: 1. Outlook Today - [Mailbox - My Name] 2. Personal Folders The first folder is my link to Exchange Server. When I click on New Mail Message and click on Address Book, the list of addresses I see is from Contacts located under Personal Folders. I have two questions: 1. How do I get the Address Book to list my Outlook Today (Exchange Server) contacts? 2. How do I back up or synchronize my Outlook Today contacts so both contact lists (Outlook Today and Personal Folders) are the same? Thanks, Peter ...

Device problem
Hi, I've already spent several hours trying to figure this out, reading forums and suggestions, trying different things, and not succeeding at all. So, I decided to post my problem on here. I have a Samsung YP-S2 (Pebble). With the device, I had to install Samsung Media Studio. Everything was working great until a couple of weeks ago. I plugged in my device to add new songs, BUT Samsung Media Studio won't recognize it...so I can't do anything. Now, I noticed that My Computer lists the device as "unspecified" now. It used to list it as a portable devi...

Rules / Macro? Help
This is a multi-part message in MIME format. ------=_NextPart_000_0042_01C478A8.C4D615E0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hello. This is what I would like to do. If the subject line of the e-mail I = just received reads " Cat " then I would like Outlook to automatically = send/forward the " Cat Template ". If the subject line of the e-mail I = just received reads " Dog " then I would like Outlook to automatically = send/foard the " Cat Template ". I've looked into trying to ...

Sintax Help!
I would like to print a sheet and a graph from a macro. I would like to call both by the Number and not the Name of each. In other words if the sheet was named Chart10 (BoxTops)I need to be able to call the sheet by "Chart10" not "boxtops". This way if the name changes the macro will still work. Somthing like... Sub test() ' ' test Macro ' Macro recorded 5/23/2005 by ' 'Print Chart Sheets("chart12").Select ActiveWindow.SelectedSheets.PrintOut Copies:=1, Collate:=True End Sub But my macro errors out on the first line. How to you c...