Code to Dynamically Filter a Report; Not Working

I’m struggling a bit with some code that dynamically filters elements in a 
report.  I have a form with the following objects: lstCustomer, 
lstExecBroker, an Option Group named ‘fraTrader’, with three radio buttons; 
optOption, optCross, optBoth.  Also, I have cboSortOrder1, cboSortOrder2, and 
cboSortOrder3 as well as cboSortOrder1, cboSortOrder2, and cboSortOrder3, all 
of which control sort order.  Finally, here’s the code:

Private Sub cmdApplyFilter_Click()
    Dim varItem As Variant
    Dim strCustomer As String
    Dim strExecBroker As String
    Dim strTrade As String
    Dim strFilter As String
    Dim strSortOrder As String
    
    DoCmd.OpenReport "OptionsWorking", acViewPreview
        
    For Each varItem In Me.lstCustomer.ItemsSelected
        strCustomer = strCustomer & ",'" & Me.lstCustomer.ItemData(varItem) _
        & "'"
    Next varItem
    If Len(strCustomer) = 0 Then
        strCustomer = "Like '*'"
    Else
        strCustomer = Right(strCustomer, Len(strCustomer) - 1)
        strCustomer = "IN(" & strCustomer & ")"
    End If
    
    For Each varItem In Me.lstExecBroker.ItemsSelected
        strExecBroker = strExecBroker & ",'" & 
Me.lstExecBroker.ItemData(varItem) _
        & "'"
    Next varItem
    If Len(strExecBroker) = 0 Then
        strExecBroker = "Like '*'"
    Else
        strExecBroker = Right(strExecBroker, Len(strExecBroker) - 1)
        strExecBroker = "IN(" & strExecBroker & ")"
    End If
    
    Select Case Me.fraTrader.Value
        Case 1
            strTrade = "='O'"
        Case 2
            strTrade = "='C'"
        Case 3
            strTrade = "Like '*'"
    End Select
    
    strFilter = "[Customer] " & strCustomer & _
                " AND [ExecBroker] " & strExecBroker & _
                " AND [Trade] " & strTrade
                
    If Me.cboSortOrder1.Value <> "Not Sorted" Then
        strSortOrder = "[" & Me.cboSortOrder1.Value & "]"
        If Me.cmdSortDirection1.Caption = "Descending" Then
            strSortOrder = strSortOrder & " DESC"
        End If
        If Me.cboSortOrder2.Value <> "Not Sorted" Then
            strSortOrder = strSortOrder & ",[" & Me.cboSortOrder2.Value & "]"
            If Me.cmdSortDirection2.Caption = "Descending" Then
                strSortOrder = strSortOrder & " DESC"
            End If
            If Me.cboSortOrder3.Value <> "Not Sorted" Then
                strSortOrder = strSortOrder & ",[" & Me.cboSortOrder3.Value 
& "]"
                If Me.cmdSortDirection3.Caption = "Descending" Then
                strSortOrder = strSortOrder & " DESC"
                End If
            End If
        End If
    End If
    
    With Reports![Options]
        .Filter = strFilter
        .FilterOn = True
        .OrderBy = strSortOrder
        .OrderByOn = True
    End With
    
End Sub

I’ve seen similar things before, but I’ve never seen the 
WithReports![Options] . . . End With stuff in Access.  If I comment that out, 
the report doesn’t get filtered.  Am I missing something fairly basic here, 
or is this pretty complex.  The code pretty much makes sense to me, except 
that last part.  I can’t figure out why the report is not getting filtered.  

Let me draw your attention to one thing; a thing that may actually be the 
culprit.  When I open a report I get prompted for two Parameters, FirstName 
and 
LastName. I looked everywhere for these variables; not seeing anything at 
all, but there must be something in there that’s causing this behavior. How 
can I find out where those pesky parameters are?

Finally, there is one other noteworthy thing.  I added a few TextBoxes to 
the Report. All went in fine, except for one.  I have a little green triangle 
in the upper left hand corner and a message that reads ‘this control has an 
invalid control source’. I go to Properties  > ControlSource > … > then open 
the query that this TextBox is supposed to be  linked to and double-click the 
field in the query to get this: [ExecBroker] «Expr» 
[QueryWorking]![ExecBroker] 
I deleted the first part and ended up with this: 
= [QueryWorking]![ExecBroker] 
Access doesn’t like that very much because it gives me an #Error when I view 
the report. 

Then I delete everything in the Control Source so I have this: 
[ExecBroker] 
Then the green triangle is back!!

Can anyone tell me how to get this working?

Thanks!
Ryan--

-- 
Ryan---
If this information was helpful, please indicate this by clicking ''Yes''.
0
Utf
12/19/2009 3:41:01 AM
access.modulesdaovba 1670 articles. 0 followers. Follow

2 Replies
1014 Views

Similar Articles

[PageSpeed] 50

Hi,
not sure this is a right approach, I think you have to define filter/sort on 
report open. Have a look at this sample - it shows how to dynamically change 
grouping, but same you can do with sorting
http://www.pointltd.com/Downloads/Details.asp?dlID=45

-- 
Best regards,
___________
Alex Dybenko (MVP)
http://accessblog.net
http://www.PointLtd.com


"ryguy7272" <ryguy7272@discussions.microsoft.com> wrote in message 
news:5C398592-681F-4233-AFE8-A1123DA9B780@microsoft.com...
> I’m struggling a bit with some code that dynamically filters elements in a
> report.  I have a form with the following objects: lstCustomer,
> lstExecBroker, an Option Group named ‘fraTrader’, with three radio 
> buttons;
> optOption, optCross, optBoth.  Also, I have cboSortOrder1, cboSortOrder2, 
> and
> cboSortOrder3 as well as cboSortOrder1, cboSortOrder2, and cboSortOrder3, 
> all
> of which control sort order.  Finally, here’s the code:
>
> Private Sub cmdApplyFilter_Click()
>    Dim varItem As Variant
>    Dim strCustomer As String
>    Dim strExecBroker As String
>    Dim strTrade As String
>    Dim strFilter As String
>    Dim strSortOrder As String
>
>    DoCmd.OpenReport "OptionsWorking", acViewPreview
>
>    For Each varItem In Me.lstCustomer.ItemsSelected
>        strCustomer = strCustomer & ",'" & Me.lstCustomer.ItemData(varItem) 
> _
>        & "'"
>    Next varItem
>    If Len(strCustomer) = 0 Then
>        strCustomer = "Like '*'"
>    Else
>        strCustomer = Right(strCustomer, Len(strCustomer) - 1)
>        strCustomer = "IN(" & strCustomer & ")"
>    End If
>
>    For Each varItem In Me.lstExecBroker.ItemsSelected
>        strExecBroker = strExecBroker & ",'" &
> Me.lstExecBroker.ItemData(varItem) _
>        & "'"
>    Next varItem
>    If Len(strExecBroker) = 0 Then
>        strExecBroker = "Like '*'"
>    Else
>        strExecBroker = Right(strExecBroker, Len(strExecBroker) - 1)
>        strExecBroker = "IN(" & strExecBroker & ")"
>    End If
>
>    Select Case Me.fraTrader.Value
>        Case 1
>            strTrade = "='O'"
>        Case 2
>            strTrade = "='C'"
>        Case 3
>            strTrade = "Like '*'"
>    End Select
>
>    strFilter = "[Customer] " & strCustomer & _
>                " AND [ExecBroker] " & strExecBroker & _
>                " AND [Trade] " & strTrade
>
>    If Me.cboSortOrder1.Value <> "Not Sorted" Then
>        strSortOrder = "[" & Me.cboSortOrder1.Value & "]"
>        If Me.cmdSortDirection1.Caption = "Descending" Then
>            strSortOrder = strSortOrder & " DESC"
>        End If
>        If Me.cboSortOrder2.Value <> "Not Sorted" Then
>            strSortOrder = strSortOrder & ",[" & Me.cboSortOrder2.Value & 
> "]"
>            If Me.cmdSortDirection2.Caption = "Descending" Then
>                strSortOrder = strSortOrder & " DESC"
>            End If
>            If Me.cboSortOrder3.Value <> "Not Sorted" Then
>                strSortOrder = strSortOrder & ",[" & Me.cboSortOrder3.Value
> & "]"
>                If Me.cmdSortDirection3.Caption = "Descending" Then
>                strSortOrder = strSortOrder & " DESC"
>                End If
>            End If
>        End If
>    End If
>
>    With Reports![Options]
>        .Filter = strFilter
>        .FilterOn = True
>        .OrderBy = strSortOrder
>        .OrderByOn = True
>    End With
>
> End Sub
>
> I’ve seen similar things before, but I’ve never seen the
> WithReports![Options] . . . End With stuff in Access.  If I comment that 
> out,
> the report doesn’t get filtered.  Am I missing something fairly basic 
> here,
> or is this pretty complex.  The code pretty much makes sense to me, except
> that last part.  I can’t figure out why the report is not getting 
> filtered.
>
> Let me draw your attention to one thing; a thing that may actually be the
> culprit.  When I open a report I get prompted for two Parameters, 
> FirstName
> and
> LastName. I looked everywhere for these variables; not seeing anything at
> all, but there must be something in there that’s causing this behavior. 
> How
> can I find out where those pesky parameters are?
>
> Finally, there is one other noteworthy thing.  I added a few TextBoxes to
> the Report. All went in fine, except for one.  I have a little green 
> triangle
> in the upper left hand corner and a message that reads ‘this control has 
> an
> invalid control source’. I go to Properties  > ControlSource > … > then 
> open
> the query that this TextBox is supposed to be  linked to and double-click 
> the
> field in the query to get this: [ExecBroker] «Expr»
> [QueryWorking]![ExecBroker]
> I deleted the first part and ended up with this:
> = [QueryWorking]![ExecBroker]
> Access doesn’t like that very much because it gives me an #Error when I 
> view
> the report.
>
> Then I delete everything in the Control Source so I have this:
> [ExecBroker]
> Then the green triangle is back!!
>
> Can anyone tell me how to get this working?
>
> Thanks!
> Ryan--
>
> -- 
> Ryan---
> If this information was helpful, please indicate this by clicking ''Yes''. 

0
Alex
12/19/2009 10:42:34 AM
Thanks Alex!  As it turns out, the code came from here:
http://www.fontstuff.com/access/acctut19.htm#dialog4

I thought I recognized it.  I haven't been to that site in a couple years; 
almost forgot about it.  Anyway, I got it working based on the tips at that 
site.

Thanks for everything!
Ryan--

-- 
Ryan---
If this information was helpful, please indicate this by clicking ''Yes''.


"Alex Dybenko" wrote:

> Hi,
> not sure this is a right approach, I think you have to define filter/sort on 
> report open. Have a look at this sample - it shows how to dynamically change 
> grouping, but same you can do with sorting
> http://www.pointltd.com/Downloads/Details.asp?dlID=45
> 
> -- 
> Best regards,
> ___________
> Alex Dybenko (MVP)
> http://accessblog.net
> http://www.PointLtd.com
> 
> 
> "ryguy7272" <ryguy7272@discussions.microsoft.com> wrote in message 
> news:5C398592-681F-4233-AFE8-A1123DA9B780@microsoft.com...
> > I’m struggling a bit with some code that dynamically filters elements in a
> > report.  I have a form with the following objects: lstCustomer,
> > lstExecBroker, an Option Group named ‘fraTrader’, with three radio 
> > buttons;
> > optOption, optCross, optBoth.  Also, I have cboSortOrder1, cboSortOrder2, 
> > and
> > cboSortOrder3 as well as cboSortOrder1, cboSortOrder2, and cboSortOrder3, 
> > all
> > of which control sort order.  Finally, here’s the code:
> >
> > Private Sub cmdApplyFilter_Click()
> >    Dim varItem As Variant
> >    Dim strCustomer As String
> >    Dim strExecBroker As String
> >    Dim strTrade As String
> >    Dim strFilter As String
> >    Dim strSortOrder As String
> >
> >    DoCmd.OpenReport "OptionsWorking", acViewPreview
> >
> >    For Each varItem In Me.lstCustomer.ItemsSelected
> >        strCustomer = strCustomer & ",'" & Me.lstCustomer.ItemData(varItem) 
> > _
> >        & "'"
> >    Next varItem
> >    If Len(strCustomer) = 0 Then
> >        strCustomer = "Like '*'"
> >    Else
> >        strCustomer = Right(strCustomer, Len(strCustomer) - 1)
> >        strCustomer = "IN(" & strCustomer & ")"
> >    End If
> >
> >    For Each varItem In Me.lstExecBroker.ItemsSelected
> >        strExecBroker = strExecBroker & ",'" &
> > Me.lstExecBroker.ItemData(varItem) _
> >        & "'"
> >    Next varItem
> >    If Len(strExecBroker) = 0 Then
> >        strExecBroker = "Like '*'"
> >    Else
> >        strExecBroker = Right(strExecBroker, Len(strExecBroker) - 1)
> >        strExecBroker = "IN(" & strExecBroker & ")"
> >    End If
> >
> >    Select Case Me.fraTrader.Value
> >        Case 1
> >            strTrade = "='O'"
> >        Case 2
> >            strTrade = "='C'"
> >        Case 3
> >            strTrade = "Like '*'"
> >    End Select
> >
> >    strFilter = "[Customer] " & strCustomer & _
> >                " AND [ExecBroker] " & strExecBroker & _
> >                " AND [Trade] " & strTrade
> >
> >    If Me.cboSortOrder1.Value <> "Not Sorted" Then
> >        strSortOrder = "[" & Me.cboSortOrder1.Value & "]"
> >        If Me.cmdSortDirection1.Caption = "Descending" Then
> >            strSortOrder = strSortOrder & " DESC"
> >        End If
> >        If Me.cboSortOrder2.Value <> "Not Sorted" Then
> >            strSortOrder = strSortOrder & ",[" & Me.cboSortOrder2.Value & 
> > "]"
> >            If Me.cmdSortDirection2.Caption = "Descending" Then
> >                strSortOrder = strSortOrder & " DESC"
> >            End If
> >            If Me.cboSortOrder3.Value <> "Not Sorted" Then
> >                strSortOrder = strSortOrder & ",[" & Me.cboSortOrder3.Value
> > & "]"
> >                If Me.cmdSortDirection3.Caption = "Descending" Then
> >                strSortOrder = strSortOrder & " DESC"
> >                End If
> >            End If
> >        End If
> >    End If
> >
> >    With Reports![Options]
> >        .Filter = strFilter
> >        .FilterOn = True
> >        .OrderBy = strSortOrder
> >        .OrderByOn = True
> >    End With
> >
> > End Sub
> >
> > I’ve seen similar things before, but I’ve never seen the
> > WithReports![Options] . . . End With stuff in Access.  If I comment that 
> > out,
> > the report doesn’t get filtered.  Am I missing something fairly basic 
> > here,
> > or is this pretty complex.  The code pretty much makes sense to me, except
> > that last part.  I can’t figure out why the report is not getting 
> > filtered.
> >
> > Let me draw your attention to one thing; a thing that may actually be the
> > culprit.  When I open a report I get prompted for two Parameters, 
> > FirstName
> > and
> > LastName. I looked everywhere for these variables; not seeing anything at
> > all, but there must be something in there that’s causing this behavior. 
> > How
> > can I find out where those pesky parameters are?
> >
> > Finally, there is one other noteworthy thing.  I added a few TextBoxes to
> > the Report. All went in fine, except for one.  I have a little green 
> > triangle
> > in the upper left hand corner and a message that reads ‘this control has 
> > an
> > invalid control source’. I go to Properties  > ControlSource > … > then 
> > open
> > the query that this TextBox is supposed to be  linked to and double-click 
> > the
> > field in the query to get this: [ExecBroker] «Expr»
> > [QueryWorking]![ExecBroker]
> > I deleted the first part and ended up with this:
> > = [QueryWorking]![ExecBroker]
> > Access doesn’t like that very much because it gives me an #Error when I 
> > view
> > the report.
> >
> > Then I delete everything in the Control Source so I have this:
> > [ExecBroker]
> > Then the green triangle is back!!
> >
> > Can anyone tell me how to get this working?
> >
> > Thanks!
> > Ryan--
> >
> > -- 
> > Ryan---
> > If this information was helpful, please indicate this by clicking ''Yes''. 
> 
> .
> 
0
Utf
12/19/2009 6:31:01 PM
Reply:

Similar Artilces:

Rounding Averages on my Report
I created a summary report using the report wizard and grouped by date and selected avg. The report works fine except I would the numbers to be rounded. For example: The average for January shows 19.5, however I would like it displayed as 20. If February is 23.1678993, I would like it displayed as 23. Can someone help me with this? Thx Try... = Format([YourAvg], "#") 19.5 should display as 20 (rounding up from .5 or greater) 23.1678993 should display as 23 (rounding down from .5 or less) or... if you need numeric... ...

Outlook 2003
More than 50% of my contacts do not have email addresses, so it therefore clutters the Address book unnecessarily. Is there anyway to allow the address book (the popup which appears when clicking on "To:") to only show contacts that have email addresses? I can use categories to assign contacts as ValidEmailUser, but I can't seem to find a way to force the address book popup form, to show based on a category. Thanks. That's odd. I have never seen the Outlook Address Book display Contacts without electronic addresses. It simply won't do that. Do these Contacts ...

Error Code :0x80040605
Outlook asked me to upgrade the Connector when i choose to repair, nothing happened except that my email account could not sign in and when i choose remove the outlook connector automatically removed. Troubleshooting Outlook Hotmail Connector - http://www.officeforlawyers.com/outlook/tsol.htm#hm -- -Ben- Ben M. Schorr, MVP Roland Schorr & Tower http://www.rolandschorr.com http://www.officeforlawyers.com/outlook.htm Author: The Lawyer's Guide to Microsoft Outlook 2007: http://tinyurl.com/ol4law-amazon "Karen" <Karen@discussions.microsoft.com> wr...

How to generate a truly empty cell
"" generates a zero-length string, not a truly empty cell. This is causing problems elsewhere. I'd like to find an output for an IF statement that will give me a truly empty cell. The current formula is: =IF(COUNT(C24:C29)>0,SUM(C24:C29),"") Any ideas? If it involves a macro (as I think it might, having read other posts), please explain how to implement it. Thanks! <This is causing problems elsewhere> It shouldn't. Don't use ISBLANK(A1), use A1="" -- Kind regards, Niek Otten Microsoft MVP - Excel "paulkaye" <paulmjkaye@gm...

Problems with Crystal Reports
Hi everyone We are currently encountering a problem with Crystal Reports on MSCRM. Launching one takes about 10-15 seconds before data is displayed (even if only 1 record is retrieved). The standard Accounts reports are worse, we get a Timed Out error everytime. We are deploying MSCRM on 2 servers - CRM Server has dual procs and 1GB RAM. Any suggestions are very much appreciated. Thanks in advance. Regards. Hon Having Crystal reports in CRM 1.0 timeout is a known bug. (Happens after you try to retrieve more than about 10K records.) There is a private hotfix. It will also be fi...

FRx Report Date won't change
We have a customer that has a GP Fiscal Year of 9073. Apparently, an AP transaction had accidentally been posted with a document date of 9073. So, in order to void that transaction, they created the fiscal year of 9073. Now, in FRx when they try to change the Report Date to December 2008, FRx changes the report date to December 9072. We've tried deleting the .g32 file and rebuilding the FRx GL Index. We've also tried deleting the SY40100 and SY40101 tables, rebuilding the Fiscal Periods in GP then rebuilding the FRx GL index but we still can use the 12/2008 date in FRx. Any...

Why doesn't indirect work with a dynamic range created using offse
Hi Has anyone else experienced this issue or I am doing something wrong. I have a series of dynamic range names defined using offset. For example the name USCities is defined as =offset(AA1,0,0,Counta(AA:AA),1) and the name Europeancities is defined as =offset(AB1,0,0,counta(AB:AB),1) In column A, dataentry into the cells is limited to USCities or Europeancities. In column B, I want to limit data entry to the range name appearing in column A. For example if USCities is selected in A1, data entry in cell B1 is to be limited to those cells forming the USCities range name. I have tri...

Outlook Rules not working with new Exchange Server
We recently (last week) upgraded our Exchange 5.5 server with a new machine running Exchange 2003. Since that change, a few clients who use Outlook Rules to forward messages to other email addresses have noticed that those messages are no longer being delivered. We have clients using Outlook 2000 and some using 2003 - it doesn't seem to matter which version of Outlook that's being used. The rules work just fine for placing specific messages into specific folders, but anytime that a message is supposed to be forwarded to an outside email address, it is never delivered. Any ide...

(?) Free credit report and monitoring from Experian?
How do I get the free "credit report and monitoring from Experian" offered with Money Deluxe 2004? When I click, I'm sent to https://msmoney.creditexpert.com/CE_site/MCCLogin_C.aspx , but I see no-where to create a new account. Queries to customerservice@creditexpert.com have not been answered. Thanks, -stephen Do a little search at the Consumer Reports site and you will find the addresses and email addresses of the 3 credit reporting agencies. I believe they are required to send you a free report once per-year. You can research the referenced CR reports at your local libra...

Match Duplicate Accounts doesn't work?
I just recently upgarded my Money 2004 to 2006 Deluxe. To take advantage of new features, I started setting up the online services for my checking account. I was able to have Money establish a connection w/ my bank and login w/ my supplied username and password. Then I got to the part where Money asks "Are you already keeping track of any of these accounts ..." - Yes - No - I'm not sure So, I select Yes because I have indeed already set up that account (and have many years worth of data in it!). Then I click thex Next buton whic...

DLookup Not Working
I have a form i want to create a DLookup where I get the Last_Name on the tblUserNameTest when the field txtUser on the active form equals the User_IDon the tblUserNameTest table. I have this and it is not working what am I doing wrong? =DLookUp("[Last_Name]","tblUserNameTest","User_ID = " & [txtUser]) Whatever you can do to help would be greatly appreciated. Thanks. lisa What data type is the field User_ID? Your code indicates it is a numeric data type. If txtUser is a form control on the current form, you should be qualifying it with either Me. or...

Hyperlinks to pdfs and word documents are not working
My Access database was recently upgraded to Access 2007. Now all of the hyperlinks I have to pdfs and word documents are not working. In browsing "external data" I see that I can link to text files and excel files, etc. Please explain why my links to pdfs and word documents no longer are working and how I can fix them. -- Archivist Try to eplain a little more, what do you mean by not working? Do the links react but present you with some kind of warning. In what way were the links created. Have you set the directory where your files reside as trusted in the trus...

sum by coding without 0
hi in the following program if there is no value in the cells a1 and b1 it returns 0 Public Sub Add2Cells() Range("C1").Value = Range("A1").Value + Range("B1").Value End Sub i need only the output if the both the cells have the data will you can tell me that Public Sub Add2Cells() If Not(IsEmpty(Range("A1"))) And _ Not(IsEmpty(Range("B1"))) Then Range("C1").Value = Range("A1").Value + Range("B1").Value End If End Sub Empty is not the same as zero, so either/both could actually ...

How do gift cards work?
I'm new to MS POS 2.0, so please forgive me if this is off base... I want to be able to sell and accept gift cards in my store. I do not want to use pre-loaded Visa cards, but rather just a custom card that I will have someone build for me. What is the right way to go about this? I'm thinking that I need to get cards with a unique code on their mag-stripe which I can register in MS POS 2.0 with an associated $ amount. Is this correct? MS POS doesn't support Gift Cards, only RMS. Craig "Randy M" <RandyMagnuson@hotmail.com> wrote in message news:%23pJNqwRFI...

LDAP lookup not working with Outlook 2003
I have recently upgraded to Outlook 2003 and notice that I could no longer resolve names via the LDAP server. I get always get a message that there are too many matches in the Internet Directory. This does not occur with Outlook 2002 or Outlook Express. With these two applications, the name is always resolved in less that 20 seconds. Any ideas? Try a new mail profile. --� Milly Staples [MVP - Outlook] Post all replies to the group to keep the discussion intact. Due to the Swen virus, all e-mails sent to my actual account will be deleted w/out reading. After searching google.groups...

Report WRITER legends values #2
Hello. I need to modify existing modified report. Where can I find values for legends fields? Thanks. Sofiya. Hello Sofiya, Legend fields are placeholders that may contain pretty much anything, depending of the report you are working with. For example, on many reports, they are used to display the range values used when generating the report. (From-To) One thing you must remember though is that they are always typed as strings so you need to convert them if you want to do any arithmetic operations with them. In conclusion, if you want to evaluate the legend field values for a report,...

Excel reporting alternatives
Hi, I am part of a team currently looking for alternatives to replace Vision XL which our Finance team uses for ad-hoc reporting in Great Plains version 8. Although I am still seeking clarification I believe that Vision XL will not work with GP 10 or Office 2007 which we will soon be upgrading too hence a need for a replacement. My team will be writing sql reports using visual studio etc but our Finance team are rather hoping that they can continue using some kind of excel reporting tool, any ideas would be most hopeful. Kind regards Matthew Carpenter Hi Mathew One of the benfits of ...

COUNT /COUNTIF for Multiple Column Defined Dynamic Named Range
Hi, Would like to use Dynamic Named Range "RESULTS" in Formula. The Dynami Named Range "RESULTS" spans 30 COLUMNS and many ROWS. Need help with Formula to COUNT specified criteria in each separat COLUMN of the Defined Dynamic Named Range "RESULTS". Looking for on Formula that can be adapted with an OFFSET / INDEX to work on the othe COLUMNS. Example Results required from Formula: COLUMN 1 in Dynamic Named Range "RESULTS" - COUNT instances of numbe 75 COLUMN 2 in Dynamic Named Range "RESULTS" - COUNT instances of numbe 75 COLUMN 30 in Dy...

Outlook (and Excel) stops working after MSXML installation
I installed MSXML 4.0 as per the "critical updates" message on my W98 today. After re-boot, when I try to open Outlook I get message "Unable to open your defauilt mail folder - the information store could not be opened" and then "Would you like to open your default file system folder instead?" - this is no good and I can't find anything. I can't open Excel either, I get messages about Visual Basic and when I close it, I get message "This process will stop the debugger". I now have a shortcut on my desktop "Microsoft MXL 4.0 parser&...

Learning C# properties from O'Relly book
In a simple time class, int hour /* public int Hour // This works { get { return hour; } set { hour = value; } } */ // Automatic property? public int Hour { get; set; } // This doesn't set hour ! // Client code Time t = new Time(now); int theHour = t.Hour; Console.WriteLine("\nRetrieved the hour: {0}\n", theHour); theHour++; Console.WriteLine("\nUpdated the hour: {0}\n", theHour); Michael Hanson wrote: > [...] > // Automatic property? > public int Hour { get; set; } // This doesn't set hour ! W...

Using Exmerge in batch-mode doesn't work
Hi there, I want to "backup" the mailboxes from my Exchangeserver to pst-files with Exmerge. I seem to have the same problem though as more people seem to have with the Exmerge utility but I haven't seen any solutions yet :-(. If I walk through the Exmerge steps using the GUI everything seems to go allright. I get a list of mailboxes, I pick the ones I want to export to .pst en Exmerge does it's thing creating a bunch of perfectly healthy .pst's. When I want to use it in batch-mode using MAILBOXES.TXT containing the mailboxes I want to export, Exmerge logs it can...

Automatically sending a daily report in word as an attachment
I hope you can help with this. I have a daily report that needs to be mailed to a co-worker. It is a simple list of clients served in a word 2003 document. I would like to automate the process. I right clicked on a toolbar and went to customize, I found the command send mail recipient as attachment and dragged the button to the standard toolbar. I assigned an email hyperlink to it. The button works perfectly as far as sending an email automatically but it doesn't send the contents of the document on the screen. I want the current document to be attached to the email as it is...

Should I create a custom report?
I would like to be able to run a report of best selling items per for select vendors. We are trying to reduce our inventory and carry only the best sellers. ...

Out of office assistant does not work from Outlook but ok from web email.
When I click on the Tools->Out of office assistant I get the following error. "The command is not available. See the program documentation about how to use this extension.". It works find if I use web mail. Any thoughts? Mike. ...

Report entries
I generated a report for all charitable contributions for 2004. Although it reflected payments made from checking and AMEX, it overlooked the ones made through Master Card. How do I customize report to get all contributions, regardless of vehicle through which they were paid? -- KAL Check to see if the report includes all accounts in its customization. "KAL" <KAL@discussions.microsoft.com> wrote in message news:5C5DD711-8FD9-4BA5-92D0-421AD81FC730@microsoft.com... >I generated a report for all charitable contributions for 2004. Although >it > reflected payme...