Programmatically connecting to backend

I have an odd issue, wondering if someone might have seen this.  Not
sure whether this question is more appropriate here, in security, or
if this is a network administration issue - but here goes...

I've got a database split into front and back end.  Back end is
password protected.  The front-end has some code that prompts the user
for a password, and then links to the back-end.  This was working
perfectly well at the client site, up until a few days ago.

They created a new folder on the server, and restricted access to only
users who are allowed access to the database.  All of a sudden, only
one user at a time is able to be in the database - otherwise, it won't
connect.  All users can access - so long as no one else is using the
database when they try.

It's almost as if the front end is now opening the back-end in
exclusive mode.

Has anyone seen this? Any suggestions?  Server is Windows 2003, client
machines run Windows XP.

Regards,
Remi

0
iso
4/17/2007 6:18:37 PM
access.formscoding 7493 articles. 0 followers. Follow

2 Replies
969 Views

Similar Articles

[PageSpeed] 29

Found it:

Problem was they had not provided permissions to users to create files
in that folder, which means the ldb file wasn't being created, which
caused the data file to be locked exclusive.

Remi.

On Apr 17, 11:18 am, R=E9mi <r...@terracognita.ca> wrote:
> I have an odd issue, wondering if someone might have seen this.  Not
> sure whether this question is more appropriate here, in security, or
> if this is a network administration issue - but here goes...
>
> I've got a database split into front and back end.  Back end is
> password protected.  The front-end has some code that prompts the user
> for a password, and then links to the back-end.  This was working
> perfectly well at the client site, up until a few days ago.
>
> They created a new folder on the server, and restricted access to only
> users who are allowed access to the database.  All of a sudden, only
> one user at a time is able to be in the database - otherwise, it won't
> connect.  All users can access - so long as no one else is using the
> database when they try.
>
> It's almost as if the front end is now opening the back-end in
> exclusive mode.
>
> Has anyone seen this? Any suggestions?  Server is Windows 2003, client
> machines run Windows XP.
>
> Regards,
> Remi


0
iso
4/17/2007 6:29:48 PM
>
> It's almost as if the front end is now opening the back-end in
> exclusive mode.
>
> Has anyone seen this? Any suggestions?  Server is Windows 2003, client
> machines run Windows XP.


Yes, we see this a lot, and 99% of the time it means the users were not 
given full permissions to that dir. when we say full permissions, that 
include file create, file delete...full means full rights.


Ms-access is a simple file share, and when you go mulit-user, ms-access 
attempts to create a locking file (the ldb file). This fie is used for 
multi-user..and managing conflicts. If ms-access can't create this file, 
then it opens the database in single user mode...

So, those users likely don't have full permissions to that directory, and 
each user needs full rights..and that includes file create, and file delete 
rights. When the user runs their front end, and opens the back end...a 
locking file is created in the SAME directory as the back end file. (so, 
users must be able to create and delete files in that directory).

-- 
Albert D. Kallal    (Access MVP)
Edmonton, Alberta Canada
pleaseNOOSpamKallal@msn.com 


0
Albert
4/17/2007 6:34:57 PM
Reply:

Similar Artilces:

Vista "ipv4 connectivity limited"
Hi We have two Vista PCs connected wirelessly to a BTHomeHub2. Both have been connecting to the internet fine, until today. My partner now can't get online. Her machine shows ipv4 connectivity limited. (Both our computers also show ipv6 limited, but my ipv4 shows "internet" and of course is connecting fine.) It reports the signal strength is excellent. Another message says "the computer is connected to the BTHomeHub2, but does not have access to the internet." As I've said, we've had no similar problem before, and have not changed any se...

connecting outlook to msn.com
i had this working on the main computer but the hard drive locked up, blowing the power supply and the mainboard. Intel 440 bx. now got my older computer working with W2k and Office 2003 and set my outlook up per http://support.microsoft.com/kb/287604/en-us to work but i still haven't figured out how to get it working. it indicates my user name or password is not right but i am connecting through hotmail ok. i need to get on msn.com so i can pull off my mail into my folders... any other hints? charlie are you using the connector or pop? -- Diane Poremsky [MVP - Outlook] Author, T...

Internet connectivity error in word
I have been having an issue with the translator in word. Whenever I attempt to translate text, the box gives me the same error message, "Office cannot connect to the internet, make sure that your computer is connected to the internet and..."<br> <br> I get this message even as I type this message while online..<br> <br> I'm studying spanish right now and this would be an excellent resource for me (if I can get it to actually work).<br> <br> Any suggestions?<br> <br> -M Check your firewall: It sounds as though the firewall (maybe i...

Outlook 2003 no longer sees or connects to my mailboxes
Hi All, I just tried to set up my new gmail account alongside my long time existing other POP3 account. First I noticed that I cannot access my gmail account (no send/recieve item for it, not able to choose the profile when composing a new message), although it is visible in account setup (and tests ok). Then after a few Outlook restarts, and (uh..) renaming the accounts, all the two have been disonnected from Outlook. Now there's no send/recieve menu items at all, and if i start a new message, there's no profiles, and i cannot send it. Any hints highly appreciated! ...

Can't connect to new mailboxes Exchange 2003
Running new single 2003 Exchange server I created new mailboxes last week - and the XP clients using Office 2003 connected OK However now - when I create a new mailbox - I am unable to connect to it from any client. I can still create a new profile and connect to existing mailboxes Help please ! heraclius@aol.com (groundhog) wrote in news:f10086a3.0402161113.786e22ad@posting.google.com: > I created new mailboxes last week - and the XP clients using Office > 2003 connected OK > > However now - when I create a new mailbox - I am unable to connect to > it from any client. I ...

Disable Startup Programmatically
Is it possible to Programmatically open an Access database while bypassing the startup? Basically I need the VBA equivilent of holding the Shift Key. I can definitely get into the nuts and bolts of the issue further but the general overview is that I am writing a version control module. It checks to see if there is a new version avaliable and the path to the newest version from an external Db on startup. If obsolete it creates and runs an executable that saves the obsolete db as a new name then copies the new version into the same folder. It then opens the new version and r...

Outlook trying to connect to the wrong Exchange
I have some user's in my network that are traveling to remote offices. The network is setup with Windows 2003 AD with two sites: head office (Office 1) with 2 DC’s and remote location (Office 2) with another 2 DC’s. Also, Exchange 2003 is setup with 2 sites, one in head office (Exch1) and one in the remote office (Exch2). The users have their mailboxes setup accordingly with their office location (ex: user working in Office 1 has his mailbox setup in Exch 1). The offices are connected with VPN links. When a user is traveling from the head office (Office 1) to the remote office (Off...

Problem starting different http connections from the same application
Hi, I have a multithreaded application in which one thread sends a request to a web server -and reads the response for a while (which is why its a separate thread). The other thread needs to send data periodically to the server - but this is where I run into problems. In the method that the second thread uses makes a new session , gets a new connection, creates a new http file - but fails to send the data. Looking at the ethereal captures, it seems that the second thread is sending requests through the same tcp connection that the very first request (that hasn't returned yet) we...

Lost Excel connection to BP
Hello: Last week, the IIS server at a client crashed. They were able to get the server back up and Business Portal is running fine, now, for all users. One user, however, is reporting that his connection to Business Portal data from Microsoft Excel no longer finds the databases (companies) except for that of a test company called “The Phone Company”. In Excel, he goes to Data…Import External Data, grabs the Microsoft Business Solutions data source, types in the URL, and he finds the root directories to the databases. But, again, the databases that he used to see are not there. I c...

Not able to connect to outgoing SMTP server using POP account in Outlook 2007
Good Day, We have a user that is using Outlook 2007 and I am able to get incoming mail but when I try to send email I get the following error. "Outlook cannot connect to your outgoing (SMTP) e-mail server" I went into configure and clicked on more settings and checked the following Outgoing Server Clicked My outgoing server (SMTP) requires authentication and Clicked on Log into incoming mail server before sending mail I have also tried the other options on this list with No luck. Does anybody have any other suggestions that I can try. Thank You Ad...

Connection Schedule #2
We have all of our store computers setup on connection schedules. One of them is not connecting automatically and we have request a data upload to get the information off the server. Does anyone know why it would not be connecting and how we can fix the problem? There are a lot of reasons that would cause a store connection to fail - Here is where I would start: 1) Is the connection schedule defined in HQ Mgr?: HQ Mgr> Admin> Stores> Locate/Highlight store> Properties> Connection Schedule - is schedule according to your connection map? 2) Make sure stores connections are...

Windows 7 slow LAN connectivity
It's really annoying that when you connect two computers to a WiFi AP and try to copy files between them it takes ages to copy anything and is slow beyond any reason. Even when I connected one of them via wire it's still terribly slow and even freezes from time to time. One of the PCs is XP the other runs 7 Ultimate. I already disabled that thing that checks for connection errors or something but still no joy. yaro yaro137 wrote: > It's really annoying that when you connect two computers to a WiFi > AP and try to copy files between them it takes ages to copy > a...

yahoo.es connection in my smtp virtual server
Our mail has slowed down to where and internal email is taking up to 3 hours when it would be there in a second. I looked in ex2k3 server manager and there were no connectors and there was a connection in my smtp virtual server named Yahoo.es Also I could not see my queue's, the server manager would stop responding. I rebooted the box then I created a connector and was able to get into my queue's. The queue's were over 7,000 and counting. I changed settings to try to clear them out. stoped and restarted smtp server. waited and It still keeps building up. My internal email...

connect access mde file to sql server
Hi All I have an application build on MsAccess XP with both Front End MsAccess and Back End MDB file. it seems that the application works perfect on a single user computer and in a multi-user up to 10 users.I need to convert the Back End MDB to SQL Database . Is it easy to do without the need to change the code in the Front End. Or is there a Step By Step Manual to do that ? thanks in advance Wael If it's only your backend you can choose to export your table to SQL-Server. When done you have a solution which uses 'linked tables'. The front_end will remain the same. Re...

Rule out "connection pool" trouble...
Friends, Probably my ignorance showing, but we are troubleshooting SQL Servers running on virtualized machines. Three virtual Server 2008 running on one piece of hardware, each running SQL Server, each with little client applications that each communicate with all three SQL Servers. The symptoms seem like "networking issues"; we have very long delays and timeouts if no activity has occurred for a while, but once the three start communicating successfully, all is well. Each little client on each server opens a connection to each of the three servers to do some work...

which evet will fire when the client closes its connection with Socket server?
Hi, I created a Stream socket server derived from CSocket and some clients r connected to it.Which event is triggered when the Client closes its connection with server? or How do i know there is no connection between server and client? Reny ...

Connecting via VPN to Exchange Server at work
I want to connect to my work's exchange server so that I can get my email in Outlook on my home PC...the VPN connection works fine...I can even ping the exchange server by name or IP address...but when I try to add a new email account in Outlook on my home PC it says: "Outlook could not log on. Check to make sure you are connected to the network and are using the proper server and mailbox name. The connection to Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action." I verified the server and mailbox name and they are correct. C...

Outlook cannot connect after 20-30 minutes idle time
We have SBS2k and Exchange server 2000. After about 20 -30 minutes my user's outlook will not connect to the exchange server and the only way to correct this is to reboot. Once they reboot they are fine until they experience 20-30 minutes of Outlook being open and just sitting there. This happens on 4 of the 16 user's machines that i have. the user's are running XP pro and one of the 4 users has MS outlook 2003 and the other three have MS outlook 2002. One thing i notice with th e user that has 2003, is that after i added a new user account to her machine she started ha...

Online bank connection not updating
Greetings, I just upgraded to Money 2005 Deluxe from 2004 deluxe and can not connect to my bank account to update. I've re-entered my password & long in info but it still will not connect. Any suggestions? Thanks! Don I'm having the same problem with Bank One and Discover. Plus, can't seem to get my bank set up. Getting a message that on-line services are not available. "Donald L. Hoffpauir" wrote: > Greetings, I just upgraded to Money 2005 Deluxe from 2004 deluxe and can > not connect to my bank account to update. I've re-entered my passw...

Linksys cable modem dropping connection
I�ve been using your model BEFCMU10 Cable modem (SN kbg30g304550) for the past several years. Began having problems with dropped internet connection, maybe once a month, progressing to weekly failures, and now I�m getting disconnected several times a day. This older model modem has 6 led indicators � power, DS, US, on-line, Ethernet, and USB. Under normal operation, DS, US, on-line are on steady and Ethernet is flashing. When my connection fails, DS is on, US may or may not be on, and both on-line and Ethernet are off. I go through the usual processes of...

Spreadsheet files load very slowly when connected to the Internet
Has anyone seen or experienced slow loading spreadsheet files when they are connected to the internet. I have a dial up connection and you can see activity going over the internet via the dial up status monitor in the task bar while loading an excel file. When not connected, the excel files load quickly. Almost like I have a hidden trojan horse or virus that is undetected and monitoring the spreadsheets being loaded. TrentC Lots of mail around regards a problem with a Norton update this week that is causing this http://service1.symantec.com/SUPPORT/sharedtech.nsf/docid/20040108102...

Cannot connect Outlook 2003 to Exchange
I have a Windows XP PC, fully patched with Office 2003 connecting to a SBS2003 network. Everything has been working fine until this week. Now Outlook is unable to connect to Exchange, apparently with no cause. I have created new user profiles, uninstalled and re-installed office into a clean folder, removed the PC from the domain and re-instated it, stopped and restarted all the Exchange services all to no avail. I have also removed all the outlook profiles and created new ones. The only anomaly I have is that when I create a new Outlook profile and specify the server (which i did by IP) and t...

Connection Error Trapping
I have a probgram that works great. I connect to a Db and run querries, but I canceled from the final connection today (instead of puting in the db password, I hit CANCEL) and my code stopped. It jammed on the EXECUTE statement below. How do I either test the connection to make sure it is in tact? I will exit the sub if no connection found. Current working code: Set MyQDF = MyDB.CreateQueryDef("") MyQDF.ODBCTimeout = 800 MyQDF.Connect = "ODBC;DSN=OTHER_DB" MyQDF.ReturnsRecords = False 'Delete Curr Transactions stSQL = stSQL & "DELE...

remote users dialup connection
Hi all, we have some remote users who need to first dial a VPN connection and then open Outlook to sync with Exchange. Is it possible for Outlook to automatically dial the connection when it is launched? I have tried selecting the VPN connection on the Connection tab under more settings of the Exchange account, but that doesnt do it. Any ideas? TIA! ...

client connections to exchange full-text index
I've setup a Full-Test Index on our Exchange server and made it available to clients. How do I check that the Outlook clients are using the FTI to perform searches? On Wed, 4 Jan 2006 16:07:26 -0800, MOW <MOW@discussions.microsoft.com> wrote: >I've setup a Full-Test Index on our Exchange server and made it available to >clients. How do I check that the Outlook clients are using the FTI to >perform searches? When your server grinds to a halt. The best way to verify this is to open Perfmon on the Exchange Server and watch the "Queries" and "Resu...